Windows Server Update Services

Purpose

Microsoft gives administrators full control over the update management process, eliminating the need for client computers to retrieve updates directly from Microsoft Update. WSUS administrators can specify the types of updates to download, create target groups of computers to receive updates, and determine which computers require updates before deployment. Administrators can approve updates for deployment automatically, uninstall updates, and generate reports to monitor update activity.

Where Applicable

System administrators can use the WSUS API to programmatically determine which updates apply to a computer or group of computers, download those updates, and install them with little or no user intervention.

Independent software vendors and end-user developers can integrate WSUS features into computer management or update management software to provide a seamless operating environment.

Developer Audience

The WSUS API is accessible by any language that supports the Microsoft .NET, including Microsoft Visual Basic .NET, C#, and managed C++.

This documentation assumes that the developer is familiar with WSUS concepts and features and does not provide in-depth conceptual material. For conceptual material, see WSUS Product Overview.

For information on the WSUS client API, see Windows Update Agent.

Run-Time Requirements

WSUS runs on the Microsoft Windows Server 2003 and Microsoft Windows 2000 Server SP4 and later operating systems. The WSUS API is available on servers that include the WSUS installation. For information about run-time requirements for a particular programming element, see the Requirements section of the reference page for that element.

Send comments about this topic to Microsoft.


What's New in Windows Server Update Services 3.0 API

Microsoft® Windows Server® Update Services 3.0 (WSUS 3.0) enables information technology administrators to deploy the latest Microsoft product updates to computers running Microsoft Windows Server 2003, Microsoft Windows® XP with Service Pack 1, and Windows 2000 with Service Pack 4 operating systems. By using WSUS, administrators can fully manage the distribution of updates that are released through Microsoft Update to computers in their network.

With this release of WSUS 3.0 API, Windows Server Update Services API addresses new key features.

WSUS 3.0 API Feature Highlights | Description
Publishing | Publish, approve, and deploy local packages
Ability to manage remote services | Provide remote administration of the WSUS server via the WSUS 3.0 API
Inventory | Provide support for lightweight inventory functionality
Cleanup | Control the scope of cleanup through providing user selections of various cleanup options

Additions and Changes to API Types

The topic, New and Changed Types in WSUS 3.0 API, provides a listing of the additional, removed, or overloaded Types for WSUS 3.0.


New and Changed Types in WSUS 3.0 API

Windows Server Update Services 3.0 (WSUS 3.0) offers new Types and changes some of the Types from WSUS 2.0.

New types added to Windows Server Update Services 3.0

The new Types added to WSUS 3.0 are listed in this section.

  • Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection (Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection)

  • Microsoft.UpdateServices.Administration.CleanupEventArgs (Microsoft.UpdateServices.Administration.CleanupEventArgs)

  • Microsoft.UpdateServices.Administration.CleanupProcessProgressStep (Microsoft.UpdateServices.Administration.CleanupProcessProgressStep)

  • Microsoft.UpdateServices.Administration.CleanupProgressEventHandler (Microsoft.UpdateServices.Administration.CleanupProgressEventHandler)

  • Microsoft.UpdateServices.Administration.CleanupResults (Microsoft.UpdateServices.Administration.CleanupResults)

  • Microsoft.UpdateServices.Administration.CleanupScope (Microsoft.UpdateServices.Administration.CleanupScope)

  • Microsoft.UpdateServices.Administration.CommandLineItem (Microsoft.UpdateServices.Administration.CommandLineItem)

  • Microsoft.UpdateServices.Administration.ComputerTargetScope (Microsoft.UpdateServices.Administration.ComputerTargetScope)

  • Microsoft.UpdateServices.Administration.EmailNotificationType (Microsoft.UpdateServices.Administration.EmailNotificationType)

  • Microsoft.UpdateServices.Administration.EmailStatusNotification (Microsoft.UpdateServices.Administration.EmailStatusNotification)

  • Microsoft.UpdateServices.Administration.FileForInstallableItem (Microsoft.UpdateServices.Administration.FileForInstallableItem)

  • Microsoft.UpdateServices.Administration.FilePropertyRowIndex (Microsoft.UpdateServices.Administration.FilePropertyRowIndex)

  • Microsoft.UpdateServices.Administration.FileType (Microsoft.UpdateServices.Administration.FileType)

  • Microsoft.UpdateServices.Administration.ICleanupManager (Microsoft.UpdateServices.Administration.ICleanupManager)

  • Microsoft.UpdateServices.Administration.IEmailNotificationConfiguration (Microsoft.UpdateServices.Administration.IEmailNotificationConfiguration)

  • Microsoft.UpdateServices.Administration.IFrontEndServer (Microsoft.UpdateServices.Administration.IFrontEndServer)

  • Microsoft.UpdateServices.Administration.IInstallableItem (Microsoft.UpdateServices.Administration.IInstallableItem)

  • Microsoft.UpdateServices.Administration.IInventoryItem (Microsoft.UpdateServices.Administration.IInventoryItem)

  • Microsoft.UpdateServices.Administration.InstallableItem (Microsoft.UpdateServices.Administration.InstallableItem)

  • Microsoft.UpdateServices.Administration.InstallableItemWithServerInformation (Microsoft.UpdateServices.Administration.InstallableItemWithServerInformation)

  • Microsoft.UpdateServices.Administration.InstallationResult (Microsoft.UpdateServices.Administration.InstallationResult)

  • Microsoft.UpdateServices.Administration.InstallBehavior (Microsoft.UpdateServices.Administration.InstallBehavior)

  • Microsoft.UpdateServices.Administration.InventoryItemProperty (Microsoft.UpdateServices.Administration.InventoryItemProperty)

  • Microsoft.UpdateServices.Administration.InventoryScope (Microsoft.UpdateServices.Administration.InventoryScope)

  • Microsoft.UpdateServices.Administration.IPublisher (Microsoft.UpdateServices.Administration.IPublisher)

  • Microsoft.UpdateServices.Administration.PackagePublicationState (Microsoft.UpdateServices.Administration.PackagePublicationState)

  • Microsoft.UpdateServices.Administration.PackagePublisherOperationCanceledException (Microsoft.UpdateServices.Administration.PackagePublisherOperationCanceledException)

  • Microsoft.UpdateServices.Administration.PackageType (Microsoft.UpdateServices.Administration.PackageType)

  • Microsoft.UpdateServices.Administration.PackageUpdateClassification (Microsoft.UpdateServices.Administration.PackageUpdateClassification)

  • Microsoft.UpdateServices.Administration.ProgramKey (Microsoft.UpdateServices.Administration.ProgramKey)

  • Microsoft.UpdateServices.Administration.PublishingEventArgs (Microsoft.UpdateServices.Administration.PublishingEventArgs)

  • Microsoft.UpdateServices.Administration.PublishingProcessProgressStep (Microsoft.UpdateServices.Administration.PublishingProcessProgressStep)

  • Microsoft.UpdateServices.Administration.ReturnCode (Microsoft.UpdateServices.Administration.ReturnCode)

  • Microsoft.UpdateServices.Administration.ScriptUtilities (Microsoft.UpdateServices.Administration.ScriptUtilities)

  • Microsoft.UpdateServices.Administration.SecurityRating (Microsoft.UpdateServices.Administration.SecurityRating)

  • Microsoft.UpdateServices.Administration.UpdateApprovalActions (Microsoft.UpdateServices.Administration.UpdateApprovalActions)

  • Microsoft.UpdateServices.Administration.UpdateFile (Microsoft.UpdateServices.Administration.UpdateFile)

  • Microsoft.UpdateServices.Administration.UpdateInstallationStates (Microsoft.UpdateServices.Administration.UpdateInstallationStates)

  • Microsoft.UpdateServices.Administration.UpdateMetadata (Microsoft.UpdateServices.Administration.UpdateMetadata)

  • Microsoft.UpdateServices.Administration.UpdateMetadataPropertyRowIndex (Microsoft.UpdateServices.Administration.UpdateMetadataPropertyRowIndex)

  • Microsoft.UpdateServices.Administration.UpdateScope (Microsoft.UpdateServices.Administration.UpdateScope)

  • Microsoft.UpdateServices.Administration.UpdateServerUserRole (Microsoft.UpdateServices.Administration.UpdateServerUserRole)

  • Microsoft.UpdateServices.Administration.UpdateServicesPackage (Microsoft.UpdateServices.Administration.UpdateServicesPackage)

  • Microsoft.UpdateServices.Administration.UpdateServicesPackageWithServerInformation (Microsoft.UpdateServices.Administration.UpdateServicesPackageWithServerInformation)

  • Microsoft.UpdateServices.Administration.UpdateTypes (Microsoft.UpdateServices.Administration.UpdateTypes)

  • Microsoft.UpdateServices.Administration.WindowsInstallerItem (Microsoft.UpdateServices.Administration.WindowsInstallerItem)

  • Microsoft.UpdateServices.Administration.WindowsInstallerPackageType (Microsoft.UpdateServices.Administration.WindowsInstallerPackageType)

  • Microsoft.UpdateServices.Administration.WindowsInstallerPatchItem (Microsoft.UpdateServices.Administration.WindowsInstallerPatchItem)

  • Microsoft.UpdateServices.Administration.WindowsInstallerRepairPath (Microsoft.UpdateServices.Administration.WindowsInstallerRepairPath)

  • Microsoft.UpdateServices.Administration.WindowsInstallerRepairPathInfo (Microsoft.UpdateServices.Administration.WindowsInstallerRepairPathInfo)

  • Microsoft.UpdateServices.Administration.WsusCollection (Microsoft.UpdateServices.Administration.WsusCollection)

  • Microsoft.UpdateServices.Administration.WsusInvalidServerException (Microsoft.UpdateServices.Administration.WsusInvalidServerException)

New additions and overloads to members, properties, and enumerations added to Windows Server Update Services 3.0

  • GetUpdateServer (Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer(System.String,System.Boolean))

  • GetUpdateServer (Microsoft.UpdateServices.Administration.AdminProxy.GetUpdateServer(System.String,System.Boolean,System.Int32))

  • Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection (Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection)

  • ApplyRule (Microsoft.UpdateServices.Administration.IAutomaticUpdateApprovalRule.ApplyRule)

  • GetCategories (Microsoft.UpdateServices.Administration.IAutomaticUpdateApprovalRule.GetCategories)

  • Id (Microsoft.UpdateServices.Administration.IAutomaticUpdateApprovalRule.Id)

  • Name (Microsoft.UpdateServices.Administration.IAutomaticUpdateApprovalRule.Name)

  • SetCategories (Microsoft.UpdateServices.Administration.IAutomaticUpdateApprovalRule.SetCategories(Microsoft.UpdateServices.Administration.UpdateCategoryCollection))

  • GetComputerTargetGroups (Microsoft.UpdateServices.Administration.IComputerTarget.GetComputerTargetGroups)

  • GetInventory (Microsoft.UpdateServices.Administration.IComputerTarget.GetInventory)

  • GetInventory (Microsoft.UpdateServices.Administration.IComputerTarget.GetInventory(System.String[]))

  • GetParentServer (Microsoft.UpdateServices.Administration.IComputerTarget.GetParentServer)

  • GetUpdateInstallationInfoPerUpdate (Microsoft.UpdateServices.Administration.IComputerTarget.GetUpdateInstallationInfoPerUpdate(Microsoft.UpdateServices.Administration.UpdateScope))

  • GetUpdateInstallationInfoPerUpdate (Microsoft.UpdateServices.Administration.IComputerTarget.GetUpdateInstallationInfoPerUpdate(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetUpdateInstallationSummary (Microsoft.UpdateServices.Administration.IComputerTarget.GetUpdateInstallationSummary)

  • GetUpdateInstallationSummary (Microsoft.UpdateServices.Administration.IComputerTarget.GetUpdateInstallationSummary(Microsoft.UpdateServices.Administration.UpdateTypes))

  • LastReportedInventoryTime (Microsoft.UpdateServices.Administration.IComputerTarget.LastReportedInventoryTime)

  • LastSyncResult (Microsoft.UpdateServices.Administration.IComputerTarget.LastSyncResult)

  • ParentServerId (Microsoft.UpdateServices.Administration.IComputerTarget.ParentServerId)

  • RequestedTargetGroupNames (Microsoft.UpdateServices.Administration.IComputerTarget.RequestedTargetGroupNames)

  • SyncsFromDownstreamServer (Microsoft.UpdateServices.Administration.IComputerTarget.SyncsFromDownstreamServer)

  • GetChildTargetGroups (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetChildTargetGroups)

  • GetComputerTargets (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetComputerTargets(System.Boolean))

  • GetComputerTargetsWithInventory (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetComputerTargetsWithInventory(Microsoft.UpdateServices.Administration.InventoryScope,System.Object,System.Boolean))

  • GetInventorySummary (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetInventorySummary(Microsoft.UpdateServices.Administration.InventoryScope[],System.Boolean))

  • GetParentTargetGroup (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetParentTargetGroup)

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetSummaryPerUpdate(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetSummaryPerUpdate(Microsoft.UpdateServices.Administration.UpdateTypes,System.Boolean))

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetTotalSummary(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetTotalSummary(Microsoft.UpdateServices.Administration.UpdateTypes,System.Boolean))

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetTotalSummaryPerComputerTarget(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetTotalSummaryPerComputerTarget(Microsoft.UpdateServices.Administration.UpdateTypes,System.Boolean))

  • GetUpdateInstallationInfoPerComputerTarget (Microsoft.UpdateServices.Administration.IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(Microsoft.UpdateServices.Administration.IUpdate,System.Boolean))

  • GetChildServers (Microsoft.UpdateServices.Administration.IDownstreamServer.GetChildServers)

  • GetParentServer (Microsoft.UpdateServices.Administration.IDownstreamServer.GetParentServer)

  • GetStatus (Microsoft.UpdateServices.Administration.IDownstreamServer.GetStatus)

  • IsReplica (Microsoft.UpdateServices.Administration.IDownstreamServer.IsReplica)

  • LastRollupTime (Microsoft.UpdateServices.Administration.IDownstreamServer.LastRollupTime)

  • ParentServerId (Microsoft.UpdateServices.Administration.IDownstreamServer.ParentServerId

  • SyncsFromDownstreamServer (Microsoft.UpdateServices.Administration.IDownstreamServer.SyncsFromDownstreamServer

  • Version (Microsoft.UpdateServices.Administration.IDownstreamServer.Version)

  • IsCategoryOnlySync (Microsoft.UpdateServices.Administration.ISubscription.IsCategoryOnlySync)

  • NumberOfSynchronizationsPerDay Microsoft.UpdateServices.Administration.ISubscription.NumberOfSynchronizationsPerDay)

  • StartSynchronizationForCategoryOnly (Microsoft.UpdateServices.Administration.ISubscription.StartSynchronizationForCategoryOnly)

  • AdvertiseForInstall (Microsoft.UpdateServices.Administration.IUpdate.AdvertiseForInstall(Microsoft.UpdateServices.Administration.IComputerTargetGroup))

  • ExpirePackage (Microsoft.UpdateServices.Administration.IUpdate.ExpirePackage)

  • ExportPackageMetadata (Microsoft.UpdateServices.Administration.IUpdate.ExportPackageMetadata(System.String))

  • GetInstallableItems (Microsoft.UpdateServices.Administration.IUpdate.GetInstallableItems)

  • GetSummaryForComputerTargetGroup (Microsoft.UpdateServices.Administration.IUpdate.GetSummaryForComputerTargetGroup(Microsoft.UpdateServices.Administration.IComputerTargetGroup))

  • GetSummaryForComputerTargetGroup (Microsoft.UpdateServices.Administration.IUpdate.GetSummaryForComputerTargetGroup(Microsoft.UpdateServices.Administration.IComputerTargetGroup,System.Boolean))

  • GetSummaryPerComputerTargetGroup (Microsoft.UpdateServices.Administration.IUpdate.GetSummaryPerComputerTargetGroup(System.Boolean))

  • GetUpdateInstallationInfoPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdate.GetUpdateInstallationInfoPerComputerTarget(Microsoft.UpdateServices.Administration.ComputerTargetScope))

  • GetUpdateInstallationInfoPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdate.GetUpdateInstallationInfoPerComputerTarget(Microsoft.UpdateServices.Administration.IComputerTargetGroup,System.Boolean))

  • IsEditable (Microsoft.UpdateServices.Administration.IUpdate.IsEditable)

  • KnowledgebaseArticles (Microsoft.UpdateServices.Administration.IUpdate.KnowledgebaseArticles)

  • Refresh (Microsoft.UpdateServices.Administration.IUpdate.Refresh)

  • ComputerTargetGroupId (Microsoft.UpdateServices.Administration.IUpdateApproval.ComputerTargetGroupId)

  • IsAssigned (Microsoft.UpdateServices.Administration.IUpdateApproval.IsAssigned)

  • UpdateId (Microsoft.UpdateServices.Administration.IUpdateApproval.UpdateId)

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IUpdateCategory.GetSummaryPerUpdate)

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IUpdateCategory.GetSummaryPerUpdate(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IUpdateCategory.GetTotalSummary)

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IUpdateCategory.GetTotalSummary(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdateCategory.GetTotalSummaryPerComputerTarget)

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdateCategory.GetTotalSummaryPerComputerTarget(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetUpdates (Microsoft.UpdateServices.Administration.IUpdateCategory.GetUpdates(Microsoft.UpdateServices.Administration.ApprovedStates,Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IUpdateClassification.GetSummaryPerUpdate)

  • GetSummaryPerUpdate (Microsoft.UpdateServices.Administration.IUpdateClassification.GetSummaryPerUpdate(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IUpdateClassification.GetTotalSummary)

  • GetTotalSummary (Microsoft.UpdateServices.Administration.IUpdateClassification.GetTotalSummary(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdateClassification.GetTotalSummaryPerComputerTarget)

  • GetTotalSummaryPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdateClassification.GetTotalSummaryPerComputerTarget(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetUpdates (Microsoft.UpdateServices.Administration.IUpdateClassification.GetUpdates(Microsoft.UpdateServices.Administration.ApprovedStates,Microsoft.UpdateServices.Administration.UpdateTypes))

  • ComputerId (Microsoft.UpdateServices.Administration.IUpdateEvent.ComputerId)

  • UpdateId (Microsoft.UpdateServices.Administration.IUpdateEvent.UpdateId)

  • ComputerTargetId (Microsoft.UpdateServices.Administration.IUpdateInstallationInfo.ComputerTargetId)

  • GetUpdateApprovalTargetGroup (Microsoft.UpdateServices.Administration.IUpdateInstallationInfo.GetUpdateApprovalTargetGroup)

  • UpdateApprovalAction (Microsoft.UpdateServices.Administration.IUpdateInstallationInfo.UpdateApprovalAction)

  • UpdateApprovalTargetGroupId (Microsoft.UpdateServices.Administration.IUpdateInstallationInfo.UpdateApprovalTargetGroupId)

  • UpdateId (Microsoft.UpdateServices.Administration.IUpdateInstallationInfo.UpdateId)

  • CreateComputerTargetGroup (Microsoft.UpdateServices.Administration.IUpdateServer.CreateComputerTargetGroup(System.String,Microsoft.UpdateServices.Administration.IComputerTargetGroup))

  • CreateInstallApprovalRule (Microsoft.UpdateServices.Administration.IUpdateServer.CreateInstallApprovalRule(System.String))

  • DeleteInstallApprovalRule (Microsoft.UpdateServices.Administration.IUpdateServer.DeleteInstallApprovalRule(System.Int32))

  • DeleteUpdate (Microsoft.UpdateServices.Administration.IUpdateServer.DeleteUpdate(System.Guid))

  • GetApprovedUpdateMetadata (Microsoft.UpdateServices.Administration.IUpdateServer.GetApprovedUpdateMetadata(Microsoft.UpdateServices.Administration.UpdateCategoryCollection,Microsoft.UpdateServices.Administration.UpdateClassificationCollection))

  • GetChildServers (Microsoft.UpdateServices.Administration.IUpdateServer.GetChildServers)

  • GetCleanupManager (Microsoft.UpdateServices.Administration.IUpdateServer.GetCleanupManager)

  • GetComputersWithRecentNameChange (Microsoft.UpdateServices.Administration.IUpdateServer.GetComputersWithRecentNameChange)

  • GetComputerTargetByName (Microsoft.UpdateServices.Administration.IUpdateServer.GetComputerTargetByName(System.String))

  • GetComputerTargetCount (Microsoft.UpdateServices.Administration.IUpdateServer.GetComputerTargetCount)

  • GetComputerTargetCount Microsoft.UpdateServices.Administration.IUpdateServer.GetComputerTargetCount(Microsoft.UpdateServices.Administration.ComputerTargetScope))

  • GetComputerTargets Microsoft.UpdateServices.Administration.IUpdateServer.GetComputerTargets(Microsoft.UpdateServices.Administration.ComputerTargetScope))

  • GetCurrentUserRole (Microsoft.UpdateServices.Administration.IUpdateServer.GetCurrentUserRole)

  • GetEmailNotificationConfiguration (Microsoft.UpdateServices.Administration.IUpdateServer.GetEmailNotificationConfiguration)

  • GetFrontEndServers (Microsoft.UpdateServices.Administration.IUpdateServer.GetFrontEndServers)

  • GetInstallApprovalRules Microsoft.UpdateServices.Administration.IUpdateServer.GetInstallApprovalRules)

  • GetPublisher (Microsoft.UpdateServices.Administration.IUpdateServer.GetPublisher(System.String))

  • GetReplicaStatus (Microsoft.UpdateServices.Administration.IUpdateServer.GetReplicaStatus)

  • GetReplicaStatus (Microsoft.UpdateServices.Administration.IUpdateServer.GetReplicaStatus(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetStatus (Microsoft.UpdateServices.Administration.IUpdateServer.GetStatus(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetSummariesPerComputerTarget (Microsoft.UpdateServices.Administration.IUpdateServer.GetSummariesPerComputerTarget(Microsoft.UpdateServices.Administration.UpdateScope,Microsoft.UpdateServices.Administration.ComputerTargetScope))

  • GetSummariesPerUpdate (Microsoft.UpdateServices.Administration.IUpdateServer.GetSummariesPerUpdate(Microsoft.UpdateServices.Administration.UpdateScope,Microsoft.UpdateServices.Administration.ComputerTargetScope))

  • GetUpdateCount (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdateCount)

  • GetUpdateCount (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdateCount(Microsoft.UpdateServices.Administration.UpdateScope))

  • GetUpdateCount (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdateCount(Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetUpdates (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdates(Microsoft.UpdateServices.Administration.ApprovedStates,System.DateTime,System.DateTime,Microsoft.UpdateServices.Administration.UpdateCategoryCollection,Microsoft.UpdateServices.Administration.UpdateClassificationCollection,Microsoft.UpdateServices.Administration.UpdateTypes))

  • GetUpdates (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdates(Microsoft.UpdateServices.Administration.UpdateScope))

  • GetUpdates (Microsoft.UpdateServices.Administration.IUpdateServer.GetUpdates(Microsoft.UpdateServices.Administration.UpdateTypes))

  • ImportUpdateFromCatalogSite (Microsoft.UpdateServices.Administration.IUpdateServer.ImportUpdateFromCatalogSite(System.Guid,System.String[]))

  • IsConnectionSecureForApiRemoting (Microsoft.UpdateServices.Administration.IUpdateServer.IsConnectionSecureForApiRemoting)

  • IsValidComputerTargetGroupName (Microsoft.UpdateServices.Administration.IUpdateServer.IsValidComputerTargetGroupName(System.String)

  • Name (Microsoft.UpdateServices.Administration.IUpdateServer.Name)

  • PortNumber (Microsoft.UpdateServices.Administration.IUpdateServer.PortNumber)

  • RollupReportingData M:Microsoft.UpdateServices.Administration.IUpdateServer.RollupReportingData)

  • SearchUpdates (Microsoft.UpdateServices.Administration.IUpdateServer.SearchUpdates(System.String,Microsoft.UpdateServices.Administration.UpdateTypes))

  • Version (Microsoft.UpdateServices.Administration.IUpdateServer.Version)

  • Change (Microsoft.UpdateServices.Administration.LogLevel.Change)

  • Categories (Microsoft.UpdateServices.Administration.SynchronizationPhase.Categories)

  • NotApproved (Microsoft.UpdateServices.Administration.UpdateApprovalAction.NotApproved)

  • ComputersUpToDateCount (Microsoft.UpdateServices.Administration.UpdateServerStatus.ComputersUpToDateCount)

  • UpdatesUpToDateCount (Microsoft.UpdateServices.Administration.UpdateServerStatus.UpdatesUpToDateCount)

  • SoftwareApplication (Microsoft.UpdateServices.Administration.UpdateType.SoftwareApplication)

  • ClientInventoryCollectionFailed (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryCollectionFailed)

  • ClientInventoryCollectionSucceeded (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryCollectionSucceeded)

  • ClientInventoryOperationalFailure (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryOperationalFailure)

  • ClientInventoryRulesDownloadFailed (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryRulesDownloadFailed)

  • ClientInventoryRulesProcessingFailed (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryRulesProcessingFailed)

  • ClientInventoryUploadFailed (Microsoft.UpdateServices.Administration.WsusEventId.ClientInventoryUploadFailed)

Members that have been removed from Windows Server Update Services 3.0

The class members that have been removed from Windows Server Update Services.

  • Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalAction.Scan

  • Microsoft.UpdateServices.Administration.IComputerTargetGroup.PurgeAssociatedReportingEvents(System.DateTime,System.DateTime)

  • Microsoft.UpdateServices.Administration.IUpdateServer.LogMessage(LogLevel,System.String,paramsobject[])

  • Microsoft.UpdateServices.Administration.IUpdateServer.GetInstallApprovalRule()

  • Microsoft.UpdateServices.Administration.IUpdateServer.GetScanApprovalRule

  • Microsoft.UpdateServices.Administration.IUpdateServer.GetDownstreamServer(System.String)

  • Microsoft.UpdateServices.Administration.UpdateApprovalAction.Block

  • Microsoft.UpdateServices.Administration.UpdateApprovalAction.Bundle

  • Microsoft.UpdateServices.Administration.UpdateApprovalAction.Scan

  • Microsoft.UpdateServices.Administration.WsusEventId.ClientStatus

  • Microsoft.UpdateServices.Administration.WsusEventId.ClientInstallationPending

  • Microsoft.UpdateServices.Administration.WsusEventId.ClientInvalidPid

  • Microsoft.UpdateServices.Administration.WsusEventId.ClientRebootCompleted

  • Microsoft.UpdateServices.Administration.WsusEventId.MaxTargetComputersReached

  • Microsoft.UpdateServices.Administration.WsusEventId.WsusServiceStarted

  • Microsoft.UpdateServices.Administration.WsusEventId.WsusServiceStopped

  • Microsoft.UpdateServices.Administration.WsusEventId.LogFileWriteFailure

  • Microsoft.UpdateServices.Administration.WsusEventId.FailedToAccessWusRegistryKey

  • Microsoft.UpdateServices.Administration.WsusEventId.EventTableFull

  • Microsoft.UpdateServices.Administration.WsusEventId.SelfUpdateTreeBroken


Using WSUS

The IUpdateServer interface is the main entry point for the WSUS API. To retrieve an IUpdateServer instance, call AdminProxy.GetUpdateServer. Then, set IUpdateServer.PreferredCulture to the locale in which you want WSUS to return strings.

The following example shows how to retrieve an instance of the IUpdateServer interface and to set the IUpdateServer.PreferredCulture property.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();
IUpdateServerConfiguration configuration = server.GetConfiguration();
System.Collections.Specialized.StringCollection supportedLanguages = configuration.SupportedUpdateLanguages;
String clientLanguageCode = System.Threading.Thread.CurrentThread.CurrentUICulture.Name; //is of the form, "en-US"

if (supportedLanguages.Contains(clientLanguageCode.ToLower()))
    server.PreferredCulture = clientLanguageCode;
else
{
    clientLanguageCode = System.Threading.Thread.CurrentThread.CurrentUICulture.Parent.Name; //is of the form, "en"
    if (supportedLanguages.Contains(clientLanguageCode.ToLower()))
        server.PreferredCulture = clientLanguageCode;
    else
        server.PreferredCulture = "en"; //default to English
}

After retrieving the IUpdateServer interface and setting the IUpdateServer.PreferredCulture property, you can use the WSUS API to perform the following tasks or other tasks:

  • Specifying Updates to Synchronize

  • Reporting Updates Needed by Clients

  • Approving Deployment of an Update to a Group of Computers

  • Retrieving Update Installation Status

For information on referencing the WSUS assembly, see Referencing the Update Services Assembly.


Referencing the Update Services Assembly

To use the WSUS API, you need to reference the Update Services assembly. The assembly is found in the global assembly cache (GAC) at %windir%\Assembly\GAC\Microsoft.UpdateServices.Administration\{version}\Microsoft.UpdateServices.Administration.dll.

If you are unable to reference the assembly in Microsoft Visual Studio, you will need to copy the assembly from the GAC to another location.


Specifying Updates to Synchronize

To download updates, you must first define your synchronization settings. The synchronization settings identify the types of updates that you want to make available to clients in your organization.

The synchronization settings specify:

  • Where to store the update files - locally or on Microsoft Update.

  • In which languages you want to download updates.

  • The category of updates to download (for example, updates for Windows XP).

  • The classification of updates to download (for example, security updates or critical updates).

  • If the WSUS server synchronizes updates with Microsoft Update or an upstream server.

  • If synchronization occurs automatically on a set schedule or is initiated by an administrator.

The following example shows how to specify synchronization settings that synchronize and store approved, critical updates for clients on an upstream WSUS server. The server variable that is used in the example is an instance of IUpdateServer (for an example that retrieves an IUpdateServer instance and sets the preferred culture, see Using WSUS).

Copy Code
using System.Collections.Specialized;  //For StringCollection

IUpdateServerConfiguration configuration = null;
ISubscription subscription = null;

//These two objects contain the properties and methods for
//specifying synchronization settings.
configuration = server.GetConfiguration();
subscription = server.GetSubscription();

//Store update files locally on the WSUS server.
//Download only update files that are approved for installation.
//Do not download express packages.
configuration.HostBinariesOnMicrosoftUpdate = false;
configuration.DownloadUpdateBinariesAsNeeded = true;
configuration.DownloadExpressPackages = false;

//Download the updates for English, French, and German languages.
configuration.AllUpdateLanguagesEnabled = false;
StringCollection enabledLanguages = new StringCollection();
enabledLanguages.AddRange(new string[] {"en", "fr", "de"});
configuration.SetEnabledUpdateLanguages(enabledLanguages);

//Subscribe to receive Windows XP family updates.
foreach (IUpdateCategory category in server.GetUpdateCategories())
{
  if (category.Title.ToLower() == "windows xp family")
  {
    UpdateCategoryCollection categories = new UpdateCategoryCollection();
    categories.Add(category);
    subscription.SetUpdateCategories(categories);
    break;
  }
}

//Subscribe to receive critical updates.
foreach (IUpdateClassification classification in server.GetUpdateClassifications())
{
  if (classification.Title.ToLower() == "critical updates")
  {
    UpdateClassificationCollection classifications = new UpdateClassificationCollection();
    classifications.Add(classification);
    subscription.SetUpdateClassifications(classifications);
    break;
  }
}

//Synchronize updates every day at 20:00. WSUS stores UTC time, so convert the local time to UTC.
subscription.SynchronizeAutomatically = true;
DateTime localSyncHour = DateTime.Today + new TimeSpan(20,0,0);
subscription.SynchronizeAutomaticallyTimeOfDay = localSyncHour.ToUniversalTime().TimeOfDay;

//Synchronize from Microsoft Update.
configuration.SyncFromMicrosoftUpdate = true;

//Save configuration changes.
//Make sure that the server is not busy before calling Save.
UpdateServerConfigurationState state = configuration.GetUpdateServerConfigurationState();
if (UpdateServerConfigurationState.Ready == state)
{
  configuration.Save();

  //Save subscription changes.
  subscription.Save();
}
else
{
  Console.WriteLine("WSUS database is busy. Please run later.");
}

To determine the current synchronization settings for a WSUS server, see Determining the Current Synchronization Settings.

To determine the progress of the synchronization process, see Determining the Progress or Status of the Synchronization Process.

To retrieve newly synchronized updates, see Reporting Newly Synchronized Updates.


Storing Update Files Locally or on Microsoft Update

You can store files locally on the WSUS server or on Microsoft Update. Storing update files locally on the WSUS server can potentially save bandwidth on your Internet connection because clients download updates directly from the WSUS server.

However, storing update files on Microsoft update saves disk space on the WSUS server and is useful if you have mobile clients, branch offices, or any scenario where a direct connection to the Internet exists and downloading updates over a WAN connection would introduce additional complexity.

To specify that you want to store update files on Microsoft Update and have clients download approved updates directly from Microsoft Update, set IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate to true.

If this property is set to false, WSUS stores the update files locally and clients download approved updates from the WSUS server. If HostBinariesOnMicrosoftUpdate is false, you must also specify values for the following settings:

  • IUpdateServerConfiguration.DownloadExpressPackages

  • IUpdateServerConfiguration.DownloadUpdateBinariesAsNeeded

  • Select update languages using either IUpdateServerConfiguration.AllUpdateLanguagesEnabled or IUpdateServerConfiguration.SetEnabledUpdateLanguages

If HostBinariesOnMicrosoftUpdate is true, WSUS ignores DownloadExpressPackages and DownloadUpdateBinariesAsNeeded, and AllUpdateLanguagesEnabled must be set to true.

To reduce network bandwidth consumption and save disk space on the WSUS server, set IUpdateServerConfiguration.DownloadUpdateBinariesAsNeeded to true. This setting downloads only the metadata and license agreement for the updates when the WSUS server synchronizes with Microsoft Update. The update files themselves are downloaded only after you approve an update for installation.

To provide for a faster download and installation of the updates on client computers, set IUpdateServerConfiguration.DownloadExpressPackages to true. Using express packages is a good option if you are servicing clients over slow links with your WSUS server. Express installation update files contain binary differences that are merged with the current binary on the client. Express installation files can reduce the bandwidth consumed on your local network because only the binary difference is downloaded to the client and it is typically smaller than a full update file.

However, express installation files that you download to the WSUS server are typically larger than a full update file because an express installation file must contain all the binary differences for each revision that it is meant to update. This can increase the bandwidth consumption on your Internet connection (connection between WSUS and Microsoft Update).

Not all updates provide express installation files. If the update does not provide an express installation file, the full update file is downloaded.

For an example that sets these properties, see Specifying Updates to Synchronize.


Specifying Languages to Support

The language configuration settings determine the languages in which the update files are downloaded. You can choose to download update files for all available languages or specific languages.

If you know the languages of all software applications and operating systems that are deployed in your network, you can specify the specific languages in which to download updates. However, if you are not sure (users can install any localized version of the operating system or software applications), you should download updates for all languages.

Selecting all languages will download all the localized packages for a given update. For example, if an update is offered in 24 languages, all 24 packages are downloaded. This option can increase bandwidth and disk space usage. To specify that WSUS synchronize updates for all languages, set IUpdateServerConfiguration.AllUpdateLanguagesEnabled to true. (AllUpdateLanguagesEnabled must be set to true if IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is set to true.)

To specify that WSUS synchronize updates for specific languages, set AllUpdateLanguagesEnabled to false and call IUpdateServerConfiguration.SetEnabledUpdateLanguages to enable the specific languages. Note that WSUS supports a subset of the language codes that are defined by RFC1766. To determine the language codes that WSUS supports, call IUpdateServerConfiguration.SupportedUpdateLanguages.

For an example that sets these properties, see Specifying Updates to Synchronize.

The language configuration settings are also used to determine in which languages the update metadata is synchronized to the WSUS server. However, most updates are bundled updates, in which case WSUS will synchronize the metadata for all languages that the bundle supports. (WSUS may download metadata for languages that are not selected.)


Specifying Update Categories to Synchronize

An update category defines the category of products for which you want to receive updates. There are three types of update categories: company, product family, and product.

The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

To retrieve a list of possible company, product family, and product categories, call IUpdateServer.GetRootUpdateCategories and iterate through each category's subcategories as shown in the following example.

Copy Code
{
  IUpdateServer server = AdminProxy.GetUpdateServer();

  DisplayCategories(server.GetRootUpdateCategories());
}

//For the given collection, print the categories and their descendants.
//The subcategories are indented under their parents.
static void DisplayCategories(UpdateCategoryCollection categories)
{
  foreach (IUpdateCategory category in categories)
  {
    //Use the category's type to indent.
    switch (category.Type)
    {
      case UpdateCategoryType.Company:
        Console.WriteLine();
        break;
      case UpdateCategoryType.ProductFamily:
        Console.Write("  ");
        break;
      case UpdateCategoryType.Product:
        Console.Write("    ");
        break;
    }

    Console.WriteLine(category.Title);

    //Recursively call this method for each category
    //that contains subcategories.
    if (category.ProhibitsSubcategories == false)
    {
      DisplayCategories(category.GetSubcategories());
    }
  }
}

To specify the categories of product updates that you want to receive, call ISubscription.SetUpdateCategories. To create the collection of categories that you pass to SetUpdateCategories, you can either:

  • Call ISubscription.GetUpdateCategories and add or remove categories from the collection as appropriate.

  • Create and populate a new category collection to pass to SetUpdateCategories as shown in the Specifying Updates to Synchronize example.

You should not include related parent child categories in the collection. For example, you should not include the Windows product family category and family product in the same collection. However, you can specify the Office product family and family product in the same collection because they are not related. If the collection contains related parent child categories, WSUS ignores the child categories and synchronizes all the products for the parent category. For example, if the collection includes Windows and family, WSUS ignores the family product category and synchronizes all Windows products.

If the collection contains a company or product family category, all products are synchronized. If a product is added in the future, the new product is automatically included in the list of products to synchronize. For example, if the collection contains the product family category, Windows, all current and future operating system product categories are synchronized. If the collection contains the company category, Microsoft Corporation, all products for all product families under Microsoft Corporation are synchronized.

If you want to prevent WSUS from automatically adding future products to the list of products being synchronized, you should use product categories only.

When Microsoft Update defines a new category, the new category is automatically downloaded to the WSUS server during the synchronization process. To determine the categories that were added since you last updated the synchronization settings, call IUpdateServer.GetUpdateCategories(DateTime, DateTime). Set the fromSyncDate parameter to ISubscription.LastModifiedTime. Use IUpdateCategory.Type to determine the type of the new categories that were added.


Specifying Update Classifications to Synchronize

Updates for a product are grouped into classifications, for example, critical updates or security updates. To retrieve a list of possible classifications, call IUpdateServer.GetUpdateClassifications.

To specify the classification of updates that you want to receive, call ISubscription.SetUpdateClassifications. To create the collection of classifications that you pass to SetUpdateClassifications, you can either:

  • Call ISubscription.GetUpdateClassifications and add or remove classifications from the collection as appropriate.

  • Create and populate a new classification collection to pass to SetUpdateClassifications as shown in the Specifying Updates to Synchronize example.

When Microsoft Update defines a new category, it is automatically downloaded to the WSUS server during the synchronization process. To determine the classifications that were added since you last updated the synchronization settings, call IUpdateServer.GetUpdateClassifications(DateTime, DateTime). Set the fromSyncDate parameter to ISubscription.LastModifiedTime.


Synchronizing from Microsoft Update or an Upstream Server

An organization can have one or more WSUS servers. Using multiple WSUS servers allows you to scale WSUS in a large organization. If the organization uses multiple WSUS servers, one of the servers will act as the upstream WSUS server (the remaining servers are downstream servers). You use the upstream server to specify the updates that you want to synchronize with Microsoft Update. The upstream WSUS server should have the IUpdateServerConfiguration.SyncFromMicrosoftUpdate configuration setting set to true.

Downstream servers synchronize updates from the upstream WSUS server. There are two forms of downstream servers: autonomous and replica. An autonomous server synchronizes the same updates as the upstream server; however, it can create its own target groups and manage its own approvals.

To specify that an autonomous downstream server synchronize with the upstream WSUS server, set IUpdateServerConfiguration.SyncFromMicrosoftUpdate to false and call:

  • IUpdateServerConfiguration.UpstreamWsusServerName to specify the name of the upstream server from which you want to synchronize

  • IUpdateServerConfiguration.UpstreamWsusServerPortNumber to specify the port number to use to communicate with the upstream server

  • IUpdateServerConfiguration.UpstreamWsusServerUseSsl to specify that you want to use a secured connection to communicate with the upstream server

A replica downstream server replicates the upstream server. The replica server synchronizes the same updates as the upstream server, and has the same target groups, approvals, accepted license agreements (EULAs), and declined status as the upstream server. The only difference between an upstream server and the replica server is the clients that are assigned to the target groups.

You specify if the server is a replica downstream server when you install WSUS; you cannot modify this setting. (See IUpdateServerConfiguration.IsReplicaServer.)

Downstream WSUS servers receive synchronization settings from the upstream WSUS server. The only settings you can change on the downstream server is the synchronization schedule. You can also start and stop the synchronization process on the downstream server.


Starting the Synchronization Process

The WSUS server does not synchronize with Microsoft Update until you start the synchronization process. To start the synchronization process manually, call ISubscription.StartSynchronization.

To synchronize with Microsoft Update at a specific time every day:

  • Set ISubscription.SynchronizeAutomatically to true

  • Set ISubscription.SynchronizeAutomaticallyTimeOfDay to the time of day when you want WSUS to synchronize

For an example, see Specifying Updates to Synchronize.

To determine the progress of the synchronization process, see Determining the Progress or Status of the Synchronization Process.

WSUS synchronizes all updates that were published since the last time you synchronized updates.


Determining the Current Synchronization Settings

The following example shows how to retrieve the current synchronization-related settings. The server variable that is used in the example is an instance of IUpdateServer (for an example that retrieves an IUpdateServer instance and sets the preferred culture, see Using WSUS).

Copy Code
using System;
using System.Collections.Specialized; //StringCollection
using Microsoft.UpdateServices.Administration; //WSUS API

IUpdateServerConfiguration configuration = null;
ISubscription subscription = null;
UpdateCategoryCollection categories = null;
UpdateClassificationCollection classifications = null;
Boolean storedOnMU = false;
Boolean syncFromMU = false;

//These two objects contain the properties and methods for
//retrieving synchronization settings.
configuration = server.GetConfiguration();
subscription = server.GetSubscription();

Console.WriteLine("Current Subscription Settings:\n");

//Store update files locally or on Microsoft Update?
storedOnMU = configuration.HostBinariesOnMicrosoftUpdate;
Console.WriteLine("Store update files {0}.",
    (storedOnMU) ? "on Microsoft Update" : "locally");

if (false == storedOnMU) //Files are stored locally.
{
  //Does WSUS download all update files or only those that are currently approved for installation?
  Console.WriteLine("Download {0}.",
      (configuration.DownloadUpdateBinariesAsNeeded) ?
        "only updates that are approved for installation" :
        "all update files");

  //Does WSUS download express installation update files if available?
  if (true == configuration.DownloadExpressPackages)
  {
    Console.WriteLine("Download the update files as express installation files, if available.");
  }
}

//In which languages are the update files downloaded?
if (true == configuration.AllUpdateLanguagesEnabled)
{
  Console.WriteLine("The update files and metadata are downloaded for all languages.");
}
else
{
  StringCollection enabledLanguages = configuration.GetEnabledUpdateLanguages();

  Console.WriteLine("Download the update files and metadata for the following languages:");
  foreach (String language in enabledLanguages)
  {
      Console.WriteLine("  {0}", language);
  }
}

//Which categories of products does WSUS synchronize?
categories = subscription.GetUpdateCategories();
Console.WriteLine("Synchronize the following categories of product updates:");
if (0 == categories.Count)
{
  Console.WriteLine("  No update categories are selected");
}
else
{
  foreach (IUpdateCategory category in categories)
  {
    if (UpdateCategoryType.Product == category.Type)
      Console.WriteLine("  {0}", category.Title);
    else
      Console.WriteLine("  All {0} products", category.Title); //Microsoft Corporation or Windows
  }
}

//Which classifications of updates does WSUS synchronize?
classifications = subscription.GetUpdateClassifications();
Console.WriteLine("Synchronize the following classification of product updates:");
if (0 == classifications.Count)
{
  Console.WriteLine("  No update classifications are selected");
}
else
{
  foreach (IUpdateClassification classification in classifications)
  {
    Console.WriteLine("  {0}", classification.Title);
  }
}

//Synchronize from Microsoft Update or an upstream server?
syncFromMU = configuration.SyncFromMicrosoftUpdate;
Console.WriteLine("Synchronize updates from {0}",
    (syncFromMU) ? "Microsoft Update." : "the following upstream WSUS server:");
if (false == syncFromMU)
{
  Console.WriteLine("  {0}", configuration.UpstreamWsusServerName);
  Console.WriteLine("\nThis server is {0}",
      (configuration.IsReplicaServer) ? "a replica downstream server." :
                                        "an autonomous downstream server.");
}

//Synchronize automatically or manually?
if (true == subscription.SynchronizeAutomatically)
{
  DateTime syncHour = DateTime.Today + subscription.SynchronizeAutomaticallyTimeOfDay;
  Console.WriteLine("Synchronize at {0} every day.", syncHour.ToLocalTime().ToShortTimeString());
}
else
{
  Console.WriteLine("The Administrator manually starts the synchronization process.");
}


Determining the Progress or Status of the Synchronization Process

The WSUS API exposes the status, progress, and results of the synchronization process. To retrieve the status of the synchronization process, call ISubscription.GetSynchronizationStatus. The synchronization status indicates if the synchronization process is currently running.

While the synchronization process is running, you can call ISubscription.GetSynchronizationProgress to retrieve its progress. If the server is a replica server, the synchronization process occurs in two phases: the first phase synchronizes the update metadata, and the second phase synchronizes the deployments. The progress information reflects only on the progress of the current phase, not both phases. For non-replica servers, the server synchronizes only the update metadata.

To determine if the synchronization process ended successfully, call ISubscription.GetLastSynchronizationInfo. Then, call ISynchronizationInfo.Result and compare the value with SynchronizationResult.Succeeded.

WSUS downloads the update files and required license agreements in parallel with synchronizing the update metadata. If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, WSUS downloads only the license agreements. To check the download progress of the update files and license agreements, call IUpdateServer.GetContentDownloadProgress.

The synchronization process can take a long time to complete depending on how long it has been since you last synchronized the WSUS server.

The following example shows how to check the status and progress of the synchronization process. The server variable that is used in the example is an instance of IUpdateServer (for an example that retrieves an IUpdateServer instance and sets the preferred culture, see Using WSUS).

Copy Code
ISubscription subscription = null;

//These two objects contain the properties and methods for
//retrieving the synchronization status information.
subscription = server.GetSubscription();

//If the synchronization process is currently running, print its progress.
while (SynchronizationStatus.Running == subscription.GetSynchronizationStatus())
{
  SynchronizationProgress progress = subscription.GetSynchronizationProgress();

  Console.WriteLine("{0}% of {1} synchronized.",
      100*progress.ProcessedItems/progress.TotalItems,
      (SynchronizationPhase.Updates) ? "updates" : "approvals");

  System.Threading.Thread.Sleep(500);
};

//If the synchronization process is not running, check if it has succeeded.
if (SynchronizationStatus.NotProcessing == subscription.GetSynchronizationStatus())
{
  ISynchronizationInfo lastSyncInfo = subscription.GetLastSynchronizationInfo();

  //Check the result to see if the synchronization process has succeeded.
  switch (lastSyncInfo.Result)
  {
    case SynchronizationResult.Succeeded :
      Console.WriteLine("Synchronization completed on {0}.",
                        lastSyncInfo.EndTime.ToLocalTime().ToString());
      break;

    case SynchronizationResult.Failed :
      Console.WriteLine("Synchronization failed with error, {0}, on {1}.",
                        lastSyncInfo.Error, lastSyncInfo.EndTime.ToLocalTime().ToString());
      Console.WriteLine(lastSyncInfo.ErrorText);

      //The synchronization process could also fail with an import error,
      //so also check UpdateErrors.
      foreach (SynchronizationUpdateErrorInfo importError in lastSyncInfo.UpdateErrors)
      {
        Console.WriteLine("Failed to import update, {0}\nReason: {1}\n",
                          server.GetUpdate(importError.UpdateId).Title,
                          importError.ErrorText);
      }

      break;

    case SynchronizationResult.Canceled :
    {
      Console.WriteLine("The synchronization process was canceled.");
      break;
    }

    case SynchronizationResult.NeverRun :
      Console.WriteLine("Synchronization has never been run on this WSUS server.");
      break;

    case SynchronizationResult.Unknown :
      Console.WriteLine("Synchronization ended for an unknown reason.");
      break;

    default :
      Console.WriteLine("Unknown synchronization result code, {0}.", lastSyncInfo.Result);
      break;
  }

  if (true == subscription.SynchronizeAutomatically)
  {
    Console.WriteLine("The next synchronization process is scheduled to occur at {0}",
                      subscription.GetNextSynchronizationTime().ToLocalTime().ToString());
  }
}
else
{
  Console.WriteLine("The synchronization process is stopping. Try again later.");
}


Reporting Newly Synchronized Updates

The following example shows how to retrieve newly synchronized updates. You can further restrict the updates that IUpdateServer.GetUpdates retrieves by including categories or classifications of updates to retrieve. This example filters the result to include only the latest revision of an update and those updates that are not declined or superseded by another update.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();
ISynchronizationInfo syncInfo = server.GetSubscription().GetLastSynchronizationInfo();
UpdateCollection updates = null;

if (SynchronizationResult.Succeeded == syncInfo.Result)
{
  updates = server.GetUpdates(ApprovedStates.Any,
                              syncInfo.StartTime, syncInfo.EndTime,
                              null, null);

  foreach (IUpdate update in updates)
  {
    if (true == update.IsLatestRevision &&
        false == update.IsSuperseded &&
        false == update.IsDeclined)
    {
      Console.WriteLine("{0}", update.Title);
    }
  }
}


Reporting Updates Needed by Clients

To determine if an update is needed by clients, the update must have been approved for deployment to one or more clients. For details, see Approving Deployment of an Update to a Group of Computers. After the clients have had time to report status back to the WSUS server, you can call one of the following methods to determine if an update is needed by one or more clients in the group:

  • IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(IUpdate)

  • IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup)

The update is needed if the IUpdateInstallationInfo.UpdateInstallationState is NotInstalled, Failed, Downloaded, or InstalledPendingReboot as shown in the following example. If the update is approved for scanning, the client returns NotInstalled if the update is applicable.

The following example shows how to determine those updates that are needed by one or more clients.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();
UpdateInstallationInfoCollection installInfoCollection = null;
IComputerTargetGroup allComputersGroup = server.GetComputerTargetGroup(ComputerTargetGroupId.AllComputers);
StringCollection clientNames = new StringCollection();
int totalUpdatesNeeded = 0;

//Retrieve each update.
foreach (IUpdate update in server.GetUpdates())
{
  //Retrieve the update installation information for each client.
  installInfoCollection = update.GetUpdateInstallationInfoPerComputerTarget(allComputersGroup);

  //For each client, determine if the client needs the update.
  foreach (IUpdateInstallationInfo installInfo in installInfoCollection)
  {
    if (UpdateInstallationState.NotInstalled == installInfo.UpdateInstallationState ||
        UpdateInstallationState.Failed == installInfo.UpdateInstallationState ||
        UpdateInstallationState.Downloaded == installInfo.UpdateInstallationState ||
        UpdateInstallationState.InstalledPendingReboot == installInfo.UpdateInstallationState)
    {
      clientNames.Add(installInfo.GetComputerTarget().FullDomainName);
    }
  }

  //If any of the clients need the update, increment the totalUpdatesNeeded counter.
  if (clientNames.Count > 0)
  {
    totalUpdatesNeeded++;

    //Print the update and the list of clients that need to install the update.
    Console.WriteLine("{0} needed by:", update.Title);
    foreach (String name in clientNames)
    {
      Console.WriteLine("{0}", name);
    }
    Console.WriteLine();

    clientNames.Clear();
  }

}

Console.WriteLine("\n{0} updates needed by clients.", totalUpdatesNeeded);

The following example shows how to determine those updates that a client needs.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();
StringCollection updateTitles = new StringCollection();

//Retrieve each client.
foreach (IComputerTarget client in server.GetComputerTargets())
{
  Console.WriteLine("{0} needs the following updates:", client.FullDomainName);

  //Retrieve the update installation information for each update.
  foreach (IUpdateInstallationInfo installInfo in client.GetUpdateInstallationInfoPerUpdate())
  {
    //For each update, determine if the client needs the update.
    if (UpdateInstallationState.NotInstalled == installInfo.UpdateInstallationState ||
        UpdateInstallationState.Failed == installInfo.UpdateInstallationState ||
        UpdateInstallationState.Downloaded == installInfo.UpdateInstallationState ||
        UpdateInstallationState.InstalledPendingReboot == installInfo.UpdateInstallationState)
    {
      updateTitles.Add(installInfo.GetUpdate().Title);
    }
  }

  if (0 == updateTitles.Count)
  {
    Console.WriteLine("\tNone\n");
  }
  else
  {
    foreach (String title in updateTitles)
    {
      Console.WriteLine("\t{0}", title);
    }
    Console.WriteLine();

    updateTitles.Clear();
  }
}

You can also call UpdateServerStatus.ComputerTargetsNeedingUpdatesCount and UpdateServerStatus.UpdatesNeededByComputersCount to retrieve this information.


Displaying Available Updates

To retrieve all updates, call IUpdateServer.GetUpdates(). The collection contains updates from all categories and classifications, updates that supersede other updates, and declined updates. If you want to retrieve a subset of updates, for example, retrieve only approved updates, call IUpdateServer.GetUpdates(ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection).

The following example shows how to retrieve all updates that were not declined or superseded. The example indicates if the update is approved or has revisions or related updates that are approved.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();

//Retrieve all the latest updates.
foreach (IUpdate update in server.GetUpdates())
{
  //If the update supersedes all other related updates and is not declined,
  //determine if the update is approved or not.
  if (false == update.IsSuperseded &&amp; false == update.IsDeclined)
  {
    Console.WriteLine("\n{0}", update.Title);

    if (update.IsApproved)
    {
      //If the update is approved, determine the action and to which
      //groups the update is approved.
      foreach (IUpdateApproval approval in update.GetUpdateApprovals())
      {
        Console.WriteLine("  This update is approved for {0} to {1}.",
                          approval.Action,
                          approval.GetComputerTargetGroup().Name);
      }
    }
    else
    {
      Console.WriteLine("  This update is not approved.");
    }

    //If the update has previous revisions, determine if any of them are approved.
    if (update.IsLatestRevision &&amp; update.HasStaleUpdateApprovals)
    {
      Console.WriteLine("  The following earlier revisions of this update are approved:");
      foreach (IUpdate revision in update.GetRelatedUpdates(UpdateRelationship.AllRevisionsOfThisUpdate))
      {
        if (revision.IsApproved)
          Console.WriteLine("    {0}", revision.Title);
      }
    }

    //Retrieve updates that are superseded by this update. If the update or one of its revisions
    //is approved, list the update.
    UpdateCollection supersededUpdates = update.GetRelatedUpdates(UpdateRelationship.UpdatesSupersededByThisUpdate);
    if (supersededUpdates.Count > 0)
    {
      Console.WriteLine("  The following superseded updates are also approved:");
      foreach (IUpdate supersededUpdate in supersededUpdates)
      {
        if (supersededUpdate.IsApproved || supersededUpdate.HasStaleUpdateApprovals)
        {
          Console.WriteLine("    {0}", supersededUpdate.Title);
        }
      }
    }

  }
}


Local Publishing of Updates and Applications

The Microsoft Windows Server Update Services (WSUS) API supports the ability to publish local updates and applications.

Note:
The WSUS user interface will not display locally published packages. The WSUS solution is limited to distributing packages from Microsoft Update and Windows Update.

Prerequisites

You must first initialize a trust between the WSUS server and clients, before performing any local publishing calls. The following two steps must be performed in order to initialize a trust.

  • Call SetSigningCertificate to install a code signing certificate.

  • Set client policy to enable Automatic Updates to trust content signed by the server (by default, the agent trusts only Microsoft signed content). This requires putting the signing certificates public key in each client's trusted publisher store and setting the Automatic Updates policy to allow content signed by trusted publishers. See Deploying Microsoft Windows Server Update Services (http://go.microsoft.com/fwlink/?LinkId=71514) for directions about setting client policy using Group Policy.

Local publishing of updates and applications

This procedure demonstrates how to use the WSUS API for local publishing of updates and applications.

To use the WSUS API for local publishing

  1. Use the Microsoft.UpdateServices.Administration.UpdateServicesPackage class to author a package. The PopulatePackageFrom*() methods allow one to quickly set correct defaults for various package types, such as MSI, MSP, and EXE.

  2. Use the Microsoft.UpdateServices.Administration.IPublisher interface to publish the package to the WSUS server.

  3. When the package is published, it can be approved and reports can be generated using the same APIs used for updates on Microsoft Update (for example, Approve).


Approving Deployment of an Update to a Group of Computers

After synchronizing updates from Microsoft Update, you can manually or automatically approve the updates for deployment to client computers in a target group. Only approved updates whose license agreement has been accepted are sent to clients when the client contacts the WSUS server (scan approvals do not require license agreement acceptance). Clients typically contact the WSUS server once every 24 hours, longer if the client is turned off or does not have network connectivity.

For details on managing approvals, see

  • Defining Automatic Approval Rules

  • Manually Approving Updates for Deployment

  • Deleting an Approval

  • Declining an Update

Note that WSUS infrastructure updates (updates required by WSUS) are automatically approved for installation to the All Computers target group.


Defining Automatic Approval Rules

Automatic approval rules apply to newly synchronized updates (the rules apply to new updates only, not to a new revision of an update). You can create one scan rule and one install rule. If the scan rule and install rule apply to the same classification and target group, the install rule overrides the scan rule.

Typically, you create an automatic approval rule to scan clients for applicable updates. A scan approval rule asks the client to detect if the update is applicable (can be installed on the client to update existing software), but does not to install the update. You can generate a report from the scan results to determine which clients in the target group can apply the update.

To define an automatic approval rule

  1. Call either the IUpdateServer.GetInstallApprovalRule() to retrieve the install approval rule or IUpdateServer.GetScanApprovalRule() to retrieve the scan approval rule.

  2. Set IAutomaticUpdateApprovalRule.Enabled to true.

  3. Call IAutomaticUpdateApprovalRule.SetUpdateClassifications(UpdateClassificationCollection) to specify the classification of updates for which you want to automatically create the approval. For example, create a scan approval rule to detect applicable critical and security updates.

  4. Call IAutomaticUpdateApprovalRule.SetComputerTargetGroups(ComputerTargetGroupCollection) to specify the target groups to which you want to apply the rule.

  5. Call IAutomaticUpdateApprovalRule.Save() to save the rule.

The following example shows how to create and enable an automatic approval rule to scan clients in the All Computers group for applicable critical and security updates. The server variable that is used in the example is an instance of Microsoft.UpdateServices.Administration.IUpdateServer (for an example that retrieves an Microsoft.UpdateServices.Administration.IUpdateServer instance and sets the preferred culture, see Using WSUS).

Copy Code
IAutomaticUpdateApprovalRule scanRule = null;
ComputerTargetGroupCollection targetGroups = null;
UpdateClassificationCollection classifications = null;

//Retrieve the scan rule.
scanRule = server.GetScanApprovalRule();

//Specify the target groups to which you want to apply the rule.
targetGroups = new ComputerTargetGroupCollection();
targetGroups.Add(server.GetComputerTargetGroup(ComputerTargetGroupId.AllComputers));
scanRule.SetComputerTargetGroups(targetGroups);

//Specify the classification of updates to which you want to apply the rule.
classifications = new UpdateClassificationCollection();
foreach (IUpdateClassification classification in server.GetUpdateClassifications())
{
  if (classification.Title.ToLower() == "critical updates" ||
      classification.Title.ToLower() == "security updates")
  {
    classifications.Add(classification);
  }
}
scanRule.SetUpdateClassifications(classifications);

//Enable the rule.
scanRule.Enabled = true;

//Save the rule.
scanRule.Save();

You can define an automatic approval rule to automatically install specific classifications of updates, for example, critical updates or security updates, to groups of clients in your organization. However, you typically use the automatic install approval rule to deploy updates to a test group where you test the update to ensure that there are no issues with the updates in your environment. If there are no issues, you can then manually approve the updates for deployment to other clients in your organization.

Note that the automatic install approval rule will not deploy an update if the update requires the acceptance of a license agreement. If this occurs, WSUS logs an NT event to the event log. The event identifier is 422.

For information on manually approving an update, see Manually Approving Updates for Deployment.


Manually Approving Updates for Deployment

To approve an update for deployment, call IUpdate.Approve(UpdateApprovalAction, IComputerTargetGroup). The update approval action indicates if you want to install the update on a client computer, scan the client computer to determine if the update is applicable, remove the update from the client, prevent the update from deploying to a specific target group, or specify that the update use the same approval action as its parent.

Before approving an update for installation, you should first call IUpdate.RequiresLicenseAgreementAcceptance to determine if the user must first accept a license agreement before approving the update. To accept the license agreement, call IUpdate.AcceptLicenseAgreement().

If the update is a revision to a previous update, you can call IUpdate.RefreshUpdateApprovals() to apply the previous revision's approval to the latest revision. If you always want to apply the current approval to the latest revision of an update, set IUpdateServerConfiguration.AutoRefreshUpdateApprovals to true.

You can approve different revisions of the same update for deployment to different groups; however, if one of the groups is the All Computers group, the approval actions cannot conflict (for example, you cannot approve one revision for installation and the other revision for removal). You cannot approve different revisions of an update for deployment to the same group.

To determine if the update is a revision to a previous update, call IUpdate.HasEarlierRevision. To determine if a previous revision of the update contains an approval, call IUpdate.HasStaleUpdateApprovals. To determine if the update is the latest revision of the update, call IUpdate.IsLatestRevision.

The following example shows how to approve an update for installation to the All Computers group. The update variable is an instance of IUpdate. The server variable is an instance of IUpdateServer.

Copy Code
bool okToApprove = true;
string response;

if (update.RequiresLicenseAgreementAcceptance)
{
  ILicenseAgreement eula = update.GetLicenseAgreement();

  //If EULA is not already accepted, display text and wait for a response.
  if (false == eula.IsAccepted)
  {
    Console.WriteLine(eula.Text);
    Console.Write("\n\nDo you accept the terms of the agreement, \"Yes\" or \"No\": ");
    response = Console.ReadLine();
    if ("yes" = response.ToLower())
      update.AcceptLicenseAgreement();
    else
      okToApprove = false;
  }
}

if (true == okToApprove)
{
  update.Approve(UpdateApprovalAction.Install, server.GetComputerTargetGroup(ComputerTargetGroupId.AllComputers));
}

For information on automatically approving updates, see Defining Automatic Approval Rules.


Deleting an Approval

To delete an approval

  1. Retrieve an Microsoft.UpdateServices.Administration.IUpdate instance of the update whose approval you want to remove.

  2. Call one of the overloaded GetUpdateApprovals methods to retrieve the approval.

  3. Call Delete to delete the approval.

You cannot remove an automatic approval rule—you can only disable the rule.

To disable an automatic approval rule

  1. Call either the IUpdateServer.GetInstallApprovalRule() to retrieve the install approval rule or IUpdateServer.GetScanApprovalRule() to retrieve the scan approval rule.

  2. Set IAutomaticUpdateApprovalRule.Enabled to false.

  3. Call IAutomaticUpdateApprovalRule.Save() to save the rule.


Declining an Update

To prevent an update from deploying

  1. Retrieve the IUpdate instance of the update that you want to prevent from being deployed.

  2. Call IUpdate.Decline() to prevent the update from deploying.

Declining an update also removes approvals from previous revisions of the update.

If you want to approve an update for the All Computers group, but block the update from deploying to a specific target group, call IUpdate.Approve(UpdateApprovalAction, IComputerTargetGroup) and set action to UpdateApprovalAction.Block.

WSUS automatically declines updates whose publication state is expired.


Retrieving Update Installation Status

You can retrieve installation information from either the IComputerTargetGroup, IComputerTarget, or IUpdate interface.

Retrieving installation information from the target group

The IComputerTargetGroup interface contains the following methods for retrieving update installation summary information:

  • IComputerTargetGroup.GetSummaryPerUpdate()

  • IComputerTargetGroup.GetTotalSummary()

  • IComputerTargetGroup.GetTotalSummaryPerComputerTarget()

  • IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(IUpdate)

For an example that calls IComputerTargetGroup.GetTotalSummary(), see Reporting Installation Status Totals by Target Group. For an example that calls IComputerTargetGroup.GetSummaryPerUpdate(), see Reporting Installation Status Totals by Update. For an example that calls IComputerTargetGroup.GetTotalSummaryPerComputerTarget(), see Reporting Installation Status Totals by Client.

Retrieving installation information from the client

The IComputerTarget interface contains the following method for retrieving update installation information:

  • IComputerTarget.GetUpdateInstallationInfoPerUpdate()

For an example that calls IComputerTarget.GetUpdateInstallationInfoPerUpdate(), see Reporting Updates Needed by Clients.

Retrieving installation information from the update

The IUpdate interface contains the following methods for retrieving update installation information:

  • IUpdate.GetSummaryPerComputerTargetGroup()

  • IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup)

For an example that calls IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup), see Reporting Updates Needed by Clients.


Reporting Installation Status Totals by Target Group

The following example shows how to use IComputerTargetGroup.GetTotalSummary() to retrieve the installation count totals for a target group. The totals reflect the installation state of all occurrences of each update approved for deployment to the group. For example, the InstalledCount summary total reflects the number of occurrences of each update that is installed in the group. If Update A is installed on five clients and Update B is installed on three clients, then the InstalledCount for the group is eight (assuming Update A and Update B are the only updates deployed to the group).

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();

//Retrieve each group.
foreach (IComputerTargetGroup group in server.GetComputerTargetGroups())
{
  //For each group, retrieve the summary installation count totals.
  IUpdateSummary totalsSummary = group.GetTotalSummary();

  Console.WriteLine("Group: {0}\nInstalled: {1}\nPending restart:{2}\nDownloaded: {3}" +
                    "\nNot installed: {4}\nFailed: {5}\nNot applicable: {6}" +
                    "\nUnknown: {7}\n",
                    group.Name,
                    totalsSummary.InstalledCount, totalsSummary.InstalledPendingRebootCount,
                    totalsSummary.DownloadedCount, totalsSummary.NotInstalledCount,
                    totalsSummary.FailedCount, totalsSummary.NotApplicableCount,
                    totalsSummary.UnknownCount);

}


Reporting Installation Status Totals by Update

The following example shows how to retrieve the summary installation totals for each approved update. For example, the summary totals indicate the number of clients in the group that have successfully installed the update. Those updates that are not specifically deployed to the given target group are reflected in the UnknownCount summary total (except for those updates that are deployed to the All Computers group, in which case the update will not be reflected in the UnknownCount summary total).

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();

//Retrieve each target group.
foreach (IComputerTargetGroup group in server.GetComputerTargetGroups())
{
  //For each group, retrieve the installation totals for each update
  //approved for deployment.
  foreach (IUpdateSummary summary in group.GetSummaryPerUpdate())
  {
    Console.WriteLine("Group: {0}\nUpdate: {1}\nInstalled: {2}\nPending restart: {3}" +
                      "\nDownloaded: {4}\nNot installed: {5}\nFailed: {6}\n" +
                      "\nNot applicable: {7}\nUnknown: {8}\n",
                      group.Name,
                      server.GetUpdate(new UpdateRevisionId(summary.UpdateId)).Title,
                      summary.InstalledCount, summary.InstalledPendingRebootCount,
                      summary.DownloadedCount, summary.NotInstalledCount,
                      summary.FailedCount, summary.NotApplicableCount,
                      summary.UnknownCount);
  }
}

The following example shows how to filter the summary installation totals in the previous example to reflect only those updates that are approved for deployment to the given target group. If the update is approved to clients in the All Computers group, the approval implicitly applies to clients in any group.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();
IComputerTargetGroup allComputersGroup = null;

//Retrieve each target group.
foreach (IComputerTargetGroup group in server.GetComputerTargetGroups())
{
  int clientCount = group.GetComputerTargets().Count;  //Count of clients in the group

  //If the group does not contain clients, do not report the status.
  if (clientCount > 0)
  {
    //Retrieve the summary installation information for each update.
    foreach (IUpdateSummary summary in group.GetSummaryPerUpdate())
    {
      bool deployedToThisGroup = false;  //Approved for deployment to clients in this group
      IUpdate update = server.GetUpdate(new UpdateRevisionId(summary.UpdateId));

      if (null == allComputersGroup) //Retrieve the All Computers group only once.
      {
        allComputersGroup = server.GetComputerTargetGroup(ComputerTargetGroupId.AllComputers);
      }

      //Determine if the update was approved for deployment to this group or
      //the All Computers group. If the update is approved to the All Computers
      //group, make sure that it is not also approved to block deployment to this group.
      if (update.GetUpdateApprovals(group).Count > 0)
      {
        if (update.GetUpdateApprovals(group, UpdateApprovalAction.Block, DateTime.MinValue, DateTime.MaxValue).Count == 0)
          deployedToThisGroup = true;
      }
      else if (update.GetUpdateApprovals(allComputersGroup).Count > 0)
      {
          deployedToThisGroup = true;
      }

      if (true == deployedToThisGroup)
      {
        Console.WriteLine("Group: {0}\nUpdate: {1}\nInstalled: {2}\nPending restart: {3}" +
                      "\nDownloaded: {4}\nNot installed: {5}\nFailed: {6}\n" +
                      "\nNot applicable: {7}\nUnknown: {8}\n",
                      group.Name, update.Title,
                      summary.InstalledCount, summary.InstalledPendingRebootCount,
                      summary.DownloadedCount, summary.NotInstalledCount,
                      summary.FailedCount, summary.NotApplicableCount,
                      summary.UnknownCount);
      }
    }
  }
}


Reporting Installation Status Totals by Client

The following example shows how to retrieve summary installation totals by client. For example, the totals reflect the number of updates installed on the client. Those updates that are not specifically deployed to the given client are reflected in the UnknownCount summary total.

Copy Code
IUpdateServer server = AdminProxy.GetUpdateServer();

//Retrieve the All Computers target group.
IComputerTargetGroup allComputersGroup = server.GetComputerTargetGroup(ComputerTargetGroupId.AllComputers);

//Retrieve the summary installation totals for each client.
foreach (IUpdateSummary summary in allComputersGroup.GetTotalSummaryPerComputerTarget())
{
  Console.WriteLine("Client: {0}\nInstalled: {1}\nPending restart: {2}" +
                    "\nDownloaded: {3}\nNot installed: {4}\nFailed: {5}\n" +
                    "\nNot applicable: {6}\nUnknown: {7}\n",
                    server.GetComputerTarget(summary.ComputerId).FullDomainName,
                    summary.InstalledCount, summary.InstalledPendingRebootCount,
                    summary.DownloadedCount, summary.NotInstalledCount,
                    summary.FailedCount, summary.NotApplicableCount,
                    summary.UnknownCount);
}


Retrieving Server Statistics

The UpdateServerStatus class contains summary statistics that summarize the current state of the WSUS server, updates, and the client computers. You can use this class to retrieve a count of the number of clients known to the WSUS server, the number of updates needed by clients, the number of critical and security updates not approved for installation, and the number of approved updates.

To retrieve this class, call IUpdateServer.GetStatus. The statistics reflect the state of the server at the time you retrieved them.


WSUS Samples

WSUS includes the following samples that exercise the WSUS API. To download the package that contains the samples, see Update Services API Samples and Tools. For details on compiling the samples, see the Readme.htm file included in the package.

Sample | Description
ADImporter | Populates target groups with computers from Active Directory. The sample connects to the default Active Directory domain controller and lists the organizational units and computers in the domain. It also lists the computer groups available on the Update Services server. Using this sample, you can select computers from Active Directory and "register" the selected computers with Update Services. Note that each computer registered must be configured to talk to the Update Services server independently of using this sample.
ApprovedUpdatesToXML | Creates an XML file with a list of approved updates. The list includes details such as the groups for which the update is approved and the approval action.
CleanStaleComputers | Removes computers from the Update Services server that have not contacted the server in a specified number of days.
ComplianceReport | Creates an HTML report that lists computers that do not have all the approved updates installed.
ComputersNeedingReboot | Creates an HTML report that lists computers that have installed updates but still require the computer to be restarted before the update is complete.
ComputerStatusToXML | Creates an XML file with a list of computers on the Update Services server and the status of updates approved for each computer.
Update Services Notifications | A Windows Service that periodically sends e-mail notifications to selected users about synchronized updates and an update status summary.
UpdateStatusToCSV | Creates a CSV file with a list of approved updates and a summary of the status of the updates on each computer.
UpdateStatusToXML | Creates an XML file with a list of approved updates and their installation status on client computers. Each update section contains an overall summary for all computers, a summary per target group, and the status of the update on each computer within each target group.
UpdatesToXML | Creates an XML file with a list of updates and information about each update, including the update's identifier, title, description, and related Knowledge Base topics.


Class Library
[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespaces

Namespace
Microsoft.UpdateServices.Administration


Microsoft.UpdateServices.Administration Namespace

You use the WSUS interfaces to access and manage WSUS. The IUpdateServer interface contains the methods that you use to retrieve the other interfaces. For example:

  • Call IUpdateServer.GetSubscription to retrieve an instance of ISubscription, which you use to manage the types of updates that you want to synchronize with Microsoft Update.

  • Call IUpdateServer.GetUpdate to retrieve an instance of IUpdate, which you use to approve an update for deployment.

  • Call IUpdateServer.GetComputerTargetGroup to retrieve an instance of IComputerTargetGroup, which you use to manage a group of clients to which updates are deployed.

  • Call IUpdateServer.GetConfiguration to retrieve an instance of IUpdateServerConfiguration, which you use to manage WSUS settings.

To retrieve an IUpdateServer instance, call AdminProxy.GetUpdateServer.

The WSUS classes are primarily collection classes returned by various interface methods.

Classes

Class | Description
AdminProxy | This class provides a starting point for getting a IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic. You use IUpdateServer to communicate with the WSUS server.
AutomaticUpdateApprovalRuleCollection | Represents a collection of AutomaticUpdateApprovalRules.
BiosInfo | Contains the BIOS information for the client computer. To retrieve this class, call the IComputerTarget.BiosInfo property.
CleanupEventArgs | Event Class containing information specific to the progress event.
CleanupResults | Unique identifier of a CleanupResults, that ICleanupManager.PerformCleanup method will return an object of, consisting of cleanup results of various cleanup options.
CleanupScope | Unique identifier of a CleanupScope, consisting of user selections of various cleanup options.
CommandLineItem |
ComputerTargetCollection | Represents a collection of client computers.
ComputerTargetGroupCollection | Collection of Categories.
ComputerTargetGroupId | Use the target group identifiers that are defined in this class to retrieve the target groups that are defined by WSUS. For example, you can use the identifiers when calling GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.
ComputerTargetScope | Defines the set of parameters that can be used to filter the results of retrieved list of ComputerTargets.
ContentDownloadProgress | Defines the download progress for all updates that are currently downloading to the WSUS server. To retrieve this class, call the IUpdateServer.GetContentDownloadProgress method.
DownstreamServerCollection | Collection of downstream Windows Server Update Servers (WSUS) servers. To retrieve this collection, call GetDownstreamServers frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDownstreamServersTopic.
FileForInstallableItem |
InstallableItem | The properties of the InstallableItem class. Each package contains one or more installable items. Typically applications have a single installable item and updates could have several instances
InstallableItemWithServerInformation | An overloaded class which duplicates all public methods of InstallableItem class and allow callers to access Server Specific properties.
InstallationBehavior | Defines the installation behavior of the update. To retrieve this class, call the InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationIUpdateClassInstallationBehaviorTopic property.
InstallBehavior | Behaviors of the Update for a specific action
InventoryItemProperty | Represents a property of an Inventory item
InventoryScope | Provides a way to limit the scope of the API to a specific class. Also defines the property to summarize by.
OSInfo | Contains information about the operating system of the client computer. To retrieve this class, call the IComputerTarget.OSInfo property.
OSVersion | Defines the version of the operating system. To retrieve this class, call the OSInfo.Version property.
PackagePublisherOperationCanceledException |
ProgramKey | Information of ProgramKey
PublishingEventArgs | Event Class containing information specific to the progress event
ReturnCode |
ScriptUtilities | This class defines a series of utilities for com clients scripting against the Windows Server Update Services API.
SubscriptionEventCollection | Collection of subscription events. To retrieve the collection, call one of the following methods: ISubscription.GetEventHistory(); ISubscription.GetEventHistory(DateTime, DateTime).
SynchronizationInfoCollection | Collection of synchronization information. To retrieve the collection, call one of the following methods: ISubscription.GetSynchronizationHistory() ; ISubscription.GetSynchronizationHistory(DateTime, DateTime).
SynchronizationProgress | Defines the progress of synchronizing update metadata and deployments to a WSUS server. If the server is a replica server, the synchronization process occurs in two phases: the first phase synchronizes the update metadata, and the second phase synchronizes the deployments. Otherwise, the server synchronizes only update metadata. The progress information reflects only the synchronization progress of the current phase, not all phases of the synchronization process. To retrieve this class, call ISubscription.GetSynchronizationProgress.
SynchronizationUpdateErrorInfo | Use this class to determine why an update failed. To retrieve this class, call SynchronizationUpdateErrorInfoCollection.Item or enumerate through the SynchronizationUpdateErrorInfoCollection collection.
SynchronizationUpdateErrorInfoCollection | Collection of errors that occurred while processing an update. To retrieve this collection, call one of the following properties: ISubscriptionEvent.UpdateErrors; ISynchronizationInfo.UpdateErrors.
UpdateApprovalCollection | Collection of update approvals. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateApprovals() ; IUpdate.GetUpdateApprovals(IComputerTargetGroup); IUpdate.GetUpdateApprovals(IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime).
UpdateCategoryCollection | Collection of product categories. For a description of product categories, see IUpdateServer.GetUpdateCategories(). To retrieve this collection, call one of the following methods: ISubscription.GetUpdateCategories(); GetUpdateCategories() ; IUpdateCategory.GetSubcategories(); IUpdateServer.GetRootUpdateCategories(); IUpdateServer.GetUpdateCategories() ; IUpdateServer.GetUpdateCategories(DateTime, DateTime) .
UpdateClassificationCollection | Collection of update classifications. Classifications define a grouping of updates. For example, Security Updates, Critical Updates, or Driver Updates. To retrieve this collection, call one of the following methods: IAutomaticUpdateApprovalRule.GetUpdateClassifications(); ISubscription.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(DateTime, DateTime).
UpdateCollection | Collection of updates. To retrieve this collection, call one of the following methods: IUpdate.GetRelatedUpdates(UpdateRelationship); IUpdateCategory.GetUpdates() ; IUpdateCategory.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(); IUpdateServer.GetUpdates() ; IUpdateServer.GetUpdates(ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection); IUpdateServer.SearchUpdates(String) .
UpdateEventCollection | Collection of update events. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IComputerTarget) ; IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate, WsusEventSource, WsusEventId[]).
UpdateFile | This class defines an update file associated with an InstallableItem.
UpdateInstallationInfoCollection | Collection of update installation information. To retrieve this collection, call one of the following methods: IComputerTarget.GetUpdateInstallationInfoPerUpdate(); IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(IUpdate); IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup) .
UpdateLanguage | Use the language code strings that are defined in this class to specify a language code.
UpdateMetadata | This class defines the set of properties belonged to an Update that includes the actual xml data and its content files if existing.
UpdateRevisionId | Identifies a specific revision of an update. Use the new keyword to initialize a new instance of the class or call one of the following properties to retrieve an instance of this class: IUpdateClassification.Id ; IUpdateCategory.Id ; SynchronizationUpdateErrorInfo.UpdateId ; IUpdate.Id .
UpdateScope | Defines the set of parameters that can be used to filter the results when obtaining the list of Updates.
UpdateServerStatus | This class contains statistics summarizing the current state of the WSUS server, updates, and the client computers. To retrieve this class, call the IUpdateServer.GetStatus method. The statistics are a snapshot in time of the current counts. You need to call the IUpdateServer.GetStatus method each time you want to receive the current counts. Do not use the new keyword to create a this class.
UpdateServicesPackage | Update Services package class. This class implements the functions of creating or updating of SDP file. Note: an admin can update/expire a locally published package only if he/she has the original SDP file. If a locally published application is imported from another server, then admin cannot update/expire this imported locally published application. Admin needs to export the SDP from the original server, revise and re-publish this application.
UpdateServicesPackageWithServerInformation | Update Services package with server specific information class used by Publishing
UpdateSummaryCollection | Collection of summary installation information for updates. To retrieve this collection, call one of the following methods: IComputerTargetGroup.GetSummaryPerUpdate(); IComputerTargetGroup.GetTotalSummaryPerComputerTarget(); IUpdate.GetSummaryPerComputerTargetGroup().
WindowsInstallerItem |
WindowsInstallerPatchItem |
WindowsInstallerRepairPath | This class is used to support Exe-wrapped-Msi. It contains TargetId (ProductCode of Msi), TargetType: for either MSI or MSP; and RelativePathToExe: a relative path to setup executable which AU will use it to determine where the repair path is for each MSI/MSP.
WindowsInstallerRepairPathInfo | This is used for publishing to fill server specific information for RepairPath. It actually only needs to fill Path property.
WsusCollection | This class provides custom validation for CollectionBase.
WsusInvalidDataException | This exception is thrown when data is found in the WSUS database that is not valid.
WsusInvalidServerException | This exception should be used when AdminProxy.GetUpdateServer() is called with an invalid server.
WsusObjectAlreadyExistsException | This exception is thrown when the object already exists in the database.
WsusObjectNotFoundException | This exception is thrown when the requested object is not found in the database.

Interfaces

Interface | Description
IAutomaticUpdateApprovalRule | Use this interface to define and enable an automatic approval rule. The approval rule creates approvals for newly synchronized updates that fall within one of the specified classification of updates. The rule applies only to new updates, not to new revisions of an update. If the approval applies to the same target group, install approvals will override scan approvals. To retrieve this interface, call the IUpdateServer.GetInstallApprovalRule or the IUpdateServer.GetScanApprovalRule.
ICleanupManager |
IComputerTarget | Use this interface to retrieve information about the client computer, remove the client from WSUS, determine the group to which it belongs, and retrieve information related to updates approved for the client. To retrieve this interface, call one of the following methods: ComputerTargetCollection.Item; IUpdateEvent.GetComputer; IUpdateInstallationInfo.GetComputerTarget; IUpdateServer.GetComputerTarget; IUpdateServer.RegisterComputer.
IComputerTargetGroup | Use this interface to add clients to or remove clients from the target group, delete the group, or retrieve installation results for client members. To retrieve this interface, call the following methods: P:Microsoft.UpdateServices.Administration.ComputerTargetGroupCollection.Item(System.Int32); GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassGetComputerTargetGroupTopic; GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateApprovalClassGetComputerTargetGroupTopic; CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.
IDatabaseConfiguration | Defines the IDatabaseConfiguration Interface for accessing Database Configuration Information. To retrieve this interface, call GetDatabaseConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDatabaseConfigurationTopic.
IDownstreamServer | Use this interface to retrieve the name of the downstream server or to remove the downstream server from the list of downstream servers connected to this WSUS server.
IEmailNotificationConfiguration | Defines the IEmailNotificatioNConfiguration Interface for configuring email user account and email server.
IFrontEndServer | This type defines interface of a front end server.
IInstallableItem | This type defines a non-explicitly-deployable Update and all the methods that act on an it.
IInventoryItem | Represents an Inventory item
ILicenseAgreement | Use this interface to retrieve the text of the license agreement and to determine if the agreement was accepted and by whom. To retrieve this interface, call IUpdate.GetLicenseAgreement.
IPublisher | The properties of the IPublisher interface.
ISubscription | Use this interface to view or modify the synchronization settings and to manually or automatically start the synchronization process. Downstream servers (DSS) receive synchronization settings from the upstream server. Downstream servers can modify and save synchronization settings; however, only the synchronization schedule is used by the downstream server, WSUS ignores the other settings. Downstream servers can also start and stop the synchronization process. To retrieve this interface, call GetSubscription frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetSubscriptionTopic.
ISubscriptionEvent | Use this interface to retrieve information about subscription and synchronization events. To retrieve this interface, call the following methods: IUpdateServer.GetSubscriptionEvent; SubscriptionEventCollection.Item.
ISynchronizationInfo | Use this interface to retrieve information about the last synchronization process. To retrieve this interface, call one of the following methods: ISubscription.GetLastSynchronizationInfo; IUpdateServer.GetSynchronizationInfo; SynchronizationInfoCollection.Item.
IUpdate | Use this interface to approve or decline updates for deployment and retrieve information about the update. To retrieve this interface, call one of the following methods: IUpdateApproval.GetUpdate; IUpdateEvent.GetUpdate; IUpdateInstallationInfo.GetUpdate; IUpdateServer.GetUpdate; UpdateCollection.Item.
IUpdateApproval | Use this interface to retrieve information about an approval and to remove the approval. To retrieve this interface, call the following methods: IUpdate.Approve; IUpdateServer.GetUpdateApproval; UpdateApprovalCollection.Item.
IUpdateCategory | Use this interface to retrieve information and updates related to a category. To retrieve this interface, call the following methods: UpdateCategoryCollection.Item; IUpdateServer.GetUpdateCategory.
IUpdateClassification | Use this interface to retrieve information and updates related to the classification. To retrieve this interface, call the following methods: GetUpdateClassifications(); IUpdateServer.GetUpdateClassification(); UpdateClassificationCollection.Item.
IUpdateEvent | Use this interface to retrieve information about events that are associated with updates. To retrieve this interface, call UpdateEventCollection.Item.
IUpdateInstallationInfo | Use this interface to retrieve the state of the update installation on the client computer. To retrieve this interface, call UpdateInstallationInfoCollection.Item.
IUpdateServer | Use this interface to access WSUS components. To retrieve this interface, call AdminProxy.GetUpdateServer.
IUpdateServerConfiguration | Use this interface to configure the WSUS server. For example, to specify the update languages to download, the proxy to use, and whether the updates are stored locally. To retrieve an IUpdateServerConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassTopic, call GetConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetConfigurationTopic.
IUpdateSummary | Use this interface to retrieve summary information regarding the number of clients in various states of installing updates. To retrieve this interface, call one of the following methods: IComputerTargetGroup.GetTotalSummary; UpdateSummaryCollection.Item.

Delegates

Delegate | Description
CleanupProgressEventHandler | Delegate definition for the CleanupProgressEventHandler.

Enumerations

Enumeration | Description
ApprovedStates | Indicates whether or not an Update is approved or declined. These flags can be used to retrieve Updates in the specified state.
AutomaticUpdateApprovalAction | Defines the possible AutomaticUpdateApproval actions which an AutomaticUpdateApproval rule can perform.
CleanupProcessProgressStep | Enumeration showing the current step of the Cleanup Process.
EmailNotificationType | Enumerates possible types of email notification
EmailStatusNotification | Enumerates possible types of status reports
FilePropertyRowIndex |
FileType |
InstallationImpact | Defines constants that indicate the possible impact an update may have on the computer or on other applications that are running on the computer.
InstallationResult | The result of an installation or uninstallation. All installations and uninstallations must result in one of these values.
InstallationStatus | Defines constants for the possible installation states of an update on the client computer.
LogDestinations | Defines constants that indicate where log messages are written.
LogLevel | Defines constants for specifying the logging level that you want WSUS to use.
MsrcSeverity | Defines constants for the severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with an update.
PackagePublicationState | Publication State for the Package (optional)
PackageType | Type of this package
PackageUpdateClassification | The classification of the update as specified by the SE cabinet.
PublicationState | Defines the publication states of the update.
PublishingProcessProgressStep | Enumeration showing the current step that the Publishing Process is working on.
RebootBehavior | Defines constants that indicate the computer restart behavior of an update.
RevisionChanges | Defines constants that are used to indicate the revisions that were made to an update.
SecurityRating | The maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin associated with the update.
SubscriptionEventCategory | Defines constants that are the possible categories for a subscription event.
SynchronizationError | Defines constants that indicate what caused the synchronization process to fail.
SynchronizationPhase | Defines constants that indicate the content that the downstream server is currently synchronizing with the upstream server.
SynchronizationResult | Defines constants that indicate the result of the synchronization process.
SynchronizationStatus | Defines constants that indicate if the synchronization process is currently running.
SynchronizationUpdateError | Defines constants that indicate the reason for the update failure.
TargetingMode | Defines constants for the possible targeting modes. The targeting mode determines if the server or client decides to which group the client belongs.
UpdateApprovalAction | Defines constants that indicate the action a client performs when applying the update.
UpdateApprovalActions |
UpdateApprovalState | Defines constants the indicate the current state of an approval.
UpdateCategoryType | Defines constants that describe the different update categories.
UpdateInstallationState | Defines constants that indicate the current state of the update on the client computer.
UpdateInstallationStates |
UpdateMetadataPropertyRowIndex |
UpdateRelationship | Defines constants the describe the relationship between updates.
UpdateServerConfigurationState | Defines constants that indicate if the WSUS database is ready to save changes.
UpdateServerUserRole | Describes a user's role on the WSUS server.
UpdateState | Defines constants that indicate the state of an update.
UpdateType | Defines constants that indicate if the update is a software or driver update.
UpdateTypes | Set of flags used to specify what kind of updates to retrieve
WindowsInstallerPackageType | Type of the MSI package
WsusEventId |
WsusEventSource | Defines constants that indicate the source of an event.


AdminProxy Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class provides a starting point for getting a IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic. You use IUpdateServer to communicate with the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim adminProxy1 As New AdminProxy()

Syntax

Visual Basic
NotInheritable Public Class AdminProxy
C#
public sealed class AdminProxy
C++
public ref class AdminProxy sealed
J#
public final class AdminProxy
JScript
public class AdminProxy

Remarks

Do not use the new keyword to create an instance of AdminProxyfrlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic if you use GetUpdateServer frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassGetUpdateServerTopic to retrieve an interface to the WSUS server—the GetUpdateServerfrlrfMicrosoftUpdateServicesAdministrationAdminProxyClassGetUpdateServerTopic method is static. However, if you use GetUpdateServerInstance frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassGetUpdateServerInstanceTopic, then you must use the new keyword to create an instance of AdminProxyfrlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic.

Note:
This class is not thread safe.

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.AdminProxy

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Members
Microsoft.UpdateServices.Administration Namespace
IUpdateServer


AdminProxy Members
See Also Constructors Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class provides a starting point for getting a IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic. You use IUpdateServer to communicate with the WSUS server.

The following tables list the members exposed by the AdminProxy type.

Public Constructors

Name | Description
AdminProxy | Initializes a new instance of the AdminProxy frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic class.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | GetUpdateServer | Overloaded. Instantiates an UpdateServer within the AdminAPI. The server is assumed to be on the local machine.
public method | GetUpdateServerInstance | Instantiates a local copy UpdateServer within the AdminAPI.
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

AdminProxy Class
Microsoft.UpdateServices.Administration Namespace
IUpdateServer


AdminProxy Constructor
See Also
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the AdminProxy frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim adminProxy1 As New AdminProxy()

Syntax

Visual Basic
Public Sub New()
C#
public AdminProxy();
C++
public:
AdminProxy();
J#
public AdminProxy();
JScript
public function AdminProxy();

Remarks

Only initialize a new instance of AdminProxyfrlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic if you use GetUpdateServerInstance frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassGetUpdateServerInstanceTopic to retrieve an interface to the WSUS server. GetUpdateServer frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassGetUpdateServerTopic is static and does not require you to initialize a new instance of AdminProxyfrlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Class
AdminProxy Members
Microsoft.UpdateServices.Administration Namespace


AdminProxy Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | GetUpdateServer | Overloaded. Instantiates an UpdateServer within the AdminAPI. The server is assumed to be on the local machine.
public method | GetUpdateServerInstance | Instantiates a local copy UpdateServer within the AdminAPI.
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

AdminProxy Class
Microsoft.UpdateServices.Administration Namespace
IUpdateServer


AdminProxy.GetUpdateServer Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Instantiates an UpdateServer within the AdminAPI. The server is assumed to be on the local machine.

After retrieving IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic, you should call PreferredCulture frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassPreferredCultureTopic to specify the language code that WSUS uses to return strings.

Overload List

Name | Description
AdminProxy.GetUpdateServer () | Instantiates an UpdateServer within the AdminAPI. The server is assumed to be on the local machine.
AdminProxy.GetUpdateServer (String, Boolean) | Instantiates an UpdateServer within the AdminAPI.
AdminProxy.GetUpdateServer (String, Boolean, Int32) | Instantiates an UpdateServer within the AdminAPI.

See Also

Reference

AdminProxy Class
AdminProxy Members


AdminProxy.GetUpdateServer Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Instantiates an UpdateServer within the AdminAPI. The server is assumed to be on the local machine.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateServer
returnValue = AdminProxy.GetUpdateServer()

Syntax

Visual Basic
Overloads Public Shared Function GetUpdateServer() As IUpdateServer
C#
public static IUpdateServer GetUpdateServer();
C++
public:
static IUpdateServer^ GetUpdateServer();
J#
public static IUpdateServer GetUpdateServer();
JScript
public static function GetUpdateServer() : IUpdateServer;

Return Value

An object that implements the IUpdateServer interface.

Exceptions

Exception type | Condition
WebException | The server could not be contacted.

Remarks

After retrieving IUpdateServerfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic, you should call PreferredCulture frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassPreferredCultureTopic to specify the language code that WSUS uses to return strings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Class
AdminProxy Members


AdminProxy.GetUpdateServer Method (String, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Instantiates an UpdateServer within the AdminAPI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim serverName As String
Dim useSecureConnection As Boolean
Dim returnValue As IUpdateServer
returnValue = AdminProxy.GetUpdateServer(serverName, useSecureConnection)

Syntax

Visual Basic
Overloads Public Shared Function GetUpdateServer( _
    ByVal serverName As String, _
    ByVal useSecureConnection As Boolean _
) As IUpdateServer
C#
public static IUpdateServer GetUpdateServer(
    string serverName,
    bool useSecureConnection
);
C++
public:
static IUpdateServer^ GetUpdateServer(
    String^ serverName,
    bool useSecureConnection
);
J#
public static IUpdateServer GetUpdateServer(
    System.String serverName,
    boolean useSecureConnection
);
JScript
public static function GetUpdateServer(
     serverName : String,
     useSecureConnection : Boolean
) : IUpdateServer;

Parameters

serverName

Name of the remote machine running WSUS server.

useSecureConnection

If set to true, uses https instead of http.

If set to false, uses http.

Return Value

An object that implements the IUpdateServer interface.

Exceptions

Exception type | Condition
ArgumentNullException | serverName is null.
ArgumentOutOfRangeException | serverName is too large.
ArgumentException | serverName does not follow the rules for a valid domain name string.
WebException | The server could not be contacted.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Class
AdminProxy Members


AdminProxy.GetUpdateServer Method (String, Boolean, Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Instantiates an UpdateServer within the AdminAPI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim serverName As String
Dim useSecureConnection As Boolean
Dim portNumber As Integer
Dim returnValue As IUpdateServer
returnValue = AdminProxy.GetUpdateServer(serverName, useSecureConnection, portNumber)

Syntax

Visual Basic
Overloads Public Shared Function GetUpdateServer( _
    ByVal serverName As String, _
    ByVal useSecureConnection As Boolean, _
    ByVal portNumber As Integer _
) As IUpdateServer
C#
public static IUpdateServer GetUpdateServer(
    string serverName,
    bool useSecureConnection,
    int portNumber
);
C++
public:
static IUpdateServer^ GetUpdateServer(
    String^ serverName,
    bool useSecureConnection,
    int portNumber
);
J#
public static IUpdateServer GetUpdateServer(
    System.String serverName,
    boolean useSecureConnection,
    int portNumber
);
JScript
public static function GetUpdateServer(
     serverName : String,
     useSecureConnection : Boolean,
     portNumber : int
) : IUpdateServer;

Parameters

serverName

Name of the remote machine running WSUS server

useSecureConnection

If set to true, uses https instead of http.

If set to false, uses http.

portNumber

The port number.

Return Value

An object that implements the IUpdateServer interface.

Exceptions

Exception type | Condition
ArgumentNullException | serverName is null.
ArgumentOutOfRangeException | serverName is too large.
ArgumentException | serverName does not follow the rules for a valid domain name string.
WebException | The server could not be contacted.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Class
AdminProxy Members


AdminProxy.GetUpdateServerInstance Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Instantiates a local copy UpdateServer within the AdminAPI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateServer
Dim adminProxy1 As AdminProxy
returnValue = adminProxy1.GetUpdateServerInstance()

Syntax

Visual Basic
Public Function GetUpdateServerInstance() As IUpdateServer
C#
public IUpdateServer GetUpdateServerInstance();
C++
public:
IUpdateServer^ GetUpdateServerInstance();
J#
public IUpdateServer GetUpdateServerInstance();
JScript
public function GetUpdateServerInstance() : IUpdateServer;

Return Value

An object that implements the IUpdateServer interface.

Exceptions

Exception type | Condition
WebException | The server could not be contacted.

Remarks

This method is the same as the static GetUpdateServer. This method exists so it can be called by script (which cannot access static members). To use this method, you must first create an AdminProxy frlrfMicrosoftUpdateServicesAdministrationAdminProxyClassTopic object.

After retrieving IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic, you should call PreferredCulture frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassPreferredCultureTopic to specify the language code that WSUS uses to return strings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AdminProxy Class
AdminProxy Members


ApprovedStates Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Indicates whether or not an Update is approved or declined. These flags can be used to retrieve Updates in the specified state.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates1 As ApprovedStates = ApprovedStates.Any

Syntax

Visual Basic
Public Enum ApprovedStates
C#
public enum ApprovedStates
C++
public enum class ApprovedStates
J#
public enum ApprovedStates
JScript
public enum ApprovedStates

Members

Member name | Description
Any | Includes all Updates, regardless of whether they are approved, declined, or not approved.
Declined | Includes Updates that have been declined.
HasStaleUpdateApprovals | Includes Updates that have an approval on a revision that is not the latest revision.
LatestRevisionApproved | Includes Updates whose latest revision is approved.
NotApproved | Includes Updates that have not been approved or declined.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


AutomaticUpdateApprovalAction Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the possible AutomaticUpdateApproval actions which an AutomaticUpdateApproval rule can perform.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim automaticUpdateApprovalAction1 As AutomaticUpdateApprovalAction = AutomaticUpdateApprovalAction.Install

Syntax

Visual Basic
Public Enum AutomaticUpdateApprovalAction
C#
public enum AutomaticUpdateApprovalAction
C++
public enum class AutomaticUpdateApprovalAction
J#
public enum AutomaticUpdateApprovalAction
JScript
public enum AutomaticUpdateApprovalAction

Members

Member name | Description
Install | Updates will be automatically approved for Install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


AutomaticUpdateApprovalRuleCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a collection of AutomaticUpdateApprovalRules.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim automaticUpdateApprovalRuleCollection1 As New AutomaticUpdateApprovalRuleCollection()

Syntax

Visual Basic
Public Class AutomaticUpdateApprovalRuleCollection
    Inherits WsusCollection
C#
public class AutomaticUpdateApprovalRuleCollection : WsusCollection
C++
public ref class AutomaticUpdateApprovalRuleCollection : WsusCollection
J#
public class AutomaticUpdateApprovalRuleCollection extends WsusCollection
JScript
public class AutomaticUpdateApprovalRuleCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a collection of AutomaticUpdateApprovalRules.

The following tables list the members exposed by the AutomaticUpdateApprovalRuleCollection type.

Public Constructors

Name | Description
AutomaticUpdateApprovalRuleCollection | Initializes a new instance of the AutomaticUpdateApprovalRuleCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Gets or sets the element at the specified index. In C#, this property is the indexer for the AutomaticUpdateApprovalRuleCollection class.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded. Adds an AutomaticUpdateApprovalRule to the end of the AutomaticUpdateApprovalRuleCollection.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded. Determines whether the specified AutomaticUpdateApprovalRule is in the AutomaticUpdateApprovalRuleCollection.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | Insert | Overloaded. Inserts an AutomaticUpdateApprovalRule into the AutomaticUpdateApprovalRuleCollection at the specified index.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded. Removes a specified AutomaticUpdateApprovalRule from the AutomaticUpdateApprovalRuleCollection.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class


AutomaticUpdateApprovalRuleCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the AutomaticUpdateApprovalRuleCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim automaticUpdateApprovalRuleCollection1 As New AutomaticUpdateApprovalRuleCollection()

Syntax

Visual Basic
Public Sub New()
C#
public AutomaticUpdateApprovalRuleCollection();
C++
public:
AutomaticUpdateApprovalRuleCollection();
J#
public AutomaticUpdateApprovalRuleCollection();
JScript
public function AutomaticUpdateApprovalRuleCollection();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded. Adds an AutomaticUpdateApprovalRule to the end of the AutomaticUpdateApprovalRuleCollection.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded. Determines whether the specified AutomaticUpdateApprovalRule is in the AutomaticUpdateApprovalRuleCollection.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | Insert | Overloaded. Inserts an AutomaticUpdateApprovalRule into the AutomaticUpdateApprovalRuleCollection at the specified index.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded. Removes a specified AutomaticUpdateApprovalRule from the AutomaticUpdateApprovalRuleCollection.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class


AutomaticUpdateApprovalRuleCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an AutomaticUpdateApprovalRule to the end of the AutomaticUpdateApprovalRuleCollection.

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.Add (IAutomaticUpdateApprovalRule) | Adds an AutomaticUpdateApprovalRule to the end of the AutomaticUpdateApprovalRuleCollection.
AutomaticUpdateApprovalRuleCollection.Add (Object) |

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Add Method (IAutomaticUpdateApprovalRule)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an AutomaticUpdateApprovalRule to the end of the AutomaticUpdateApprovalRuleCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IAutomaticUpdateApprovalRule
Dim returnValue As Integer
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
returnValue = automaticUpdateApprovalRuleCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IAutomaticUpdateApprovalRule _
) As Integer
C#
public int Add(
    IAutomaticUpdateApprovalRule value
);
C++
public:
int Add(
    IAutomaticUpdateApprovalRule^ value
);
J#
public int Add(
    IAutomaticUpdateApprovalRule value
);
JScript
public function Add(
     value : IAutomaticUpdateApprovalRule
) : int;

Parameters

value

The AutomaticUpdateApprovalRule to add to the end of the AutomaticUpdateApprovalRuleCollection

Return Value

The zero-based index at which the new element is indexed.

Exceptions

Exception type | Condition
ArgumentNullException | value is a null reference (Nothing in Visual Basic).
ArgumentException | value already exists in the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.AddRange (Array) |
AutomaticUpdateApprovalRuleCollection.AddRange (AutomaticUpdateApprovalRuleCollection) | Adds the elements of an AutomaticUpdateApprovalRuleCollection to the end of this collection.
AutomaticUpdateApprovalRuleCollection.AddRange (IAutomaticUpdateApprovalRule[]) | Adds the elements of an AutomaticUpdateApprovalRuleCollection to the end of this collection.
AutomaticUpdateApprovalRuleCollection.AddRange (WsusCollection) |

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.AddRange Method (AutomaticUpdateApprovalRuleCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the elements of an AutomaticUpdateApprovalRuleCollection to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As AutomaticUpdateApprovalRuleCollection
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
automaticUpdateApprovalRuleCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As AutomaticUpdateApprovalRuleCollection _
)
C#
public void AddRange(
    AutomaticUpdateApprovalRuleCollection value
);
C++
public:
void AddRange(
    AutomaticUpdateApprovalRuleCollection^ value
);
J#
public void AddRange(
    AutomaticUpdateApprovalRuleCollection value
);
JScript
public function AddRange(
     value : AutomaticUpdateApprovalRuleCollection
) : Void;

Parameters

value

The collection of IAutomaticUpdateApprovalRule to add.

Exceptions

Exception type | Condition
ArgumentNullException | value is a null reference (Nothing in Visual Basic).
ArgumentException | value already exists in the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.AddRange Method (IAutomaticUpdateApprovalRule[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the elements of an AutomaticUpdateApprovalRuleCollection to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IAutomaticUpdateApprovalRule
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
automaticUpdateApprovalRuleCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IAutomaticUpdateApprovalRule _
)
C#
public void AddRange(
    IAutomaticUpdateApprovalRule[] value
);
C++
public:
void AddRange(
    array<IAutomaticUpdateApprovalRule^>^ value
);
J#
public void AddRange(
    IAutomaticUpdateApprovalRule[] value
);
JScript
public function AddRange(
     value : IAutomaticUpdateApprovalRule[]
) : Void;

Parameters

value

The array of IAutomaticUpdateApprovalRule to add

Exceptions

Exception type | Condition
ArgumentNullException | Thrown if value is null, or if any of the elements in value are null.
ArgumentException | Thrown if any of the elements in value are already in the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the specified AutomaticUpdateApprovalRule is in the AutomaticUpdateApprovalRuleCollection.

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.Contains (IAutomaticUpdateApprovalRule) | Determines whether the specified AutomaticUpdateApprovalRule is in the AutomaticUpdateApprovalRuleCollection.
AutomaticUpdateApprovalRuleCollection.Contains (Object) |

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Contains Method (IAutomaticUpdateApprovalRule)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the specified AutomaticUpdateApprovalRule is in the AutomaticUpdateApprovalRuleCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IAutomaticUpdateApprovalRule
Dim returnValue As Boolean
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
returnValue = automaticUpdateApprovalRuleCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IAutomaticUpdateApprovalRule _
) As Boolean
C#
public bool Contains(
    IAutomaticUpdateApprovalRule value
);
C++
public:
bool Contains(
    IAutomaticUpdateApprovalRule^ value
);
J#
public boolean Contains(
    IAutomaticUpdateApprovalRule value
);
JScript
public function Contains(
     value : IAutomaticUpdateApprovalRule
) : Boolean;

Parameters

value

The AutomaticUpdateApprovalRule to locate in the AutomaticUpdateApprovalRuleCollection.

Return Value

true if value is found in the AutomaticUpdateApprovalRuleCollection; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.CopyTo (Array, Int32) |
AutomaticUpdateApprovalRuleCollection.CopyTo (IAutomaticUpdateApprovalRule[], Int32) | Copies the entire AutomaticUpdateApprovalRuleCollection values to a one- dimensional array of AutomaticUpdateApprovalRules, starting at the specified index of the target array.

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.CopyTo Method (IAutomaticUpdateApprovalRule[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the entire AutomaticUpdateApprovalRuleCollection values to a one- dimensional array of AutomaticUpdateApprovalRules, starting at the specified index of the target array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IAutomaticUpdateApprovalRule
Dim index As Integer
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
automaticUpdateApprovalRuleCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IAutomaticUpdateApprovalRule, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IAutomaticUpdateApprovalRule[] array,
    int index
);
C++
public:
void CopyTo(
    array<IAutomaticUpdateApprovalRule^>^ array,
    int index
);
J#
public void CopyTo(
    IAutomaticUpdateApprovalRule[] array,
    int index
);
JScript
public function CopyTo(
     array : IAutomaticUpdateApprovalRule[],
     index : int
) : Void;

Parameters

array

The one-dimensional array of AutomaticUpdateApprovalRule that is the destination of the elements copied from AutomaticUpdateApprovalRuleCollection. The array must have zero-based indexing.

index

The zero-based index in array at which copying begins.

Exceptions

Exception type | Condition
ArgumentNullException | array is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | index is less than zero
ArgumentException | index is equal to or greater than the length of array. -or- The number of elements in the source, AutomaticUpdateApprovalRuleCollection, is greater than the available space from index to the end of the destination array.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an AutomaticUpdateApprovalRule into the AutomaticUpdateApprovalRuleCollection at the specified index.

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.Insert (Int32, IAutomaticUpdateApprovalRule) | Inserts an AutomaticUpdateApprovalRule into the AutomaticUpdateApprovalRuleCollection at the specified index.
AutomaticUpdateApprovalRuleCollection.Insert (Int32, Object) |

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Insert Method (Int32, IAutomaticUpdateApprovalRule)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an AutomaticUpdateApprovalRule into the AutomaticUpdateApprovalRuleCollection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IAutomaticUpdateApprovalRule
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
automaticUpdateApprovalRuleCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IAutomaticUpdateApprovalRule _
)
C#
public void Insert(
    int index,
    IAutomaticUpdateApprovalRule value
);
C++
public:
void Insert(
    int index,
    IAutomaticUpdateApprovalRule^ value
);
J#
public void Insert(
    int index,
    IAutomaticUpdateApprovalRule value
);
JScript
public function Insert(
     index : int,
     value : IAutomaticUpdateApprovalRule
) : Void;

Parameters

index

The zero-based index at which value is inserted.

value

The AutomaticUpdateApprovalRule to insert.

Exceptions

Exception type | Condition
ArgumentNullException | value is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | index is less than zero -or- index is equal or greater than Count
ArgumentException | value already exists in the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a specified AutomaticUpdateApprovalRule from the AutomaticUpdateApprovalRuleCollection.

Overload List

Name | Description
AutomaticUpdateApprovalRuleCollection.Remove (IAutomaticUpdateApprovalRule) | Removes a specified AutomaticUpdateApprovalRule from the AutomaticUpdateApprovalRuleCollection.
AutomaticUpdateApprovalRuleCollection.Remove (Object) |

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection.Remove Method (IAutomaticUpdateApprovalRule)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a specified AutomaticUpdateApprovalRule from the AutomaticUpdateApprovalRuleCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IAutomaticUpdateApprovalRule
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection
automaticUpdateApprovalRuleCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IAutomaticUpdateApprovalRule _
)
C#
public void Remove(
    IAutomaticUpdateApprovalRule value
);
C++
public:
void Remove(
    IAutomaticUpdateApprovalRule^ value
);
J#
public void Remove(
    IAutomaticUpdateApprovalRule value
);
JScript
public function Remove(
     value : IAutomaticUpdateApprovalRule
) : Void;

Parameters

value

The AutomaticUpdateApprovalRule to remove from the AutomaticUpdateApprovalRuleCollection.

Exceptions

Exception type | Condition
ArgumentNullException | value does not exist in this collection.
ArgumentException | value is a null reference (Nothing in Visual Basic).

Remarks

The next AutomaticUpdateApprovalRule following the removed element moves up to occupy vacated spot.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


AutomaticUpdateApprovalRuleCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Gets or sets the element at the specified index. In C#, this property is the indexer for the AutomaticUpdateApprovalRuleCollection class.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class


AutomaticUpdateApprovalRuleCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the element at the specified index. In C#, this property is the indexer for the AutomaticUpdateApprovalRuleCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim automaticUpdateApprovalRuleCollection1 As AutomaticUpdateApprovalRuleCollection

Dim key As Integer
Dim returnValue As IAutomaticUpdateApprovalRule
returnValue = automaticUpdateApprovalRuleCollection1.Item(key)

Dim sampleValue As IAutomaticUpdateApprovalRule
automaticUpdateApprovalRuleCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IAutomaticUpdateApprovalRule
C#
public new IAutomaticUpdateApprovalRule this[
    int index
] {get; set;}
C++
public:
property IAutomaticUpdateApprovalRule^ default[int] {
    IAutomaticUpdateApprovalRule^ get(int index);
    void set(int index, IAutomaticUpdateApprovalRule^ value);
}
J#
new public IAutomaticUpdateApprovalRule get_Item(
    int index
);
public void set_Item(
    int index
IAutomaticUpdateApprovalRule);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

The zero-based index of the element to get or set.

Property Value

The AutomaticUpdateApprovalRule at the specified index.

Exceptions

Exception type | Condition
ArgumentNullException | Attempted to set the value to null.
ArgumentOutOfRangeException | index is less than zero -or- index is equal or greater than Count
ArgumentException | Attempted set to a value already in the collection at a different index.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

AutomaticUpdateApprovalRuleCollection Class
AutomaticUpdateApprovalRuleCollection Members


BiosInfo Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Contains the BIOS information for the client computer. To retrieve this class, call the IComputerTarget.BiosInfo property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim biosInfo1 As New BiosInfo()

Syntax

Visual Basic
Public Class BiosInfo
C#
public class BiosInfo
C++
public ref class BiosInfo
J#
public class BiosInfo
JScript
public class BiosInfo

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.BiosInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Members


BiosInfo Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Contains the BIOS information for the client computer. To retrieve this class, call the IComputerTarget.BiosInfo property.

The following tables list the members exposed by the BiosInfo type.

Public Constructors

Name | Description
BiosInfo | Overloaded.
Top

Public Properties

 | Name | Description
public property | Name | Gets or sets the name of the BIOS.
public property | ReleaseDate | Gets or sets the release date of the BIOS.
public property | Version | Gets or sets the version of the BIOS.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

BiosInfo Class


BiosInfo Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
BiosInfo () | Initializes a new instance of the BiosInfo class.
BiosInfo (String, String, DateTime) | Initializes a new instance of the BiosInfo class.

See Also

Reference

BiosInfo Class
BiosInfo Members


BiosInfo Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the BiosInfo class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim biosInfo1 As New BiosInfo()

Syntax

Visual Basic
Public Sub New()
C#
public BiosInfo();
C++
public:
BiosInfo();
J#
public BiosInfo();
JScript
public function BiosInfo();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Class
BiosInfo Members


BiosInfo Constructor (String, String, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the BiosInfo class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim version As String
Dim releaseDate As DateTime
Dim biosInfo1 As New BiosInfo(name, version, releaseDate)

Syntax

Visual Basic
Public Sub New( _
    ByVal name As String, _
    ByVal version As String, _
    ByVal releaseDate As DateTime _
)
C#
public BiosInfo(
    string name,
    string version,
    DateTime releaseDate
);
C++
public:
BiosInfo(
    String^ name,
    String^ version,
    DateTime^ releaseDate
);
J#
public BiosInfo(
    System.String name,
    System.String version,
    DateTime releaseDate
);
JScript
public function BiosInfo(
     name : String,
     version : String,
     releaseDate : DateTime
);

Parameters

name

Name of the BIOS.

version

Version of the BIOS.

releaseDate

Release date of the BIOS.

Exceptions

Exception type | Condition
ArgumentNullException | name is a null reference. -or- version is a null reference.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Class
BiosInfo Members


BiosInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

BiosInfo Class


BiosInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Name | Gets or sets the name of the BIOS.
public property | ReleaseDate | Gets or sets the release date of the BIOS.
public property | Version | Gets or sets the version of the BIOS.

See Also

Reference

BiosInfo Class


BiosInfo.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the name of the BIOS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim biosInfo1 As BiosInfo

Dim returnValue As String
returnValue = biosInfo1.Name

Dim sampleValue As String
biosInfo1.Name = sampleValue

Syntax

Visual Basic
Public Property Name() As String
C#
public string Name {get; set;}
C++
public:
property String^ Name {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Name();
public void set_Name(System.String);
JScript
public function get Name() : String;
public function set Name(String);

Property Value

The name of the BIOS.

Exceptions

Exception type | Condition
ArgumentNullException | Attempted to set this property to a null reference.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Class
BiosInfo Members


BiosInfo.ReleaseDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the release date of the BIOS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim biosInfo1 As BiosInfo

Dim returnValue As DateTime
returnValue = biosInfo1.ReleaseDate

Dim sampleValue As DateTime
biosInfo1.ReleaseDate = sampleValue

Syntax

Visual Basic
Public Property ReleaseDate() As DateTime
C#
public DateTime ReleaseDate {get; set;}
C++
public:
property DateTime^ ReleaseDate {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_ReleaseDate();
public void set_ReleaseDate(DateTime);
JScript
public function get ReleaseDate() : DateTime;
public function set ReleaseDate(DateTime);

Property Value

The release date of the BIOS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Class
BiosInfo Members


BiosInfo.Version Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the version of the BIOS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim biosInfo1 As BiosInfo

Dim returnValue As String
returnValue = biosInfo1.Version

Dim sampleValue As String
biosInfo1.Version = sampleValue

Syntax

Visual Basic
Public Property Version() As String
C#
public string Version {get; set;}
C++
public:
property String^ Version {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Version();
public void set_Version(System.String);
JScript
public function get Version() : String;
public function set Version(String);

Property Value

The version of the BIOS.

Exceptions

Exception type | Condition
ArgumentNullException | Attempted to set this property to a null reference.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

BiosInfo Class
BiosInfo Members


CleanupEventArgs Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Event Class containing information specific to the progress event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As New CleanupEventArgs()

Syntax

Visual Basic
Public Class CleanupEventArgs
    Inherits EventArgs
C#
public class CleanupEventArgs : EventArgs
C++
public ref class CleanupEventArgs : EventArgs
J#
public class CleanupEventArgs extends EventArgs
JScript
public class CleanupEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.UpdateServices.Administration.CleanupEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Members


CleanupEventArgs Members
See Also Constructors Fields Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Event Class containing information specific to the progress event.

The following tables list the members exposed by the CleanupEventArgs type.

Public Constructors

Name | Description
CleanupEventArgs | Overloaded. Initializes a new instance of the CleanupEventArgs class.
Top

Public Fields

Name | Description
Empty | (Inherited from EventArgs )
Top

Public Properties

 | Name | Description
public property | CurrentProgress | Get/Set the Current Progress value for this operation.
public property | ProgressInfo | Get/Set any additional information about the progress event.
public property | ProgressStep | Get/Set the CleanupProcessProgressStep for this event.
public property | UpperProgressBound | Get/Set the Upper Progress value for this operation.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

CleanupEventArgs Class


CleanupEventArgs Fields
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Fields

Name | Description
Empty | (Inherited from EventArgs )

See Also

Reference

CleanupEventArgs Class


CleanupEventArgs Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the CleanupEventArgs class.

Overload List

Name | Description
CleanupEventArgs () | Initializes a new instance of the CleanupEventArgs class.
CleanupEventArgs (CleanupProcessProgressStep, String, Int64, Int64) | Constructor to initialize CleanupEventArgs class.

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the CleanupEventArgs class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As New CleanupEventArgs()

Syntax

Visual Basic
Public Sub New()
C#
public CleanupEventArgs();
C++
public:
CleanupEventArgs();
J#
public CleanupEventArgs();
JScript
public function CleanupEventArgs();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs Constructor (CleanupProcessProgressStep, String, Int64, Int64)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor to initialize CleanupEventArgs class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim step As CleanupProcessProgressStep
Dim info As String
Dim current As Long
Dim upperBound As Long
Dim cleanupEventArgs1 As New CleanupEventArgs(step, info, current, upperBound)

Syntax

Visual Basic
Public Sub New( _
    ByVal step As CleanupProcessProgressStep, _
    ByVal info As String, _
    ByVal current As Long, _
    ByVal upperBound As Long _
)
C#
public CleanupEventArgs(
    CleanupProcessProgressStep step,
    string info,
    long current,
    long upperBound
);
C++
public:
CleanupEventArgs(
    CleanupProcessProgressStep step,
    String^ info,
    long long current,
    long long upperBound
);
J#
public CleanupEventArgs(
    CleanupProcessProgressStep step,
    System.String info,
    long current,
    long upperBound
);
JScript
public function CleanupEventArgs(
     step : CleanupProcessProgressStep,
     info : String,
     current : long,
     upperBound : long
);

Parameters

step

The CleanupProcessProgressStep for this progress event

info

Additional information related to the progress step for this event

current

Current progress value

upperBound

Upper Progress value, when the 'current' progress reaches this value the step is complete

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

CleanupEventArgs Class


CleanupEventArgs Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | CurrentProgress | Get/Set the Current Progress value for this operation.
public property | ProgressInfo | Get/Set any additional information about the progress event.
public property | ProgressStep | Get/Set the CleanupProcessProgressStep for this event.
public property | UpperProgressBound | Get/Set the Upper Progress value for this operation.

See Also

Reference

CleanupEventArgs Class


CleanupEventArgs.CurrentProgress Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the Current Progress value for this operation.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As CleanupEventArgs

Dim returnValue As Long
returnValue = cleanupEventArgs1.CurrentProgress

Dim sampleValue As Long
cleanupEventArgs1.CurrentProgress = sampleValue

Syntax

Visual Basic
Public Property CurrentProgress() As Long
C#
public long CurrentProgress {get; set;}
C++
public:
property long long CurrentProgress {
    long long get();
    void set(long long value);
}
J#
public long get_CurrentProgress();
public void set_CurrentProgress(long);
JScript
public function get CurrentProgress() : long;
public function set CurrentProgress(long);

Property Value

The Current Progress value for this operation.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs.ProgressInfo Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set any additional information about the progress event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As CleanupEventArgs

Dim returnValue As String
returnValue = cleanupEventArgs1.ProgressInfo

Dim sampleValue As String
cleanupEventArgs1.ProgressInfo = sampleValue

Syntax

Visual Basic
Public Property ProgressInfo() As String
C#
public string ProgressInfo {get; set;}
C++
public:
property String^ ProgressInfo {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ProgressInfo();
public void set_ProgressInfo(System.String);
JScript
public function get ProgressInfo() : String;
public function set ProgressInfo(String);

Property Value

Any additional information about the progress event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs.ProgressStep Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the CleanupProcessProgressStep for this event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As CleanupEventArgs

Dim returnValue As CleanupProcessProgressStep
returnValue = cleanupEventArgs1.ProgressStep

Dim sampleValue As CleanupProcessProgressStep
cleanupEventArgs1.ProgressStep = sampleValue

Syntax

Visual Basic
Public Property ProgressStep() As CleanupProcessProgressStep
C#
public CleanupProcessProgressStep ProgressStep {get; set;}
C++
public:
property CleanupProcessProgressStep ProgressStep {
    CleanupProcessProgressStep get();
    void set(CleanupProcessProgressStep value);
}
J#
public CleanupProcessProgressStep get_ProgressStep();
public void set_ProgressStep(CleanupProcessProgressStep);
JScript
public function get ProgressStep() : CleanupProcessProgressStep;
public function set ProgressStep(CleanupProcessProgressStep);

Property Value

The CleanupProcessProgressStep for this event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupEventArgs.UpperProgressBound Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the Upper Progress value for this operation.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupEventArgs1 As CleanupEventArgs

Dim returnValue As Long
returnValue = cleanupEventArgs1.UpperProgressBound

Dim sampleValue As Long
cleanupEventArgs1.UpperProgressBound = sampleValue

Syntax

Visual Basic
Public Property UpperProgressBound() As Long
C#
public long UpperProgressBound {get; set;}
C++
public:
property long long UpperProgressBound {
    long long get();
    void set(long long value);
}
J#
public long get_UpperProgressBound();
public void set_UpperProgressBound(long);
JScript
public function get UpperProgressBound() : long;
public function set UpperProgressBound(long);

Property Value

The Upper Progress value for this operation.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupEventArgs Class
CleanupEventArgs Members


CleanupProcessProgressStep Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Enumeration showing the current step of the Cleanup Process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupProcessProgressStep1 As CleanupProcessProgressStep = CleanupProcessProgressStep.CleanupObsoleteComputers

Syntax

Visual Basic
Public Enum CleanupProcessProgressStep
C#
public enum CleanupProcessProgressStep
C++
public enum class CleanupProcessProgressStep
J#
public enum CleanupProcessProgressStep
JScript
public enum CleanupProcessProgressStep

Members

Member name | Description
CleanupObsoleteComputers | Clean up information and related reports of computers who haven't contacted the server for over a month.
CleanupObsoleteUpdates | Clean up unneeded update's metadata. An unneeded update is defined as:
CleanupUnneededContentFiles | Removes content files applying the following steps:
CompressUpdates | Remove any revision of updates if they meet this criteria:
DeclineExpiredUpdates | Decline expired unapproved updates.
DeclineSupersededUpdates | Decline updates which are superseded by an approved update, not deployed and unneeded by clients for a minimum of 3months (This value is configurable.).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


CleanupProgressEventHandler Delegate
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Delegate definition for the CleanupProgressEventHandler.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Sub Sub1(sender As Object, _
    e As CleanupEventArgs)
End Sub
Dim cleanupProgressEventHandler1 As New CleanupProgressEventHandler(AddressOf Sub1)

Syntax

Visual Basic
Public Delegate Sub CleanupProgressEventHandler( _
    ByVal sender As Object, _
    ByVal e As CleanupEventArgs _
)
C#
public delegate void CleanupProgressEventHandler(
    object sender,
    CleanupEventArgs e
);
C++
public delegate void CleanupProgressEventHandler(
    Object^ sender,
    CleanupEventArgs^ e
);
J#
public delegate void CleanupProgressEventHandler(
    System.Object sender,
    CleanupEventArgs e
);
JScript
In JScript, you can use the delegates in the .NET Framework, but you cannot define your own.

Parameters

sender

The CleanupManager that sent the progress notification.

e

An instance of CleanupEventArgs containing progress information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


CleanupResults Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Unique identifier of a CleanupResults, that ICleanupManager.PerformCleanup method will return an object of, consisting of cleanup results of various cleanup options.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As New CleanupResults()

Syntax

Visual Basic
Public Class CleanupResults
C#
public class CleanupResults
C++
public ref class CleanupResults
J#
public class CleanupResults
JScript
public class CleanupResults

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.CleanupResults

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Members


CleanupResults Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Unique identifier of a CleanupResults, that ICleanupManager.PerformCleanup method will return an object of, consisting of cleanup results of various cleanup options.

The following tables list the members exposed by the CleanupResults type.

Public Constructors

Name | Description
CleanupResults | Overloaded. Overloaded. Initialize a new instance of the CleanupResults class.
Top

Public Properties

 | Name | Description
public property | DiskSpaceFreed | Gets or sets the amount of space freed, in bytes, after unneeded content files were deleted.
public property | ExpiredUpdatesDeclined | Gets or sets the number of updates that were declined because they were expired.
public property | ObsoleteComputersDeleted | Gets or sets the number of computers that were deleted because they were considered obsolete.
public property | ObsoleteUpdatesDeleted | Gets or sets the number of updates that were deleted because they were considered obsolete.
public property | SupersededUpdatesDeclined | Gets or sets the number of updates that were declined because they were superseded.
public property | UpdatesCompressed | Gets or sets the number of updates whose old revisions have been removed.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

CleanupResults Class


CleanupResults Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overloaded. Initialize a new instance of the CleanupResults class.

Overload List

Name | Description
CleanupResults () | Default constructor.
CleanupResults (Int32, Int32, Int32, Int32, Int32, Int64) | Overloaded constructor.

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As New CleanupResults()

Syntax

Visual Basic
Public Sub New()
C#
public CleanupResults();
C++
public:
CleanupResults();
J#
public CleanupResults();
JScript
public function CleanupResults();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults Constructor (Int32, Int32, Int32, Int32, Int32, Int64)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overloaded constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim supersededUpdatesDeclined As Integer
Dim expiredUpdatesDeclined As Integer
Dim obsoleteUpdatesDeleted As Integer
Dim obsoleteComputersDeleted As Integer
Dim updatesCompressed As Integer
Dim diskSpaceFreed As Long
Dim cleanupResults1 As New CleanupResults(supersededUpdatesDeclined, expiredUpdatesDeclined, obsoleteUpdatesDeleted, obsoleteComputersDeleted, updatesCompressed, diskSpaceFreed)

Syntax

Visual Basic
Public Sub New( _
    ByVal supersededUpdatesDeclined As Integer, _
    ByVal expiredUpdatesDeclined As Integer, _
    ByVal obsoleteUpdatesDeleted As Integer, _
    ByVal obsoleteComputersDeleted As Integer, _
    ByVal updatesCompressed As Integer, _
    ByVal diskSpaceFreed As Long _
)
C#
public CleanupResults(
    int supersededUpdatesDeclined,
    int expiredUpdatesDeclined,
    int obsoleteUpdatesDeleted,
    int obsoleteComputersDeleted,
    int updatesCompressed,
    long diskSpaceFreed
);
C++
public:
CleanupResults(
    int supersededUpdatesDeclined,
    int expiredUpdatesDeclined,
    int obsoleteUpdatesDeleted,
    int obsoleteComputersDeleted,
    int updatesCompressed,
    long long diskSpaceFreed
);
J#
public CleanupResults(
    int supersededUpdatesDeclined,
    int expiredUpdatesDeclined,
    int obsoleteUpdatesDeleted,
    int obsoleteComputersDeleted,
    int updatesCompressed,
    long diskSpaceFreed
);
JScript
public function CleanupResults(
     supersededUpdatesDeclined : int,
     expiredUpdatesDeclined : int,
     obsoleteUpdatesDeleted : int,
     obsoleteComputersDeleted : int,
     updatesCompressed : int,
     diskSpaceFreed : long
);

Parameters

supersededUpdatesDeclined

Number of updates that were declined because they were superseded.

expiredUpdatesDeclined

Number of updates that were declined because they were expired.

obsoleteUpdatesDeleted

Number of updates that were deleted because they were considered obsolete.

obsoleteComputersDeleted

Number of computers that were deleted because they were considered obsolete.

updatesCompressed

Number of updates whose old revisions have been removed.

diskSpaceFreed

Amount of disk space freed, in bytes, as a result of deleting unneeded content files.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

CleanupResults Class


CleanupResults Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | DiskSpaceFreed | Gets or sets the amount of space freed, in bytes, after unneeded content files were deleted.
public property | ExpiredUpdatesDeclined | Gets or sets the number of updates that were declined because they were expired.
public property | ObsoleteComputersDeleted | Gets or sets the number of computers that were deleted because they were considered obsolete.
public property | ObsoleteUpdatesDeleted | Gets or sets the number of updates that were deleted because they were considered obsolete.
public property | SupersededUpdatesDeclined | Gets or sets the number of updates that were declined because they were superseded.
public property | UpdatesCompressed | Gets or sets the number of updates whose old revisions have been removed.

See Also

Reference

CleanupResults Class


CleanupResults.DiskSpaceFreed Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the amount of space freed, in bytes, after unneeded content files were deleted.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Long
returnValue = cleanupResults1.DiskSpaceFreed

Dim sampleValue As Long
cleanupResults1.DiskSpaceFreed = sampleValue

Syntax

Visual Basic
Public Property DiskSpaceFreed() As Long
C#
public long DiskSpaceFreed {get; set;}
C++
public:
property long long DiskSpaceFreed {
    long long get();
    void set(long long value);
}
J#
public long get_DiskSpaceFreed();
public void set_DiskSpaceFreed(long);
JScript
public function get DiskSpaceFreed() : long;
public function set DiskSpaceFreed(long);

Property Value

Amount of disk space freed, in bytes, as a result of deleting unneeded content files.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults.ExpiredUpdatesDeclined Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the number of updates that were declined because they were expired.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Integer
returnValue = cleanupResults1.ExpiredUpdatesDeclined

Dim sampleValue As Integer
cleanupResults1.ExpiredUpdatesDeclined = sampleValue

Syntax

Visual Basic
Public Property ExpiredUpdatesDeclined() As Integer
C#
public int ExpiredUpdatesDeclined {get; set;}
C++
public:
property int ExpiredUpdatesDeclined {
    int get();
    void set(int value);
}
J#
public int get_ExpiredUpdatesDeclined();
public void set_ExpiredUpdatesDeclined(int);
JScript
public function get ExpiredUpdatesDeclined() : int;
public function set ExpiredUpdatesDeclined(int);

Property Value

Number of updates that were declined because they were expired.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults.ObsoleteComputersDeleted Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the number of computers that were deleted because they were considered obsolete.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Integer
returnValue = cleanupResults1.ObsoleteComputersDeleted

Dim sampleValue As Integer
cleanupResults1.ObsoleteComputersDeleted = sampleValue

Syntax

Visual Basic
Public Property ObsoleteComputersDeleted() As Integer
C#
public int ObsoleteComputersDeleted {get; set;}
C++
public:
property int ObsoleteComputersDeleted {
    int get();
    void set(int value);
}
J#
public int get_ObsoleteComputersDeleted();
public void set_ObsoleteComputersDeleted(int);
JScript
public function get ObsoleteComputersDeleted() : int;
public function set ObsoleteComputersDeleted(int);

Property Value

Number of computers that were deleted because they were considered obsolete.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults.ObsoleteUpdatesDeleted Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the number of updates that were deleted because they were considered obsolete.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Integer
returnValue = cleanupResults1.ObsoleteUpdatesDeleted

Dim sampleValue As Integer
cleanupResults1.ObsoleteUpdatesDeleted = sampleValue

Syntax

Visual Basic
Public Property ObsoleteUpdatesDeleted() As Integer
C#
public int ObsoleteUpdatesDeleted {get; set;}
C++
public:
property int ObsoleteUpdatesDeleted {
    int get();
    void set(int value);
}
J#
public int get_ObsoleteUpdatesDeleted();
public void set_ObsoleteUpdatesDeleted(int);
JScript
public function get ObsoleteUpdatesDeleted() : int;
public function set ObsoleteUpdatesDeleted(int);

Property Value

Number of updates that were deleted because they were considered obsolete.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults.SupersededUpdatesDeclined Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the number of updates that were declined because they were superseded.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Integer
returnValue = cleanupResults1.SupersededUpdatesDeclined

Dim sampleValue As Integer
cleanupResults1.SupersededUpdatesDeclined = sampleValue

Syntax

Visual Basic
Public Property SupersededUpdatesDeclined() As Integer
C#
public int SupersededUpdatesDeclined {get; set;}
C++
public:
property int SupersededUpdatesDeclined {
    int get();
    void set(int value);
}
J#
public int get_SupersededUpdatesDeclined();
public void set_SupersededUpdatesDeclined(int);
JScript
public function get SupersededUpdatesDeclined() : int;
public function set SupersededUpdatesDeclined(int);

Property Value

Number of updates that were declined because they were superseded.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupResults.UpdatesCompressed Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the number of updates whose old revisions have been removed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupResults1 As CleanupResults

Dim returnValue As Integer
returnValue = cleanupResults1.UpdatesCompressed

Dim sampleValue As Integer
cleanupResults1.UpdatesCompressed = sampleValue

Syntax

Visual Basic
Public Property UpdatesCompressed() As Integer
C#
public int UpdatesCompressed {get; set;}
C++
public:
property int UpdatesCompressed {
    int get();
    void set(int value);
}
J#
public int get_UpdatesCompressed();
public void set_UpdatesCompressed(int);
JScript
public function get UpdatesCompressed() : int;
public function set UpdatesCompressed(int);

Property Value

Number of updates whose old revisions have been removed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupResults Class
CleanupResults Members


CleanupScope Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Unique identifier of a CleanupScope, consisting of user selections of various cleanup options.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As New CleanupScope()

Syntax

Visual Basic
Public Class CleanupScope
C#
public class CleanupScope
C++
public ref class CleanupScope
J#
public class CleanupScope
JScript
public class CleanupScope

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.CleanupScope

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Members


CleanupScope Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Unique identifier of a CleanupScope, consisting of user selections of various cleanup options.

The following tables list the members exposed by the CleanupScope type.

Public Constructors

Name | Description
CleanupScope | Overloaded. Constructor definitions.
Top

Public Properties

 | Name | Description
public property | CleanupObsoleteComputers | Retrieves or sets whether or not obsolete computers should be deleted from the database.
public property | CleanupObsoleteUpdates | Retrieves or sets whether or not obsolete updates should be deleted from the database.
public property | CleanupUnneededContentFiles | Retrieves or sets whether or not unneeded update files should be deleted.
public property | CompressUpdates | Retrieves or sets whether or not obsolete revisions to updates should be deleted from the database.
public property | DeclineExpiredUpdates | Retrieves or sets whether or not expired updates should be declined.
public property | DeclineSupersededUpdates | Retrieves or sets whether or not superseded updates should be declined.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

CleanupScope Class


CleanupScope Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor definitions.

Overload List

Name | Description
CleanupScope () | Default constructor.
CleanupScope (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Overloaded constructor.

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As New CleanupScope()

Syntax

Visual Basic
Public Sub New()
C#
public CleanupScope();
C++
public:
CleanupScope();
J#
public CleanupScope();
JScript
public function CleanupScope();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope Constructor (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overloaded constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim supersededUpdates As Boolean
Dim expiredUpdates As Boolean
Dim obsoleteUpdates As Boolean
Dim compressUpdates As Boolean
Dim obsoleteComputers As Boolean
Dim unneededContentFiles As Boolean
Dim cleanupScope1 As New CleanupScope(supersededUpdates, expiredUpdates, obsoleteUpdates, compressUpdates, obsoleteComputers, unneededContentFiles)

Syntax

Visual Basic
Public Sub New( _
    ByVal supersededUpdates As Boolean, _
    ByVal expiredUpdates As Boolean, _
    ByVal obsoleteUpdates As Boolean, _
    ByVal compressUpdates As Boolean, _
    ByVal obsoleteComputers As Boolean, _
    ByVal unneededContentFiles As Boolean _
)
C#
public CleanupScope(
    bool supersededUpdates,
    bool expiredUpdates,
    bool obsoleteUpdates,
    bool compressUpdates,
    bool obsoleteComputers,
    bool unneededContentFiles
);
C++
public:
CleanupScope(
    bool supersededUpdates,
    bool expiredUpdates,
    bool obsoleteUpdates,
    bool compressUpdates,
    bool obsoleteComputers,
    bool unneededContentFiles
);
J#
public CleanupScope(
    boolean supersededUpdates,
    boolean expiredUpdates,
    boolean obsoleteUpdates,
    boolean compressUpdates,
    boolean obsoleteComputers,
    boolean unneededContentFiles
);
JScript
public function CleanupScope(
     supersededUpdates : Boolean,
     expiredUpdates : Boolean,
     obsoleteUpdates : Boolean,
     compressUpdates : Boolean,
     obsoleteComputers : Boolean,
     unneededContentFiles : Boolean
);

Parameters

supersededUpdates

Number of updates each of which is:

  • superseded by an approved update

  • not deployed

  • and no clients need it for 3 months (configurable)

expiredUpdates

Number of expired unapproved updates.

obsoleteUpdates

Number of updates each of which is:

  • expired, explicitly-deployable software/driver, or

  • expired category/detectoid

And

  • not deployed > 3 months and

  • ReceivedFromCreateService > 3 months (This value is configurable.)

And,

  • not referenced as a bundle or prerequisite of another update

compressUpdates

Number of old revisions of updates that meet the following criteria:

  • never been deployed

  • have been undeployed for at least 3 months and ReceivedFromCreateServer > 3 months (configurable)

  • and not referenced as a bundle or prerequisite of other updates.

obsoleteComputers

Number of computers who haven't contacted the server for over a month.

unneededContentFiles

Number of unneeded content or binaries with the following criteria:

  • Any orphan content

  • Any file marked as NotNeeded and not requested by Down Stream Server (DSS)

  • Any file referenced by an expired update, not referenced by any other active update and not requested by DSS

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

CleanupScope Class


CleanupScope Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | CleanupObsoleteComputers | Retrieves or sets whether or not obsolete computers should be deleted from the database.
public property | CleanupObsoleteUpdates | Retrieves or sets whether or not obsolete updates should be deleted from the database.
public property | CleanupUnneededContentFiles | Retrieves or sets whether or not unneeded update files should be deleted.
public property | CompressUpdates | Retrieves or sets whether or not obsolete revisions to updates should be deleted from the database.
public property | DeclineExpiredUpdates | Retrieves or sets whether or not expired updates should be declined.
public property | DeclineSupersededUpdates | Retrieves or sets whether or not superseded updates should be declined.

See Also

Reference

CleanupScope Class


CleanupScope.CleanupObsoleteComputers Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not obsolete computers should be deleted from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.CleanupObsoleteComputers

Dim sampleValue As Boolean
cleanupScope1.CleanupObsoleteComputers = sampleValue

Syntax

Visual Basic
Public Property CleanupObsoleteComputers() As Boolean
C#
public bool CleanupObsoleteComputers {get; set;}
C++
public:
property bool CleanupObsoleteComputers {
    bool get();
    void set(bool value);
}
J#
public boolean get_CleanupObsoleteComputers();
public void set_CleanupObsoleteComputers(boolean);
JScript
public function get CleanupObsoleteComputers() : Boolean;
public function set CleanupObsoleteComputers(Boolean);

Property Value

If set to true, obsolete computers will be deleted from the database. If set to false, obsolete computers will not be deleted from the database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope.CleanupObsoleteUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not obsolete updates should be deleted from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.CleanupObsoleteUpdates

Dim sampleValue As Boolean
cleanupScope1.CleanupObsoleteUpdates = sampleValue

Syntax

Visual Basic
Public Property CleanupObsoleteUpdates() As Boolean
C#
public bool CleanupObsoleteUpdates {get; set;}
C++
public:
property bool CleanupObsoleteUpdates {
    bool get();
    void set(bool value);
}
J#
public boolean get_CleanupObsoleteUpdates();
public void set_CleanupObsoleteUpdates(boolean);
JScript
public function get CleanupObsoleteUpdates() : Boolean;
public function set CleanupObsoleteUpdates(Boolean);

Property Value

If set to true, obsolete updates will be deleted from the database. If set to false, obsolete updates will not be deleted from the database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope.CleanupUnneededContentFiles Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not unneeded update files should be deleted.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.CleanupUnneededContentFiles

Dim sampleValue As Boolean
cleanupScope1.CleanupUnneededContentFiles = sampleValue

Syntax

Visual Basic
Public Property CleanupUnneededContentFiles() As Boolean
C#
public bool CleanupUnneededContentFiles {get; set;}
C++
public:
property bool CleanupUnneededContentFiles {
    bool get();
    void set(bool value);
}
J#
public boolean get_CleanupUnneededContentFiles();
public void set_CleanupUnneededContentFiles(boolean);
JScript
public function get CleanupUnneededContentFiles() : Boolean;
public function set CleanupUnneededContentFiles(Boolean);

Property Value

If set to true, unneeded update files will be deleted from the database. If set to false, unneeded update files will not be deleted from the database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope.CompressUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not obsolete revisions to updates should be deleted from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.CompressUpdates

Dim sampleValue As Boolean
cleanupScope1.CompressUpdates = sampleValue

Syntax

Visual Basic
Public Property CompressUpdates() As Boolean
C#
public bool CompressUpdates {get; set;}
C++
public:
property bool CompressUpdates {
    bool get();
    void set(bool value);
}
J#
public boolean get_CompressUpdates();
public void set_CompressUpdates(boolean);
JScript
public function get CompressUpdates() : Boolean;
public function set CompressUpdates(Boolean);

Property Value

If set to true, obsolete revisions to updates will be deleted from the database. If set to false, obsolete revisions to updates will not be deleted from the database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope.DeclineExpiredUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not expired updates should be declined.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.DeclineExpiredUpdates

Dim sampleValue As Boolean
cleanupScope1.DeclineExpiredUpdates = sampleValue

Syntax

Visual Basic
Public Property DeclineExpiredUpdates() As Boolean
C#
public bool DeclineExpiredUpdates {get; set;}
C++
public:
property bool DeclineExpiredUpdates {
    bool get();
    void set(bool value);
}
J#
public boolean get_DeclineExpiredUpdates();
public void set_DeclineExpiredUpdates(boolean);
JScript
public function get DeclineExpiredUpdates() : Boolean;
public function set DeclineExpiredUpdates(Boolean);

Property Value

If set to true, expired updates will be declined. If set to false, expired updates will not be declined.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CleanupScope.DeclineSupersededUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not superseded updates should be declined.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope1 As CleanupScope

Dim returnValue As Boolean
returnValue = cleanupScope1.DeclineSupersededUpdates

Dim sampleValue As Boolean
cleanupScope1.DeclineSupersededUpdates = sampleValue

Syntax

Visual Basic
Public Property DeclineSupersededUpdates() As Boolean
C#
public bool DeclineSupersededUpdates {get; set;}
C++
public:
property bool DeclineSupersededUpdates {
    bool get();
    void set(bool value);
}
J#
public boolean get_DeclineSupersededUpdates();
public void set_DeclineSupersededUpdates(boolean);
JScript
public function get DeclineSupersededUpdates() : Boolean;
public function set DeclineSupersededUpdates(Boolean);

Property Value

If set to true, superseded updates will be declined. If set to false, superseded updates will not be declined.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CleanupScope Class
CleanupScope Members


CommandLineItem Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As New CommandLineItem()

Syntax

Visual Basic
Public Class CommandLineItem
    Inherits InstallableItem
C#
public class CommandLineItem : InstallableItem
C++
public ref class CommandLineItem : InstallableItem
J#
public class CommandLineItem extends InstallableItem
JScript
public class CommandLineItem extends InstallableItem

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallableItem
Microsoft.UpdateServices.Administration.CommandLineItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Members


CommandLineItem Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the CommandLineItem type.

Public Constructors

Name | Description
CommandLineItem | Overloaded.
Top

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.(Inherited from InstallableItem)
public property | Arguments | Get/Set Install arguments.
public property | CommandLineExecutableName | Get/Set Program name.
public property | DefaultResult | Get/Set default installation result.
public property | Id | Retrieves the ID uniquely identifying the InstallableItem(Inherited from InstallableItem)
public property | InstallBehavior | Get/Set InstallBehavior property(Inherited from InstallableItem)
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.(Inherited from InstallableItem)
public property | Languages | Retrieves the list of languages that this binary has been localized to.(Inherited from InstallableItem)
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem)
public property | RebootByDefault | Get/Set default reboot value. Default: false.
public property | RepairPaths | Returns the MSI repair paths to use if this executable wraps an MSI.
public property | ReturnCodes | Get ReturnCodes list.
public property | UninstallBehavior | Get/Set UninstallBehavior(Inherited from InstallableItem)
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

CommandLineItem Class


CommandLineItem Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
CommandLineItem () | Default constructor.
CommandLineItem (String) | Create a CommandLineItem from input executable file name.

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As New CommandLineItem()

Syntax

Visual Basic
Public Sub New()
C#
public CommandLineItem();
C++
public:
CommandLineItem();
J#
public CommandLineItem();
JScript
public function CommandLineItem();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a CommandLineItem from input executable file name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim executableFilePath As String
Dim commandLineItem1 As New CommandLineItem(executableFilePath)

Syntax

Visual Basic
Public Sub New( _
    ByVal executableFilePath As String _
)
C#
public CommandLineItem(
    string executableFilePath
);
C++
public:
CommandLineItem(
    String^ executableFilePath
);
J#
public CommandLineItem(
    System.String executableFilePath
);
JScript
public function CommandLineItem(
     executableFilePath : String
);

Parameters

executableFilePath

Path to the input executable file.

Exceptions

Exception type | Condition
ArgumentException | The executableFilePath is null or empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

CommandLineItem Class


CommandLineItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item. (Inherited from InstallableItem )
public property | Arguments | Get/Set Install arguments.
public property | CommandLineExecutableName | Get/Set Program name.
public property | DefaultResult | Get/Set default installation result.
public property | Id | Retrieves the ID uniquely identifying the InstallableItem (Inherited from InstallableItem )
public property | InstallBehavior | Get/Set InstallBehavior property (Inherited from InstallableItem )
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item. (Inherited from InstallableItem )
public property | Languages | Retrieves the list of languages that this binary has been localized to. (Inherited from InstallableItem )
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem )
public property | RebootByDefault | Get/Set default reboot value. Default: false.
public property | RepairPaths | Returns the MSI repair paths to use if this executable wraps an MSI.
public property | ReturnCodes | Get ReturnCodes list.
public property | UninstallBehavior | Get/Set UninstallBehavior (Inherited from InstallableItem )

See Also

Reference

CommandLineItem Class


CommandLineItem.Arguments Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Install arguments.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As String
returnValue = commandLineItem1.Arguments

Dim sampleValue As String
commandLineItem1.Arguments = sampleValue

Syntax

Visual Basic
Public Property Arguments() As String
C#
public string Arguments {get; set;}
C++
public:
property String^ Arguments {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Arguments();
public void set_Arguments(System.String);
JScript
public function get Arguments() : String;
public function set Arguments(String);

Property Value

The command line arguments to pass to the executable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem.CommandLineExecutableName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Program name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As String
returnValue = commandLineItem1.CommandLineExecutableName

Dim sampleValue As String
commandLineItem1.CommandLineExecutableName = sampleValue

Syntax

Visual Basic
Public Property CommandLineExecutableName() As String
C#
public string CommandLineExecutableName {get; set;}
C++
public:
property String^ CommandLineExecutableName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_CommandLineExecutableName();
public void set_CommandLineExecutableName(System.String);
JScript
public function get CommandLineExecutableName() : String;
public function set CommandLineExecutableName(String);

Property Value

The program executable name to execute.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem.DefaultResult Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set default installation result.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As InstallationResult
returnValue = commandLineItem1.DefaultResult

Dim sampleValue As InstallationResult
commandLineItem1.DefaultResult = sampleValue

Syntax

Visual Basic
Public Property DefaultResult() As InstallationResult
C#
public InstallationResult DefaultResult {get; set;}
C++
public:
property InstallationResult DefaultResult {
    InstallationResult get();
    void set(InstallationResult value);
}
J#
public InstallationResult get_DefaultResult();
public void set_DefaultResult(InstallationResult);
JScript
public function get DefaultResult() : InstallationResult;
public function set DefaultResult(InstallationResult);

Property Value

The default InstallationResult to use if the executable returns a code not listed in ReturnCodes.

Remarks

Default value is set to Failed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem.RebootByDefault Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set default reboot value. Default: false.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As Boolean
returnValue = commandLineItem1.RebootByDefault

Dim sampleValue As Boolean
commandLineItem1.RebootByDefault = sampleValue

Syntax

Visual Basic
Public Property RebootByDefault() As Boolean
C#
public bool RebootByDefault {get; set;}
C++
public:
property bool RebootByDefault {
    bool get();
    void set(bool value);
}
J#
public boolean get_RebootByDefault();
public void set_RebootByDefault(boolean);
JScript
public function get RebootByDefault() : Boolean;
public function set RebootByDefault(Boolean);

Property Value

If set to true, the client will be rebooted if the executable returns a code not listed in ReturnCodes. If set to false, the client will not be rebooted if the executable returns a code not listed in ReturnCodes.

Remarks

Default value is set to false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem.RepairPaths Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Returns the MSI repair paths to use if this executable wraps an MSI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As IList(Of WindowsInstallerRepairPath)
returnValue = commandLineItem1.RepairPaths

Syntax

Visual Basic
Public ReadOnly Property RepairPaths() As IList(Of WindowsInstallerRepairPath)
C#
public IList<WindowsInstallerRepairPath> RepairPaths {get;}
C++
public:
property IList<WindowsInstallerRepairPath^>^ RepairPaths {
    IList<WindowsInstallerRepairPath^>^ get();
}
J#
public IList<WindowsInstallerRepairPath> get_RepairPaths();
JScript
public function get RepairPaths() : JScript does not support Generics.;

Property Value

The MSI repair paths to use if this executable wraps an MSI.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


CommandLineItem.ReturnCodes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get ReturnCodes list.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim commandLineItem1 As CommandLineItem

Dim returnValue As IList(Of ReturnCode)
returnValue = commandLineItem1.ReturnCodes

Syntax

Visual Basic
Public ReadOnly Property ReturnCodes() As IList(Of ReturnCode)
C#
public IList<ReturnCode> ReturnCodes {get;}
C++
public:
property IList<ReturnCode^>^ ReturnCodes {
    IList<ReturnCode^>^ get();
}
J#
public IList<ReturnCode> get_ReturnCodes();
JScript
public function get ReturnCodes() : JScript does not support Generics.;

Property Value

The list of return codes that the executable is expected to return, and how those codes should be interpreted.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

CommandLineItem Class
CommandLineItem Members


ComputerTargetCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a collection of client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetCollection1 As New ComputerTargetCollection()

Syntax

Visual Basic
Public Class ComputerTargetCollection
    Inherits WsusCollection
C#
public class ComputerTargetCollection : WsusCollection
C++
public ref class ComputerTargetCollection : WsusCollection
J#
public class ComputerTargetCollection extends WsusCollection
JScript
public class ComputerTargetCollection extends WsusCollection

Remarks

To retrieve a collection of client computers, call one of the following methods:

  • GetComputerTargets

  • GetComputerTargets

  • SearchComputerTargets

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.ComputerTargetCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Members


ComputerTargetCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a collection of client computers.

The following tables list the members exposed by the ComputerTargetCollection type.

Public Constructors

Name | Description
ComputerTargetCollection | Initializes a new instance of the ComputerTargetCollection frlrfMicrosoftUpdateServicesAdministrationComputerTargetCollectionClassTopic class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieve or set the element at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded. Adds a ComputerTarget to the end of the ComputerTargetCollection.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded. Searches for the specified ComputerTarget and returns the zero-based index of it if it exists.
public method | Insert | Overloaded. Inserts an ComputerTarget into the ComputerTargetCollection at the specified index.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded. Removes a specified ComputerTarget from the ComputerTargetCollection.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

ComputerTargetCollection Class


ComputerTargetCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ComputerTargetCollection frlrfMicrosoftUpdateServicesAdministrationComputerTargetCollectionClassTopic class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetCollection1 As New ComputerTargetCollection()

Syntax

Visual Basic
Public Sub New()
C#
public ComputerTargetCollection();
C++
public:
ComputerTargetCollection();
J#
public ComputerTargetCollection();
JScript
public function ComputerTargetCollection();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded. Adds a ComputerTarget to the end of the ComputerTargetCollection.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded. Searches for the specified ComputerTarget and returns the zero-based index of it if it exists.
public method | Insert | Overloaded. Inserts an ComputerTarget into the ComputerTargetCollection at the specified index.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded. Removes a specified ComputerTarget from the ComputerTargetCollection.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

ComputerTargetCollection Class


ComputerTargetCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a ComputerTarget to the end of the ComputerTargetCollection.

Overload List

Name | Description
ComputerTargetCollection.Add (IComputerTarget) | Adds a client computer to the end of the collection.
ComputerTargetCollection.Add (Object) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Insert
IComputerTargetGroup.GetComputerTargets()
IUpdateServer.GetComputerTarget(String)
IUpdateServer.RegisterComputer(String)


ComputerTargetCollection.Add Method (IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a client computer to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTarget
Dim returnValue As Integer
Dim computerTargetCollection1 As ComputerTargetCollection
returnValue = computerTargetCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IComputerTarget _
) As Integer
C#
public int Add(
    IComputerTarget value
);
C++
public:
int Add(
    IComputerTarget^ value
);
J#
public int Add(
    IComputerTarget value
);
JScript
public function Add(
     value : IComputerTarget
) : int;

Parameters

value

An IComputerTarget frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassTopic of the client computer to add to the end of the collection.

Return Value

Zero-based index at which the client computer was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The client computer (value) already exists in this collection.
ArgumentNullException | value cannot be null reference (Nothing in Visual Basic).

Remarks

To add a collection of client computers to this collection, call AddRange frlrfMicrosoftUpdateServicesAdministrationComputerTargetCollectionClassAddRangeTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Insert
IComputerTargetGroup.GetComputerTargets()
IUpdateServer.GetComputerTarget(String)
IUpdateServer.RegisterComputer(String)


ComputerTargetCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetCollection.AddRange (Array) |
ComputerTargetCollection.AddRange (ComputerTargetCollection) | Adds the members of a collection of computers to the end of this collection.
ComputerTargetCollection.AddRange (IComputerTarget[]) | Adds the elements of a ComputerTarget array to the end of this collection.
ComputerTargetCollection.AddRange (WsusCollection) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection.AddRange Method (ComputerTargetCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a collection of computers to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ComputerTargetCollection
Dim computerTargetCollection1 As ComputerTargetCollection
computerTargetCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As ComputerTargetCollection _
)
C#
public void AddRange(
    ComputerTargetCollection value
);
C++
public:
void AddRange(
    ComputerTargetCollection^ value
);
J#
public void AddRange(
    ComputerTargetCollection value
);
JScript
public function AddRange(
     value : ComputerTargetCollection
) : Void;

Parameters

value

The collection of IComputers to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection. value contains elements which are already in the collection.
ArgumentNullException | value cannot be null reference.

Remarks

To add a single client computer to this collection, call Add frlrfMicrosoftUpdateServicesAdministrationComputerTargetCollectionClassAddTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.AddRange(IComputerTarget[])
IComputerTargetGroup.GetComputerTargets()


ComputerTargetCollection.AddRange Method (IComputerTarget[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the elements of a ComputerTarget array to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IComputerTarget
Dim computerTargetCollection1 As ComputerTargetCollection
computerTargetCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IComputerTarget _
)
C#
public void AddRange(
    IComputerTarget[] value
);
C++
public:
void AddRange(
    array<IComputerTarget^>^ value
);
J#
public void AddRange(
    IComputerTarget[] value
);
JScript
public function AddRange(
     value : IComputerTarget[]
) : Void;

Parameters

value

The array of IComputers to add.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Remarks

To add a single client computer to this collection, call Add frlrfMicrosoftUpdateServicesAdministrationComputerTargetCollectionClassAddTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.AddRange(ComputerTargetCollection)
IComputerTargetGroup.GetComputerTargets()


ComputerTargetCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetCollection.Contains (IComputerTarget) | Determines whether the specified ComputerTarget is in the ComputerTargetCollection.
ComputerTargetCollection.Contains (Object) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.IndexOf


ComputerTargetCollection.Contains Method (IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the specified ComputerTarget is in the ComputerTargetCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTarget
Dim returnValue As Boolean
Dim computerTargetCollection1 As ComputerTargetCollection
returnValue = computerTargetCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IComputerTarget _
) As Boolean
C#
public bool Contains(
    IComputerTarget value
);
C++
public:
bool Contains(
    IComputerTarget^ value
);
J#
public boolean Contains(
    IComputerTarget value
);
JScript
public function Contains(
     value : IComputerTarget
) : Boolean;

Parameters

value

The ComputerTarget to locate in the ComputerTargetCollection.

Return Value

True, if value is found in the ComputerTargetCollection. False, if value is not found in the ComputerTargetCollection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.IndexOf


ComputerTargetCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetCollection.CopyTo (Array, Int32) |
ComputerTargetCollection.CopyTo (IComputerTarget[], Int32) | Copies the client computers in the collection to a one-dimensional array.

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection.CopyTo Method (IComputerTarget[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the client computers in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IComputerTarget
Dim index As Integer
Dim computerTargetCollection1 As ComputerTargetCollection
computerTargetCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IComputerTarget, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IComputerTarget[] array,
    int index
);
C++
public:
void CopyTo(
    array<IComputerTarget^>^ array,
    int index
);
J#
public void CopyTo(
    IComputerTarget[] array,
    int index
);
JScript
public function CopyTo(
     array : IComputerTarget[],
     index : int
) : Void;

Parameters

array

The one-dimensional array of Computers as the destination of the elements copied from ComputerTargetCollection. The Array must have zero-based indexing.

index

Zero-based index that specifies the location in the array at which to begin adding the client computer elements.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements in the source ComputerTargetCollection is greater than the available space from index to the end of the destination array
ArgumentNullException

array is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException

Index cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Searches for the specified ComputerTarget and returns the zero-based index of it if it exists.

Overload List

Name | Description
ComputerTargetCollection.IndexOf (IComputerTarget) | Determines if the collection contains the specified client computer. If the collection contains the client, the method returns the zero-based index to the client computer in the collection.
ComputerTargetCollection.IndexOf (Object) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Contains
ComputerTargetCollection.Item


ComputerTargetCollection.IndexOf Method (IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified client computer. If the collection contains the client, the method returns the zero-based index to the client computer in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTarget
Dim returnValue As Integer
Dim computerTargetCollection1 As ComputerTargetCollection
returnValue = computerTargetCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IComputerTarget _
) As Integer
C#
public int IndexOf(
    IComputerTarget value
);
C++
public:
int IndexOf(
    IComputerTarget^ value
);
J#
public int IndexOf(
    IComputerTarget value
);
JScript
public function IndexOf(
     value : IComputerTarget
) : int;

Parameters

value

The ComputerTarget to locate.

Return Value

The zero-based index of the first occurrence of value in the ComputerTargetCollection, if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Contains
ComputerTargetCollection.Item


ComputerTargetCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an ComputerTarget into the ComputerTargetCollection at the specified index.

Overload List

Name | Description
ComputerTargetCollection.Insert (Int32, IComputerTarget) | Inserts an ComputerTarget into the ComputerTargetCollection at the specified index.
ComputerTargetCollection.Insert (Int32, Object) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Add


ComputerTargetCollection.Insert Method (Int32, IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an ComputerTarget into the ComputerTargetCollection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IComputerTarget
Dim computerTargetCollection1 As ComputerTargetCollection
computerTargetCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IComputerTarget _
)
C#
public void Insert(
    int index,
    IComputerTarget value
);
C++
public:
void Insert(
    int index,
    IComputerTarget^ value
);
J#
public void Insert(
    int index,
    IComputerTarget value
);
JScript
public function Insert(
     index : int,
     value : IComputerTarget
) : Void;

Parameters

index

Zero-based index at which to insert the client computer value into the collection.

value

The ComputerTarget to insert.

Exceptions

Exception type | Condition
ArgumentException | The client computer already exists in this collection.
ArgumentNullException | value is a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | index cannot be less than zero or greater than ComputerTargetCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members
Microsoft.UpdateServices.Administration Namespace
ComputerTargetCollection.Add


ComputerTargetCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a specified ComputerTarget from the ComputerTargetCollection.

Overload List

Name | Description
ComputerTargetCollection.Remove (IComputerTarget) | Removes a client computer from the collection.
ComputerTargetCollection.Remove (Object) |

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection.Remove Method (IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a client computer from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTarget
Dim computerTargetCollection1 As ComputerTargetCollection
computerTargetCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IComputerTarget _
)
C#
public void Remove(
    IComputerTarget value
);
C++
public:
void Remove(
    IComputerTarget^ value
);
J#
public void Remove(
    IComputerTarget value
);
JScript
public function Remove(
     value : IComputerTarget
) : Void;

Parameters

value

An IComputerTarget frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassTopic of the client computer to remove from the collection.

Exceptions

Exception type | Condition
ArgumentException | The client computer does not exist in the collection.
ArgumentNullException | value is a null reference (Nothing in Visual Basic).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieve or set the element at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

ComputerTargetCollection Class


ComputerTargetCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieve or set the element at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetCollection1 As ComputerTargetCollection

Dim key As Integer
Dim returnValue As IComputerTarget
returnValue = computerTargetCollection1.Item(key)

Dim sampleValue As IComputerTarget
computerTargetCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IComputerTarget
C#
public new IComputerTarget this[
    int index
] {get; set;}
C++
public:
property IComputerTarget^ default[int] {
    IComputerTarget^ get(int index);
    void set(int index, IComputerTarget^ value);
}
J#
new public IComputerTarget get_Item(
    int index
);
public void set_Item(
    int index
IComputerTarget);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Property Value

The ComputerTarget at the specified index.

Exceptions

Exception type | Condition
ArgumentException | Attempted set to a value already in the collection at a different index. The client computer already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index is less than zero -or- index is equal or greater than ComputerTargetCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetCollection Class
ComputerTargetCollection Members


ComputerTargetGroupCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of Categories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetGroupCollection1 As New ComputerTargetGroupCollection()

Syntax

Visual Basic
Public Class ComputerTargetGroupCollection
    Inherits WsusCollection
C#
public class ComputerTargetGroupCollection : WsusCollection
C++
public ref class ComputerTargetGroupCollection : WsusCollection
J#
public class ComputerTargetGroupCollection extends WsusCollection
JScript
public class ComputerTargetGroupCollection extends WsusCollection

Remarks

To retrieve or use a collection of target groups, call one of the following methods:

  • GetComputerTargetGroups

  • SetComputerTargetGroups

  • GetComputerTargetGroups

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.ComputerTargetGroupCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Members


ComputerTargetGroupCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of Categories.

The following tables list the members exposed by the ComputerTargetGroupCollection type.

Public Constructors

Name | Description
ComputerTargetGroupCollection | Initializes a new instance of the ComputerTargetGroupCollection frlrfMicrosoftUpdateServicesAdministrationComputerTargetGroupCollectionClassTopic class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

ComputerTargetGroupCollection Class


ComputerTargetGroupCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ComputerTargetGroupCollection frlrfMicrosoftUpdateServicesAdministrationComputerTargetGroupCollectionClassTopic class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetGroupCollection1 As New ComputerTargetGroupCollection()

Syntax

Visual Basic
Public Sub New()
C#
public ComputerTargetGroupCollection();
C++
public:
ComputerTargetGroupCollection();
J#
public ComputerTargetGroupCollection();
JScript
public function ComputerTargetGroupCollection();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

ComputerTargetGroupCollection Class


ComputerTargetGroupCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.Add (IComputerTargetGroup) | Adds an existing ComputerTargetGroup to the end of the ComputerTargetGroupCollection.
ComputerTargetGroupCollection.Add (Object) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Add Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an existing ComputerTargetGroup to the end of the ComputerTargetGroupCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTargetGroup
Dim returnValue As Integer
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
returnValue = computerTargetGroupCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IComputerTargetGroup _
) As Integer
C#
public int Add(
    IComputerTargetGroup value
);
C++
public:
int Add(
    IComputerTargetGroup^ value
);
J#
public int Add(
    IComputerTargetGroup value
);
JScript
public function Add(
     value : IComputerTargetGroup
) : int;

Parameters

value

The ComputerTargetGroup to add to the end of the ComputerTargetGroupCollection.

Return Value

Zero-based index at which the target group was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The target group already exists in the collection.
ArgumentNullException | value is a null reference (Nothing in Visual Basic).

Remarks

You can use this method to build a specific target group collection to pass to SetComputerTargetGroups frlrfMicrosoftUpdateServicesAdministrationIAutomaticUpdateApprovalRuleClassSetComputerTargetGroupsTopic.

To create a target group, call CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.AddRange (Array) |
ComputerTargetGroupCollection.AddRange (ComputerTargetGroupCollection) | Adds the members of a ComputerTargetGroupCollection to the end of this collection.
ComputerTargetGroupCollection.AddRange (IComputerTargetGroup[]) | Adds the elements of a ComputerTargetGroup array to the end of the collection.
ComputerTargetGroupCollection.AddRange (WsusCollection) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.AddRange Method (ComputerTargetGroupCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a ComputerTargetGroupCollection to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ComputerTargetGroupCollection
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
computerTargetGroupCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As ComputerTargetGroupCollection _
)
C#
public void AddRange(
    ComputerTargetGroupCollection value
);
C++
public:
void AddRange(
    ComputerTargetGroupCollection^ value
);
J#
public void AddRange(
    ComputerTargetGroupCollection value
);
JScript
public function AddRange(
     value : ComputerTargetGroupCollection
) : Void;

Parameters

value

The collection of ICategories to add

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Remarks

You can use this method to build a specific target group collection to pass to SetComputerTargetGroups frlrfMicrosoftUpdateServicesAdministrationIAutomaticUpdateApprovalRuleClassSetComputerTargetGroupsTopic.

To add an array of target groups to the collection, call AddRange

To create a target group, call CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.AddRange Method (IComputerTargetGroup[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the elements of a ComputerTargetGroup array to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IComputerTargetGroup
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
computerTargetGroupCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IComputerTargetGroup _
)
C#
public void AddRange(
    IComputerTargetGroup[] value
);
C++
public:
void AddRange(
    array<IComputerTargetGroup^>^ value
);
J#
public void AddRange(
    IComputerTargetGroup[] value
);
JScript
public function AddRange(
     value : IComputerTargetGroup[]
) : Void;

Parameters

value

The array of ICategories to add.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Remarks

You can use this method to build a specific target group collection to pass to SetComputerTargetGroups frlrfMicrosoftUpdateServicesAdministrationIAutomaticUpdateApprovalRuleClassSetComputerTargetGroupsTopic.

To add a collection of target groups to the collection, call AddRange

To create a target group, call CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.Contains (IComputerTargetGroup) | Determines whether the specified ComputerTargetGroup is in the ComputerTargetGroupCollection.
ComputerTargetGroupCollection.Contains (Object) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Contains Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the specified ComputerTargetGroup is in the ComputerTargetGroupCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTargetGroup
Dim returnValue As Boolean
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
returnValue = computerTargetGroupCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IComputerTargetGroup _
) As Boolean
C#
public bool Contains(
    IComputerTargetGroup value
);
C++
public:
bool Contains(
    IComputerTargetGroup^ value
);
J#
public boolean Contains(
    IComputerTargetGroup value
);
JScript
public function Contains(
     value : IComputerTargetGroup
) : Boolean;

Parameters

value

The ComputerTargetGroup to locate in the ComputerTargetGroupCollection.

Return Value

True, if value is found in the ComputerTargetGroupCollection; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.CopyTo (Array, Int32) |
ComputerTargetGroupCollection.CopyTo (IComputerTargetGroup[], Int32) | Copies the entire ComputerTargetGroupCollection values to a one- dimensional array of Categories, starting at the specified index of the target array.

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.CopyTo Method (IComputerTargetGroup[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the entire ComputerTargetGroupCollection values to a one- dimensional array of Categories, starting at the specified index of the target array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IComputerTargetGroup
Dim index As Integer
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
computerTargetGroupCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IComputerTargetGroup, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IComputerTargetGroup[] array,
    int index
);
C++
public:
void CopyTo(
    array<IComputerTargetGroup^>^ array,
    int index
);
J#
public void CopyTo(
    IComputerTargetGroup[] array,
    int index
);
JScript
public function CopyTo(
     array : IComputerTargetGroup[],
     index : int
) : Void;

Parameters

array

The one-dimensional array of Categories that is the destination of the elements copied from ComputerTargetGroupCollection. The Array must have zero-based indexing.

index

Zero-based index that specifies the location in the array at which to begin adding the target groups.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of elements in the source ComputerTargetGroupCollection.
ArgumentNullException

array cannot be a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.IndexOf (IComputerTargetGroup) | Determines if the collection contains the specified ComputerTargetGroup. If the collection contains the ComputerTargetGroup, the method returns the zero-based index of the first occurrence of the ComputerTargetGroup in the ComputerTargetGroupCollection.
ComputerTargetGroupCollection.IndexOf (Object) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.IndexOf Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified ComputerTargetGroup. If the collection contains the ComputerTargetGroup, the method returns the zero-based index of the first occurrence of the ComputerTargetGroup in the ComputerTargetGroupCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTargetGroup
Dim returnValue As Integer
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
returnValue = computerTargetGroupCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IComputerTargetGroup _
) As Integer
C#
public int IndexOf(
    IComputerTargetGroup value
);
C++
public:
int IndexOf(
    IComputerTargetGroup^ value
);
J#
public int IndexOf(
    IComputerTargetGroup value
);
JScript
public function IndexOf(
     value : IComputerTargetGroup
) : int;

Parameters

value

The ComputerTargetGroup to locate.

Return Value

Zero-based index of the first occurrence of value in the ComputerTargetGroupCollection, if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.Insert (Int32, IComputerTargetGroup) | Inserts an ComputerTargetGroup into the ComputerTargetGroupCollection at the specified index.
ComputerTargetGroupCollection.Insert (Int32, Object) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Insert Method (Int32, IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an ComputerTargetGroup into the ComputerTargetGroupCollection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IComputerTargetGroup
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
computerTargetGroupCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IComputerTargetGroup _
)
C#
public void Insert(
    int index,
    IComputerTargetGroup value
);
C++
public:
void Insert(
    int index,
    IComputerTargetGroup^ value
);
J#
public void Insert(
    int index,
    IComputerTargetGroup value
);
JScript
public function Insert(
     index : int,
     value : IComputerTargetGroup
) : Void;

Parameters

index

The zero-based index at which value is inserted.

value

The ComputerTargetGroup to insert.

Exceptions

Exception type | Condition
ArgumentException | The target group already exists in this collection.
ArgumentNullException | value cannot be a null reference (Nothing in Visual Basic).
ArgumentOutOfRangeException | index cannot be less than zero or greater than ComputerTargetGroupCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ComputerTargetGroupCollection.Remove (IComputerTargetGroup) | Removes the ComputerTargetGroup from the ComputerTargetGroupCollection.
ComputerTargetGroupCollection.Remove (Object) |

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection.Remove Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the ComputerTargetGroup from the ComputerTargetGroupCollection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IComputerTargetGroup
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection
computerTargetGroupCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IComputerTargetGroup _
)
C#
public void Remove(
    IComputerTargetGroup value
);
C++
public:
void Remove(
    IComputerTargetGroup^ value
);
J#
public void Remove(
    IComputerTargetGroup value
);
JScript
public function Remove(
     value : IComputerTargetGroup
) : Void;

Parameters

value

The ComputerTargetGroup to remove from the ComputerTargetGroupCollection.

Exceptions

Exception type | Condition
ArgumentException | value does not exist in the collection.
ArgumentNullException | value cannot be a null reference (Nothing in Visual Basic).

Remarks

When you remove the group, the clients in the group are moved to the Unassigned Computers group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

ComputerTargetGroupCollection Class


ComputerTargetGroupCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetGroupCollection1 As ComputerTargetGroupCollection

Dim key As Integer
Dim returnValue As IComputerTargetGroup
returnValue = computerTargetGroupCollection1.Item(key)

Dim sampleValue As IComputerTargetGroup
computerTargetGroupCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IComputerTargetGroup
C#
public new IComputerTargetGroup this[
    int index
] {get; set;}
C++
public:
property IComputerTargetGroup^ default[int] {
    IComputerTargetGroup^ get(int index);
    void set(int index, IComputerTargetGroup^ value);
}
J#
new public IComputerTargetGroup get_Item(
    int index
);
public void set_Item(
    int index
IComputerTargetGroup);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Property Value

The ComputerTargetGroup at the specified index.

Exceptions

Exception type | Condition
ArgumentException | The target group already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or index cannot be greater than or equal to ComputerTargetGroupCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupCollection Class
ComputerTargetGroupCollection Members


ComputerTargetGroupId Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use the target group identifiers that are defined in this class to retrieve the target groups that are defined by WSUS. For example, you can use the identifiers when calling GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetGroupId1 As ComputerTargetGroupId

Syntax

Visual Basic
NotInheritable Public Class ComputerTargetGroupId
C#
public sealed class ComputerTargetGroupId
C++
public ref class ComputerTargetGroupId sealed
J#
public final class ComputerTargetGroupId
JScript
public class ComputerTargetGroupId

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ComputerTargetGroupId

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupId Members


ComputerTargetGroupId Members
See Also Fields Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use the target group identifiers that are defined in this class to retrieve the target groups that are defined by WSUS. For example, you can use the identifiers when calling GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.

The following tables list the members exposed by the ComputerTargetGroupId type.

Public Fields

Name | Description
AllComputers | ComputerTargetGroupId of the "All Computers" target group.
AllDssTargetGroups | Guid indicating "All DSS target groups".
UnassignedComputers | ComputerTargetGroupId of the "Unassigned" TargetGroup.
WindowsProductIdValidated | ComputerTargetGroupId of the "Windows PID Validated" TargetGroup.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ComputerTargetGroupId Class


ComputerTargetGroupId Fields
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Fields

Name | Description
AllComputers | ComputerTargetGroupId of the "All Computers" target group.
AllDssTargetGroups | Guid indicating "All DSS target groups".
UnassignedComputers | ComputerTargetGroupId of the "Unassigned" TargetGroup.
WindowsProductIdValidated | ComputerTargetGroupId of the "Windows PID Validated" TargetGroup.

See Also

Reference

ComputerTargetGroupId Class


ComputerTargetGroupId.AllComputers Field
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

ComputerTargetGroupId of the "All Computers" target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Guid
returnValue = ComputerTargetGroupId.AllComputers

Dim sampleValue As Guid
ComputerTargetGroupId.AllComputers = sampleValue

Syntax

Visual Basic
Public Shared ReadOnly AllComputers As Guid
C#
public static readonly Guid AllComputers;
C++
public:
static initonly Guid^ AllComputers;
J#
public static Guid AllComputers;
JScript
public static var AllComputers : Guid;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupId Class
ComputerTargetGroupId Members


ComputerTargetGroupId.AllDssTargetGroups Field
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Guid indicating "All DSS target groups".

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Guid
returnValue = ComputerTargetGroupId.AllDssTargetGroups

Dim sampleValue As Guid
ComputerTargetGroupId.AllDssTargetGroups = sampleValue

Syntax

Visual Basic
Public Shared ReadOnly AllDssTargetGroups As Guid
C#
public static readonly Guid AllDssTargetGroups;
C++
public:
static initonly Guid^ AllDssTargetGroups;
J#
public static Guid AllDssTargetGroups;
JScript
public static var AllDssTargetGroups : Guid;

Remarks

The GUID is not a real ComputerTargetGroupId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupId Class
ComputerTargetGroupId Members


ComputerTargetGroupId.UnassignedComputers Field
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

ComputerTargetGroupId of the "Unassigned" TargetGroup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Guid
returnValue = ComputerTargetGroupId.UnassignedComputers

Dim sampleValue As Guid
ComputerTargetGroupId.UnassignedComputers = sampleValue

Syntax

Visual Basic
Public Shared ReadOnly UnassignedComputers As Guid
C#
public static readonly Guid UnassignedComputers;
C++
public:
static initonly Guid^ UnassignedComputers;
J#
public static Guid UnassignedComputers;
JScript
public static var UnassignedComputers : Guid;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupId Class
ComputerTargetGroupId Members


ComputerTargetGroupId.WindowsProductIdValidated Field
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

ComputerTargetGroupId of the "Windows PID Validated" TargetGroup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Guid
returnValue = ComputerTargetGroupId.WindowsProductIdValidated

Dim sampleValue As Guid
ComputerTargetGroupId.WindowsProductIdValidated = sampleValue

Syntax

Visual Basic
Public Shared ReadOnly WindowsProductIdValidated As Guid
C#
public static readonly Guid WindowsProductIdValidated;
C++
public:
static initonly Guid^ WindowsProductIdValidated;
J#
public static Guid WindowsProductIdValidated;
JScript
public static var WindowsProductIdValidated : Guid;

Remarks

Reserved for future use.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetGroupId Class
ComputerTargetGroupId Members


ComputerTargetGroupId Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ComputerTargetGroupId Class


ComputerTargetScope Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the set of parameters that can be used to filter the results of retrieved list of ComputerTargets.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As New ComputerTargetScope()

Syntax

Visual Basic
Public Class ComputerTargetScope
C#
public class ComputerTargetScope
C++
public ref class ComputerTargetScope
J#
public class ComputerTargetScope
JScript
public class ComputerTargetScope

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ComputerTargetScope

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Members


ComputerTargetScope Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the set of parameters that can be used to filter the results of retrieved list of ComputerTargets.

The following tables list the members exposed by the ComputerTargetScope type.

Public Constructors

Name | Description
ComputerTargetScope | Default constructor.
Top

Public Properties

 | Name | Description
public property | ComputerTargetGroups | Retrieves the list of target groups to search in.
public property | ExcludedInstallationStates | Retrieves or sets the installation states to exclude.
public property | FromLastReportedStatusTime | Retrieves or sets the minimum LastReportedStatusTime to search for.
public property | FromLastSyncTime | Retrieves or sets the minimum LastSyncTime to search for.
public property | IncludedInstallationStates | Retrieves or sets the installation states to search for.
public property | IncludeDownstreamComputerTargets | Retrieves or sets whether or not computers that sync from a downstream server, rather than this server, should be included.
public property | IncludeSubgroups | Retrieves or sets whether the ComputerTargetGroups property should be interpreted to include descendent subgroups or not.
public property | NameIncludes | Retrieves or sets a name to search for.
public property | RequestedTargetGroupNames | Retrieves the list of requested target group names to search for.
public property | ToLastReportedStatusTime | Retreives or sets the maximum LastReportedStatusTime to search for.
public property | ToLastSyncTime | Gets or sets the maximum LastSyncTime to search for.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ComputerTargetScope Class


ComputerTargetScope Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As New ComputerTargetScope()

Syntax

Visual Basic
Public Sub New()
C#
public ComputerTargetScope();
C++
public:
ComputerTargetScope();
J#
public ComputerTargetScope();
JScript
public function ComputerTargetScope();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ComputerTargetScope Class


ComputerTargetScope Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ComputerTargetGroups | Retrieves the list of target groups to search in.
public property | ExcludedInstallationStates | Retrieves or sets the installation states to exclude.
public property | FromLastReportedStatusTime | Retrieves or sets the minimum LastReportedStatusTime to search for.
public property | FromLastSyncTime | Retrieves or sets the minimum LastSyncTime to search for.
public property | IncludedInstallationStates | Retrieves or sets the installation states to search for.
public property | IncludeDownstreamComputerTargets | Retrieves or sets whether or not computers that sync from a downstream server, rather than this server, should be included.
public property | IncludeSubgroups | Retrieves or sets whether the ComputerTargetGroups property should be interpreted to include descendent subgroups or not.
public property | NameIncludes | Retrieves or sets a name to search for.
public property | RequestedTargetGroupNames | Retrieves the list of requested target group names to search for.
public property | ToLastReportedStatusTime | Retreives or sets the maximum LastReportedStatusTime to search for.
public property | ToLastSyncTime | Gets or sets the maximum LastSyncTime to search for.

See Also

Reference

ComputerTargetScope Class


ComputerTargetScope.ComputerTargetGroups Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of target groups to search in.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As ComputerTargetGroupCollection
returnValue = computerTargetScope1.ComputerTargetGroups

Syntax

Visual Basic
Public ReadOnly Property ComputerTargetGroups() As ComputerTargetGroupCollection
C#
public ComputerTargetGroupCollection ComputerTargetGroups {get;}
C++
public:
property ComputerTargetGroupCollection^ ComputerTargetGroups {
    ComputerTargetGroupCollection^ get();
}
J#
public ComputerTargetGroupCollection get_ComputerTargetGroups();
JScript
public function get ComputerTargetGroups() : ComputerTargetGroupCollection;

Property Value

The list of target groups to search in. If IncludeSubgroups is false, then a computer will be included only if it is a direct member of at least one of these groups. If IncludeSubgroups is true, then a computer will be included if it is a member of at least one of these groups, or any of their descendent subgroups. If empty, then no filtering will be done based on target group membership.

Remarks

Defaults to empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.ExcludedInstallationStates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the installation states to exclude.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As UpdateInstallationStates
returnValue = computerTargetScope1.ExcludedInstallationStates

Dim sampleValue As UpdateInstallationStates
computerTargetScope1.ExcludedInstallationStates = sampleValue

Syntax

Visual Basic
Public Property ExcludedInstallationStates() As UpdateInstallationStates
C#
public UpdateInstallationStates ExcludedInstallationStates {get; set;}
C++
public:
property UpdateInstallationStates ExcludedInstallationStates {
    UpdateInstallationStates get();
    void set(UpdateInstallationStates value);
}
J#
public UpdateInstallationStates get_ExcludedInstallationStates();
public void set_ExcludedInstallationStates(UpdateInstallationStates);
JScript
public function get ExcludedInstallationStates() : UpdateInstallationStates;
public function set ExcludedInstallationStates(UpdateInstallationStates);

Property Value

A computer will be included only if it does not have any updates in any of the specified states. This value may be a combination of any number of values from UpdateInstallationStates.

Remarks

Defaults to 0.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.FromLastReportedStatusTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the minimum LastReportedStatusTime to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As DateTime
returnValue = computerTargetScope1.FromLastReportedStatusTime

Dim sampleValue As DateTime
computerTargetScope1.FromLastReportedStatusTime = sampleValue

Syntax

Visual Basic
Public Property FromLastReportedStatusTime() As DateTime
C#
public DateTime FromLastReportedStatusTime {get; set;}
C++
public:
property DateTime^ FromLastReportedStatusTime {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_FromLastReportedStatusTime();
public void set_FromLastReportedStatusTime(DateTime);
JScript
public function get FromLastReportedStatusTime() : DateTime;
public function set FromLastReportedStatusTime(DateTime);

Property Value

The minimum LastReportedStatusTime to search for . A computer will be included only if its LastSyncTime is greater than or equal to this value.

Remarks

Defaults to DateTime.MinValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.FromLastSyncTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the minimum LastSyncTime to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As DateTime
returnValue = computerTargetScope1.FromLastSyncTime

Dim sampleValue As DateTime
computerTargetScope1.FromLastSyncTime = sampleValue

Syntax

Visual Basic
Public Property FromLastSyncTime() As DateTime
C#
public DateTime FromLastSyncTime {get; set;}
C++
public:
property DateTime^ FromLastSyncTime {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_FromLastSyncTime();
public void set_FromLastSyncTime(DateTime);
JScript
public function get FromLastSyncTime() : DateTime;
public function set FromLastSyncTime(DateTime);

Property Value

The minimum LastSyncTime to search for. A computer will be included only if its LastSyncTime is greater than or equal to this value.

Remarks

Defaults to DateTime.MinValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.IncludedInstallationStates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the installation states to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As UpdateInstallationStates
returnValue = computerTargetScope1.IncludedInstallationStates

Dim sampleValue As UpdateInstallationStates
computerTargetScope1.IncludedInstallationStates = sampleValue

Syntax

Visual Basic
Public Property IncludedInstallationStates() As UpdateInstallationStates
C#
public UpdateInstallationStates IncludedInstallationStates {get; set;}
C++
public:
property UpdateInstallationStates IncludedInstallationStates {
    UpdateInstallationStates get();
    void set(UpdateInstallationStates value);
}
J#
public UpdateInstallationStates get_IncludedInstallationStates();
public void set_IncludedInstallationStates(UpdateInstallationStates);
JScript
public function get IncludedInstallationStates() : UpdateInstallationStates;
public function set IncludedInstallationStates(UpdateInstallationStates);

Property Value

The installation states to search for. A computer will be included only if it has at least one update in one of the specified states. This value may be a combination of any number of values from UpdateInstallationStates.

Remarks

Defaults to UpdateInstallationStates.All.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.IncludeDownstreamComputerTargets Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether or not computers that sync from a downstream server, rather than this server, should be included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As Boolean
returnValue = computerTargetScope1.IncludeDownstreamComputerTargets

Dim sampleValue As Boolean
computerTargetScope1.IncludeDownstreamComputerTargets = sampleValue

Syntax

Visual Basic
Public Property IncludeDownstreamComputerTargets() As Boolean
C#
public bool IncludeDownstreamComputerTargets {get; set;}
C++
public:
property bool IncludeDownstreamComputerTargets {
    bool get();
    void set(bool value);
}
J#
public boolean get_IncludeDownstreamComputerTargets();
public void set_IncludeDownstreamComputerTargets(boolean);
JScript
public function get IncludeDownstreamComputerTargets() : Boolean;
public function set IncludeDownstreamComputerTargets(Boolean);

Property Value

If set to true, computers sync from a downstream server (DSS) should be included. If set to false, computers sync from this server, should be included.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.IncludeSubgroups Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets whether the ComputerTargetGroups property should be interpreted to include descendent subgroups or not.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As Boolean
returnValue = computerTargetScope1.IncludeSubgroups

Dim sampleValue As Boolean
computerTargetScope1.IncludeSubgroups = sampleValue

Syntax

Visual Basic
Public Property IncludeSubgroups() As Boolean
C#
public bool IncludeSubgroups {get; set;}
C++
public:
property bool IncludeSubgroups {
    bool get();
    void set(bool value);
}
J#
public boolean get_IncludeSubgroups();
public void set_IncludeSubgroups(boolean);
JScript
public function get IncludeSubgroups() : Boolean;
public function set IncludeSubgroups(Boolean);

Property Value

If set to true, the ComputerTargetGroups property will be interpreted to include descendent subgroups. If set to false, the ComputerTargetGroups property will not be interpreted to include descendent subgroups.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.NameIncludes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a name to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As String
returnValue = computerTargetScope1.NameIncludes

Dim sampleValue As String
computerTargetScope1.NameIncludes = sampleValue

Syntax

Visual Basic
Public Property NameIncludes() As String
C#
public string NameIncludes {get; set;}
C++
public:
property String^ NameIncludes {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_NameIncludes();
public void set_NameIncludes(System.String);
JScript
public function get NameIncludes() : String;
public function set NameIncludes(String);

Property Value

The name substring to search for. A computer will be included only if its FullDomainName contains this string. If string.Empty, then no filtering will be done based on computer names.

Remarks

Defaults to string.Empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.RequestedTargetGroupNames Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of requested target group names to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As StringCollection
returnValue = computerTargetScope1.RequestedTargetGroupNames

Syntax

Visual Basic
Public ReadOnly Property RequestedTargetGroupNames() As StringCollection
C#
public StringCollection RequestedTargetGroupNames {get;}
C++
public:
property StringCollection^ RequestedTargetGroupNames {
    StringCollection^ get();
}
J#
public StringCollection get_RequestedTargetGroupNames();
JScript
public function get RequestedTargetGroupNames() : StringCollection;

Property Value

The list of requested target group names to search for. A computer will be included only if its RequestedTargetGroupNames contains at least one of these strings. If empty, then no filtering will be done based on requested target group names.

Remarks

Defaults to empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.ToLastReportedStatusTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retreives or sets the maximum LastReportedStatusTime to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As DateTime
returnValue = computerTargetScope1.ToLastReportedStatusTime

Dim sampleValue As DateTime
computerTargetScope1.ToLastReportedStatusTime = sampleValue

Syntax

Visual Basic
Public Property ToLastReportedStatusTime() As DateTime
C#
public DateTime ToLastReportedStatusTime {get; set;}
C++
public:
property DateTime^ ToLastReportedStatusTime {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_ToLastReportedStatusTime();
public void set_ToLastReportedStatusTime(DateTime);
JScript
public function get ToLastReportedStatusTime() : DateTime;
public function set ToLastReportedStatusTime(DateTime);

Property Value

The maximum LastReportedStatusTime to search for. A computer will be included only if its LastSyncTime is less than or equal to this value.

Remarks

Defaults to DateTime.MaxValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ComputerTargetScope.ToLastSyncTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the maximum LastSyncTime to search for.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerTargetScope1 As ComputerTargetScope

Dim returnValue As DateTime
returnValue = computerTargetScope1.ToLastSyncTime

Dim sampleValue As DateTime
computerTargetScope1.ToLastSyncTime = sampleValue

Syntax

Visual Basic
Public Property ToLastSyncTime() As DateTime
C#
public DateTime ToLastSyncTime {get; set;}
C++
public:
property DateTime^ ToLastSyncTime {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_ToLastSyncTime();
public void set_ToLastSyncTime(DateTime);
JScript
public function get ToLastSyncTime() : DateTime;
public function set ToLastSyncTime(DateTime);

Property Value

The maximum LastSyncTime to search for. A computer will be included only if its LastSyncTime is less than or equal to this value.

Remarks

Defaults to DateTime.MaxValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ComputerTargetScope Class
ComputerTargetScope Members


ContentDownloadProgress Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the download progress for all updates that are currently downloading to the WSUS server. To retrieve this class, call the IUpdateServer.GetContentDownloadProgress method.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim totalBytesToDownload As Long
Dim downloadedBytes As Long
Dim contentDownloadProgress1 As New ContentDownloadProgress(totalBytesToDownload, downloadedBytes)

Syntax

Visual Basic
Public Class ContentDownloadProgress
C#
public class ContentDownloadProgress
C++
public ref class ContentDownloadProgress
J#
public class ContentDownloadProgress
JScript
public class ContentDownloadProgress

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ContentDownloadProgress

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Members
Microsoft.UpdateServices.Administration Namespace
IUpdateServer.GetContentDownloadProgress
SynchronizationProgress


ContentDownloadProgress Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the download progress for all updates that are currently downloading to the WSUS server. To retrieve this class, call the IUpdateServer.GetContentDownloadProgress method.

The following tables list the members exposed by the ContentDownloadProgress type.

Public Constructors

Name | Description
ContentDownloadProgress | Initializes a new instance of the ContentDownloadProgress class.
Top

Public Properties

 | Name | Description
public property | DownloadedBytes | Number of bytes downloaded so far.
public property | TotalBytesToDownload | Total number of bytes to download.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ContentDownloadProgress Class
Microsoft.UpdateServices.Administration Namespace
IUpdateServer.GetContentDownloadProgress
SynchronizationProgress


ContentDownloadProgress Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ContentDownloadProgress class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim totalBytesToDownload As Long
Dim downloadedBytes As Long
Dim contentDownloadProgress1 As New ContentDownloadProgress(totalBytesToDownload, downloadedBytes)

Syntax

Visual Basic
Public Sub New( _
    ByVal totalBytesToDownload As Long, _
    ByVal downloadedBytes As Long _
)
C#
public ContentDownloadProgress(
    long totalBytesToDownload,
    long downloadedBytes
);
C++
public:
ContentDownloadProgress(
    long long totalBytesToDownload,
    long long downloadedBytes
);
J#
public ContentDownloadProgress(
    long totalBytesToDownload,
    long downloadedBytes
);
JScript
public function ContentDownloadProgress(
     totalBytesToDownload : long,
     downloadedBytes : long
);

Parameters

totalBytesToDownload

Total number of bytes to download.

downloadedBytes

Number of bytes downloaded so far.

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


ContentDownloadProgress Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ContentDownloadProgress Class
Microsoft.UpdateServices.Administration Namespace
IUpdateServer.GetContentDownloadProgress
SynchronizationProgress


ContentDownloadProgress.Equals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ContentDownloadProgress.Equals (Object) |
ContentDownloadProgress.Equals (Object, Object) |

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


ContentDownloadProgress.Equals Method (Object)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim obj As Object
Dim returnValue As Boolean
Dim contentDownloadProgress1 As ContentDownloadProgress
returnValue = contentDownloadProgress1.Equals(obj)

Syntax

Visual Basic
Overloads Public Overrides Function Equals( _
    ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
    object obj
);
C++
public:
virtual bool Equals(
    Object^ obj
) override;
J#
public override boolean Equals(
    System.Object obj
);
JScript
public override function Equals(
     obj : Object
) : Boolean;

Parameters

obj

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


ContentDownloadProgress.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim contentDownloadProgress1 As ContentDownloadProgress
returnValue = contentDownloadProgress1.GetHashCode()

Syntax

Visual Basic
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode();
C++
public:
virtual int GetHashCode() override;
J#
public override int GetHashCode();
JScript
public override function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


ContentDownloadProgress Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | DownloadedBytes | Number of bytes downloaded so far.
public property | TotalBytesToDownload | Total number of bytes to download.

See Also

Reference

ContentDownloadProgress Class
Microsoft.UpdateServices.Administration Namespace
IUpdateServer.GetContentDownloadProgress
SynchronizationProgress


ContentDownloadProgress.DownloadedBytes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of bytes downloaded so far.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim contentDownloadProgress1 As ContentDownloadProgress

Dim returnValue As Long
returnValue = contentDownloadProgress1.DownloadedBytes

Syntax

Visual Basic
Public ReadOnly Property DownloadedBytes() As Long
C#
public long DownloadedBytes {get;}
C++
public:
property long long DownloadedBytes {
    long long get();
}
J#
public long get_DownloadedBytes();
JScript
public function get DownloadedBytes() : long;

Property Value

Number of bytes downloaded so far.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


ContentDownloadProgress.TotalBytesToDownload Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Total number of bytes to download.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim contentDownloadProgress1 As ContentDownloadProgress

Dim returnValue As Long
returnValue = contentDownloadProgress1.TotalBytesToDownload

Syntax

Visual Basic
Public ReadOnly Property TotalBytesToDownload() As Long
C#
public long TotalBytesToDownload {get;}
C++
public:
property long long TotalBytesToDownload {
    long long get();
}
J#
public long get_TotalBytesToDownload();
JScript
public function get TotalBytesToDownload() : long;

Property Value

Total number of bytes to download.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ContentDownloadProgress Class
ContentDownloadProgress Members


DownstreamServerCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of downstream Windows Server Update Servers (WSUS) servers. To retrieve this collection, call GetDownstreamServers frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDownstreamServersTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim downstreamServerCollection1 As New DownstreamServerCollection()

Syntax

Visual Basic
Public Class DownstreamServerCollection
    Inherits WsusCollection
C#
public class DownstreamServerCollection : WsusCollection
C++
public ref class DownstreamServerCollection : WsusCollection
J#
public class DownstreamServerCollection extends WsusCollection
JScript
public class DownstreamServerCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.DownstreamServerCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Members


DownstreamServerCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of downstream Windows Server Update Servers (WSUS) servers. To retrieve this collection, call GetDownstreamServers frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDownstreamServersTopic.

The following tables list the members exposed by the DownstreamServerCollection type.

Public Constructors

Name | Description
DownstreamServerCollection | Initializes a new instance of the DownstreamServerCollection frlrfMicrosoftUpdateServicesAdministrationDownstreamServerCollectionClassTopic class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

DownstreamServerCollection Class


DownstreamServerCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the DownstreamServerCollection frlrfMicrosoftUpdateServicesAdministrationDownstreamServerCollectionClassTopic class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim downstreamServerCollection1 As New DownstreamServerCollection()

Syntax

Visual Basic
Public Sub New()
C#
public DownstreamServerCollection();
C++
public:
DownstreamServerCollection();
J#
public DownstreamServerCollection();
JScript
public function DownstreamServerCollection();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

DownstreamServerCollection Class


DownstreamServerCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.Add (IDownstreamServer) | Adds a downstream server to the end of the collection.
DownstreamServerCollection.Add (Object) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Add Method (IDownstreamServer)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a downstream server to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IDownstreamServer
Dim returnValue As Integer
Dim downstreamServerCollection1 As DownstreamServerCollection
returnValue = downstreamServerCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IDownstreamServer _
) As Integer
C#
public int Add(
    IDownstreamServer value
);
C++
public:
int Add(
    IDownstreamServer^ value
);
J#
public int Add(
    IDownstreamServer value
);
JScript
public function Add(
     value : IDownstreamServer
) : int;

Parameters

value

An IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic of the downstream server to add.

Return Value

Zero-based index at which the downstream server was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The downstream server already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.AddRange (Array) |
DownstreamServerCollection.AddRange (DownstreamServerCollection) | Adds the members of a downstream server collection to the end of the collection.
DownstreamServerCollection.AddRange (IDownstreamServer[]) | Adds an array of downstream servers to the end of the collection.
DownstreamServerCollection.AddRange (WsusCollection) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.AddRange Method (DownstreamServerCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a downstream server collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As DownstreamServerCollection
Dim downstreamServerCollection1 As DownstreamServerCollection
downstreamServerCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As DownstreamServerCollection _
)
C#
public void AddRange(
    DownstreamServerCollection value
);
C++
public:
void AddRange(
    DownstreamServerCollection^ value
);
J#
public void AddRange(
    DownstreamServerCollection value
);
JScript
public function AddRange(
     value : DownstreamServerCollection
) : Void;

Parameters

value

A DownstreamServerCollection frlrfMicrosoftUpdateServicesAdministrationDownstreamServerCollectionClassTopic collection of downstream servers to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.AddRange Method (IDownstreamServer[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of downstream servers to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IDownstreamServer
Dim downstreamServerCollection1 As DownstreamServerCollection
downstreamServerCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IDownstreamServer _
)
C#
public void AddRange(
    IDownstreamServer[] value
);
C++
public:
void AddRange(
    array<IDownstreamServer^>^ value
);
J#
public void AddRange(
    IDownstreamServer[] value
);
JScript
public function AddRange(
     value : IDownstreamServer[]
) : Void;

Parameters

value

Array of IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.Contains (IDownstreamServer) | Determines if the collection contains the specified downstream server.
DownstreamServerCollection.Contains (Object) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Contains Method (IDownstreamServer)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified downstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IDownstreamServer
Dim returnValue As Boolean
Dim downstreamServerCollection1 As DownstreamServerCollection
returnValue = downstreamServerCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IDownstreamServer _
) As Boolean
C#
public bool Contains(
    IDownstreamServer value
);
C++
public:
bool Contains(
    IDownstreamServer^ value
);
J#
public boolean Contains(
    IDownstreamServer value
);
JScript
public function Contains(
     value : IDownstreamServer
) : Boolean;

Parameters

value

An IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic of the downstream server to locate in the collection.

Return Value

true if the collection contains the downstream server; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.CopyTo (Array, Int32) |
DownstreamServerCollection.CopyTo (IDownstreamServer[], Int32) | Copies the downstream servers in the collection to a one-dimensional array.

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.CopyTo Method (IDownstreamServer[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the downstream servers in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IDownstreamServer
Dim index As Integer
Dim downstreamServerCollection1 As DownstreamServerCollection
downstreamServerCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IDownstreamServer, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IDownstreamServer[] array,
    int index
);
C++
public:
void CopyTo(
    array<IDownstreamServer^>^ array,
    int index
);
J#
public void CopyTo(
    IDownstreamServer[] array,
    int index
);
JScript
public function CopyTo(
     array : IDownstreamServer[],
     index : int
) : Void;

Parameters

array

Array of IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the downstream servers.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.IndexOf (IDownstreamServer) | Determines if the collection contains the specified downstream server. If the collection contains the downstream server, the method returns the zero-based index to the downstream server in the collection.
DownstreamServerCollection.IndexOf (Object) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.IndexOf Method (IDownstreamServer)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified downstream server. If the collection contains the downstream server, the method returns the zero-based index to the downstream server in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IDownstreamServer
Dim returnValue As Integer
Dim downstreamServerCollection1 As DownstreamServerCollection
returnValue = downstreamServerCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IDownstreamServer _
) As Integer
C#
public int IndexOf(
    IDownstreamServer value
);
C++
public:
int IndexOf(
    IDownstreamServer^ value
);
J#
public int IndexOf(
    IDownstreamServer value
);
JScript
public function IndexOf(
     value : IDownstreamServer
) : int;

Parameters

value

An IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic of the downstream server to locate in the collection.

Return Value

Zero-based index of the downstream server in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.Insert (Int32, IDownstreamServer) | Inserts a downstream server into the collection.
DownstreamServerCollection.Insert (Int32, Object) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Insert Method (Int32, IDownstreamServer)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts a downstream server into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IDownstreamServer
Dim downstreamServerCollection1 As DownstreamServerCollection
downstreamServerCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IDownstreamServer _
)
C#
public void Insert(
    int index,
    IDownstreamServer value
);
C++
public:
void Insert(
    int index,
    IDownstreamServer^ value
);
J#
public void Insert(
    int index,
    IDownstreamServer value
);
JScript
public function Insert(
     index : int,
     value : IDownstreamServer
) : Void;

Parameters

index

Zero-based index at which to insert the downstream server into the collection.

value

An IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic of the downstream server to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The downstream server already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than DownstreamServerCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
DownstreamServerCollection.Remove (IDownstreamServer) | Removes the downstream server from the collection.
DownstreamServerCollection.Remove (Object) |

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection.Remove Method (IDownstreamServer)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the downstream server from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IDownstreamServer
Dim downstreamServerCollection1 As DownstreamServerCollection
downstreamServerCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IDownstreamServer _
)
C#
public void Remove(
    IDownstreamServer value
);
C++
public:
void Remove(
    IDownstreamServer^ value
);
J#
public void Remove(
    IDownstreamServer value
);
JScript
public function Remove(
     value : IDownstreamServer
) : Void;

Parameters

value

An IDownstreamServer frlrfMicrosoftUpdateServicesAdministrationIDownstreamServerClassTopic of the downstream server to remove.

Exceptions

Exception type | Condition
ArgumentException | The downstream server does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


DownstreamServerCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

DownstreamServerCollection Class


DownstreamServerCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim downstreamServerCollection1 As DownstreamServerCollection

Dim key As Integer
Dim returnValue As IDownstreamServer
returnValue = downstreamServerCollection1.Item(key)

Dim sampleValue As IDownstreamServer
downstreamServerCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IDownstreamServer
C#
public new IDownstreamServer this[
    int index
] {get; set;}
C++
public:
property IDownstreamServer^ default[int] {
    IDownstreamServer^ get(int index);
    void set(int index, IDownstreamServer^ value);
}
J#
new public IDownstreamServer get_Item(
    int index
);
public void set_Item(
    int index
IDownstreamServer);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Property Value

The DownstreamServer at the specified index.

Exceptions

Exception type | Condition
ArgumentException | The downstream server already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than or equal to DownstreamServerCollection.Count.

Remarks

This property is an indexer for the DownstreamServerCollection class in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

DownstreamServerCollection Class
DownstreamServerCollection Members


EmailNotificationType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Enumerates possible types of email notification

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim emailNotificationType1 As EmailNotificationType = EmailNotificationType.NewSync

Syntax

Visual Basic
Public Enum EmailNotificationType
C#
public enum EmailNotificationType
C++
public enum class EmailNotificationType
J#
public enum EmailNotificationType
JScript
public enum EmailNotificationType

Members

Member name | Description
NewSync | Email for test
Summary | Email for alerting new updates upon each s/s sync
Test | Email for alerting new updates upon each s/s sync

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


EmailStatusNotification Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Enumerates possible types of status reports

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim emailStatusNotification1 As EmailStatusNotification = EmailStatusNotification.Daily

Syntax

Visual Basic
Public Enum EmailStatusNotification
C#
public enum EmailStatusNotification
C++
public enum class EmailStatusNotification
J#
public enum EmailStatusNotification
JScript
public enum EmailStatusNotification

Members

Member name | Description
Daily | Email status on daily summary
Weekly | Email status on monthly summary

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


FileForInstallableItem Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As New FileForInstallableItem()

Syntax

Visual Basic
Public Class FileForInstallableItem
C#
public class FileForInstallableItem
C++
public ref class FileForInstallableItem
J#
public class FileForInstallableItem
JScript
public class FileForInstallableItem

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.FileForInstallableItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Members


FileForInstallableItem Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the FileForInstallableItem type.

Public Constructors

Name | Description
FileForInstallableItem | Default constructor.
Top

Public Properties

 | Name | Description
public property | Digest | Retrieves or sets the FileDigest property.
public property | FileName | Retrieves or sets the FileName property.
public property | Modified | Retrieves or sets the File Modified Date
public property | OriginUri | Retrieves or sets the OriginUri (the URL where the file was originally retrieved from).
public property | Size | Retrieves or sets the File size property.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

FileForInstallableItem Class


FileForInstallableItem Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As New FileForInstallableItem()

Syntax

Visual Basic
Public Sub New()
C#
public FileForInstallableItem();
C++
public:
FileForInstallableItem();
J#
public FileForInstallableItem();
JScript
public function FileForInstallableItem();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FileForInstallableItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

FileForInstallableItem Class


FileForInstallableItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Digest | Retrieves or sets the FileDigest property.
public property | FileName | Retrieves or sets the FileName property.
public property | Modified | Retrieves or sets the File Modified Date
public property | OriginUri | Retrieves or sets the OriginUri (the URL where the file was originally retrieved from).
public property | Size | Retrieves or sets the File size property.

See Also

Reference

FileForInstallableItem Class


FileForInstallableItem.Digest Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the FileDigest property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As FileForInstallableItem

Dim returnValue As String
returnValue = fileForInstallableItem1.Digest

Dim sampleValue As String
fileForInstallableItem1.Digest = sampleValue

Syntax

Visual Basic
Public Property Digest() As String
C#
public string Digest {get; set;}
C++
public:
property String^ Digest {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Digest();
public void set_Digest(System.String);
JScript
public function get Digest() : String;
public function set Digest(String);

Property Value

The SHA-1 file digest in base64 encoding.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FileForInstallableItem.FileName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the FileName property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As FileForInstallableItem

Dim returnValue As String
returnValue = fileForInstallableItem1.FileName

Dim sampleValue As String
fileForInstallableItem1.FileName = sampleValue

Syntax

Visual Basic
Public Property FileName() As String
C#
public string FileName {get; set;}
C++
public:
property String^ FileName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_FileName();
public void set_FileName(System.String);
JScript
public function get FileName() : String;
public function set FileName(String);

Property Value

The FileName

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FileForInstallableItem.Modified Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the File Modified Date

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As FileForInstallableItem

Dim returnValue As DateTime
returnValue = fileForInstallableItem1.Modified

Dim sampleValue As DateTime
fileForInstallableItem1.Modified = sampleValue

Syntax

Visual Basic
Public Property Modified() As DateTime
C#
public DateTime Modified {get; set;}
C++
public:
property DateTime^ Modified {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_Modified();
public void set_Modified(DateTime);
JScript
public function get Modified() : DateTime;
public function set Modified(DateTime);

Property Value

The last modified date.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FileForInstallableItem.OriginUri Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the OriginUri (the URL where the file was originally retrieved from).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As FileForInstallableItem

Dim returnValue As Uri
returnValue = fileForInstallableItem1.OriginUri

Dim sampleValue As Uri
fileForInstallableItem1.OriginUri = sampleValue

Syntax

Visual Basic
Public Property OriginUri() As Uri
C#
public Uri OriginUri {get; set;}
C++
public:
property Uri^ OriginUri {
    Uri^ get();
    void set(Uri^ value);
}
J#
public Uri get_OriginUri();
public void set_OriginUri(Uri);
JScript
public function get OriginUri() : Uri;
public function set OriginUri(Uri);

Property Value

The URL where the file was originally retrieved from.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FileForInstallableItem.Size Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the File size property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileForInstallableItem1 As FileForInstallableItem

Dim returnValue As Integer
returnValue = fileForInstallableItem1.Size

Dim sampleValue As Integer
fileForInstallableItem1.Size = sampleValue

Syntax

Visual Basic
Public Property Size() As Integer
C#
public int Size {get; set;}
C++
public:
property int Size {
    int get();
    void set(int value);
}
J#
public int get_Size();
public void set_Size(int);
JScript
public function get Size() : int;
public function set Size(int);

Property Value

The file size in xxx format.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

FileForInstallableItem Class
FileForInstallableItem Members


FilePropertyRowIndex Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePropertyRowIndex1 As FilePropertyRowIndex = FilePropertyRowIndex.Hash

Syntax

Visual Basic
Public Enum FilePropertyRowIndex
C#
public enum FilePropertyRowIndex
C++
public enum class FilePropertyRowIndex
J#
public enum FilePropertyRowIndex
JScript
public enum FilePropertyRowIndex

Members

Member name | Description
Hash | SHA1 hash
HostOnMu | Host On MU
IsEula | IsEula file flag
Modified | NTFS modified date
MuUrl | MU URL
Name | File name
RevisionId | Locally unique revision ID
TotalBytes | Total size in Bytes of this file
Type | type of this file

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


FileType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileType1 As FileType = FileType.Express

Syntax

Visual Basic
Public Enum FileType
C#
public enum FileType
C++
public enum class FileType
J#
public enum FileType
JScript
public enum FileType

Members

Member name | Description
Express | Express file type
MspBinaryDelta | Windows Installer patch file type
None | No file type
SelfContained | Self contained

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


IAutomaticUpdateApprovalRule Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to define and enable an automatic approval rule. The approval rule creates approvals for newly synchronized updates that fall within one of the specified classification of updates. The rule applies only to new updates, not to new revisions of an update. If the approval applies to the same target group, install approvals will override scan approvals. To retrieve this interface, call the IUpdateServer.GetInstallApprovalRule or the IUpdateServer.GetScanApprovalRule.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class automaticUpdateApprovalRuleImplementation
    Implements IAutomaticUpdateApprovalRule
End Class
Dim automaticUpdateApprovalRuleImplementation1 As New automaticUpdateApprovalRuleImplementation()

Syntax

Visual Basic
Public Interface IAutomaticUpdateApprovalRule
C#
public interface IAutomaticUpdateApprovalRule
C++
public interface class IAutomaticUpdateApprovalRule
J#
public interface IAutomaticUpdateApprovalRule
JScript
public interface IAutomaticUpdateApprovalRule

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to define and enable an automatic approval rule. The approval rule creates approvals for newly synchronized updates that fall within one of the specified classification of updates. The rule applies only to new updates, not to new revisions of an update. If the approval applies to the same target group, install approvals will override scan approvals. To retrieve this interface, call the IUpdateServer.GetInstallApprovalRule or the IUpdateServer.GetScanApprovalRule.

The following tables list the members exposed by the IAutomaticUpdateApprovalRule type.

Public Properties

 | Name | Description
public property | Action | Retrieves the type of action that the rule performs.
public property | Enabled | Retrieves or sets a value to enable or disable the automatic approval rule.
public property | Id | Get the Id of the AutomaticUpdateApproval Rule
public property | Name | Get or Set the name of the AutomaticUpdateApproval Rule
Top

Public Methods

 | Name | Description
public method | ApplyRule | Applies the defined approval rule against the existing updates on the WSUS server. Any update that the approval rule applies to that is not already approved with the same action defined in the approval rule and is not declined will be approved.
public method | GetCategories | Gets the Categories of updates which will be approved automatically by this rule.
public method | GetComputerTargetGroups | Retrieves the target groups to which this automatic approval rule applies.
public method | GetUpdateClassifications | Retrieves the classification of updates for which you want to automatically create approvals.
public method | Save | Saves changes to the automatic approval rule settings.
public method | SetCategories | Sets the Categories of updates which will be approved automatically by this rule.
public method | SetComputerTargetGroups | Specifies the target groups to which this automatic approval rule applies.
public method | SetUpdateClassifications | Specifies the classification of updates for which you want to automatically create approvals.
Top

See Also

Reference

IAutomaticUpdateApprovalRule Interface


IAutomaticUpdateApprovalRule Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | ApplyRule | Applies the defined approval rule against the existing updates on the WSUS server. Any update that the approval rule applies to that is not already approved with the same action defined in the approval rule and is not declined will be approved.
public method | GetCategories | Gets the Categories of updates which will be approved automatically by this rule.
public method | GetComputerTargetGroups | Retrieves the target groups to which this automatic approval rule applies.
public method | GetUpdateClassifications | Retrieves the classification of updates for which you want to automatically create approvals.
public method | Save | Saves changes to the automatic approval rule settings.
public method | SetCategories | Sets the Categories of updates which will be approved automatically by this rule.
public method | SetComputerTargetGroups | Specifies the target groups to which this automatic approval rule applies.
public method | SetUpdateClassifications | Specifies the classification of updates for which you want to automatically create approvals.

See Also

Reference

IAutomaticUpdateApprovalRule Interface


IAutomaticUpdateApprovalRule.ApplyRule Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Applies the defined approval rule against the existing updates on the WSUS server. Any update that the approval rule applies to that is not already approved with the same action defined in the approval rule and is not declined will be approved.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ReadOnlyCollection(Of UpdateRevisionId)
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
returnValue = iAutomaticUpdateApprovalRule1.ApplyRule()

Syntax

Visual Basic
Function ApplyRule() As ReadOnlyCollection(Of UpdateRevisionId)
C#
ReadOnlyCollection<UpdateRevisionId> ApplyRule();
C++
public:
virtual ReadOnlyCollection<UpdateRevisionId^>^ ApplyRule();
J#
public ReadOnlyCollection<UpdateRevisionId> ApplyRule();
JScript
function ApplyRule() : JScript does not support Generics.;

Return Value

ReadOnlyCollection of UpdateRevisionIds that were approved during the ApplyRule() process.

Exceptions

Exception type | Condition
InvalidOperationException | This method is called when the approval rule not enabled or when the server is in ReplicaMode
WsusObjectNotFoundException | The rule could not found in the DB.

Remarks

This process will use the approval rules that are saved in the database. If any changes have been made to the IAutomaticUpdateApprovalRule object the caller should call Save() before calling this method. This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.GetCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the Categories of updates which will be approved automatically by this rule.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
returnValue = iAutomaticUpdateApprovalRule1.GetCategories()

Syntax

Visual Basic
Function GetCategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetCategories();
C++
public:
virtual UpdateCategoryCollection^ GetCategories();
J#
public UpdateCategoryCollection GetCategories();
JScript
function GetCategories() : UpdateCategoryCollection;

Return Value

The Categories which should be approved automatically by this rule.

Remarks

These Categories specify what updates the rule applies to. When an update belongs to one of these Categories and optionally one of the specified UpdateClassifications (GetUpdateClassifications), it will be approved for the specified Action for the specified ComputerTargetGroups (

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.GetComputerTargetGroups Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the target groups to which this automatic approval rule applies.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetGroupCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
returnValue = iAutomaticUpdateApprovalRule1.GetComputerTargetGroups()

Syntax

Visual Basic
Function GetComputerTargetGroups() As ComputerTargetGroupCollection
C#
ComputerTargetGroupCollection GetComputerTargetGroups();
C++
public:
virtual ComputerTargetGroupCollection^ GetComputerTargetGroups();
J#
public ComputerTargetGroupCollection GetComputerTargetGroups();
JScript
function GetComputerTargetGroups() : ComputerTargetGroupCollection;

Return Value

A ComputerTargetGroupCollection collection that contains the target groups to which this automatic approval rule applies.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members
Microsoft.UpdateServices.Administration Namespace
IAutomaticUpdateApprovalRule.SetComputerTargetGroups


IAutomaticUpdateApprovalRule.GetUpdateClassifications Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the classification of updates for which you want to automatically create approvals.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateClassificationCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
returnValue = iAutomaticUpdateApprovalRule1.GetUpdateClassifications()

Syntax

Visual Basic
Function GetUpdateClassifications() As UpdateClassificationCollection
C#
UpdateClassificationCollection GetUpdateClassifications();
C++
public:
virtual UpdateClassificationCollection^ GetUpdateClassifications();
J#
public UpdateClassificationCollection GetUpdateClassifications();
JScript
function GetUpdateClassifications() : UpdateClassificationCollection;

Return Value

An UpdateClassificationCollection collection that contains the classification of updates for which you want to automatically create approvals. For example, the rule applies to newly synchronized security updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members
Microsoft.UpdateServices.Administration Namespace
IAutomaticUpdateApprovalRule.SetUpdateClassifications


IAutomaticUpdateApprovalRule.Save Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Saves changes to the automatic approval rule settings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
iAutomaticUpdateApprovalRule1.Save()

Syntax

Visual Basic
Sub Save()
C#
void Save();
C++
public:
virtual void Save();
J#
public void Save();
JScript
function Save() : Void;

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Could not find the rule in the database.
InvalidOperationException | You cannot modify an automatic approval rule if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.SetCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the Categories of updates which will be approved automatically by this rule.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim categories As UpdateCategoryCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
iAutomaticUpdateApprovalRule1.SetCategories(categories)

Syntax

Visual Basic
Sub SetCategories( _
    ByVal categories As UpdateCategoryCollection _
)
C#
void SetCategories(
    UpdateCategoryCollection categories
);
C++
public:
virtual void SetCategories(
    UpdateCategoryCollection^ categories
);
J#
public void SetCategories(
    UpdateCategoryCollection categories
);
JScript
function SetCategories(
     categories : UpdateCategoryCollection
) : Void;

Parameters

categories

The Categories of updates which should be approved automatically by this rule.

Remarks

These Categories specify what updates the rule applies to. When an update belongs to one of these Categories and optionally one of the specified UpdateClassifications, it will be approved for the specified Action for the specified ComputerTargetGroups

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.SetComputerTargetGroups Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Specifies the target groups to which this automatic approval rule applies.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroups As ComputerTargetGroupCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
iAutomaticUpdateApprovalRule1.SetComputerTargetGroups(targetGroups)

Syntax

Visual Basic
Sub SetComputerTargetGroups( _
    ByVal targetGroups As ComputerTargetGroupCollection _
)
C#
void SetComputerTargetGroups(
    ComputerTargetGroupCollection targetGroups
);
C++
public:
virtual void SetComputerTargetGroups(
    ComputerTargetGroupCollection^ targetGroups
);
J#
public void SetComputerTargetGroups(
    ComputerTargetGroupCollection targetGroups
);
JScript
function SetComputerTargetGroups(
     targetGroups : ComputerTargetGroupCollection
) : Void;

Parameters

targetGroups

A ComputerTargetGroupCollection collection that contains the target groups to which this automatic approval rule applies.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroups cannot be null.

Remarks

To save your changes, call IAutomaticUpdateApprovalRule.Save.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members
Microsoft.UpdateServices.Administration Namespace
IAutomaticUpdateApprovalRule.GetComputerTargetGroups()


IAutomaticUpdateApprovalRule.SetUpdateClassifications Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Specifies the classification of updates for which you want to automatically create approvals.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateClassifications As UpdateClassificationCollection
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule
iAutomaticUpdateApprovalRule1.SetUpdateClassifications(updateClassifications)

Syntax

Visual Basic
Sub SetUpdateClassifications( _
    ByVal updateClassifications As UpdateClassificationCollection _
)
C#
void SetUpdateClassifications(
    UpdateClassificationCollection updateClassifications
);
C++
public:
virtual void SetUpdateClassifications(
    UpdateClassificationCollection^ updateClassifications
);
J#
public void SetUpdateClassifications(
    UpdateClassificationCollection updateClassifications
);
JScript
function SetUpdateClassifications(
     updateClassifications : UpdateClassificationCollection
) : Void;

Parameters

updateClassifications

An UpdateClassificationCollection collection that contains the classification of updates for which you want to automatically create approvals. For example, the rule applies to security update or critical updates.

Exceptions

Exception type | Condition
ArgumentNullException | updateClassifications cannot be null.

Remarks

To save your changes, call IAutomaticUpdateApprovalRule.Save.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members
Microsoft.UpdateServices.Administration Namespace
IAutomaticUpdateApprovalRule.GetUpdateClassifications


IAutomaticUpdateApprovalRule Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Action | Retrieves the type of action that the rule performs.
public property | Enabled | Retrieves or sets a value to enable or disable the automatic approval rule.
public property | Id | Get the Id of the AutomaticUpdateApproval Rule
public property | Name | Get or Set the name of the AutomaticUpdateApproval Rule

See Also

Reference

IAutomaticUpdateApprovalRule Interface


IAutomaticUpdateApprovalRule.Action Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the type of action that the rule performs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule

Dim returnValue As AutomaticUpdateApprovalAction
returnValue = iAutomaticUpdateApprovalRule1.Action

Syntax

Visual Basic
ReadOnly Property Action() As AutomaticUpdateApprovalAction
C#
AutomaticUpdateApprovalAction Action {get;}
C++
property virtual AutomaticUpdateApprovalAction Action {
    AutomaticUpdateApprovalAction get();
}
J#
public AutomaticUpdateApprovalAction get_Action();
JScript
function get Action() : AutomaticUpdateApprovalAction;

Property Value

Type of action that the rule performs. For example, this value specifies if the rule applies to installing the update on the client or scanning the client to determine if the update is applicable. For possible values, see AutomaticUpdateApprovalAction.

Remarks

This value is set when you call IUpdateServer.GetInstallApprovalRule or IUpdateServer.GetScanApprovalRule.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.Enabled Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value to enable or disable the automatic approval rule.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule

Dim returnValue As Boolean
returnValue = iAutomaticUpdateApprovalRule1.Enabled

Dim sampleValue As Boolean
iAutomaticUpdateApprovalRule1.Enabled = sampleValue

Syntax

Visual Basic
Property Enabled() As Boolean
C#
bool Enabled {get; set;}
C++
property virtual bool Enabled {
    bool get();
    void set(bool value);
}
J#
public boolean get_Enabled();
public void set_Enabled(boolean);
JScript
function get Enabled() : Boolean;
function set Enabled(Boolean);

Property Value

True enables the approval rule. False disables the approval rule.

Remarks

To save your changes, call IAutomaticUpdateApprovalRule.Save.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the Id of the AutomaticUpdateApproval Rule

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule

Dim returnValue As Integer
returnValue = iAutomaticUpdateApprovalRule1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Integer
C#
int Id {get;}
C++
property virtual int Id {
    int get();
}
J#
public int get_Id();
JScript
function get Id() : int;

Property Value

The Id of the AutomaticUpdateApproval Rule

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


IAutomaticUpdateApprovalRule.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get or Set the name of the AutomaticUpdateApproval Rule

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iAutomaticUpdateApprovalRule1 As IAutomaticUpdateApprovalRule

Dim returnValue As String
returnValue = iAutomaticUpdateApprovalRule1.Name

Dim sampleValue As String
iAutomaticUpdateApprovalRule1.Name = sampleValue

Syntax

Visual Basic
Property Name() As String
C#
string Name {get; set;}
C++
property virtual String^ Name {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Name();
public void set_Name(System.String);
JScript
function get Name() : String;
function set Name(String);

Property Value

The name of the AutomaticUpdateApproval Rule

Exceptions

Exception type | Condition
ArgumentNullException | Attempted to set this property to null. Use String.Empty instead.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IAutomaticUpdateApprovalRule Interface
IAutomaticUpdateApprovalRule Members


ICleanupManager Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class cleanupManagerImplementation
    Implements ICleanupManager
End Class
Dim cleanupManagerImplementation1 As New cleanupManagerImplementation()

Syntax

Visual Basic
Public Interface ICleanupManager
C#
public interface ICleanupManager
C++
public interface class ICleanupManager
J#
public interface ICleanupManager
JScript
public interface ICleanupManager

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ICleanupManager Members


ICleanupManager Members
See Also Events Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the ICleanupManager type.

Public Methods

 | Name | Description
public method | PerformCleanup | Perform the cleanup process.
Top

Public Events

 | Name | Description
public event | ProgressHandler | Progress event handler accepts delegates to be called during the Cleanup process
Top

See Also

Reference

ICleanupManager Interface


ICleanupManager Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | PerformCleanup | Perform the cleanup process.

See Also

Reference

ICleanupManager Interface


ICleanupManager.PerformCleanup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Perform the cleanup process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim cleanupScope As CleanupScope
Dim returnValue As CleanupResults
Dim iCleanupManager1 As ICleanupManager
returnValue = iCleanupManager1.PerformCleanup(cleanupScope)

Syntax

Visual Basic
Function PerformCleanup( _
    ByVal cleanupScope As CleanupScope _
) As CleanupResults
C#
CleanupResults PerformCleanup(
    CleanupScope cleanupScope
);
C++
public:
virtual CleanupResults^ PerformCleanup(
    CleanupScope^ cleanupScope
);
J#
public CleanupResults PerformCleanup(
    CleanupScope cleanupScope
);
JScript
function PerformCleanup(
     cleanupScope : CleanupScope
) : CleanupResults;

Parameters

cleanupScope

User selections of different items to be cleaned up, wrapped up in a CleanupScope object.

Return Value

Cleanup results wrapped in an object of CleanupResults class

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ICleanupManager Interface
ICleanupManager Members


ICleanupManager Events
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Events

 | Name | Description
public event | ProgressHandler | Progress event handler accepts delegates to be called during the Cleanup process

See Also

Reference

ICleanupManager Interface


ICleanupManager.ProgressHandler Event
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Progress event handler accepts delegates to be called during the Cleanup process

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
WithEvents iCleanupManager1 As ICleanupManager
Function iCleanupManager1_ProgressHandler(sender As Object, _
    e As CleanupEventArgs) As Void
    Handles iCleanupManager1.ProgressHandler
End Function

Syntax

Visual Basic
Event ProgressHandler As CleanupProgressEventHandler
C#
event CleanupProgressEventHandler ProgressHandler;
C++
event CleanupProgressEventHandler^ ProgressHandler;
J#
 void add_ProgressHandler(CleanupProgressEventHandler handler);
 void remove_ProgressHandler(CleanupProgressEventHandler handler);
JScript
In JScript, you can handle the events defined by a class, but you cannot define your own.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ICleanupManager Interface
ICleanupManager Members


IComputerTarget Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about the client computer, remove the client from WSUS, determine the group to which it belongs, and retrieve information related to updates approved for the client. To retrieve this interface, call one of the following methods: ComputerTargetCollection.Item; IUpdateEvent.GetComputer; IUpdateInstallationInfo.GetComputerTarget; IUpdateServer.GetComputerTarget; IUpdateServer.RegisterComputer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class computerTargetImplementation
    Implements IComputerTarget
End Class
Dim computerTargetImplementation1 As New computerTargetImplementation()

Syntax

Visual Basic
Public Interface IComputerTarget
C#
public interface IComputerTarget
C++
public interface class IComputerTarget
J#
public interface IComputerTarget
JScript
public interface IComputerTarget

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Members


IComputerTarget Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about the client computer, remove the client from WSUS, determine the group to which it belongs, and retrieve information related to updates approved for the client. To retrieve this interface, call one of the following methods: ComputerTargetCollection.Item; IUpdateEvent.GetComputer; IUpdateInstallationInfo.GetComputerTarget; IUpdateServer.GetComputerTarget; IUpdateServer.RegisterComputer.

The following tables list the members exposed by the IComputerTarget type.

Public Properties

 | Name | Description
public property | BiosInfo | Retrieves the BIOS information of the client.
public property | FullDomainName | Retrieves the full domain name of the client.
public property | Id | Retrieves the unique identifier of the client computer.
public property | IPAddress | Retrieves the IP address of the client.
public property | LastReportedInventoryTime | Get the UTC time that the ComputerTarget last reported inventory to this server.
public property | LastReportedStatusTime | Retrieves the last time the client sent its status to the WSUS server.
public property | LastSyncResult | Get the UTC time that the ComputerTarget last reported inventory to this server.
public property | LastSyncTime | Retrieves the last time the client synchronized itself with the WSUS server.
public property | Make | Retrieves the make of the client computer.
public property | Model | Retrieves the model of the client computer.
public property | OSInfo | Retrieves the operating system information of the client computer.
public property | ParentServerId | Get the ID of the WSUS server the client last synced from.
public property | ProcessorArchitecture | Retrieves the processor architecture of the client computer.
public property | RequestedTargetGroupName | Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.
public property | RequestedTargetGroupNames | Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.
public property | SyncsFromDownstreamServer | Get the value indicating whether the client syncs from a downstream server, or from this server.
Top

Public Methods

 | Name | Description
public method | Delete | Removes the client computer from the list of clients known to WSUS.
public method | GetComputerTargetGroup | Retrieves the target group to which the client belongs.
public method | GetComputerTargetGroups | Get the target groups to which this ComputerTarget belongs.
public method | GetHashCode | Serves as a hash function for the current ComputerTarget, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInventory | Overloaded.
public method | GetParentServer | Gets the server from which this ComputerTarget last synchronized.
public method | GetUpdateInstallationInfoPerUpdate | Overloaded.
public method | GetUpdateInstallationSummary | Overloaded.
public method | PurgeAssociatedReportingEvents | Removes the events that are associated with the client.
Top

See Also

Reference

IComputerTarget Interface


IComputerTarget Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | Delete | Removes the client computer from the list of clients known to WSUS.
public method | GetComputerTargetGroup | Retrieves the target group to which the client belongs.
public method | GetComputerTargetGroups | Get the target groups to which this ComputerTarget belongs.
public method | GetHashCode | Serves as a hash function for the current ComputerTarget, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInventory | Overloaded.
public method | GetParentServer | Gets the server from which this ComputerTarget last synchronized.
public method | GetUpdateInstallationInfoPerUpdate | Overloaded.
public method | GetUpdateInstallationSummary | Overloaded.
public method | PurgeAssociatedReportingEvents | Removes the events that are associated with the client.

See Also

Reference

IComputerTarget Interface


IComputerTarget.Delete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the client computer from the list of clients known to WSUS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget
iComputerTarget1.Delete()

Syntax

Visual Basic
Sub Delete()
C#
void Delete();
C++
public:
virtual void Delete();
J#
public void Delete();
JScript
function Delete() : Void;

Remarks

The client is also removed from any group to which it belongs.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the target group to which the client belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTargetGroup
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetComputerTargetGroup()

Syntax

Visual Basic
Function GetComputerTargetGroup() As IComputerTargetGroup
C#
IComputerTargetGroup GetComputerTargetGroup();
C++
public:
virtual IComputerTargetGroup^ GetComputerTargetGroup();
J#
public IComputerTargetGroup GetComputerTargetGroup();
JScript
function GetComputerTargetGroup() : IComputerTargetGroup;

Return Value

An IComputerTargetGroup to which the client belongs.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer was not found in the database.

Remarks

By default, all clients are members of the All Computers target group. The client can also be explicitly assigned to one other target group. The method returns the group to which the client is explicitly assigned or the Unassigned Computers target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetComputerTargetGroups Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the target groups to which this ComputerTarget belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetGroupCollection
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetComputerTargetGroups()

Syntax

Visual Basic
Function GetComputerTargetGroups() As ComputerTargetGroupCollection
C#
ComputerTargetGroupCollection GetComputerTargetGroups();
C++
public:
virtual ComputerTargetGroupCollection^ GetComputerTargetGroups();
J#
public ComputerTargetGroupCollection GetComputerTargetGroups();
JScript
function GetComputerTargetGroups() : ComputerTargetGroupCollection;

Return Value

The collection of target groups to which this ComputerTarget belongs.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer was not found in the database.

Remarks

If the ComputerTarget is not explicitly a member of any target group, the unassigned target group will be returned. This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current ComputerTarget, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current ComputerTarget.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetInventory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTarget.GetInventory () | Returns a collection of inventory items for this computer. All inventory items are returned.
IComputerTarget.GetInventory (String[]) | Returns a collection of inventory items for this computer. The inventoryClasses argument defines the classes to return. Returns an empty list if passed an empty array. Throws ArgumentNullException if passed null.

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetInventory Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Returns a collection of inventory items for this computer. All inventory items are returned.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ReadOnlyCollection(Of IInventoryItem)
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetInventory()

Syntax

Visual Basic
Function GetInventory() As ReadOnlyCollection(Of IInventoryItem)
C#
ReadOnlyCollection<IInventoryItem> GetInventory();
C++
public:
virtual ReadOnlyCollection<IInventoryItem^>^ GetInventory();
J#
public ReadOnlyCollection<IInventoryItem> GetInventory();
JScript
function GetInventory() : JScript does not support Generics.;

Return Value

Collection of inventory items for this computer.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer was not found in the database.

Remarks

This operation requires WSUS Reporter privileges

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetInventory Method (String[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Returns a collection of inventory items for this computer. The inventoryClasses argument defines the classes to return. Returns an empty list if passed an empty array. Throws ArgumentNullException if passed null.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim inventoryClasses() As String
Dim returnValue As ReadOnlyCollection(Of IInventoryItem)
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetInventory(inventoryClasses)

Syntax

Visual Basic
Function GetInventory( _
    ByVal inventoryClasses() As String _
) As ReadOnlyCollection(Of IInventoryItem)
C#
ReadOnlyCollection<IInventoryItem> GetInventory(
    string[] inventoryClasses
);
C++
public:
virtual ReadOnlyCollection<IInventoryItem^>^ GetInventory(
    array<String^>^ inventoryClasses
);
J#
public ReadOnlyCollection<IInventoryItem> GetInventory(
    System.String[] inventoryClasses
);
JScript
function GetInventory(
     inventoryClasses : String[]
) : JScript does not support Generics.;

Parameters

inventoryClasses

WMI classes of inventory items.

Return Value

Collection of InventoryItems of the types specified in inventoryClasses, present on this computer.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetParentServer Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the server from which this ComputerTarget last synchronized.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IDownstreamServer
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetParentServer()

Syntax

Visual Basic
Function GetParentServer() As IDownstreamServer
C#
IDownstreamServer GetParentServer();
C++
public:
virtual IDownstreamServer^ GetParentServer();
J#
public IDownstreamServer GetParentServer();
JScript
function GetParentServer() : IDownstreamServer;

Return Value

The downstream server from which this ComputerTarget last synchronized.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The parent server could not be found in the database.
InvalidOperationException | SyncsFromDownstreamServer is false.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationInfoPerUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTarget.GetUpdateInstallationInfoPerUpdate () | Retrieves the installation state for all approved updates.
IComputerTarget.GetUpdateInstallationInfoPerUpdate (UpdateScope) | Gets installation information for all updates matching the specified search filter for this ComputerTarget.
IComputerTarget.GetUpdateInstallationInfoPerUpdate (UpdateTypes) | Gets installation information for all updates of the specified type for this ComputerTarget. Updates with at least one approval are included, even if the update is not approved for this particular target group.

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationInfoPerUpdate Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the installation state for all approved updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateInstallationInfoCollection
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetUpdateInstallationInfoPerUpdate()

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerUpdate() As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate();
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerUpdate();
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate();
JScript
function GetUpdateInstallationInfoPerUpdate() : UpdateInstallationInfoCollection;

Return Value

An UpdateInstallationInfoCollection collection that contains the installation state for all approved updates.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Cannot find update installation information for the client computer.

Remarks

The collection may include installation status for updates that were not approved for deployment to the target group to which this client belongs. For example, if the WSUS server contains 10 updates (five approved for the group to which this client belongs and three approved for another group), at least three of the updates will have an Unknown installation state.

Other updates could also contain an Unknown installation state if the client was unable to report the status for the update. You can call IUpdate.GetUpdateApprovals(IComputerTargetGroup) to determine if the update is deployed to this group so you know for certain which case the state represents.

If you want to know if the update was approved for deployment to this client, call IUpdate.GetUpdateApprovals(IComputerTargetGroup).

Including updates that are not approved for deployment to this client provides you with visibility of those updates that you may want to approve for deployment to the client's target group in the future.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationInfoPerUpdate Method (UpdateScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets installation information for all updates matching the specified search filter for this ComputerTarget.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updatesToInclude As UpdateScope
Dim returnValue As UpdateInstallationInfoCollection
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetUpdateInstallationInfoPerUpdate(updatesToInclude)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerUpdate( _
    ByVal updatesToInclude As UpdateScope _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate(
    UpdateScope updatesToInclude
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerUpdate(
    UpdateScope^ updatesToInclude
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate(
    UpdateScope updatesToInclude
);
JScript
function GetUpdateInstallationInfoPerUpdate(
     updatesToInclude : UpdateScope
) : UpdateInstallationInfoCollection;

Parameters

updatesToInclude

Search criteria defining the set of updates to return status for.

Return Value

A collection containing one entry for each update.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer could not be found in the database.
ArgumentNullException | updatesToInclude is null.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationInfoPerUpdate Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets installation information for all updates of the specified type for this ComputerTarget. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateInstallationInfoCollection
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetUpdateInstallationInfoPerUpdate(updateTypes)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerUpdate( _
    ByVal updateTypes As UpdateTypes _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerUpdate(
    UpdateTypes updateTypes
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerUpdate(
    UpdateTypes updateTypes
);
JScript
function GetUpdateInstallationInfoPerUpdate(
     updateTypes : UpdateTypes
) : UpdateInstallationInfoCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each update.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationSummary Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTarget.GetUpdateInstallationSummary () | Gets the installation summary for all drivers and software updates on this computer.
IComputerTarget.GetUpdateInstallationSummary (UpdateTypes) | Gets the installation summary for all updates of the specified type on this computer.

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationSummary Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the installation summary for all drivers and software updates on this computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateSummary
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetUpdateInstallationSummary()

Syntax

Visual Basic
Function GetUpdateInstallationSummary() As IUpdateSummary
C#
IUpdateSummary GetUpdateInstallationSummary();
C++
public:
virtual IUpdateSummary^ GetUpdateInstallationSummary();
J#
public IUpdateSummary GetUpdateInstallationSummary();
JScript
function GetUpdateInstallationSummary() : IUpdateSummary;

Return Value

One summary with counts summed across all drivers and software updates on this computer.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer could not be found in the database.

Remarks

This is equivalent to GetUpdateInstallationSummary(UpdateTypes.Driver (Driver) | UpdateTypes.SoftwareUpdate(SoftwareUpdate)).

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.GetUpdateInstallationSummary Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the installation summary for all updates of the specified type on this computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As IUpdateSummary
Dim iComputerTarget1 As IComputerTarget
returnValue = iComputerTarget1.GetUpdateInstallationSummary(updateTypes)

Syntax

Visual Basic
Function GetUpdateInstallationSummary( _
    ByVal updateTypes As UpdateTypes _
) As IUpdateSummary
C#
IUpdateSummary GetUpdateInstallationSummary(
    UpdateTypes updateTypes
);
C++
public:
virtual IUpdateSummary^ GetUpdateInstallationSummary(
    UpdateTypes updateTypes
);
J#
public IUpdateSummary GetUpdateInstallationSummary(
    UpdateTypes updateTypes
);
JScript
function GetUpdateInstallationSummary(
     updateTypes : UpdateTypes
) : IUpdateSummary;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

One summary with counts summed across all updates on this computer.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.PurgeAssociatedReportingEvents Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the events that are associated with the client.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim iComputerTarget1 As IComputerTarget
iComputerTarget1.PurgeAssociatedReportingEvents(fromDate, toDate)

Syntax

Visual Basic
Sub PurgeAssociatedReportingEvents( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
)
C#
void PurgeAssociatedReportingEvents(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual void PurgeAssociatedReportingEvents(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public void PurgeAssociatedReportingEvents(
    DateTime fromDate,
    DateTime toDate
);
JScript
function PurgeAssociatedReportingEvents(
     fromDate : DateTime,
     toDate : DateTime
) : Void;

Parameters

fromDate

Begin date used to remove events that are associated with the client. Specify the date in Coordinated Universal Time.

toDate

End date used to remove events that are associated with the client. Specify the date in Coordinated Universal Time.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate must be less than toDate.

Remarks

Typically, events are removed based on the IUpdateServerConfiguration.ServerEventExpirationTime configuration setting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | BiosInfo | Retrieves the BIOS information of the client.
public property | FullDomainName | Retrieves the full domain name of the client.
public property | Id | Retrieves the unique identifier of the client computer.
public property | IPAddress | Retrieves the IP address of the client.
public property | LastReportedInventoryTime | Get the UTC time that the ComputerTarget last reported inventory to this server.
public property | LastReportedStatusTime | Retrieves the last time the client sent its status to the WSUS server.
public property | LastSyncResult | Get the UTC time that the ComputerTarget last reported inventory to this server.
public property | LastSyncTime | Retrieves the last time the client synchronized itself with the WSUS server.
public property | Make | Retrieves the make of the client computer.
public property | Model | Retrieves the model of the client computer.
public property | OSInfo | Retrieves the operating system information of the client computer.
public property | ParentServerId | Get the ID of the WSUS server the client last synced from.
public property | ProcessorArchitecture | Retrieves the processor architecture of the client computer.
public property | RequestedTargetGroupName | Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.
public property | RequestedTargetGroupNames | Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.
public property | SyncsFromDownstreamServer | Get the value indicating whether the client syncs from a downstream server, or from this server.

See Also

Reference

IComputerTarget Interface


IComputerTarget.BiosInfo Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the BIOS information of the client.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As BiosInfo
returnValue = iComputerTarget1.BiosInfo

Syntax

Visual Basic
ReadOnly Property BiosInfo() As BiosInfo
C#
BiosInfo BiosInfo {get;}
C++
property virtual BiosInfo^ BiosInfo {
    BiosInfo^ get();
}
J#
public BiosInfo get_BiosInfo();
JScript
function get BiosInfo() : BiosInfo;

Property Value

A BiosInfo class that contains the BIOS information of the client.

Remarks

The BIOS information may not exist if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.FullDomainName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the full domain name of the client.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.FullDomainName

Syntax

Visual Basic
ReadOnly Property FullDomainName() As String
C#
string FullDomainName {get;}
C++
property virtual String^ FullDomainName {
    String^ get();
}
J#
public System.String get_FullDomainName();
JScript
function get FullDomainName() : String;

Property Value

Full domain name of the client.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.Id

Syntax

Visual Basic
ReadOnly Property Id() As String
C#
string Id {get;}
C++
property virtual String^ Id {
    String^ get();
}
J#
public System.String get_Id();
JScript
function get Id() : String;

Property Value

Unique identifier of the client computer.

Remarks

WSUS sets the identifier value when:

  • You call IUpdateServer.RegisterComputer to register a client computer

  • The client first contacts the WSUS server to register itself

Note that when you call IUpdateServer.RegisterComputer, WSUS creates a temporary Id value for the client. When the client first contacts the WSUS server, WSUS changes the identifier to the client's identifier value. If you try to retrieve the client using the temporary value after WSUS changes the identifier, you will receive a WsusObjectNotFoundException exception.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.IPAddress Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the IP address of the client.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As IPAddress
returnValue = iComputerTarget1.IPAddress

Syntax

Visual Basic
ReadOnly Property IPAddress() As IPAddress
C#
IPAddress IPAddress {get;}
C++
property virtual IPAddress^ IPAddress {
    IPAddress^ get();
}
J#
public IPAddress get_IPAddress();
JScript
function get IPAddress() : IPAddress;

Property Value

IP address of the client. For details, see System.Net.IPAddress.

Remarks

The IP address is System.Net.IPAddress.None if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.LastReportedInventoryTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the UTC time that the ComputerTarget last reported inventory to this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As DateTime
returnValue = iComputerTarget1.LastReportedInventoryTime

Syntax

Visual Basic
ReadOnly Property LastReportedInventoryTime() As DateTime
C#
DateTime LastReportedInventoryTime {get;}
C++
property virtual DateTime^ LastReportedInventoryTime {
    DateTime^ get();
}
J#
public DateTime get_LastReportedInventoryTime();
JScript
function get LastReportedInventoryTime() : DateTime;

Property Value

The UTC time that the ComputerTarget last reported inventory to this server.

Remarks

DateTime.MinValue means the ComputerTarget has never reported inventory to this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.LastReportedStatusTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last time the client sent its status to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As DateTime
returnValue = iComputerTarget1.LastReportedStatusTime

Syntax

Visual Basic
ReadOnly Property LastReportedStatusTime() As DateTime
C#
DateTime LastReportedStatusTime {get;}
C++
property virtual DateTime^ LastReportedStatusTime {
    DateTime^ get();
}
J#
public DateTime get_LastReportedStatusTime();
JScript
function get LastReportedStatusTime() : DateTime;

Property Value

Last time the client sent its status to the WSUS server. The date is in Coordinated Universal Time. DateTime.MinValue means the client has never sent its status to the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.LastSyncResult Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the UTC time that the ComputerTarget last reported inventory to this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As SynchronizationResult
returnValue = iComputerTarget1.LastSyncResult

Syntax

Visual Basic
ReadOnly Property LastSyncResult() As SynchronizationResult
C#
SynchronizationResult LastSyncResult {get;}
C++
property virtual SynchronizationResult LastSyncResult {
    SynchronizationResult get();
}
J#
public SynchronizationResult get_LastSyncResult();
JScript
function get LastSyncResult() : SynchronizationResult;

Property Value

The UTC time that the ComputerTarget last reported inventory to this server.

Remarks

DateTime.MinValue means the ComputerTarget has never reported inventory to this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.LastSyncTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last time the client synchronized itself with the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As DateTime
returnValue = iComputerTarget1.LastSyncTime

Syntax

Visual Basic
ReadOnly Property LastSyncTime() As DateTime
C#
DateTime LastSyncTime {get;}
C++
property virtual DateTime^ LastSyncTime {
    DateTime^ get();
}
J#
public DateTime get_LastSyncTime();
JScript
function get LastSyncTime() : DateTime;

Property Value

Last time the client synchronized itself with the WSUS server. The date is in Coordinated Universal Time. DateTime.MinValue means the client has never synchronized itself with the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.Make Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the make of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.Make

Syntax

Visual Basic
ReadOnly Property Make() As String
C#
string Make {get;}
C++
property virtual String^ Make {
    String^ get();
}
J#
public System.String get_Make();
JScript
function get Make() : String;

Property Value

Make of the client computer.

Remarks

The value is String.Empty if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.Model Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the model of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.Model

Syntax

Visual Basic
ReadOnly Property Model() As String
C#
string Model {get;}
C++
property virtual String^ Model {
    String^ get();
}
J#
public System.String get_Model();
JScript
function get Model() : String;

Property Value

Model of the client computer.

Remarks

The value is String.Empty if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.OSInfo Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the operating system information of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As OSInfo
returnValue = iComputerTarget1.OSInfo

Syntax

Visual Basic
ReadOnly Property OSInfo() As OSInfo
C#
OSInfo OSInfo {get;}
C++
property virtual OSInfo^ OSInfo {
    OSInfo^ get();
}
J#
public OSInfo get_OSInfo();
JScript
function get OSInfo() : OSInfo;

Property Value

Operating system information of the client computer. For details, see OSInfo.

Remarks

The operating system information may not exist (version information is zero and the value for the user interface language is String.Empty) if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.ParentServerId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the ID of the WSUS server the client last synced from.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As Guid
returnValue = iComputerTarget1.ParentServerId

Syntax

Visual Basic
ReadOnly Property ParentServerId() As Guid
C#
Guid ParentServerId {get;}
C++
property virtual Guid^ ParentServerId {
    Guid^ get();
}
J#
public Guid get_ParentServerId();
JScript
function get ParentServerId() : Guid;

Property Value

The ID of the downstream WSUS server the client last synced from, or Guid.Empty if the client syncs directly from this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.ProcessorArchitecture Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the processor architecture of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.ProcessorArchitecture

Syntax

Visual Basic
ReadOnly Property ProcessorArchitecture() As String
C#
string ProcessorArchitecture {get;}
C++
property virtual String^ ProcessorArchitecture {
    String^ get();
}
J#
public System.String get_ProcessorArchitecture();
JScript
function get ProcessorArchitecture() : String;

Property Value

Processor architecture of the client computer.

Remarks

The value is String.Empty if the client has not yet contacted the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.RequestedTargetGroupName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As String
returnValue = iComputerTarget1.RequestedTargetGroupName

Syntax

Visual Basic
ReadOnly Property RequestedTargetGroupName() As String
C#
string RequestedTargetGroupName {get;}
C++
property virtual String^ RequestedTargetGroupName {
    String^ get();
}
J#
public System.String get_RequestedTargetGroupName();
JScript
function get RequestedTargetGroupName() : String;

Property Value

The name of the ComputerTargetGroup that this ComputerTarget claims to be a member of, or String.Empty if the ComputerTarget has not reported a membership to this server. If the ComputerTarget has claimed multiple ComputerTargetGroups, then one of those groups is chosen arbitrarily for this property. This value is for informational purposes. Administrators may choose to use this value to see which ComputerTargetGroups should be created on this server.

Remarks

This value is for informational purposes only. Administrators can use this value to create the appropriate groups on the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.RequestedTargetGroupNames Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the name of the ComputerTargetGroup that this ComputerTarget claims to be a member of.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As StringCollection
returnValue = iComputerTarget1.RequestedTargetGroupNames

Syntax

Visual Basic
ReadOnly Property RequestedTargetGroupNames() As StringCollection
C#
StringCollection RequestedTargetGroupNames {get;}
C++
property virtual StringCollection^ RequestedTargetGroupNames {
    StringCollection^ get();
}
J#
public StringCollection get_RequestedTargetGroupNames();
JScript
function get RequestedTargetGroupNames() : StringCollection;

Property Value

The name of the ComputerTargetGroup that this ComputerTarget claims to be a member of, or String.Empty if the ComputerTarget has not reported a membership to this server. If the ComputerTarget has claimed multiple ComputerTargetGroups, then one of those groups is chosen arbitrarily for this property. This value is for informational purposes. Admins may choose to use this value to see which ComputerTargetGroups should be created on this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTarget.SyncsFromDownstreamServer Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the value indicating whether the client syncs from a downstream server, or from this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTarget1 As IComputerTarget

Dim returnValue As Boolean
returnValue = iComputerTarget1.SyncsFromDownstreamServer

Syntax

Visual Basic
ReadOnly Property SyncsFromDownstreamServer() As Boolean
C#
bool SyncsFromDownstreamServer {get;}
C++
property virtual bool SyncsFromDownstreamServer {
    bool get();
}
J#
public boolean get_SyncsFromDownstreamServer();
JScript
function get SyncsFromDownstreamServer() : Boolean;

Property Value

true if the client syncs from a downstreamserver; false if it syncs from this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTarget Interface
IComputerTarget Members


IComputerTargetGroup Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to add clients to or remove clients from the target group, delete the group, or retrieve installation results for client members. To retrieve this interface, call the following methods: P:Microsoft.UpdateServices.Administration.ComputerTargetGroupCollection.Item(System.Int32); GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassGetComputerTargetGroupTopic; GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateApprovalClassGetComputerTargetGroupTopic; CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class computerTargetGroupImplementation
    Implements IComputerTargetGroup
End Class
Dim computerTargetGroupImplementation1 As New computerTargetGroupImplementation()

Syntax

Visual Basic
Public Interface IComputerTargetGroup
C#
public interface IComputerTargetGroup
C++
public interface class IComputerTargetGroup
J#
public interface IComputerTargetGroup
JScript
public interface IComputerTargetGroup

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Members


IComputerTargetGroup Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to add clients to or remove clients from the target group, delete the group, or retrieve installation results for client members. To retrieve this interface, call the following methods: P:Microsoft.UpdateServices.Administration.ComputerTargetGroupCollection.Item(System.Int32); GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassGetComputerTargetGroupTopic; GetComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateApprovalClassGetComputerTargetGroupTopic; CreateComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassCreateComputerTargetGroupTopic frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetComputerTargetGroupTopic.

The following tables list the members exposed by the IComputerTargetGroup type.

Public Properties

 | Name | Description
public property | Id | Retrieves the unique identifier of the target group.
public property | Name | Retrieves the name of the group.
Top

Public Methods

 | Name | Description
public method | AddComputerTarget | Adds a client computer to the target group.
public method | Delete | Removes the target group from the list of groups known to WSUS.
public method | GetChildTargetGroups | Get the list of ComputerTargetGroups that are belong to this ComputerTargetGroup
public method | GetComputerTargets | Overloaded.
public method | GetComputerTargetsWithInventory | Returns a collection of computers that have reported the requested inventory item.
public method | GetHashCode | Serves as a hash function for the current ComputerTargetGroup, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInventorySummary | Returns a collection of inventory items summed across this target group.
public method | GetParentTargetGroup | Get the parent ComputerTargetGroup
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdateInstallationInfoPerComputerTarget | Overloaded.
public method | RemoveComputerTarget | Removes a client computer from the target group.
Top

See Also

Reference

IComputerTargetGroup Interface


IComputerTargetGroup Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | AddComputerTarget | Adds a client computer to the target group.
public method | Delete | Removes the target group from the list of groups known to WSUS.
public method | GetChildTargetGroups | Get the list of ComputerTargetGroups that are belong to this ComputerTargetGroup
public method | GetComputerTargets | Overloaded.
public method | GetComputerTargetsWithInventory | Returns a collection of computers that have reported the requested inventory item.
public method | GetHashCode | Serves as a hash function for the current ComputerTargetGroup, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInventorySummary | Returns a collection of inventory items summed across this target group.
public method | GetParentTargetGroup | Get the parent ComputerTargetGroup
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdateInstallationInfoPerComputerTarget | Overloaded.
public method | RemoveComputerTarget | Removes a client computer from the target group.

See Also

Reference

IComputerTargetGroup Interface


IComputerTargetGroup.AddComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a client computer to the target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim target As IComputerTarget
Dim iComputerTargetGroup1 As IComputerTargetGroup
iComputerTargetGroup1.AddComputerTarget(target)

Syntax

Visual Basic
Sub AddComputerTarget( _
    ByVal target As IComputerTarget _
)
C#
void AddComputerTarget(
    IComputerTarget target
);
C++
public:
virtual void AddComputerTarget(
    IComputerTarget^ target
);
J#
public void AddComputerTarget(
    IComputerTarget target
);
JScript
function AddComputerTarget(
     target : IComputerTarget
) : Void;

Parameters

target

An IComputerTarget of the client computer to add to the target group.

Exceptions

Exception type | Condition
ArgumentNullException | target cannot be null.

Remarks

The client computer is moved from its current group to this group. If the client is currently not explicitly assigned to a group, the client is moved from the Unassigned Computers group to this group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.Delete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the target group from the list of groups known to WSUS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTargetGroup1 As IComputerTargetGroup
iComputerTargetGroup1.Delete()

Syntax

Visual Basic
Sub Delete()
C#
void Delete();
C++
public:
virtual void Delete();
J#
public void Delete();
JScript
function Delete() : Void;

Exceptions

Exception type Condition
InvalidOperationException

You can receive this exception for one of the following reasons:

  • You cannot delete the All Computers or Unassigned Computers target group.

  • You cannot delete the target group if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Remarks

When you remove the group, the clients in the group are moved to the Unassigned Computers group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetChildTargetGroups Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the list of ComputerTargetGroups that are belong to this ComputerTargetGroup

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetGroupCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetChildTargetGroups()

Syntax

Visual Basic
Function GetChildTargetGroups() As ComputerTargetGroupCollection
C#
ComputerTargetGroupCollection GetChildTargetGroups();
C++
public:
virtual ComputerTargetGroupCollection^ GetChildTargetGroups();
J#
public ComputerTargetGroupCollection GetChildTargetGroups();
JScript
function GetChildTargetGroups() : ComputerTargetGroupCollection;

Return Value

The list of ComputerTargetGroups that are belong to this ComputerTargetGroup

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetComputerTargets Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTargetGroup.GetComputerTargets () | Retrieves a list of client computers that are assigned to the group.
IComputerTargetGroup.GetComputerTargets (Boolean) | Get the list of ComputerTargets in the ComputerTargetGroup

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetComputerTargets Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of client computers that are assigned to the group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetComputerTargets()

Syntax

Visual Basic
Function GetComputerTargets() As ComputerTargetCollection
C#
ComputerTargetCollection GetComputerTargets();
C++
public:
virtual ComputerTargetCollection^ GetComputerTargets();
J#
public ComputerTargetCollection GetComputerTargets();
JScript
function GetComputerTargets() : ComputerTargetCollection;

Return Value

A ComputerTargetCollection collection that contains the client computers that are assigned to the group.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The target group has been deleted.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetComputerTargets Method (Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the list of ComputerTargets in the ComputerTargetGroup

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim includeSubgroups As Boolean
Dim returnValue As ComputerTargetCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetComputerTargets(includeSubgroups)

Syntax

Visual Basic
Function GetComputerTargets( _
    ByVal includeSubgroups As Boolean _
) As ComputerTargetCollection
C#
ComputerTargetCollection GetComputerTargets(
    bool includeSubgroups
);
C++
public:
virtual ComputerTargetCollection^ GetComputerTargets(
    bool includeSubgroups
);
J#
public ComputerTargetCollection GetComputerTargets(
    boolean includeSubgroups
);
JScript
function GetComputerTargets(
     includeSubgroups : Boolean
) : ComputerTargetCollection;

Parameters

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

The list of ComputerTargets in the ComputerTargetGroup

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetComputerTargetsWithInventory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Returns a collection of computers that have reported the requested inventory item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim scope As InventoryScope
Dim propertyValue As Object
Dim includeSubgroups As Boolean
Dim returnValue As ComputerTargetCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetComputerTargetsWithInventory(scope, propertyValue, includeSubgroups)

Syntax

Visual Basic
Function GetComputerTargetsWithInventory( _
    ByVal scope As InventoryScope, _
    ByVal propertyValue As Object, _
    ByVal includeSubgroups As Boolean _
) As ComputerTargetCollection
C#
ComputerTargetCollection GetComputerTargetsWithInventory(
    InventoryScope scope,
    object propertyValue,
    bool includeSubgroups
);
C++
public:
virtual ComputerTargetCollection^ GetComputerTargetsWithInventory(
    InventoryScope^ scope,
    Object^ propertyValue,
    bool includeSubgroups
);
J#
public ComputerTargetCollection GetComputerTargetsWithInventory(
    InventoryScope scope,
    System.Object propertyValue,
    boolean includeSubgroups
);
JScript
function GetComputerTargetsWithInventory(
     scope : InventoryScope,
     propertyValue : Object,
     includeSubgroups : Boolean
) : ComputerTargetCollection;

Parameters

scope

Defines the class and property to look for.

propertyValue

The value of the property to match.

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

A collection of computers that have reported the requested inventory item.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.
ArgumentNullException | scope cannot be null.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current ComputerTargetGroup, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current ComputerTargetGroup.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetInventorySummary Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Returns a collection of inventory items summed across this target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim scopes() As InventoryScope
Dim includeSubgroups As Boolean
Dim returnValue As ReadOnlyCollection(Of IInventoryItem)
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetInventorySummary(scopes, includeSubgroups)

Syntax

Visual Basic
Function GetInventorySummary( _
    ByVal scopes() As InventoryScope, _
    ByVal includeSubgroups As Boolean _
) As ReadOnlyCollection(Of IInventoryItem)
C#
ReadOnlyCollection<IInventoryItem> GetInventorySummary(
    InventoryScope[] scopes,
    bool includeSubgroups
);
C++
public:
virtual ReadOnlyCollection<IInventoryItem^>^ GetInventorySummary(
    array<InventoryScope^>^ scopes,
    bool includeSubgroups
);
J#
public ReadOnlyCollection<IInventoryItem> GetInventorySummary(
    InventoryScope[] scopes,
    boolean includeSubgroups
);
JScript
function GetInventorySummary(
     scopes : InventoryScope[],
     includeSubgroups : Boolean
) : JScript does not support Generics.;

Parameters

scopes

The classes to return summaries for, and which properties to summarize by.

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

Empty if passed an empty list; throws ArgumentNullException if passed null.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.
ArgumentNullException | scopes cannot be a null reference.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetParentTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the parent ComputerTargetGroup

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTargetGroup
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetParentTargetGroup()

Syntax

Visual Basic
Function GetParentTargetGroup() As IComputerTargetGroup
C#
IComputerTargetGroup GetParentTargetGroup();
C++
public:
virtual IComputerTargetGroup^ GetParentTargetGroup();
J#
public IComputerTargetGroup GetParentTargetGroup();
JScript
function GetParentTargetGroup() : IComputerTargetGroup;

Return Value

The parent ComputerTargetGroup

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.
InvalidOperationException | ComputerTargetGroup cannot be the All Computers group.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetSummaryPerUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTargetGroup.GetSummaryPerUpdate () | Retrieves the summary installation counts for all approved updates.
IComputerTargetGroup.GetSummaryPerUpdate (UpdateTypes) | Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.
IComputerTargetGroup.GetSummaryPerUpdate (UpdateTypes, Boolean) | Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetSummaryPerUpdate Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the summary installation counts for all approved updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetSummaryPerUpdate()

Syntax

Visual Basic
Function GetSummaryPerUpdate() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate();
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate();
J#
public UpdateSummaryCollection GetSummaryPerUpdate();
JScript
function GetSummaryPerUpdate() : UpdateSummaryCollection;

Return Value

An UpdateSummaryCollection collection that contains summary installation counts for all approved updates. The results are summarized by update (each member of the collection represents an approved update). For example, for each update, the collection provides the number of clients in this group that have successfully installed the update.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Summary information for the target group is not available.

Remarks

The collection may include updates that were not approved for deployment to this target group. For example, if the WSUS server contains 10 updates with eight updates being approved for deployment (five are approved for deployment to this group and three are approved for deployment to another group), this method would return an UpdateSummaryCollection collection that contains eight members.

If the update was not approved for deployment to this group of computers, the value for IUpdateSummary.UnknownCount should be equal to the number of clients in this group.

The UnknownCount also represents those clients in this group that have not reported their status. You can call IUpdate.GetUpdateApprovals(IComputerTargetGroup) to determine if the update is deployed to this group so that you will know for certain as to which state the count represents. However, if the unknown count is less than the number of clients in this group, then the update was approved for deployment to this group.

To retrieve summary information that sums the results for all updates that are deployed to all clients in the group, call IComputerTargetGroup.GetTotalSummary.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetSummaryPerUpdate Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetSummaryPerUpdate(updateTypes)

Syntax

Visual Basic
Function GetSummaryPerUpdate( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
JScript
function GetSummaryPerUpdate(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each update for this ComputerTargetGroup, each with counts summed across all ComputerTargets in this ComputerTargetGroup.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetSummaryPerUpdate Method (UpdateTypes, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim includeSubgroups As Boolean
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetSummaryPerUpdate(updateTypes, includeSubgroups)

Syntax

Visual Basic
Function GetSummaryPerUpdate( _
    ByVal updateTypes As UpdateTypes, _
    ByVal includeSubgroups As Boolean _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
J#
public UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes,
    boolean includeSubgroups
);
JScript
function GetSummaryPerUpdate(
     updateTypes : UpdateTypes,
     includeSubgroups : Boolean
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

collection containing one entry for each update for this ComputerTargetGroup, each with counts summed across all ComputerTargets in this ComputerTargetGroup.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummary Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTargetGroup.GetTotalSummary () | Retrieves the summary installation counts for all approved updates.
IComputerTargetGroup.GetTotalSummary (UpdateTypes) | Get one summary summed across all updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.
IComputerTargetGroup.GetTotalSummary (UpdateTypes, Boolean) | Get one summary, summed across all updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummary Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the summary installation counts for all approved updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateSummary
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummary()

Syntax

Visual Basic
Function GetTotalSummary() As IUpdateSummary
C#
IUpdateSummary GetTotalSummary();
C++
public:
virtual IUpdateSummary^ GetTotalSummary();
J#
public IUpdateSummary GetTotalSummary();
JScript
function GetTotalSummary() : IUpdateSummary;

Return Value

An IUpdateSummary that provides summary installation counts for all approved updates on all clients in the group. For example, the summary shows the total number of updates that were successfully installed on all clients in the group.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Summary information for the target group is not available.

Remarks

The IUpdateSummary.UnknownCount count may include updates that were not approved for deployment to clients in this target group. For example, if the WSUS server contains 10 updates (five are approved for deployment to this group and three are approved for deployment to another group) and this group contains five clients, the unknown count value would be at least 15. This value could be more if clients in this group were unable to report status for one or more of the updates.

To retrieve summary information that sums the results for each update that is deployed to clients in the group, call IComputerTargetGroup.GetSummaryPerUpdate.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummary Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary summed across all updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As IUpdateSummary
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummary(updateTypes)

Syntax

Visual Basic
Function GetTotalSummary( _
    ByVal updateTypes As UpdateTypes _
) As IUpdateSummary
C#
IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
C++
public:
virtual IUpdateSummary^ GetTotalSummary(
    UpdateTypes updateTypes
);
J#
public IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummary(
     updateTypes : UpdateTypes
) : IUpdateSummary;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

One summary with counts summed across all updates and all ComputerTargets in this ComputerTargetGroup.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummary Method (UpdateTypes, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary, summed across all updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim includeSubgroups As Boolean
Dim returnValue As IUpdateSummary
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummary(updateTypes, includeSubgroups)

Syntax

Visual Basic
Function GetTotalSummary( _
    ByVal updateTypes As UpdateTypes, _
    ByVal includeSubgroups As Boolean _
) As IUpdateSummary
C#
IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
C++
public:
virtual IUpdateSummary^ GetTotalSummary(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
J#
public IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes,
    boolean includeSubgroups
);
JScript
function GetTotalSummary(
     updateTypes : UpdateTypes,
     includeSubgroups : Boolean
) : IUpdateSummary;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

One summary with counts summed across all updates and all ComputerTargets in this ComputerTargetGroup.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummaryPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTargetGroup.GetTotalSummaryPerComputerTarget () | Retrieves summary installation counts for all approved updates.
IComputerTargetGroup.GetTotalSummaryPerComputerTarget (UpdateTypes) | Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.
IComputerTargetGroup.GetTotalSummaryPerComputerTarget (UpdateTypes, Boolean) | Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummaryPerComputerTarget Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves summary installation counts for all approved updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummaryPerComputerTarget()

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget();
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
JScript
function GetTotalSummaryPerComputerTarget() : UpdateSummaryCollection;

Return Value

An UpdateSummaryCollection collection that provides summary installation counts for each client computer in the group (each member of the collection represents a client). For example, the counts for a client show the number of updates that were successfully installed on the client.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Summary information for the target group is not available.

Remarks

The IUpdateSummary.UnknownCount count for each client may include updates that were not approved for deployment to clients in this target group. For example, if the WSUS server contains 10 updates (five are approved for deployment to this group and three are approved for deployment to another group), the unknown count value for each client would be at least 15. This value could be more if the client was unable to report status for one or more of the updates.

To retrieve summary information that sums the results for all updates that are deployed to all clients in the group, call IComputerTargetGroup.GetTotalSummary.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummaryPerComputerTarget Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummaryPerComputerTarget(updateTypes)

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummaryPerComputerTarget(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each ComputerTarget in this ComputerTargetGroup, each with counts summed across all included updates.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetTotalSummaryPerComputerTarget Method (UpdateTypes, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type for computers in this ComputerTargetGroup. Updates with at least one approval are included, even if the update is not approved for this particular target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim includeSubgroups As Boolean
Dim returnValue As UpdateSummaryCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetTotalSummaryPerComputerTarget(updateTypes, includeSubgroups)

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget( _
    ByVal updateTypes As UpdateTypes, _
    ByVal includeSubgroups As Boolean _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes,
    bool includeSubgroups
);
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes,
    boolean includeSubgroups
);
JScript
function GetTotalSummaryPerComputerTarget(
     updateTypes : UpdateTypes,
     includeSubgroups : Boolean
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

includeSubgroups

Whether or not computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

A collection containing one entry for each ComputerTarget in this ComputerTargetGroup, each with counts summed across all included updates.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget (IUpdate) | Retrieves installation information about a specific update for each client computer in the group.
IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget (IUpdate, Boolean) | Get the collection of installation information for ComputerTargets in this ComputerTargetGroup for a specific Update.

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget Method (IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves installation information about a specific update for each client computer in the group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim update As IUpdate
Dim returnValue As UpdateInstallationInfoCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetUpdateInstallationInfoPerComputerTarget(update)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerComputerTarget( _
    ByVal update As IUpdate _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IUpdate update
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerComputerTarget(
    IUpdate^ update
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IUpdate update
);
JScript
function GetUpdateInstallationInfoPerComputerTarget(
     update : IUpdate
) : UpdateInstallationInfoCollection;

Parameters

update

An IUpdate that represents the update for which you want to retrieve installation information for each client computer in the group.

Return Value

An UpdateInstallationInfoCollection collection that contains the update's installation information for each client in the group.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Summary information for the target group is not available.
ArgumentNullException | update cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget Method (IUpdate, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the collection of installation information for ComputerTargets in this ComputerTargetGroup for a specific Update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim update As IUpdate
Dim includeSubgroups As Boolean
Dim returnValue As UpdateInstallationInfoCollection
Dim iComputerTargetGroup1 As IComputerTargetGroup
returnValue = iComputerTargetGroup1.GetUpdateInstallationInfoPerComputerTarget(update, includeSubgroups)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerComputerTarget( _
    ByVal update As IUpdate, _
    ByVal includeSubgroups As Boolean _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IUpdate update,
    bool includeSubgroups
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerComputerTarget(
    IUpdate^ update,
    bool includeSubgroups
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IUpdate update,
    boolean includeSubgroups
);
JScript
function GetUpdateInstallationInfoPerComputerTarget(
     update : IUpdate,
     includeSubgroups : Boolean
) : UpdateInstallationInfoCollection;

Parameters

update

The update for which to retrieve data.

includeSubgroups

A value indicating whether computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.
ArgumentNullException | update cannot be a null reference.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.RemoveComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a client computer from the target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim target As IComputerTarget
Dim iComputerTargetGroup1 As IComputerTargetGroup
iComputerTargetGroup1.RemoveComputerTarget(target)

Syntax

Visual Basic
Sub RemoveComputerTarget( _
    ByVal target As IComputerTarget _
)
C#
void RemoveComputerTarget(
    IComputerTarget target
);
C++
public:
virtual void RemoveComputerTarget(
    IComputerTarget^ target
);
J#
public void RemoveComputerTarget(
    IComputerTarget target
);
JScript
function RemoveComputerTarget(
     target : IComputerTarget
) : Void;

Parameters

target

An IComputerTarget of the client computer to be removed from the group. The client is moved to the Unassigned Computers group.

Exceptions

Exception type | Condition
ArgumentNullException | target cannot be null.
InvalidOperationException | Cannot delete the target group. For example, you cannot delete the All Computers or Unassigned Computers target group.
WsusObjectNotFoundException | The target group or computer has been deleted.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Id | Retrieves the unique identifier of the target group.
public property | Name | Retrieves the name of the group.

See Also

Reference

IComputerTargetGroup Interface


IComputerTargetGroup.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTargetGroup1 As IComputerTargetGroup

Dim returnValue As Guid
returnValue = iComputerTargetGroup1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IComputerTargetGroup.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iComputerTargetGroup1 As IComputerTargetGroup

Dim returnValue As String
returnValue = iComputerTargetGroup1.Name

Syntax

Visual Basic
ReadOnly Property Name() As String
C#
string Name {get;}
C++
property virtual String^ Name {
    String^ get();
}
J#
public System.String get_Name();
JScript
function get Name() : String;

Property Value

Name of the group. This name is unique amongst all groups.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IComputerTargetGroup Interface
IComputerTargetGroup Members


IDatabaseConfiguration Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the IDatabaseConfiguration Interface for accessing Database Configuration Information. To retrieve this interface, call GetDatabaseConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDatabaseConfigurationTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class databaseConfigurationImplementation
    Implements IDatabaseConfiguration
End Class
Dim databaseConfigurationImplementation1 As New databaseConfigurationImplementation()

Syntax

Visual Basic
Public Interface IDatabaseConfiguration
C#
public interface IDatabaseConfiguration
C++
public interface class IDatabaseConfiguration
J#
public interface IDatabaseConfiguration
JScript
public interface IDatabaseConfiguration

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Members


IDatabaseConfiguration Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the IDatabaseConfiguration Interface for accessing Database Configuration Information. To retrieve this interface, call GetDatabaseConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetDatabaseConfigurationTopic.

The following tables list the members exposed by the IDatabaseConfiguration type.

Public Properties

 | Name | Description
public property | DatabaseName | Retrieves the name of the database that Windows Server Update Services (WSUS) is using.
public property | IsUsingWsusWmsdeInstall | Determines if the WSUS server is using the local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, that was installed during setup.
public property | IsWsusWmsdeInstalled | Determines if a local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, was installed during setup.
public property | ServerName | Retrieves the name of the database server instance WSUS is using.
Top

Public Methods

 | Name | Description
public method | ConnectToDatabase | Tests the connectivity to the SQL database.
Top

See Also

Reference

IDatabaseConfiguration Interface


IDatabaseConfiguration Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | ConnectToDatabase | Tests the connectivity to the SQL database.

See Also

Reference

IDatabaseConfiguration Interface


IDatabaseConfiguration.ConnectToDatabase Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Tests the connectivity to the SQL database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDatabaseConfiguration1 As IDatabaseConfiguration
iDatabaseConfiguration1.ConnectToDatabase()

Syntax

Visual Basic
Sub ConnectToDatabase()
C#
void ConnectToDatabase();
C++
public:
virtual void ConnectToDatabase();
J#
public void ConnectToDatabase();
JScript
function ConnectToDatabase() : Void;

Exceptions

Exception type | Condition
SqlException | Failed to connect to SQL Database. SqlException may be interrogated for information about cause of failure.

Remarks

This function tests connectivity. If connectivity is achieved, it will return; else it will throw SqlException which is generated by a failed connection attempt.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Interface
IDatabaseConfiguration Members


IDatabaseConfiguration Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | DatabaseName | Retrieves the name of the database that Windows Server Update Services (WSUS) is using.
public property | IsUsingWsusWmsdeInstall | Determines if the WSUS server is using the local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, that was installed during setup.
public property | IsWsusWmsdeInstalled | Determines if a local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, was installed during setup.
public property | ServerName | Retrieves the name of the database server instance WSUS is using.

See Also

Reference

IDatabaseConfiguration Interface


IDatabaseConfiguration.DatabaseName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the database that Windows Server Update Services (WSUS) is using.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDatabaseConfiguration1 As IDatabaseConfiguration

Dim returnValue As String
returnValue = iDatabaseConfiguration1.DatabaseName

Syntax

Visual Basic
ReadOnly Property DatabaseName() As String
C#
string DatabaseName {get;}
C++
property virtual String^ DatabaseName {
    String^ get();
}
J#
public System.String get_DatabaseName();
JScript
function get DatabaseName() : String;

Property Value

Name of the database used by WSUS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Interface
IDatabaseConfiguration Members


IDatabaseConfiguration.IsUsingWsusWmsdeInstall Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the WSUS server is using the local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, that was installed during setup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDatabaseConfiguration1 As IDatabaseConfiguration

Dim returnValue As Boolean
returnValue = iDatabaseConfiguration1.IsUsingWsusWmsdeInstall

Syntax

Visual Basic
ReadOnly Property IsUsingWsusWmsdeInstall() As Boolean
C#
bool IsUsingWsusWmsdeInstall {get;}
C++
property virtual bool IsUsingWsusWmsdeInstall {
    bool get();
}
J#
public boolean get_IsUsingWsusWmsdeInstall();
JScript
function get IsUsingWsusWmsdeInstall() : Boolean;

Property Value

True if WSUS is installed to a WMSDE instance that WSUS installed during setup. False, if WSUS is not using a WMSDE instance that WSUS installed during setup.

Remarks

  • This property can be true only if IsWsusWmsdeInstalled frlrfMicrosoftUpdateServicesAdministrationIDatabaseConfigurationClassIsWsusWmsdeInstalledTopic is true.

  • This property is obsolete in WSUS 3.0, and will always return false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Interface
IDatabaseConfiguration Members


IDatabaseConfiguration.IsWsusWmsdeInstalled Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if a local instance of the SQL Server 2000 Desktop Engine (Windows), known as WMSDE, was installed during setup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDatabaseConfiguration1 As IDatabaseConfiguration

Dim returnValue As Boolean
returnValue = iDatabaseConfiguration1.IsWsusWmsdeInstalled

Syntax

Visual Basic
ReadOnly Property IsWsusWmsdeInstalled() As Boolean
C#
bool IsWsusWmsdeInstalled {get;}
C++
property virtual bool IsWsusWmsdeInstalled {
    bool get();
}
J#
public boolean get_IsWsusWmsdeInstalled();
JScript
function get IsWsusWmsdeInstalled() : Boolean;

Property Value

True if a local WMSDE instance was installed during setup; otherwise, false.

Remarks

This property is obsolete in WSUS 3.0, and will always return false.

Windows 2000 Server Platform Note: WMSDE is not supported, therefore the property value will be false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Interface
IDatabaseConfiguration Members


IDatabaseConfiguration.ServerName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the database server instance WSUS is using.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDatabaseConfiguration1 As IDatabaseConfiguration

Dim returnValue As String
returnValue = iDatabaseConfiguration1.ServerName

Syntax

Visual Basic
ReadOnly Property ServerName() As String
C#
string ServerName {get;}
C++
property virtual String^ ServerName {
    String^ get();
}
J#
public System.String get_ServerName();
JScript
function get ServerName() : String;

Property Value

Name of the database server instance WSUS is using. The name is of the form, <servername>\<instancename>.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDatabaseConfiguration Interface
IDatabaseConfiguration Members


IDownstreamServer Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the name of the downstream server or to remove the downstream server from the list of downstream servers connected to this WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class downstreamServerImplementation
    Implements IDownstreamServer
End Class
Dim downstreamServerImplementation1 As New downstreamServerImplementation()

Syntax

Visual Basic
Public Interface IDownstreamServer
C#
public interface IDownstreamServer
C++
public interface class IDownstreamServer
J#
public interface IDownstreamServer
JScript
public interface IDownstreamServer

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Members


IDownstreamServer Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the name of the downstream server or to remove the downstream server from the list of downstream servers connected to this WSUS server.

The following tables list the members exposed by the IDownstreamServer type.

Public Properties

 | Name | Description
public property | FullDomainName | Retrieves the full domain name of the downstream server.
public property | Id | Retrieves the unique identifier of the downstream server.
public property | IsReplica | Determines whether the downstream server is a replica server.
public property | LastRollupTime | Retrieves the UTC time that the DownstreamServer last rolled up reporting data to this server.
public property | LastSyncTime | Retrieves the last UTC time the downstream server synchronized with this server.
public property | ParentServerId | Retrieves or sets the ID of the WSUS server the downstream server last synced from.
public property | SyncsFromDownstreamServer | Determines whether the downstream server syncs from another downstream server, or from this server.
public property | Version | Retrieves or sets the version of WSUS that is installed on the downstream server
Top

Public Methods

 | Name | Description
public method | Delete | Removes the downstream server from the list of downstream servers that are connected to this WSUS server.
public method | GetChildServers | Retrieves the list of downstream servers that synchronize directly from this server.
public method | GetHashCode | Serves as a hash function for the current DownstreamServer, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetParentServer | Retrieves the server from which this server last synchronized.
public method | GetStatus | Retrieves a set of status information summarizing the current state of the server and its client computers.
Top

See Also

Reference

IDownstreamServer Interface


IDownstreamServer Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | Delete | Removes the downstream server from the list of downstream servers that are connected to this WSUS server.
public method | GetChildServers | Retrieves the list of downstream servers that synchronize directly from this server.
public method | GetHashCode | Serves as a hash function for the current DownstreamServer, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetParentServer | Retrieves the server from which this server last synchronized.
public method | GetStatus | Retrieves a set of status information summarizing the current state of the server and its client computers.

See Also

Reference

IDownstreamServer Interface


IDownstreamServer.Delete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the downstream server from the list of downstream servers that are connected to this WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer
iDownstreamServer1.Delete()

Syntax

Visual Basic
Sub Delete()
C#
void Delete();
C++
public:
virtual void Delete();
J#
public void Delete();
JScript
function Delete() : Void;

Remarks

Typically, you delete a downstream server when the downstream server no longer connects to this WSUS server. If you reconfigure your WSUS server hierarchy to remove the relationship, you should modify the downstream server to point to another upstream server (or Microsoft Update) before deleting the downstream server.

Note that if the downstream server talks to this WSUS server again, it will reappear on the list of downstream servers.

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.GetChildServers Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of downstream servers that synchronize directly from this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As DownstreamServerCollection
Dim iDownstreamServer1 As IDownstreamServer
returnValue = iDownstreamServer1.GetChildServers()

Syntax

Visual Basic
Function GetChildServers() As DownstreamServerCollection
C#
DownstreamServerCollection GetChildServers();
C++
public:
virtual DownstreamServerCollection^ GetChildServers();
J#
public DownstreamServerCollection GetChildServers();
JScript
function GetChildServers() : DownstreamServerCollection;

Return Value

The list of downstream servers that synchronize directly from this server.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current DownstreamServer, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iDownstreamServer1 As IDownstreamServer
returnValue = iDownstreamServer1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

hash code for the current DownstreamServer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.GetParentServer Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the server from which this server last synchronized.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IDownstreamServer
Dim iDownstreamServer1 As IDownstreamServer
returnValue = iDownstreamServer1.GetParentServer()

Syntax

Visual Basic
Function GetParentServer() As IDownstreamServer
C#
IDownstreamServer GetParentServer();
C++
public:
virtual IDownstreamServer^ GetParentServer();
J#
public IDownstreamServer GetParentServer();
JScript
function GetParentServer() : IDownstreamServer;

Return Value

Gets the server from which this server last synchronized.

Exceptions

Exception type | Condition
InvalidOperationException | SyncsFromDownstreamServer is false.
WsusObjectNotFoundException | The parent server could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.GetStatus Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a set of status information summarizing the current state of the server and its client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateServerStatus
Dim iDownstreamServer1 As IDownstreamServer
returnValue = iDownstreamServer1.GetStatus()

Syntax

Visual Basic
Function GetStatus() As UpdateServerStatus
C#
UpdateServerStatus GetStatus();
C++
public:
virtual UpdateServerStatus^ GetStatus();
J#
public UpdateServerStatus GetStatus();
JScript
function GetStatus() : UpdateServerStatus;

Return Value

A set of status information summarizing the current state of the UpdateServer and its client computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | FullDomainName | Retrieves the full domain name of the downstream server.
public property | Id | Retrieves the unique identifier of the downstream server.
public property | IsReplica | Determines whether the downstream server is a replica server.
public property | LastRollupTime | Retrieves the UTC time that the DownstreamServer last rolled up reporting data to this server.
public property | LastSyncTime | Retrieves the last UTC time the downstream server synchronized with this server.
public property | ParentServerId | Retrieves or sets the ID of the WSUS server the downstream server last synced from.
public property | SyncsFromDownstreamServer | Determines whether the downstream server syncs from another downstream server, or from this server.
public property | Version | Retrieves or sets the version of WSUS that is installed on the downstream server

See Also

Reference

IDownstreamServer Interface


IDownstreamServer.FullDomainName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the full domain name of the downstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As String
returnValue = iDownstreamServer1.FullDomainName

Syntax

Visual Basic
ReadOnly Property FullDomainName() As String
C#
string FullDomainName {get;}
C++
property virtual String^ FullDomainName {
    String^ get();
}
J#
public System.String get_FullDomainName();
JScript
function get FullDomainName() : String;

Property Value

Full domain name of the downstream server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the downstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As Guid
returnValue = iDownstreamServer1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the downstream server.

Remarks

The identifier is the same value as the ServerId frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerIdTopic value on the downstream server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.IsReplica Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the downstream server is a replica server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As Boolean
returnValue = iDownstreamServer1.IsReplica

Syntax

Visual Basic
ReadOnly Property IsReplica() As Boolean
C#
bool IsReplica {get;}
C++
property virtual bool IsReplica {
    bool get();
}
J#
public boolean get_IsReplica();
JScript
function get IsReplica() : Boolean;

Property Value

true if the downstream server is a replica server, false otherwise.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.LastRollupTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the UTC time that the DownstreamServer last rolled up reporting data to this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As DateTime
returnValue = iDownstreamServer1.LastRollupTime

Syntax

Visual Basic
ReadOnly Property LastRollupTime() As DateTime
C#
DateTime LastRollupTime {get;}
C++
property virtual DateTime^ LastRollupTime {
    DateTime^ get();
}
J#
public DateTime get_LastRollupTime();
JScript
function get LastRollupTime() : DateTime;

Property Value

The UTC time that the DownstreamServer last rolled up reporting data to this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.LastSyncTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last UTC time the downstream server synchronized with this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As DateTime
returnValue = iDownstreamServer1.LastSyncTime

Syntax

Visual Basic
ReadOnly Property LastSyncTime() As DateTime
C#
DateTime LastSyncTime {get;}
C++
property virtual DateTime^ LastSyncTime {
    DateTime^ get();
}
J#
public DateTime get_LastSyncTime();
JScript
function get LastSyncTime() : DateTime;

Property Value

The UTC time that the DownstreamServer last synced from this server.

Remarks

This value can be DateTime.MinValue if the downstream server attempted to synchronize with this server but the synchronization process failed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.ParentServerId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the ID of the WSUS server the downstream server last synced from.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As Guid
returnValue = iDownstreamServer1.ParentServerId

Syntax

Visual Basic
ReadOnly Property ParentServerId() As Guid
C#
Guid ParentServerId {get;}
C++
property virtual Guid^ ParentServerId {
    Guid^ get();
}
J#
public Guid get_ParentServerId();
JScript
function get ParentServerId() : Guid;

Property Value

The ID of the downstream WSUS server the server last synced from, or Guid.Empty if the downstream server syncs directly from this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.SyncsFromDownstreamServer Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the downstream server syncs from another downstream server, or from this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As Boolean
returnValue = iDownstreamServer1.SyncsFromDownstreamServer

Syntax

Visual Basic
ReadOnly Property SyncsFromDownstreamServer() As Boolean
C#
bool SyncsFromDownstreamServer {get;}
C++
property virtual bool SyncsFromDownstreamServer {
    bool get();
}
J#
public boolean get_SyncsFromDownstreamServer();
JScript
function get SyncsFromDownstreamServer() : Boolean;

Property Value

true if the downstream server syncs from another downstreamserver. false if it syncs from this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IDownstreamServer.Version Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the version of WSUS that is installed on the downstream server

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iDownstreamServer1 As IDownstreamServer

Dim returnValue As Version
returnValue = iDownstreamServer1.Version

Syntax

Visual Basic
ReadOnly Property Version() As Version
C#
Version Version {get;}
C++
property virtual Version^ Version {
    Version^ get();
}
J#
public Version get_Version();
JScript
function get Version() : Version;

Property Value

A Version object representing the version of WSUS that is installed on the downstream server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IDownstreamServer Interface
IDownstreamServer Members


IEmailNotificationConfiguration Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the IEmailNotificatioNConfiguration Interface for configuring email user account and email server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class emailNotificationConfigurationImplementation
    Implements IEmailNotificationConfiguration
End Class
Dim emailNotificationConfigurationImplementation1 As New emailNotificationConfigurationImplementation()

Syntax

Visual Basic
Public Interface IEmailNotificationConfiguration
C#
public interface IEmailNotificationConfiguration
C++
public interface class IEmailNotificationConfiguration
J#
public interface IEmailNotificationConfiguration
JScript
public interface IEmailNotificationConfiguration

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Members


IEmailNotificationConfiguration Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the IEmailNotificatioNConfiguration Interface for configuring email user account and email server.

The following tables list the members exposed by the IEmailNotificationConfiguration type.

Public Properties

 | Name | Description
public property | EmailLanguage | Gets and Sets the language setting for the email
public property | EmailNotificationEnabled | Gets if Email Notification is configured
public property | HasSmtpUserPassword | Get if the email sender's password is already set
public property | LastModifiedBy | Gets the name of the last Administrator to modify the email notification settings.
public property | LastModifiedTime | Gets the last time email notification settings were modified.
public property | SendStatusNotification | Gets and Sets if Email Notification is needed for periadical new update status summary
public property | SendSyncNotification | Gets and Sets if Email Notification is needed for new update alerts after each sync
public property | SmtpHostName | True if it new update alert is enabled, false if not.
public property | SmtpPort | Gets and Sets the email SMTP port number
public property | SmtpServerRequireAuthentication | Gets and Sets if email server needs authentication
public property | SmtpUserDisplayName | Gets and Sets the email sender's display name
public property | SmtpUserMailAddress | Gets and Sets the email sender's email address
public property | SmtpUserName | Gets and Sets the email sender's account name
public property | StatusNotification | Gets and Sets Email Notification status report types
public property | StatusNotificationTimeOfDay | Gets and Sets Email Notification sending time of the day
public property | SupportedEmailLanguages | Get the supported languages for email contents
Top

Public Methods

 | Name | Description
public method | GetStatusNotificationRecipients | Gets Status Notification recipients
public method | GetSyncNotificationRecipients | Gets Update synchronization notification recipients
public method | Save | Save the email configuration to database
public method | SetSmtpUserPassword | Overloaded. Sets the email sender's password
public method | SetStatusNotificationRecipients | This operation requires WSUS Administrator privileges.
public method | SetSyncNotificationRecipients | Sets Update Synch Notification recipients
public method | Test | Triggers an email configuration to manually test the mail server and mail accounts
Top

See Also

Reference

IEmailNotificationConfiguration Interface


IEmailNotificationConfiguration Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetStatusNotificationRecipients | Gets Status Notification recipients
public method | GetSyncNotificationRecipients | Gets Update synchronization notification recipients
public method | Save | Save the email configuration to database
public method | SetSmtpUserPassword | Overloaded. Sets the email sender's password
public method | SetStatusNotificationRecipients | This operation requires WSUS Administrator privileges.
public method | SetSyncNotificationRecipients | Sets Update Synch Notification recipients
public method | Test | Triggers an email configuration to manually test the mail server and mail accounts

See Also

Reference

IEmailNotificationConfiguration Interface


IEmailNotificationConfiguration.GetStatusNotificationRecipients Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets Status Notification recipients

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As MailAddressCollection
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
returnValue = iEmailNotificationConfiguration1.GetStatusNotificationRecipients()

Syntax

Visual Basic
Function GetStatusNotificationRecipients() As MailAddressCollection
C#
MailAddressCollection GetStatusNotificationRecipients();
C++
public:
virtual MailAddressCollection^ GetStatusNotificationRecipients();
J#
public MailAddressCollection GetStatusNotificationRecipients();
JScript
function GetStatusNotificationRecipients() : MailAddressCollection;

Return Value

The collection of email addresses that receive status notification

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.GetSyncNotificationRecipients Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets Update synchronization notification recipients

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As MailAddressCollection
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
returnValue = iEmailNotificationConfiguration1.GetSyncNotificationRecipients()

Syntax

Visual Basic
Function GetSyncNotificationRecipients() As MailAddressCollection
C#
MailAddressCollection GetSyncNotificationRecipients();
C++
public:
virtual MailAddressCollection^ GetSyncNotificationRecipients();
J#
public MailAddressCollection GetSyncNotificationRecipients();
JScript
function GetSyncNotificationRecipients() : MailAddressCollection;

Return Value

The collection of email addresses that receive status notification

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.Save Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Save the email configuration to database

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.Save()

Syntax

Visual Basic
Sub Save()
C#
void Save();
C++
public:
virtual void Save();
J#
public void Save();
JScript
function Save() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SetSmtpUserPassword Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the email sender's password

Overload List

Name | Description
IEmailNotificationConfiguration.SetSmtpUserPassword (SecureString) | Sets the email sender's password
IEmailNotificationConfiguration.SetSmtpUserPassword (String) | Sets the email sender's password

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SetSmtpUserPassword Method (SecureString)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the email sender's password

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim password As SecureString
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.SetSmtpUserPassword(password)

Syntax

Visual Basic
Sub SetSmtpUserPassword( _
    ByVal password As SecureString _
)
C#
void SetSmtpUserPassword(
    SecureString password
);
C++
public:
virtual void SetSmtpUserPassword(
    SecureString^ password
);
J#
public void SetSmtpUserPassword(
    SecureString password
);
JScript
function SetSmtpUserPassword(
     password : SecureString
) : Void;

Parameters

password

The email sender's password

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SetSmtpUserPassword Method (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the email sender's password

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim password As String
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.SetSmtpUserPassword(password)

Syntax

Visual Basic
Sub SetSmtpUserPassword( _
    ByVal password As String _
)
C#
void SetSmtpUserPassword(
    string password
);
C++
public:
virtual void SetSmtpUserPassword(
    String^ password
);
J#
public void SetSmtpUserPassword(
    System.String password
);
JScript
function SetSmtpUserPassword(
     password : String
) : Void;

Parameters

password

The email sender's password

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SetStatusNotificationRecipients Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This operation requires WSUS Administrator privileges.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As MailAddressCollection
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.SetStatusNotificationRecipients(value)

Syntax

Visual Basic
Sub SetStatusNotificationRecipients( _
    ByVal value As MailAddressCollection _
)
C#
void SetStatusNotificationRecipients(
    MailAddressCollection value
);
C++
public:
virtual void SetStatusNotificationRecipients(
    MailAddressCollection^ value
);
J#
public void SetStatusNotificationRecipients(
    MailAddressCollection value
);
JScript
function SetStatusNotificationRecipients(
     value : MailAddressCollection
) : Void;

Parameters

value

The collection of email addressess to receive status notification

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SetSyncNotificationRecipients Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets Update Synch Notification recipients

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As MailAddressCollection
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.SetSyncNotificationRecipients(value)

Syntax

Visual Basic
Sub SetSyncNotificationRecipients( _
    ByVal value As MailAddressCollection _
)
C#
void SetSyncNotificationRecipients(
    MailAddressCollection value
);
C++
public:
virtual void SetSyncNotificationRecipients(
    MailAddressCollection^ value
);
J#
public void SetSyncNotificationRecipients(
    MailAddressCollection value
);
JScript
function SetSyncNotificationRecipients(
     value : MailAddressCollection
) : Void;

Parameters

value

The collection of email addressess to receive update synch notification

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.Test Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Triggers an email configuration to manually test the mail server and mail accounts

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration
iEmailNotificationConfiguration1.Test()

Syntax

Visual Basic
Sub Test()
C#
void Test();
C++
public:
virtual void Test();
J#
public void Test();
JScript
function Test() : Void;

Remarks

This method will return send out a test email to check the status of email server as well as email accounts. It is an asynchrnous call. To get the test status, you need to review the log file for related information. This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | EmailLanguage | Gets and Sets the language setting for the email
public property | EmailNotificationEnabled | Gets if Email Notification is configured
public property | HasSmtpUserPassword | Get if the email sender's password is already set
public property | LastModifiedBy | Gets the name of the last Administrator to modify the email notification settings.
public property | LastModifiedTime | Gets the last time email notification settings were modified.
public property | SendStatusNotification | Gets and Sets if Email Notification is needed for periadical new update status summary
public property | SendSyncNotification | Gets and Sets if Email Notification is needed for new update alerts after each sync
public property | SmtpHostName | True if it new update alert is enabled, false if not.
public property | SmtpPort | Gets and Sets the email SMTP port number
public property | SmtpServerRequireAuthentication | Gets and Sets if email server needs authentication
public property | SmtpUserDisplayName | Gets and Sets the email sender's display name
public property | SmtpUserMailAddress | Gets and Sets the email sender's email address
public property | SmtpUserName | Gets and Sets the email sender's account name
public property | StatusNotification | Gets and Sets Email Notification status report types
public property | StatusNotificationTimeOfDay | Gets and Sets Email Notification sending time of the day
public property | SupportedEmailLanguages | Get the supported languages for email contents

See Also

Reference

IEmailNotificationConfiguration Interface


IEmailNotificationConfiguration.EmailLanguage Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets the language setting for the email

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As String
returnValue = iEmailNotificationConfiguration1.EmailLanguage

Dim sampleValue As String
iEmailNotificationConfiguration1.EmailLanguage = sampleValue

Syntax

Visual Basic
Property EmailLanguage() As String
C#
string EmailLanguage {get; set;}
C++
property virtual String^ EmailLanguage {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_EmailLanguage();
public void set_EmailLanguage(System.String);
JScript
function get EmailLanguage() : String;
function set EmailLanguage(String);

Property Value

The email content's culture.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.EmailNotificationEnabled Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets if Email Notification is configured

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Boolean
returnValue = iEmailNotificationConfiguration1.EmailNotificationEnabled

Syntax

Visual Basic
ReadOnly Property EmailNotificationEnabled() As Boolean
C#
bool EmailNotificationEnabled {get;}
C++
property virtual bool EmailNotificationEnabled {
    bool get();
}
J#
public boolean get_EmailNotificationEnabled();
JScript
function get EmailNotificationEnabled() : Boolean;

Property Value

True if it Email Notification is configured

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.HasSmtpUserPassword Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get if the email sender's password is already set

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Boolean
returnValue = iEmailNotificationConfiguration1.HasSmtpUserPassword

Syntax

Visual Basic
ReadOnly Property HasSmtpUserPassword() As Boolean
C#
bool HasSmtpUserPassword {get;}
C++
property virtual bool HasSmtpUserPassword {
    bool get();
}
J#
public boolean get_HasSmtpUserPassword();
JScript
function get HasSmtpUserPassword() : Boolean;

Property Value

True if email sender's password is set, false if not

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.LastModifiedBy Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the name of the last Administrator to modify the email notification settings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As String
returnValue = iEmailNotificationConfiguration1.LastModifiedBy

Syntax

Visual Basic
ReadOnly Property LastModifiedBy() As String
C#
string LastModifiedBy {get;}
C++
property virtual String^ LastModifiedBy {
    String^ get();
}
J#
public System.String get_LastModifiedBy();
JScript
function get LastModifiedBy() : String;

Property Value

The name of the last administrator to modify the email notification settings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.LastModifiedTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the last time email notification settings were modified.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As DateTime
returnValue = iEmailNotificationConfiguration1.LastModifiedTime

Syntax

Visual Basic
ReadOnly Property LastModifiedTime() As DateTime
C#
DateTime LastModifiedTime {get;}
C++
property virtual DateTime^ LastModifiedTime {
    DateTime^ get();
}
J#
public DateTime get_LastModifiedTime();
JScript
function get LastModifiedTime() : DateTime;

Property Value

The last time the email notification settings were modified in UTC Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SendStatusNotification Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets if Email Notification is needed for periadical new update status summary

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Boolean
returnValue = iEmailNotificationConfiguration1.SendStatusNotification

Dim sampleValue As Boolean
iEmailNotificationConfiguration1.SendStatusNotification = sampleValue

Syntax

Visual Basic
Property SendStatusNotification() As Boolean
C#
bool SendStatusNotification {get; set;}
C++
property virtual bool SendStatusNotification {
    bool get();
    void set(bool value);
}
J#
public boolean get_SendStatusNotification();
public void set_SendStatusNotification(boolean);
JScript
function get SendStatusNotification() : Boolean;
function set SendStatusNotification(Boolean);

Property Value

True if it new update status summary is enabled, false if not.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SendSyncNotification Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets if Email Notification is needed for new update alerts after each sync

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Boolean
returnValue = iEmailNotificationConfiguration1.SendSyncNotification

Dim sampleValue As Boolean
iEmailNotificationConfiguration1.SendSyncNotification = sampleValue

Syntax

Visual Basic
Property SendSyncNotification() As Boolean
C#
bool SendSyncNotification {get; set;}
C++
property virtual bool SendSyncNotification {
    bool get();
    void set(bool value);
}
J#
public boolean get_SendSyncNotification();
public void set_SendSyncNotification(boolean);
JScript
function get SendSyncNotification() : Boolean;
function set SendSyncNotification(Boolean);

Property Value

True if it new update alert is enabled, false if not.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpHostName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

True if it new update alert is enabled, false if not.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As String
returnValue = iEmailNotificationConfiguration1.SmtpHostName

Dim sampleValue As String
iEmailNotificationConfiguration1.SmtpHostName = sampleValue

Syntax

Visual Basic
Property SmtpHostName() As String
C#
string SmtpHostName {get; set;}
C++
property virtual String^ SmtpHostName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_SmtpHostName();
public void set_SmtpHostName(System.String);
JScript
function get SmtpHostName() : String;
function set SmtpHostName(String);

Property Value

The name of smtp server

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpPort Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets the email SMTP port number

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Integer
returnValue = iEmailNotificationConfiguration1.SmtpPort

Dim sampleValue As Integer
iEmailNotificationConfiguration1.SmtpPort = sampleValue

Syntax

Visual Basic
Property SmtpPort() As Integer
C#
int SmtpPort {get; set;}
C++
property virtual int SmtpPort {
    int get();
    void set(int value);
}
J#
public int get_SmtpPort();
public void set_SmtpPort(int);
JScript
function get SmtpPort() : int;
function set SmtpPort(int);

Property Value

The port number of SMTP server

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpServerRequireAuthentication Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets if email server needs authentication

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As Boolean
returnValue = iEmailNotificationConfiguration1.SmtpServerRequireAuthentication

Dim sampleValue As Boolean
iEmailNotificationConfiguration1.SmtpServerRequireAuthentication = sampleValue

Syntax

Visual Basic
Property SmtpServerRequireAuthentication() As Boolean
C#
bool SmtpServerRequireAuthentication {get; set;}
C++
property virtual bool SmtpServerRequireAuthentication {
    bool get();
    void set(bool value);
}
J#
public boolean get_SmtpServerRequireAuthentication();
public void set_SmtpServerRequireAuthentication(boolean);
JScript
function get SmtpServerRequireAuthentication() : Boolean;
function set SmtpServerRequireAuthentication(Boolean);

Property Value

True if email server need authentication, false if not

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpUserDisplayName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets the email sender's display name

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As String
returnValue = iEmailNotificationConfiguration1.SmtpUserDisplayName

Dim sampleValue As String
iEmailNotificationConfiguration1.SmtpUserDisplayName = sampleValue

Syntax

Visual Basic
Property SmtpUserDisplayName() As String
C#
string SmtpUserDisplayName {get; set;}
C++
property virtual String^ SmtpUserDisplayName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_SmtpUserDisplayName();
public void set_SmtpUserDisplayName(System.String);
JScript
function get SmtpUserDisplayName() : String;
function set SmtpUserDisplayName(String);

Property Value

The email sender's display name

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpUserMailAddress Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets the email sender's email address

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As MailAddress
returnValue = iEmailNotificationConfiguration1.SmtpUserMailAddress

Dim sampleValue As MailAddress
iEmailNotificationConfiguration1.SmtpUserMailAddress = sampleValue

Syntax

Visual Basic
Property SmtpUserMailAddress() As MailAddress
C#
MailAddress SmtpUserMailAddress {get; set;}
C++
property virtual MailAddress^ SmtpUserMailAddress {
    MailAddress^ get();
    void set(MailAddress^ value);
}
J#
public MailAddress get_SmtpUserMailAddress();
public void set_SmtpUserMailAddress(MailAddress);
JScript
function get SmtpUserMailAddress() : MailAddress;
function set SmtpUserMailAddress(MailAddress);

Property Value

The email sender's email address

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SmtpUserName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets the email sender's account name

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As String
returnValue = iEmailNotificationConfiguration1.SmtpUserName

Dim sampleValue As String
iEmailNotificationConfiguration1.SmtpUserName = sampleValue

Syntax

Visual Basic
Property SmtpUserName() As String
C#
string SmtpUserName {get; set;}
C++
property virtual String^ SmtpUserName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_SmtpUserName();
public void set_SmtpUserName(System.String);
JScript
function get SmtpUserName() : String;
function set SmtpUserName(String);

Property Value

The email sender's account name

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.StatusNotification Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets Email Notification status report types

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As EmailStatusNotification
returnValue = iEmailNotificationConfiguration1.StatusNotification

Dim sampleValue As EmailStatusNotification
iEmailNotificationConfiguration1.StatusNotification = sampleValue

Syntax

Visual Basic
Property StatusNotification() As EmailStatusNotification
C#
EmailStatusNotification StatusNotification {get; set;}
C++
property virtual EmailStatusNotification StatusNotification {
    EmailStatusNotification get();
    void set(EmailStatusNotification value);
}
J#
public EmailStatusNotification get_StatusNotification();
public void set_StatusNotification(EmailStatusNotification);
JScript
function get StatusNotification() : EmailStatusNotification;
function set StatusNotification(EmailStatusNotification);

Property Value

The types of status report, weekly or monthly.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.StatusNotificationTimeOfDay Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets and Sets Email Notification sending time of the day

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As TimeSpan
returnValue = iEmailNotificationConfiguration1.StatusNotificationTimeOfDay

Dim sampleValue As TimeSpan
iEmailNotificationConfiguration1.StatusNotificationTimeOfDay = sampleValue

Syntax

Visual Basic
Property StatusNotificationTimeOfDay() As TimeSpan
C#
TimeSpan StatusNotificationTimeOfDay {get; set;}
C++
property virtual TimeSpan^ StatusNotificationTimeOfDay {
    TimeSpan^ get();
    void set(TimeSpan^ value);
}
J#
public TimeSpan get_StatusNotificationTimeOfDay();
public void set_StatusNotificationTimeOfDay(TimeSpan);
JScript
function get StatusNotificationTimeOfDay() : TimeSpan;
function set StatusNotificationTimeOfDay(TimeSpan);

Property Value

The time the email notification is sent when due

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IEmailNotificationConfiguration.SupportedEmailLanguages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the supported languages for email contents

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iEmailNotificationConfiguration1 As IEmailNotificationConfiguration

Dim returnValue As StringCollection
returnValue = iEmailNotificationConfiguration1.SupportedEmailLanguages

Syntax

Visual Basic
ReadOnly Property SupportedEmailLanguages() As StringCollection
C#
StringCollection SupportedEmailLanguages {get;}
C++
property virtual StringCollection^ SupportedEmailLanguages {
    StringCollection^ get();
}
J#
public StringCollection get_SupportedEmailLanguages();
JScript
function get SupportedEmailLanguages() : StringCollection;

Property Value

The supported languages for email contents

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IEmailNotificationConfiguration Interface
IEmailNotificationConfiguration Members


IFrontEndServer Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This type defines interface of a front end server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class frontEndServerImplementation
    Implements IFrontEndServer
End Class
Dim frontEndServerImplementation1 As New frontEndServerImplementation()

Syntax

Visual Basic
Public Interface IFrontEndServer
C#
public interface IFrontEndServer
C++
public interface class IFrontEndServer
J#
public interface IFrontEndServer
JScript
public interface IFrontEndServer

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Members


IFrontEndServer Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This type defines interface of a front end server.

The following tables list the members exposed by the IFrontEndServer type.

Public Properties

 | Name | Description
public property | FullDomainName | Retrieves the full domain name of this front end server.
public property | IsActive | Retrieves IsActive status of a front end server.
public property | IsMaster | Determines if the front end server is a master server.
public property | LastContactedTime | Retrieves the last time the server updates its heartbeat.
Top

Public Methods

 | Name | Description
public method | Delete | Remove the record of this frontend server in DB. Note: if the server is still active, it'd add itself back to the DB.
Top

See Also

Reference

IFrontEndServer Interface


IFrontEndServer Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | Delete | Remove the record of this frontend server in DB. Note: if the server is still active, it'd add itself back to the DB.

See Also

Reference

IFrontEndServer Interface


IFrontEndServer.Delete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Remove the record of this frontend server in DB. Note: if the server is still active, it'd add itself back to the DB.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iFrontEndServer1 As IFrontEndServer
iFrontEndServer1.Delete()

Syntax

Visual Basic
Sub Delete()
C#
void Delete();
C++
public:
virtual void Delete();
J#
public void Delete();
JScript
function Delete() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Interface
IFrontEndServer Members


IFrontEndServer Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | FullDomainName | Retrieves the full domain name of this front end server.
public property | IsActive | Retrieves IsActive status of a front end server.
public property | IsMaster | Determines if the front end server is a master server.
public property | LastContactedTime | Retrieves the last time the server updates its heartbeat.

See Also

Reference

IFrontEndServer Interface


IFrontEndServer.FullDomainName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the full domain name of this front end server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iFrontEndServer1 As IFrontEndServer

Dim returnValue As String
returnValue = iFrontEndServer1.FullDomainName

Syntax

Visual Basic
ReadOnly Property FullDomainName() As String
C#
string FullDomainName {get;}
C++
property virtual String^ FullDomainName {
    String^ get();
}
J#
public System.String get_FullDomainName();
JScript
function get FullDomainName() : String;

Property Value

Full domain name of this front end server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Interface
IFrontEndServer Members


IFrontEndServer.IsActive Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves IsActive status of a front end server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iFrontEndServer1 As IFrontEndServer

Dim returnValue As Boolean
returnValue = iFrontEndServer1.IsActive

Syntax

Visual Basic
ReadOnly Property IsActive() As Boolean
C#
bool IsActive {get;}
C++
property virtual bool IsActive {
    bool get();
}
J#
public boolean get_IsActive();
JScript
function get IsActive() : Boolean;

Property Value

IsActive status of a front end server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Interface
IFrontEndServer Members


IFrontEndServer.IsMaster Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the front end server is a master server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iFrontEndServer1 As IFrontEndServer

Dim returnValue As Boolean
returnValue = iFrontEndServer1.IsMaster

Syntax

Visual Basic
ReadOnly Property IsMaster() As Boolean
C#
bool IsMaster {get;}
C++
property virtual bool IsMaster {
    bool get();
}
J#
public boolean get_IsMaster();
JScript
function get IsMaster() : Boolean;

Property Value

True if the front end server is a master server. False if the front end server is not a master server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Interface
IFrontEndServer Members


IFrontEndServer.LastContactedTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last time the server updates its heartbeat.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iFrontEndServer1 As IFrontEndServer

Dim returnValue As DateTime
returnValue = iFrontEndServer1.LastContactedTime

Syntax

Visual Basic
ReadOnly Property LastContactedTime() As DateTime
C#
DateTime LastContactedTime {get;}
C++
property virtual DateTime^ LastContactedTime {
    DateTime^ get();
}
J#
public DateTime get_LastContactedTime();
JScript
function get LastContactedTime() : DateTime;

Property Value

The last time the server updates its heartbeat.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IFrontEndServer Interface
IFrontEndServer Members


IInstallableItem Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This type defines a non-explicitly-deployable Update and all the methods that act on an it.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class installableItemImplementation
    Implements IInstallableItem
End Class
Dim installableItemImplementation1 As New installableItemImplementation()

Syntax

Visual Basic
Public Interface IInstallableItem
C#
public interface IInstallableItem
C++
public interface class IInstallableItem
J#
public interface IInstallableItem
JScript
public interface IInstallableItem

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInstallableItem Members


IInstallableItem Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This type defines a non-explicitly-deployable Update and all the methods that act on an it.

The following tables list the members exposed by the IInstallableItem type.

Public Properties

 | Name | Description
public property | Files | Gets the collection of UpdateFile in this InstallableItem.
public property | Id | Gets the globally-unique identifier for this InstallableItem.
public property | Languages | Gets all the languages supported by this InstallableItem.
Top

Public Methods

 | Name | Description
public method | GetInstallableItems | Gets the read-only collection of InstallableItem that represent the directly bundled, non-explicitly-deployable child updates of this InstallableItem.
Top

See Also

Reference

IInstallableItem Interface


IInstallableItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetInstallableItems | Gets the read-only collection of InstallableItem that represent the directly bundled, non-explicitly-deployable child updates of this InstallableItem.

See Also

Reference

IInstallableItem Interface


IInstallableItem.GetInstallableItems Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the read-only collection of InstallableItem that represent the directly bundled, non-explicitly-deployable child updates of this InstallableItem.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ReadOnlyCollection(Of IInstallableItem)
Dim iInstallableItem1 As IInstallableItem
returnValue = iInstallableItem1.GetInstallableItems()

Syntax

Visual Basic
Function GetInstallableItems() As ReadOnlyCollection(Of IInstallableItem)
C#
ReadOnlyCollection<IInstallableItem> GetInstallableItems();
C++
public:
virtual ReadOnlyCollection<IInstallableItem^>^ GetInstallableItems();
J#
public ReadOnlyCollection<IInstallableItem> GetInstallableItems();
JScript
function GetInstallableItems() : JScript does not support Generics.;

Return Value

The collection of InstallableItem that represent the directly bundled, non-explicitly-deployable child updates of this InstallableItem.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInstallableItem Interface
IInstallableItem Members


IInstallableItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Files | Gets the collection of UpdateFile in this InstallableItem.
public property | Id | Gets the globally-unique identifier for this InstallableItem.
public property | Languages | Gets all the languages supported by this InstallableItem.

See Also

Reference

IInstallableItem Interface


IInstallableItem.Files Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the collection of UpdateFile in this InstallableItem.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInstallableItem1 As IInstallableItem

Dim returnValue As ReadOnlyCollection(Of UpdateFile)
returnValue = iInstallableItem1.Files

Syntax

Visual Basic
ReadOnly Property Files() As ReadOnlyCollection(Of UpdateFile)
C#
ReadOnlyCollection<UpdateFile> Files {get;}
C++
property virtual ReadOnlyCollection<UpdateFile^>^ Files {
    ReadOnlyCollection<UpdateFile^>^ get();
}
J#
public ReadOnlyCollection<UpdateFile> get_Files();
JScript
function get Files() : JScript does not support Generics.;

Property Value

The collection of UpdateFile that represent the files belonged to this InstallableItem.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInstallableItem Interface
IInstallableItem Members


IInstallableItem.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the globally-unique identifier for this InstallableItem.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInstallableItem1 As IInstallableItem

Dim returnValue As UpdateRevisionId
returnValue = iInstallableItem1.Id

Syntax

Visual Basic
ReadOnly Property Id() As UpdateRevisionId
C#
UpdateRevisionId Id {get;}
C++
property virtual UpdateRevisionId^ Id {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_Id();
JScript
function get Id() : UpdateRevisionId;

Property Value

The globally-unique identifier of this InstallableItem.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInstallableItem Interface
IInstallableItem Members


IInstallableItem.Languages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets all the languages supported by this InstallableItem.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInstallableItem1 As IInstallableItem

Dim returnValue As StringCollection
returnValue = iInstallableItem1.Languages

Syntax

Visual Basic
ReadOnly Property Languages() As StringCollection
C#
StringCollection Languages {get;}
C++
property virtual StringCollection^ Languages {
    StringCollection^ get();
}
J#
public StringCollection get_Languages();
JScript
function get Languages() : StringCollection;

Property Value

The collection of RFC1766 style language Ids representing each language supported by this InstallableItem.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInstallableItem Interface
IInstallableItem Members


IInventoryItem Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents an Inventory item

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class inventoryItemImplementation
    Implements IInventoryItem
End Class
Dim inventoryItemImplementation1 As New inventoryItemImplementation()

Syntax

Visual Basic
Public Interface IInventoryItem
C#
public interface IInventoryItem
C++
public interface class IInventoryItem
J#
public interface IInventoryItem
JScript
public interface IInventoryItem

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Members


IInventoryItem Members
See Also Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents an Inventory item

The following tables list the members exposed by the IInventoryItem type.

Public Properties

 | Name | Description
public property | Id | Unique identifier of the inventory item.
public property | IsSummedAcrossComputers | Flag indicating if this item is being used in a summary. Some properties will be null if this is true.
public property | Name | Name of the inventory item. For hardware inventory items, this represents the display name of the hardware item (something like disk, computer, videocard). For software inventory items, this represents the name of the software item.
public property | NumberOfInstances | The number of instances of this application in the system. This is always == 1 if got from a single computer.
public property | Properties | The list of properties and values defined on the inventory item.
Top

See Also

Reference

IInventoryItem Interface


IInventoryItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Id | Unique identifier of the inventory item.
public property | IsSummedAcrossComputers | Flag indicating if this item is being used in a summary. Some properties will be null if this is true.
public property | Name | Name of the inventory item. For hardware inventory items, this represents the display name of the hardware item (something like disk, computer, videocard). For software inventory items, this represents the name of the software item.
public property | NumberOfInstances | The number of instances of this application in the system. This is always == 1 if got from a single computer.
public property | Properties | The list of properties and values defined on the inventory item.

See Also

Reference

IInventoryItem Interface


IInventoryItem.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Unique identifier of the inventory item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInventoryItem1 As IInventoryItem

Dim returnValue As Integer
returnValue = iInventoryItem1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Integer
C#
int Id {get;}
C++
property virtual int Id {
    int get();
}
J#
public int get_Id();
JScript
function get Id() : int;

Property Value

The unique identifier of the inventory item.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Interface
IInventoryItem Members


IInventoryItem.IsSummedAcrossComputers Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Flag indicating if this item is being used in a summary. Some properties will be null if this is true.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInventoryItem1 As IInventoryItem

Dim returnValue As Boolean
returnValue = iInventoryItem1.IsSummedAcrossComputers

Syntax

Visual Basic
ReadOnly Property IsSummedAcrossComputers() As Boolean
C#
bool IsSummedAcrossComputers {get;}
C++
property virtual bool IsSummedAcrossComputers {
    bool get();
}
J#
public boolean get_IsSummedAcrossComputers();
JScript
function get IsSummedAcrossComputers() : Boolean;

Property Value

Flag indicating if this item is being used in a summary.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Interface
IInventoryItem Members


IInventoryItem.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Name of the inventory item. For hardware inventory items, this represents the display name of the hardware item (something like disk, computer, videocard). For software inventory items, this represents the name of the software item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInventoryItem1 As IInventoryItem

Dim returnValue As String
returnValue = iInventoryItem1.Name

Syntax

Visual Basic
ReadOnly Property Name() As String
C#
string Name {get;}
C++
property virtual String^ Name {
    String^ get();
}
J#
public System.String get_Name();
JScript
function get Name() : String;

Property Value

The name of the inventory item.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Interface
IInventoryItem Members


IInventoryItem.NumberOfInstances Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The number of instances of this application in the system. This is always == 1 if got from a single computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInventoryItem1 As IInventoryItem

Dim returnValue As Integer
returnValue = iInventoryItem1.NumberOfInstances

Syntax

Visual Basic
ReadOnly Property NumberOfInstances() As Integer
C#
int NumberOfInstances {get;}
C++
property virtual int NumberOfInstances {
    int get();
}
J#
public int get_NumberOfInstances();
JScript
function get NumberOfInstances() : int;

Property Value

The number of instances of this application in the system.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Interface
IInventoryItem Members


IInventoryItem.Properties Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The list of properties and values defined on the inventory item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iInventoryItem1 As IInventoryItem

Dim returnValue As ReadOnlyCollection(Of InventoryItemProperty)
returnValue = iInventoryItem1.Properties

Syntax

Visual Basic
ReadOnly Property Properties() As ReadOnlyCollection(Of InventoryItemProperty)
C#
ReadOnlyCollection<InventoryItemProperty> Properties {get;}
C++
property virtual ReadOnlyCollection<InventoryItemProperty^>^ Properties {
    ReadOnlyCollection<InventoryItemProperty^>^ get();
}
J#
public ReadOnlyCollection<InventoryItemProperty> get_Properties();
JScript
function get Properties() : JScript does not support Generics.;

Property Value

The list of properties and values defined on the inventory item.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IInventoryItem Interface
IInventoryItem Members


ILicenseAgreement Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the text of the license agreement and to determine if the agreement was accepted and by whom. To retrieve this interface, call IUpdate.GetLicenseAgreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class licenseAgreementImplementation
    Implements ILicenseAgreement
End Class
Dim licenseAgreementImplementation1 As New licenseAgreementImplementation()

Syntax

Visual Basic
Public Interface ILicenseAgreement
C#
public interface ILicenseAgreement
C++
public interface class ILicenseAgreement
J#
public interface ILicenseAgreement
JScript
public interface ILicenseAgreement

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Members


ILicenseAgreement Members
See Also Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the text of the license agreement and to determine if the agreement was accepted and by whom. To retrieve this interface, call IUpdate.GetLicenseAgreement.

The following tables list the members exposed by the ILicenseAgreement type.

Public Properties

 | Name | Description
public property | AcceptedDate | Retrieves the date when the administrator accepted the license agreement.
public property | AdministratorName | Retrieves the name of the administrator who accepted the license agreement.
public property | Id | Retrieves the unique identifier of the license agreement.
public property | IsAccepted | Retrieves the value that indicates if the license agreement has been accepted.
public property | Text | Retrieves the text of the license agreement.
Top

See Also

Reference

ILicenseAgreement Interface


ILicenseAgreement Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | AcceptedDate | Retrieves the date when the administrator accepted the license agreement.
public property | AdministratorName | Retrieves the name of the administrator who accepted the license agreement.
public property | Id | Retrieves the unique identifier of the license agreement.
public property | IsAccepted | Retrieves the value that indicates if the license agreement has been accepted.
public property | Text | Retrieves the text of the license agreement.

See Also

Reference

ILicenseAgreement Interface


ILicenseAgreement.AcceptedDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date when the administrator accepted the license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iLicenseAgreement1 As ILicenseAgreement

Dim returnValue As DateTime
returnValue = iLicenseAgreement1.AcceptedDate

Syntax

Visual Basic
ReadOnly Property AcceptedDate() As DateTime
C#
DateTime AcceptedDate {get;}
C++
property virtual DateTime^ AcceptedDate {
    DateTime^ get();
}
J#
public DateTime get_AcceptedDate();
JScript
function get AcceptedDate() : DateTime;

Property Value

Date and time when the administrator first accepted the license agreement. The date is in Coordinated Universal Time. The value is DateTime.MinValue if ILicenseAgreement.IsAccepted is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Interface
ILicenseAgreement Members
Microsoft.UpdateServices.Administration Namespace
ILicenseAgreement.AdministratorName


ILicenseAgreement.AdministratorName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the administrator who accepted the license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iLicenseAgreement1 As ILicenseAgreement

Dim returnValue As String
returnValue = iLicenseAgreement1.AdministratorName

Syntax

Visual Basic
ReadOnly Property AdministratorName() As String
C#
string AdministratorName {get;}
C++
property virtual String^ AdministratorName {
    String^ get();
}
J#
public System.String get_AdministratorName();
JScript
function get AdministratorName() : String;

Property Value

Name of the administrator who first accepted the license agreement. The name is in the form, domain\username. The string is empty if ILicenseAgreement.IsAccepted is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Interface
ILicenseAgreement Members
Microsoft.UpdateServices.Administration Namespace
ILicenseAgreement.AcceptedDate


ILicenseAgreement.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iLicenseAgreement1 As ILicenseAgreement

Dim returnValue As Guid
returnValue = iLicenseAgreement1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the license agreement.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Interface
ILicenseAgreement Members


ILicenseAgreement.IsAccepted Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the value that indicates if the license agreement has been accepted.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iLicenseAgreement1 As ILicenseAgreement

Dim returnValue As Boolean
returnValue = iLicenseAgreement1.IsAccepted

Syntax

Visual Basic
ReadOnly Property IsAccepted() As Boolean
C#
bool IsAccepted {get;}
C++
property virtual bool IsAccepted {
    bool get();
}
J#
public boolean get_IsAccepted();
JScript
function get IsAccepted() : Boolean;

Property Value

True if the license agreement has been accepted; otherwise, false.

Remarks

A license agreement can cover one or more updates, so accepting the agreement for one update automatically accepts the agreement for the other updates that are covered by the agreement.

Revisions to an update may require the administrator to accept the license agreement again.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Interface
ILicenseAgreement Members


ILicenseAgreement.Text Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the text of the license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iLicenseAgreement1 As ILicenseAgreement

Dim returnValue As String
returnValue = iLicenseAgreement1.Text

Syntax

Visual Basic
ReadOnly Property Text() As String
C#
string Text {get;}
C++
property virtual String^ Text {
    String^ get();
}
J#
public System.String get_Text();
JScript
function get Text() : String;

Property Value

Text of the license agreement. The property returns the text using the preferred culture if the localized text is available; otherwise, the text is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ILicenseAgreement Interface
ILicenseAgreement Members


InstallableItem Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The properties of the InstallableItem class. Each package contains one or more installable items. Typically applications have a single installable item and updates could have several instances

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Syntax

Visual Basic
Public Class InstallableItem
C#
public class InstallableItem
C++
public ref class InstallableItem
J#
public class InstallableItem
JScript
public class InstallableItem

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallableItem
Microsoft.UpdateServices.Administration.CommandLineItem
Microsoft.UpdateServices.Administration.WindowsInstallerItem
Microsoft.UpdateServices.Administration.WindowsInstallerPatchItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Members


InstallableItem Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The properties of the InstallableItem class. Each package contains one or more installable items. Typically applications have a single installable item and updates could have several instances

The following tables list the members exposed by the InstallableItem type.

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.
public property | Id | Retrieves the ID uniquely identifying the InstallableItem
public property | InstallBehavior | Get/Set InstallBehavior property
public property | InstallHandlerSpecificData |
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.
public property | Languages | Retrieves the list of languages that this binary has been localized to.
public property | OriginalSourceFile | Retrieve the original source of this update.
public property | UninstallBehavior | Get/Set UninstallBehavior
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml |
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InstallableItem Class


InstallableItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml |
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InstallableItem Class


InstallableItem.GetXml Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class installableItemImplementation
    Inherits InstallableItem
        Protected Overrides Function GetXml(elementName As String, _
            installHandlerSpecificXml As String)
            MyBase.GetXml(elementName, installHandlerSpecificXml)
        End Function
End Class

Syntax

Visual Basic
Protected Function GetXml( _
    ByVal elementName As String, _
    ByVal installHandlerSpecificXml As String _
) As String
C#
protected string GetXml(
    string elementName,
    string installHandlerSpecificXml
);
C++
protected:
String^ GetXml(
    String^ elementName,
    String^ installHandlerSpecificXml
);
J#
protected System.String GetXml(
    System.String elementName,
    System.String installHandlerSpecificXml
);
JScript
protected function GetXml(
     elementName : String,
     installHandlerSpecificXml : String
) : String;

Parameters

elementName

installHandlerSpecificXml

Remarks

This method is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.
public property | Id | Retrieves the ID uniquely identifying the InstallableItem
public property | InstallBehavior | Get/Set InstallBehavior property
public property | InstallHandlerSpecificData |
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.
public property | Languages | Retrieves the list of languages that this binary has been localized to.
public property | OriginalSourceFile | Retrieve the original source of this update.
public property | UninstallBehavior | Get/Set UninstallBehavior

See Also

Reference

InstallableItem Class


InstallableItem.ApplicabilityMetadata Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets Metadata applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As String
returnValue = installableItem1.ApplicabilityMetadata

Dim sampleValue As String
installableItem1.ApplicabilityMetadata = sampleValue

Syntax

Visual Basic
Public Property ApplicabilityMetadata() As String
C#
public string ApplicabilityMetadata {get; set;}
C++
public:
property String^ ApplicabilityMetadata {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ApplicabilityMetadata();
public void set_ApplicabilityMetadata(System.String);
JScript
public function get ApplicabilityMetadata() : String;
public function set ApplicabilityMetadata(String);

Property Value

Metadata applicability rules of this installable item.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the ID uniquely identifying the InstallableItem

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As Guid
returnValue = installableItem1.Id

Dim sampleValue As Guid
installableItem1.Id = sampleValue

Syntax

Visual Basic
Public Property Id() As Guid
C#
public Guid Id {get; set;}
C++
public:
property Guid^ Id {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_Id();
public void set_Id(Guid);
JScript
public function get Id() : Guid;
public function set Id(Guid);

Property Value

The ID uniquely identifying the InstallableItem

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.InstallBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set InstallBehavior property

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As InstallBehavior
returnValue = installableItem1.InstallBehavior

Dim sampleValue As InstallBehavior
installableItem1.InstallBehavior = sampleValue

Syntax

Visual Basic
Public Property InstallBehavior() As InstallBehavior
C#
public InstallBehavior InstallBehavior {get; set;}
C++
public:
property InstallBehavior^ InstallBehavior {
    InstallBehavior^ get();
    void set(InstallBehavior^ value);
}
J#
public InstallBehavior get_InstallBehavior();
public void set_InstallBehavior(InstallBehavior);
JScript
public function get InstallBehavior() : InstallBehavior;
public function set InstallBehavior(InstallBehavior);

Property Value

The InstallBehavior.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.InstallHandlerSpecificData Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As Object
returnValue = installableItem1.InstallHandlerSpecificData

Syntax

Visual Basic
Public ReadOnly Property InstallHandlerSpecificData() As Object
C#
public object InstallHandlerSpecificData {get;}
C++
public:
property Object^ InstallHandlerSpecificData {
    Object^ get();
}
J#
public System.Object get_InstallHandlerSpecificData();
JScript
public function get InstallHandlerSpecificData() : Object;

Property Value

This property value is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.IsInstallableApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the IsInstallable applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As String
returnValue = installableItem1.IsInstallableApplicabilityRule

Dim sampleValue As String
installableItem1.IsInstallableApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsInstallableApplicabilityRule() As String
C#
public string IsInstallableApplicabilityRule {get; set;}
C++
public:
property String^ IsInstallableApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsInstallableApplicabilityRule();
public void set_IsInstallableApplicabilityRule(System.String);
JScript
public function get IsInstallableApplicabilityRule() : String;
public function set IsInstallableApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is installable on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.IsInstalledApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the InInstalled applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As String
returnValue = installableItem1.IsInstalledApplicabilityRule

Dim sampleValue As String
installableItem1.IsInstalledApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsInstalledApplicabilityRule() As String
C#
public string IsInstalledApplicabilityRule {get; set;}
C++
public:
property String^ IsInstalledApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsInstalledApplicabilityRule();
public void set_IsInstalledApplicabilityRule(System.String);
JScript
public function get IsInstalledApplicabilityRule() : String;
public function set IsInstalledApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is installed on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.IsSupersededApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the IsSupersed applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As String
returnValue = installableItem1.IsSupersededApplicabilityRule

Dim sampleValue As String
installableItem1.IsSupersededApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsSupersededApplicabilityRule() As String
C#
public string IsSupersededApplicabilityRule {get; set;}
C++
public:
property String^ IsSupersededApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsSupersededApplicabilityRule();
public void set_IsSupersededApplicabilityRule(System.String);
JScript
public function get IsSupersededApplicabilityRule() : String;
public function set IsSupersededApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is superseded by another update on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.Languages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of languages that this binary has been localized to.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As StringCollection
returnValue = installableItem1.Languages

Syntax

Visual Basic
Public ReadOnly Property Languages() As StringCollection
C#
public StringCollection Languages {get;}
C++
public:
property StringCollection^ Languages {
    StringCollection^ get();
}
J#
public StringCollection get_Languages();
JScript
public function get Languages() : StringCollection;

Property Value

The languages that this binary has been localized to. If empty, the item is language-independent.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.OriginalSourceFile Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieve the original source of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As FileForInstallableItem
returnValue = installableItem1.OriginalSourceFile

Dim sampleValue As FileForInstallableItem
installableItem1.OriginalSourceFile = sampleValue

Syntax

Visual Basic
Public Property OriginalSourceFile() As FileForInstallableItem
C#
public FileForInstallableItem OriginalSourceFile {get; set;}
C++
public:
property FileForInstallableItem^ OriginalSourceFile {
    FileForInstallableItem^ get();
    void set(FileForInstallableItem^ value);
}
J#
public FileForInstallableItem get_OriginalSourceFile();
public void set_OriginalSourceFile(FileForInstallableItem);
JScript
public function get OriginalSourceFile() : FileForInstallableItem;
public function set OriginalSourceFile(FileForInstallableItem);

Remarks

This is an optional property. Systems Management Server is the only user of this property, currently.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItem.UninstallBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set UninstallBehavior

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItem1 As InstallableItem

Dim returnValue As InstallBehavior
returnValue = installableItem1.UninstallBehavior

Dim sampleValue As InstallBehavior
installableItem1.UninstallBehavior = sampleValue

Syntax

Visual Basic
Public Property UninstallBehavior() As InstallBehavior
C#
public InstallBehavior UninstallBehavior {get; set;}
C++
public:
property InstallBehavior^ UninstallBehavior {
    InstallBehavior^ get();
    void set(InstallBehavior^ value);
}
J#
public InstallBehavior get_UninstallBehavior();
public void set_UninstallBehavior(InstallBehavior);
JScript
public function get UninstallBehavior() : InstallBehavior;
public function set UninstallBehavior(InstallBehavior);

Property Value

The uninstall behavior.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItem Class
InstallableItem Members


InstallableItemWithServerInformation Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

An overloaded class which duplicates all public methods of InstallableItem class and allow callers to access Server Specific properties.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As InstallableItem
Dim installableItemWithServerInformation1 As New InstallableItemWithServerInformation(value)

Syntax

Visual Basic
Public Class InstallableItemWithServerInformation
C#
public class InstallableItemWithServerInformation
C++
public ref class InstallableItemWithServerInformation
J#
public class InstallableItemWithServerInformation
JScript
public class InstallableItemWithServerInformation

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallableItemWithServerInformation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Members


InstallableItemWithServerInformation Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

An overloaded class which duplicates all public methods of InstallableItem class and allow callers to access Server Specific properties.

The following tables list the members exposed by the InstallableItemWithServerInformation type.

Public Constructors

Name | Description
InstallableItemWithServerInformation | Constructs a new InstallableItemWithServerInformation instance, copying over values from the specified InstallableItem instance.
Top

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.
public property | Id | Retrieves or sets the unique identifier of InstallableItemWithServerInformation
public property | InstallationPointDirectory | Retrieves or sets the InstallationPointDirectory.
public property | InstallationSourceCabFile | Retrieves or sets the PackageCabFile location.
public property | InstallBehavior | Retrieves or sets the InstallBehavior property
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.
public property | Languages | Retrieves the list of languages that this binary has been localized to.
public property | OriginalSourceFile | Retrieve the original source of this update.
public property | RepairPaths | This is used for publishing to fill server specific information for RepairPath. It actually only needs to the fill Path property.
public property | ServerSpecificFileInformation | Retrieves or sets Server specific information.
public property | UninstallBehavior | Retrieves or sets UninstallBehavior
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InstallableItemWithServerInformation Class


InstallableItemWithServerInformation Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructs a new InstallableItemWithServerInformation instance, copying over values from the specified InstallableItem instance.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As InstallableItem
Dim installableItemWithServerInformation1 As New InstallableItemWithServerInformation(value)

Syntax

Visual Basic
Public Sub New( _
    ByVal value As InstallableItem _
)
C#
public InstallableItemWithServerInformation(
    InstallableItem value
);
C++
public:
InstallableItemWithServerInformation(
    InstallableItem^ value
);
J#
public InstallableItemWithServerInformation(
    InstallableItem value
);
JScript
public function InstallableItemWithServerInformation(
     value : InstallableItem
);

Parameters

value

The InstallableItem instance to copy property values from.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InstallableItemWithServerInformation Class


InstallableItemWithServerInformation Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.
public property | Id | Retrieves or sets the unique identifier of InstallableItemWithServerInformation
public property | InstallationPointDirectory | Retrieves or sets the InstallationPointDirectory.
public property | InstallationSourceCabFile | Retrieves or sets the PackageCabFile location.
public property | InstallBehavior | Retrieves or sets the InstallBehavior property
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.
public property | Languages | Retrieves the list of languages that this binary has been localized to.
public property | OriginalSourceFile | Retrieve the original source of this update.
public property | RepairPaths | This is used for publishing to fill server specific information for RepairPath. It actually only needs to the fill Path property.
public property | ServerSpecificFileInformation | Retrieves or sets Server specific information.
public property | UninstallBehavior | Retrieves or sets UninstallBehavior

See Also

Reference

InstallableItemWithServerInformation Class


InstallableItemWithServerInformation.ApplicabilityMetadata Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets Metadata applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.ApplicabilityMetadata

Dim sampleValue As String
installableItemWithServerInformation1.ApplicabilityMetadata = sampleValue

Syntax

Visual Basic
Public Property ApplicabilityMetadata() As String
C#
public string ApplicabilityMetadata {get; set;}
C++
public:
property String^ ApplicabilityMetadata {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ApplicabilityMetadata();
public void set_ApplicabilityMetadata(System.String);
JScript
public function get ApplicabilityMetadata() : String;
public function set ApplicabilityMetadata(String);

Property Value

Metadata applicability rules of this installable item.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the unique identifier of InstallableItemWithServerInformation

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As Guid
returnValue = installableItemWithServerInformation1.Id

Dim sampleValue As Guid
installableItemWithServerInformation1.Id = sampleValue

Syntax

Visual Basic
Public Property Id() As Guid
C#
public Guid Id {get; set;}
C++
public:
property Guid^ Id {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_Id();
public void set_Id(Guid);
JScript
public function get Id() : Guid;
public function set Id(Guid);

Property Value

The ID uniquely identifying the InstallableItem

Remarks

Duplication functions to access underneath object.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.InstallationPointDirectory Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the InstallationPointDirectory.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.InstallationPointDirectory

Dim sampleValue As String
installableItemWithServerInformation1.InstallationPointDirectory = sampleValue

Syntax

Visual Basic
Public Property InstallationPointDirectory() As String
C#
public string InstallationPointDirectory {get; set;}
C++
public:
property String^ InstallationPointDirectory {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_InstallationPointDirectory();
public void set_InstallationPointDirectory(System.String);
JScript
public function get InstallationPointDirectory() : String;
public function set InstallationPointDirectory(String);

Property Value

The InstallationPointDirectory.

Remarks

WSUS-specific. This value will be set by WSUS Publishing function in publishing.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.InstallationSourceCabFile Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the PackageCabFile location.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.InstallationSourceCabFile

Dim sampleValue As String
installableItemWithServerInformation1.InstallationSourceCabFile = sampleValue

Syntax

Visual Basic
Public Property InstallationSourceCabFile() As String
C#
public string InstallationSourceCabFile {get; set;}
C++
public:
property String^ InstallationSourceCabFile {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_InstallationSourceCabFile();
public void set_InstallationSourceCabFile(System.String);
JScript
public function get InstallationSourceCabFile() : String;
public function set InstallationSourceCabFile(String);

Property Value

The PackageCabFile location.

Remarks

Note: WSUS specific file details. This value will be set by WSUS publishing function during publishing.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.InstallBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the InstallBehavior property

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As InstallBehavior
returnValue = installableItemWithServerInformation1.InstallBehavior

Dim sampleValue As InstallBehavior
installableItemWithServerInformation1.InstallBehavior = sampleValue

Syntax

Visual Basic
Public Property InstallBehavior() As InstallBehavior
C#
public InstallBehavior InstallBehavior {get; set;}
C++
public:
property InstallBehavior^ InstallBehavior {
    InstallBehavior^ get();
    void set(InstallBehavior^ value);
}
J#
public InstallBehavior get_InstallBehavior();
public void set_InstallBehavior(InstallBehavior);
JScript
public function get InstallBehavior() : InstallBehavior;
public function set InstallBehavior(InstallBehavior);

Property Value

The InstallBehavior.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.IsInstallableApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the IsInstallable applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.IsInstallableApplicabilityRule

Dim sampleValue As String
installableItemWithServerInformation1.IsInstallableApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsInstallableApplicabilityRule() As String
C#
public string IsInstallableApplicabilityRule {get; set;}
C++
public:
property String^ IsInstallableApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsInstallableApplicabilityRule();
public void set_IsInstallableApplicabilityRule(System.String);
JScript
public function get IsInstallableApplicabilityRule() : String;
public function set IsInstallableApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is installable on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.IsInstalledApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the InInstalled applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.IsInstalledApplicabilityRule

Dim sampleValue As String
installableItemWithServerInformation1.IsInstalledApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsInstalledApplicabilityRule() As String
C#
public string IsInstalledApplicabilityRule {get; set;}
C++
public:
property String^ IsInstalledApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsInstalledApplicabilityRule();
public void set_IsInstalledApplicabilityRule(System.String);
JScript
public function get IsInstalledApplicabilityRule() : String;
public function set IsInstalledApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is installed on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.IsSupersededApplicabilityRule Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the IsSupersed applicability rules of this installable item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As String
returnValue = installableItemWithServerInformation1.IsSupersededApplicabilityRule

Dim sampleValue As String
installableItemWithServerInformation1.IsSupersededApplicabilityRule = sampleValue

Syntax

Visual Basic
Public Property IsSupersededApplicabilityRule() As String
C#
public string IsSupersededApplicabilityRule {get; set;}
C++
public:
property String^ IsSupersededApplicabilityRule {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsSupersededApplicabilityRule();
public void set_IsSupersededApplicabilityRule(System.String);
JScript
public function get IsSupersededApplicabilityRule() : String;
public function set IsSupersededApplicabilityRule(String);

Property Value

Rules for determining whether or not this item is superseded by another update on a given computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.Languages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of languages that this binary has been localized to.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As StringCollection
returnValue = installableItemWithServerInformation1.Languages

Syntax

Visual Basic
Public ReadOnly Property Languages() As StringCollection
C#
public StringCollection Languages {get;}
C++
public:
property StringCollection^ Languages {
    StringCollection^ get();
}
J#
public StringCollection get_Languages();
JScript
public function get Languages() : StringCollection;

Property Value

The languages that this binary has been localized to. If empty, the item is language-independent.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.OriginalSourceFile Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieve the original source of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As FileForInstallableItem
returnValue = installableItemWithServerInformation1.OriginalSourceFile

Dim sampleValue As FileForInstallableItem
installableItemWithServerInformation1.OriginalSourceFile = sampleValue

Syntax

Visual Basic
Public Property OriginalSourceFile() As FileForInstallableItem
C#
public FileForInstallableItem OriginalSourceFile {get; set;}
C++
public:
property FileForInstallableItem^ OriginalSourceFile {
    FileForInstallableItem^ get();
    void set(FileForInstallableItem^ value);
}
J#
public FileForInstallableItem get_OriginalSourceFile();
public void set_OriginalSourceFile(FileForInstallableItem);
JScript
public function get OriginalSourceFile() : FileForInstallableItem;
public function set OriginalSourceFile(FileForInstallableItem);

Property Value

Specifies original can on Download Center.

Remarks

This is an optional property. Systems Management Server is the only user of this property, currently.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.RepairPaths Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This is used for publishing to fill server specific information for RepairPath. It actually only needs to the fill Path property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As IList(Of WindowsInstallerRepairPath)
returnValue = installableItemWithServerInformation1.RepairPaths

Syntax

Visual Basic
Public ReadOnly Property RepairPaths() As IList(Of WindowsInstallerRepairPath)
C#
public IList<WindowsInstallerRepairPath> RepairPaths {get;}
C++
public:
property IList<WindowsInstallerRepairPath^>^ RepairPaths {
    IList<WindowsInstallerRepairPath^>^ get();
}
J#
public IList<WindowsInstallerRepairPath> get_RepairPaths();
JScript
public function get RepairPaths() : JScript does not support Generics.;

Property Value

The list of repair paths.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.ServerSpecificFileInformation Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets Server specific information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As FileForInstallableItem
returnValue = installableItemWithServerInformation1.ServerSpecificFileInformation

Dim sampleValue As FileForInstallableItem
installableItemWithServerInformation1.ServerSpecificFileInformation = sampleValue

Syntax

Visual Basic
Public Property ServerSpecificFileInformation() As FileForInstallableItem
C#
public FileForInstallableItem ServerSpecificFileInformation {get; set;}
C++
public:
property FileForInstallableItem^ ServerSpecificFileInformation {
    FileForInstallableItem^ get();
    void set(FileForInstallableItem^ value);
}
J#
public FileForInstallableItem get_ServerSpecificFileInformation();
public void set_ServerSpecificFileInformation(FileForInstallableItem);
JScript
public function get ServerSpecificFileInformation() : FileForInstallableItem;
public function set ServerSpecificFileInformation(FileForInstallableItem);

Property Value

Server specific file information.

Remarks

This value will be set by WSUS publishing function during publishing.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallableItemWithServerInformation.UninstallBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets UninstallBehavior

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installableItemWithServerInformation1 As InstallableItemWithServerInformation

Dim returnValue As InstallBehavior
returnValue = installableItemWithServerInformation1.UninstallBehavior

Dim sampleValue As InstallBehavior
installableItemWithServerInformation1.UninstallBehavior = sampleValue

Syntax

Visual Basic
Public Property UninstallBehavior() As InstallBehavior
C#
public InstallBehavior UninstallBehavior {get; set;}
C++
public:
property InstallBehavior^ UninstallBehavior {
    InstallBehavior^ get();
    void set(InstallBehavior^ value);
}
J#
public InstallBehavior get_UninstallBehavior();
public void set_UninstallBehavior(InstallBehavior);
JScript
public function get UninstallBehavior() : InstallBehavior;
public function set UninstallBehavior(InstallBehavior);

Property Value

The uninstall behavior

Remarks

Has the same properties as InstallBehavior

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallableItemWithServerInformation Class
InstallableItemWithServerInformation Members


InstallationBehavior Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the installation behavior of the update. To retrieve this class, call the InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationIUpdateClassInstallationBehaviorTopic property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As New InstallationBehavior()

Syntax

Visual Basic
Public Class InstallationBehavior
C#
public class InstallationBehavior
C++
public ref class InstallationBehavior
J#
public class InstallationBehavior
JScript
public class InstallationBehavior

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallationBehavior

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Members


InstallationBehavior Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the installation behavior of the update. To retrieve this class, call the InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationIUpdateClassInstallationBehaviorTopic property.

The following tables list the members exposed by the InstallationBehavior type.

Public Constructors

Name | Description
InstallationBehavior | Overloaded. Constructor.
Top

Public Properties

 | Name | Description
public property | CanRequestUserInput | Determines if the update installation program may request input from the user.
public property | Impact | Retrieves or sets the impact to the user and other applications when installing the update on the client computer.
public property | IsSupported | Determines if the update supports the approval action associated with the update.
public property | RebootBehavior | Retrieves or sets the restart behavior of the update.
public property | RequiresNetworkConnectivity | Determines if the installation of the update requires network connectivity.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InstallationBehavior Class


InstallationBehavior Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor.

Overload List

Name | Description
InstallationBehavior () | Initializes a new instance of the InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationInstallationBehaviorClassTopic class.
InstallationBehavior (Boolean, Boolean, InstallationImpact, RebootBehavior, Boolean) | Initializes a new instance of the InstallationBehavior class.

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationInstallationBehaviorClassTopic class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As New InstallationBehavior()

Syntax

Visual Basic
Public Sub New()
C#
public InstallationBehavior();
C++
public:
InstallationBehavior();
J#
public InstallationBehavior();
JScript
public function InstallationBehavior();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior Constructor (Boolean, Boolean, InstallationImpact, RebootBehavior, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the InstallationBehavior class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim isSupported As Boolean
Dim canRequestUserInput As Boolean
Dim impact As InstallationImpact
Dim rebootBehavior As RebootBehavior
Dim requiresNetworkConnectivity As Boolean
Dim installationBehavior1 As New InstallationBehavior(isSupported, canRequestUserInput, impact, rebootBehavior, requiresNetworkConnectivity)

Syntax

Visual Basic
Public Sub New( _
    ByVal isSupported As Boolean, _
    ByVal canRequestUserInput As Boolean, _
    ByVal impact As InstallationImpact, _
    ByVal rebootBehavior As RebootBehavior, _
    ByVal requiresNetworkConnectivity As Boolean _
)
C#
public InstallationBehavior(
    bool isSupported,
    bool canRequestUserInput,
    InstallationImpact impact,
    RebootBehavior rebootBehavior,
    bool requiresNetworkConnectivity
);
C++
public:
InstallationBehavior(
    bool isSupported,
    bool canRequestUserInput,
    InstallationImpact impact,
    RebootBehavior rebootBehavior,
    bool requiresNetworkConnectivity
);
J#
public InstallationBehavior(
    boolean isSupported,
    boolean canRequestUserInput,
    InstallationImpact impact,
    RebootBehavior rebootBehavior,
    boolean requiresNetworkConnectivity
);
JScript
public function InstallationBehavior(
     isSupported : Boolean,
     canRequestUserInput : Boolean,
     impact : InstallationImpact,
     rebootBehavior : RebootBehavior,
     requiresNetworkConnectivity : Boolean
);

Parameters

isSupported

true if the update supports the update approval action; otherwise, false.

canRequestUserInput

true if the update can require input from the user; otherwise, false.

impact

Specify the impact to the user and applications when installing the update on the computer. For details, see InstallationImpact frlrfMicrosoftUpdateServicesAdministrationInstallationImpactClassTopic.

rebootBehavior

Specify if the update requires the computer to be restarted in order for the update to take effect. For details, see RebootBehavior frlrfMicrosoftUpdateServicesAdministrationRebootBehaviorClassTopic.

requiresNetworkConnectivity

true if the installation of the update requires network connectivity; otherwise, false.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | impact is not a defined enum value. -or- rebootBehavior is not a defined enum value.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InstallationBehavior Class


InstallationBehavior Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | CanRequestUserInput | Determines if the update installation program may request input from the user.
public property | Impact | Retrieves or sets the impact to the user and other applications when installing the update on the client computer.
public property | IsSupported | Determines if the update supports the approval action associated with the update.
public property | RebootBehavior | Retrieves or sets the restart behavior of the update.
public property | RequiresNetworkConnectivity | Determines if the installation of the update requires network connectivity.

See Also

Reference

InstallationBehavior Class


InstallationBehavior.CanRequestUserInput Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the update installation program may request input from the user.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As InstallationBehavior

Dim returnValue As Boolean
returnValue = installationBehavior1.CanRequestUserInput

Dim sampleValue As Boolean
installationBehavior1.CanRequestUserInput = sampleValue

Syntax

Visual Basic
Public Property CanRequestUserInput() As Boolean
C#
public bool CanRequestUserInput {get; set;}
C++
public:
property bool CanRequestUserInput {
    bool get();
    void set(bool value);
}
J#
public boolean get_CanRequestUserInput();
public void set_CanRequestUserInput(boolean);
JScript
public function get CanRequestUserInput() : Boolean;
public function set CanRequestUserInput(Boolean);

Property Value

true if the installation program can request input from the user; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior.Impact Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the impact to the user and other applications when installing the update on the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As InstallationBehavior

Dim returnValue As InstallationImpact
returnValue = installationBehavior1.Impact

Dim sampleValue As InstallationImpact
installationBehavior1.Impact = sampleValue

Syntax

Visual Basic
Public Property Impact() As InstallationImpact
C#
public InstallationImpact Impact {get; set;}
C++
public:
property InstallationImpact Impact {
    InstallationImpact get();
    void set(InstallationImpact value);
}
J#
public InstallationImpact get_Impact();
public void set_Impact(InstallationImpact);
JScript
public function get Impact() : InstallationImpact;
public function set Impact(InstallationImpact);

Property Value

Impact of installing the update on the client computer. For example, can you continue to use the computer while the update installs or do you need to close all applications and restart the computer. For details, see InstallationImpact frlrfMicrosoftUpdateServicesAdministrationInstallationImpactClassTopic.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | Attempted to set a value that is an invalid impact value.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior.IsSupported Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the update supports the approval action associated with the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As InstallationBehavior

Dim returnValue As Boolean
returnValue = installationBehavior1.IsSupported

Dim sampleValue As Boolean
installationBehavior1.IsSupported = sampleValue

Syntax

Visual Basic
Public Property IsSupported() As Boolean
C#
public bool IsSupported {get; set;}
C++
public:
property bool IsSupported {
    bool get();
    void set(bool value);
}
J#
public boolean get_IsSupported();
public void set_IsSupported(boolean);
JScript
public function get IsSupported() : Boolean;
public function set IsSupported(Boolean);

Property Value

true if the update supports the action; otherwise, false.

Remarks

Typically, updates support the Install action; however, some updates may not support the Uninstall action.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior.RebootBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the restart behavior of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As InstallationBehavior

Dim returnValue As RebootBehavior
returnValue = installationBehavior1.RebootBehavior

Dim sampleValue As RebootBehavior
installationBehavior1.RebootBehavior = sampleValue

Syntax

Visual Basic
Public Property RebootBehavior() As RebootBehavior
C#
public RebootBehavior RebootBehavior {get; set;}
C++
public:
property RebootBehavior RebootBehavior {
    RebootBehavior get();
    void set(RebootBehavior value);
}
J#
public RebootBehavior get_RebootBehavior();
public void set_RebootBehavior(RebootBehavior);
JScript
public function get RebootBehavior() : RebootBehavior;
public function set RebootBehavior(RebootBehavior);

Property Value

Indicates if the update requires the computer to be restarted in order for the update to take effect. For details, see RebootBehavior frlrfMicrosoftUpdateServicesAdministrationRebootBehaviorClassTopic.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | Attempted to set a value that is an invalid reboot behavior.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationBehavior.RequiresNetworkConnectivity Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the installation of the update requires network connectivity.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationBehavior1 As InstallationBehavior

Dim returnValue As Boolean
returnValue = installationBehavior1.RequiresNetworkConnectivity

Dim sampleValue As Boolean
installationBehavior1.RequiresNetworkConnectivity = sampleValue

Syntax

Visual Basic
Public Property RequiresNetworkConnectivity() As Boolean
C#
public bool RequiresNetworkConnectivity {get; set;}
C++
public:
property bool RequiresNetworkConnectivity {
    bool get();
    void set(bool value);
}
J#
public boolean get_RequiresNetworkConnectivity();
public void set_RequiresNetworkConnectivity(boolean);
JScript
public function get RequiresNetworkConnectivity() : Boolean;
public function set RequiresNetworkConnectivity(Boolean);

Property Value

true if the installation of the update requires network connectivity and the Client will not attempt the action if the machine is not connected to a network; otherwise, false.

Remarks

Note that this attribute does not test reachability of the Internet or any particular network server; that can be tested with applicabiilty rules.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallationBehavior Class
InstallationBehavior Members


InstallationImpact Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the possible impact an update may have on the computer or on other applications that are running on the computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationImpact1 As InstallationImpact = InstallationImpact.Minor

Syntax

Visual Basic
Public Enum InstallationImpact
C#
public enum InstallationImpact
C++
public enum class InstallationImpact
J#
public enum InstallationImpact
JScript
public enum InstallationImpact

Members

Member name | Description
Minor | Specifies that the Update qualifies as a "zero service interruption" (ZSI) Update. Installing/uninstalling a ZSI Update results in negligible impact on the system. This is the desired behavior for all Updates. The Update must meet stringent requirements to qualify for this rating, including but not limited to: it must not perform or require a reboot, it must not display any UI, and it must install/uninstall successfully even if it affects an application or service that is currently in use. Updates that qualify for this rating may be eligible for special handling within MSUS, such as accelerated distribution.
Normal | Specifies that installing/uninstalling the Update will result in the level of impact to the system that is typical to most updates. This means, in essence, that the update does not qualify for any of the special impact ratings defined below.
RequiresExclusiveHandling | Specifies that installing or uninstalling the update results in such a high impact to the system that it must be installed "exclusively". This means the MSUS Client will install or uninstall this Update by itself without batching it together with others. Update authors should avoid authoring exclusive Updates if at all possible. Exclusive Updates typically reboot during or after installation (although it is permitted to author an exclusive Update that does not reboot). Exclusive Updates may face restrictions in how they may be distributed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


InstallationResult Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The result of an installation or uninstallation. All installations and uninstallations must result in one of these values.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationResult1 As InstallationResult = InstallationResult.Cancelled

Syntax

Visual Basic
Public Enum InstallationResult
C#
public enum InstallationResult
C++
public enum class InstallationResult
J#
public enum InstallationResult
JScript
public enum InstallationResult

Members

Member name | Description
Cancelled | 0x01
Failed | 0x02
Succeeded | 0x03

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


InstallationStatus Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants for the possible installation states of an update on the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installationStatus1 As InstallationStatus = InstallationStatus.DetectionComplete

Syntax

Visual Basic
Public Enum InstallationStatus
C#
public enum InstallationStatus
C++
public enum class InstallationStatus
J#
public enum InstallationStatus
JScript
public enum InstallationStatus

Members

Member name | Description
DetectionComplete | Completed scanning the client computer for applicable updates.
DetectionFailed | Scanning of the client computer for applicable updates failed.
DownloadCanceled | Downloading of the update to the client computer was canceled.
DownloadFailed | Downloading of the update to the client computer failed.
DownloadSucceeded | Downloading of the update to the client computer succeeded.
Failed | Failed to install the update on the client computer.
Installable | The update is applicable to the client computer, but the update is not installed.
Installed | The update is applicable to the client computer and is currently installed.
NotApplicable | The update is not applicable to the client computer.
Started | Started the installation or removal of an update on the client computer.
Succeeded | Successfully installed the update on the client computer.
Superseded | The update is applicable to the client computer, but the update is superseded by another update that is currently installed.
UninstallationFailed | Failed to remove the update from the client computer.
UninstallationSucceeded | Successfully removed the update from the client computer.
Unknown | The installation status is unknown. The client may not have synchronized with the WSUS server.

Remarks

The client sends the following status codes to indicate the result of a scan (which occurs when the update is deployed for scan, install, or uninstall):

  • Installable

  • Installed

  • Superseded

  • NotApplicable

The client sends the following status codes when it initiates the detection logic (the client asks the WSUS server for a list of updates and then scans itself to determine which updates apply). The status codes are not associated with an update.

  • DetectionComplete

  • DetectionFailed

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.Status


InstallBehavior Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Behaviors of the Update for a specific action

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As New InstallBehavior()

Syntax

Visual Basic
Public Class InstallBehavior
C#
public class InstallBehavior
C++
public ref class InstallBehavior
J#
public class InstallBehavior
JScript
public class InstallBehavior

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallBehavior

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Members


InstallBehavior Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Behaviors of the Update for a specific action

The following tables list the members exposed by the InstallBehavior type.

Public Constructors

Name | Description
InstallBehavior | Default constructor.
Top

Public Properties

 | Name | Description
public property | CanRequestUserInput | Retrieves or sets a value indicating if user input will be requested.
public property | Impact | Retrieves or sets the impact of this action.
public property | RebootBehavior | Retrieves or sets the reboot behavior for this action.
public property | RequiresNetworkConnectivity | Retrieves or sets a value indicating whether this action requires network connectivity.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | GetXml | Get XML
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InstallBehavior Class


InstallBehavior Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As New InstallBehavior()

Syntax

Visual Basic
Public Sub New()
C#
public InstallBehavior();
C++
public:
InstallBehavior();
J#
public InstallBehavior();
JScript
public function InstallBehavior();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InstallBehavior Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | GetXml | Get XML
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InstallBehavior Class


InstallBehavior.GetXml Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get XML

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim elementName As String
Dim returnValue As String
Dim installBehavior1 As InstallBehavior
returnValue = installBehavior1.GetXml(elementName)

Syntax

Visual Basic
Public Function GetXml( _
    ByVal elementName As String _
) As String
C#
public string GetXml(
    string elementName
);
C++
public:
String^ GetXml(
    String^ elementName
);
J#
public System.String GetXml(
    System.String elementName
);
JScript
public function GetXml(
     elementName : String
) : String;

Parameters

elementName

The name of the root element.

Return Value

An XML element string representing this InstallBehavior instance.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InstallBehavior Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | CanRequestUserInput | Retrieves or sets a value indicating if user input will be requested.
public property | Impact | Retrieves or sets the impact of this action.
public property | RebootBehavior | Retrieves or sets the reboot behavior for this action.
public property | RequiresNetworkConnectivity | Retrieves or sets a value indicating whether this action requires network connectivity.

See Also

Reference

InstallBehavior Class


InstallBehavior.CanRequestUserInput Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating if user input will be requested.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As InstallBehavior

Dim returnValue As Boolean
returnValue = installBehavior1.CanRequestUserInput

Dim sampleValue As Boolean
installBehavior1.CanRequestUserInput = sampleValue

Syntax

Visual Basic
Public Property CanRequestUserInput() As Boolean
C#
public bool CanRequestUserInput {get; set;}
C++
public:
property bool CanRequestUserInput {
    bool get();
    void set(bool value);
}
J#
public boolean get_CanRequestUserInput();
public void set_CanRequestUserInput(boolean);
JScript
public function get CanRequestUserInput() : Boolean;
public function set CanRequestUserInput(Boolean);

Property Value

True if there is any possibility that user input will be requested. False if there will never be any user input needed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InstallBehavior.Impact Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the impact of this action.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As InstallBehavior

Dim returnValue As InstallationImpact
returnValue = installBehavior1.Impact

Dim sampleValue As InstallationImpact
installBehavior1.Impact = sampleValue

Syntax

Visual Basic
Public Property Impact() As InstallationImpact
C#
public InstallationImpact Impact {get; set;}
C++
public:
property InstallationImpact Impact {
    InstallationImpact get();
    void set(InstallationImpact value);
}
J#
public InstallationImpact get_Impact();
public void set_Impact(InstallationImpact);
JScript
public function get Impact() : InstallationImpact;
public function set Impact(InstallationImpact);

Property Value

The impact of applying this Update with this action.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InstallBehavior.RebootBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the reboot behavior for this action.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As InstallBehavior

Dim returnValue As RebootBehavior
returnValue = installBehavior1.RebootBehavior

Dim sampleValue As RebootBehavior
installBehavior1.RebootBehavior = sampleValue

Syntax

Visual Basic
Public Property RebootBehavior() As RebootBehavior
C#
public RebootBehavior RebootBehavior {get; set;}
C++
public:
property RebootBehavior RebootBehavior {
    RebootBehavior get();
    void set(RebootBehavior value);
}
J#
public RebootBehavior get_RebootBehavior();
public void set_RebootBehavior(RebootBehavior);
JScript
public function get RebootBehavior() : RebootBehavior;
public function set RebootBehavior(RebootBehavior);

Property Value

The RebootBehavior for this action.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InstallBehavior.RequiresNetworkConnectivity Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether this action requires network connectivity.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim installBehavior1 As InstallBehavior

Dim returnValue As Boolean
returnValue = installBehavior1.RequiresNetworkConnectivity

Dim sampleValue As Boolean
installBehavior1.RequiresNetworkConnectivity = sampleValue

Syntax

Visual Basic
Public Property RequiresNetworkConnectivity() As Boolean
C#
public bool RequiresNetworkConnectivity {get; set;}
C++
public:
property bool RequiresNetworkConnectivity {
    bool get();
    void set(bool value);
}
J#
public boolean get_RequiresNetworkConnectivity();
public void set_RequiresNetworkConnectivity(boolean);
JScript
public function get RequiresNetworkConnectivity() : Boolean;
public function set RequiresNetworkConnectivity(Boolean);

Property Value

If true, the client machine will not attempt the action if the machine is not connected to a network.
Note:
This property does not test reachability of the Internet or any particular network server; reachability can be tested with applicability rules.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InstallBehavior Class
InstallBehavior Members


InventoryItemProperty Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a property of an Inventory item

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim value As Object
Dim inventoryItemProperty1 As New InventoryItemProperty(name, value)

Syntax

Visual Basic
Public Class InventoryItemProperty
C#
public class InventoryItemProperty
C++
public ref class InventoryItemProperty
J#
public class InventoryItemProperty
JScript
public class InventoryItemProperty

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InventoryItemProperty

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryItemProperty Members


InventoryItemProperty Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Represents a property of an Inventory item

The following tables list the members exposed by the InventoryItemProperty type.

Public Constructors

Name | Description
InventoryItemProperty | Constructor
Top

Public Properties

 | Name | Description
public property | Name | The name of the inventory item property.
public property | Value | The value of the inventory item property.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InventoryItemProperty Class


InventoryItemProperty Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim value As Object
Dim inventoryItemProperty1 As New InventoryItemProperty(name, value)

Syntax

Visual Basic
Public Sub New( _
    ByVal name As String, _
    ByVal value As Object _
)
C#
public InventoryItemProperty(
    string name,
    object value
);
C++
public:
InventoryItemProperty(
    String^ name,
    Object^ value
);
J#
public InventoryItemProperty(
    System.String name,
    System.Object value
);
JScript
public function InventoryItemProperty(
     name : String,
     value : Object
);

Parameters

name

The name of the inventory item property.

value

The value of the inventory item property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryItemProperty Class
InventoryItemProperty Members


InventoryItemProperty Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InventoryItemProperty Class


InventoryItemProperty Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Name | The name of the inventory item property.
public property | Value | The value of the inventory item property.

See Also

Reference

InventoryItemProperty Class


InventoryItemProperty.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The name of the inventory item property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim inventoryItemProperty1 As InventoryItemProperty

Dim returnValue As String
returnValue = inventoryItemProperty1.Name

Syntax

Visual Basic
Public ReadOnly Property Name() As String
C#
public string Name {get;}
C++
public:
property String^ Name {
    String^ get();
}
J#
public System.String get_Name();
JScript
public function get Name() : String;

Property Value

The name of the inventory item property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryItemProperty Class
InventoryItemProperty Members


InventoryItemProperty.Value Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The value of the inventory item property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim inventoryItemProperty1 As InventoryItemProperty

Dim returnValue As Object
returnValue = inventoryItemProperty1.Value

Syntax

Visual Basic
Public ReadOnly Property Value() As Object
C#
public object Value {get;}
C++
public:
property Object^ Value {
    Object^ get();
}
J#
public System.Object get_Value();
JScript
public function get Value() : Object;

Property Value

The value of the inventory item property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryItemProperty Class
InventoryItemProperty Members


InventoryScope Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Provides a way to limit the scope of the API to a specific class. Also defines the property to summarize by.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim className As String
Dim propertyName As String
Dim inventoryScope1 As New InventoryScope(className, propertyName)

Syntax

Visual Basic
Public Class InventoryScope
C#
public class InventoryScope
C++
public ref class InventoryScope
J#
public class InventoryScope
JScript
public class InventoryScope

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InventoryScope

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryScope Members


InventoryScope Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Provides a way to limit the scope of the API to a specific class. Also defines the property to summarize by.

The following tables list the members exposed by the InventoryScope type.

Public Constructors

Name | Description
InventoryScope | Constructor
Top

Public Properties

 | Name | Description
public property | ClassName | The class name which the caller is interested in.
public property | PropertyName | The property within the class ID the caller is interested in.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

InventoryScope Class


InventoryScope Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim className As String
Dim propertyName As String
Dim inventoryScope1 As New InventoryScope(className, propertyName)

Syntax

Visual Basic
Public Sub New( _
    ByVal className As String, _
    ByVal propertyName As String _
)
C#
public InventoryScope(
    string className,
    string propertyName
);
C++
public:
InventoryScope(
    String^ className,
    String^ propertyName
);
J#
public InventoryScope(
    System.String className,
    System.String propertyName
);
JScript
public function InventoryScope(
     className : String,
     propertyName : String
);

Parameters

className

The class name which the caller is interested in

propertyName

property within the class ID the caller is interested in

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryScope Class
InventoryScope Members


InventoryScope Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

InventoryScope Class


InventoryScope Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ClassName | The class name which the caller is interested in.
public property | PropertyName | The property within the class ID the caller is interested in.

See Also

Reference

InventoryScope Class


InventoryScope.ClassName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The class name which the caller is interested in.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim inventoryScope1 As InventoryScope

Dim returnValue As String
returnValue = inventoryScope1.ClassName

Syntax

Visual Basic
Public ReadOnly Property ClassName() As String
C#
public string ClassName {get;}
C++
public:
property String^ ClassName {
    String^ get();
}
J#
public System.String get_ClassName();
JScript
public function get ClassName() : String;

Property Value

The class name which the caller is interested in.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryScope Class
InventoryScope Members


InventoryScope.PropertyName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The property within the class ID the caller is interested in.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim inventoryScope1 As InventoryScope

Dim returnValue As String
returnValue = inventoryScope1.PropertyName

Syntax

Visual Basic
Public ReadOnly Property PropertyName() As String
C#
public string PropertyName {get;}
C++
public:
property String^ PropertyName {
    String^ get();
}
J#
public System.String get_PropertyName();
JScript
public function get PropertyName() : String;

Property Value

The property within the class ID the caller is interested in.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

InventoryScope Class
InventoryScope Members


IPublisher Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The properties of the IPublisher interface.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class publisherImplementation
    Implements IPublisher
End Class
Dim publisherImplementation1 As New publisherImplementation()

Syntax

Visual Basic
Public Interface IPublisher
C#
public interface IPublisher
C++
public interface class IPublisher
J#
public interface IPublisher
JScript
public interface IPublisher

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Members


IPublisher Members
See Also Events Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The properties of the IPublisher interface.

The following tables list the members exposed by the IPublisher type.

Public Properties

 | Name | Description
public property | MetadataOnly | Retreives or sets a value indicating whether or not the Publishing Process will operate in a metadata only mode.
Top

Public Methods

 | Name | Description
public method | Cancel | Asynchronously called method to attempt to cancel the PublishPackage() API call.
public method | PublishPackage | Overloaded. Publishes a new Package to the WSUS server.
public method | PublishSignedPackage | Publishes a new Package to the WSUS server using an existing pre signed cab file
public method | ResignPackage | Re-signs all cab files used by an existing Package and publishes a new revision referencing them.
public method | RevisePackage | Revises an existing Package, expects to perform no file operations and simply update the metadata for the update.
public method | VerifyAndPublishPackage | This operation requires WSUS Administrator privileges.
Top

Public Events

 | Name | Description
public event | ProgressHandler | Progress event handler accepts delegates to be called during the Publishing process.
Top

See Also

Reference

IPublisher Interface


IPublisher Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | Cancel | Asynchronously called method to attempt to cancel the PublishPackage() API call.
public method | PublishPackage | Overloaded. Publishes a new Package to the WSUS server.
public method | PublishSignedPackage | Publishes a new Package to the WSUS server using an existing pre signed cab file
public method | ResignPackage | Re-signs all cab files used by an existing Package and publishes a new revision referencing them.
public method | RevisePackage | Revises an existing Package, expects to perform no file operations and simply update the metadata for the update.
public method | VerifyAndPublishPackage | This operation requires WSUS Administrator privileges.

See Also

Reference

IPublisher Interface


IPublisher.Cancel Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Asynchronously called method to attempt to cancel the PublishPackage() API call.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iPublisher1 As IPublisher
iPublisher1.Cancel()

Syntax

Visual Basic
Sub Cancel()
C#
void Cancel();
C++
public:
virtual void Cancel();
J#
public void Cancel();
JScript
function Cancel() : Void;

Remarks

Some of the steps in the PublishPackage operation are not cancelable. If the Cancel request was successfully processed the API will throw an PackagePublisherOperationCanceledException. If the operation could not be canceled the PublishPackage() call will return without errors.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.PublishPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Publishes a new Package to the WSUS server.

Overload List

Name | Description
IPublisher.PublishPackage (String, String) | Publishes a new Package to the WSUS server.
IPublisher.PublishPackage (String, String, String) | Publishes a new Package to the WSUS server.

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.PublishPackage Method (String, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Publishes a new Package to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim sourcePath As String
Dim packageDirectoryName As String
Dim iPublisher1 As IPublisher
iPublisher1.PublishPackage(sourcePath, packageDirectoryName)

Syntax

Visual Basic
Sub PublishPackage( _
    ByVal sourcePath As String, _
    ByVal packageDirectoryName As String _
)
C#
void PublishPackage(
    string sourcePath,
    string packageDirectoryName
);
C++
public:
virtual void PublishPackage(
    String^ sourcePath,
    String^ packageDirectoryName
);
J#
public void PublishPackage(
    System.String sourcePath,
    System.String packageDirectoryName
);
JScript
function PublishPackage(
     sourcePath : String,
     packageDirectoryName : String
) : Void;

Parameters

sourcePath

Location of the source files to use to copy the InstallableItem InstallPointDirectory.

packageDirectoryName

Optional name to use for the Package directory under the Applications server path. Can be null in which case the directory name will be the Title_PackageId.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.PublishPackage Method (String, String, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Publishes a new Package to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim sourcePath As String
Dim additionalSourcePath As String
Dim packageDirectoryName As String
Dim iPublisher1 As IPublisher
iPublisher1.PublishPackage(sourcePath, additionalSourcePath, packageDirectoryName)

Syntax

Visual Basic
Sub PublishPackage( _
    ByVal sourcePath As String, _
    ByVal additionalSourcePath As String, _
    ByVal packageDirectoryName As String _
)
C#
void PublishPackage(
    string sourcePath,
    string additionalSourcePath,
    string packageDirectoryName
);
C++
public:
virtual void PublishPackage(
    String^ sourcePath,
    String^ additionalSourcePath,
    String^ packageDirectoryName
);
J#
public void PublishPackage(
    System.String sourcePath,
    System.String additionalSourcePath,
    System.String packageDirectoryName
);
JScript
function PublishPackage(
     sourcePath : String,
     additionalSourcePath : String,
     packageDirectoryName : String
) : Void;

Parameters

sourcePath

Location of the source files to use to copy the InstallableItem InstallPointDirectory.

additionalSourcePath

Location of additional source files to copy to the InstallableItem InstallPointDirectory. This is used to add files to a package that were not on the original source media (e.g. Office install configuration files) so they can be used during setup.

packageDirectoryName

Optional name to use for the Package directory under the Applications server path. Can be null in which case the directory name will be the Title_PackageId.

Remarks

This operation requires WSUS Administrator privileges.

PublishPackage() should never be used to publish a new revision of an update that has already been published to change the contents of the binaries of that package from one revision to the next as this is not a supported WSUS scenario. It is supported to call PublishPackage() to supply binaries to a package that was previously published as MetadataOnly. To re-publish an existing package with new binaries first use the IUpdateServer.DeleteUpdate API to delete the original locally published package and then publish normally.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.PublishSignedPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Publishes a new Package to the WSUS server using an existing pre signed cab file

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim sourceCabFile As String
Dim packageDirectoryName As String
Dim iPublisher1 As IPublisher
iPublisher1.PublishSignedPackage(sourceCabFile, packageDirectoryName)

Syntax

Visual Basic
Sub PublishSignedPackage( _
    ByVal sourceCabFile As String, _
    ByVal packageDirectoryName As String _
)
C#
void PublishSignedPackage(
    string sourceCabFile,
    string packageDirectoryName
);
C++
public:
virtual void PublishSignedPackage(
    String^ sourceCabFile,
    String^ packageDirectoryName
);
J#
public void PublishSignedPackage(
    System.String sourceCabFile,
    System.String packageDirectoryName
);
JScript
function PublishSignedPackage(
     sourceCabFile : String,
     packageDirectoryName : String
) : Void;

Parameters

sourceCabFile

Full path and filename of the cab to be published

packageDirectoryName

Optional name to use for the Package directory under the Applications server path. Can be null in which case the directory name will be the Title_PackageId.

Remarks

This operation requires WSUS Administrator privileges.

PublishSignedPackage() should never be used to publish a new revision of an update that has already been published to change the contents of the binaries of that package from one revision to the next as this is not a supported WSUS scenario. To re-publish an existing package with new binaries first use the IUpdateServer.DeleteUpdate API to delete the original locally published package and then publish normally.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.ResignPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Re-signs all cab files used by an existing Package and publishes a new revision referencing them.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iPublisher1 As IPublisher
iPublisher1.ResignPackage()

Syntax

Visual Basic
Sub ResignPackage()
C#
void ResignPackage();
C++
public:
virtual void ResignPackage();
J#
public void ResignPackage();
JScript
function ResignPackage() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.RevisePackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Revises an existing Package, expects to perform no file operations and simply update the metadata for the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iPublisher1 As IPublisher
iPublisher1.RevisePackage()

Syntax

Visual Basic
Sub RevisePackage()
C#
void RevisePackage();
C++
public:
virtual void RevisePackage();
J#
public void RevisePackage();
JScript
function RevisePackage() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher.VerifyAndPublishPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This operation requires WSUS Administrator privileges.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iPublisher1 As IPublisher
iPublisher1.VerifyAndPublishPackage()

Syntax

Visual Basic
Sub VerifyAndPublishPackage()
C#
void VerifyAndPublishPackage();
C++
public:
virtual void VerifyAndPublishPackage();
J#
public void VerifyAndPublishPackage();
JScript
function VerifyAndPublishPackage() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | MetadataOnly | Retreives or sets a value indicating whether or not the Publishing Process will operate in a metadata only mode.

See Also

Reference

IPublisher Interface


IPublisher.MetadataOnly Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retreives or sets a value indicating whether or not the Publishing Process will operate in a metadata only mode.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iPublisher1 As IPublisher

Dim returnValue As Boolean
returnValue = iPublisher1.MetadataOnly

Dim sampleValue As Boolean
iPublisher1.MetadataOnly = sampleValue

Syntax

Visual Basic
Property MetadataOnly() As Boolean
C#
bool MetadataOnly {get; set;}
C++
property virtual bool MetadataOnly {
    bool get();
    void set(bool value);
}
J#
public boolean get_MetadataOnly();
public void set_MetadataOnly(boolean);
JScript
function get MetadataOnly() : Boolean;
function set MetadataOnly(Boolean);

Property Value

A value indicating whether or not the Publishing Process will operate in a metadata only mode.

Remarks

By default this value is false and should remain so unless needed for a very specific scenario and server configuration. When this property is true the subsequent call to PublishPackage() will skip all file operations for the package and will instead read the file information from the OriginFile element in the SoftwareDistributionPackage xml. If that OriginFile information is missing the PublishPackage() process will fail. This property is only supported when the Server is configured to host content on MU. The MUUrl for the files of the published package will point to the location of the Origin File and clients will be expected to download the file using that URL. Other server configuration combinations (host locally, parent and child hierarchies) may not work and will cause the package to enter a Failed state on the server. If that happens either change the server configuration or re-publish the package without using the Metadata only property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


IPublisher Events
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Events

 | Name | Description
public event | ProgressHandler | Progress event handler accepts delegates to be called during the Publishing process.

See Also

Reference

IPublisher Interface


IPublisher.ProgressHandler Event
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Progress event handler accepts delegates to be called during the Publishing process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
No usage available.

Syntax

Visual Basic
Event ProgressHandler As EventHandler(Of PublishingEventArgs)
C#
event EventHandler<PublishingEventArgs> ProgressHandler;
C++
event EventHandler<PublishingEventArgs^>^ ProgressHandler;
J#
 void add_ProgressHandler(EventHandler<PublishingEventArgs> handler);
 void remove_ProgressHandler(EventHandler<PublishingEventArgs> handler);
JScript
In JScript, you can handle the events defined by a class, but you cannot define your own.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IPublisher Interface
IPublisher Members


ISubscription Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to view or modify the synchronization settings and to manually or automatically start the synchronization process. Downstream servers (DSS) receive synchronization settings from the upstream server. Downstream servers can modify and save synchronization settings; however, only the synchronization schedule is used by the downstream server, WSUS ignores the other settings. Downstream servers can also start and stop the synchronization process. To retrieve this interface, call GetSubscription frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetSubscriptionTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class subscriptionImplementation
    Implements ISubscription
End Class
Dim subscriptionImplementation1 As New subscriptionImplementation()

Syntax

Visual Basic
Public Interface ISubscription
C#
public interface ISubscription
C++
public interface class ISubscription
J#
public interface ISubscription
JScript
public interface ISubscription

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Members


ISubscription Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to view or modify the synchronization settings and to manually or automatically start the synchronization process. Downstream servers (DSS) receive synchronization settings from the upstream server. Downstream servers can modify and save synchronization settings; however, only the synchronization schedule is used by the downstream server, WSUS ignores the other settings. Downstream servers can also start and stop the synchronization process. To retrieve this interface, call GetSubscription frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetSubscriptionTopic.

The following tables list the members exposed by the ISubscription type.

Public Properties

 | Name | Description
public property | IsCategoryOnlySync |
public property | LastModifiedBy | Retrieves the name of the user who last modified the WSUS server subscription settings.
public property | LastModifiedTime | Retrieves the last time the WSUS server subscription settings were modified.
public property | NumberOfSynchronizationsPerDay | Retrieves or sets the number of server to server synchronizations a day.
public property | SynchronizeAutomatically | Determines if the WSUS server automatically synchronizes the updates every day.
public property | SynchronizeAutomaticallyTimeOfDay | Retrieves or sets the time of day when the WSUS server automatically synchronizes the updates.
Top

Public Methods

 | Name | Description
public method | GetEventHistory | Overloaded.
public method | GetLastSynchronizationInfo | Retrieves the synchronization history of the last synchronization.
public method | GetNextSynchronizationTime | Retrieves the next time the server will synchronize the updates.
public method | GetSynchronizationHistory | Overloaded.
public method | GetSynchronizationProgress | Retrieves the synchronization progress, if the server is currently synchronizing updates.
public method | GetSynchronizationStatus | Retrieves the status of the synchronization process.
public method | GetUpdateCategories | Retrieves the categories of updates that the WSUS server synchronizes. For example, updates for Windows products or updates for the family.
public method | GetUpdateClassifications | Retrieves the classifications of updates that the WSUS server synchronizes. For example, security or critical updates.
public method | Save | Saves changes to the WSUS server subscription settings.
public method | SetUpdateCategories | Specifies the categories of updates that you want the WSUS server to synchronize.
public method | SetUpdateClassifications | Specifies the classifications of updates that WSUS synchronizes. For example, security or critical updates.
public method | StartSynchronization | Starts the WSUS server synchronization process.
public method | StartSynchronizationForCategoryOnly | This is a revised version of StartSynchronization. StartSynchronizationForCategoryOnly only processes the categories and detectoids but not software/driver updates, which is essentially the first part of StartSynchronization.
public method | StopSynchronization | Stops the WSUS server synchronization process if it is running.
Top

See Also

Reference

ISubscription Interface


ISubscription Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetEventHistory | Overloaded.
public method | GetLastSynchronizationInfo | Retrieves the synchronization history of the last synchronization.
public method | GetNextSynchronizationTime | Retrieves the next time the server will synchronize the updates.
public method | GetSynchronizationHistory | Overloaded.
public method | GetSynchronizationProgress | Retrieves the synchronization progress, if the server is currently synchronizing updates.
public method | GetSynchronizationStatus | Retrieves the status of the synchronization process.
public method | GetUpdateCategories | Retrieves the categories of updates that the WSUS server synchronizes. For example, updates for Windows products or updates for the family.
public method | GetUpdateClassifications | Retrieves the classifications of updates that the WSUS server synchronizes. For example, security or critical updates.
public method | Save | Saves changes to the WSUS server subscription settings.
public method | SetUpdateCategories | Specifies the categories of updates that you want the WSUS server to synchronize.
public method | SetUpdateClassifications | Specifies the classifications of updates that WSUS synchronizes. For example, security or critical updates.
public method | StartSynchronization | Starts the WSUS server synchronization process.
public method | StartSynchronizationForCategoryOnly | This is a revised version of StartSynchronization. StartSynchronizationForCategoryOnly only processes the categories and detectoids but not software/driver updates, which is essentially the first part of StartSynchronization.
public method | StopSynchronization | Stops the WSUS server synchronization process if it is running.

See Also

Reference

ISubscription Interface


ISubscription.GetEventHistory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ISubscription.GetEventHistory () | Retrieves all subscription and synchronization events.
ISubscription.GetEventHistory (DateTime, DateTime) | Retrieves subscription and synchronization events that occurred during the specified time period.

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetEventHistory Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves all subscription and synchronization events.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As SubscriptionEventCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetEventHistory()

Syntax

Visual Basic
Function GetEventHistory() As SubscriptionEventCollection
C#
SubscriptionEventCollection GetEventHistory();
C++
public:
virtual SubscriptionEventCollection^ GetEventHistory();
J#
public SubscriptionEventCollection GetEventHistory();
JScript
function GetEventHistory() : SubscriptionEventCollection;

Return Value

A SubscriptionEventCollection frlrfMicrosoftUpdateServicesAdministrationSubscriptionEventCollectionClassTopic collection that contains all subscription and synchronization events. The collection is empty if there are no events.

Remarks

The number of events that are returned is partially dependent on the length of time the events are retained in the database. For more information, see ServerEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic.

To retrieve events for a specific period of time, call GetEventHistory

To retrieve synchronization-specific information, for example, the start and end time of the synchronization process and a list of any errors that occurred, call GetSynchronizationHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetSynchronizationHistoryTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetEventHistory Method (DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves subscription and synchronization events that occurred during the specified time period.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim returnValue As SubscriptionEventCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetEventHistory(fromDate, toDate)

Syntax

Visual Basic
Function GetEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
) As SubscriptionEventCollection
C#
SubscriptionEventCollection GetEventHistory(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual SubscriptionEventCollection^ GetEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public SubscriptionEventCollection GetEventHistory(
    DateTime fromDate,
    DateTime toDate
);
JScript
function GetEventHistory(
     fromDate : DateTime,
     toDate : DateTime
) : SubscriptionEventCollection;

Parameters

fromDate

Begin date that is used to search for events. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events. Specify the date in Coordinated Universal Time.

Return Value

A SubscriptionEventCollection is a collection containing subscription and synchronization events that occurred during the specified time period (inclusively). The collection is unordered. The collection is empty if no events occurred during the time period.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

The number of events that are returned is partially dependent on the length of time the events are retained in the database. For more information, see ServerEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic.

To retrieve all subscription and synchronization events, call GetEventHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetEventHistoryTopic.

To retrieve synchronization-specific information, for example, when the start and end time of the synchronization process and a list of any errors that occurred, call GetSynchronizationHistory.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetLastSynchronizationInfo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the synchronization history of the last synchronization.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ISynchronizationInfo
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetLastSynchronizationInfo()

Syntax

Visual Basic
Function GetLastSynchronizationInfo() As ISynchronizationInfo
C#
ISynchronizationInfo GetLastSynchronizationInfo();
C++
public:
virtual ISynchronizationInfo^ GetLastSynchronizationInfo();
J#
public ISynchronizationInfo GetLastSynchronizationInfo();
JScript
function GetLastSynchronizationInfo() : ISynchronizationInfo;

Return Value

An ISynchronizationInfo that contains the history of the last synchronization. If the synchronization process has never run, ISynchronizationInfo.Result is SynchronizationResult.NeverRun.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetNextSynchronizationTime Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the next time the server will synchronize the updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As DateTime
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetNextSynchronizationTime()

Syntax

Visual Basic
Function GetNextSynchronizationTime() As DateTime
C#
DateTime GetNextSynchronizationTime();
C++
public:
virtual DateTime^ GetNextSynchronizationTime();
J#
public DateTime GetNextSynchronizationTime();
JScript
function GetNextSynchronizationTime() : DateTime;

Return Value

The date and time for when the server is scheduled to synchronize the updates. The date is in Coordinated Universal Time. The date is DateTime.MinValue if SynchronizeAutomatically frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSynchronizeAutomaticallyTopic is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetSynchronizationHistory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
ISubscription.GetSynchronizationHistory () | Retrieves all synchronization history in the database.
ISubscription.GetSynchronizationHistory (DateTime, DateTime) | Retrieves synchronization history that occurred during the specified time period.

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetSynchronizationHistory Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves all synchronization history in the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As SynchronizationInfoCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetSynchronizationHistory()

Syntax

Visual Basic
Function GetSynchronizationHistory() As SynchronizationInfoCollection
C#
SynchronizationInfoCollection GetSynchronizationHistory();
C++
public:
virtual SynchronizationInfoCollection^ GetSynchronizationHistory();
J#
public SynchronizationInfoCollection GetSynchronizationHistory();
JScript
function GetSynchronizationHistory() : SynchronizationInfoCollection;

Return Value

A SynchronizationInfoCollection frlrfMicrosoftUpdateServicesAdministrationSynchronizationInfoCollectionClassTopic collection of all synchronization history in the database. The collection is empty if there is no synchronization history.

Remarks

WSUS uses subscription events to generate a synchronization history. The synchronization history is lost when subscription events are removed. Events are removed based on the ServerEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic configuration setting.

To retrieve the history for a specific period of time, call GetSynchronizationHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetSynchronizationHistoryTopic.

To retrieve synchronization and subscription events, call GetEventHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetEventHistoryTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetSynchronizationHistory Method (DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves synchronization history that occurred during the specified time period.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim returnValue As SynchronizationInfoCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetSynchronizationHistory(fromDate, toDate)

Syntax

Visual Basic
Function GetSynchronizationHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
) As SynchronizationInfoCollection
C#
SynchronizationInfoCollection GetSynchronizationHistory(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual SynchronizationInfoCollection^ GetSynchronizationHistory(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public SynchronizationInfoCollection GetSynchronizationHistory(
    DateTime fromDate,
    DateTime toDate
);
JScript
function GetSynchronizationHistory(
     fromDate : DateTime,
     toDate : DateTime
) : SynchronizationInfoCollection;

Parameters

fromDate

Begin date that is used to search for events. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events. Specify the date in Coordinated Universal Time.

Return Value

A SynchronizationInfoCollection frlrfMicrosoftUpdateServicesAdministrationSynchronizationInfoCollectionClassTopic collection that contains the synchronization history that overlaps the specified time period (the method returns the history if the start or end time falls within the period). The collection is unordered. The collection is empty if no events occurred during the time period.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

WSUS uses subscription events to generate synchronization history. The synchronization history is lost when subscription events are removed. Events are removed based on the ServerEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic configuration setting.

To retrieve all synchronization history, call GetSynchronizationHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetSynchronizationHistoryTopic.

To retrieve synchronization and subscription events, call GetEventHistory frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetEventHistoryTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetSynchronizationProgress Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the synchronization progress, if the server is currently synchronizing updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As SynchronizationProgress
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetSynchronizationProgress()

Syntax

Visual Basic
Function GetSynchronizationProgress() As SynchronizationProgress
C#
SynchronizationProgress GetSynchronizationProgress();
C++
public:
virtual SynchronizationProgress^ GetSynchronizationProgress();
J#
public SynchronizationProgress GetSynchronizationProgress();
JScript
function GetSynchronizationProgress() : SynchronizationProgress;

Return Value

A SynchronizationProgress frlrfMicrosoftUpdateServicesAdministrationSynchronizationProgressClassTopic that contains the total updates to synchronize and the number of updates that have synchronized so far.

Remarks

To determine if WSUS is currently synchronizing updates, call GetSynchronizationStatus frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetSynchronizationStatusTopic. The status is RunningfrlrfMicrosoftUpdateServicesAdministrationSynchronizationStatusClassTopic if WSUS is currently synchronizing updates.

If the synchronization process is not running, Phase frlrfMicrosoftUpdateServicesAdministrationSynchronizationProgressClassPhaseTopic is SynchronizationPhase.NotRunning.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetSynchronizationStatus Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the status of the synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As SynchronizationStatus
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetSynchronizationStatus()

Syntax

Visual Basic
Function GetSynchronizationStatus() As SynchronizationStatus
C#
SynchronizationStatus GetSynchronizationStatus();
C++
public:
virtual SynchronizationStatus GetSynchronizationStatus();
J#
public SynchronizationStatus GetSynchronizationStatus();
JScript
function GetSynchronizationStatus() : SynchronizationStatus;

Return Value

Status of the synchronization process indicating whether the synchronization is currently running, not running, or in the process of stopping. For details of the possible status values, see SynchronizationStatus frlrfMicrosoftUpdateServicesAdministrationSynchronizationStatusClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetUpdateCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the categories of updates that the WSUS server synchronizes. For example, updates for Windows products or updates for the family.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetUpdateCategories()

Syntax

Visual Basic
Function GetUpdateCategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetUpdateCategories();
C++
public:
virtual UpdateCategoryCollection^ GetUpdateCategories();
J#
public UpdateCategoryCollection GetUpdateCategories();
JScript
function GetUpdateCategories() : UpdateCategoryCollection;

Return Value

An UpdateCategoryCollection frlrfMicrosoftUpdateServicesAdministrationUpdateCategoryCollectionClassTopic collection of the update categories that the WSUS server synchronizes.

Remarks

The collection contains a snapshot of the categories that are defined at the time you retrieved the ISubscription frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassTopic instance. It is possible for the list of categories to be updated after you retrieve the instance.

To specify the categories that the WSUS server synchronizes, call SetUpdateCategories frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSetUpdateCategoriesTopic. If you call GetUpdateClassifications frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetUpdateClassificationsTopic after calling SetUpdateCategoriesfrlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSetUpdateCategoriesTopic, the collection that GetUpdateClassificationsfrlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetUpdateClassificationsTopic returns will not reflect your changes.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.GetUpdateClassifications Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the classifications of updates that the WSUS server synchronizes. For example, security or critical updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateClassificationCollection
Dim iSubscription1 As ISubscription
returnValue = iSubscription1.GetUpdateClassifications()

Syntax

Visual Basic
Function GetUpdateClassifications() As UpdateClassificationCollection
C#
UpdateClassificationCollection GetUpdateClassifications();
C++
public:
virtual UpdateClassificationCollection^ GetUpdateClassifications();
J#
public UpdateClassificationCollection GetUpdateClassifications();
JScript
function GetUpdateClassifications() : UpdateClassificationCollection;

Return Value

An UpdateClassificationCollection frlrfMicrosoftUpdateServicesAdministrationUpdateClassificationCollectionClassTopic collection that contains the classifications of updates that the WSUS server synchronizes.

Remarks

The collection contains a snapshot of the classifications that are defined at the time you retrieved the ISubscription frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassTopic instance. It is possible for the list of classifications to be updated after you retrieve the instance.

To specify the classifications that the WSUS server synchronizes, call SetUpdateClassifications frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSetUpdateClassificationsTopic. If you call GetUpdateClassificationsfrlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetUpdateClassificationsTopic after calling SetUpdateClassificationsfrlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSetUpdateClassificationsTopic, the collection that GetUpdateClassificationsfrlrfMicrosoftUpdateServicesAdministrationISubscriptionClassGetUpdateClassificationsTopic returns will not reflect your changes.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.Save Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Saves changes to the WSUS server subscription settings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription
iSubscription1.Save()

Syntax

Visual Basic
Sub Save()
C#
void Save();
C++
public:
virtual void Save();
J#
public void Save();
JScript
function Save() : Void;

Exceptions

Exception type | Condition
InvalidOperationException | The subscription cannot be modified because WSUS is currently synchronizing updates.

Remarks

Downstream servers receive synchronization settings from the upstream server. Downstream servers can modify and save synchronization settings; however, only the synchronization schedule is used by the downstream server, WSUS ignores the other settings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.SetUpdateCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Specifies the categories of updates that you want the WSUS server to synchronize.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCategories As UpdateCategoryCollection
Dim iSubscription1 As ISubscription
iSubscription1.SetUpdateCategories(updateCategories)

Syntax

Visual Basic
Sub SetUpdateCategories( _
    ByVal updateCategories As UpdateCategoryCollection _
)
C#
void SetUpdateCategories(
    UpdateCategoryCollection updateCategories
);
C++
public:
virtual void SetUpdateCategories(
    UpdateCategoryCollection^ updateCategories
);
J#
public void SetUpdateCategories(
    UpdateCategoryCollection updateCategories
);
JScript
function SetUpdateCategories(
     updateCategories : UpdateCategoryCollection
) : Void;

Parameters

updateCategories

An UpdateCategoryCollection frlrfMicrosoftUpdateServicesAdministrationUpdateCategoryCollectionClassTopic collection of the categories of updates to synchronize.

Exceptions

Exception type | Condition
ArgumentNullException | categories cannot be null.

Remarks

To use the specified categories in the synchronization process, you must call Save frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSaveTopic.

Note that the categories of a downstream server are determined by the upstream server; WSUS ignores the categories that you specify on a downstream server (when SyncFromMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic is false).

You should not include related parent-child categories in the collection. For example, you should not include the Windows product family category and the family product in the same collection. However, you can specify the Office product family category and the family product category in the same collection because they are not related. If the collection contains related parent-child categories, WSUS ignores the child categories and synchronizes all the products for the parent category. For example, if the collection includes both the Windows product family category and the family product category, WSUS ignores the family product category and synchronizes all the Windows products.

If the collection contains a company category, all the products for that company are synchronized. If the collection contains a product family category, all products for that product family are synchronized. If the collection contains a company category or a product family category, all new products for the company or product family are automatically included in the list of products to synchronize.

If you want to control the products that WSUS synchronizes, include only those products that you want to synchronize in the collection (do not include the company or product family categories).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.SetUpdateClassifications Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Specifies the classifications of updates that WSUS synchronizes. For example, security or critical updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateClassifications As UpdateClassificationCollection
Dim iSubscription1 As ISubscription
iSubscription1.SetUpdateClassifications(updateClassifications)

Syntax

Visual Basic
Sub SetUpdateClassifications( _
    ByVal updateClassifications As UpdateClassificationCollection _
)
C#
void SetUpdateClassifications(
    UpdateClassificationCollection updateClassifications
);
C++
public:
virtual void SetUpdateClassifications(
    UpdateClassificationCollection^ updateClassifications
);
J#
public void SetUpdateClassifications(
    UpdateClassificationCollection updateClassifications
);
JScript
function SetUpdateClassifications(
     updateClassifications : UpdateClassificationCollection
) : Void;

Parameters

updateClassifications

An UpdateClassificationCollection frlrfMicrosoftUpdateServicesAdministrationUpdateClassificationCollectionClassTopic collection that contains the update classifications to use when WSUS synchronizes the updates.

Exceptions

Exception type | Condition
ArgumentNullException | updateClassifications cannot be null.

Remarks

To use the specified classifications in the synchronization process, you must call Save frlrfMicrosoftUpdateServicesAdministrationISubscriptionClassSaveTopic.

For a complete list of classifications, call GetUpdateClassifications frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetUpdateClassificationsTopic.

Note that the classifications of a downstream server are determined by the upstream server; WSUS ignores the classifications that you specify on a downstream server (when SyncFromMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic is false).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.StartSynchronization Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Starts the WSUS server synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription
iSubscription1.StartSynchronization()

Syntax

Visual Basic
Sub StartSynchronization()
C#
void StartSynchronization();
C++
public:
virtual void StartSynchronization();
J#
public void StartSynchronization();
JScript
function StartSynchronization() : Void;

Exceptions

Exception type | Condition
InvalidOperationException | The subscription cannot be started either because of its current state or because WSUS is currently saving server configuration changes.

Remarks

Use this method to manually start the synchronization agent (the agent runs in a separate process). To schedule synchronization to occur every day at a specific time, call ISubscription.SynchronizeAutomatically and ISubscription.SynchronizeAutomaticallyTimeOfDay.

Note that it can take a long time to synchronize the updates. The amount of time depends on the number of categories and classifications to synchronize, the time since you last synchronized, and the available network bandwidth.

To determine if the WSUS server is currently saving the server configuration changes, call GetUpdateServerConfigurationState. If the call returns ProcessingSave then the server is in the process of saving the server configuration.

WSUS synchronizes only new updates (or the latest new revision of an update) that were published since the last time you synchronized the updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.StartSynchronizationForCategoryOnly Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This is a revised version of StartSynchronization. StartSynchronizationForCategoryOnly only processes the categories and detectoids but not software/driver updates, which is essentially the first part of StartSynchronization.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription
iSubscription1.StartSynchronizationForCategoryOnly()

Syntax

Visual Basic
Sub StartSynchronizationForCategoryOnly()
C#
void StartSynchronizationForCategoryOnly();
C++
public:
virtual void StartSynchronizationForCategoryOnly();
J#
public void StartSynchronizationForCategoryOnly();
JScript
function StartSynchronizationForCategoryOnly() : Void;

Exceptions

Exception type | Condition
InvalidOperationException | The subscription cannot be started either because of its current state or because WSUS is currently saving server configuration changes.

Remarks

This operation requires WSUS Administrator privileges.

To determine if the WSUS server is currently saving the server configuration changes, call GetUpdateServerConfigurationState. If the call returns ProcessingSave then the server is in the process of saving the server configuration.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.StopSynchronization Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Stops the WSUS server synchronization process if it is running.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription
iSubscription1.StopSynchronization()

Syntax

Visual Basic
Sub StopSynchronization()
C#
void StopSynchronization();
C++
public:
virtual void StopSynchronization();
J#
public void StopSynchronization();
JScript
function StopSynchronization() : Void;

Remarks

To determine if the synchronization process is running, call ISubscription.GetSynchronizationStatus. The process is running if SynchronizationStatus is Running.

If you stop the synchronization process while it is in the middle of processing an update, the update is not synchronized. When the synchronization process starts again, WSUS determines a new list of updates to synchronize.

After WSUS synchronizes an update, WSUS begins downloading the update if the WSUS server hosts the updates locally (IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is false). To stop the download, call IUpdateServer.CancelAllDownloads or IUpdate.CancelDownload.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | IsCategoryOnlySync |
public property | LastModifiedBy | Retrieves the name of the user who last modified the WSUS server subscription settings.
public property | LastModifiedTime | Retrieves the last time the WSUS server subscription settings were modified.
public property | NumberOfSynchronizationsPerDay | Retrieves or sets the number of server to server synchronizations a day.
public property | SynchronizeAutomatically | Determines if the WSUS server automatically synchronizes the updates every day.
public property | SynchronizeAutomaticallyTimeOfDay | Retrieves or sets the time of day when the WSUS server automatically synchronizes the updates.

See Also

Reference

ISubscription Interface


ISubscription.IsCategoryOnlySync Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As Boolean
returnValue = iSubscription1.IsCategoryOnlySync

Syntax

Visual Basic
ReadOnly Property IsCategoryOnlySync() As Boolean
C#
bool IsCategoryOnlySync {get;}
C++
property virtual bool IsCategoryOnlySync {
    bool get();
}
J#
public boolean get_IsCategoryOnlySync();
JScript
function get IsCategoryOnlySync() : Boolean;

Property Value

For internal use only.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.LastModifiedBy Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the user who last modified the WSUS server subscription settings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As String
returnValue = iSubscription1.LastModifiedBy

Syntax

Visual Basic
ReadOnly Property LastModifiedBy() As String
C#
string LastModifiedBy {get;}
C++
property virtual String^ LastModifiedBy {
    String^ get();
}
J#
public System.String get_LastModifiedBy();
JScript
function get LastModifiedBy() : String;

Property Value

Name of the user who last modified the WSUS server subscription settings. The name is of the form, domain\username.

Remarks

If the settings have not been changed since WSUS was installed, the name is the user who installed WSUS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.LastModifiedTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last time the WSUS server subscription settings were modified.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As DateTime
returnValue = iSubscription1.LastModifiedTime

Syntax

Visual Basic
ReadOnly Property LastModifiedTime() As DateTime
C#
DateTime LastModifiedTime {get;}
C++
property virtual DateTime^ LastModifiedTime {
    DateTime^ get();
}
J#
public DateTime get_LastModifiedTime();
JScript
function get LastModifiedTime() : DateTime;

Property Value

Last time the subscription settings were modified. The date is in Coordinated Universal Time.

Remarks

If the settings have not been changed since WSUS was installed, the date is the WSUS installation date.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.NumberOfSynchronizationsPerDay Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the number of server to server synchronizations a day.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As Integer
returnValue = iSubscription1.NumberOfSynchronizationsPerDay

Dim sampleValue As Integer
iSubscription1.NumberOfSynchronizationsPerDay = sampleValue

Syntax

Visual Basic
Property NumberOfSynchronizationsPerDay() As Integer
C#
int NumberOfSynchronizationsPerDay {get; set;}
C++
property virtual int NumberOfSynchronizationsPerDay {
    int get();
    void set(int value);
}
J#
public int get_NumberOfSynchronizationsPerDay();
public void set_NumberOfSynchronizationsPerDay(int);
JScript
function get NumberOfSynchronizationsPerDay() : int;
function set NumberOfSynchronizationsPerDay(int);

Property Value

The number of server to server synchronizations a day between 1 and 24.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The value cannot be greater than 24 or smaller than 1.

Remarks

This allows for a more granular server to server synchronization setting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.SynchronizeAutomatically Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the WSUS server automatically synchronizes the updates every day.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As Boolean
returnValue = iSubscription1.SynchronizeAutomatically

Dim sampleValue As Boolean
iSubscription1.SynchronizeAutomatically = sampleValue

Syntax

Visual Basic
Property SynchronizeAutomatically() As Boolean
C#
bool SynchronizeAutomatically {get; set;}
C++
property virtual bool SynchronizeAutomatically {
    bool get();
    void set(bool value);
}
J#
public boolean get_SynchronizeAutomatically();
public void set_SynchronizeAutomatically(boolean);
JScript
function get SynchronizeAutomatically() : Boolean;
function set SynchronizeAutomatically(Boolean);

Property Value

True if the WSUS server automatically synchronizes the updates every day; otherwise, false.

Remarks

If true, call ISubscription.SynchronizeAutomaticallyTimeOfDay to specify the time of day to synchronize the updates.

If false, call ISubscription.StartSynchronization to manually start synchronization.

WSUS synchronizes only the new updates (or the latest new revision of an update) that were published since the last time you synchronized the updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscription.SynchronizeAutomaticallyTimeOfDay Property
See Also Example
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the time of day when the WSUS server automatically synchronizes the updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscription1 As ISubscription

Dim returnValue As TimeSpan
returnValue = iSubscription1.SynchronizeAutomaticallyTimeOfDay

Dim sampleValue As TimeSpan
iSubscription1.SynchronizeAutomaticallyTimeOfDay = sampleValue

Syntax

Visual Basic
Property SynchronizeAutomaticallyTimeOfDay() As TimeSpan
C#
TimeSpan SynchronizeAutomaticallyTimeOfDay {get; set;}
C++
property virtual TimeSpan^ SynchronizeAutomaticallyTimeOfDay {
    TimeSpan^ get();
    void set(TimeSpan^ value);
}
J#
public TimeSpan get_SynchronizeAutomaticallyTimeOfDay();
public void set_SynchronizeAutomaticallyTimeOfDay(TimeSpan);
JScript
function get SynchronizeAutomaticallyTimeOfDay() : TimeSpan;
function set SynchronizeAutomaticallyTimeOfDay(TimeSpan);

Property Value

Time of day when the WSUS server automatically synchronizes the updates. Specify the value as a time span since midnight. Express the time in Coordinated Universal Time (UTC). The smallest allowable unit of time is a second—fractions of a second will be truncated.

Example

The following example shows how to set SynchronizeAutomaticallyTimeOfDay. The server variable that is used in the example is an instance of IUpdateServer (for information on retrieving an IUpdateServer instance, see Using WSUS).

Copy Code
ISubscription subscription = server.GetSubscription();

subscription.SynchronizeAutomatically = true;

//Synchronize updates automatically at 4:30 every morning.
DateTime localSyncHour = DateTime.Today + new TimeSpan(4,30,0);

//WSUS stores dates and times in Coordinated Universal Time,
//so convert the local time to Coordinated Universal Time.
subscription.SynchronizeAutomaticallyTimeOfDay = localSyncHour.ToUniversalTime().TimeOfDay;
subscription.Save;

The following example shows how to retrieve SynchronizeAutomaticallyTimeOfDay. The server variable that is used in the example is an instance of IUpdateServer (for information on retrieving an IUpdateServer instance, see Using WSUS).

Copy Code
ISubscription subscription = server.GetSubscription();

//WSUS stores dates and times in Coordinated Universal Time.
//Convert the Coordinated Universal Time to local time and
//display the string.
DateTime syncHour = DateTime.Today + subscription.SynchronizeAutomaticallyTimeOfDay;
Console.WriteLine("Synchronize at {0} every day.", syncHour.ToLocalTime().ToShortTimeString());

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The time span cannot be greater than or equal to 24 hours or set to a negative time value.

Remarks

The time of day value is used only if ISubscription.SynchronizeAutomatically is true.

Note:
WSUS stores the time in Coordinated Universal Time. This can affect the local time value that you display. For example, if the user wants the server to synchronize at 03:00 local time in a standard time zone that is 8 hours west of Coordinated Universal Time, you would set this property to 11:00 Coordinated Universal Time. When daylight saving time occurs, the server will continue to synchronize at 11:00 Coordinated Universal Time, however the local time value of this property will be 04:00.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscription Interface
ISubscription Members


ISubscriptionEvent Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about subscription and synchronization events. To retrieve this interface, call the following methods: IUpdateServer.GetSubscriptionEvent; SubscriptionEventCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class subscriptionEventImplementation
    Implements ISubscriptionEvent
End Class
Dim subscriptionEventImplementation1 As New subscriptionEventImplementation()

Syntax

Visual Basic
Public Interface ISubscriptionEvent
C#
public interface ISubscriptionEvent
C++
public interface class ISubscriptionEvent
J#
public interface ISubscriptionEvent
JScript
public interface ISubscriptionEvent

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Members


ISubscriptionEvent Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about subscription and synchronization events. To retrieve this interface, call the following methods: IUpdateServer.GetSubscriptionEvent; SubscriptionEventCollection.Item.

The following tables list the members exposed by the ISubscriptionEvent type.

Public Properties

 | Name | Description
public property | Administrator | Retrieves the name of the administrator who generated the event.
public property | CreationDate | Retrieves the date when the event was generated.
public property | Error | Retrieves the error that is associated with a synchronization failure.
public property | ErrorText | Retrieves the exception text of the last synchronization failure.
public property | EventCategory | Retrieves the category of events to which the event belongs.
public property | Id | Retrieves the unique identifier of the event.
public property | IsError | Retrieves a value that indicates if the event represents an error.
public property | Message | Retrieves a message text that is associated with the event.
public property | UpdateErrors | Retrieves a collection of update errors.
public property | WsusEventId | Retrieves the type of event.
Top

Public Methods

 | Name | Description
public method | GetHashCode |
Top

See Also

Reference

ISubscriptionEvent Interface


ISubscriptionEvent Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetHashCode |

See Also

Reference

ISubscriptionEvent Interface


ISubscriptionEvent.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iSubscriptionEvent1 As ISubscriptionEvent
returnValue = iSubscriptionEvent1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
                        int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Administrator | Retrieves the name of the administrator who generated the event.
public property | CreationDate | Retrieves the date when the event was generated.
public property | Error | Retrieves the error that is associated with a synchronization failure.
public property | ErrorText | Retrieves the exception text of the last synchronization failure.
public property | EventCategory | Retrieves the category of events to which the event belongs.
public property | Id | Retrieves the unique identifier of the event.
public property | IsError | Retrieves a value that indicates if the event represents an error.
public property | Message | Retrieves a message text that is associated with the event.
public property | UpdateErrors | Retrieves a collection of update errors.
public property | WsusEventId | Retrieves the type of event.

See Also

Reference

ISubscriptionEvent Interface


ISubscriptionEvent.Administrator Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the administrator who generated the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As String
returnValue = iSubscriptionEvent1.Administrator

Syntax

Visual Basic
ReadOnly Property Administrator() As String
C#
string Administrator {get;}
C++
property virtual String^ Administrator {
    String^ get();
}
J#
public System.String get_Administrator();
JScript
function get Administrator() : String;

Property Value

Name of the administrator who generated the event. The name is in the form, domain\username. The string is empty if an administrator did not cause the event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.CreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date when the event was generated.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As DateTime
returnValue = iSubscriptionEvent1.CreationDate

Syntax

Visual Basic
ReadOnly Property CreationDate() As DateTime
C#
DateTime CreationDate {get;}
C++
property virtual DateTime^ CreationDate {
    DateTime^ get();
}
J#
public DateTime get_CreationDate();
JScript
function get CreationDate() : DateTime;

Property Value

Date and time when the event was generated. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.Error Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the error that is associated with a synchronization failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As SynchronizationError
returnValue = iSubscriptionEvent1.Error

Syntax

Visual Basic
ReadOnly Property Error() As SynchronizationError
C#
SynchronizationError Error {get;}
C++
property virtual SynchronizationError Error {
    SynchronizationError get();
}
J#
public SynchronizationError get_Error();
JScript
function get Error() : SynchronizationError;

Property Value

If ISubscriptionEvent.WsusEventId equals SynchronizationCompletedFailure, the value represents the error that is associated with a synchronization failure; otherwise, the value is SynchronizationError.NotApplicable. For possible values, see SynchronizationError.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members
Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.ErrorText


ISubscriptionEvent.ErrorText Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the exception text of the last synchronization failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As String
returnValue = iSubscriptionEvent1.ErrorText

Syntax

Visual Basic
ReadOnly Property ErrorText() As String
C#
string ErrorText {get;}
C++
property virtual String^ ErrorText {
    String^ get();
}
J#
public System.String get_ErrorText();
JScript
function get ErrorText() : String;

Property Value

If ISubscriptionEvent.WsusEventId equals SynchronizationCompletedFailure, the text contains the exception message and call stack that are associated with the failure; otherwise, the text is empty.

Remarks

The text is localized in the language of the .NET Framework install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members
Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.Error


ISubscriptionEvent.EventCategory Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the category of events to which the event belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As SubscriptionEventCategory
returnValue = iSubscriptionEvent1.EventCategory

Syntax

Visual Basic
ReadOnly Property EventCategory() As SubscriptionEventCategory
C#
SubscriptionEventCategory EventCategory {get;}
C++
property virtual SubscriptionEventCategory EventCategory {
    SubscriptionEventCategory get();
}
J#
public SubscriptionEventCategory get_EventCategory();
JScript
function get EventCategory() : SubscriptionEventCategory;

Property Value

The category of events to which the event belongs. Events are broken into different categories. For example, when you modify a subscription, the event is marked as a SubscriptionModification event. For a list of possible categories, see SubscriptionEventCategory.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As Guid
returnValue = iSubscriptionEvent1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.IsError Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the event represents an error.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As Boolean
returnValue = iSubscriptionEvent1.IsError

Syntax

Visual Basic
ReadOnly Property IsError() As Boolean
C#
bool IsError {get;}
C++
property virtual bool IsError {
    bool get();
}
J#
public boolean get_IsError();
JScript
function get IsError() : Boolean;

Property Value

True if the event represents an error; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.Message Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a message text that is associated with the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As String
returnValue = iSubscriptionEvent1.Message

Syntax

Visual Basic
ReadOnly Property Message() As String
C#
string Message {get;}
C++
property virtual String^ Message {
    String^ get();
}
J#
public System.String get_Message();
JScript
function get Message() : String;

Property Value

Message text that is associated with the event. The property returns the text using the preferred culture if the localized text is available; otherwise, the text is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members
Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.WsusEventId


ISubscriptionEvent.UpdateErrors Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of update errors.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As SynchronizationUpdateErrorInfoCollection
returnValue = iSubscriptionEvent1.UpdateErrors

Syntax

Visual Basic
ReadOnly Property UpdateErrors() As SynchronizationUpdateErrorInfoCollection
C#
SynchronizationUpdateErrorInfoCollection UpdateErrors {get;}
C++
property virtual SynchronizationUpdateErrorInfoCollection^ UpdateErrors {
    SynchronizationUpdateErrorInfoCollection^ get();
}
J#
public SynchronizationUpdateErrorInfoCollection get_UpdateErrors();
JScript
function get UpdateErrors() : SynchronizationUpdateErrorInfoCollection;

Property Value

A SynchronizationUpdateErrorInfoCollection collection that contains update errors. The collection contains errors only if the value of ISubscriptionEvent.EventCategory is SubscriptionEventCategory.SynchronizationCompletion; otherwise, the collection is empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members


ISubscriptionEvent.WsusEventId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the type of event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSubscriptionEvent1 As ISubscriptionEvent

Dim returnValue As WsusEventId
returnValue = iSubscriptionEvent1.WsusEventId

Syntax

Visual Basic
ReadOnly Property WsusEventId() As WsusEventId
C#
WsusEventId WsusEventId {get;}
C++
property virtual WsusEventId WsusEventId {
    WsusEventId get();
}
J#
public WsusEventId get_WsusEventId();
JScript
function get WsusEventId() : WsusEventId;

Property Value

Identifies the type of event. For possible values, see WsusEventId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISubscriptionEvent Interface
ISubscriptionEvent Members
Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.Message


ISynchronizationInfo Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about the last synchronization process. To retrieve this interface, call one of the following methods: ISubscription.GetLastSynchronizationInfo; IUpdateServer.GetSynchronizationInfo; SynchronizationInfoCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class synchronizationInfoImplementation
    Implements ISynchronizationInfo
End Class
Dim synchronizationInfoImplementation1 As New synchronizationInfoImplementation()

Syntax

Visual Basic
Public Interface ISynchronizationInfo
C#
public interface ISynchronizationInfo
C++
public interface class ISynchronizationInfo
J#
public interface ISynchronizationInfo
JScript
public interface ISynchronizationInfo

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Members


ISynchronizationInfo Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about the last synchronization process. To retrieve this interface, call one of the following methods: ISubscription.GetLastSynchronizationInfo; IUpdateServer.GetSynchronizationInfo; SynchronizationInfoCollection.Item.

The following tables list the members exposed by the ISynchronizationInfo type.

Public Properties

 | Name | Description
public property | EndTime | Retrieves the time when the synchronization process ended.
public property | Error | Retrieves the error that is associated with a synchronization failure.
public property | ErrorText | Retrieves the exception text of the last synchronization failure.
public property | Id | Retrieves the unique identifier of the synchronization information.
public property | Result | Retrieves the result of the synchronization process.
public property | StartedManually | Retrieves a value that indicates if the synchronization process was started manually.
public property | StartTime | Retrieves the time when the synchronization process started.
public property | UpdateErrors | Retrieves a collection of errors for updates that failed to import into the local database.
Top

Public Methods

 | Name | Description
public method | GetHashCode |
Top

See Also

Reference

ISynchronizationInfo Interface


ISynchronizationInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetHashCode |

See Also

Reference

ISynchronizationInfo Interface


ISynchronizationInfo.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iSynchronizationInfo1 As ISynchronizationInfo
returnValue = iSynchronizationInfo1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
                        int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members


ISynchronizationInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | EndTime | Retrieves the time when the synchronization process ended.
public property | Error | Retrieves the error that is associated with a synchronization failure.
public property | ErrorText | Retrieves the exception text of the last synchronization failure.
public property | Id | Retrieves the unique identifier of the synchronization information.
public property | Result | Retrieves the result of the synchronization process.
public property | StartedManually | Retrieves a value that indicates if the synchronization process was started manually.
public property | StartTime | Retrieves the time when the synchronization process started.
public property | UpdateErrors | Retrieves a collection of errors for updates that failed to import into the local database.

See Also

Reference

ISynchronizationInfo Interface


ISynchronizationInfo.EndTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the time when the synchronization process ended.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As DateTime
returnValue = iSynchronizationInfo1.EndTime

Syntax

Visual Basic
ReadOnly Property EndTime() As DateTime
C#
DateTime EndTime {get;}
C++
property virtual DateTime^ EndTime {
    DateTime^ get();
}
J#
public DateTime get_EndTime();
JScript
function get EndTime() : DateTime;

Property Value

Date and time the synchronization process ended. The date is in Coordinated Universal Time.

Remarks

If the value of ISynchronizationInfo.Result is SynchronizationResult.Unknown, then the value for EndTime is the same as ISynchronizationInfo.StartTime.

If ISynchronizationInfo.Result is SynchronizationResult.NeverRun, then the value for StartTime is DateTime.MinValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members
Microsoft.UpdateServices.Administration Namespace
ISynchronizationInfo.StartTime


ISynchronizationInfo.Error Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the error that is associated with a synchronization failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As SynchronizationError
returnValue = iSynchronizationInfo1.Error

Syntax

Visual Basic
ReadOnly Property Error() As SynchronizationError
C#
SynchronizationError Error {get;}
C++
property virtual SynchronizationError Error {
    SynchronizationError get();
}
J#
public SynchronizationError get_Error();
JScript
function get Error() : SynchronizationError;

Property Value

Error that is associated with a synchronization failure. For possible values, see SynchronizationError.

Remarks

The error code represents either the error that is associated with a synchronization failure or indicates if a user has canceled the synchronization process. If ISynchronizationInfo.Result is SynchronizationResult.Failed, the value represents the error that is associated with a synchronization failure. If ISynchronizationInfo.Result is SynchronizationResult.Canceled, the value is SynchronizationError.UserCanceled.

If there was no error, then the value is SynchronizationError.NotApplicable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members
Microsoft.UpdateServices.Administration Namespace
ISynchronizationInfo.ErrorText


ISynchronizationInfo.ErrorText Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the exception text of the last synchronization failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As String
returnValue = iSynchronizationInfo1.ErrorText

Syntax

Visual Basic
ReadOnly Property ErrorText() As String
C#
string ErrorText {get;}
C++
property virtual String^ ErrorText {
    String^ get();
}
J#
public System.String get_ErrorText();
JScript
function get ErrorText() : String;

Property Value

If ISynchronizationInfo.Result is SynchronizationResult.Failed, the text contains the exception message and call stack associated with the failure; otherwise, the text is empty.

Remarks

The text is localized in the language of the .NET Framework install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members
Microsoft.UpdateServices.Administration Namespace
ISynchronizationInfo.Error


ISynchronizationInfo.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the synchronization information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As Guid
returnValue = iSynchronizationInfo1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the synchronization information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members


ISynchronizationInfo.Result Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the result of the synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As SynchronizationResult
returnValue = iSynchronizationInfo1.Result

Syntax

Visual Basic
ReadOnly Property Result() As SynchronizationResult
C#
SynchronizationResult Result {get;}
C++
property virtual SynchronizationResult Result {
    SynchronizationResult get();
}
J#
public SynchronizationResult get_Result();
JScript
function get Result() : SynchronizationResult;

Property Value

Result of the synchronization process. For example, this value indicates if the synchronization process has succeeded or failed. For possible values, see SynchronizationResult.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members


ISynchronizationInfo.StartedManually Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the synchronization process was started manually.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As Boolean
returnValue = iSynchronizationInfo1.StartedManually

Syntax

Visual Basic
ReadOnly Property StartedManually() As Boolean
C#
bool StartedManually {get;}
C++
property virtual bool StartedManually {
    bool get();
}
J#
public boolean get_StartedManually();
JScript
function get StartedManually() : Boolean;

Property Value

True if ISubscription.StartSynchronization was called to start the synchronization process. Otherwise, false if the synchronization process was started automatically based on the synchronization schedule.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members


ISynchronizationInfo.StartTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the time when the synchronization process started.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As DateTime
returnValue = iSynchronizationInfo1.StartTime

Syntax

Visual Basic
ReadOnly Property StartTime() As DateTime
C#
DateTime StartTime {get;}
C++
property virtual DateTime^ StartTime {
    DateTime^ get();
}
J#
public DateTime get_StartTime();
JScript
function get StartTime() : DateTime;

Property Value

Date and time the synchronization process started. The date is in Coordinated Universal Time.

Remarks

If ISynchronizationInfo.Result is SynchronizationResult.NeverRun, then the value for StartTime is DateTime.MinValue.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members
Microsoft.UpdateServices.Administration Namespace
ISynchronizationInfo.EndTime


ISynchronizationInfo.UpdateErrors Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of errors for updates that failed to import into the local database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iSynchronizationInfo1 As ISynchronizationInfo

Dim returnValue As SynchronizationUpdateErrorInfoCollection
returnValue = iSynchronizationInfo1.UpdateErrors

Syntax

Visual Basic
ReadOnly Property UpdateErrors() As SynchronizationUpdateErrorInfoCollection
C#
SynchronizationUpdateErrorInfoCollection UpdateErrors {get;}
C++
property virtual SynchronizationUpdateErrorInfoCollection^ UpdateErrors {
    SynchronizationUpdateErrorInfoCollection^ get();
}
J#
public SynchronizationUpdateErrorInfoCollection get_UpdateErrors();
JScript
function get UpdateErrors() : SynchronizationUpdateErrorInfoCollection;

Property Value

A SynchronizationUpdateErrorInfoCollection collection that contains errors that occurred when trying to import updates into the local database. You should check this collection only if the value of ISynchronizationInfo.Result is SynchronizationResult.Failed.

Remarks

Although ISynchronizationInfo.Error can return SynchronizationError.ImportUpdateError, which indicates that this collection contains import errors, you should not use that as an indicator of when to retrieve the collection because the synchronization process can report both import and non-import errors at the same time. When import and non-import errors occur at the same time, ISynchronizationInfo.Error reports the non-import errors and ISynchronizationInfo.UpdateErrors reports the import errors.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ISynchronizationInfo Interface
ISynchronizationInfo Members


IUpdate Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to approve or decline updates for deployment and retrieve information about the update. To retrieve this interface, call one of the following methods: IUpdateApproval.GetUpdate; IUpdateEvent.GetUpdate; IUpdateInstallationInfo.GetUpdate; IUpdateServer.GetUpdate; UpdateCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateImplementation
    Implements IUpdate
End Class
Dim updateImplementation1 As New updateImplementation()

Syntax

Visual Basic
Public Interface IUpdate
C#
public interface IUpdate
C++
public interface class IUpdate
J#
public interface IUpdate
JScript
public interface IUpdate

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Members


IUpdate Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to approve or decline updates for deployment and retrieve information about the update. To retrieve this interface, call one of the following methods: IUpdateApproval.GetUpdate; IUpdateEvent.GetUpdate; IUpdateInstallationInfo.GetUpdate; IUpdateServer.GetUpdate; UpdateCollection.Item.

The following tables list the members exposed by the IUpdate type.

Public Properties

 | Name | Description
public property | AdditionalInformationUrls | Retrieves a collection of URLs provided by the publisher of the update that provide additional information about the update.
public property | ArrivalDate | Retrieves the date and time when the metadata for this revision of the update finished downloading to the WSUS server.
public property | CompanyTitles | Retrieves the titles of all the companies to which this update belongs.
public property | CreationDate | Retrieves the date and time when this revision of the update's metadata was authored.
public property | Description | Retrieves a short description of the update.
public property | HasEarlierRevision | Retrieves a value that indicates if the WSUS server contains earlier revisions of this update.
public property | HasLicenseAgreement | Retrieves a value that indicates if the update has an associated license agreement.
public property | HasStaleUpdateApprovals | Retrieves a value that indicates if an older revision of the update contains an approval.
public property | HasSupersededUpdates | Retrieves a value that indicates if the update supersedes other updates.
public property | Id | Retrieves the unique identifier of the update.
public property | InstallationBehavior | Retrieves the installation behavior of the update.
public property | IsApproved | Retrieves a value that indicates if this revision of the update is approved for at least one target group.
public property | IsDeclined | Retrieves a value that indicates if this update is declined.
public property | IsEditable | Retrieves a value indicating whether this update is editable.
public property | IsLatestRevision | Retrieves a value that indicates if this revision is the latest revision of the update.
public property | IsSuperseded | Retrieves a value that indicates if this update is superseded by related updates.
public property | IsWsusInfrastructureUpdate | Retrieves a value that indicates if this update is a WSUS infrastructure update.
public property | KnowledgebaseArticles | Retrieves a collection of strings, each containing a Knowledgebase article number that describes an issue related to or fixed by this Update.
public property | LegacyName | Retrieves the name of the update that was used in previous versions.
public property | MsrcSeverity | Retrieves the maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with the update.
public property | ProductFamilyTitles | Retrieves the titles of all product family categories to which the update belongs.
public property | ProductTitles | Retrieves the titles of all product categories to which the update belongs.
public property | PublicationState | Retrieves the publication state of the update.
public property | RequiresLicenseAgreementAcceptance | Retrieves a value that indicates if the update requires a user to accept the license agreement.
public property | SecurityBulletins | Retrieves a collection of Security Bulletin numbers. The bulletins describe security issues and changes that are related to the update.
public property | State | Retrieves the current state of the update.
public property | Title | Retrieves the title of the update.
public property | UninstallationBehavior | Retrieves the removal behavior of the update.
public property | UpdateClassificationTitle | Retrieves the title of the classification to which the update belongs.
public property | UpdateType | Retrieves a value that indicates if the update is a software update or a driver update.
Top

Public Methods

 | Name | Description
public method | AcceptLicenseAgreement | Accepts the license agreement that is associated with the update.
public method | AdvertiseForInstall | Approve an Update to be advertised to clients for optional installation. Clients will be able to install the update using the Add or Remove Programs control panel.
public method | Approve | Overloaded.
public method | CancelDownload | Stops downloading the update and its dependencies to the WSUS server.
public method | Decline | Declines the update for deployment.
public method | ExpirePackage | Revises the Locally Published Package to Expire it.
public method | ExportPackageMetadata | Exports an SDP file for a locally published update
public method | GetChangesFromPreviousRevision | Retrieves the reasons for why the update was revised.
public method | GetHashCode | Serves as a hash function for the current Update, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInstallableItems | Gets the read-only collection of InstallableItem that represents the directly bundled, non-explicitly-deployable child updates of this Update. Creates an Installableitem on behalf of this update(parent) if the update(parent) itself has files (not a common case).
public method | GetLicenseAgreement | Retrieves the license agreement for this update.
public method | GetRelatedUpdates | Gets a list of related Updates.
public method | GetSummaryForComputerTargetGroup | Overloaded.
public method | GetSummaryPerComputerTargetGroup | Overloaded.
public method | GetSupportedUpdateLanguages | Retrieves a collection of the languages that this update supports.
public method | GetUpdateApprovals | Overloaded.
public method | GetUpdateCategories | Retrieves a collection of product categories to which this update belongs.
public method | GetUpdateClassification | Retrieves the classification to which the update belongs.
public method | GetUpdateEventHistory | Retrieves the event history that is associated with this update.
public method | GetUpdateInstallationInfoPerComputerTarget | Overloaded.
public method | PurgeAssociatedReportingEvents | Uses the specified date range to remove events that are associated with this update.
public method | Refresh | Refreshes the properties of this Update with the latest values.
public method | RefreshUpdateApprovals | Moves existing approvals from older revisions to the latest revision of this update.
public method | ResumeDownload | Identifies to the synchronization agent the update to download.
Top

See Also

Reference

IUpdate Interface


IUpdate Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | AcceptLicenseAgreement | Accepts the license agreement that is associated with the update.
public method | AdvertiseForInstall | Approve an Update to be advertised to clients for optional installation. Clients will be able to install the update using the Add or Remove Programs control panel.
public method | Approve | Overloaded.
public method | CancelDownload | Stops downloading the update and its dependencies to the WSUS server.
public method | Decline | Declines the update for deployment.
public method | ExpirePackage | Revises the Locally Published Package to Expire it.
public method | ExportPackageMetadata | Exports an SDP file for a locally published update
public method | GetChangesFromPreviousRevision | Retrieves the reasons for why the update was revised.
public method | GetHashCode | Serves as a hash function for the current Update, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetInstallableItems | Gets the read-only collection of InstallableItem that represents the directly bundled, non-explicitly-deployable child updates of this Update. Creates an Installableitem on behalf of this update(parent) if the update(parent) itself has files (not a common case).
public method | GetLicenseAgreement | Retrieves the license agreement for this update.
public method | GetRelatedUpdates | Gets a list of related Updates.
public method | GetSummaryForComputerTargetGroup | Overloaded.
public method | GetSummaryPerComputerTargetGroup | Overloaded.
public method | GetSupportedUpdateLanguages | Retrieves a collection of the languages that this update supports.
public method | GetUpdateApprovals | Overloaded.
public method | GetUpdateCategories | Retrieves a collection of product categories to which this update belongs.
public method | GetUpdateClassification | Retrieves the classification to which the update belongs.
public method | GetUpdateEventHistory | Retrieves the event history that is associated with this update.
public method | GetUpdateInstallationInfoPerComputerTarget | Overloaded.
public method | PurgeAssociatedReportingEvents | Uses the specified date range to remove events that are associated with this update.
public method | Refresh | Refreshes the properties of this Update with the latest values.
public method | RefreshUpdateApprovals | Moves existing approvals from older revisions to the latest revision of this update.
public method | ResumeDownload | Identifies to the synchronization agent the update to download.

See Also

Reference

IUpdate Interface


IUpdate.AcceptLicenseAgreement Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Accepts the license agreement that is associated with the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.AcceptLicenseAgreement()

Syntax

Visual Basic
Sub AcceptLicenseAgreement()
C#
void AcceptLicenseAgreement();
C++
public:
virtual void AcceptLicenseAgreement();
J#
public void AcceptLicenseAgreement();
JScript
function AcceptLicenseAgreement() : Void;

Exceptions

Exception type Condition
WsusObjectNotFoundException

You can receive this exception because of either of the following reasons:

  • The update has a License Agreement, but it could not be found in the database.

  • The update does not have an associated License Agreement or the License Agreement has not been completely downloaded.

Remarks

Some updates require that you accept the license agreement before you can deploy the update. If IUpdate.RequiresLicenseAgreementAcceptance is true, you must accept the license agreement before deploying the update.

Typically, you call IUpdate.GetLicenseAgreement to retrieve the license agreement, display the contents of license agreement to the user, and ask the user to accept the license agreement. If the user accepts the agreement, then call AcceptLicenseAgreement.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.AdvertiseForInstall Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Approve an Update to be advertised to clients for optional installation. Clients will be able to install the update using the Add or Remove Programs control panel.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim returnValue As IUpdateApproval
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.AdvertiseForInstall(targetGroup)

Syntax

Visual Basic
Function AdvertiseForInstall( _
    ByVal targetGroup As IComputerTargetGroup _
) As IUpdateApproval
C#
IUpdateApproval AdvertiseForInstall(
    IComputerTargetGroup targetGroup
);
C++
public:
virtual IUpdateApproval^ AdvertiseForInstall(
    IComputerTargetGroup^ targetGroup
);
J#
public IUpdateApproval AdvertiseForInstall(
    IComputerTargetGroup targetGroup
);
JScript
function AdvertiseForInstall(
     targetGroup : IComputerTargetGroup
) : IUpdateApproval;

Parameters

targetGroup

The Computer Target Group to which the Update is targeted.

Return Value

The newly created IUpdateApproval

Exceptions

Exception type Condition
ArgumentNullException

targetGroup is a null reference.
InvalidOperationException

One of the following conditions will cause this exception to be thrown:

  • This Update has a license agreement that must be accepted before it can be approved.

  • The desired action cannot be used because a dependency has been approved for the opposite action.

  • This Update is expired.
WsusObjectNotFoundException

One of the following conditions will cause this exception to be thrown:

  • The update could not be found in the database.

  • The specified target group could not be found in the database.

Remarks

This method does not update the value of the IsApproved property, or any other properties of this update. Use Refresh to update the properties of this update if necessary.

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Approve Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdate.Approve (UpdateApprovalAction, IComputerTargetGroup) | Approves an update for deployment to clients.
IUpdate.Approve (UpdateApprovalAction, IComputerTargetGroup, DateTime) | Approves an update for deployment to clients and provides a deadline by when the client must act on the update.

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Approve Method (UpdateApprovalAction, IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Approves an update for deployment to clients.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim action As UpdateApprovalAction
Dim targetGroup As IComputerTargetGroup
Dim returnValue As IUpdateApproval
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.Approve(action, targetGroup)

Syntax

Visual Basic
Function Approve( _
    ByVal action As UpdateApprovalAction, _
    ByVal targetGroup As IComputerTargetGroup _
) As IUpdateApproval
C#
IUpdateApproval Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup targetGroup
);
C++
public:
virtual IUpdateApproval^ Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup^ targetGroup
);
J#
public IUpdateApproval Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup targetGroup
);
JScript
function Approve(
     action : UpdateApprovalAction,
     targetGroup : IComputerTargetGroup
) : IUpdateApproval;

Parameters

action

Action that clients should perform when applying the associated update. For example, installing or removing the update. For details, see UpdateApprovalAction.

targetGroup

Target group to which you want to deploy the update.

Return Value

An IUpdateApproval frlrfMicrosoftUpdateServicesAdministrationIUpdateApprovalClassTopic that represents the approval.

Exceptions

Exception type Condition
ArgumentOutOfRangeException

The value for action is not valid. Only Install, Uninstall, Scan, and Block are valid values.
ArgumentNullException

targetGroup cannot be null.
InvalidOperationException

You can receive this exception because of either of the following reasons:

  • You must accept the license agreement for this update before you can approve the update for deployment.

  • You cannot approve the update if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

  • You can deploy an expired update only when action is UpdateApprovalAction.Uninstall. For information on expired updates, see IUpdate.PublicationState.

  • You cannot create a block approval to the All Computers target group.

  • The desired action cannot be used because a dependency has been approved for the opposite action.
WsusObjectNotFoundException

The update or target group was not found in the database.

Remarks

You can approve an update for only a single action per target group. Approving the update for another action overrides the current approval.

To impose a deadline by when the action must occur, call IUpdate.Approve(UpdateApprovalAction, IComputerTargetGroup, DateTime).

A bundled update represents multiple child updates. The children updates may be explicitly or implicitly deployable. Approving a bundled update also approves its children.

Before approving an update for removal (setting action to UpdateApprovalAction.Uninstall), you should call IUpdate.UninstallationBehavior to verify that the update is removable. The update is removable if IUpdate.UninstallationBehavior.IsSupported is true.

There are no restrictions on approving superseded updates. When you approve superseded updates, the client determines the correct update to install. This is often the safest course of action.

You can also approve different revisions of the same update for deployment to different groups; however, if one of the groups is the All Computers group, the approval actions cannot conflict (for example, you cannot approve one revision for installation and another revision for removal). You cannot approve different revisions of an update for deployment to the same group.

Approving different revisions of an update is typically done when you want to test the latest revision. In this case, you will deploy the latest revision to a test group for testing. Once testing is complete, you will remove the deployment to the test group and call IUpdate.RefreshUpdateApprovals() to move the deployment from the older revision to the latest revision.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Approve Method (UpdateApprovalAction, IComputerTargetGroup, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Approves an update for deployment to clients and provides a deadline by when the client must act on the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim action As UpdateApprovalAction
Dim targetGroup As IComputerTargetGroup
Dim deadline As DateTime
Dim returnValue As IUpdateApproval
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.Approve(action, targetGroup, deadline)

Syntax

Visual Basic
Function Approve( _
    ByVal action As UpdateApprovalAction, _
    ByVal targetGroup As IComputerTargetGroup, _
    ByVal deadline As DateTime _
) As IUpdateApproval
C#
IUpdateApproval Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup targetGroup,
    DateTime deadline
);
C++
public:
virtual IUpdateApproval^ Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup^ targetGroup,
    DateTime^ deadline
);
J#
public IUpdateApproval Approve(
    UpdateApprovalAction action,
    IComputerTargetGroup targetGroup,
    DateTime deadline
);
JScript
function Approve(
     action : UpdateApprovalAction,
     targetGroup : IComputerTargetGroup,
     deadline : DateTime
) : IUpdateApproval;

Parameters

action

Action that clients should perform when applying the associated update. For example, installing or removing the update. For details, see UpdateApprovalAction frlrfMicrosoftUpdateServicesAdministrationUpdateApprovalActionClassTopic.

targetGroup

Target group to which you want to deploy the update.

deadline

Date by when the client will be forced to apply the update if it has not already done so. DateTime.MaxValue indicates that there is no deadline. Specify the date in Coordinated Universal Time. The deadline applies only if the action is install or uninstall.

Return Value

An IUpdateApproval frlrfMicrosoftUpdateServicesAdministrationIUpdateApprovalClassTopic that represents the approval.

Exceptions

Exception type Condition
ArgumentOutOfRangeException

The value for action is not valid. Only Install, Uninstall, Scan, and Block are valid values.
ArgumentNullException

targetGroup cannot be null.
InvalidOperationException

You can receive this exception because of either of the following reasons:

  • You must accept the license agreement for this update before you can approve the update for deployment.

  • You cannot approve the update if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

  • You can deploy an expired update only when action is UpdateApprovalAction.Uninstall. For information on expired updates, see IUpdate.PublicationState.

  • You cannot create a block approval to the All Computers target group.

  • The desired action cannot be used because a dependency has been approved for the opposite action.
WsusObjectNotFoundException

The update or target group was not found in the database.

Remarks

You can approve an update for only a single action per target group. Approving the update for another action overrides the current approval.

A bundled update represents multiple child updates. The children updates may be explicitly or implicitly deployable. Approving a bundled update also approves its children.

Before approving an update for removal (setting action to UpdateApprovalAction.Uninstall), you should call IUpdate.UninstallationBehavior to verify that the update is removable. The update is removable if IUpdate.UninstallationBehavior.IsSupported is true.

There are no restrictions on approving superseded updates. When you approve superseded updates, the client determines the correct update to install. This is often the safest course of action.

You can also approve different revisions of the same update for deployment to different groups; however, if one of the groups is the All Computers group, the approval actions cannot conflict (for example, you cannot approve one revision for installation and another revision for removal). You cannot approve different revisions of an update for deployment to the same group.

Approving different revisions of an update is typically done when you want to test the latest revision. In this case, you will deploy the latest revision to a test group for testing. Once testing is complete, you will remove the deployment to the test group and call IUpdate.RefreshUpdateApprovals() to move the deployment from the older revision to the latest revision.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.CancelDownload Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Stops downloading the update and its dependencies to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.CancelDownload()

Syntax

Visual Basic
Sub CancelDownload()
C#
void CancelDownload();
C++
public:
virtual void CancelDownload();
J#
public void CancelDownload();
JScript
function CancelDownload() : Void;

Remarks

This method cancels the download only if the state of the update is UpdateState.NotReady.

If more than one update shares a dependency that is downloading, canceling one of the updates will cancel the other updates that share the dependency.

Note that an update can include a download job for each language it supports. Those download jobs that successfully completed before you called CancelDownload are retained; the others are canceled.

To determine if the update is currently downloading, call IUpdate.State. The update is currently downloading if the state is UpdateState.NotReady.

If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, CancelDownload cancels the downloading of the end-user license agreements.

To restart canceled downloads, call IUpdate.ResumeDownload. To restart all update downloads, call IUpdateServer.ResumeAllDownloads.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Decline Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Declines the update for deployment.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.Decline()

Syntax

Visual Basic
Sub Decline()
C#
void Decline();
C++
public:
virtual void Decline();
J#
public void Decline();
JScript
function Decline() : Void;

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Cannot find the update to decline.
InvalidOperationException | You cannot decline the update if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Remarks

If the update is currently approved, this method removes the approval from the update. To determine if an update is declined, call IUpdate.IsDeclined. Declining the update does not affect clients that have already received the approved update. If this is an issue, you may need to approve the update again using a different action. For example, if you approved an update to be installed on the clients and later declined the update, you should change the approval action to uninstall to remove the update from the clients.

Declining an update removes all approvals for all revisions of the update.

A bundled update represents multiple child updates. The children may be explicitly or implicitly deployable. Declining a bundled update also declines its children.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ExpirePackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Revises the Locally Published Package to Expire it.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.ExpirePackage()

Syntax

Visual Basic
Sub ExpirePackage()
C#
void ExpirePackage();
C++
public:
virtual void ExpirePackage();
J#
public void ExpirePackage();
JScript
function ExpirePackage() : Void;

Exceptions

Exception type | Condition
InvalidOperationException | Thrown when the package was not imported on this server (there is no SDP file in the database) or when the package was already Expired.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ExportPackageMetadata Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Exports an SDP file for a locally published update

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fileName As String
Dim iUpdate1 As IUpdate
iUpdate1.ExportPackageMetadata(fileName)

Syntax

Visual Basic
Sub ExportPackageMetadata( _
    ByVal fileName As String _
)
C#
void ExportPackageMetadata(
    string fileName
);
C++
public:
virtual void ExportPackageMetadata(
    String^ fileName
);
J#
public void ExportPackageMetadata(
    System.String fileName
);
JScript
function ExportPackageMetadata(
     fileName : String
) : Void;

Parameters

fileName

Full Path and Filename to write the SDP file

Exceptions

Exception type | Condition
InvalidOperationException | when the Update to be exported is not a locally published update and has no save SDP information
ArgumentNullException | fileName is null.

Remarks

This method can throw many other exception types when trying to write to the specified location. See the documentation for the StreamWriter class and its constructor. This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetChangesFromPreviousRevision Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the reasons for why the update was revised.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As RevisionChanges
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetChangesFromPreviousRevision()

Syntax

Visual Basic
Function GetChangesFromPreviousRevision() As RevisionChanges
C#
RevisionChanges GetChangesFromPreviousRevision();
C++
public:
virtual RevisionChanges GetChangesFromPreviousRevision();
J#
public RevisionChanges GetChangesFromPreviousRevision();
JScript
function GetChangesFromPreviousRevision() : RevisionChanges;

Return Value

Indicates which properties of the update were revised. An update can be revised for one or more reasons. For possible values, see RevisionChanges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current Update, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current Update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetInstallableItems Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the read-only collection of InstallableItem that represents the directly bundled, non-explicitly-deployable child updates of this Update. Creates an Installableitem on behalf of this update(parent) if the update(parent) itself has files (not a common case).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ReadOnlyCollection(Of IInstallableItem)
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetInstallableItems()

Syntax

Visual Basic
Function GetInstallableItems() As ReadOnlyCollection(Of IInstallableItem)
C#
ReadOnlyCollection<IInstallableItem> GetInstallableItems();
C++
public:
virtual ReadOnlyCollection<IInstallableItem^>^ GetInstallableItems();
J#
public ReadOnlyCollection<IInstallableItem> GetInstallableItems();
JScript
function GetInstallableItems() : JScript does not support Generics.;

Return Value

The collection of InstallableItem that represent the directly bundled, non-explicitly-deployable child updates of this Update. It includes an Installableitem on behalf of this update(parent) if the update(parent) itself has files.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetLicenseAgreement Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the license agreement for this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ILicenseAgreement
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetLicenseAgreement()

Syntax

Visual Basic
Function GetLicenseAgreement() As ILicenseAgreement
C#
ILicenseAgreement GetLicenseAgreement();
C++
public:
virtual ILicenseAgreement^ GetLicenseAgreement();
J#
public ILicenseAgreement GetLicenseAgreement();
JScript
function GetLicenseAgreement() : ILicenseAgreement;

Return Value

An ILicenseAgreement that contains the text of the agreement and indicates if the agreement has been accepted and by whom.

Exceptions

Exception type | Condition
InvalidOperationException | The update does not have a license agreement. To determine if the update has an associated license agreement, call IUpdate.HasLicenseAgreement.
WsusObjectNotFoundException | The update has a license agreement, but the agreement could not be found in the database. The license agreement must be downloaded before you can retrieve the agreement. To determine if the agreement has been downloaded, call IUpdate.State. The agreement is not downloaded if the state is UpdateState.LicenseAgreementNotReady or UpdateState.LicenseAgreementFailed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetRelatedUpdates Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets a list of related Updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim relationship As UpdateRelationship
Dim returnValue As UpdateCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetRelatedUpdates(relationship)

Syntax

Visual Basic
Function GetRelatedUpdates( _
    ByVal relationship As UpdateRelationship _
) As UpdateCollection
C#
UpdateCollection GetRelatedUpdates(
    UpdateRelationship relationship
);
C++
public:
virtual UpdateCollection^ GetRelatedUpdates(
    UpdateRelationship relationship
);
J#
public UpdateCollection GetRelatedUpdates(
    UpdateRelationship relationship
);
JScript
function GetRelatedUpdates(
     relationship : UpdateRelationship
) : UpdateCollection;

Parameters

relationship

Specifies the relationship to build the UpdateCollection.

Return Value

The list of Updates that match the specified relationship to this Update, or an empty collection if none match.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | relationship is not a valid UpdateRelationship.
WsusObjectNotFoundException | The update could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryForComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdate.GetSummaryForComputerTargetGroup (IComputerTargetGroup) | Retrieves the summary information about this Update for the specified ComputerTargetGroup.
IUpdate.GetSummaryForComputerTargetGroup (IComputerTargetGroup, Boolean) |

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryForComputerTargetGroup Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the summary information about this Update for the specified ComputerTargetGroup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim returnValue As IUpdateSummary
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetSummaryForComputerTargetGroup(targetGroup)

Syntax

Visual Basic
Function GetSummaryForComputerTargetGroup( _
    ByVal targetGroup As IComputerTargetGroup _
) As IUpdateSummary
C#
IUpdateSummary GetSummaryForComputerTargetGroup(
    IComputerTargetGroup targetGroup
);
C++
public:
virtual IUpdateSummary^ GetSummaryForComputerTargetGroup(
    IComputerTargetGroup^ targetGroup
);
J#
public IUpdateSummary GetSummaryForComputerTargetGroup(
    IComputerTargetGroup targetGroup
);
JScript
function GetSummaryForComputerTargetGroup(
     targetGroup : IComputerTargetGroup
) : IUpdateSummary;

Parameters

targetGroup

The target group to get summary data for.

Return Value

IUpdateSummary object with totals summed across all Computers in the ComputerTargetGroup for this update.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup is a null reference.
WsusObjectNotFoundException | The update or the specified target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryForComputerTargetGroup Method (IComputerTargetGroup, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim includeSubgroups As Boolean
Dim returnValue As IUpdateSummary
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetSummaryForComputerTargetGroup(targetGroup, includeSubgroups)

Syntax

Visual Basic
Function GetSummaryForComputerTargetGroup( _
    ByVal targetGroup As IComputerTargetGroup, _
    ByVal includeSubgroups As Boolean _
) As IUpdateSummary
C#
IUpdateSummary GetSummaryForComputerTargetGroup(
    IComputerTargetGroup targetGroup,
    bool includeSubgroups
);
C++
public:
virtual IUpdateSummary^ GetSummaryForComputerTargetGroup(
    IComputerTargetGroup^ targetGroup,
    bool includeSubgroups
);
J#
public IUpdateSummary GetSummaryForComputerTargetGroup(
    IComputerTargetGroup targetGroup,
    boolean includeSubgroups
);
JScript
function GetSummaryForComputerTargetGroup(
     targetGroup : IComputerTargetGroup,
     includeSubgroups : Boolean
) : IUpdateSummary;

Parameters

targetGroup

The target group to get summary data for.

includeSubgroups

A value indicating whether computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

IUpdateSummary object with totals summed across all Computers in the ComputerTargetGroup for this update.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup is a null reference.
WsusObjectNotFoundException | The update or the specified target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryPerComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdate.GetSummaryPerComputerTargetGroup () | Retrieves a collection of summary information for each target group to which the update applies.
IUpdate.GetSummaryPerComputerTargetGroup (Boolean) |

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryPerComputerTargetGroup Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of summary information for each target group to which the update applies.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetSummaryPerComputerTargetGroup()

Syntax

Visual Basic
Function GetSummaryPerComputerTargetGroup() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerComputerTargetGroup();
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerComputerTargetGroup();
J#
public UpdateSummaryCollection GetSummaryPerComputerTargetGroup();
JScript
function GetSummaryPerComputerTargetGroup() : UpdateSummaryCollection;

Return Value

An UpdateSummaryCollection collection that contains summary information for each target group to which the update applies. The summary information represents the installation state totals summed across all clients in the target group. For example, the total number of clients that installed the update.

Remarks

To determine the installation state of individual clients within a target group, call IUpdate.GetUpdateInstallationInfoPerComputerTarget. Then, for each client in the group, call IUpdateInstallationInfo.UpdateInstallationState.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSummaryPerComputerTargetGroup Method (Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim includeSubgroups As Boolean
Dim returnValue As UpdateSummaryCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetSummaryPerComputerTargetGroup(includeSubgroups)

Syntax

Visual Basic
Function GetSummaryPerComputerTargetGroup( _
    ByVal includeSubgroups As Boolean _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerComputerTargetGroup(
    bool includeSubgroups
);
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerComputerTargetGroup(
    bool includeSubgroups
);
J#
public UpdateSummaryCollection GetSummaryPerComputerTargetGroup(
    boolean includeSubgroups
);
JScript
function GetSummaryPerComputerTargetGroup(
     includeSubgroups : Boolean
) : UpdateSummaryCollection;

Parameters

includeSubgroups

A value indicating whether computers belonging to descendant subgroups should be included. If false, only direct members of each group are included; if true, members of the group and any descendant target groups are included are included in each group summary.

Return Value

A Collection of IUpdateSummary objects, one per ComputerTargetGroup, each with totals summed across all Computers in the ComputerTargetGroup for this update.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetSupportedUpdateLanguages Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of the languages that this update supports.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As StringCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetSupportedUpdateLanguages()

Syntax

Visual Basic
Function GetSupportedUpdateLanguages() As StringCollection
C#
StringCollection GetSupportedUpdateLanguages();
C++
public:
virtual StringCollection^ GetSupportedUpdateLanguages();
J#
public StringCollection GetSupportedUpdateLanguages();
JScript
function GetSupportedUpdateLanguages() : StringCollection;

Return Value

Collection of language codes that the update supports.

Remarks

The language codes follow the format specified in RFC1766. For example, "en" for English or "pt-br" for Portuguese (Brazil). WSUS supports a subset of the language and culture codes specified in ISO 639 and ISO 3166, respectively.

A value of UpdateLanguage.All indicates that the update applies to all languages.

Note that WSUS stores the language codes in lowercase, so if you use StringCollection.Contains to determine if the collection contains a specific language code, you must specify the language code in lowercase (Contains performs a case-sensitive comparison).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateApprovals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdate.GetUpdateApprovals () | Retrieves a collection of all approvals for this update.
IUpdate.GetUpdateApprovals (IComputerTargetGroup) | Retrieves a collection of approvals for this update. The update must have been approved for deployment to the given target group.
IUpdate.GetUpdateApprovals (IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime) | Retrieves a collection of approvals for this update based on the given criteria.

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateApprovals Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of all approvals for this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateApprovalCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateApprovals()

Syntax

Visual Basic
Function GetUpdateApprovals() As UpdateApprovalCollection
C#
UpdateApprovalCollection GetUpdateApprovals();
C++
public:
virtual UpdateApprovalCollection^ GetUpdateApprovals();
J#
public UpdateApprovalCollection GetUpdateApprovals();
JScript
function GetUpdateApprovals() : UpdateApprovalCollection;

Return Value

An UpdateApprovalCollection frlrfMicrosoftUpdateServicesAdministrationUpdateApprovalCollectionClassTopic collection that contains the list of all approvals for this update.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update was not found in the database.

Remarks

To limit the collection to approvals for a specific target group, call IUpdate.GetUpdateApprovals(IComputerTargetGroup).

To further limit the collection, call IUpdate.GetUpdateApprovals(IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateApprovals Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of approvals for this update. The update must have been approved for deployment to the given target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim returnValue As UpdateApprovalCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateApprovals(targetGroup)

Syntax

Visual Basic
Function GetUpdateApprovals( _
    ByVal targetGroup As IComputerTargetGroup _
) As UpdateApprovalCollection
C#
UpdateApprovalCollection GetUpdateApprovals(
    IComputerTargetGroup targetGroup
);
C++
public:
virtual UpdateApprovalCollection^ GetUpdateApprovals(
    IComputerTargetGroup^ targetGroup
);
J#
public UpdateApprovalCollection GetUpdateApprovals(
    IComputerTargetGroup targetGroup
);
JScript
function GetUpdateApprovals(
     targetGroup : IComputerTargetGroup
) : UpdateApprovalCollection;

Parameters

targetGroup

Target group for which you want to retrieve a list of approvals for this update.

Return Value

An UpdateApprovalCollection frlrfMicrosoftUpdateServicesAdministrationUpdateApprovalCollectionClassTopic collection that contains the list of all approvals for this update in the given target group. The collection is empty if the update is not approved for deployment to the target group.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup cannot be null.
WsusObjectNotFoundException | The update was not found in the database.

Remarks

To further limit the collection, call IUpdate.GetUpdateApprovals(IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime).

To retrieve all approvals for this update, call IUpdate.GetUpdateApprovals().

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateApprovals Method (IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of approvals for this update based on the given criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim approvalAction As UpdateApprovalAction
Dim fromApprovalDate As DateTime
Dim toApprovalDate As DateTime
Dim returnValue As UpdateApprovalCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateApprovals(targetGroup, approvalAction, fromApprovalDate, toApprovalDate)

Syntax

Visual Basic
Function GetUpdateApprovals( _
    ByVal targetGroup As IComputerTargetGroup, _
    ByVal approvalAction As UpdateApprovalAction, _
    ByVal fromApprovalDate As DateTime, _
    ByVal toApprovalDate As DateTime _
) As UpdateApprovalCollection
C#
UpdateApprovalCollection GetUpdateApprovals(
    IComputerTargetGroup targetGroup,
    UpdateApprovalAction approvalAction,
    DateTime fromApprovalDate,
    DateTime toApprovalDate
);
C++
public:
virtual UpdateApprovalCollection^ GetUpdateApprovals(
    IComputerTargetGroup^ targetGroup,
    UpdateApprovalAction approvalAction,
    DateTime^ fromApprovalDate,
    DateTime^ toApprovalDate
);
J#
public UpdateApprovalCollection GetUpdateApprovals(
    IComputerTargetGroup targetGroup,
    UpdateApprovalAction approvalAction,
    DateTime fromApprovalDate,
    DateTime toApprovalDate
);
JScript
function GetUpdateApprovals(
     targetGroup : IComputerTargetGroup,
     approvalAction : UpdateApprovalAction,
     fromApprovalDate : DateTime,
     toApprovalDate : DateTime
) : UpdateApprovalCollection;

Parameters

targetGroup

Target group for which you want to retrieve a list of approvals for this update.

approvalAction

Retrieve only approvals that contain the given approval action. To include all approval actions, set to UpdateApprovalAction.All.

fromApprovalDate

Begin date that is used to search for approvals. Specify the date in Coordinated Universal Time.

toApprovalDate

End date that is used to search for approvals. Specify the date in Coordinated Universal Time.

Return Value

An UpdateApprovalCollection frlrfMicrosoftUpdateServicesAdministrationUpdateApprovalCollectionClassTopic collection that contains the list of approvals for this update based on the given criteria. The collection is empty if the approval does not match the criteria.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup cannot be null.
ArgumentOutOfRangeException | fromApprovalDate cannot be greater than toApprovalDate, or the value of approvalAction is not valid.
WsusObjectNotFoundException | The update was not found in the database.

Remarks

To retrieve all approvals for this update, call IUpdate.GetUpdateApprovals().

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of product categories to which this update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateCategories()

Syntax

Visual Basic
Function GetUpdateCategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetUpdateCategories();
C++
public:
virtual UpdateCategoryCollection^ GetUpdateCategories();
J#
public UpdateCategoryCollection GetUpdateCategories();
JScript
function GetUpdateCategories() : UpdateCategoryCollection;

Return Value

An UpdateCategoryCollection frlrfMicrosoftUpdateServicesAdministrationUpdateCategoryCollectionClassTopic collection of product categories to which this update belongs.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateClassification Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the classification to which the update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateClassification
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateClassification()

Syntax

Visual Basic
Function GetUpdateClassification() As IUpdateClassification
C#
IUpdateClassification GetUpdateClassification();
C++
public:
virtual IUpdateClassification^ GetUpdateClassification();
J#
public IUpdateClassification GetUpdateClassification();
JScript
function GetUpdateClassification() : IUpdateClassification;

Return Value

An IUpdateClassification frlrfMicrosoftUpdateServicesAdministrationIUpdateClassificationClassTopic of the classification to which the update belongs.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update was not found in the database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateEventHistory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the event history that is associated with this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim returnValue As UpdateEventCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateEventHistory(fromDate, toDate)

Syntax

Visual Basic
Function GetUpdateEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
) As UpdateEventCollection
C#
UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual UpdateEventCollection^ GetUpdateEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate
);
JScript
function GetUpdateEventHistory(
     fromDate : DateTime,
     toDate : DateTime
) : UpdateEventCollection;

Parameters

fromDate

Begin date that is used to search for events that are associated with this update. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events that are associated with this update. Specify the date in Coordinated Universal Time.

Return Value

An UpdateEventCollection frlrfMicrosoftUpdateServicesAdministrationUpdateEventCollectionClassTopic collection that contains the event history of this update for the specified date range.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

Events are removed based on the IUpdateServerConfiguration.ServerEventExpirationTime configuration setting. You can also call IUpdate.PurgeAssociatedReportingEvents to remove events.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateInstallationInfoPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdate.GetUpdateInstallationInfoPerComputerTarget (ComputerTargetScope) | Retrieves the collection of installation information about this Update for each Computer that matches the specified search filter.
IUpdate.GetUpdateInstallationInfoPerComputerTarget (IComputerTargetGroup) | Retrieves a collection of installation information for each client in the specified target group.
IUpdate.GetUpdateInstallationInfoPerComputerTarget (IComputerTargetGroup, Boolean) | Retrieves the collection of installation information about this Update for each Computer in the specified TargetGroup.

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateInstallationInfoPerComputerTarget Method (ComputerTargetScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the collection of installation information about this Update for each Computer that matches the specified search filter.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computersToInclude As ComputerTargetScope
Dim returnValue As UpdateInstallationInfoCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateInstallationInfoPerComputerTarget(computersToInclude)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerComputerTarget( _
    ByVal computersToInclude As ComputerTargetScope _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    ComputerTargetScope computersToInclude
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerComputerTarget(
    ComputerTargetScope^ computersToInclude
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    ComputerTargetScope computersToInclude
);
JScript
function GetUpdateInstallationInfoPerComputerTarget(
     computersToInclude : ComputerTargetScope
) : UpdateInstallationInfoCollection;

Parameters

computersToInclude

Search criteria defining the set of computers to return status for.

Return Value

A collection of UpdateInstallationInfoCollection objects, one per Computer.

Exceptions

Exception type | Condition
ArgumentNullException | computersToInclude is null.
ArgumentOutOfRangeException | computersToInclude.FromLastSyncTime is greater than computersToInclude.ToLastSyncTime --or-- computersToInclude.FromLastReportedStatusTime is greater than computersToInclude.ToLastReportedStatusTime
WsusObjectNotFoundException | The update could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateInstallationInfoPerComputerTarget Method (IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of installation information for each client in the specified target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim returnValue As UpdateInstallationInfoCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateInstallationInfoPerComputerTarget(targetGroup)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerComputerTarget( _
    ByVal targetGroup As IComputerTargetGroup _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup targetGroup
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup^ targetGroup
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup targetGroup
);
JScript
function GetUpdateInstallationInfoPerComputerTarget(
     targetGroup : IComputerTargetGroup
) : UpdateInstallationInfoCollection;

Parameters

targetGroup

Target group for which you want to retrieve client installation information.

To specify All Computers or Unassigned Computers, use ComputerTargetGroupId.AllComputers and ComputerTargetGroupId.UnassignedComputers, respectively, when you create your target group.

Return Value

An UpdateInstallationInfoCollection frlrfMicrosoftUpdateServicesAdministrationUpdateInstallationInfoCollectionClassTopic collection that contains the installation state for each client in the target group.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup cannot be null.
WsusObjectNotFoundException | The target group does not exist.

Remarks

To retrieve summary information for each target group to which the update applies, call IUpdate.GetSummaryPerComputerTargetGroup.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.GetUpdateInstallationInfoPerComputerTarget Method (IComputerTargetGroup, Boolean)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the collection of installation information about this Update for each Computer in the specified TargetGroup.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetGroup As IComputerTargetGroup
Dim includeSubgroups As Boolean
Dim returnValue As UpdateInstallationInfoCollection
Dim iUpdate1 As IUpdate
returnValue = iUpdate1.GetUpdateInstallationInfoPerComputerTarget(targetGroup, includeSubgroups)

Syntax

Visual Basic
Function GetUpdateInstallationInfoPerComputerTarget( _
    ByVal targetGroup As IComputerTargetGroup, _
    ByVal includeSubgroups As Boolean _
) As UpdateInstallationInfoCollection
C#
UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup targetGroup,
    bool includeSubgroups
);
C++
public:
virtual UpdateInstallationInfoCollection^ GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup^ targetGroup,
    bool includeSubgroups
);
J#
public UpdateInstallationInfoCollection GetUpdateInstallationInfoPerComputerTarget(
    IComputerTargetGroup targetGroup,
    boolean includeSubgroups
);
JScript
function GetUpdateInstallationInfoPerComputerTarget(
     targetGroup : IComputerTargetGroup,
     includeSubgroups : Boolean
) : UpdateInstallationInfoCollection;

Parameters

targetGroup

The TargetGroup for which to get information.

includeSubgroups

The value indicating whether computers belonging to descendant subgroups should be included. If false, only direct members of this group are included; if true, members of this group and any descendant target groups are included.

Return Value

A collection of UpdateInstallationInfo objects, one per Computer in the specified TargetGroup.

Exceptions

Exception type | Condition
ArgumentNullException | targetGroup is null.
WsusObjectNotFoundException | The update or the specified target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.PurgeAssociatedReportingEvents Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Uses the specified date range to remove events that are associated with this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim iUpdate1 As IUpdate
iUpdate1.PurgeAssociatedReportingEvents(fromDate, toDate)

Syntax

Visual Basic
Sub PurgeAssociatedReportingEvents( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
)
C#
void PurgeAssociatedReportingEvents(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual void PurgeAssociatedReportingEvents(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public void PurgeAssociatedReportingEvents(
    DateTime fromDate,
    DateTime toDate
);
JScript
function PurgeAssociatedReportingEvents(
     fromDate : DateTime,
     toDate : DateTime
) : Void;

Parameters

fromDate

Begin date that is used to remove events that are associated with this update. Specify the date in Coordinated Universal Time.

toDate

End date that is used to remove events that are associated with this update. Specify the date in Coordinated Universal Time.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

Typically, events are removed based on the IUpdateServerConfiguration.ServerEventExpirationTime configuration setting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Refresh Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Refreshes the properties of this Update with the latest values.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.Refresh()

Syntax

Visual Basic
Sub Refresh()
C#
void Refresh();
C++
public:
virtual void Refresh();
J#
public void Refresh();
JScript
function Refresh() : Void;

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.RefreshUpdateApprovals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Moves existing approvals from older revisions to the latest revision of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.RefreshUpdateApprovals()

Syntax

Visual Basic
Sub RefreshUpdateApprovals()
C#
void RefreshUpdateApprovals();
C++
public:
virtual void RefreshUpdateApprovals();
J#
public void RefreshUpdateApprovals();
JScript
function RefreshUpdateApprovals() : Void;

Exceptions

Exception type | Condition
InvalidOperationException | You cannot refresh approvals for the update if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ResumeDownload Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifies to the synchronization agent the update to download.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate
iUpdate1.ResumeDownload()

Syntax

Visual Basic
Sub ResumeDownload()
C#
void ResumeDownload();
C++
public:
virtual void ResumeDownload();
J#
public void ResumeDownload();
JScript
function ResumeDownload() : Void;

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The update has been deleted.

Remarks

This method does not restart a failed or canceled download; it only identifies to the synchronization agent the update to download. The update could be a new update, an update that was canceled during a previous synchronization, or an update that failed to download. The synchronization agent will then start the download based on the synchronization schedule or earlier if you call ISubscription.StartSynchronization.

If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, ResumeDownload resumes downloading the end-user license agreements.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | AdditionalInformationUrls | Retrieves a collection of URLs provided by the publisher of the update that provide additional information about the update.
public property | ArrivalDate | Retrieves the date and time when the metadata for this revision of the update finished downloading to the WSUS server.
public property | CompanyTitles | Retrieves the titles of all the companies to which this update belongs.
public property | CreationDate | Retrieves the date and time when this revision of the update's metadata was authored.
public property | Description | Retrieves a short description of the update.
public property | HasEarlierRevision | Retrieves a value that indicates if the WSUS server contains earlier revisions of this update.
public property | HasLicenseAgreement | Retrieves a value that indicates if the update has an associated license agreement.
public property | HasStaleUpdateApprovals | Retrieves a value that indicates if an older revision of the update contains an approval.
public property | HasSupersededUpdates | Retrieves a value that indicates if the update supersedes other updates.
public property | Id | Retrieves the unique identifier of the update.
public property | InstallationBehavior | Retrieves the installation behavior of the update.
public property | IsApproved | Retrieves a value that indicates if this revision of the update is approved for at least one target group.
public property | IsDeclined | Retrieves a value that indicates if this update is declined.
public property | IsEditable | Retrieves a value indicating whether this update is editable.
public property | IsLatestRevision | Retrieves a value that indicates if this revision is the latest revision of the update.
public property | IsSuperseded | Retrieves a value that indicates if this update is superseded by related updates.
public property | IsWsusInfrastructureUpdate | Retrieves a value that indicates if this update is a WSUS infrastructure update.
public property | KnowledgebaseArticles | Retrieves a collection of strings, each containing a Knowledgebase article number that describes an issue related to or fixed by this Update.
public property | LegacyName | Retrieves the name of the update that was used in previous versions.
public property | MsrcSeverity | Retrieves the maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with the update.
public property | ProductFamilyTitles | Retrieves the titles of all product family categories to which the update belongs.
public property | ProductTitles | Retrieves the titles of all product categories to which the update belongs.
public property | PublicationState | Retrieves the publication state of the update.
public property | RequiresLicenseAgreementAcceptance | Retrieves a value that indicates if the update requires a user to accept the license agreement.
public property | SecurityBulletins | Retrieves a collection of Security Bulletin numbers. The bulletins describe security issues and changes that are related to the update.
public property | State | Retrieves the current state of the update.
public property | Title | Retrieves the title of the update.
public property | UninstallationBehavior | Retrieves the removal behavior of the update.
public property | UpdateClassificationTitle | Retrieves the title of the classification to which the update belongs.
public property | UpdateType | Retrieves a value that indicates if the update is a software update or a driver update.

See Also

Reference

IUpdate Interface


IUpdate.AdditionalInformationUrls Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of URLs provided by the publisher of the update that provide additional information about the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.AdditionalInformationUrls

Syntax

Visual Basic
ReadOnly Property AdditionalInformationUrls() As StringCollection
C#
StringCollection AdditionalInformationUrls {get;}
C++
property virtual StringCollection^ AdditionalInformationUrls {
    StringCollection^ get();
}
J#
public StringCollection get_AdditionalInformationUrls();
JScript
function get AdditionalInformationUrls() : StringCollection;

Property Value

String collection that contains URLs provided by the publisher of the update that provide additional information about the update.

Remarks

To retrieve a summary description of the update, call IUpdate.Description.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ArrivalDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date and time when the metadata for this revision of the update finished downloading to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As DateTime
returnValue = iUpdate1.ArrivalDate

Syntax

Visual Basic
ReadOnly Property ArrivalDate() As DateTime
C#
DateTime ArrivalDate {get;}
C++
property virtual DateTime^ ArrivalDate {
    DateTime^ get();
}
J#
public DateTime get_ArrivalDate();
JScript
function get ArrivalDate() : DateTime;

Property Value

Date and time when the metadata for this revision of the update finished downloading to the WSUS server. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.CompanyTitles Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the titles of all the companies to which this update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.CompanyTitles

Syntax

Visual Basic
ReadOnly Property CompanyTitles() As StringCollection
C#
StringCollection CompanyTitles {get;}
C++
property virtual StringCollection^ CompanyTitles {
    StringCollection^ get();
}
J#
public StringCollection get_CompanyTitles();
JScript
function get CompanyTitles() : StringCollection;

Property Value

String collection that contains the titles of all the companies to which this update belongs.

Remarks

If the title is localized, the property returns the title in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.CreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date and time when this revision of the update's metadata was authored.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As DateTime
returnValue = iUpdate1.CreationDate

Syntax

Visual Basic
ReadOnly Property CreationDate() As DateTime
C#
DateTime CreationDate {get;}
C++
property virtual DateTime^ CreationDate {
    DateTime^ get();
}
J#
public DateTime get_CreationDate();
JScript
function get CreationDate() : DateTime;

Property Value

Date and time when this revision of the update's metadata was authored. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a short description of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As String
returnValue = iUpdate1.Description

Syntax

Visual Basic
ReadOnly Property Description() As String
C#
string Description {get;}
C++
property virtual String^ Description {
    String^ get();
}
J#
public System.String get_Description();
JScript
function get Description() : String;

Property Value

Short description of the update.

Remarks

If the description is localized, the property returns the description in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

To obtain additional information about the update, call IUpdate.AdditionalInformationUrls. Sometimes the provider of the update uses the URLs to provide a more extensive description of the update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.HasEarlierRevision Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the WSUS server contains earlier revisions of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.HasEarlierRevision

Syntax

Visual Basic
ReadOnly Property HasEarlierRevision() As Boolean
C#
bool HasEarlierRevision {get;}
C++
property virtual bool HasEarlierRevision {
    bool get();
}
J#
public boolean get_HasEarlierRevision();
JScript
function get HasEarlierRevision() : Boolean;

Property Value

True if the WSUS server contains earlier revisions of this update; otherwise, false.

Remarks

To determine if this update is the latest revision, call IUpdate.IsLatestRevision.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.HasLicenseAgreement Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the update has an associated license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.HasLicenseAgreement

Syntax

Visual Basic
ReadOnly Property HasLicenseAgreement() As Boolean
C#
bool HasLicenseAgreement {get;}
C++
property virtual bool HasLicenseAgreement {
    bool get();
}
J#
public boolean get_HasLicenseAgreement();
JScript
function get HasLicenseAgreement() : Boolean;

Property Value

True if the update has an associated license agreement; otherwise, false.

Remarks

To retrieve the license agreement, call IUpdate.GetLicenseAgreement. To determine if the user must accept the agreement before you can approve the update, call IUpdate.RequiresLicenseAgreementAcceptance.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.HasStaleUpdateApprovals Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if an older revision of the update contains an approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.HasStaleUpdateApprovals

Syntax

Visual Basic
ReadOnly Property HasStaleUpdateApprovals() As Boolean
C#
bool HasStaleUpdateApprovals {get;}
C++
property virtual bool HasStaleUpdateApprovals {
    bool get();
}
J#
public boolean get_HasStaleUpdateApprovals();
JScript
function get HasStaleUpdateApprovals() : Boolean;

Property Value

True if an older revision of the update contains an approval; otherwise, false.

Remarks

To find the older revision that contains the approval, call IUpdate.GetRelatedUpdates (set relationship to UpdateRelationship.AllRevisionsOfThisUpdate). Iterate through the collection of older revisions until you find the update whose IsApproved property is true.

To move the approvals forward to the latest revision, call IUpdate.RefreshUpdateApprovals. To automatically move approvals forward, set IUpdateServerConfiguration.AutoRefreshUpdateApprovals.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.HasSupersededUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the update supersedes other updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.HasSupersededUpdates

Syntax

Visual Basic
ReadOnly Property HasSupersededUpdates() As Boolean
C#
bool HasSupersededUpdates {get;}
C++
property virtual bool HasSupersededUpdates {
    bool get();
}
J#
public boolean get_HasSupersededUpdates();
JScript
function get HasSupersededUpdates() : Boolean;

Property Value

True if the update supersedes other updates; otherwise, false.

Remarks

To find the updates that this update supersedes, call IUpdate.GetRelatedUpdates (set relationship to UpdateRelationship.UpdatesSupersededByThisUpdate).

To determine if this update is superseded by other updates, call IUpdate.IsSuperseded

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As UpdateRevisionId
returnValue = iUpdate1.Id

Syntax

Visual Basic
ReadOnly Property Id() As UpdateRevisionId
C#
UpdateRevisionId Id {get;}
C++
property virtual UpdateRevisionId^ Id {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_Id();
JScript
function get Id() : UpdateRevisionId;

Property Value

Unique identifier of the update. For details on uniquely identifying an update, see UpdateRevisionId frlrfMicrosoftUpdateServicesAdministrationUpdateRevisionIdClassTopic

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.InstallationBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the installation behavior of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As InstallationBehavior
returnValue = iUpdate1.InstallationBehavior

Syntax

Visual Basic
ReadOnly Property InstallationBehavior() As InstallationBehavior
C#
InstallationBehavior InstallationBehavior {get;}
C++
property virtual InstallationBehavior^ InstallationBehavior {
    InstallationBehavior^ get();
}
J#
public InstallationBehavior get_InstallationBehavior();
JScript
function get InstallationBehavior() : InstallationBehavior;

Property Value

Installation behavior of the update. For example, the update requests user input or requires the user to restart the computer. For details, see InstallationBehavior frlrfMicrosoftUpdateServicesAdministrationInstallationBehaviorClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsApproved Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if this revision of the update is approved for at least one target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsApproved

Syntax

Visual Basic
ReadOnly Property IsApproved() As Boolean
C#
bool IsApproved {get;}
C++
property virtual bool IsApproved {
    bool get();
}
J#
public boolean get_IsApproved();
JScript
function get IsApproved() : Boolean;

Property Value

True if this revision of the update is approved for at least one target group; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsDeclined Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if this update is declined.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsDeclined

Syntax

Visual Basic
ReadOnly Property IsDeclined() As Boolean
C#
bool IsDeclined {get;}
C++
property virtual bool IsDeclined {
    bool get();
}
J#
public boolean get_IsDeclined();
JScript
function get IsDeclined() : Boolean;

Property Value

True if the update is declined; otherwise, false.

Remarks

You cannot deploy declined updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsEditable Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value indicating whether this update is editable.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsEditable

Syntax

Visual Basic
ReadOnly Property IsEditable() As Boolean
C#
bool IsEditable {get;}
C++
property virtual bool IsEditable {
    bool get();
}
J#
public boolean get_IsEditable();
JScript
function get IsEditable() : Boolean;

Property Value

The value indicating whether this update is editable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsLatestRevision Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if this revision is the latest revision of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsLatestRevision

Syntax

Visual Basic
ReadOnly Property IsLatestRevision() As Boolean
C#
bool IsLatestRevision {get;}
C++
property virtual bool IsLatestRevision {
    bool get();
}
J#
public boolean get_IsLatestRevision();
JScript
function get IsLatestRevision() : Boolean;

Property Value

True if this revision is the latest revision of the update; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsSuperseded Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if this update is superseded by related updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsSuperseded

Syntax

Visual Basic
ReadOnly Property IsSuperseded() As Boolean
C#
bool IsSuperseded {get;}
C++
property virtual bool IsSuperseded {
    bool get();
}
J#
public boolean get_IsSuperseded();
JScript
function get IsSuperseded() : Boolean;

Property Value

True if this update is superseded by a related update; otherwise, false.

Remarks

For example, if UpdateD supersedes UpdateC which supersedes UpdateB which supersedes UpdateA, this property would return false for UpdateD and true for the others.

To find the updates that supersede this update, call IUpdate.GetRelatedUpdates (set relationship to UpdateRelationship.UpdatesThatSupersedeThisUpdate).

To determine if this update supersedes other updates, call IUpdate.HasSupersededUpdates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.IsWsusInfrastructureUpdate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if this update is a WSUS infrastructure update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.IsWsusInfrastructureUpdate

Syntax

Visual Basic
ReadOnly Property IsWsusInfrastructureUpdate() As Boolean
C#
bool IsWsusInfrastructureUpdate {get;}
C++
property virtual bool IsWsusInfrastructureUpdate {
    bool get();
}
J#
public boolean get_IsWsusInfrastructureUpdate();
JScript
function get IsWsusInfrastructureUpdate() : Boolean;

Property Value

True if this update is a WSUS infrastructure update; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.KnowledgebaseArticles Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of strings, each containing a Knowledgebase article number that describes an issue related to or fixed by this Update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.KnowledgebaseArticles

Syntax

Visual Basic
ReadOnly Property KnowledgebaseArticles() As StringCollection
C#
StringCollection KnowledgebaseArticles {get;}
C++
property virtual StringCollection^ KnowledgebaseArticles {
    StringCollection^ get();
}
J#
public StringCollection get_KnowledgebaseArticles();
JScript
function get KnowledgebaseArticles() : StringCollection;

Property Value

A collection of strings, each containing a Knowledgebase article number that describes an issue related to or fixed by this Update. An empty collection if this Update has no associated Knowledge Base articles.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.LegacyName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the update that was used in previous versions.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As String
returnValue = iUpdate1.LegacyName

Syntax

Visual Basic
ReadOnly Property LegacyName() As String
C#
string LegacyName {get;}
C++
property virtual String^ LegacyName {
    String^ get();
}
J#
public System.String get_LegacyName();
JScript
function get LegacyName() : String;

Property Value

Name of the update that was used in previous versions; otherwise, an empty string.

Remarks

For most updates, the value will be String.Empty. However, this property can be used for migrating older updates to the current version of WSUS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.MsrcSeverity Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As MsrcSeverity
returnValue = iUpdate1.MsrcSeverity

Syntax

Visual Basic
ReadOnly Property MsrcSeverity() As MsrcSeverity
C#
MsrcSeverity MsrcSeverity {get;}
C++
property virtual MsrcSeverity MsrcSeverity {
    MsrcSeverity get();
}
J#
public MsrcSeverity get_MsrcSeverity();
JScript
function get MsrcSeverity() : MsrcSeverity;

Property Value

Maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with this update. For possible values, see MsrcSeverity frlrfMicrosoftUpdateServicesAdministrationMsrcSeverityClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ProductFamilyTitles Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the titles of all product family categories to which the update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.ProductFamilyTitles

Syntax

Visual Basic
ReadOnly Property ProductFamilyTitles() As StringCollection
C#
StringCollection ProductFamilyTitles {get;}
C++
property virtual StringCollection^ ProductFamilyTitles {
    StringCollection^ get();
}
J#
public StringCollection get_ProductFamilyTitles();
JScript
function get ProductFamilyTitles() : StringCollection;

Property Value

String collection that contains the titles of all product family categories to which the update belongs.

Remarks

If the title is localized, the property returns the title in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.ProductTitles Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the titles of all product categories to which the update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.ProductTitles

Syntax

Visual Basic
ReadOnly Property ProductTitles() As StringCollection
C#
StringCollection ProductTitles {get;}
C++
property virtual StringCollection^ ProductTitles {
    StringCollection^ get();
}
J#
public StringCollection get_ProductTitles();
JScript
function get ProductTitles() : StringCollection;

Property Value

String collection that contains the titles of all product categories to which the update belongs.

Remarks

If the title is localized, the property returns the title in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.PublicationState Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the publication state of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As PublicationState
returnValue = iUpdate1.PublicationState

Syntax

Visual Basic
ReadOnly Property PublicationState() As PublicationState
C#
PublicationState PublicationState {get;}
C++
property virtual PublicationState PublicationState {
    PublicationState get();
}
J#
public PublicationState get_PublicationState();
JScript
function get PublicationState() : PublicationState;

Property Value

Publication state of the update. Indicates if the update is deployed or has expired. For possible values, see PublicationState frlrfMicrosoftUpdateServicesAdministrationPublicationStateClassTopic.

Remarks

If the update is expired, WSUS automatically removes the approval rule from the update and sets IUpdate.IsDeclined to true.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.RequiresLicenseAgreementAcceptance Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the update requires a user to accept the license agreement.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As Boolean
returnValue = iUpdate1.RequiresLicenseAgreementAcceptance

Syntax

Visual Basic
ReadOnly Property RequiresLicenseAgreementAcceptance() As Boolean
C#
bool RequiresLicenseAgreementAcceptance {get;}
C++
property virtual bool RequiresLicenseAgreementAcceptance {
    bool get();
}
J#
public boolean get_RequiresLicenseAgreementAcceptance();
JScript
function get RequiresLicenseAgreementAcceptance() : Boolean;

Property Value

True if the update requires a user to accept the license agreement before you can approve the update for deployment; otherwise, false.

Remarks

To retrieve the license agreement, call IUpdate.GetLicenseAgreement.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.SecurityBulletins Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of Security Bulletin numbers. The bulletins describe security issues and changes that are related to the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As StringCollection
returnValue = iUpdate1.SecurityBulletins

Syntax

Visual Basic
ReadOnly Property SecurityBulletins() As StringCollection
C#
StringCollection SecurityBulletins {get;}
C++
property virtual StringCollection^ SecurityBulletins {
    StringCollection^ get();
}
J#
public StringCollection get_SecurityBulletins();
JScript
function get SecurityBulletins() : StringCollection;

Property Value

String collection that contains Security Bulletin numbers. For example, MS04-025, which is the security bulletin number for Cumulative Security Update for Internet Explorer (867801).

Remarks

To view additional information about the security bulletin, use the URL in IUpdate.AdditionalInformationUrls.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.State Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the current state of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As UpdateState
returnValue = iUpdate1.State

Syntax

Visual Basic
ReadOnly Property State() As UpdateState
C#
UpdateState State {get;}
C++
property virtual UpdateState State {
    UpdateState get();
}
J#
public UpdateState get_State();
JScript
function get State() : UpdateState;

Property Value

Current state of the update. For example, the update is ready to install or the update is waiting for license agreement to download before it can be approved. For a list of possible values, see UpdateState frlrfMicrosoftUpdateServicesAdministrationUpdateStateClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.Title Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the title of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As String
returnValue = iUpdate1.Title

Syntax

Visual Basic
ReadOnly Property Title() As String
C#
string Title {get;}
C++
property virtual String^ Title {
    String^ get();
}
J#
public System.String get_Title();
JScript
function get Title() : String;

Property Value

Title of the update.

Remarks

If the title is localized, the property returns the title in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.UninstallationBehavior Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the removal behavior of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As InstallationBehavior
returnValue = iUpdate1.UninstallationBehavior

Syntax

Visual Basic
ReadOnly Property UninstallationBehavior() As InstallationBehavior
C#
InstallationBehavior UninstallationBehavior {get;}
C++
property virtual InstallationBehavior^ UninstallationBehavior {
    InstallationBehavior^ get();
}
J#
public InstallationBehavior get_UninstallationBehavior();
JScript
function get UninstallationBehavior() : InstallationBehavior;

Property Value

Removal behavior of the update. For example, the update requests user input or requires the user to restart the computer. For details, see InstallationBehavior.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.UpdateClassificationTitle Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the title of the classification to which the update belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As String
returnValue = iUpdate1.UpdateClassificationTitle

Syntax

Visual Basic
ReadOnly Property UpdateClassificationTitle() As String
C#
string UpdateClassificationTitle {get;}
C++
property virtual String^ UpdateClassificationTitle {
    String^ get();
}
J#
public System.String get_UpdateClassificationTitle();
JScript
function get UpdateClassificationTitle() : String;

Property Value

Classification to which the update belongs. For example, the update is a critical update or security update.

Remarks

If the title is localized, the property returns the title in the language that IUpdateServer.PreferredCulture specifies; otherwise, English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdate.UpdateType Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the update is a software update or a driver update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdate1 As IUpdate

Dim returnValue As UpdateType
returnValue = iUpdate1.UpdateType

Syntax

Visual Basic
ReadOnly Property UpdateType() As UpdateType
C#
UpdateType UpdateType {get;}
C++
property virtual UpdateType UpdateType {
    UpdateType get();
}
J#
public UpdateType get_UpdateType();
JScript
function get UpdateType() : UpdateType;

Property Value

Identifies if the update is a software update or a driver update. For possible values, see UpdateType frlrfMicrosoftUpdateServicesAdministrationUpdateTypeClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdate Interface
IUpdate Members


IUpdateApproval Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about an approval and to remove the approval. To retrieve this interface, call the following methods: IUpdate.Approve; IUpdateServer.GetUpdateApproval; UpdateApprovalCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateApprovalImplementation
    Implements IUpdateApproval
End Class
Dim updateApprovalImplementation1 As New updateApprovalImplementation()

Syntax

Visual Basic
Public Interface IUpdateApproval
C#
public interface IUpdateApproval
C++
public interface class IUpdateApproval
J#
public interface IUpdateApproval
JScript
public interface IUpdateApproval

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Members


IUpdateApproval Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about an approval and to remove the approval. To retrieve this interface, call the following methods: IUpdate.Approve; IUpdateServer.GetUpdateApproval; UpdateApprovalCollection.Item.

The following tables list the members exposed by the IUpdateApproval type.

Public Properties

 | Name | Description
public property | Action | Retrieves a value that indicates the action that the client performs when applying the update.
public property | AdministratorName | Retrieves the name of the administrator who approved the update for deployment.
public property | ComputerTargetGroupId | Get the ID of the ComputerTargetGroup that this UpdateApproval applies to.
public property | CreationDate | Retrieves the date when the administrator approved the update for deployment.
public property | Deadline | Retrieves the date by when the client will be forced to apply the update.
public property | Id | Retrieves the unique identifier of the approval.
public property | IsAssigned | Get whether this UpdateApproval will be targeted for the Autoamtic Update (AU) client.
public property | State | Retrieves the current state of the approval.
public property | UpdateId | Get the ID of the update that this UpdateApproval applies to.
Top

Public Methods

 | Name | Description
public method | Delete | Removes the approval from the update.
public method | GetComputerTargetGroup | Retrieves the target group to which this approval applies.
public method | GetHashCode | Serves as a hash function for the current UpdateApproval, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update to which this approval applies.
Top

See Also

Reference

IUpdateApproval Interface


IUpdateApproval Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | Delete | Removes the approval from the update.
public method | GetComputerTargetGroup | Retrieves the target group to which this approval applies.
public method | GetHashCode | Serves as a hash function for the current UpdateApproval, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update to which this approval applies.

See Also

Reference

IUpdateApproval Interface


IUpdateApproval.Delete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the approval from the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval
iUpdateApproval1.Delete()

Syntax

Visual Basic
Sub Delete()
C#
void Delete();
C++
public:
virtual void Delete();
J#
public void Delete();
JScript
function Delete() : Void;

Exceptions

Exception type Condition
InvalidOperationException

You can receive this exception because of either of the following reasons:

  • You cannot remove the approval if IUpdateApproval.Action is UpdateApprovalAction.Bundle. To remove the approval, you must remove the approval from the parent update that bundles this update. To find the parent update call IUpdateApproval.GetUpdate. Then, call IUpdate.GetRelatedUpdates, setting relationship to UpdateRelationship.UpdatesThatBundleThisUpdate.

  • You cannot delete approvals for the update if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Remarks

Note that it is possible for the clients in the target group that is associated with this approval to receive the update if the same approval is also applied to the All Computers target group (because the All Computers target group contains all clients).

For example, if you remove the approval from the Accounting group and the same approval is applied to the All Computers target group, the clients in the Accounting group will still apply the update. To prevent clients in the Accounting group from receiving the update, you must create another approval for the update that uses the UpdateApprovalAction.Block action and apply it to the Accounting group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.GetComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the target group to which this approval applies.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTargetGroup
Dim iUpdateApproval1 As IUpdateApproval
returnValue = iUpdateApproval1.GetComputerTargetGroup()

Syntax

Visual Basic
Function GetComputerTargetGroup() As IComputerTargetGroup
C#
IComputerTargetGroup GetComputerTargetGroup();
C++
public:
virtual IComputerTargetGroup^ GetComputerTargetGroup();
J#
public IComputerTargetGroup GetComputerTargetGroup();
JScript
function GetComputerTargetGroup() : IComputerTargetGroup;

Return Value

An IComputerTargetGroup of the target group to which this approval applies.

Exceptions

Exception type | Condition
InvalidOperationException | Could not retrieve the target group. If this exception persists, you may need to recreate the approval.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current UpdateApproval, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateApproval1 As IUpdateApproval
returnValue = iUpdateApproval1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current UpdateApproval.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.GetUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the update to which this approval applies.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdate
Dim iUpdateApproval1 As IUpdateApproval
returnValue = iUpdateApproval1.GetUpdate()

Syntax

Visual Basic
Function GetUpdate() As IUpdate
C#
IUpdate GetUpdate();
C++
public:
virtual IUpdate^ GetUpdate();
J#
public IUpdate GetUpdate();
JScript
function GetUpdate() : IUpdate;

Return Value

An IUpdate of the update to which this approval applies.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Action | Retrieves a value that indicates the action that the client performs when applying the update.
public property | AdministratorName | Retrieves the name of the administrator who approved the update for deployment.
public property | ComputerTargetGroupId | Get the ID of the ComputerTargetGroup that this UpdateApproval applies to.
public property | CreationDate | Retrieves the date when the administrator approved the update for deployment.
public property | Deadline | Retrieves the date by when the client will be forced to apply the update.
public property | Id | Retrieves the unique identifier of the approval.
public property | IsAssigned | Get whether this UpdateApproval will be targeted for the Autoamtic Update (AU) client.
public property | State | Retrieves the current state of the approval.
public property | UpdateId | Get the ID of the update that this UpdateApproval applies to.

See Also

Reference

IUpdateApproval Interface


IUpdateApproval.Action Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates the action that the client performs when applying the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As UpdateApprovalAction
returnValue = iUpdateApproval1.Action

Syntax

Visual Basic
ReadOnly Property Action() As UpdateApprovalAction
C#
UpdateApprovalAction Action {get;}
C++
property virtual UpdateApprovalAction Action {
    UpdateApprovalAction get();
}
J#
public UpdateApprovalAction get_Action();
JScript
function get Action() : UpdateApprovalAction;

Property Value

Action the client performs when applying the update. For example, installing or removing the update. For a list of possible values, see UpdateApprovalAction.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.AdministratorName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the name of the administrator who approved the update for deployment.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As String
returnValue = iUpdateApproval1.AdministratorName

Syntax

Visual Basic
ReadOnly Property AdministratorName() As String
C#
string AdministratorName {get;}
C++
property virtual String^ AdministratorName {
    String^ get();
}
J#
public System.String get_AdministratorName();
JScript
function get AdministratorName() : String;

Property Value

Name of the administrator who approved the update. The name is in the form, domain\username.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.ComputerTargetGroupId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the ID of the ComputerTargetGroup that this UpdateApproval applies to.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As Guid
returnValue = iUpdateApproval1.ComputerTargetGroupId

Syntax

Visual Basic
ReadOnly Property ComputerTargetGroupId() As Guid
C#
Guid ComputerTargetGroupId {get;}
C++
property virtual Guid^ ComputerTargetGroupId {
    Guid^ get();
}
J#
public Guid get_ComputerTargetGroupId();
JScript
function get ComputerTargetGroupId() : Guid;

Property Value

The ID of the ComputerTargetGroup that this UpdateApproval applies to.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.CreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date when the administrator approved the update for deployment.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As DateTime
returnValue = iUpdateApproval1.CreationDate

Syntax

Visual Basic
ReadOnly Property CreationDate() As DateTime
C#
DateTime CreationDate {get;}
C++
property virtual DateTime^ CreationDate {
    DateTime^ get();
}
J#
public DateTime get_CreationDate();
JScript
function get CreationDate() : DateTime;

Property Value

Date and time that the administrator approved the update for deployment. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.Deadline Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date by when the client will be forced to apply the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As DateTime
returnValue = iUpdateApproval1.Deadline

Syntax

Visual Basic
ReadOnly Property Deadline() As DateTime
C#
DateTime Deadline {get;}
C++
property virtual DateTime^ Deadline {
    DateTime^ get();
}
J#
public DateTime get_Deadline();
JScript
function get Deadline() : DateTime;

Property Value

Date by when the client will be forced to apply the update. DateTime.MaxValue indicates that there is no deadline. The date is in Coordinated Universal Time. The deadline applies only if the IUpdateApproval.Action is install or uninstall.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As Guid
returnValue = iUpdateApproval1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the approval.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.IsAssigned Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get whether this UpdateApproval will be targeted for the Autoamtic Update (AU) client.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As Boolean
returnValue = iUpdateApproval1.IsAssigned

Syntax

Visual Basic
ReadOnly Property IsAssigned() As Boolean
C#
bool IsAssigned {get;}
C++
property virtual bool IsAssigned {
    bool get();
}
J#
public boolean get_IsAssigned();
JScript
function get IsAssigned() : Boolean;

Property Value

If true, the associated Update is distributed via the Automatic Update client. If false, AU will not automatically download the Update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.State Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the current state of the approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As UpdateApprovalState
returnValue = iUpdateApproval1.State

Syntax

Visual Basic
ReadOnly Property State() As UpdateApprovalState
C#
UpdateApprovalState State {get;}
C++
property virtual UpdateApprovalState State {
    UpdateApprovalState get();
}
J#
public UpdateApprovalState get_State();
JScript
function get State() : UpdateApprovalState;

Property Value

Current state of the approval. For example, if the approval is pending or active. For details, see UpdateApprovalState frlrfMicrosoftUpdateServicesAdministrationUpdateApprovalStateClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateApproval.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the ID of the update that this UpdateApproval applies to.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateApproval1 As IUpdateApproval

Dim returnValue As UpdateRevisionId
returnValue = iUpdateApproval1.UpdateId

Syntax

Visual Basic
ReadOnly Property UpdateId() As UpdateRevisionId
C#
UpdateRevisionId UpdateId {get;}
C++
property virtual UpdateRevisionId^ UpdateId {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_UpdateId();
JScript
function get UpdateId() : UpdateRevisionId;

Property Value

The ID of the update that this UpdateApproval applies to.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateApproval Interface
IUpdateApproval Members


IUpdateCategory Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information and updates related to a category. To retrieve this interface, call the following methods: UpdateCategoryCollection.Item; IUpdateServer.GetUpdateCategory.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateCategoryImplementation
    Implements IUpdateCategory
End Class
Dim updateCategoryImplementation1 As New updateCategoryImplementation()

Syntax

Visual Basic
Public Interface IUpdateCategory
C#
public interface IUpdateCategory
C++
public interface class IUpdateCategory
J#
public interface IUpdateCategory
JScript
public interface IUpdateCategory

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Members


IUpdateCategory Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information and updates related to a category. To retrieve this interface, call the following methods: UpdateCategoryCollection.Item; IUpdateServer.GetUpdateCategory.

The following tables list the members exposed by the IUpdateCategory type.

Public Properties

 | Name | Description
public property | ArrivalDate | Retrieves the date and time the category was added.
public property | Description | Retrieves the description of the category.
public property | DisplayOrder | Retrieves the order in which the category is displayed relative to its siblings.
public property | Id | Retrieves the unique identifier of the category.
public property | ProhibitsSubcategories | Retrieves a value that indicates if the category allows subcategories.
public property | ProhibitsUpdates | Retrieves a value that indicates if the category allows child updates.
public property | ReleaseNotes | Retrieves the release notes for the category.
public property | Title | Retrieves the title of the category.
public property | Type | Retrieves the type of the category.
Top

Public Methods

 | Name | Description
public method | GetHashCode | Serves as a hash function for the current UpdateCategory, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetParentUpdateCategory | Retrieves the parent category of this category.
public method | GetSubcategories | Retrieves the subcategories of this category.
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdates | Overloaded.
Top

See Also

Reference

IUpdateCategory Interface


IUpdateCategory Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetHashCode | Serves as a hash function for the current UpdateCategory, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetParentUpdateCategory | Retrieves the parent category of this category.
public method | GetSubcategories | Retrieves the subcategories of this category.
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdates | Overloaded.

See Also

Reference

IUpdateCategory Interface


IUpdateCategory.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current UpdateCategory, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current UpdateCategory.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetParentUpdateCategory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the parent category of this category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateCategory
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetParentUpdateCategory()

Syntax

Visual Basic
Function GetParentUpdateCategory() As IUpdateCategory
C#
IUpdateCategory GetParentUpdateCategory();
C++
public:
virtual IUpdateCategory^ GetParentUpdateCategory();
J#
public IUpdateCategory GetParentUpdateCategory();
JScript
function GetParentUpdateCategory() : IUpdateCategory;

Return Value

An IUpdateCategory of the parent category of this category. Otherwise, null if the parent category does not exist.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetSubcategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the subcategories of this category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetSubcategories()

Syntax

Visual Basic
Function GetSubcategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetSubcategories();
C++
public:
virtual UpdateCategoryCollection^ GetSubcategories();
J#
public UpdateCategoryCollection GetSubcategories();
JScript
function GetSubcategories() : UpdateCategoryCollection;

Return Value

An UpdateCategoryCollection collection that contains the subcategories of this category. The collection is empty if the category does not contain subcategories.

Remarks

A category can represent a company, product family, or product. The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. To determine the category's type, use IUpdateCategory.Type. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetSummaryPerUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateCategory.GetSummaryPerUpdate () | Get the summary information for drivers and software updates in this category and all subcategories for all computers. Only updates with at least one approval are included.
IUpdateCategory.GetSummaryPerUpdate (UpdateTypes) | Get the summary information for updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetSummaryPerUpdate Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for drivers and software updates in this category and all subcategories for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetSummaryPerUpdate()

Syntax

Visual Basic
Function GetSummaryPerUpdate() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate();
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate();
J#
public UpdateSummaryCollection GetSummaryPerUpdate();
JScript
function GetSummaryPerUpdate() : UpdateSummaryCollection;

Return Value

A collection containing one entry for each update, each with counts summed across all ComputerTargets.

Remarks

This is equivalent to GetSummaryPerUpdate(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetSummaryPerUpdate Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetSummaryPerUpdate(updateTypes)

Syntax

Visual Basic
Function GetSummaryPerUpdate( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
JScript
function GetSummaryPerUpdate(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each update, each with counts summed across all ComputerTargets.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummary Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateCategory.GetTotalSummary () | Get one summary summed across all drivers and software updates in this category and all subcategories for all computers.
IUpdateCategory.GetTotalSummary (UpdateTypes) | Get one summary summed across updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummary Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary summed across all drivers and software updates in this category and all subcategories for all computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateSummary
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetTotalSummary()

Syntax

Visual Basic
Function GetTotalSummary() As IUpdateSummary
C#
IUpdateSummary GetTotalSummary();
C++
public:
virtual IUpdateSummary^ GetTotalSummary();
J#
public IUpdateSummary GetTotalSummary();
JScript
function GetTotalSummary() : IUpdateSummary;

Return Value

One summary with counts summed across all drivers and software updates in this category and all subcategories for all computers. Only updates with at least one approval are included.

Remarks

This is equivalent to GetTotalSummary(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummary Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary summed across updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As IUpdateSummary
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetTotalSummary(updateTypes)

Syntax

Visual Basic
Function GetTotalSummary( _
    ByVal updateTypes As UpdateTypes _
) As IUpdateSummary
C#
IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
C++
public:
virtual IUpdateSummary^ GetTotalSummary(
    UpdateTypes updateTypes
);
J#
public IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummary(
     updateTypes : UpdateTypes
) : IUpdateSummary;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

One summary with counts summed across updates of the specified type in this category and all subcategories for all computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummaryPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateCategory.GetTotalSummaryPerComputerTarget () | Get the summary information for drivers and software updates in this category and all subcategories for all computers. Only updates with at least one approval are included.
IUpdateCategory.GetTotalSummaryPerComputerTarget (UpdateTypes) | Get the summary information for updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummaryPerComputerTarget Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for drivers and software updates in this category and all subcategories for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetTotalSummaryPerComputerTarget()

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget();
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
JScript
function GetTotalSummaryPerComputerTarget() : UpdateSummaryCollection;

Return Value

A collection containing one entry for each ComputerTarget, each with counts summed across all included updates.

Remarks

This is equivalent to GetTotalSummaryPerComputerTarget(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetTotalSummaryPerComputerTarget Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type in this category and all subcategories for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetTotalSummaryPerComputerTarget(updateTypes)

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummaryPerComputerTarget(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each ComputerTarget, each with counts summed across all included updates.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetUpdates Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateCategory.GetUpdates () | Retrieves a list of updates that belong to this category and its descendent categories.
IUpdateCategory.GetUpdates (ApprovedStates) | Retrieves a list of updates that belong to this category and its descendent categories.
IUpdateCategory.GetUpdates (ApprovedStates, UpdateTypes) | Get the list of updates of the specified approved states and update types in this category and all its subcategories.

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetUpdates Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of updates that belong to this category and its descendent categories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetUpdates()

Syntax

Visual Basic
Function GetUpdates() As UpdateCollection
C#
UpdateCollection GetUpdates();
C++
public:
virtual UpdateCollection^ GetUpdates();
J#
public UpdateCollection GetUpdates();
JScript
function GetUpdates() : UpdateCollection;

Return Value

An UpdateCollection collection of that contains updates for that belong to this category and its descendent categories.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetUpdates Method (ApprovedStates)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of updates that belong to this category and its descendent categories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim returnValue As UpdateCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetUpdates(approvedStates)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates
) : UpdateCollection;

Parameters

approvedStates

Limits the collection to updates with the specified approved state, for example, updates that are approved or updates that are declined. For a list of possible values, see ApprovedStates.

Return Value

An UpdateCollection collection of that contains updates that belong to this category and its descendent categories.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.GetUpdates Method (ApprovedStates, UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the list of updates of the specified approved states and update types in this category and all its subcategories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateCollection
Dim iUpdateCategory1 As IUpdateCategory
returnValue = iUpdateCategory1.GetUpdates(approvedStates, updateTypes)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates, _
    ByVal updateTypes As UpdateTypes _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates,
     updateTypes : UpdateTypes
) : UpdateCollection;

Parameters

approvedStates

Retrieve only updates with the specified approved states.

updateTypes

The types of updates to get. Can be any combination of values from UpdateTypes.

Return Value

Collection of all updates with the specified approved states and update types in this category and all its subcategories, recursively. The UpdateCollection is a flat list of the combined contents of all subcategories.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ArrivalDate | Retrieves the date and time the category was added.
public property | Description | Retrieves the description of the category.
public property | DisplayOrder | Retrieves the order in which the category is displayed relative to its siblings.
public property | Id | Retrieves the unique identifier of the category.
public property | ProhibitsSubcategories | Retrieves a value that indicates if the category allows subcategories.
public property | ProhibitsUpdates | Retrieves a value that indicates if the category allows child updates.
public property | ReleaseNotes | Retrieves the release notes for the category.
public property | Title | Retrieves the title of the category.
public property | Type | Retrieves the type of the category.

See Also

Reference

IUpdateCategory Interface


IUpdateCategory.ArrivalDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date and time the category was added.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As DateTime
returnValue = iUpdateCategory1.ArrivalDate

Syntax

Visual Basic
ReadOnly Property ArrivalDate() As DateTime
C#
DateTime ArrivalDate {get;}
C++
property virtual DateTime^ ArrivalDate {
    DateTime^ get();
}
J#
public DateTime get_ArrivalDate();
JScript
function get ArrivalDate() : DateTime;

Property Value

Date and time the category was added. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the description of the category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As String
returnValue = iUpdateCategory1.Description

Syntax

Visual Basic
ReadOnly Property Description() As String
C#
string Description {get;}
C++
property virtual String^ Description {
    String^ get();
}
J#
public System.String get_Description();
JScript
function get Description() : String;

Property Value

Description of the category. The property returns the description using the preferred culture if the localized text is available; otherwise, the description is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.DisplayOrder Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the order in which the category is displayed relative to its siblings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As Integer
returnValue = iUpdateCategory1.DisplayOrder

Syntax

Visual Basic
ReadOnly Property DisplayOrder() As Integer
C#
int DisplayOrder {get;}
C++
property virtual int DisplayOrder {
    int get();
}
J#
public int get_DisplayOrder();
JScript
function get DisplayOrder() : int;

Property Value

Order from lower to higher in which the category is displayed relative to its siblings. The value is Int32.MaxValue if no order is specified (add the category to the end of the list). Siblings can specify the same display order.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As Guid
returnValue = iUpdateCategory1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the category.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.ProhibitsSubcategories Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the category allows subcategories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As Boolean
returnValue = iUpdateCategory1.ProhibitsSubcategories

Syntax

Visual Basic
ReadOnly Property ProhibitsSubcategories() As Boolean
C#
bool ProhibitsSubcategories {get;}
C++
property virtual bool ProhibitsSubcategories {
    bool get();
}
J#
public boolean get_ProhibitsSubcategories();
JScript
function get ProhibitsSubcategories() : Boolean;

Property Value

True if the category does not allow subcategories; otherwise, false.

Remarks

If the value of IUpdateCategory.Type is UpdateCategoryType.Product, ProhibitsSubcategories is true.

If true, IUpdateCategory.GetSubcategories will be empty.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.ProhibitsUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the category allows child updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As Boolean
returnValue = iUpdateCategory1.ProhibitsUpdates

Syntax

Visual Basic
ReadOnly Property ProhibitsUpdates() As Boolean
C#
bool ProhibitsUpdates {get;}
C++
property virtual bool ProhibitsUpdates {
    bool get();
}
J#
public boolean get_ProhibitsUpdates();
JScript
function get ProhibitsUpdates() : Boolean;

Property Value

True if the category does not allow child updates; otherwise, false.

Remarks

If the value of IUpdateCategory.Type is UpdateCategoryType.ProductFamily or UpdateCategoryType.Company, ProhibitsUpdatesis true.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.ReleaseNotes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the release notes for the category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As String
returnValue = iUpdateCategory1.ReleaseNotes

Syntax

Visual Basic
ReadOnly Property ReleaseNotes() As String
C#
string ReleaseNotes {get;}
C++
property virtual String^ ReleaseNotes {
    String^ get();
}
J#
public System.String get_ReleaseNotes();
JScript
function get ReleaseNotes() : String;

Property Value

Release notes for the category. The property returns the release notes using the preferred culture if the localized text is available; otherwise, the release notes are in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.Title Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the title of the category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As String
returnValue = iUpdateCategory1.Title

Syntax

Visual Basic
ReadOnly Property Title() As String
C#
string Title {get;}
C++
property virtual String^ Title {
    String^ get();
}
J#
public System.String get_Title();
JScript
function get Title() : String;

Property Value

Title of the category. The property returns the title using the preferred culture if the localized text is available; otherwise, the title is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateCategory.Type Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the type of the category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateCategory1 As IUpdateCategory

Dim returnValue As UpdateCategoryType
returnValue = iUpdateCategory1.Type

Syntax

Visual Basic
ReadOnly Property Type() As UpdateCategoryType
C#
UpdateCategoryType Type {get;}
C++
property virtual UpdateCategoryType Type {
    UpdateCategoryType get();
}
J#
public UpdateCategoryType get_Type();
JScript
function get Type() : UpdateCategoryType;

Property Value

Type of the category. For example, indicates if this category is a product family category or product category. For possible values, see UpdateCategoryType.

Remarks

A category can represent a company, product family, or product. The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateCategory Interface
IUpdateCategory Members


IUpdateClassification Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information and updates related to the classification. To retrieve this interface, call the following methods: GetUpdateClassifications(); IUpdateServer.GetUpdateClassification(); UpdateClassificationCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateClassificationImplementation
    Implements IUpdateClassification
End Class
Dim updateClassificationImplementation1 As New updateClassificationImplementation()

Syntax

Visual Basic
Public Interface IUpdateClassification
C#
public interface IUpdateClassification
C++
public interface class IUpdateClassification
J#
public interface IUpdateClassification
JScript
public interface IUpdateClassification

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Members


IUpdateClassification Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information and updates related to the classification. To retrieve this interface, call the following methods: GetUpdateClassifications(); IUpdateServer.GetUpdateClassification(); UpdateClassificationCollection.Item.

The following tables list the members exposed by the IUpdateClassification type.

Public Properties

 | Name | Description
public property | ArrivalDate | Retrieves the date and time when the classification was added.
public property | Description | Retrieves the description of the classification.
public property | Id | Retrieves the unique identifier of the classification.
public property | ReleaseNotes | Retrieves the release notes for the classification.
public property | Title | Retrieves the title of the classification.
Top

Public Methods

 | Name | Description
public method | GetHashCode | Get a hash function for the current UpdateClassification, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdates | Overloaded.
Top

See Also

Reference

IUpdateClassification Interface


IUpdateClassification Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetHashCode | Get a hash function for the current UpdateClassification, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetSummaryPerUpdate | Overloaded.
public method | GetTotalSummary | Overloaded.
public method | GetTotalSummaryPerComputerTarget | Overloaded.
public method | GetUpdates | Overloaded.

See Also

Reference

IUpdateClassification Interface


IUpdateClassification.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a hash function for the current UpdateClassification, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current UpdateClassification.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetSummaryPerUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateClassification.GetSummaryPerUpdate () | Get the summary information for drivers and software updates in this classification for all computers. Only updates with at least one approval are included.
IUpdateClassification.GetSummaryPerUpdate (UpdateTypes) | Get the summary information for updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetSummaryPerUpdate Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for drivers and software updates in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetSummaryPerUpdate()

Syntax

Visual Basic
Function GetSummaryPerUpdate() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate();
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate();
J#
public UpdateSummaryCollection GetSummaryPerUpdate();
JScript
function GetSummaryPerUpdate() : UpdateSummaryCollection;

Return Value

A collection containing one entry for each update, each with counts summed across all ComputerTargets.

Remarks

This is equivalent to GetSummaryPerUpdate(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetSummaryPerUpdate Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetSummaryPerUpdate(updateTypes)

Syntax

Visual Basic
Function GetSummaryPerUpdate( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetSummaryPerUpdate(
    UpdateTypes updateTypes
);
JScript
function GetSummaryPerUpdate(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each update, each with counts summed across all ComputerTargets.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummary Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateClassification.GetTotalSummary () | Get one summary summed across all drivers and software updates in this classification for all computers. Only updates with at least one approval are included.
IUpdateClassification.GetTotalSummary (UpdateTypes) | Get one summary summed across updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummary Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary summed across all drivers and software updates in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateSummary
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetTotalSummary()

Syntax

Visual Basic
Function GetTotalSummary() As IUpdateSummary
C#
IUpdateSummary GetTotalSummary();
C++
public:
virtual IUpdateSummary^ GetTotalSummary();
J#
public IUpdateSummary GetTotalSummary();
JScript
function GetTotalSummary() : IUpdateSummary;

Return Value

One summary with counts summed across all drivers and software updates in this classification for all computers.

Remarks

This is equivalent to GetTotalSummary(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummary Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get one summary summed across updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As IUpdateSummary
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetTotalSummary(updateTypes)

Syntax

Visual Basic
Function GetTotalSummary( _
    ByVal updateTypes As UpdateTypes _
) As IUpdateSummary
C#
IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
C++
public:
virtual IUpdateSummary^ GetTotalSummary(
    UpdateTypes updateTypes
);
J#
public IUpdateSummary GetTotalSummary(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummary(
     updateTypes : UpdateTypes
) : IUpdateSummary;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

One summary with counts summed across updates of the specified type in this classification for all computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummaryPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateClassification.GetTotalSummaryPerComputerTarget () | Get the summary information for drivers and software updates in this classification for all computers. Only updates with at least one approval are included.
IUpdateClassification.GetTotalSummaryPerComputerTarget (UpdateTypes) | Gets the summary information for updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummaryPerComputerTarget Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the summary information for drivers and software updates in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateSummaryCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetTotalSummaryPerComputerTarget()

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget() As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget();
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget();
JScript
function GetTotalSummaryPerComputerTarget() : UpdateSummaryCollection;

Return Value

A collection containing one entry for each ComputerTarget, each with counts summed across all included updates.

Remarks

This is equivalent to GetTotalSummaryPerComputerTarget(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate). This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetTotalSummaryPerComputerTarget Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the summary information for updates of the specified type in this classification for all computers. Only updates with at least one approval are included.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateSummaryCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetTotalSummaryPerComputerTarget(updateTypes)

Syntax

Visual Basic
Function GetTotalSummaryPerComputerTarget( _
    ByVal updateTypes As UpdateTypes _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateSummaryCollection^ GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
J#
public UpdateSummaryCollection GetTotalSummaryPerComputerTarget(
    UpdateTypes updateTypes
);
JScript
function GetTotalSummaryPerComputerTarget(
     updateTypes : UpdateTypes
) : UpdateSummaryCollection;

Parameters

updateTypes

The types of updates to get information for. Can be any combination of values from UpdateTypes.

Return Value

A collection containing one entry for each ComputerTarget, each with counts summed across all included updates.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetUpdates Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateClassification.GetUpdates () | Retrieves a list of updates that belong to this classification.
IUpdateClassification.GetUpdates (ApprovedStates) | Retrieves a list of updates that belong to this classification.
IUpdateClassification.GetUpdates (ApprovedStates, UpdateTypes) | Gets the list of updates of the specified approved states and update types in this classification.

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetUpdates Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of updates that belong to this classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetUpdates()

Syntax

Visual Basic
Function GetUpdates() As UpdateCollection
C#
UpdateCollection GetUpdates();
C++
public:
virtual UpdateCollection^ GetUpdates();
J#
public UpdateCollection GetUpdates();
JScript
function GetUpdates() : UpdateCollection;

Return Value

An UpdateCollection collection of updates that belong to this classification.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetUpdates Method (ApprovedStates)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of updates that belong to this classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim returnValue As UpdateCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetUpdates(approvedStates)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates
) : UpdateCollection;

Parameters

approvedStates

Limits the collection to updates with the specified approved state, for example, updates that are approved or updates that are declined. For a list of possible values, see ApprovedStates.

Return Value

An UpdateCollection collection of updates that belong to this classification.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.GetUpdates Method (ApprovedStates, UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the list of updates of the specified approved states and update types in this classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateCollection
Dim iUpdateClassification1 As IUpdateClassification
returnValue = iUpdateClassification1.GetUpdates(approvedStates, updateTypes)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates, _
    ByVal updateTypes As UpdateTypes _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    UpdateTypes updateTypes
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates,
     updateTypes : UpdateTypes
) : UpdateCollection;

Parameters

approvedStates

Retrieve only updates with the specified approved states.

updateTypes

The types of updates to get. Can be any combination of values from UpdateTypes.

Return Value

Collection of all updates with the specified approved states and update types in this classification.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ArrivalDate | Retrieves the date and time when the classification was added.
public property | Description | Retrieves the description of the classification.
public property | Id | Retrieves the unique identifier of the classification.
public property | ReleaseNotes | Retrieves the release notes for the classification.
public property | Title | Retrieves the title of the classification.

See Also

Reference

IUpdateClassification Interface


IUpdateClassification.ArrivalDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date and time when the classification was added.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateClassification1 As IUpdateClassification

Dim returnValue As DateTime
returnValue = iUpdateClassification1.ArrivalDate

Syntax

Visual Basic
ReadOnly Property ArrivalDate() As DateTime
C#
DateTime ArrivalDate {get;}
C++
property virtual DateTime^ ArrivalDate {
    DateTime^ get();
}
J#
public DateTime get_ArrivalDate();
JScript
function get ArrivalDate() : DateTime;

Property Value

Date and time when the classification was added.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the description of the classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateClassification1 As IUpdateClassification

Dim returnValue As String
returnValue = iUpdateClassification1.Description

Syntax

Visual Basic
ReadOnly Property Description() As String
C#
string Description {get;}
C++
property virtual String^ Description {
    String^ get();
}
J#
public System.String get_Description();
JScript
function get Description() : String;

Property Value

Description of the classification. The property returns the description using the preferred culture if the localized text is available; otherwise, the description is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateClassification1 As IUpdateClassification

Dim returnValue As Guid
returnValue = iUpdateClassification1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the classification.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.ReleaseNotes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the release notes for the classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateClassification1 As IUpdateClassification

Dim returnValue As String
returnValue = iUpdateClassification1.ReleaseNotes

Syntax

Visual Basic
ReadOnly Property ReleaseNotes() As String
C#
string ReleaseNotes {get;}
C++
property virtual String^ ReleaseNotes {
    String^ get();
}
J#
public System.String get_ReleaseNotes();
JScript
function get ReleaseNotes() : String;

Property Value

Release notes for the classification. The property returns the release notes using the preferred culture if the localized text is available; otherwise, the release notes are in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateClassification.Title Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the title of the classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateClassification1 As IUpdateClassification

Dim returnValue As String
returnValue = iUpdateClassification1.Title

Syntax

Visual Basic
ReadOnly Property Title() As String
C#
string Title {get;}
C++
property virtual String^ Title {
    String^ get();
}
J#
public System.String get_Title();
JScript
function get Title() : String;

Property Value

Title of the classification. The property returns the title using the preferred culture if the localized text is available; otherwise, the title is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateClassification Interface
IUpdateClassification Members


IUpdateEvent Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about events that are associated with updates. To retrieve this interface, call UpdateEventCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateEventImplementation
    Implements IUpdateEvent
End Class
Dim updateEventImplementation1 As New updateEventImplementation()

Syntax

Visual Basic
Public Interface IUpdateEvent
C#
public interface IUpdateEvent
C++
public interface class IUpdateEvent
J#
public interface IUpdateEvent
JScript
public interface IUpdateEvent

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Members


IUpdateEvent Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve information about events that are associated with updates. To retrieve this interface, call UpdateEventCollection.Item.

The following tables list the members exposed by the IUpdateEvent type.

Public Properties

 | Name | Description
public property | ComputerId | Get the ID of the computer associated with this event.
public property | CreationDate | Retrieves the date when the event was generated.
public property | ErrorCode | Retrieves the error code that is returned by the client when the client event represents a failure.
public property | HasAssociatedComputer | Retrieves a value that indicates if the event is associated with a client computer.
public property | HasAssociatedUpdate | Retrieves a value that indicates if the event is associated with an update.
public property | Id | Retrieves the unique identifier of the event.
public property | IsError | Retrieves a value that indicates if the event represents an error.
public property | Message | Retrieves the message text that is associated with the event.
public property | Status | Retrieves the installation status of the update at the time this event was recorded.
public property | UpdateId | Get the update revision ID of the update associated with this event.
public property | WsusEventId | Retrieves the type of event.
public property | WsusEventSource | Retrieves the source of the event.
Top

Public Methods

 | Name | Description
public method | GetComputer | Retrieves the client computer that is associated with this event.
public method | GetHashCode | Get as a hash code for the current UpdateEvent, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update that is associated with this event.
Top

See Also

Reference

IUpdateEvent Interface


IUpdateEvent Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetComputer | Retrieves the client computer that is associated with this event.
public method | GetHashCode | Get as a hash code for the current UpdateEvent, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update that is associated with this event.

See Also

Reference

IUpdateEvent Interface


IUpdateEvent.GetComputer Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the client computer that is associated with this event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTarget
Dim iUpdateEvent1 As IUpdateEvent
returnValue = iUpdateEvent1.GetComputer()

Syntax

Visual Basic
Function GetComputer() As IComputerTarget
C#
IComputerTarget GetComputer();
C++
public:
virtual IComputerTarget^ GetComputer();
J#
public IComputerTarget GetComputer();
JScript
function GetComputer() : IComputerTarget;

Return Value

An IComputerTarget that represents the client computer that is associated with this event.

Exceptions

Exception type | Condition
InvalidOperationException | The event is not associated with a client computer (IUpdateEvent.HasAssociatedComputer is false).
WsusObjectNotFoundException | The client computer is no longer registered with the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get as a hash code for the current UpdateEvent, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateEvent1 As IUpdateEvent
returnValue = iUpdateEvent1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current UpdateEvent.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.GetUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the update that is associated with this event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdate
Dim iUpdateEvent1 As IUpdateEvent
returnValue = iUpdateEvent1.GetUpdate()

Syntax

Visual Basic
Function GetUpdate() As IUpdate
C#
IUpdate GetUpdate();
C++
public:
virtual IUpdate^ GetUpdate();
J#
public IUpdate GetUpdate();
JScript
function GetUpdate() : IUpdate;

Return Value

An IUpdate that represents the update that is associated with this event.

Exceptions

Exception type | Condition
InvalidOperationException | The event is not associated with an update (IUpdateEvent.HasAssociatedUpdate is false).
WsusObjectNotFoundException | The update that is associated with this event cannot be found on the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ComputerId | Get the ID of the computer associated with this event.
public property | CreationDate | Retrieves the date when the event was generated.
public property | ErrorCode | Retrieves the error code that is returned by the client when the client event represents a failure.
public property | HasAssociatedComputer | Retrieves a value that indicates if the event is associated with a client computer.
public property | HasAssociatedUpdate | Retrieves a value that indicates if the event is associated with an update.
public property | Id | Retrieves the unique identifier of the event.
public property | IsError | Retrieves a value that indicates if the event represents an error.
public property | Message | Retrieves the message text that is associated with the event.
public property | Status | Retrieves the installation status of the update at the time this event was recorded.
public property | UpdateId | Get the update revision ID of the update associated with this event.
public property | WsusEventId | Retrieves the type of event.
public property | WsusEventSource | Retrieves the source of the event.

See Also

Reference

IUpdateEvent Interface


IUpdateEvent.ComputerId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the ID of the computer associated with this event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As String
returnValue = iUpdateEvent1.ComputerId

Syntax

Visual Basic
ReadOnly Property ComputerId() As String
C#
string ComputerId {get;}
C++
property virtual String^ ComputerId {
    String^ get();
}
J#
public System.String get_ComputerId();
JScript
function get ComputerId() : String;

Property Value

The ID of the computer associated with this event. Returns an empty string if there is no computer associated with this event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.CreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date when the event was generated.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As DateTime
returnValue = iUpdateEvent1.CreationDate

Syntax

Visual Basic
ReadOnly Property CreationDate() As DateTime
C#
DateTime CreationDate {get;}
C++
property virtual DateTime^ CreationDate {
    DateTime^ get();
}
J#
public DateTime get_CreationDate();
JScript
function get CreationDate() : DateTime;

Property Value

Date and time when the event was generated. The date is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.ErrorCode Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the error code that is returned by the client when the client event represents a failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As Integer
returnValue = iUpdateEvent1.ErrorCode

Syntax

Visual Basic
ReadOnly Property ErrorCode() As Integer
C#
int ErrorCode {get;}
C++
property virtual int ErrorCode {
    int get();
}
J#
public int get_ErrorCode();
JScript
function get ErrorCode() : int;

Property Value

Error code that is returned by the client when the client event represents a failure. The error code is an HRESULT value.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members
Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.IsError


IUpdateEvent.HasAssociatedComputer Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the event is associated with a client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As Boolean
returnValue = iUpdateEvent1.HasAssociatedComputer

Syntax

Visual Basic
ReadOnly Property HasAssociatedComputer() As Boolean
C#
bool HasAssociatedComputer {get;}
C++
property virtual bool HasAssociatedComputer {
    bool get();
}
J#
public boolean get_HasAssociatedComputer();
JScript
function get HasAssociatedComputer() : Boolean;

Property Value

True if the event is associated with a client computer; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members
Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.GetComputer


IUpdateEvent.HasAssociatedUpdate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the event is associated with an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As Boolean
returnValue = iUpdateEvent1.HasAssociatedUpdate

Syntax

Visual Basic
ReadOnly Property HasAssociatedUpdate() As Boolean
C#
bool HasAssociatedUpdate {get;}
C++
property virtual bool HasAssociatedUpdate {
    bool get();
}
J#
public boolean get_HasAssociatedUpdate();
JScript
function get HasAssociatedUpdate() : Boolean;

Property Value

True if the event is associated with an update; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members
Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.GetUpdate


IUpdateEvent.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As Guid
returnValue = iUpdateEvent1.Id

Syntax

Visual Basic
ReadOnly Property Id() As Guid
C#
Guid Id {get;}
C++
property virtual Guid^ Id {
    Guid^ get();
}
J#
public Guid get_Id();
JScript
function get Id() : Guid;

Property Value

Unique identifier of the event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.IsError Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the event represents an error.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As Boolean
returnValue = iUpdateEvent1.IsError

Syntax

Visual Basic
ReadOnly Property IsError() As Boolean
C#
bool IsError {get;}
C++
property virtual bool IsError {
    bool get();
}
J#
public boolean get_IsError();
JScript
function get IsError() : Boolean;

Property Value

True if the event represents an error; otherwise, false.

Remarks

To retrieve the error code that is associated with the error, call IUpdateEvent.ErrorCode.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.Message Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the message text that is associated with the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As String
returnValue = iUpdateEvent1.Message

Syntax

Visual Basic
ReadOnly Property Message() As String
C#
string Message {get;}
C++
property virtual String^ Message {
    String^ get();
}
J#
public System.String get_Message();
JScript
function get Message() : String;

Property Value

Message text that is associated with the event. The property returns the text using the preferred culture if the localized text is available; otherwise, the text is in English.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members
Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.WsusEventId


IUpdateEvent.Status Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the installation status of the update at the time this event was recorded.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As InstallationStatus
returnValue = iUpdateEvent1.Status

Syntax

Visual Basic
ReadOnly Property Status() As InstallationStatus
C#
InstallationStatus Status {get;}
C++
property virtual InstallationStatus Status {
    InstallationStatus get();
}
J#
public InstallationStatus get_Status();
JScript
function get Status() : InstallationStatus;

Property Value

Deployment status of the update at the time this event was recorded. For example, the update succeeded. For possible values, see InstallationStatus.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the update revision ID of the update associated with this event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As UpdateRevisionId
returnValue = iUpdateEvent1.UpdateId

Syntax

Visual Basic
ReadOnly Property UpdateId() As UpdateRevisionId
C#
UpdateRevisionId UpdateId {get;}
C++
property virtual UpdateRevisionId^ UpdateId {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_UpdateId();
JScript
function get UpdateId() : UpdateRevisionId;

Property Value

The update revision ID of the update associated with this event. Returns an UpdateRevisionID with UpdateId equal to Guid.Empty if there is no update associated with this event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateEvent.WsusEventId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the type of event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As WsusEventId
returnValue = iUpdateEvent1.WsusEventId

Syntax

Visual Basic
ReadOnly Property WsusEventId() As WsusEventId
C#
WsusEventId WsusEventId {get;}
C++
property virtual WsusEventId WsusEventId {
    WsusEventId get();
}
J#
public WsusEventId get_WsusEventId();
JScript
function get WsusEventId() : WsusEventId;

Property Value

Identifies the type of event. For possible values, see WsusEventId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members
Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.Message


IUpdateEvent.WsusEventSource Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the source of the event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateEvent1 As IUpdateEvent

Dim returnValue As WsusEventSource
returnValue = iUpdateEvent1.WsusEventSource

Syntax

Visual Basic
ReadOnly Property WsusEventSource() As WsusEventSource
C#
WsusEventSource WsusEventSource {get;}
C++
property virtual WsusEventSource WsusEventSource {
    WsusEventSource get();
}
J#
public WsusEventSource get_WsusEventSource();
JScript
function get WsusEventSource() : WsusEventSource;

Property Value

Source of the event. For example, indicates if the client or server generated the event. For possible values, see WsusEventSource.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateEvent Interface
IUpdateEvent Members


IUpdateInstallationInfo Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the state of the update installation on the client computer. To retrieve this interface, call UpdateInstallationInfoCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateInstallationInfoImplementation
    Implements IUpdateInstallationInfo
End Class
Dim updateInstallationInfoImplementation1 As New updateInstallationInfoImplementation()

Syntax

Visual Basic
Public Interface IUpdateInstallationInfo
C#
public interface IUpdateInstallationInfo
C++
public interface class IUpdateInstallationInfo
J#
public interface IUpdateInstallationInfo
JScript
public interface IUpdateInstallationInfo

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Members


IUpdateInstallationInfo Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve the state of the update installation on the client computer. To retrieve this interface, call UpdateInstallationInfoCollection.Item.

The following tables list the members exposed by the IUpdateInstallationInfo type.

Public Properties

 | Name | Description
public property | ComputerTargetId | Gets the ID of the computer that this UpdateInstallationInfo object describes.
public property | UpdateApprovalAction | Gets the effective approval action for this update on this computer.
public property | UpdateApprovalTargetGroupId | Gets the ID of the target group that the effective update approval belongs to.
public property | UpdateId | Gets the ID of the update that this UpdateInstallationInfo object describes.
public property | UpdateInstallationState | Retrieves the state of the update installation on the client computer.
Top

Public Methods

 | Name | Description
public method | GetComputerTarget | Retrieves the client computer that is associated with the installation information.
public method | GetHashCode | Serves as a hash function for the current UpdateInstallationInfo, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update that is associated with the installation information.
public method | GetUpdateApprovalTargetGroup | Gets the ComputerTargetGroup that the effective approval comes from.
Top

See Also

Reference

IUpdateInstallationInfo Interface


IUpdateInstallationInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetComputerTarget | Retrieves the client computer that is associated with the installation information.
public method | GetHashCode | Serves as a hash function for the current UpdateInstallationInfo, suitable for use in hashing algorithms and data structures, such as a hash table.
public method | GetUpdate | Retrieves the update that is associated with the installation information.
public method | GetUpdateApprovalTargetGroup | Gets the ComputerTargetGroup that the effective approval comes from.

See Also

Reference

IUpdateInstallationInfo Interface


IUpdateInstallationInfo.GetComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the client computer that is associated with the installation information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTarget
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo
returnValue = iUpdateInstallationInfo1.GetComputerTarget()

Syntax

Visual Basic
Function GetComputerTarget() As IComputerTarget
C#
IComputerTarget GetComputerTarget();
C++
public:
virtual IComputerTarget^ GetComputerTarget();
J#
public IComputerTarget GetComputerTarget();
JScript
function GetComputerTarget() : IComputerTarget;

Return Value

An IComputerTarget that represents the client computer that is associated with the installation information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for the current UpdateInstallationInfo, suitable for use in hashing algorithms and data structures, such as a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo
returnValue = iUpdateInstallationInfo1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Return Value

A hash code for the current UpdateInstallationInfo.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.GetUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the update that is associated with the installation information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdate
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo
returnValue = iUpdateInstallationInfo1.GetUpdate()

Syntax

Visual Basic
Function GetUpdate() As IUpdate
C#
IUpdate GetUpdate();
C++
public:
virtual IUpdate^ GetUpdate();
J#
public IUpdate GetUpdate();
JScript
function GetUpdate() : IUpdate;

Return Value

An IUpdate that represents the update that is associated with the installation information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.GetUpdateApprovalTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the ComputerTargetGroup that the effective approval comes from.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IComputerTargetGroup
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo
returnValue = iUpdateInstallationInfo1.GetUpdateApprovalTargetGroup()

Syntax

Visual Basic
Function GetUpdateApprovalTargetGroup() As IComputerTargetGroup
C#
IComputerTargetGroup GetUpdateApprovalTargetGroup();
C++
public:
virtual IComputerTargetGroup^ GetUpdateApprovalTargetGroup();
J#
public IComputerTargetGroup GetUpdateApprovalTargetGroup();
JScript
function GetUpdateApprovalTargetGroup() : IComputerTargetGroup;

Return Value

The ComputerTargetGroup that the effective approval comes from.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The computer target group could not be found in the database.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ComputerTargetId | Gets the ID of the computer that this UpdateInstallationInfo object describes.
public property | UpdateApprovalAction | Gets the effective approval action for this update on this computer.
public property | UpdateApprovalTargetGroupId | Gets the ID of the target group that the effective update approval belongs to.
public property | UpdateId | Gets the ID of the update that this UpdateInstallationInfo object describes.
public property | UpdateInstallationState | Retrieves the state of the update installation on the client computer.

See Also

Reference

IUpdateInstallationInfo Interface


IUpdateInstallationInfo.ComputerTargetId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the ID of the computer that this UpdateInstallationInfo object describes.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo

Dim returnValue As String
returnValue = iUpdateInstallationInfo1.ComputerTargetId

Syntax

Visual Basic
ReadOnly Property ComputerTargetId() As String
C#
string ComputerTargetId {get;}
C++
property virtual String^ ComputerTargetId {
    String^ get();
}
J#
public System.String get_ComputerTargetId();
JScript
function get ComputerTargetId() : String;

Property Value

The ID of the computer that this UpdateInstallationInfo object describes.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.UpdateApprovalAction Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the effective approval action for this update on this computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo

Dim returnValue As UpdateApprovalAction
returnValue = iUpdateInstallationInfo1.UpdateApprovalAction

Syntax

Visual Basic
ReadOnly Property UpdateApprovalAction() As UpdateApprovalAction
C#
UpdateApprovalAction UpdateApprovalAction {get;}
C++
property virtual UpdateApprovalAction UpdateApprovalAction {
    UpdateApprovalAction get();
}
J#
public UpdateApprovalAction get_UpdateApprovalAction();
JScript
function get UpdateApprovalAction() : UpdateApprovalAction;

Property Value

The effective approval action for this update on this computer.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.UpdateApprovalTargetGroupId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the ID of the target group that the effective update approval belongs to.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo

Dim returnValue As Guid
returnValue = iUpdateInstallationInfo1.UpdateApprovalTargetGroupId

Syntax

Visual Basic
ReadOnly Property UpdateApprovalTargetGroupId() As Guid
C#
Guid UpdateApprovalTargetGroupId {get;}
C++
property virtual Guid^ UpdateApprovalTargetGroupId {
    Guid^ get();
}
J#
public Guid get_UpdateApprovalTargetGroupId();
JScript
function get UpdateApprovalTargetGroupId() : Guid;

Property Value

The ID of the target group that the effective update approval belongs to.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the ID of the update that this UpdateInstallationInfo object describes.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo

Dim returnValue As Guid
returnValue = iUpdateInstallationInfo1.UpdateId

Syntax

Visual Basic
ReadOnly Property UpdateId() As Guid
C#
Guid UpdateId {get;}
C++
property virtual Guid^ UpdateId {
    Guid^ get();
}
J#
public Guid get_UpdateId();
JScript
function get UpdateId() : Guid;

Property Value

The ID of the update that this UpdateInstallationInfo object describes.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateInstallationInfo.UpdateInstallationState Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the state of the update installation on the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateInstallationInfo1 As IUpdateInstallationInfo

Dim returnValue As UpdateInstallationState
returnValue = iUpdateInstallationInfo1.UpdateInstallationState

Syntax

Visual Basic
ReadOnly Property UpdateInstallationState() As UpdateInstallationState
C#
UpdateInstallationState UpdateInstallationState {get;}
C++
property virtual UpdateInstallationState UpdateInstallationState {
    UpdateInstallationState get();
}
J#
public UpdateInstallationState get_UpdateInstallationState();
JScript
function get UpdateInstallationState() : UpdateInstallationState;

Property Value

State of the installation on the client computer. For example, if the installation is installed or has failed to install. For possible values, see UpdateInstallationState.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateInstallationInfo Interface
IUpdateInstallationInfo Members


IUpdateServer Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to access WSUS components. To retrieve this interface, call AdminProxy.GetUpdateServer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateServerImplementation
    Implements IUpdateServer
End Class
Dim updateServerImplementation1 As New updateServerImplementation()

Syntax

Visual Basic
Public Interface IUpdateServer
C#
public interface IUpdateServer
C++
public interface class IUpdateServer
J#
public interface IUpdateServer
JScript
public interface IUpdateServer

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Members


IUpdateServer Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to access WSUS components. To retrieve this interface, call AdminProxy.GetUpdateServer.

The following tables list the members exposed by the IUpdateServer type.

Public Properties

 | Name | Description
public property | IsConnectionSecureForApiRemoting | Get a value indicating whether a secure connection to the update server is being used for API Remoting.
public property | Name | Gets the name of the server.
public property | PortNumber | Get the port number of the API Remoting web service on the update server.
public property | PreferredCulture | Retrieves or sets the language code that you want the WSUS server to use when returning strings.
public property | Version | Get the version of the update server.
Top

Public Methods

 | Name | Description
public method | CancelAllDownloads | Cancels updates that are currently being downloaded to the WSUS server.
public method | CreateComputerTargetGroup | Overloaded.
public method | CreateInstallApprovalRule | Create a new empty Install Automatic Approval Rule
public method | DeleteInstallApprovalRule | Deletes an Install Automatic Approval Rule from the database.
public method | DeleteUpdate | Delete an update specified by the UpdateID.
public method | GetApprovedUpdateMetadata | Return meta-data for all updates/detectoids/subcategories/installable items (latest revision only) under the specified category and classification that have approvals; if the classification collection is empty or null, return everything under the given category collection.
public method | GetChildServers | Get all downstream servers that sync directly from this server.
public method | GetCleanupManager | Get an instance of the ICleanupManager interface for performing cleanup tasks to the server.
public method | GetComponentsWithErrors | Retrieves a list of server components that are currently in an error state.
public method | GetComputersNotContactedSinceCount | Number of clients that have not reported their status to the WSUS server since the specified time.
public method | GetComputersWithRecentNameChange | Gets the list of client computers that have changed their names more than once in the past 24 hours.
public method | GetComputerTarget | Retrieves the specified client computer.
public method | GetComputerTargetByName | Get the ComputerTarget with the specified name.
public method | GetComputerTargetCount | Overloaded.
public method | GetComputerTargetGroup | Retrieves the specified target group.
public method | GetComputerTargetGroups | Retrieves a collection of all the target groups on the WSUS server.
public method | GetComputerTargets | Overloaded.
public method | GetConfiguration | Retrieves an IUpdateServerConfiguration that you use to configure the WSUS server.
public method | GetContentDownloadProgress | Retrieves the progress of all updates that are currently downloading.
public method | GetCurrentUserRole | Gets the current user's role on the WSUS server.
public method | GetDatabaseConfiguration | Retrieves an IDatabaseConfiguration that you use to configure the database connection.
public method | GetDownstreamServer | Get the DownstreamServer corresponding to the supplied Id.
public method | GetDownstreamServers | Retrieves a collection of downstream WSUS servers that are registered with this WSUS server.
public method | GetEmailNotificationConfiguration | Gets the email notification configuration interface
public method | GetFrontEndServers | Gets the list of all front-end servers
public method | GetInstallApprovalRules | Get a collection of IAutomaticUpdateApprovalRule rules from the database.
public method | GetPublisher | Gets an instance of the IPublisher interface for publishing a package to the server.
public method | GetReplicaStatus | Overloaded.
public method | GetRootUpdateCategories | Retrieves a collection of the top-level categories on the WSUS server.
public method | GetStatus | Overloaded.
public method | GetSubscription | Retrieves a subscription instance that you use to manage the synchronization process.
public method | GetSubscriptionEvent | Retrieves a subscription event that identifies changes to the subscription.
public method | GetSummariesPerComputerTarget | Get per-computer summaries for each of the specified computers, summed across all of the specified updates.
public method | GetSummariesPerUpdate | Get per-update summaries for each of the specified update, summed across all of the specified computers.
public method | GetSynchronizationInfo | Retrieves information that is related to a specific synchronization process.
public method | GetUpdate | Retrieves the specified update.
public method | GetUpdateApproval | Retrieves the specified approval.
public method | GetUpdateCategories | Overloaded.
public method | GetUpdateCategory | Retrieves the category of updates for the given identifier.
public method | GetUpdateClassification | Retrieves the requested update classification.
public method | GetUpdateClassifications | Overloaded.
public method | GetUpdateCount | Overloaded.
public method | GetUpdateEventHistory | Overloaded.
public method | GetUpdates | Overloaded.
public method | ImportUpdateFromCatalogSite | Imports an update and all of its prerequisites and bundle dependencies. If the update requires content files that are not available from MU, they are downloaded by the catalog site to a local path before calling this method. An update imported by this method will be flagged appropriately so that newer revisions can be sync'ed later even when the update does not match the categories/classifications filter of the synchronization settins.
public method | IsValidComputerTargetGroupName | Determines if the specified name is a valid computer target group name.
public method | LogMessage | Logs a message in the SoftwareDistribution Log file.
public method | RegisterComputer | Registers a client computer with the WSUS server.
public method | ResetAndVerifyContentState | Forces the synchronization of all update metadata on the WSUS server and verifies that all update files on the WSUS server are valid.
public method | ResumeAllDownloads | Identifies the updates to download.
public method | RollupReportingData | Rolls up reporting data to an upstream server.
public method | SearchComputerTargets | Retrieves a collection of target computers whose full domain name contains the given string.
public method | SearchUpdates | Overloaded.
Top

See Also

Reference

IUpdateServer Interface


IUpdateServer Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | CancelAllDownloads | Cancels updates that are currently being downloaded to the WSUS server.
public method | CreateComputerTargetGroup | Overloaded.
public method | CreateInstallApprovalRule | Create a new empty Install Automatic Approval Rule
public method | DeleteInstallApprovalRule | Deletes an Install Automatic Approval Rule from the database.
public method | DeleteUpdate | Delete an update specified by the UpdateID.
public method | GetApprovedUpdateMetadata | Return meta-data for all updates/detectoids/subcategories/installable items (latest revision only) under the specified category and classification that have approvals; if the classification collection is empty or null, return everything under the given category collection.
public method | GetChildServers | Get all downstream servers that sync directly from this server.
public method | GetCleanupManager | Get an instance of the ICleanupManager interface for performing cleanup tasks to the server.
public method | GetComponentsWithErrors | Retrieves a list of server components that are currently in an error state.
public method | GetComputersNotContactedSinceCount | Number of clients that have not reported their status to the WSUS server since the specified time.
public method | GetComputersWithRecentNameChange | Gets the list of client computers that have changed their names more than once in the past 24 hours.
public method | GetComputerTarget | Retrieves the specified client computer.
public method | GetComputerTargetByName | Get the ComputerTarget with the specified name.
public method | GetComputerTargetCount | Overloaded.
public method | GetComputerTargetGroup | Retrieves the specified target group.
public method | GetComputerTargetGroups | Retrieves a collection of all the target groups on the WSUS server.
public method | GetComputerTargets | Overloaded.
public method | GetConfiguration | Retrieves an IUpdateServerConfiguration that you use to configure the WSUS server.
public method | GetContentDownloadProgress | Retrieves the progress of all updates that are currently downloading.
public method | GetCurrentUserRole | Gets the current user's role on the WSUS server.
public method | GetDatabaseConfiguration | Retrieves an IDatabaseConfiguration that you use to configure the database connection.
public method | GetDownstreamServer | Get the DownstreamServer corresponding to the supplied Id.
public method | GetDownstreamServers | Retrieves a collection of downstream WSUS servers that are registered with this WSUS server.
public method | GetEmailNotificationConfiguration | Gets the email notification configuration interface
public method | GetFrontEndServers | Gets the list of all front-end servers
public method | GetInstallApprovalRules | Get a collection of IAutomaticUpdateApprovalRule rules from the database.
public method | GetPublisher | Gets an instance of the IPublisher interface for publishing a package to the server.
public method | GetReplicaStatus | Overloaded.
public method | GetRootUpdateCategories | Retrieves a collection of the top-level categories on the WSUS server.
public method | GetStatus | Overloaded.
public method | GetSubscription | Retrieves a subscription instance that you use to manage the synchronization process.
public method | GetSubscriptionEvent | Retrieves a subscription event that identifies changes to the subscription.
public method | GetSummariesPerComputerTarget | Get per-computer summaries for each of the specified computers, summed across all of the specified updates.
public method | GetSummariesPerUpdate | Get per-update summaries for each of the specified update, summed across all of the specified computers.
public method | GetSynchronizationInfo | Retrieves information that is related to a specific synchronization process.
public method | GetUpdate | Retrieves the specified update.
public method | GetUpdateApproval | Retrieves the specified approval.
public method | GetUpdateCategories | Overloaded.
public method | GetUpdateCategory | Retrieves the category of updates for the given identifier.
public method | GetUpdateClassification | Retrieves the requested update classification.
public method | GetUpdateClassifications | Overloaded.
public method | GetUpdateCount | Overloaded.
public method | GetUpdateEventHistory | Overloaded.
public method | GetUpdates | Overloaded.
public method | ImportUpdateFromCatalogSite | Imports an update and all of its prerequisites and bundle dependencies. If the update requires content files that are not available from MU, they are downloaded by the catalog site to a local path before calling this method. An update imported by this method will be flagged appropriately so that newer revisions can be sync'ed later even when the update does not match the categories/classifications filter of the synchronization settins.
public method | IsValidComputerTargetGroupName | Determines if the specified name is a valid computer target group name.
public method | LogMessage | Logs a message in the SoftwareDistribution Log file.
public method | RegisterComputer | Registers a client computer with the WSUS server.
public method | ResetAndVerifyContentState | Forces the synchronization of all update metadata on the WSUS server and verifies that all update files on the WSUS server are valid.
public method | ResumeAllDownloads | Identifies the updates to download.
public method | RollupReportingData | Rolls up reporting data to an upstream server.
public method | SearchComputerTargets | Retrieves a collection of target computers whose full domain name contains the given string.
public method | SearchUpdates | Overloaded.

See Also

Reference

IUpdateServer Interface


IUpdateServer.CancelAllDownloads Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Cancels updates that are currently being downloaded to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.CancelAllDownloads()

Syntax

Visual Basic
Sub CancelAllDownloads()
C#
void CancelAllDownloads();
C++
public:
virtual void CancelAllDownloads();
J#
public void CancelAllDownloads();
JScript
function CancelAllDownloads() : Void;

Remarks

To restart canceled downloads, call IUpdateServer.ResumeAllDownloads. To restart individual update downloads, call IUpdate.ResumeDownload.

Note that an update can include a download job for each language that it supports. Those download jobs that are successfully completed before you called CancelAllDownloads are retained; the others are canceled.

To determine which updates are currently downloading, call IUpdate.State. The update is currently downloading if the state is UpdateState.NotReady.

If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, CancelAllDownloads cancels the downloading of the end-user license agreements.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members
Microsoft.UpdateServices.Administration Namespace
IUpdate.CancelDownload
IUpdateServer.ResumeAllDownloads


IUpdateServer.CreateComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.CreateComputerTargetGroup (String) | Creates a target group that you use to target client computers for updates.
IUpdateServer.CreateComputerTargetGroup (String, IComputerTargetGroup) | Create a new ComputerTargetGroup on the server as a child of the specified target group.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.CreateComputerTargetGroup Method (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Creates a target group that you use to target client computers for updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As IComputerTargetGroup
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.CreateComputerTargetGroup(name)

Syntax

Visual Basic
Function CreateComputerTargetGroup( _
    ByVal name As String _
) As IComputerTargetGroup
C#
IComputerTargetGroup CreateComputerTargetGroup(
    string name
);
C++
public:
virtual IComputerTargetGroup^ CreateComputerTargetGroup(
    String^ name
);
J#
public IComputerTargetGroup CreateComputerTargetGroup(
    System.String name
);
JScript
function CreateComputerTargetGroup(
     name : String
) : IComputerTargetGroup;

Parameters

name

Name of the target group to create. For example, Accounting or Manufacturing. The name must be unique, less than 256 characters, and cannot include the following characters: ~!@#$^&*()=+[]\{}|;:’”<>/.

Return Value

An IComputerTargetGroup whose methods and properties you use to manage the group, for example, to add clients to the group.

Exceptions

Exception type | Condition
WsusObjectAlreadyExistsException | The name already exists. The group name must be unique.
ArgumentNullException | The name cannot be null.
ArgumentOutOfRangeException | The name cannot be empty or the name is too long.
ArgumentException | The name contains characters that are not valid.
InvalidOperationException | Unable to return the newly created IComputerTargetGroup. For example, you cannot create a computer target group if the server is a replica WSUS server (if IUpdateServerConfiguration.IsReplicaServer is true).

Remarks

You use target groups to logically group and manage client computers on the server. By default, there are two groups, All Computers and Unassigned Computers. All clients belong to the All Computers group. A client can also belong to one other group.

If IUpdateServerConfiguration.TargetingMode is TargetingMode.Server, you can use IComputerTargetGroup.AddComputerTarget to add clients to the group. Otherwise, clients can add themselves to the group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.CreateComputerTargetGroup Method (String, IComputerTargetGroup)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a new ComputerTargetGroup on the server as a child of the specified target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim parentGroup As IComputerTargetGroup
Dim returnValue As IComputerTargetGroup
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.CreateComputerTargetGroup(name, parentGroup)

Syntax

Visual Basic
Function CreateComputerTargetGroup( _
    ByVal name As String, _
    ByVal parentGroup As IComputerTargetGroup _
) As IComputerTargetGroup
C#
IComputerTargetGroup CreateComputerTargetGroup(
    string name,
    IComputerTargetGroup parentGroup
);
C++
public:
virtual IComputerTargetGroup^ CreateComputerTargetGroup(
    String^ name,
    IComputerTargetGroup^ parentGroup
);
J#
public IComputerTargetGroup CreateComputerTargetGroup(
    System.String name,
    IComputerTargetGroup parentGroup
);
JScript
function CreateComputerTargetGroup(
     name : String,
     parentGroup : IComputerTargetGroup
) : IComputerTargetGroup;

Parameters

name

The name of the target group to create. This name must be a unique name on this server.

parentGroup

The target group to use as the parent of the new group. If null, the group will be created as a child of the All Computers target group.

Return Value

The newly created ComputerTargetGroup.

Exceptions

Exception type Condition
ArgumentNullException

name is a null reference.
ArgumentOutOfRangeException

name is an empty string or greater than 256 characters in length.
ArgumentException

name contains an invalid character.
WsusObjectAlreadyExistsException

A ComputerTargetGroup already exists with the requested name.
WsusObjectNotFoundException

The specified parent target group could not be found in the DB.
InvalidOperationException

This method is called when

  • the server is in replica mode

  • parentGroup refers to the Unassigned Computers target group

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.CreateInstallApprovalRule Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a new empty Install Automatic Approval Rule

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As IAutomaticUpdateApprovalRule
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.CreateInstallApprovalRule(name)

Syntax

Visual Basic
Function CreateInstallApprovalRule( _
    ByVal name As String _
) As IAutomaticUpdateApprovalRule
C#
IAutomaticUpdateApprovalRule CreateInstallApprovalRule(
    string name
);
C++
public:
virtual IAutomaticUpdateApprovalRule^ CreateInstallApprovalRule(
    String^ name
);
J#
public IAutomaticUpdateApprovalRule CreateInstallApprovalRule(
    System.String name
);
JScript
function CreateInstallApprovalRule(
     name : String
) : IAutomaticUpdateApprovalRule;

Parameters

name

Name for the AutomaticApprovalRule

Return Value

The new IAutomaticUpdateApprovalRule object that was created

Exceptions

Exception type | Condition
ArgumentNullException | name cannot be null. Use String.Empty instead.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.DeleteInstallApprovalRule Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Deletes an Install Automatic Approval Rule from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim ruleId As Integer
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.DeleteInstallApprovalRule(ruleId)

Syntax

Visual Basic
Sub DeleteInstallApprovalRule( _
    ByVal ruleId As Integer _
)
C#
void DeleteInstallApprovalRule(
    int ruleId
);
C++
public:
virtual void DeleteInstallApprovalRule(
    int ruleId
);
J#
public void DeleteInstallApprovalRule(
    int ruleId
);
JScript
function DeleteInstallApprovalRule(
     ruleId : int
) : Void;

Parameters

ruleId

The Automatic Approval Rule Id to delete

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.DeleteUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Delete an update specified by the UpdateID.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateID As Guid
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.DeleteUpdate(updateID)

Syntax

Visual Basic
Sub DeleteUpdate( _
    ByVal updateID As Guid _
)
C#
void DeleteUpdate(
    Guid updateID
);
C++
public:
virtual void DeleteUpdate(
    Guid^ updateID
);
J#
public void DeleteUpdate(
    Guid updateID
);
JScript
function DeleteUpdate(
     updateID : Guid
) : Void;

Parameters

updateID

The updateID in Guid format.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Cannot find the Update by the specified updateID.
InvalidOperationException | Cannot delete the Update retrieved by the specified updateID. The common cause of this exception is that this Update is still referenced by at least another Update in the database.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetApprovedUpdateMetadata Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Return meta-data for all updates/detectoids/subcategories/installable items (latest revision only) under the specified category and classification that have approvals; if the classification collection is empty or null, return everything under the given category collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim categories As UpdateCategoryCollection
Dim classifications As UpdateClassificationCollection
Dim returnValue As ReadOnlyCollection(Of UpdateMetadata)
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetApprovedUpdateMetadata(categories, classifications)

Syntax

Visual Basic
Function GetApprovedUpdateMetadata( _
    ByVal categories As UpdateCategoryCollection, _
    ByVal classifications As UpdateClassificationCollection _
) As ReadOnlyCollection(Of UpdateMetadata)
C#
ReadOnlyCollection<UpdateMetadata> GetApprovedUpdateMetadata(
    UpdateCategoryCollection categories,
    UpdateClassificationCollection classifications
);
C++
public:
virtual ReadOnlyCollection<UpdateMetadata^>^ GetApprovedUpdateMetadata(
    UpdateCategoryCollection^ categories,
    UpdateClassificationCollection^ classifications
);
J#
public ReadOnlyCollection<UpdateMetadata> GetApprovedUpdateMetadata(
    UpdateCategoryCollection categories,
    UpdateClassificationCollection classifications
);
JScript
function GetApprovedUpdateMetadata(
     categories : UpdateCategoryCollection,
     classifications : UpdateClassificationCollection
) : JScript does not support Generics.;

Parameters

categories

Collection of update categories to be used to filter the update collection with.

classifications

Collection of update classifications to be used to filter the update collection with.

Return Value

A collection of UpdateMetadata object, in the asending order of local update id.

Remarks

Categories and updateClassifications can both be null. Null categories and updateclassifications tells this API not to filter by categories or update classifications or both. This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetChildServers Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get all downstream servers that sync directly from this server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As DownstreamServerCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetChildServers()

Syntax

Visual Basic
Function GetChildServers() As DownstreamServerCollection
C#
DownstreamServerCollection GetChildServers();
C++
public:
virtual DownstreamServerCollection^ GetChildServers();
J#
public DownstreamServerCollection GetChildServers();
JScript
function GetChildServers() : DownstreamServerCollection;

Return Value

A collection containing all downstream servers that sync directly from this server.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetCleanupManager Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get an instance of the ICleanupManager interface for performing cleanup tasks to the server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ICleanupManager
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetCleanupManager()

Syntax

Visual Basic
Function GetCleanupManager() As ICleanupManager
C#
ICleanupManager GetCleanupManager();
C++
public:
virtual ICleanupManager^ GetCleanupManager();
J#
public ICleanupManager GetCleanupManager();
JScript
function GetCleanupManager() : ICleanupManager;

Return Value

ICleanupManager instance

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComponentsWithErrors Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a list of server components that are currently in an error state.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As StringCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComponentsWithErrors()

Syntax

Visual Basic
Function GetComponentsWithErrors() As StringCollection
C#
StringCollection GetComponentsWithErrors();
C++
public:
virtual StringCollection^ GetComponentsWithErrors();
J#
public StringCollection GetComponentsWithErrors();
JScript
function GetComponentsWithErrors() : StringCollection;

Return Value

List of server components that are currently in an error state, or an empty collection if everything is working as expected. For example, CatalogSyncAgent or ContentSyncAgent.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputersNotContactedSinceCount Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of clients that have not reported their status to the WSUS server since the specified time.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputersNotContactedSinceCount(fromDate)

Syntax

Visual Basic
Function GetComputersNotContactedSinceCount( _
    ByVal fromDate As DateTime _
) As Integer
C#
int GetComputersNotContactedSinceCount(
    DateTime fromDate
);
C++
public:
virtual int GetComputersNotContactedSinceCount(
    DateTime^ fromDate
);
J#
public int GetComputersNotContactedSinceCount(
    DateTime fromDate
);
JScript
function GetComputersNotContactedSinceCount(
     fromDate : DateTime
) : int;

Parameters

fromDate

Date and time of interest. Specify the date and time in Coordinated Universal Time.

Return Value

Number of clients that have not reported their status to the WSUS server since the time that is specified in fromDate.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputersWithRecentNameChange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the list of client computers that have changed their names more than once in the past 24 hours.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As StringCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputersWithRecentNameChange()

Syntax

Visual Basic
Function GetComputersWithRecentNameChange() As StringCollection
C#
StringCollection GetComputersWithRecentNameChange();
C++
public:
virtual StringCollection^ GetComputersWithRecentNameChange();
J#
public StringCollection GetComputersWithRecentNameChange();
JScript
function GetComputersWithRecentNameChange() : StringCollection;

Return Value

List of client computer names (fully qualified domain names, FQDNs)

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the specified client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As String
Dim returnValue As IComputerTarget
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTarget(id)

Syntax

Visual Basic
Function GetComputerTarget( _
    ByVal id As String _
) As IComputerTarget
C#
IComputerTarget GetComputerTarget(
    string id
);
C++
public:
virtual IComputerTarget^ GetComputerTarget(
    String^ id
);
J#
public IComputerTarget GetComputerTarget(
    System.String id
);
JScript
function GetComputerTarget(
     id : String
) : IComputerTarget;

Parameters

id

Unique identifier of the client that you want to retrieve. For details, see IComputerTarget.Id.

Return Value

An IComputerTarget that represents the specified client computer. Use the interface to retrieve client metadata, for example, its IP address or domain name.

Exceptions

Exception type | Condition
ArgumentNullException | id cannot be null.
WsusObjectNotFoundException | WSUS could not find the client computer with the given identifier.

Remarks

Note that the metadata may not exist if the client has not yet contacted the WSUS server.

To retrieve a computer target using a full domain name, call IUpdateServer.SearchComputerTargets(String).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetByName Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the ComputerTarget with the specified name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As IComputerTarget
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargetByName(name)

Syntax

Visual Basic
Function GetComputerTargetByName( _
    ByVal name As String _
) As IComputerTarget
C#
IComputerTarget GetComputerTargetByName(
    string name
);
C++
public:
virtual IComputerTarget^ GetComputerTargetByName(
    String^ name
);
J#
public IComputerTarget GetComputerTargetByName(
    System.String name
);
JScript
function GetComputerTargetByName(
     name : String
) : IComputerTarget;

Parameters

name

FullDomainName of the ComputerTarget to get

Return Value

The ComputerTarget with the specified name

Exceptions

Exception type | Condition
WsusObjectNotFoundException | A ComputerTarget with the specified name could not be found.
ArgumentNullException | id is a null reference.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetCount Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetComputerTargetCount () | Gets the count of computers.
IUpdateServer.GetComputerTargetCount (ComputerTargetScope) | Gets the count of computers that match the specified search criteria.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetCount Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the count of computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargetCount()

Syntax

Visual Basic
Function GetComputerTargetCount() As Integer
C#
int GetComputerTargetCount();
C++
public:
virtual int GetComputerTargetCount();
J#
public int GetComputerTargetCount();
JScript
function GetComputerTargetCount() : int;

Return Value

The count of computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetCount Method (ComputerTargetScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the count of computers that match the specified search criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchScope As ComputerTargetScope
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargetCount(searchScope)

Syntax

Visual Basic
Function GetComputerTargetCount( _
    ByVal searchScope As ComputerTargetScope _
) As Integer
C#
int GetComputerTargetCount(
    ComputerTargetScope searchScope
);
C++
public:
virtual int GetComputerTargetCount(
    ComputerTargetScope^ searchScope
);
J#
public int GetComputerTargetCount(
    ComputerTargetScope searchScope
);
JScript
function GetComputerTargetCount(
     searchScope : ComputerTargetScope
) : int;

Parameters

searchScope

Search parameters used to filter the result set.

Return Value

The count of computers that match the specified search criteria.

Exceptions

Exception type Condition
ArgumentNullException

searchScope is null.
ArgumentOutOfRangeException

Meets one of the following conditions:

  • searchScope.FromLastSyncTime is greater than searchScope.ToLastSyncTime

  • searchScope.FromLastReportedStatusTime is greater than searchScope.ToLastReportedStatusTime

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetGroup Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the specified target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As IComputerTargetGroup
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargetGroup(id)

Syntax

Visual Basic
Function GetComputerTargetGroup( _
    ByVal id As Guid _
) As IComputerTargetGroup
C#
IComputerTargetGroup GetComputerTargetGroup(
    Guid id
);
C++
public:
virtual IComputerTargetGroup^ GetComputerTargetGroup(
    Guid^ id
);
J#
public IComputerTargetGroup GetComputerTargetGroup(
    Guid id
);
JScript
function GetComputerTargetGroup(
     id : Guid
) : IComputerTargetGroup;

Parameters

id

Unique identifier of the target group.

Return Value

An IComputerTargetGroup whose properties and methods you use to manage the group of client computers and retrieve update statistics for the group.

Exceptions

Exception type | Condition
ArgumentNullException | id cannot be null.
WsusObjectNotFoundException | WSUS could not find the target group with the given identifier.

Remarks

To retrieve the All Computers or Unassigned Computers target group, use ComputerTargetGroupId.AllComputers or ComputerTargetGroupId.UnassignedComputers, respectively.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargetGroups Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of all the target groups on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetGroupCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargetGroups()

Syntax

Visual Basic
Function GetComputerTargetGroups() As ComputerTargetGroupCollection
C#
ComputerTargetGroupCollection GetComputerTargetGroups();
C++
public:
virtual ComputerTargetGroupCollection^ GetComputerTargetGroups();
J#
public ComputerTargetGroupCollection GetComputerTargetGroups();
JScript
function GetComputerTargetGroups() : ComputerTargetGroupCollection;

Return Value

An ComputerTargetGroupCollection collection that you use to enumerate target groups on the WSUS server.

Exceptions

Exception type | Condition
InvalidOperationException | One of more groups is of an unknown type.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargets Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetComputerTargets () | Retrieves a collection of all client computers that are known to the WSUS server.
IUpdateServer.GetComputerTargets (ComputerTargetScope) | Gets all computers that match the specified search criteria.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargets Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of all client computers that are known to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ComputerTargetCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargets()

Syntax

Visual Basic
Function GetComputerTargets() As ComputerTargetCollection
C#
ComputerTargetCollection GetComputerTargets();
C++
public:
virtual ComputerTargetCollection^ GetComputerTargets();
J#
public ComputerTargetCollection GetComputerTargets();
JScript
function GetComputerTargets() : ComputerTargetCollection;

Return Value

Collection of all client computers that are known to the WSUS server.

Remarks

Clients register themselves with the WSUS server if IUpdateServerConfiguration.TargetingMode is Client. You can also call IUpdateServer.RegisterComputer to register a client computer.

To retrieve the client computers for a specific group, call IComputerTargetGroup.GetComputerTargets.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetComputerTargets Method (ComputerTargetScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets all computers that match the specified search criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchScope As ComputerTargetScope
Dim returnValue As ComputerTargetCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetComputerTargets(searchScope)

Syntax

Visual Basic
Function GetComputerTargets( _
    ByVal searchScope As ComputerTargetScope _
) As ComputerTargetCollection
C#
ComputerTargetCollection GetComputerTargets(
    ComputerTargetScope searchScope
);
C++
public:
virtual ComputerTargetCollection^ GetComputerTargets(
    ComputerTargetScope^ searchScope
);
J#
public ComputerTargetCollection GetComputerTargets(
    ComputerTargetScope searchScope
);
JScript
function GetComputerTargets(
     searchScope : ComputerTargetScope
) : ComputerTargetCollection;

Parameters

searchScope

Search parameters used to filter the result set.

Return Value

A collection of computers that match the specified search criteria.

Exceptions

Exception type Condition
ArgumentNullException

searchScope is null.
ArgumentOutOfRangeException

Meets one of the following conditions:

  • searchScope.FromLastSyncTime is greater than searchScope.ToLastSyncTime

  • searchScope.FromLastReportedStatusTime is greater than searchScope.ToLastReportedStatusTime

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetConfiguration Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves an IUpdateServerConfiguration that you use to configure the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IUpdateServerConfiguration
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetConfiguration()

Syntax

Visual Basic
Function GetConfiguration() As IUpdateServerConfiguration
C#
IUpdateServerConfiguration GetConfiguration();
C++
public:
virtual IUpdateServerConfiguration^ GetConfiguration();
J#
public IUpdateServerConfiguration GetConfiguration();
JScript
function GetConfiguration() : IUpdateServerConfiguration;

Return Value

Use IUpdateServerConfiguration to configure the WSUS server. For example, to specify the update languages to download, the proxy to use, and whether the updates are stored locally.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetContentDownloadProgress Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the progress of all updates that are currently downloading.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ContentDownloadProgress
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetContentDownloadProgress()

Syntax

Visual Basic
Function GetContentDownloadProgress() As ContentDownloadProgress
C#
ContentDownloadProgress GetContentDownloadProgress();
C++
public:
virtual ContentDownloadProgress^ GetContentDownloadProgress();
J#
public ContentDownloadProgress GetContentDownloadProgress();
JScript
function GetContentDownloadProgress() : ContentDownloadProgress;

Return Value

Provides the total number of bytes to download and the number of bytes downloaded so far.

Exceptions

Exception type | Condition
InvalidOperationException | Unable to retrieve the progress information.

Remarks

If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, the progress shows the progress of downloading the end-user license agreements (EULAs); otherwise, the progress shows the progress of downloading the EULAs and updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetCurrentUserRole Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the current user's role on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateServerUserRole
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetCurrentUserRole()

Syntax

Visual Basic
Function GetCurrentUserRole() As UpdateServerUserRole
C#
UpdateServerUserRole GetCurrentUserRole();
C++
public:
virtual UpdateServerUserRole GetCurrentUserRole();
J#
public UpdateServerUserRole GetCurrentUserRole();
JScript
function GetCurrentUserRole() : UpdateServerUserRole;

Return Value

The current user's role on the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetDatabaseConfiguration Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves an IDatabaseConfiguration that you use to configure the database connection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IDatabaseConfiguration
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetDatabaseConfiguration()

Syntax

Visual Basic
Function GetDatabaseConfiguration() As IDatabaseConfiguration
C#
IDatabaseConfiguration GetDatabaseConfiguration();
C++
public:
virtual IDatabaseConfiguration^ GetDatabaseConfiguration();
J#
public IDatabaseConfiguration GetDatabaseConfiguration();
JScript
function GetDatabaseConfiguration() : IDatabaseConfiguration;

Return Value

An IDatabaseConfiguration that you use to configure the database connection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetDownstreamServer Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the DownstreamServer corresponding to the supplied Id.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As IDownstreamServer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetDownstreamServer(id)

Syntax

Visual Basic
Function GetDownstreamServer( _
    ByVal id As Guid _
) As IDownstreamServer
C#
IDownstreamServer GetDownstreamServer(
    Guid id
);
C++
public:
virtual IDownstreamServer^ GetDownstreamServer(
    Guid^ id
);
J#
public IDownstreamServer GetDownstreamServer(
    Guid id
);
JScript
function GetDownstreamServer(
     id : Guid
) : IDownstreamServer;

Parameters

id

Unique Id of the requested DownstreamServer

Return Value

The DownstreamServer corresponding to the specified Id

Exceptions

Exception type | Condition
WsusObjectNotFoundException | A DownstreamServer with the specified id could not be found.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetDownstreamServers Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of downstream WSUS servers that are registered with this WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As DownstreamServerCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetDownstreamServers()

Syntax

Visual Basic
Function GetDownstreamServers() As DownstreamServerCollection
C#
DownstreamServerCollection GetDownstreamServers();
C++
public:
virtual DownstreamServerCollection^ GetDownstreamServers();
J#
public DownstreamServerCollection GetDownstreamServers();
JScript
function GetDownstreamServers() : DownstreamServerCollection;

Return Value

Collection of downstream servers that are registered with this server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetEmailNotificationConfiguration Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the email notification configuration interface

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As IEmailNotificationConfiguration
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetEmailNotificationConfiguration()

Syntax

Visual Basic
Function GetEmailNotificationConfiguration() As IEmailNotificationConfiguration
C#
IEmailNotificationConfiguration GetEmailNotificationConfiguration();
C++
public:
virtual IEmailNotificationConfiguration^ GetEmailNotificationConfiguration();
J#
public IEmailNotificationConfiguration GetEmailNotificationConfiguration();
JScript
function GetEmailNotificationConfiguration() : IEmailNotificationConfiguration;

Return Value

The email notification configuration interface

Exceptions

Exception type | Condition
WsusObjectNotFoundException | The email notification configuration cannot be found.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetFrontEndServers Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the list of all front-end servers

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ReadOnlyCollection(Of IFrontEndServer)
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetFrontEndServers()

Syntax

Visual Basic
Function GetFrontEndServers() As ReadOnlyCollection(Of IFrontEndServer)
C#
ReadOnlyCollection<IFrontEndServer> GetFrontEndServers();
C++
public:
virtual ReadOnlyCollection<IFrontEndServer^>^ GetFrontEndServers();
J#
public ReadOnlyCollection<IFrontEndServer> GetFrontEndServers();
JScript
function GetFrontEndServers() : JScript does not support Generics.;

Return Value

A readonly collection of front-end servers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetInstallApprovalRules Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a collection of IAutomaticUpdateApprovalRule rules from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As AutomaticUpdateApprovalRuleCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetInstallApprovalRules()

Syntax

Visual Basic
Function GetInstallApprovalRules() As AutomaticUpdateApprovalRuleCollection
C#
AutomaticUpdateApprovalRuleCollection GetInstallApprovalRules();
C++
public:
virtual AutomaticUpdateApprovalRuleCollection^ GetInstallApprovalRules();
J#
public AutomaticUpdateApprovalRuleCollection GetInstallApprovalRules();
JScript
function GetInstallApprovalRules() : AutomaticUpdateApprovalRuleCollection;

Return Value

The collection of automatic install approval rules

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetPublisher Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets an instance of the IPublisher interface for publishing a package to the server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim sdpFile As String
Dim returnValue As IPublisher
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetPublisher(sdpFile)

Syntax

Visual Basic
Function GetPublisher( _
    ByVal sdpFile As String _
) As IPublisher
C#
IPublisher GetPublisher(
    string sdpFile
);
C++
public:
virtual IPublisher^ GetPublisher(
    String^ sdpFile
);
J#
public IPublisher GetPublisher(
    System.String sdpFile
);
JScript
function GetPublisher(
     sdpFile : String
) : IPublisher;

Parameters

sdpFile

Full FileName and Path to the SDP File to be Published/Revised

Return Value

IPublisher instance

Exceptions

Exception type | Condition
ArgumentNullException | sdpFile is a null reference.
FileNotFoundException | sdpFile cannot be found
UnauthorizedAccessException | When the current user is not a WSUS Administrator
InvalidDataException | When the SDP Xml is Invalid (e.g. Invalid PackageID)
InvalidOperationException | When an Internal Error Occurs

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetReplicaStatus Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetReplicaStatus () | Get a set of status information summarizing the current state of the UpdateServer's replica set and its client computers.
IUpdateServer.GetReplicaStatus (UpdateTypes) | Get a set of status information summarizing the current state of the UpdateServer's replica set and its client computers.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetReplicaStatus Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a set of status information summarizing the current state of the UpdateServer's replica set and its client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateServerStatus
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetReplicaStatus()

Syntax

Visual Basic
Function GetReplicaStatus() As UpdateServerStatus
C#
UpdateServerStatus GetReplicaStatus();
C++
public:
virtual UpdateServerStatus^ GetReplicaStatus();
J#
public UpdateServerStatus GetReplicaStatus();
JScript
function GetReplicaStatus() : UpdateServerStatus;

Return Value

A set of status information summarizing the current state of the UpdateServer's replica set and its client computers.

Remarks

This operation requires WSUS Reporter privileges. This is equivalent to GetReplicaStatus(UpdateTypes.Driver | UpdateTypes.SoftwareUpdate)

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetReplicaStatus Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a set of status information summarizing the current state of the UpdateServer's replica set and its client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateServerStatus
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetReplicaStatus(updateTypes)

Syntax

Visual Basic
Function GetReplicaStatus( _
    ByVal updateTypes As UpdateTypes _
) As UpdateServerStatus
C#
UpdateServerStatus GetReplicaStatus(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateServerStatus^ GetReplicaStatus(
    UpdateTypes updateTypes
);
J#
public UpdateServerStatus GetReplicaStatus(
    UpdateTypes updateTypes
);
JScript
function GetReplicaStatus(
     updateTypes : UpdateTypes
) : UpdateServerStatus;

Parameters

updateTypes

The types of updates to include. Can be any combination of values from UpdateTypes.

Return Value

A set of status information summarizing the current state of the UpdateServer's replica set and its client computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetRootUpdateCategories Method
See Also Example
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of the top-level categories on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetRootUpdateCategories()

Syntax

Visual Basic
Function GetRootUpdateCategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetRootUpdateCategories();
C++
public:
virtual UpdateCategoryCollection^ GetRootUpdateCategories();
J#
public UpdateCategoryCollection GetRootUpdateCategories();
JScript
function GetRootUpdateCategories() : UpdateCategoryCollection;

Return Value

An UpdateCategoryCollection collection of the top-level categories on the WSUS server.

Example

The following example shows how to recursively retrieve all categories on the WSUS server. The server variable that is used in the example is an instance of IUpdateServer (for information on retrieving an IUpdateServer instance, see AdminProxy.GetUpdateServer).

Copy Code
   //Display all root categories and their subcategories.
   DisplayCategories(server.GetRootUpdateCategories());

. . .

static void DisplayCategories(UpdateCategoryCollection categories)
{
   foreach (IUpdateCategory category in categories)
   {
      switch (category.Type)
      {
         case UpdateCategoryType.Company:
            Console.WriteLine();
            break;
         case UpdateCategoryType.ProductFamily:
            Console.Write("  ");
            break;
         case UpdateCategoryType.Company:
            Console.Write("    ");
            break;
      }

      Console.WriteLine("{0}", category.Title);
      if (category.ProhibitSubcategories == false) //category does not have subcategories
      {
         DisplayCategories(category.GetSubcategories());
      }
   }
}

Remarks

A category can represent a company, product family, or product. The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. To determine the category's type, use IUpdateCategory.Type. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

Typically, you use this method to list the available product and product families for each company. The user can then select the products to which they want to subscribe. For details, see ISubscription.SetUpdateCategories.

To retrieve all new categories that were added during a given period, call IUpdateServer.GetUpdateCategories.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetStatus Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetStatus () | Retrieves statistics that summarize the current state of the WSUS server, updates, and the client computers.
IUpdateServer.GetStatus (UpdateTypes) | Get a set of status information summarizing the current state of the UpdateServer and its client computers.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetStatus Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves statistics that summarize the current state of the WSUS server, updates, and the client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateServerStatus
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetStatus()

Syntax

Visual Basic
Function GetStatus() As UpdateServerStatus
C#
UpdateServerStatus GetStatus();
C++
public:
virtual UpdateServerStatus^ GetStatus();
J#
public UpdateServerStatus GetStatus();
JScript
function GetStatus() : UpdateServerStatus;

Return Value

An UpdateServerStatus that you can use to retrieve statistics that summarize the current state of the WSUS server, updates, and the client computers.

Remarks

The statistics are a snapshot in time of the current counts. You need to call this method each time you want to receive the current counts.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetStatus Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a set of status information summarizing the current state of the UpdateServer and its client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateServerStatus
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetStatus(updateTypes)

Syntax

Visual Basic
Function GetStatus( _
    ByVal updateTypes As UpdateTypes _
) As UpdateServerStatus
C#
UpdateServerStatus GetStatus(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateServerStatus^ GetStatus(
    UpdateTypes updateTypes
);
J#
public UpdateServerStatus GetStatus(
    UpdateTypes updateTypes
);
JScript
function GetStatus(
     updateTypes : UpdateTypes
) : UpdateServerStatus;

Parameters

updateTypes

The types of updates to include. Can be any combination of values from UpdateTypes.

Return Value

A set of status information summarizing the current state of the UpdateServer and its client computers.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetSubscription Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a subscription instance that you use to manage the synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As ISubscription
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetSubscription()

Syntax

Visual Basic
Function GetSubscription() As ISubscription
C#
ISubscription GetSubscription();
C++
public:
virtual ISubscription^ GetSubscription();
J#
public ISubscription GetSubscription();
JScript
function GetSubscription() : ISubscription;

Return Value

An ISubscription that you use to manage the synchronization process. For example, you use the instance to specify the product updates to synchronize, determine when the synchronization process begins, and determine the synchronization's progress.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Unable to find the system subscription.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetSubscriptionEvent Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a subscription event that identifies changes to the subscription.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As ISubscriptionEvent
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetSubscriptionEvent(id)

Syntax

Visual Basic
Function GetSubscriptionEvent( _
    ByVal id As Guid _
) As ISubscriptionEvent
C#
ISubscriptionEvent GetSubscriptionEvent(
    Guid id
);
C++
public:
virtual ISubscriptionEvent^ GetSubscriptionEvent(
    Guid^ id
);
J#
public ISubscriptionEvent GetSubscriptionEvent(
    Guid id
);
JScript
function GetSubscriptionEvent(
     id : Guid
) : ISubscriptionEvent;

Parameters

id

Identifier of the subscription event to retrieve.

Return Value

An ISubscriptionEvent that describes the change to the subscription.

Exceptions

Exception type | Condition
ArgumentException | The identifier is not a subscription event identifier.
WsusObjectNotFoundException | Unable to find an event with the given identifier.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members
Microsoft.UpdateServices.Administration Namespace
ISubscription.GetEventHistory


IUpdateServer.GetSummariesPerComputerTarget Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get per-computer summaries for each of the specified computers, summed across all of the specified updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updatesToInclude As UpdateScope
Dim computersToInclude As ComputerTargetScope
Dim returnValue As UpdateSummaryCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetSummariesPerComputerTarget(updatesToInclude, computersToInclude)

Syntax

Visual Basic
Function GetSummariesPerComputerTarget( _
    ByVal updatesToInclude As UpdateScope, _
    ByVal computersToInclude As ComputerTargetScope _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummariesPerComputerTarget(
    UpdateScope updatesToInclude,
    ComputerTargetScope computersToInclude
);
C++
public:
virtual UpdateSummaryCollection^ GetSummariesPerComputerTarget(
    UpdateScope^ updatesToInclude,
    ComputerTargetScope^ computersToInclude
);
J#
public UpdateSummaryCollection GetSummariesPerComputerTarget(
    UpdateScope updatesToInclude,
    ComputerTargetScope computersToInclude
);
JScript
function GetSummariesPerComputerTarget(
     updatesToInclude : UpdateScope,
     computersToInclude : ComputerTargetScope
) : UpdateSummaryCollection;

Parameters

updatesToInclude

Search criteria defining the set of updates to include in the summary.

computersToInclude

Search criteria defining the set of computers to include in the summary.

Return Value

UpdateSummaryCollection containing one summary for each computer.

Exceptions

Exception type Condition
ArgumentNullException

Either updatesToInclude or computersToInclude is null.

ArgumentOutOfRangeException

One of the following conditions exist:

  • updatesToInclude.FromArrivalDate is greater than updatesToInclude.ToArrivalDate

  • updatesToInclude.FromCreationDate is greater than updatesToInclude.ToCreationDate

  • computersToInclude.FromLastSyncTime is greater than computersToInclude.ToLastSyncTime

  • computersToInclude.FromLastReportedStatusTime is greater than computersToInclude.ToLastReportedStatusTime

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetSummariesPerUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get per-update summaries for each of the specified update, summed across all of the specified computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updatesToInclude As UpdateScope
Dim computersToInclude As ComputerTargetScope
Dim returnValue As UpdateSummaryCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetSummariesPerUpdate(updatesToInclude, computersToInclude)

Syntax

Visual Basic
Function GetSummariesPerUpdate( _
    ByVal updatesToInclude As UpdateScope, _
    ByVal computersToInclude As ComputerTargetScope _
) As UpdateSummaryCollection
C#
UpdateSummaryCollection GetSummariesPerUpdate(
    UpdateScope updatesToInclude,
    ComputerTargetScope computersToInclude
);
C++
public:
virtual UpdateSummaryCollection^ GetSummariesPerUpdate(
    UpdateScope^ updatesToInclude,
    ComputerTargetScope^ computersToInclude
);
J#
public UpdateSummaryCollection GetSummariesPerUpdate(
    UpdateScope updatesToInclude,
    ComputerTargetScope computersToInclude
);
JScript
function GetSummariesPerUpdate(
     updatesToInclude : UpdateScope,
     computersToInclude : ComputerTargetScope
) : UpdateSummaryCollection;

Parameters

updatesToInclude

Search criteria defining the set of updates to include in the summary.

computersToInclude

Search criteria defining the set of computers to include in the summary.

Return Value

UpdateSummaryCollection containing one summary for each update.

Exceptions

Exception type Condition
ArgumentNullException

Either updatesToInclude or computersToInclude is null.

ArgumentOutOfRangeException

One of the following conditions exist:

  • updatesToInclude.FromArrivalDate is greater than updatesToInclude.ToArrivalDate

  • updatesToInclude.FromCreationDate is greater than updatesToInclude.ToCreationDate

  • computersToInclude.FromLastSyncTime is greater than computersToInclude.ToLastSyncTime

  • computersToInclude.FromLastReportedStatusTime is greater than computersToInclude.ToLastReportedStatusTime

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetSynchronizationInfo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves information that is related to a specific synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As ISynchronizationInfo
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetSynchronizationInfo(id)

Syntax

Visual Basic
Function GetSynchronizationInfo( _
    ByVal id As Guid _
) As ISynchronizationInfo
C#
ISynchronizationInfo GetSynchronizationInfo(
    Guid id
);
C++
public:
virtual ISynchronizationInfo^ GetSynchronizationInfo(
    Guid^ id
);
J#
public ISynchronizationInfo GetSynchronizationInfo(
    Guid id
);
JScript
function GetSynchronizationInfo(
     id : Guid
) : ISynchronizationInfo;

Parameters

id

Identifies the synchronization information to retrieve.

Return Value

An ISynchronizationInfo that you use to determine when the process started and ended, if the process was successful, and list any errors that occurred.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Unable to find synchronization information with the given identifier.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the specified update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As UpdateRevisionId
Dim returnValue As IUpdate
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdate(id)

Syntax

Visual Basic
Function GetUpdate( _
    ByVal id As UpdateRevisionId _
) As IUpdate
C#
IUpdate GetUpdate(
    UpdateRevisionId id
);
C++
public:
virtual IUpdate^ GetUpdate(
    UpdateRevisionId^ id
);
J#
public IUpdate GetUpdate(
    UpdateRevisionId id
);
JScript
function GetUpdate(
     id : UpdateRevisionId
) : IUpdate;

Parameters

id

Identifier of the update to retrieve. To return the latest revision of the specified update, set UpdateRevisionId.RevisionNumber to 0.

Return Value

An IUpdate that you use to approve the update and retrieve information about the update.

Exceptions

Exception type | Condition
WsusInvalidDataException | Unable to retrieve the given update.
WsusObjectNotFoundException | Unable to find an update with the given identifier.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateApproval Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the specified approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As IUpdateApproval
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateApproval(id)

Syntax

Visual Basic
Function GetUpdateApproval( _
    ByVal id As Guid _
) As IUpdateApproval
C#
IUpdateApproval GetUpdateApproval(
    Guid id
);
C++
public:
virtual IUpdateApproval^ GetUpdateApproval(
    Guid^ id
);
J#
public IUpdateApproval GetUpdateApproval(
    Guid id
);
JScript
function GetUpdateApproval(
     id : Guid
) : IUpdateApproval;

Parameters

id

Identifier of the approval to retrieve.

Return Value

An IUpdateApproval that you can use to determine who approved the update and the current state of the approval.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Unable to find an update approval with the given identifier.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCategories Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetUpdateCategories () | Retrieves the list of all update categories that are known to the WSUS server.
IUpdateServer.GetUpdateCategories (DateTime, DateTime) | Retrieves the update categories that were added within the specified date range.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCategories Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of all update categories that are known to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCategoryCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCategories()

Syntax

Visual Basic
Function GetUpdateCategories() As UpdateCategoryCollection
C#
UpdateCategoryCollection GetUpdateCategories();
C++
public:
virtual UpdateCategoryCollection^ GetUpdateCategories();
J#
public UpdateCategoryCollection GetUpdateCategories();
JScript
function GetUpdateCategories() : UpdateCategoryCollection;

Return Value

An UpdateCategoryCollection collection that contains all the categories of updates that are known to the WSUS server. The collection is unordered.

Remarks

A category can represent a company, product family, or product. The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. To determine the category's type, use IUpdateCategory.Type. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

To retrieve a list of categories added during a given time period, call IUpdateServer.GetUpdateCategories(DateTime, DateTime).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCategories Method (DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the update categories that were added within the specified date range.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromArrivalDate As DateTime
Dim toArrivalDate As DateTime
Dim returnValue As UpdateCategoryCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCategories(fromArrivalDate, toArrivalDate)

Syntax

Visual Basic
Function GetUpdateCategories( _
    ByVal fromArrivalDate As DateTime, _
    ByVal toArrivalDate As DateTime _
) As UpdateCategoryCollection
C#
UpdateCategoryCollection GetUpdateCategories(
    DateTime fromArrivalDate,
    DateTime toArrivalDate
);
C++
public:
virtual UpdateCategoryCollection^ GetUpdateCategories(
    DateTime^ fromArrivalDate,
    DateTime^ toArrivalDate
);
J#
public UpdateCategoryCollection GetUpdateCategories(
    DateTime fromArrivalDate,
    DateTime toArrivalDate
);
JScript
function GetUpdateCategories(
     fromArrivalDate : DateTime,
     toArrivalDate : DateTime
) : UpdateCategoryCollection;

Parameters

fromArrivalDate

UTC Date and time for the beginning of the date range corresponding to the date when UpdateCategories were added locally to this server.

toArrivalDate

UTC Date and time for the end of the date range corresponding to the date when UpdateCategories were added locally to this server.

Return Value

An UpdateCategoryCollection collection that contains the categories that were added during the specified date range (inclusively). The collection is unordered.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromArrivalDate cannot be greater than toArrivalDate.

Remarks

A category can represent a company, product family, or product. The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. To determine the category's type, use IUpdateCategory.Type. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCategory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the category of updates for the given identifier.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As IUpdateCategory
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCategory(id)

Syntax

Visual Basic
Function GetUpdateCategory( _
    ByVal id As Guid _
) As IUpdateCategory
C#
IUpdateCategory GetUpdateCategory(
    Guid id
);
C++
public:
virtual IUpdateCategory^ GetUpdateCategory(
    Guid^ id
);
J#
public IUpdateCategory GetUpdateCategory(
    Guid id
);
JScript
function GetUpdateCategory(
     id : Guid
) : IUpdateCategory;

Parameters

id

Unique identifier of the category.

Return Value

The requested IUpdateCategory which you can use to retrieve information about the category or updates that belong to this category.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Unable to find an update category with the given identifier.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members
Microsoft.UpdateServices.Administration Namespace
IUpdateCategory.ID


IUpdateServer.GetUpdateClassification Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the requested update classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim id As Guid
Dim returnValue As IUpdateClassification
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateClassification(id)

Syntax

Visual Basic
Function GetUpdateClassification( _
    ByVal id As Guid _
) As IUpdateClassification
C#
IUpdateClassification GetUpdateClassification(
    Guid id
);
C++
public:
virtual IUpdateClassification^ GetUpdateClassification(
    Guid^ id
);
J#
public IUpdateClassification GetUpdateClassification(
    Guid id
);
JScript
function GetUpdateClassification(
     id : Guid
) : IUpdateClassification;

Parameters

id

Identifies the update.

Return Value

The requested IUpdateClassification that you can use to retrieve information about the classification or retrieve updates that belong to this classification.

Exceptions

Exception type | Condition
WsusObjectNotFoundException | Unable to find the requested update classification.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateClassifications Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetUpdateClassifications () | Retrieves a collection of update classifications that are known to the WSUS server.
IUpdateServer.GetUpdateClassifications (DateTime, DateTime) | Retrieves the update classifications that were added within the specified date range.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateClassifications Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of update classifications that are known to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateClassificationCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateClassifications()

Syntax

Visual Basic
Function GetUpdateClassifications() As UpdateClassificationCollection
C#
UpdateClassificationCollection GetUpdateClassifications();
C++
public:
virtual UpdateClassificationCollection^ GetUpdateClassifications();
J#
public UpdateClassificationCollection GetUpdateClassifications();
JScript
function GetUpdateClassifications() : UpdateClassificationCollection;

Return Value

An UpdateClassificationCollection collection of classifications that are known to the WSUS server. The collection is unordered.

Remarks

Classifications define a grouping of updates. For example, Security Updates, Critical Updates, or Driver Updates. You can select the classifications you want to subscribe to from the collection and pass the list to ISubscription.SetUpdateClassifications.

To retrieve a list of classifications added during a given time period, call IUpdateServer.GetUpdateClassifications(DateTime, DateTime).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateClassifications Method (DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the update classifications that were added within the specified date range.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromArrivalDate As DateTime
Dim toArrivalDate As DateTime
Dim returnValue As UpdateClassificationCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateClassifications(fromArrivalDate, toArrivalDate)

Syntax

Visual Basic
Function GetUpdateClassifications( _
    ByVal fromArrivalDate As DateTime, _
    ByVal toArrivalDate As DateTime _
) As UpdateClassificationCollection
C#
UpdateClassificationCollection GetUpdateClassifications(
    DateTime fromArrivalDate,
    DateTime toArrivalDate
);
C++
public:
virtual UpdateClassificationCollection^ GetUpdateClassifications(
    DateTime^ fromArrivalDate,
    DateTime^ toArrivalDate
);
J#
public UpdateClassificationCollection GetUpdateClassifications(
    DateTime fromArrivalDate,
    DateTime toArrivalDate
);
JScript
function GetUpdateClassifications(
     fromArrivalDate : DateTime,
     toArrivalDate : DateTime
) : UpdateClassificationCollection;

Parameters

fromArrivalDate

UTC Date and time for the beginning of the date range corresponding to the date when UpdateClassifications were added locally to this server.

toArrivalDate

UTC Date and time for the end of the date range corresponding to the date when UpdateClassifications were added locally to this server.

Return Value

An UpdateCategoryCollection collection that contains the classifications that were added during the specified date range (inclusively). The collection is unordered.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromArrivalDate cannot be greater than toArrivalDate.

Remarks

Classifications define a grouping of updates. For example, Security Updates, Critical Updates, or Driver Updates. You can select the classifications that you want to subscribe to from the collection and pass the list to ISubscription.SetUpdateClassifications.

To retrieve a list of all known classifications, call IUpdateServer.GetUpdateClassifications().

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCount Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetUpdateCount () | Gets the count of all available drivers and software updates.
IUpdateServer.GetUpdateCount (UpdateScope) | Get the count of updates that match the specified search criteria.
IUpdateServer.GetUpdateCount (UpdateTypes) | Gets the count of all available drivers and software updates.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCount Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the count of all available drivers and software updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCount()

Syntax

Visual Basic
Function GetUpdateCount() As Integer
C#
int GetUpdateCount();
C++
public:
virtual int GetUpdateCount();
J#
public int GetUpdateCount();
JScript
function GetUpdateCount() : int;

Return Value

The count of available drivers and software updates.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCount Method (UpdateScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the count of updates that match the specified search criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchScope As UpdateScope
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCount(searchScope)

Syntax

Visual Basic
Function GetUpdateCount( _
    ByVal searchScope As UpdateScope _
) As Integer
C#
int GetUpdateCount(
    UpdateScope searchScope
);
C++
public:
virtual int GetUpdateCount(
    UpdateScope^ searchScope
);
J#
public int GetUpdateCount(
    UpdateScope searchScope
);
JScript
function GetUpdateCount(
     searchScope : UpdateScope
) : int;

Parameters

searchScope

Search parameters used to filter the result set.

Return Value

The count of updates that match the specified search criteria.

Exceptions

Exception type Condition
ArgumentNullException

searchScope is null.
ArgumentOutOfRangeException

One of the following conditions exist:

  • searchScope.FromArrivalDate is greater than searchScope.ToArrivalDate

  • searchScope.FromCreationDate is greater than searchScope.ToCreationDate

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateCount Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the count of all available drivers and software updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As Integer
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateCount(updateTypes)

Syntax

Visual Basic
Function GetUpdateCount( _
    ByVal updateTypes As UpdateTypes _
) As Integer
C#
int GetUpdateCount(
    UpdateTypes updateTypes
);
C++
public:
virtual int GetUpdateCount(
    UpdateTypes updateTypes
);
J#
public int GetUpdateCount(
    UpdateTypes updateTypes
);
JScript
function GetUpdateCount(
     updateTypes : UpdateTypes
) : int;

Parameters

updateTypes

The type of update to count. Can be any combination of values from UpdateTypes.

Return Value

The count of available drivers and software updates.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateEventHistory Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetUpdateEventHistory (DateTime, DateTime) | Retrieves all installation events for all clients for the specified date range.
IUpdateServer.GetUpdateEventHistory (DateTime, DateTime, Guid) | Retrieves all installation events that were raised by all clients for the specified update and date range.
IUpdateServer.GetUpdateEventHistory (DateTime, DateTime, IComputerTarget) | Retrieves all installation events that were raised by the specified client for the specified date range.
IUpdateServer.GetUpdateEventHistory (DateTime, DateTime, Guid, WsusEventSource, WsusEventId[]) | Retrieves events based on the specified criteria.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateEventHistory Method (DateTime, DateTime)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves all installation events for all clients for the specified date range.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim returnValue As UpdateEventCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateEventHistory(fromDate, toDate)

Syntax

Visual Basic
Function GetUpdateEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime _
) As UpdateEventCollection
C#
UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate
);
C++
public:
virtual UpdateEventCollection^ GetUpdateEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate
);
J#
public UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate
);
JScript
function GetUpdateEventHistory(
     fromDate : DateTime,
     toDate : DateTime
) : UpdateEventCollection;

Parameters

fromDate

Begin date that is used to search for events that were raised to the WSUS server by all clients. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events that were raised to the WSUS server by all clients. Specify the date in Coordinated Universal Time.

Return Value

An UpdateEventCollection collection of the installation events that were raised by all clients for the specified date range.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

Events are removed based on the IUpdateServerConfiguration.ServerEventExpirationTime configuration setting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateEventHistory Method (DateTime, DateTime, Guid)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves all installation events that were raised by all clients for the specified update and date range.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim updateId As Guid
Dim returnValue As UpdateEventCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateEventHistory(fromDate, toDate, updateId)

Syntax

Visual Basic
Function GetUpdateEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime, _
    ByVal updateId As Guid _
) As UpdateEventCollection
C#
UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    Guid updateId
);
C++
public:
virtual UpdateEventCollection^ GetUpdateEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate,
    Guid^ updateId
);
J#
public UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    Guid updateId
);
JScript
function GetUpdateEventHistory(
     fromDate : DateTime,
     toDate : DateTime,
     updateId : Guid
) : UpdateEventCollection;

Parameters

fromDate

Begin date that is used to search for events that were raised to the WSUS server for the specified update by all clients. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events that were raised to the WSUS server for the specified update by all clients. Specify the date in Coordinated Universal Time.

updateId

Identifier of the update whose installation history you want to retrieve.

Return Value

An UpdateEventCollection collection of the installation events that were raised by all clients for the specified update and date range.

Exceptions

Exception type | Condition
ArgumentNullException | update cannot be null.
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

Events are removed based on the IUpdateServerConfiguration.ServerEventExpirationTime configuration setting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateEventHistory Method (DateTime, DateTime, IComputerTarget)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves all installation events that were raised by the specified client for the specified date range.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim computer As IComputerTarget
Dim returnValue As UpdateEventCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateEventHistory(fromDate, toDate, computer)

Syntax

Visual Basic
Function GetUpdateEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime, _
    ByVal computer As IComputerTarget _
) As UpdateEventCollection
C#
UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    IComputerTarget computer
);
C++
public:
virtual UpdateEventCollection^ GetUpdateEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate,
    IComputerTarget^ computer
);
J#
public UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    IComputerTarget computer
);
JScript
function GetUpdateEventHistory(
     fromDate : DateTime,
     toDate : DateTime,
     computer : IComputerTarget
) : UpdateEventCollection;

Parameters

fromDate

Begin date that is used to search for events that were raised to the WSUS server by the specified client. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events that were raised to the WSUS server by the specified client. Specify the date in Coordinated Universal Time.

computer

Client whose events you want to retrieve.

Return Value

An UpdateEventCollection collection of the installation events raised by the specified client for the specified date range.

Exceptions

Exception type | Condition
ArgumentNullException | computer cannot be null.
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdateEventHistory Method (DateTime, DateTime, Guid, WsusEventSource, WsusEventId[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves events based on the specified criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim fromDate As DateTime
Dim toDate As DateTime
Dim updateId As Guid
Dim eventSource As WsusEventSource
Dim eventIds() As WsusEventId
Dim returnValue As UpdateEventCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdateEventHistory(fromDate, toDate, updateId, eventSource, eventIds)

Syntax

Visual Basic
Function GetUpdateEventHistory( _
    ByVal fromDate As DateTime, _
    ByVal toDate As DateTime, _
    ByVal updateId As Guid, _
    ByVal eventSource As WsusEventSource, _
    ByVal ParamArray eventIds() As WsusEventId _
) As UpdateEventCollection
C#
UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    Guid updateId,
    WsusEventSource eventSource,
    params WsusEventId[] eventIds
);
C++
public:
virtual UpdateEventCollection^ GetUpdateEventHistory(
    DateTime^ fromDate,
    DateTime^ toDate,
    Guid^ updateId,
    WsusEventSource eventSource,
    ... array<WsusEventId>^ eventIds
);
J#
public UpdateEventCollection GetUpdateEventHistory(
    DateTime fromDate,
    DateTime toDate,
    Guid updateId,
    WsusEventSource eventSource,
    WsusEventId[] eventIds
);
JScript
function GetUpdateEventHistory(
     fromDate : DateTime,
     toDate : DateTime,
     updateId : Guid,
     eventSource : WsusEventSource,
     eventIds : WsusEventId[]
) : UpdateEventCollection;

Parameters

fromDate

Begin date that is used to search for events. Specify the date in Coordinated Universal Time.

toDate

End date that is used to search for events. Specify the date in Coordinated Universal Time.

updateId

Identifier of the update whose installation history events you want to retrieve. Events will be returned for all revisions of this update.

eventSource

Indicates if you want to retrieve events that were raised by clients or servers.

eventIds

Array of events to retrieve. You can specify 0 or more identifiers as parameters, or an array. If you specify a null or a value of 0, the method returns all events for the specified source.

Return Value

An UpdateEventCollection collection of events that were raised that match the specified criteria. The collection is empty if no events match the criteria.

Exceptions

Exception type | Condition
ArgumentNullException | update cannot be null.
ArgumentOutOfRangeException | fromDate cannot be greater than toDate.

Remarks

The date time range is inclusive of fromDate and toDate. This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.GetUpdates () | Retrieves a collection of the latest revision of each update.
IUpdateServer.GetUpdates (UpdateScope) | Gets all updates that match the specified search criteria.
IUpdateServer.GetUpdates (UpdateTypes) | Gets the latest revisions of all available updates of the specified types.
IUpdateServer.GetUpdates (ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection) | Retrieves a collection of updates based on the specified criteria.
IUpdateServer.GetUpdates (ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection, UpdateTypes) |

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of the latest revision of each update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdates()

Syntax

Visual Basic
Function GetUpdates() As UpdateCollection
C#
UpdateCollection GetUpdates();
C++
public:
virtual UpdateCollection^ GetUpdates();
J#
public UpdateCollection GetUpdates();
JScript
function GetUpdates() : UpdateCollection;

Return Value

An UpdateCollection collection of the latest revision of each update. The collection includes updates that were superseded by other updates and declined updates.

Remarks

To retrieve a subset of available updates, call IUpdateServer.GetUpdates(ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method (UpdateScope)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets all updates that match the specified search criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchScope As UpdateScope
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdates(searchScope)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal searchScope As UpdateScope _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    UpdateScope searchScope
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    UpdateScope^ searchScope
);
J#
public UpdateCollection GetUpdates(
    UpdateScope searchScope
);
JScript
function GetUpdates(
     searchScope : UpdateScope
) : UpdateCollection;

Parameters

searchScope

Search parameters used to filter the result set.

Return Value

A collection of updates that match the specified search criteria.

Exceptions

Exception type Condition
ArgumentNullException

searchScope is null.
ArgumentOutOfRangeException

One of the following conditions exist:

  • searchScope.FromArrivalDate is greater than searchScope.ToArrivalDate

  • searchScope.FromCreationDate is greater than searchScope.ToCreationDate

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method (UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the latest revisions of all available updates of the specified types.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdates(updateTypes)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal updateTypes As UpdateTypes _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    UpdateTypes updateTypes
);
J#
public UpdateCollection GetUpdates(
    UpdateTypes updateTypes
);
JScript
function GetUpdates(
     updateTypes : UpdateTypes
) : UpdateCollection;

Parameters

updateTypes

The types of updates to get. Can be any combination of values from UpdateTypes.

Return Value

A collection of updates.

Remarks

This is equivalent to GetUpdates(ApprovedStates.Any, DateTime.MinValue, DateTime.MaxValue, null, null, updateTypes); This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method (ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of updates based on the specified criteria.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim fromArrivalDate As DateTime
Dim toArrivalDate As DateTime
Dim updateCategories As UpdateCategoryCollection
Dim updateClassifications As UpdateClassificationCollection
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdates(approvedStates, fromArrivalDate, toArrivalDate, updateCategories, updateClassifications)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates, _
    ByVal fromArrivalDate As DateTime, _
    ByVal toArrivalDate As DateTime, _
    ByVal updateCategories As UpdateCategoryCollection, _
    ByVal updateClassifications As UpdateClassificationCollection _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    DateTime fromArrivalDate,
    DateTime toArrivalDate,
    UpdateCategoryCollection updateCategories,
    UpdateClassificationCollection updateClassifications
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates,
    DateTime^ fromArrivalDate,
    DateTime^ toArrivalDate,
    UpdateCategoryCollection^ updateCategories,
    UpdateClassificationCollection^ updateClassifications
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    DateTime fromArrivalDate,
    DateTime toArrivalDate,
    UpdateCategoryCollection updateCategories,
    UpdateClassificationCollection updateClassifications
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates,
     fromArrivalDate : DateTime,
     toArrivalDate : DateTime,
     updateCategories : UpdateCategoryCollection,
     updateClassifications : UpdateClassificationCollection
) : UpdateCollection;

Parameters

approvedStates

Include updates that match the specified approved state. You can specify one or more states. For example, specify ApprovedStates.Approved to include only the updates that are approved.

fromArrivalDate

Start date and time that is used to search for updates. Updates that are synchronized on or after this date and time are included in the collection. To avoid filtering updates based on a start date, specify DateTime.MinValue. You must specify the date in Coordinated Universal Time.

toArrivalDate

End date and time that is used to search for updates. Updates synchronized on or before this date and time are included in the collection. To avoid filtering updates based on an end date, specify DateTime.MaxValue. You must specify the date in Coordinated Universal Time.

updateCategories

An UpdateCategoryCollection collection that contains the product categories for which you want to retrieve updates. For example, the family. This parameter can be null.

updateClassifications

An UpdateClassificationCollection collection that contains the classification of updates for which you want to retrieve updates. For example, Critical Updates. This parameter can be null.

Return Value

An UpdateCollection collection of the most recent revision of any update that matches the given criteria.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromSyncDate cannot be greater than toSyncDate.

Remarks

Categories and updateClassifications can both be null. Null categories and updateclassifications tells this API not to filter by categories or update classifications or both.

This search method will only search on and return the most recent revision of any update. For example, suppose an update was added on a Monday, and then revised by a new revision at a a day later on Tuesday. If one was to search with a ArrivalDate filter which included Monday, but not Tuesday, the update would not be returned.

This operation requires WSUS Reporter privileges.

To retrieve all updates, call IUpdateServer.GetUpdates().

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.GetUpdates Method (ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection, UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim approvedStates As ApprovedStates
Dim fromArrivalDate As DateTime
Dim toArrivalDate As DateTime
Dim updateCategories As UpdateCategoryCollection
Dim updateClassifications As UpdateClassificationCollection
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.GetUpdates(approvedStates, fromArrivalDate, toArrivalDate, updateCategories, updateClassifications, updateTypes)

Syntax

Visual Basic
Function GetUpdates( _
    ByVal approvedStates As ApprovedStates, _
    ByVal fromArrivalDate As DateTime, _
    ByVal toArrivalDate As DateTime, _
    ByVal updateCategories As UpdateCategoryCollection, _
    ByVal updateClassifications As UpdateClassificationCollection, _
    ByVal updateTypes As UpdateTypes _
) As UpdateCollection
C#
UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    DateTime fromArrivalDate,
    DateTime toArrivalDate,
    UpdateCategoryCollection updateCategories,
    UpdateClassificationCollection updateClassifications,
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateCollection^ GetUpdates(
    ApprovedStates approvedStates,
    DateTime^ fromArrivalDate,
    DateTime^ toArrivalDate,
    UpdateCategoryCollection^ updateCategories,
    UpdateClassificationCollection^ updateClassifications,
    UpdateTypes updateTypes
);
J#
public UpdateCollection GetUpdates(
    ApprovedStates approvedStates,
    DateTime fromArrivalDate,
    DateTime toArrivalDate,
    UpdateCategoryCollection updateCategories,
    UpdateClassificationCollection updateClassifications,
    UpdateTypes updateTypes
);
JScript
function GetUpdates(
     approvedStates : ApprovedStates,
     fromArrivalDate : DateTime,
     toArrivalDate : DateTime,
     updateCategories : UpdateCategoryCollection,
     updateClassifications : UpdateClassificationCollection,
     updateTypes : UpdateTypes
) : UpdateCollection;

Parameters

approvedStates

Flags that specify which Updates to include. See ApprovedStates for details on what each flag represents.

fromArrivalDate

UTC Date and time for the beginning of the date range corresponding to the date when updates were modified locally on this server.

toArrivalDate

UTC Date and time for the end of the date range corresponding to the date when updates were modified locally on this server.

updateCategories

Collection of update categories to be used to filter the update collection with.

updateClassifications

Collection of update classifications to be used to filter the update collection with.

updateTypes

The types of updates to get. Can be any combination of values from UpdateTypes.

Return Value

A collection of Updates.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | fromDate is greater than toDate.

Remarks

categories and updateClassifications can both be null. Null categories and updateclassifications tells this API not to filter by categories or update classifications or both.

This search method will only search on and return the most recent revision of any update. For example, an update was added on a Monday, and then revised by a new revision a day later on Tuesday. If one was to search with an ArrivalDate filter which included Monday, but not Tuesday, the update would not be returned.

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.ImportUpdateFromCatalogSite Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Imports an update and all of its prerequisites and bundle dependencies. If the update requires content files that are not available from MU, they are downloaded by the catalog site to a local path before calling this method. An update imported by this method will be flagged appropriately so that newer revisions can be sync'ed later even when the update does not match the categories/classifications filter of the synchronization settins.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateID As Guid
Dim downloadedFilePaths() As String
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.ImportUpdateFromCatalogSite(updateID, downloadedFilePaths)

Syntax

Visual Basic
Sub ImportUpdateFromCatalogSite( _
    ByVal updateID As Guid, _
    ByVal downloadedFilePaths() As String _
)
C#
void ImportUpdateFromCatalogSite(
    Guid updateID,
    string[] downloadedFilePaths
);
C++
public:
virtual void ImportUpdateFromCatalogSite(
    Guid^ updateID,
    array<String^>^ downloadedFilePaths
);
J#
public void ImportUpdateFromCatalogSite(
    Guid updateID,
    System.String[] downloadedFilePaths
);
JScript
function ImportUpdateFromCatalogSite(
     updateID : Guid,
     downloadedFilePaths : String[]
) : Void;

Parameters

updateID

Identifies the update to be imported

downloadedFilePaths

The local paths where any files required by the update can be found. The files must exist at the time when the method is called. They are copied to the proper location in the local content store.

Exceptions

Exception type | Condition
ArgumentNullException | downloadedFilePaths, or one of the items in downloadedFilePaths is a null reference.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.IsValidComputerTargetGroupName Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the specified name is a valid computer target group name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As Boolean
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.IsValidComputerTargetGroupName(name)

Syntax

Visual Basic
Function IsValidComputerTargetGroupName( _
    ByVal name As String _
) As Boolean
C#
bool IsValidComputerTargetGroupName(
    string name
);
C++
public:
virtual bool IsValidComputerTargetGroupName(
    String^ name
);
J#
public boolean IsValidComputerTargetGroupName(
    System.String name
);
JScript
function IsValidComputerTargetGroupName(
     name : String
) : Boolean;

Parameters

name

The string to check.

Return Value

True, if the string is a well-formed target group name string, false otherwise.

Exceptions

Exception type | Condition
ArgumentNullException | name is a null reference.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.LogMessage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Logs a message in the SoftwareDistribution Log file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim logLevel As LogLevel
Dim message As String
Dim args() As Object
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.LogMessage(logLevel, message, args)

Syntax

Visual Basic
Sub LogMessage( _
    ByVal logLevel As LogLevel, _
    ByVal message As String, _
    ByVal ParamArray args() As Object _
)
C#
void LogMessage(
    LogLevel logLevel,
    string message,
    params object[] args
);
C++
public:
virtual void LogMessage(
    LogLevel logLevel,
    String^ message,
    ... array<Object^>^ args
);
J#
public void LogMessage(
    LogLevel logLevel,
    System.String message,
    System.Object[] args
);
JScript
function LogMessage(
     logLevel : LogLevel,
     message : String,
     args : Object[]
) : Void;

Parameters

logLevel

The level of the message to log.

message

The message to log.

args

Arguments to insert into message

Remarks

This method internally calls string.Format, and can support any message and args that string.Format can support.

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.RegisterComputer Method
See Also Example
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Registers a client computer with the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim computerName As String
Dim returnValue As IComputerTarget
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.RegisterComputer(computerName)

Syntax

Visual Basic
Function RegisterComputer( _
    ByVal computerName As String _
) As IComputerTarget
C#
IComputerTarget RegisterComputer(
    string computerName
);
C++
public:
virtual IComputerTarget^ RegisterComputer(
    String^ computerName
);
J#
public IComputerTarget RegisterComputer(
    System.String computerName
);
JScript
function RegisterComputer(
     computerName : String
) : IComputerTarget;

Parameters

computerName

Name of the client computer to add. For example, if the client is a member of a domain, use the fully qualified domain name (name.domain.corp.com). The name must be less than 256 characters.

Return Value

An IComputerTarget that represents the specified client computer. Use the instance to add the client to a group.

Example

The following example shows how to query computers from a fictitious Accounting organizational unit in Active Directory, register them in WSUS, and move them to the Accounting group. The server variable that is used in the example is an instance of IUpdateServer (for information on retrieving an IUpdateServer instance, see AdminProxy.GetUpdateServer).

Copy Code
//Reference the Directory Services namespace.
using System.DirectoryServices;

try
{
   IComputerTargetGroup accounting; //The example assumes this has already been set.
   IComputerTarget client;

   //Use the DCs to specify the full domain server name (name.domain.corp.com)
   DirectoryEntry root = new DirectoryEntry("LDAP://OU=Accounting, DC=<name>, DC=<domain>, DC=<corp>, DC=com");
   DirectorySearcher searcher = new DirectorySearcher(root);
   searcher.SearchScope = SearchScope.OneLevel;
   searcher.Filter = "(objectClass=computer)";

   foreach (SearchResult result in searcher.FindAll())
   {
      String fullClientName = (String)result.GetDirectoryEntry().Properties["dnsHostName"].Value;

      if (null != fullClientName)
      {
         client = server.RegisterComputer(fullClientName);

         if (TargetMode.Server == server.GetConfiguration().TargetingMode)
         {
            accounting.AddComputerTarget(client);
         }
      }
   }
}
catch (System.Runtime.InteropServices.COMException e)
{
   Console.WriteLine("Error retrieving computer name from Active Directory.");
}
catch (WsusObjectAlreadyExistsException e)
{
   Console.WriteLine("The client, {0}, already exists.\n{1}", fullClientName, e.Message);
}

Exceptions

Exception type | Condition
ArgumentException | The name contains a character that is not valid.
ArgumentNullException | computerName cannot be null.
ArgumentOutOfRangeException | computerName cannot be an empty string and must be less than 256 characters.
WsusObjectAlreadyExistsException | A client with the specified name is already registered.

Remarks

Typically, client computers register themselves the first time they contact the WSUS server. You can use this method to pre-register the computer so you can use the client information for planning purposes.

The name that you specify must match the name that is used by the client when the client first contacts the WSUS server. If the names match, WSUS updates the temporary IComputerTarget.Id value of the client you registered to the unique identifier that is specified by the client. If the names do not match, the client will register itself, leaving the client that you pre-registered untouched.

If you try to retrieve the client using the temporary value after WSUS changes the identifier, you will receive a WsusObjectNotFoundException exception.

This method validates that the specified computer name is well-formed according to DNS standards, but does not verify that the name exists.

The client is placed in the All Computers group and the Unassigned Computers group. If the server's targeting mode is Server, call IComputerTargetGroup.AddComputerTarget to move the client from the Unassigned Computers group to another group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.ResetAndVerifyContentState Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Forces the synchronization of all update metadata on the WSUS server and verifies that all update files on the WSUS server are valid.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.ResetAndVerifyContentState()

Syntax

Visual Basic
Sub ResetAndVerifyContentState()
C#
void ResetAndVerifyContentState();
C++
public:
virtual void ResetAndVerifyContentState();
J#
public void ResetAndVerifyContentState();
JScript
function ResetAndVerifyContentState() : Void;

Remarks

If you host binaries on Microsoft Update, the method validates the license agreements that were downloaded to the WSUS server. Otherwise, the method validates both the update files and the license agreements.

This method does not identify validation errors. Instead, this method fixes any issues that were found and leaves the WSUS server in a valid state.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.ResumeAllDownloads Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifies the updates to download.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.ResumeAllDownloads()

Syntax

Visual Basic
Sub ResumeAllDownloads()
C#
void ResumeAllDownloads();
C++
public:
virtual void ResumeAllDownloads();
J#
public void ResumeAllDownloads();
JScript
function ResumeAllDownloads() : Void;

Remarks

This method does not start the download; it only identifies to the synchronization agent the updates to download. The updates could be new updates, updates that were canceled during a previous synchronization, or updates that failed to download. The synchronization agent will then start the download based on the synchronization schedule or earlier if you call ISubscription.StartSynchronization.

If IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true, ResumeAllDownloads restarts the downloading of the end-user license agreements.

This method does not affect the synchronization process, which downloads metadata about the updates, not the updates themselves.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.RollupReportingData Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Rolls up reporting data to an upstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer
iUpdateServer1.RollupReportingData()

Syntax

Visual Basic
Sub RollupReportingData()
C#
void RollupReportingData();
C++
public:
virtual void RollupReportingData();
J#
public void RollupReportingData();
JScript
function RollupReportingData() : Void;

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.SearchComputerTargets Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of target computers whose full domain name contains the given string.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim returnValue As ComputerTargetCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.SearchComputerTargets(name)

Syntax

Visual Basic
Function SearchComputerTargets( _
    ByVal name As String _
) As ComputerTargetCollection
C#
ComputerTargetCollection SearchComputerTargets(
    string name
);
C++
public:
virtual ComputerTargetCollection^ SearchComputerTargets(
    String^ name
);
J#
public ComputerTargetCollection SearchComputerTargets(
    System.String name
);
JScript
function SearchComputerTargets(
     name : String
) : ComputerTargetCollection;

Parameters

name

String to search for. The string must be less than 256 characters. The method compares the string to the full domain name of each target computer. The target is added to the returned collection if the string is a substring of the target's full domain name. The comparison is case-insensitive.

Return Value

A ComputerTargetCollection collection of target computers whose name contains the search string. The collection is empty if no matches are found.

Exceptions

Exception type | Condition
ArgumentNullException | name cannot be null.
ArgumentOutOfRangeException | name cannot be an empty string or greater than 255 characters.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.SearchUpdates Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServer.SearchUpdates (String) | Retrieves a collection of updates whose metadata contains the given string.
IUpdateServer.SearchUpdates (String, UpdateTypes) | Searches for updates of the specified type matching the specified string.

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.SearchUpdates Method (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of updates whose metadata contains the given string.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchText As String
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.SearchUpdates(searchText)

Syntax

Visual Basic
Function SearchUpdates( _
    ByVal searchText As String _
) As UpdateCollection
C#
UpdateCollection SearchUpdates(
    string searchText
);
C++
public:
virtual UpdateCollection^ SearchUpdates(
    String^ searchText
);
J#
public UpdateCollection SearchUpdates(
    System.String searchText
);
JScript
function SearchUpdates(
     searchText : String
) : UpdateCollection;

Parameters

searchText

String to search for. The method compares the string to the following update properties:

  • Title

  • Description

  • Knowledge Base (KB) article number

  • Microsoft Security Response Center (MSRC) severity

  • Security Bulletin number

The update is added to the returned collection if the string is a substring of one of these properties. The comparison is case-insensitive.

Return Value

A UpdateCollection collection of updates whose metadata contains the search string. The collection is empty if no matches are found.

Exceptions

Exception type | Condition
ArgumentNullException | searchText cannot be null.
ArgumentOutOfRangeException | searchText cannot be an empty string or greater than 255 characters.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.SearchUpdates Method (String, UpdateTypes)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Searches for updates of the specified type matching the specified string.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim searchText As String
Dim updateTypes As UpdateTypes
Dim returnValue As UpdateCollection
Dim iUpdateServer1 As IUpdateServer
returnValue = iUpdateServer1.SearchUpdates(searchText, updateTypes)

Syntax

Visual Basic
Function SearchUpdates( _
    ByVal searchText As String, _
    ByVal updateTypes As UpdateTypes _
) As UpdateCollection
C#
UpdateCollection SearchUpdates(
    string searchText,
    UpdateTypes updateTypes
);
C++
public:
virtual UpdateCollection^ SearchUpdates(
    String^ searchText,
    UpdateTypes updateTypes
);
J#
public UpdateCollection SearchUpdates(
    System.String searchText,
    UpdateTypes updateTypes
);
JScript
function SearchUpdates(
     searchText : String,
     updateTypes : UpdateTypes
) : UpdateCollection;

Parameters

searchText

A string to search for. The string will be checked for a substring match in the Title, Description, KB article number, and Security Bulletin number properties of the Update.

updateTypes

The types of updates to search for. Can be any combination of values from UpdateTypes.

Return Value

A collection of Updates that match the specified searchText, or an empty collection if none are found.

Remarks

This operation requires WSUS Reporter privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | IsConnectionSecureForApiRemoting | Get a value indicating whether a secure connection to the update server is being used for API Remoting.
public property | Name | Gets the name of the server.
public property | PortNumber | Get the port number of the API Remoting web service on the update server.
public property | PreferredCulture | Retrieves or sets the language code that you want the WSUS server to use when returning strings.
public property | Version | Get the version of the update server.

See Also

Reference

IUpdateServer Interface


IUpdateServer.IsConnectionSecureForApiRemoting Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get a value indicating whether a secure connection to the update server is being used for API Remoting.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer

Dim returnValue As Boolean
returnValue = iUpdateServer1.IsConnectionSecureForApiRemoting

Syntax

Visual Basic
ReadOnly Property IsConnectionSecureForApiRemoting() As Boolean
C#
bool IsConnectionSecureForApiRemoting {get;}
C++
property virtual bool IsConnectionSecureForApiRemoting {
    bool get();
}
J#
public boolean get_IsConnectionSecureForApiRemoting();
JScript
function get IsConnectionSecureForApiRemoting() : Boolean;

Property Value

A value indicating whether a secure connection to the update server is being used for API Remoting.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the name of the server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer

Dim returnValue As String
returnValue = iUpdateServer1.Name

Syntax

Visual Basic
ReadOnly Property Name() As String
C#
string Name {get;}
C++
property virtual String^ Name {
    String^ get();
}
J#
public System.String get_Name();
JScript
function get Name() : String;

Property Value

The name of the server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.PortNumber Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the port number of the API Remoting web service on the update server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer

Dim returnValue As Integer
returnValue = iUpdateServer1.PortNumber

Syntax

Visual Basic
ReadOnly Property PortNumber() As Integer
C#
int PortNumber {get;}
C++
property virtual int PortNumber {
    int get();
}
J#
public int get_PortNumber();
JScript
function get PortNumber() : int;

Property Value

The port number of the API Remoting web service on the update server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.PreferredCulture Property
See Also Example
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the language code that you want the WSUS server to use when returning strings.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer

Dim returnValue As String
returnValue = iUpdateServer1.PreferredCulture

Dim sampleValue As String
iUpdateServer1.PreferredCulture = sampleValue

Syntax

Visual Basic
Property PreferredCulture() As String
C#
string PreferredCulture {get; set;}
C++
property virtual String^ PreferredCulture {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_PreferredCulture();
public void set_PreferredCulture(System.String);
JScript
function get PreferredCulture() : String;
function set PreferredCulture(String);

Property Value

Language code that you want the WSUS server to use when returning strings. For example, "en" for English or "pt-br" for Portuguese (Brazil). If you do not set this property, WSUS uses English ("en") as the preferred culture when returning strings.

Example

For an example that sets the preferred culture, see Using WSUS.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | WSUS does not support the given language code. For a list of valid values, see IUpdateServerConfiguration.SupportedUpdateLanguages.
ArgumentNullException | You cannot specify a null value.

Remarks

You should set this property before calling any of the IUpdateServer methods. The language code is not persisted; you must set the language code each time you retrieve a new IUpdateServer instance. The language code applies to all other objects that IUpdateServer returns.

This property tells the WSUS server the culture to use when returning strings. The preferred culture string follows the format that is specified in RFC1766. WSUS supports a subset of the language and culture codes that are specified in ISO 639 and ISO 3166, respectively. To determine if WSUS supports a preferred culture value, call IUpdateServerConfiguration.SupportedUpdateLanguages.

Strings that come from user input are not localized. All other strings should be localized. For example, the metadata for updates is localized. When you specify a preferred culture, if an update has localized metadata in that language, the WSUS server returns the information in the specified language. If not, the server returns the strings in English.

This property stores the value in lowercase. If you set the property to pt-BR, WSUS returns the property value as pt-br.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServer.Version Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get the version of the update server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServer1 As IUpdateServer

Dim returnValue As Version
returnValue = iUpdateServer1.Version

Syntax

Visual Basic
ReadOnly Property Version() As Version
C#
Version Version {get;}
C++
property virtual Version^ Version {
    Version^ get();
}
J#
public Version get_Version();
JScript
function get Version() : Version;

Property Value

The version of the update server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServer Interface
IUpdateServer Members


IUpdateServerConfiguration Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to configure the WSUS server. For example, to specify the update languages to download, the proxy to use, and whether the updates are stored locally. To retrieve an IUpdateServerConfigurationfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassTopic, call GetConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetConfigurationTopic.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateServerConfigurationImplementation
    Implements IUpdateServerConfiguration
End Class
Dim updateServerConfigurationImplementation1 As New updateServerConfigurationImplementation()

Syntax

Visual Basic
Public Interface IUpdateServerConfiguration
C#
public interface IUpdateServerConfiguration
C++
public interface class IUpdateServerConfiguration
J#
public interface IUpdateServerConfiguration
JScript
public interface IUpdateServerConfiguration

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Members


IUpdateServerConfiguration Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to configure the WSUS server. For example, to specify the update languages to download, the proxy to use, and whether the updates are stored locally. To retrieve an IUpdateServerConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassTopic, call GetConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetConfigurationTopic.

The following tables list the members exposed by the IUpdateServerConfiguration type.

Public Properties

 | Name | Description
public property | AllowProxyCredentialsOverNonSsl | Retrieves or sets a value that indicates if user credentials can be sent to the proxy server using HTTP instead of HTTPS.
public property | AllUpdateLanguagesEnabled | Retrieves or sets a value that indicates if the WSUS server downloads updates for all languages or a subset of languages.
public property | AllUpdateLanguagesUssEnabled | Retrieves or sets a value indicating whether Upstream Server (USS - the server's parent server) supports all languages.
public property | AnonymousProxyAccess | Retrieves or sets a value that indicates if you want to connect to the proxy server anonymously or using user credentials.
public property | AutoApproveWsusInfrastructureUpdates | Retrieves or sets a value that indicates if you want to automatically approve WSUS infrastructure updates.
public property | AutoRefreshUpdateApprovals | Retrieves or sets a value that indicates if you want to automatically approve the latest revision of the update.
public property | AutoRefreshUpdateApprovalsDeclineExpired | Retrieves or sets a value indicating whether an update should be automatically declined when it is revised to be expired and AutoRefreshUpdateApprovals is enabled.
public property | ClientEventExpirationTime | Retrieves or sets the period of time that client events are retained before being removed from the database.
public property | CollectClientInventory | Retrieves or sets a value indicating whether client inventory data will be collected.
public property | DoDetailedRollup | Retrieves or sets a value indicating whether the downstream server (DSS) should rollup detailed computer and update status information.
public property | DownloadExpressPackages | Retrieves a value that indicates if you want to download express installation packages if they are available.
public property | DownloadUpdateBinariesAsNeeded | Retrieves or sets a value that indicates if updates are downloaded only when they are approved.
public property | ExpiredEventDetectionPeriod | Retrieves or sets the period of time between scans for removing expired client and server events from the server.
public property | GetContentFromMU | Retrieves or sets a value indicating whether update binaries are downloaded from Microsoft Update (MU) or from the upstream server (USS).
public property | HasProxyPassword | Retrieves a value that indicates if the proxy password is set.
public property | HostBinariesOnMicrosoftUpdate | Retrieves or sets a value that indicates if you store updates locally or point clients directly to Microsoft Update to download the approved updates.
public property | IsReplicaServer | Retrieves a value that indicates if the WSUS server is a replica server.
public property | LastConfigChange | Retrieves the last time the configuration information changed.
public property | LocalContentCachePath | Retrieves the path of the local content cache.
public property | LogDestinations | Retrieves or sets a value that specifies where log messages are written.
public property | LogFilePath | Retrieves or sets the path of the log file.
public property | LogLevel | Retrieves or sets the level of logging that WSUS generates.
public property | LogRolloverFileSizeInBytes | Retrieves or sets the size of the log file.
public property | MURollupOptin | Retrieves or sets a value indicating whether the top-level server in the server hierarchy will send data to Microsoft Update about machine properties, number of servers, number of clients, etc.
public property | ProxyName | Retrieves or sets the name of the proxy server.
public property | ProxyServerPort | Retrieves or sets the port number that is used to connect to the proxy server.
public property | ProxyUserDomain | Retrieves or sets the name of the domain that contains the user's logon account.
public property | ProxyUserName | Retrieves or sets the user name to use when accessing the proxy server.
public property | ServerEventExpirationTime | Retrieves or sets the period of time that server events are retained before being removed from the database.
public property | ServerId | Retrieves the unique identifier of the WSUS server.
public property | ServerString | Retrieves or sets the string sent to the upstream server or to Microsoft Update to identify the server type.
public property | SupportedUpdateLanguages | Retrieves a collection of languages that WSUS supports.
public property | SyncFromMicrosoftUpdate | Retrieves or sets a value that indicates if the WSUS server synchronizes updates from Microsoft Update or a local WSUS server.
public property | TargetingMode | Retrieves or sets the current targeting mode.
public property | UpstreamWsusServerName | Retrieves or sets the name of a local server from which to synchronize updates.
public property | UpstreamWsusServerPortNumber | Retrieves or sets the port number to use to communicate with the upstream WSUS server.
public property | UpstreamWsusServerUseSsl | Retrieves or sets a value that indicates if the WSUS server should use SSL (HTTPS) to communicate with an upstream server.
public property | UseProxy | Retrieves or sets a value that indicates if you want to use a proxy to download updates.
Top

Public Methods

 | Name | Description
public method | GetEnabledUpdateLanguages | Retrieves a collection of the language codes that are enabled on the WSUS server.
public method | GetProgramKeys | Retrieves the inserted program keys in the DB.
public method | GetSigningCertificate | To save the current registered certificate into certificateFile path.
public method | GetUpdateServerConfigurationState | Determines if the WSUS database is able to process requests at this time.
public method | GetUssEnabledUpdateLanguages | Retrieves the UpdateLanguages on the server whose UssEnabled state is true.
public method | Save | Saves your copy of the WSUS configuration information to the database.
public method | SetEnabledUpdateLanguages | Enables updates for the specified languages.
public method | SetProgramKeys | Sets the inserted program keys in DB.
public method | SetProxyPassword | Overloaded.
public method | SetSigningCertificate | Overloaded. To create and register a self-signed certificate in WSUS store and remove any old self-signed certificate if it exists.
Top

See Also

Reference

IUpdateServerConfiguration Interface


IUpdateServerConfiguration Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetEnabledUpdateLanguages | Retrieves a collection of the language codes that are enabled on the WSUS server.
public method | GetProgramKeys | Retrieves the inserted program keys in the DB.
public method | GetSigningCertificate | To save the current registered certificate into certificateFile path.
public method | GetUpdateServerConfigurationState | Determines if the WSUS database is able to process requests at this time.
public method | GetUssEnabledUpdateLanguages | Retrieves the UpdateLanguages on the server whose UssEnabled state is true.
public method | Save | Saves your copy of the WSUS configuration information to the database.
public method | SetEnabledUpdateLanguages | Enables updates for the specified languages.
public method | SetProgramKeys | Sets the inserted program keys in DB.
public method | SetProxyPassword | Overloaded.
public method | SetSigningCertificate | Overloaded. To create and register a self-signed certificate in WSUS store and remove any old self-signed certificate if it exists.

See Also

Reference

IUpdateServerConfiguration Interface


IUpdateServerConfiguration.GetEnabledUpdateLanguages Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of the language codes that are enabled on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As StringCollection
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
returnValue = iUpdateServerConfiguration1.GetEnabledUpdateLanguages()

Syntax

Visual Basic
Function GetEnabledUpdateLanguages() As StringCollection
C#
StringCollection GetEnabledUpdateLanguages();
C++
public:
virtual StringCollection^ GetEnabledUpdateLanguages();
J#
public StringCollection GetEnabledUpdateLanguages();
JScript
function GetEnabledUpdateLanguages() : StringCollection;

Return Value

Collection of the language codes that are enabled on the WSUS server.

Remarks

The language codes follow the format that is specified in RFC1766. For example, "en" for English or "pt-br" for Portuguese (Brazil). WSUS supports a subset of the language codes that are specified in ISO 639 and culture codes that are specified in ISO 3166.

Note that WSUS stores the language codes in lowercase. If you use Contains (from the System.Collections.Specialized.StringCollection) to determine whether the collection contains a specific language code, you must specify the language code in lowercase (Contains performs a case-sensitive comparison).

The collection contains a snapshot of the languages that are enabled at the time you retrieved the IUpdateServerConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassTopic instance. It is possible for the list of enabled languages to be updated after you retrieve the instance.

To enable language codes, call SetEnabledUpdateLanguages frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetEnabledUpdateLanguagesTopic. If you call GetEnabledUpdateLanguagesfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassGetEnabledUpdateLanguagesTopic after calling SetEnabledUpdateLanguagesfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetEnabledUpdateLanguagesTopic, the collection that GetEnabledUpdateLanguagesfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassGetEnabledUpdateLanguagesTopic returns will not reflect your changes.

For a list of language codes that WSUS supports, call SupportedUpdateLanguages frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSupportedUpdateLanguagesTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.GetProgramKeys Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the inserted program keys in the DB.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Collection(Of ProgramKey)
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
returnValue = iUpdateServerConfiguration1.GetProgramKeys()

Syntax

Visual Basic
Function GetProgramKeys() As Collection(Of ProgramKey)
C#
Collection<ProgramKey> GetProgramKeys();
C++
public:
virtual Collection<ProgramKey^>^ GetProgramKeys();
J#
public Collection<ProgramKey> GetProgramKeys();
JScript
function GetProgramKeys() : JScript does not support Generics.;

Return Value

The program keys currently registered with the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.GetSigningCertificate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

To save the current registered certificate into certificateFile path.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim certificateFile As String
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.GetSigningCertificate(certificateFile)

Syntax

Visual Basic
Sub GetSigningCertificate( _
    ByVal certificateFile As String _
)
C#
void GetSigningCertificate(
    string certificateFile
);
C++
public:
virtual void GetSigningCertificate(
    String^ certificateFile
);
J#
public void GetSigningCertificate(
    System.String certificateFile
);
JScript
function GetSigningCertificate(
     certificateFile : String
) : Void;

Parameters

certificateFile

The full file path of certificate

Exceptions

Exception type | Condition
Win32Exception | HRESULT error code returns from native function.
ArgumentNullException | certificateFile is null.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.GetUpdateServerConfigurationState Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the WSUS database is able to process requests at this time.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As UpdateServerConfigurationState
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
returnValue = iUpdateServerConfiguration1.GetUpdateServerConfigurationState()

Syntax

Visual Basic
Function GetUpdateServerConfigurationState() As UpdateServerConfigurationState
C#
UpdateServerConfigurationState GetUpdateServerConfigurationState();
C++
public:
virtual UpdateServerConfigurationState GetUpdateServerConfigurationState();
J#
public UpdateServerConfigurationState GetUpdateServerConfigurationState();
JScript
function GetUpdateServerConfigurationState() : UpdateServerConfigurationState;

Return Value

Current state of the WSUS database. Use the state to determine if the database can process your request at this time. For a list of possible states, see UpdateServerConfigurationState frlrfMicrosoftUpdateServicesAdministrationUpdateServerConfigurationStateClassTopic.

Remarks

Typically, you call this method before calling Save frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSaveTopic. The Save method throws an exception if the current state of the database is not ReadyfrlrfMicrosoftUpdateServicesAdministrationUpdateServerConfigurationStateClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.GetUssEnabledUpdateLanguages Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the UpdateLanguages on the server whose UssEnabled state is true.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As StringCollection
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
returnValue = iUpdateServerConfiguration1.GetUssEnabledUpdateLanguages()

Syntax

Visual Basic
Function GetUssEnabledUpdateLanguages() As StringCollection
C#
StringCollection GetUssEnabledUpdateLanguages();
C++
public:
virtual StringCollection^ GetUssEnabledUpdateLanguages();
J#
public StringCollection GetUssEnabledUpdateLanguages();
JScript
function GetUssEnabledUpdateLanguages() : StringCollection;

Return Value

A string collection containing the update languages which are enabled on the upstream server (parent server). These values should be a subset of those returned by GetSupportedUpdateLanguages.

Remarks

All language ids are lower case. Be sure to use ToLower() when searching for a specific language as StringCollection methods are case-sensitive. This method does not hit the database to retrieve enabled languages. Instead, this method will return languages loaded on the local IUpdateServerConfiguration object. To get a refreshed copy of the enabled languages, get a new instance of IUpdateServerConfiguration.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.Save Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Saves your copy of the WSUS configuration information to the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.Save()

Syntax

Visual Basic
Sub Save()
C#
void Save();
C++
public:
virtual void Save();
J#
public void Save();
JScript
function Save() : Void;

Exceptions

Exception type Condition
WsusInvalidDataException

You can receive this exception because of any of the following reasons:

  • If UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true, ProxyName frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassProxyNameTopic cannot be empty and ProxyServerPort frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassProxyServerPortTopic must be valid

  • If UseProxyis true and AnonymousProxyAccess frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false, ProxyUserName frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassProxyUserNameTopic cannot be empty

  • If SyncFromMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic is false, UpstreamWsusServerName frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUpstreamWsusServerNameTopic cannot be empty

  • If HostBinariesOnMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic is true, AllUpdateLanguagesEnabled frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAllUpdateLanguagesEnabledTopic must be true

  • If HostBinariesOnMicrosoftUpdatefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic is false and AllUpdateLanguagesEnabledfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAllUpdateLanguagesEnabledTopic is false, you must use SetEnabledUpdateLanguages frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetEnabledUpdateLanguagesTopic to enable at least one language
InvalidOperationException

You can receive this exception because of any of the following reasons:

  • WSUS is currently synchronizing updates

  • WSUS is currently processing a previous configuration save request

  • If IsReplicaServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassIsReplicaServerTopic is true, SyncFromMicrosoftUpdatefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSyncFromMicrosoftUpdateTopic cannot be true

Remarks

When you call GetConfiguration frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetConfigurationTopic, you will receive a copy of the configuration information that is currently saved in the WSUS database. Changes that you make to the configuration information are made only to your local copy. To make your changes visible to other application and to the WSUS server, call SavefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSaveTopic.

WSUS contains configuration information from the last application to save changes.

Changes to some configuration settings can cause WSUS to start a background process, which can prevent other processes from saving configuration settings (the process can run for up to three minutes). If you call Save while the background process is running, WSUS throws the System.InvalidOperationException exception. You can implement retry logic to handle this exception or call GetUpdateServerConfigurationState frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassGetUpdateServerConfigurationStateTopic before calling Save to determine if you can save configuration settings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetEnabledUpdateLanguages Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Enables updates for the specified languages.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim enabledUpdateLanguages As StringCollection
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetEnabledUpdateLanguages(enabledUpdateLanguages)

Syntax

Visual Basic
Sub SetEnabledUpdateLanguages( _
    ByVal enabledUpdateLanguages As StringCollection _
)
C#
void SetEnabledUpdateLanguages(
    StringCollection enabledUpdateLanguages
);
C++
public:
virtual void SetEnabledUpdateLanguages(
    StringCollection^ enabledUpdateLanguages
);
J#
public void SetEnabledUpdateLanguages(
    StringCollection enabledUpdateLanguages
);
JScript
function SetEnabledUpdateLanguages(
     enabledUpdateLanguages : StringCollection
) : Void;

Parameters

enabledUpdateLanguages

Collection of language codes to enable for updates. Language codes that are not included in the collection are disabled. You must specify the language code strings in lowercase.

Exceptions

Exception type | Condition
ArgumentException | One of the language code strings in the collection is not valid. For a list of valid language codes, see SupportedUpdateLanguages frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSupportedUpdateLanguagesTopic.
ArgumentNullException | enabledUpdateLanguages cannot be null.

Remarks

The language codes follow the format that is specified in RFC1766. For example, "en" for English or "pt-br" for Portuguese (Brazil). WSUS supports a subset of the language codes that are specified in ISO 639 and culture codes that are specified in ISO 3166.

For a list of language codes that WSUS supports, call SupportedUpdateLanguagesfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSupportedUpdateLanguagesTopic. The language codes that you specify must match the language codes that WSUS supports.

WSUS ignores the specified languages if AllUpdateLanguagesEnabled frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAllUpdateLanguagesEnabledTopic is true.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetProgramKeys Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the inserted program keys in DB.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim programKeys As IEnumerable
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetProgramKeys(programKeys)

Syntax

Visual Basic
Sub SetProgramKeys( _
    ByVal programKeys As IEnumerable(Of ProgramKey) _
)
C#
void SetProgramKeys(
    IEnumerable<ProgramKey> programKeys
);
C++
public:
virtual void SetProgramKeys(
    IEnumerable<ProgramKey^>^ programKeys
);
J#
public void SetProgramKeys(
    IEnumerable<ProgramKey> programKeys
);
JScript
function SetProgramKeys(
     programKeys : JScript does not support Generics.
) : Void;

Parameters

programKeys

The program keys to register.

Exceptions

Exception type | Condition
ArgumentNullException | The property value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetProxyPassword Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
IUpdateServerConfiguration.SetProxyPassword (SecureString) | Sets the password to use when accessing the proxy.
IUpdateServerConfiguration.SetProxyPassword (String) | Specifies the password to use when accessing the proxy server.

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetProxyPassword Method (SecureString)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Sets the password to use when accessing the proxy.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim password As SecureString
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetProxyPassword(password)

Syntax

Visual Basic
Sub SetProxyPassword( _
    ByVal password As SecureString _
)
C#
void SetProxyPassword(
    SecureString password
);
C++
public:
virtual void SetProxyPassword(
    SecureString^ password
);
J#
public void SetProxyPassword(
    SecureString password
);
JScript
function SetProxyPassword(
     password : SecureString
) : Void;

Parameters

password

Password to use when accessing the proxy

Exceptions

Exception type | Condition
ArgumentNullException | The password is null.
ArgumentOutOfRangeException | The password is longer than 256 characters.

Remarks

The password is stored in an encrypted format.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetProxyPassword Method (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Specifies the password to use when accessing the proxy server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim password As String
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetProxyPassword(password)

Syntax

Visual Basic
Sub SetProxyPassword( _
    ByVal password As String _
)
C#
void SetProxyPassword(
    string password
);
C++
public:
virtual void SetProxyPassword(
    String^ password
);
J#
public void SetProxyPassword(
    System.String password
);
JScript
function SetProxyPassword(
     password : String
) : Void;

Parameters

password

Password to use when accessing the proxy server.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | password cannot be greater than 255 characters.
ArgumentNullException | password cannot be null.

Remarks

WSUS securely encrypts the password for security reasons before storing the password in the database.

You cannot retrieve the password, you can only set it. To determine if the password is set, call HasProxyPassword frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHasProxyPasswordTopic. To remove the password, set password to an empty string (String.Empty).

User credentials are used only if UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true and AnonymousProxyAccess frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetSigningCertificate Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

To create and register a self-signed certificate in WSUS store and remove any old self-signed certificate if it exists.

Overload List

Name | Description
IUpdateServerConfiguration.SetSigningCertificate () | To create and register a self-sign certificate in WSUS store and remove old self-signed certificate if it exists.
IUpdateServerConfiguration.SetSigningCertificate (String, SecureString) | To import and register the PFX certificate into WSUS store and remove any old self-signed certificate if exists. If PFXFile is null, the current registered certificate will be removed.
IUpdateServerConfiguration.SetSigningCertificate (String, String) | To import and register the PFX certificate into WSUS store and remove any old self-signed certificate if exists. If PFXFile is null, the current registered certificate will be removed.

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetSigningCertificate Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

To create and register a self-sign certificate in WSUS store and remove old self-signed certificate if it exists.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetSigningCertificate()

Syntax

Visual Basic
Sub SetSigningCertificate()
C#
void SetSigningCertificate();
C++
public:
virtual void SetSigningCertificate();
J#
public void SetSigningCertificate();
JScript
function SetSigningCertificate() : Void;

Exceptions

Exception type | Condition
Win32Exception | HRESULT error code returns from native function.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetSigningCertificate Method (String, SecureString)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

To import and register the PFX certificate into WSUS store and remove any old self-signed certificate if exists. If PFXFile is null, the current registered certificate will be removed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim pfxFile As String
Dim password As SecureString
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetSigningCertificate(pfxFile, password)

Syntax

Visual Basic
Sub SetSigningCertificate( _
    ByVal pfxFile As String, _
    ByVal password As SecureString _
)
C#
void SetSigningCertificate(
    string pfxFile,
    SecureString password
);
C++
public:
virtual void SetSigningCertificate(
    String^ pfxFile,
    SecureString^ password
);
J#
public void SetSigningCertificate(
    System.String pfxFile,
    SecureString password
);
JScript
function SetSigningCertificate(
     pfxFile : String,
     password : SecureString
) : Void;

Parameters

pfxFile

The PFX certificate to import into WSUS store.

password

Password to open the PFX file

Exceptions

Exception type | Condition
Win32Exception | HRESULT error code returns from native function.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SetSigningCertificate Method (String, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

To import and register the PFX certificate into WSUS store and remove any old self-signed certificate if exists. If PFXFile is null, the current registered certificate will be removed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim pfxFile As String
Dim password As String
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration
iUpdateServerConfiguration1.SetSigningCertificate(pfxFile, password)

Syntax

Visual Basic
Sub SetSigningCertificate( _
    ByVal pfxFile As String, _
    ByVal password As String _
)
C#
void SetSigningCertificate(
    string pfxFile,
    string password
);
C++
public:
virtual void SetSigningCertificate(
    String^ pfxFile,
    String^ password
);
J#
public void SetSigningCertificate(
    System.String pfxFile,
    System.String password
);
JScript
function SetSigningCertificate(
     pfxFile : String,
     password : String
) : Void;

Parameters

pfxFile

The PFX certificate to import into WSUS store.

password

Password to open the PFX file

Exceptions

Exception type | Condition
Win32Exception | HRESULT error code returns from native function.

Remarks

This operation requires WSUS Administrator privileges.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | AllowProxyCredentialsOverNonSsl | Retrieves or sets a value that indicates if user credentials can be sent to the proxy server using HTTP instead of HTTPS.
public property | AllUpdateLanguagesEnabled | Retrieves or sets a value that indicates if the WSUS server downloads updates for all languages or a subset of languages.
public property | AllUpdateLanguagesUssEnabled | Retrieves or sets a value indicating whether Upstream Server (USS - the server's parent server) supports all languages.
public property | AnonymousProxyAccess | Retrieves or sets a value that indicates if you want to connect to the proxy server anonymously or using user credentials.
public property | AutoApproveWsusInfrastructureUpdates | Retrieves or sets a value that indicates if you want to automatically approve WSUS infrastructure updates.
public property | AutoRefreshUpdateApprovals | Retrieves or sets a value that indicates if you want to automatically approve the latest revision of the update.
public property | AutoRefreshUpdateApprovalsDeclineExpired | Retrieves or sets a value indicating whether an update should be automatically declined when it is revised to be expired and AutoRefreshUpdateApprovals is enabled.
public property | ClientEventExpirationTime | Retrieves or sets the period of time that client events are retained before being removed from the database.
public property | CollectClientInventory | Retrieves or sets a value indicating whether client inventory data will be collected.
public property | DoDetailedRollup | Retrieves or sets a value indicating whether the downstream server (DSS) should rollup detailed computer and update status information.
public property | DownloadExpressPackages | Retrieves a value that indicates if you want to download express installation packages if they are available.
public property | DownloadUpdateBinariesAsNeeded | Retrieves or sets a value that indicates if updates are downloaded only when they are approved.
public property | ExpiredEventDetectionPeriod | Retrieves or sets the period of time between scans for removing expired client and server events from the server.
public property | GetContentFromMU | Retrieves or sets a value indicating whether update binaries are downloaded from Microsoft Update (MU) or from the upstream server (USS).
public property | HasProxyPassword | Retrieves a value that indicates if the proxy password is set.
public property | HostBinariesOnMicrosoftUpdate | Retrieves or sets a value that indicates if you store updates locally or point clients directly to Microsoft Update to download the approved updates.
public property | IsReplicaServer | Retrieves a value that indicates if the WSUS server is a replica server.
public property | LastConfigChange | Retrieves the last time the configuration information changed.
public property | LocalContentCachePath | Retrieves the path of the local content cache.
public property | LogDestinations | Retrieves or sets a value that specifies where log messages are written.
public property | LogFilePath | Retrieves or sets the path of the log file.
public property | LogLevel | Retrieves or sets the level of logging that WSUS generates.
public property | LogRolloverFileSizeInBytes | Retrieves or sets the size of the log file.
public property | MURollupOptin | Retrieves or sets a value indicating whether the top-level server in the server hierarchy will send data to Microsoft Update about machine properties, number of servers, number of clients, etc.
public property | ProxyName | Retrieves or sets the name of the proxy server.
public property | ProxyServerPort | Retrieves or sets the port number that is used to connect to the proxy server.
public property | ProxyUserDomain | Retrieves or sets the name of the domain that contains the user's logon account.
public property | ProxyUserName | Retrieves or sets the user name to use when accessing the proxy server.
public property | ServerEventExpirationTime | Retrieves or sets the period of time that server events are retained before being removed from the database.
public property | ServerId | Retrieves the unique identifier of the WSUS server.
public property | ServerString | Retrieves or sets the string sent to the upstream server or to Microsoft Update to identify the server type.
public property | SupportedUpdateLanguages | Retrieves a collection of languages that WSUS supports.
public property | SyncFromMicrosoftUpdate | Retrieves or sets a value that indicates if the WSUS server synchronizes updates from Microsoft Update or a local WSUS server.
public property | TargetingMode | Retrieves or sets the current targeting mode.
public property | UpstreamWsusServerName | Retrieves or sets the name of a local server from which to synchronize updates.
public property | UpstreamWsusServerPortNumber | Retrieves or sets the port number to use to communicate with the upstream WSUS server.
public property | UpstreamWsusServerUseSsl | Retrieves or sets a value that indicates if the WSUS server should use SSL (HTTPS) to communicate with an upstream server.
public property | UseProxy | Retrieves or sets a value that indicates if you want to use a proxy to download updates.

See Also

Reference

IUpdateServerConfiguration Interface


IUpdateServerConfiguration.AllowProxyCredentialsOverNonSsl Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if user credentials can be sent to the proxy server using HTTP instead of HTTPS.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AllowProxyCredentialsOverNonSsl

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AllowProxyCredentialsOverNonSsl = sampleValue

Syntax

Visual Basic
Property AllowProxyCredentialsOverNonSsl() As Boolean
C#
bool AllowProxyCredentialsOverNonSsl {get; set;}
C++
property virtual bool AllowProxyCredentialsOverNonSsl {
    bool get();
    void set(bool value);
}
J#
public boolean get_AllowProxyCredentialsOverNonSsl();
public void set_AllowProxyCredentialsOverNonSsl(boolean);
JScript
function get AllowProxyCredentialsOverNonSsl() : Boolean;
function set AllowProxyCredentialsOverNonSsl(Boolean);

Property Value

True allows user credentials to be sent to the proxy server using HTTP; otherwise, the user credentials are sent to the proxy server using HTTPS.

Remarks

By default, WSUS uses HTTPS to access the proxy server. If HTTPS is not available and AllowProxyCredentialsOverNonSslfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAllowProxyCredentialsOverNonSslTopic is true, WSUS will use HTTP. Otherwise, WSUS will fail. Note that if WSUS uses HTTP to access the proxy server, the credentials are sent in plain-text.

User credentials are used only if UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true and AnonymousProxyAccess frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AllUpdateLanguagesEnabled Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if the WSUS server downloads updates for all languages or a subset of languages.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AllUpdateLanguagesEnabled

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AllUpdateLanguagesEnabled = sampleValue

Syntax

Visual Basic
Property AllUpdateLanguagesEnabled() As Boolean
C#
bool AllUpdateLanguagesEnabled {get; set;}
C++
property virtual bool AllUpdateLanguagesEnabled {
    bool get();
    void set(bool value);
}
J#
public boolean get_AllUpdateLanguagesEnabled();
public void set_AllUpdateLanguagesEnabled(boolean);
JScript
function get AllUpdateLanguagesEnabled() : Boolean;
function set AllUpdateLanguagesEnabled(Boolean);

Property Value

Indicates whether the WSUS server downloads updates for all languages or a subset of languages. If true, the WSUS server downloads updates for all languages. If false, a call to SetEnabledUpdateLanguages frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetEnabledUpdateLanguagesTopic is made to specify which languages the WSUS server will download the update.

Remarks

If HostBinariesOnMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic is true, this property must be true.

If HostBinariesOnMicrosoftUpdatefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic is false, you must set this property to true or call the SetEnabledUpdateLanguagesfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetEnabledUpdateLanguagesTopic method to enable one or more languages.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AllUpdateLanguagesUssEnabled Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether Upstream Server (USS - the server's parent server) supports all languages.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AllUpdateLanguagesUssEnabled

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AllUpdateLanguagesUssEnabled = sampleValue

Syntax

Visual Basic
Property AllUpdateLanguagesUssEnabled() As Boolean
C#
bool AllUpdateLanguagesUssEnabled {get; set;}
C++
property virtual bool AllUpdateLanguagesUssEnabled {
    bool get();
    void set(bool value);
}
J#
public boolean get_AllUpdateLanguagesUssEnabled();
public void set_AllUpdateLanguagesUssEnabled(boolean);
JScript
function get AllUpdateLanguagesUssEnabled() : Boolean;
function set AllUpdateLanguagesUssEnabled(Boolean);

Property Value

If true, USS will support all available locales. If false, USS will only support those locales which are enabled via

Remarks

The default is true, USS will support all available locales.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AnonymousProxyAccess Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if you want to connect to the proxy server anonymously or using user credentials.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AnonymousProxyAccess

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AnonymousProxyAccess = sampleValue

Syntax

Visual Basic
Property AnonymousProxyAccess() As Boolean
C#
bool AnonymousProxyAccess {get; set;}
C++
property virtual bool AnonymousProxyAccess {
    bool get();
    void set(bool value);
}
J#
public boolean get_AnonymousProxyAccess();
public void set_AnonymousProxyAccess(boolean);
JScript
function get AnonymousProxyAccess() : Boolean;
function set AnonymousProxyAccess(Boolean);

Property Value

True to connect to the proxy server anonymously (without specifying user credentials); otherwise, false to connect using user credentials.

Remarks

If AnonymousProxyAccessfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false, you must specify ProxyUserName frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassProxyUserNameTopic and optionally ProxyUserDomain frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassProxyUserDomainTopic and SetProxyPassword frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassSetProxyPasswordTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AutoApproveWsusInfrastructureUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if you want to automatically approve WSUS infrastructure updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AutoApproveWsusInfrastructureUpdates

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AutoApproveWsusInfrastructureUpdates = sampleValue

Syntax

Visual Basic
Property AutoApproveWsusInfrastructureUpdates() As Boolean
C#
bool AutoApproveWsusInfrastructureUpdates {get; set;}
C++
property virtual bool AutoApproveWsusInfrastructureUpdates {
    bool get();
    void set(bool value);
}
J#
public boolean get_AutoApproveWsusInfrastructureUpdates();
public void set_AutoApproveWsusInfrastructureUpdates(boolean);
JScript
function get AutoApproveWsusInfrastructureUpdates() : Boolean;
function set AutoApproveWsusInfrastructureUpdates(Boolean);

Property Value

True to automatically approve WSUS infrastructure updates to the All Computers group; otherwise, false.

Remarks

Note:
WSUS infrastructure updates are important to the continued operation of the WSUS server. Failure to approve these updates could prevent important updates from being installed on client computers.

The default returned value is true, to automatically approve WSUS infrastructure updates to the All Computers group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AutoRefreshUpdateApprovals Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if you want to automatically approve the latest revision of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AutoRefreshUpdateApprovals

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AutoRefreshUpdateApprovals = sampleValue

Syntax

Visual Basic
Property AutoRefreshUpdateApprovals() As Boolean
C#
bool AutoRefreshUpdateApprovals {get; set;}
C++
property virtual bool AutoRefreshUpdateApprovals {
    bool get();
    void set(bool value);
}
J#
public boolean get_AutoRefreshUpdateApprovals();
public void set_AutoRefreshUpdateApprovals(boolean);
JScript
function get AutoRefreshUpdateApprovals() : Boolean;
function set AutoRefreshUpdateApprovals(Boolean);

Property Value

True to automatically approve the latest revision of the update; otherwise, false to continue using the older revision and to manually approve new update revisions.

Remarks

If true, WSUS removes the approval from the previous revision (only one revision of an update can contain an approval).

WSUS can automatically approve the latest revision only if the new revision does not require the user to accept a new license agreement. If a new license agreement acceptance is required, you must deploy the new revision manually.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.AutoRefreshUpdateApprovalsDeclineExpired Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether an update should be automatically declined when it is revised to be expired and AutoRefreshUpdateApprovals is enabled.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.AutoRefreshUpdateApprovalsDeclineExpired

Dim sampleValue As Boolean
iUpdateServerConfiguration1.AutoRefreshUpdateApprovalsDeclineExpired = sampleValue

Syntax

Visual Basic
Property AutoRefreshUpdateApprovalsDeclineExpired() As Boolean
C#
bool AutoRefreshUpdateApprovalsDeclineExpired {get; set;}
C++
property virtual bool AutoRefreshUpdateApprovalsDeclineExpired {
    bool get();
    void set(bool value);
}
J#
public boolean get_AutoRefreshUpdateApprovalsDeclineExpired();
public void set_AutoRefreshUpdateApprovalsDeclineExpired(boolean);
JScript
function get AutoRefreshUpdateApprovalsDeclineExpired() : Boolean;
function set AutoRefreshUpdateApprovalsDeclineExpired(Boolean);

Property Value

True, if an update should be automatically declined during import, if it is expired. False, if the Update will not be declined.

Remarks

This configuration value is only used when the AutoRefreshUpdateApprovals configuration value is enabled.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ClientEventExpirationTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the period of time that client events are retained before being removed from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As TimeSpan
returnValue = iUpdateServerConfiguration1.ClientEventExpirationTime

Dim sampleValue As TimeSpan
iUpdateServerConfiguration1.ClientEventExpirationTime = sampleValue

Syntax

Visual Basic
Property ClientEventExpirationTime() As TimeSpan
C#
TimeSpan ClientEventExpirationTime {get; set;}
C++
property virtual TimeSpan^ ClientEventExpirationTime {
    TimeSpan^ get();
    void set(TimeSpan^ value);
}
J#
public TimeSpan get_ClientEventExpirationTime();
public void set_ClientEventExpirationTime(TimeSpan);
JScript
function get ClientEventExpirationTime() : TimeSpan;
function set ClientEventExpirationTime(TimeSpan);

Property Value

Period of time that client events are retained before being removed from the database. The minimum unit of time is one day—fractions of a day are truncated (the property returns only the day value). The maximum unit of time is 365 days. The default is 15 days.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The time span cannot be less than zero.

Remarks

WSUS scans for client events to remove when it receives a client event and ExpiredEventDetectionPeriod frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassExpiredEventDetectionPeriodTopic has elapsed.

To remove client events immediately, set ClientEventExpirationTimefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassClientEventExpirationTimeTopic to 0. To remove events for a specific client, call PurgeAssociatedReportingEvents frlrfMicrosoftUpdateServicesAdministrationIComputerTargetClassPurgeAssociatedReportingEventsTopic.

To view client events, call one of the GetUpdateEventHistory frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetUpdateEventHistoryTopic overloads. The collection returns both client and server events. Use WsusEventSource frlrfMicrosoftUpdateServicesAdministrationIUpdateEventClassWsusEventSourceTopic to determine the event's origin.

Note:
You can exceed the size of the database if there is a high volume of client events and you specify a large value for ClientEventExpirationTimefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassClientEventExpirationTimeTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.CollectClientInventory Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether client inventory data will be collected.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.CollectClientInventory

Dim sampleValue As Boolean
iUpdateServerConfiguration1.CollectClientInventory = sampleValue

Syntax

Visual Basic
Property CollectClientInventory() As Boolean
C#
bool CollectClientInventory {get; set;}
C++
property virtual bool CollectClientInventory {
    bool get();
    void set(bool value);
}
J#
public boolean get_CollectClientInventory();
public void set_CollectClientInventory(boolean);
JScript
function get CollectClientInventory() : Boolean;
function set CollectClientInventory(Boolean);

Property Value

True if client inventory data will be collected; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.DoDetailedRollup Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether the downstream server (DSS) should rollup detailed computer and update status information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.DoDetailedRollup

Dim sampleValue As Boolean
iUpdateServerConfiguration1.DoDetailedRollup = sampleValue

Syntax

Visual Basic
Property DoDetailedRollup() As Boolean
C#
bool DoDetailedRollup {get; set;}
C++
property virtual bool DoDetailedRollup {
    bool get();
    void set(bool value);
}
J#
public boolean get_DoDetailedRollup();
public void set_DoDetailedRollup(boolean);
JScript
function get DoDetailedRollup() : Boolean;
function set DoDetailedRollup(Boolean);

Property Value

If true the DSS should rollup detailed computer and update status information; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.DownloadExpressPackages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if you want to download express installation packages if they are available.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.DownloadExpressPackages

Dim sampleValue As Boolean
iUpdateServerConfiguration1.DownloadExpressPackages = sampleValue

Syntax

Visual Basic
Property DownloadExpressPackages() As Boolean
C#
bool DownloadExpressPackages {get; set;}
C++
property virtual bool DownloadExpressPackages {
    bool get();
    void set(bool value);
}
J#
public boolean get_DownloadExpressPackages();
public void set_DownloadExpressPackages(boolean);
JScript
function get DownloadExpressPackages() : Boolean;
function set DownloadExpressPackages(Boolean);

Property Value

True to download express installation packages if they are available (express packages are not available for all updates); otherwise, false.

Remarks

WSUS ignore this property if HostBinariesOnMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic is true.

Express installation files provide faster download and installation on client computers, but are larger and increase download times on the server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.DownloadUpdateBinariesAsNeeded Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if updates are downloaded only when they are approved.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.DownloadUpdateBinariesAsNeeded

Dim sampleValue As Boolean
iUpdateServerConfiguration1.DownloadUpdateBinariesAsNeeded = sampleValue

Syntax

Visual Basic
Property DownloadUpdateBinariesAsNeeded() As Boolean
C#
bool DownloadUpdateBinariesAsNeeded {get; set;}
C++
property virtual bool DownloadUpdateBinariesAsNeeded {
    bool get();
    void set(bool value);
}
J#
public boolean get_DownloadUpdateBinariesAsNeeded();
public void set_DownloadUpdateBinariesAsNeeded(boolean);
JScript
function get DownloadUpdateBinariesAsNeeded() : Boolean;
function set DownloadUpdateBinariesAsNeeded(Boolean);

Property Value

True, to download only approved updates. Otherwise, false, to download all updates after the WSUS server synchronizes with Microsoft Update.

Remarks

WSUS ignores this property if HostBinariesOnMicrosoftUpdate frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic is true.

The synchronization process downloads the update's metadata and license agreement. Once the metadata is downloaded, WSUS uses HostBinariesOnMicrosoftUpdatefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic and DownloadUpdateBinariesAsNeededfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassDownloadUpdateBinariesAsNeededTopic to determine if the update file is downloaded. If both properties are false, WSUS downloads the update file. If HostBinariesOnMicrosoftUpdatefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassHostBinariesOnMicrosoftUpdateTopic is false and DownloadUpdateBinariesAsNeededfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassDownloadUpdateBinariesAsNeededTopic is true, WSUS downloads the update file only after it is approved for deployment.

Setting DownloadUpdateBinariesAsNeededfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassDownloadUpdateBinariesAsNeededTopic to false saves disk space on the WSUS server, but may delay deployment to the clients.

An administrator can manually approve an update or create an automatic approval rule to automatically approve an update and its revisions.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ExpiredEventDetectionPeriod Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the period of time between scans for removing expired client and server events from the server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As TimeSpan
returnValue = iUpdateServerConfiguration1.ExpiredEventDetectionPeriod

Dim sampleValue As TimeSpan
iUpdateServerConfiguration1.ExpiredEventDetectionPeriod = sampleValue

Syntax

Visual Basic
Property ExpiredEventDetectionPeriod() As TimeSpan
C#
TimeSpan ExpiredEventDetectionPeriod {get; set;}
C++
property virtual TimeSpan^ ExpiredEventDetectionPeriod {
    TimeSpan^ get();
    void set(TimeSpan^ value);
}
J#
public TimeSpan get_ExpiredEventDetectionPeriod();
public void set_ExpiredEventDetectionPeriod(TimeSpan);
JScript
function get ExpiredEventDetectionPeriod() : TimeSpan;
function set ExpiredEventDetectionPeriod(TimeSpan);

Property Value

Period of time between scans for removing expired events from the server. The minimum unit of time is one hour—fractions of an hour are truncated. The maximum unit of time is 168 hours (7 days).

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The time span cannot be less than zero.

Remarks

An expired event is an event that is older than ClientEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassClientEventExpirationTimeTopic or ServerEventExpirationTime frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic.

To remove events immediately, set ExpiredEventDetectionPeriodfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassExpiredEventDetectionPeriodTopic to 0.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.GetContentFromMU Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether update binaries are downloaded from Microsoft Update (MU) or from the upstream server (USS).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.GetContentFromMU

Dim sampleValue As Boolean
iUpdateServerConfiguration1.GetContentFromMU = sampleValue

Syntax

Visual Basic
Property GetContentFromMU() As Boolean
C#
bool GetContentFromMU {get; set;}
C++
property virtual bool GetContentFromMU {
    bool get();
    void set(bool value);
}
J#
public boolean get_GetContentFromMU();
public void set_GetContentFromMU(boolean);
JScript
function get GetContentFromMU() : Boolean;
function set GetContentFromMU(Boolean);

Property Value

If true, the server will download update binaries from Microsoft Update. If false, the server will download update binaries from its upstream server.

Remarks

This option only applies if the server is a downstream server and content is downloaded locally.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.HasProxyPassword Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the proxy password is set.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.HasProxyPassword

Syntax

Visual Basic
ReadOnly Property HasProxyPassword() As Boolean
C#
bool HasProxyPassword {get;}
C++
property virtual bool HasProxyPassword {
    bool get();
}
J#
public boolean get_HasProxyPassword();
JScript
function get HasProxyPassword() : Boolean;

Property Value

True if the proxy password is set; otherwise, false.

Remarks

The proxy password is ignored if UseProxy is false, or AnonymousProxyAccess is true.

While the Proxy password cannot be directly accessed, this property will tell you if one is set or not. This can be useful in UI scenarios.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if you store updates locally or point clients directly to Microsoft Update to download the approved updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.HostBinariesOnMicrosoftUpdate

Dim sampleValue As Boolean
iUpdateServerConfiguration1.HostBinariesOnMicrosoftUpdate = sampleValue

Syntax

Visual Basic
Property HostBinariesOnMicrosoftUpdate() As Boolean
C#
bool HostBinariesOnMicrosoftUpdate {get; set;}
C++
property virtual bool HostBinariesOnMicrosoftUpdate {
    bool get();
    void set(bool value);
}
J#
public boolean get_HostBinariesOnMicrosoftUpdate();
public void set_HostBinariesOnMicrosoftUpdate(boolean);
JScript
function get HostBinariesOnMicrosoftUpdate() : Boolean;
function set HostBinariesOnMicrosoftUpdate(Boolean);

Property Value

True to store updates on Microsoft Update; otherwise, false to download and store updates on the local server. If true, WSUS downloads an update's metadata and license agreement when WSUS synchronizes with Microsoft Update.

Remarks

Storing update files locally on the WSUS server can potentially save bandwidth on your Internet connection because clients download updates directly from a WSUS server. This option requires enough disk space to store the updates that you intend to download. There is a minimum recommendation 30GB of hard disk space to store updates locally.

Storing update files on Microsoft Update and having clients download only approved updates is useful if you have mobile clients, branch offices, or any scenario in which a direct connection to the Internet exists and downloading updates over a WAN connection would introduce additional complexity. With this option, only approvals are distributed over the WAN link. Also, when you synchronize with Microsoft Update, you will get only update metadata, which describes each of the available updates—the updates themselves are never downloaded and stored on the WSUS server.

To download only approved updates, set HostBinariesOnMicrosoftUpdate to false and DownloadUpdateBinariesAsNeeded to true.

WSUS ignores the following property values if HostBinariesOnMicrosoftUpdate is true:

  • DownloadExpressPackages

  • DownloadUpdateBinariesAsNeeded

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.IsReplicaServer Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the WSUS server is a replica server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.IsReplicaServer

Dim sampleValue As Boolean
iUpdateServerConfiguration1.IsReplicaServer = sampleValue

Syntax

Visual Basic
Property IsReplicaServer() As Boolean
C#
bool IsReplicaServer {get; set;}
C++
property virtual bool IsReplicaServer {
    bool get();
    void set(bool value);
}
J#
public boolean get_IsReplicaServer();
public void set_IsReplicaServer(boolean);
JScript
function get IsReplicaServer() : Boolean;
function set IsReplicaServer(Boolean);

Property Value

True if the WSUS server is a replica server; otherwise, false.

Remarks

You specify if the server replicates an upstream server when you install WSUS; you cannot modify this setting.

A downstream server can be an autonomous server or a replica server. An autonomous server synchronizes the same updates as the upstream server; however, it can create its own target groups and manage its own approvals, and can download content from Microsoft Update or from the upstream server.

A replica server replicates the upstream server. The only difference between an upstream server and the replica server is their clients. The replica server synchronize the same updates as the upstream server, and has the same target groups, approvals, accepted license agreements (EULAs), and declined status as the upstream server.

Note that you must be on the replica server to view the status of clients of the replica server.

Automatic approval rules are disabled on the replica server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LastConfigChange Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the last time the configuration information changed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As DateTime
returnValue = iUpdateServerConfiguration1.LastConfigChange

Syntax

Visual Basic
ReadOnly Property LastConfigChange() As DateTime
C#
DateTime LastConfigChange {get;}
C++
property virtual DateTime^ LastConfigChange {
    DateTime^ get();
}
J#
public DateTime get_LastConfigChange();
JScript
function get LastConfigChange() : DateTime;

Property Value

Last time an application saved configuration information to the database. The time is in Coordinated Universal Time.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LocalContentCachePath Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the path of the local content cache.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.LocalContentCachePath

Syntax

Visual Basic
ReadOnly Property LocalContentCachePath() As String
C#
string LocalContentCachePath {get;}
C++
property virtual String^ LocalContentCachePath {
    String^ get();
}
J#
public System.String get_LocalContentCachePath();
JScript
function get LocalContentCachePath() : String;

Property Value

Local or network path of the local content cache that contains the update binaries that were downloaded from the upstream server.

Remarks

This path is used to cache newly downloaded content during the synchronization process.

To change the location of the cache, use the Move Local Content Cache feature of WsusUtil.exe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LogDestinations Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that specifies where log messages are written.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As LogDestinations
returnValue = iUpdateServerConfiguration1.LogDestinations

Dim sampleValue As LogDestinations
iUpdateServerConfiguration1.LogDestinations = sampleValue

Syntax

Visual Basic
Property LogDestinations() As LogDestinations
C#
LogDestinations LogDestinations {get; set;}
C++
property virtual LogDestinations LogDestinations {
    LogDestinations get();
    void set(LogDestinations value);
}
J#
public LogDestinations get_LogDestinations();
public void set_LogDestinations(LogDestinations);
JScript
function get LogDestinations() : LogDestinations;
function set LogDestinations(LogDestinations);

Property Value

Specifies where log messages are written. For example, log messages can be written to an attached debugger or log file. For a list of log message destinations, see LogDestinations frlrfMicrosoftUpdateServicesAdministrationLogDestinationsClassTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LogFilePath Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the path of the log file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.LogFilePath

Dim sampleValue As String
iUpdateServerConfiguration1.LogFilePath = sampleValue

Syntax

Visual Basic
Property LogFilePath() As String
C#
string LogFilePath {get; set;}
C++
property virtual String^ LogFilePath {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_LogFilePath();
public void set_LogFilePath(System.String);
JScript
function get LogFilePath() : String;
function set LogFilePath(String);

Property Value

Absolute local path of the log file. The path can include environment variables and all folders in the path must exist and have write permission. The path must include a file name.

Exceptions

Exception type | Condition
ArgumentNullException | The property value cannot be null.
ArgumentOutOfRangeException | The path must be less than 256 characters.

Remarks

The default log file is "%programfiles%\Microsoft Windows Update Services\LogFiles\SoftwareDistribution.log".

The log file is a text file. New messages append to the log file until the log file reaches 20MB (maximum log file size). When the log file reaches its maximum size, WSUS moves the current log file to <logfilename>.log.old (for example, SoftwareDistribution.log.old), replacing any previous .old file and starts a new file.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LogLevel Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the level of logging that WSUS generates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As LogLevel
returnValue = iUpdateServerConfiguration1.LogLevel

Dim sampleValue As LogLevel
iUpdateServerConfiguration1.LogLevel = sampleValue

Syntax

Visual Basic
Property LogLevel() As LogLevel
C#
LogLevel LogLevel {get; set;}
C++
property virtual LogLevel LogLevel {
    LogLevel get();
    void set(LogLevel value);
}
J#
public LogLevel get_LogLevel();
public void set_LogLevel(LogLevel);
JScript
function get LogLevel() : LogLevel;
function set LogLevel(LogLevel);

Property Value

Level of logging that WSUS generates. For a list of levels, see LogLevel frlrfMicrosoftUpdateServicesAdministrationLogLevelClassTopic.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The log level value is not valid.

Remarks

Note that increasing the level of logging can negatively affect the performance of WSUS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.LogRolloverFileSizeInBytes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the size of the log file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Integer
returnValue = iUpdateServerConfiguration1.LogRolloverFileSizeInBytes

Dim sampleValue As Integer
iUpdateServerConfiguration1.LogRolloverFileSizeInBytes = sampleValue

Syntax

Visual Basic
Property LogRolloverFileSizeInBytes() As Integer
C#
int LogRolloverFileSizeInBytes {get; set;}
C++
property virtual int LogRolloverFileSizeInBytes {
    int get();
    void set(int value);
}
J#
public int get_LogRolloverFileSizeInBytes();
public void set_LogRolloverFileSizeInBytes(int);
JScript
function get LogRolloverFileSizeInBytes() : int;
function set LogRolloverFileSizeInBytes(int);

Property Value

Size of the log file, in bytes. The default is 20000000 bytes (20MB).

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The value must be greater than zero.

Remarks

When the current log file reaches the specified file size, WSUS renames the log file to include a ".bak" extension and creates a new log file with the original name. If a log file with the .bak extension already exists, WSUS overwrites the file.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.MURollupOptin Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value indicating whether the top-level server in the server hierarchy will send data to Microsoft Update about machine properties, number of servers, number of clients, etc.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.MURollupOptin

Dim sampleValue As Boolean
iUpdateServerConfiguration1.MURollupOptin = sampleValue

Syntax

Visual Basic
Property MURollupOptin() As Boolean
C#
bool MURollupOptin {get; set;}
C++
property virtual bool MURollupOptin {
    bool get();
    void set(bool value);
}
J#
public boolean get_MURollupOptin();
public void set_MURollupOptin(boolean);
JScript
function get MURollupOptin() : Boolean;
function set MURollupOptin(Boolean);

Property Value

If true, the top-level server in the server hierarchy will send data to Microsoft Update about machine properties, number of servers, number of clients, etc. If false, the top-level server in the server hierarchy will not send data to Microsoft Update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ProxyName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the name of the proxy server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.ProxyName

Dim sampleValue As String
iUpdateServerConfiguration1.ProxyName = sampleValue

Syntax

Visual Basic
Property ProxyName() As String
C#
string ProxyName {get; set;}
C++
property virtual String^ ProxyName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ProxyName();
public void set_ProxyName(System.String);
JScript
function get ProxyName() : String;
function set ProxyName(String);

Property Value

Well-formed name of the proxy server to use to download updates. The name must be less than 256 characters. You can specify a host name or an IP address.

Exceptions

Exception type | Condition
ArgumentNullException | The property value cannot be null.
ArgumentOutOfRangeException | The name must be less than 256 characters.

Remarks

You must specify a proxy name if UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ProxyServerPort Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the port number that is used to connect to the proxy server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Integer
returnValue = iUpdateServerConfiguration1.ProxyServerPort

Dim sampleValue As Integer
iUpdateServerConfiguration1.ProxyServerPort = sampleValue

Syntax

Visual Basic
Property ProxyServerPort() As Integer
C#
int ProxyServerPort {get; set;}
C++
property virtual int ProxyServerPort {
    int get();
    void set(int value);
}
J#
public int get_ProxyServerPort();
public void set_ProxyServerPort(int);
JScript
function get ProxyServerPort() : int;
function set ProxyServerPort(int);

Property Value

Port number that is used to connect to the proxy server. The default is port 80. The port number must be greater than zero and less than 65536.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The port number must be greater than zero and less than 65536.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ProxyUserDomain Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the name of the domain that contains the user's logon account.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.ProxyUserDomain

Dim sampleValue As String
iUpdateServerConfiguration1.ProxyUserDomain = sampleValue

Syntax

Visual Basic
Property ProxyUserDomain() As String
C#
string ProxyUserDomain {get; set;}
C++
property virtual String^ ProxyUserDomain {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ProxyUserDomain();
public void set_ProxyUserDomain(System.String);
JScript
function get ProxyUserDomain() : String;
function set ProxyUserDomain(String);

Property Value

Name of the domain that contains the user's logon account. The name must be less than 256 characters.

Exceptions

Exception type | Condition
ArgumentNullException | The property value cannot be null.
ArgumentOutOfRangeException | The name must be less than 256 characters.

Remarks

User credentials are used only if UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true and AnonymousProxyAccess frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ProxyUserName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the user name to use when accessing the proxy server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.ProxyUserName

Dim sampleValue As String
iUpdateServerConfiguration1.ProxyUserName = sampleValue

Syntax

Visual Basic
Property ProxyUserName() As String
C#
string ProxyUserName {get; set;}
C++
property virtual String^ ProxyUserName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ProxyUserName();
public void set_ProxyUserName(System.String);
JScript
function get ProxyUserName() : String;
function set ProxyUserName(String);

Property Value

User name to use when accessing the proxy server. The name must be less than 256 characters.

Exceptions

Exception type | Condition
ArgumentNullException | The property value cannot be null.
ArgumentOutOfRangeException | The name must be less than 256 characters.

Remarks

User credentials are used only if UseProxy frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassUseProxyTopic is true and AnonymousProxyAccess frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false.

If AnonymousProxyAccessfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassAnonymousProxyAccessTopic is false, you must specify a user name before saving the configuration settings.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ServerEventExpirationTime Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the period of time that server events are retained before being removed from the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As TimeSpan
returnValue = iUpdateServerConfiguration1.ServerEventExpirationTime

Dim sampleValue As TimeSpan
iUpdateServerConfiguration1.ServerEventExpirationTime = sampleValue

Syntax

Visual Basic
Property ServerEventExpirationTime() As TimeSpan
C#
TimeSpan ServerEventExpirationTime {get; set;}
C++
property virtual TimeSpan^ ServerEventExpirationTime {
    TimeSpan^ get();
    void set(TimeSpan^ value);
}
J#
public TimeSpan get_ServerEventExpirationTime();
public void set_ServerEventExpirationTime(TimeSpan);
JScript
function get ServerEventExpirationTime() : TimeSpan;
function set ServerEventExpirationTime(TimeSpan);

Property Value

Period of time that server events are retained before being removed from the database. The minimum unit of time is one day—fractions of a day are truncated (the property returns only the day value). The maximum unit of time is 365 days. The default is 90 days.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The time span cannot be less than zero.

Remarks

WSUS scans for server events to remove when it receives a server event and ExpiredEventDetectionPeriod frlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassExpiredEventDetectionPeriodTopic has elapsed.

To remove events for a specific update, call PurgeAssociatedReportingEvents frlrfMicrosoftUpdateServicesAdministrationIUpdateClassPurgeAssociatedReportingEventsTopic.

To view server events, call one of the GetUpdateEventHistory frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassGetUpdateEventHistoryTopic overloads. The collection returns both client and server events. Use WsusEventSource to determine the event's origin.

WSUS uses subscription server events to generate synchronization history. The synchronization history is lost when subscription server events are removed.

Note that you can exceed the size of the database if there is a high volume of server events and you specify large value for ServerEventExpirationTimefrlrfMicrosoftUpdateServicesAdministrationIUpdateServerConfigurationClassServerEventExpirationTimeTopic.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ServerId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Guid
returnValue = iUpdateServerConfiguration1.ServerId

Dim sampleValue As Guid
iUpdateServerConfiguration1.ServerId = sampleValue

Syntax

Visual Basic
Property ServerId() As Guid
C#
Guid ServerId {get; set;}
C++
property virtual Guid^ ServerId {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_ServerId();
public void set_ServerId(Guid);
JScript
function get ServerId() : Guid;
function set ServerId(Guid);

Property Value

Unique identifier of the WSUS server. WSUS generates the identifier when WSUS is installed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.ServerString Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the string sent to the upstream server or to Microsoft Update to identify the server type.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.ServerString

Dim sampleValue As String
iUpdateServerConfiguration1.ServerString = sampleValue

Syntax

Visual Basic
Property ServerString() As String
C#
string ServerString {get; set;}
C++
property virtual String^ ServerString {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ServerString();
public void set_ServerString(System.String);
JScript
function get ServerString() : String;
function set ServerString(String);

Property Value

The string sent to the upstream server or to Microsoft Update to identify the server type.

Exceptions

Exception type | Condition
ArgumentNullException | string is null.
ArgumentOutOfRangeException | String is longer than 256 characters.

Remarks

For example, the string sent to the upstream server or to Microsoft Update may be used to distinguish between a standalone WSUS server versus another product built on top of WSUS.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SupportedUpdateLanguages Property
See Also Example
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a collection of languages that WSUS supports.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As StringCollection
returnValue = iUpdateServerConfiguration1.SupportedUpdateLanguages

Syntax

Visual Basic
ReadOnly Property SupportedUpdateLanguages() As StringCollection
C#
StringCollection SupportedUpdateLanguages {get;}
C++
property virtual StringCollection^ SupportedUpdateLanguages {
    StringCollection^ get();
}
J#
public StringCollection get_SupportedUpdateLanguages();
JScript
function get SupportedUpdateLanguages() : StringCollection;

Property Value

Collection of language codes that WSUS supports.

Example

The following example shows how to iterate through the list of languages WSUS supports. The server variable that is used in the example is an instance of IUpdateServer frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic (for information on retrieving an IUpdateServerfrlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassTopic instance, see Using WSUS).

Copy Code
IUpdateServerConfiguration configuration = server.GetConfiguration();
System.Globalization.CultureInfo culture;

foreach (String languageCode in configuration.SupportedUpdateLanguages)
{
    if (languageCode.ToLower() != "ja-nec")
    {
        culture = new System.Globalization.CultureInfo(languageCode);
        Console.WriteLine("Language code: {0} ({1})", culture.Name, culture.DisplayName);
    }
}

Remarks

The language codes follow the format specified in RFC1766. For example, "en" for English or "pt-br" for Portuguese (Brazil). WSUS supports a subset of the language codes that are specified in ISO 639 and culture codes that are specified in ISO 3166.

You can use this collection to ensure the PreferredCulture frlrfMicrosoftUpdateServicesAdministrationIUpdateServerClassPreferredCultureTopic value you specify is valid or to provide a list of localized languages that WSUS supports.

Note that WSUS stores the language codes in lowercase, so if you use StringCollection.Contains to determine if the collection contains a specific language code, you must specify the language code in lowercase (Contains performs a case-sensitive comparison).

The collection contains the "ja-nec" language code. This code is for internal use. Do not try to use it to create a CultureInfo object (the call will fail).

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.SyncFromMicrosoftUpdate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if the WSUS server synchronizes updates from Microsoft Update or a local WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.SyncFromMicrosoftUpdate

Dim sampleValue As Boolean
iUpdateServerConfiguration1.SyncFromMicrosoftUpdate = sampleValue

Syntax

Visual Basic
Property SyncFromMicrosoftUpdate() As Boolean
C#
bool SyncFromMicrosoftUpdate {get; set;}
C++
property virtual bool SyncFromMicrosoftUpdate {
    bool get();
    void set(bool value);
}
J#
public boolean get_SyncFromMicrosoftUpdate();
public void set_SyncFromMicrosoftUpdate(boolean);
JScript
function get SyncFromMicrosoftUpdate() : Boolean;
function set SyncFromMicrosoftUpdate(Boolean);

Property Value

True if the WSUS server synchronizes updates from Microsoft Update. False if the WSUS server synchronizes updates from a local WSUS server.

Remarks

You cannot set this property to true if IsReplicaServer is true.

If false, you must use UpstreamWsusServerName to specify an upstream WSUS server with which to synchronize. To specify the port to use to synchronize with the upstream server, use UpstreamWsusServerPortNumber.By default, WSUS uses HTTP over port 80. To indicate that the port is an HTTPS port, set UpstreamWsusServerUseSsl to true.

WSUS ignores the following property values if you synchronize updates with an upstream WSUS server:

  • AllUpdateLanguagesEnabled

  • Languages specified using

    • SetEnabledUpdateLanguages

    • DownloadUpdateBinariesAsNeeded

    • HostBinariesOnMicrosoftUpdate

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.TargetingMode Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the current targeting mode.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As TargetingMode
returnValue = iUpdateServerConfiguration1.TargetingMode

Dim sampleValue As TargetingMode
iUpdateServerConfiguration1.TargetingMode = sampleValue

Syntax

Visual Basic
Property TargetingMode() As TargetingMode
C#
TargetingMode TargetingMode {get; set;}
C++
property virtual TargetingMode TargetingMode {
    TargetingMode get();
    void set(TargetingMode value);
}
J#
public TargetingMode get_TargetingMode();
public void set_TargetingMode(TargetingMode);
JScript
function get TargetingMode() : TargetingMode;
function set TargetingMode(TargetingMode);

Property Value

Determines if the server decides to which group the client belongs or the client decides. For possible values, see TargetingMode frlrfMicrosoftUpdateServicesAdministrationTargetingModeClassTopic.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The specified mode is not valid.

Remarks

If the server determines the group to which the client belongs, use IComputerTargetGroup frlrfMicrosoftUpdateServicesAdministrationIComputerTargetGroupClassTopic to add a client to a group.

If the client determines the group to which it belongs, use Group Policy or registry settings on the client computer to specify the group. For details, see WSUS Product Overview.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.UpstreamWsusServerName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the name of a local server from which to synchronize updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As String
returnValue = iUpdateServerConfiguration1.UpstreamWsusServerName

Dim sampleValue As String
iUpdateServerConfiguration1.UpstreamWsusServerName = sampleValue

Syntax

Visual Basic
Property UpstreamWsusServerName() As String
C#
string UpstreamWsusServerName {get; set;}
C++
property virtual String^ UpstreamWsusServerName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_UpstreamWsusServerName();
public void set_UpstreamWsusServerName(System.String);
JScript
function get UpstreamWsusServerName() : String;
function set UpstreamWsusServerName(String);

Property Value

Well-formed name of the server from which to synchronize updates. You can specify a server name or an IP address.

Exceptions

Exception type | Condition
ArgumentException | The server name is not valid.
ArgumentNullException | The property value cannot be null.
ArgumentOutOfRangeException | The name must be less than 256 characters.

Remarks

You must specify the server name when SyncFromMicrosoftUpdate is false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.UpstreamWsusServerPortNumber Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the port number to use to communicate with the upstream WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Integer
returnValue = iUpdateServerConfiguration1.UpstreamWsusServerPortNumber

Dim sampleValue As Integer
iUpdateServerConfiguration1.UpstreamWsusServerPortNumber = sampleValue

Syntax

Visual Basic
Property UpstreamWsusServerPortNumber() As Integer
C#
int UpstreamWsusServerPortNumber {get; set;}
C++
property virtual int UpstreamWsusServerPortNumber {
    int get();
    void set(int value);
}
J#
public int get_UpstreamWsusServerPortNumber();
public void set_UpstreamWsusServerPortNumber(int);
JScript
function get UpstreamWsusServerPortNumber() : int;
function set UpstreamWsusServerPortNumber(int);

Property Value

Port number to use to communicate with the upstream WSUS server. The default is port 80. The port number must be greater than zero and less than 65536.

Exceptions

Exception type | Condition
ArgumentOutOfRangeException | The port number must be greater than zero and less than 65536.

Remarks

WSUS uses the port number if SyncFromMicrosoftUpdate is false.

Typically, you specify port 80 for HTTP and 443 for HTTPS. If you specify an HTTPS port, set UpstreamWsusServerUseSsl to true.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.UpstreamWsusServerUseSsl Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if the WSUS server should use SSL (HTTPS) to communicate with an upstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.UpstreamWsusServerUseSsl

Dim sampleValue As Boolean
iUpdateServerConfiguration1.UpstreamWsusServerUseSsl = sampleValue

Syntax

Visual Basic
Property UpstreamWsusServerUseSsl() As Boolean
C#
bool UpstreamWsusServerUseSsl {get; set;}
C++
property virtual bool UpstreamWsusServerUseSsl {
    bool get();
    void set(bool value);
}
J#
public boolean get_UpstreamWsusServerUseSsl();
public void set_UpstreamWsusServerUseSsl(boolean);
JScript
function get UpstreamWsusServerUseSsl() : Boolean;
function set UpstreamWsusServerUseSsl(Boolean);

Property Value

True to use SSL (HTTPS) to communicate with an upstream server; otherwise, false to use HTTP.

Remarks

WSUS uses the property value if SyncFromMicrosoftUpdate is false.

If you specify true, set UpstreamWsusServerPortNumber to the correct port number for SSL, which is typically 443.

For information on configuring SSL, see Configuring SSL on a Web Server or a Web Site.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateServerConfiguration.UseProxy Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets a value that indicates if you want to use a proxy to download updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateServerConfiguration1 As IUpdateServerConfiguration

Dim returnValue As Boolean
returnValue = iUpdateServerConfiguration1.UseProxy

Dim sampleValue As Boolean
iUpdateServerConfiguration1.UseProxy = sampleValue

Syntax

Visual Basic
Property UseProxy() As Boolean
C#
bool UseProxy {get; set;}
C++
property virtual bool UseProxy {
    bool get();
    void set(bool value);
}
J#
public boolean get_UseProxy();
public void set_UseProxy(boolean);
JScript
function get UseProxy() : Boolean;
function set UseProxy(Boolean);

Property Value

True to use a proxy to download updates; otherwise, false.

Remarks

To use a proxy, you must specify the proxy server name and port number to use. If the proxy server requires user credentials, also specify the user credentials to use.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateServerConfiguration Interface
IUpdateServerConfiguration Members


IUpdateSummary Interface
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve summary information regarding the number of clients in various states of installing updates. To retrieve this interface, call one of the following methods: IComputerTargetGroup.GetTotalSummary; UpdateSummaryCollection.Item.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateSummaryImplementation
    Implements IUpdateSummary
End Class
Dim updateSummaryImplementation1 As New updateSummaryImplementation()

Syntax

Visual Basic
Public Interface IUpdateSummary
C#
public interface IUpdateSummary
C++
public interface class IUpdateSummary
J#
public interface IUpdateSummary
JScript
public interface IUpdateSummary

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Members


IUpdateSummary Members
See Also Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this interface to retrieve summary information regarding the number of clients in various states of installing updates. To retrieve this interface, call one of the following methods: IComputerTargetGroup.GetTotalSummary; UpdateSummaryCollection.Item.

The following tables list the members exposed by the IUpdateSummary type.

Public Properties

 | Name | Description
public property | ComputerTargetGroupId | Retrieves the unique identifier of the target group.
public property | ComputerTargetId | Retrieves the unique identifier of the client computer.
public property | DownloadedCount | Retrieves the number of updates that have been downloaded but not installed.
public property | FailedCount | Retrieves the number of updates that failed to install.
public property | InstalledCount | Retrieves the number of updates that have been successfully installed.
public property | InstalledPendingRebootCount | Retrieves the number of updates that have been successfully installed and are pending a computer restart to finish the installation.
public property | IsSummedAcrossAllUpdates | Retrieves a value that indicates if the summary counts are summed across all updates or represent a single update.
public property | LastUpdated | Retrieves the date when the summary information was last updated.
public property | NotApplicableCount | Retrieves the number of updates that are not applicable to a client computer.
public property | NotInstalledCount | Retrieves the number of updates that are applicable to the client computer but have not been downloaded or installed.
public property | UnknownCount | Retrieves the number of updates where the current state of the installation cannot be determined.
public property | UpdateId | Retrieves the unique identifier of the update.
Top

Public Methods

 | Name | Description
public method | GetHashCode |
Top

See Also

Reference

IUpdateSummary Interface


IUpdateSummary Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods

 | Name | Description
public method | GetHashCode |

See Also

Reference

IUpdateSummary Interface


IUpdateSummary.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim iUpdateSummary1 As IUpdateSummary
returnValue = iUpdateSummary1.GetHashCode()

Syntax

Visual Basic
Function GetHashCode() As Integer
C#
                        int GetHashCode();
C++
public:
virtual int GetHashCode();
J#
public int GetHashCode();
JScript
function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ComputerTargetGroupId | Retrieves the unique identifier of the target group.
public property | ComputerTargetId | Retrieves the unique identifier of the client computer.
public property | DownloadedCount | Retrieves the number of updates that have been downloaded but not installed.
public property | FailedCount | Retrieves the number of updates that failed to install.
public property | InstalledCount | Retrieves the number of updates that have been successfully installed.
public property | InstalledPendingRebootCount | Retrieves the number of updates that have been successfully installed and are pending a computer restart to finish the installation.
public property | IsSummedAcrossAllUpdates | Retrieves a value that indicates if the summary counts are summed across all updates or represent a single update.
public property | LastUpdated | Retrieves the date when the summary information was last updated.
public property | NotApplicableCount | Retrieves the number of updates that are not applicable to a client computer.
public property | NotInstalledCount | Retrieves the number of updates that are applicable to the client computer but have not been downloaded or installed.
public property | UnknownCount | Retrieves the number of updates where the current state of the installation cannot be determined.
public property | UpdateId | Retrieves the unique identifier of the update.

See Also

Reference

IUpdateSummary Interface


IUpdateSummary.ComputerTargetGroupId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the target group.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Guid
returnValue = iUpdateSummary1.ComputerTargetGroupId

Syntax

Visual Basic
ReadOnly Property ComputerTargetGroupId() As Guid
C#
Guid ComputerTargetGroupId {get;}
C++
property virtual Guid^ ComputerTargetGroupId {
    Guid^ get();
}
J#
public Guid get_ComputerTargetGroupId();
JScript
function get ComputerTargetGroupId() : Guid;

Property Value

Unique identifier of the target group. The GUID is empty if the counts represent more than one target group.

Remarks

To retrieve the IComputerTargetGroup that is associated with the identifier, call IUpdateServer.GetComputerTargetGroup, setting id to ComputerTargetGroupId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary.ComputerTargetId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As String
returnValue = iUpdateSummary1.ComputerTargetId

Syntax

Visual Basic
ReadOnly Property ComputerTargetId() As String
C#
string ComputerTargetId {get;}
C++
property virtual String^ ComputerTargetId {
    String^ get();
}
J#
public System.String get_ComputerTargetId();
JScript
function get ComputerTargetId() : String;

Property Value

Unique identifier of the client computer. The string is empty if the counts represent more than one client computer.

Remarks

To retrieve the IComputerTarget that is associated with the identifier, call IUpdateServer.GetComputerTarget, setting id to ComputerTargetId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary.DownloadedCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that have been downloaded but not installed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.DownloadedCount

Syntax

Visual Basic
ReadOnly Property DownloadedCount() As Integer
C#
int DownloadedCount {get;}
C++
property virtual int DownloadedCount {
    int get();
}
J#
public int get_DownloadedCount();
JScript
function get DownloadedCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients that have downloaded but have not installed the update. If the summary is for a client or target group, the count represents the number of updates that have been downloaded but not installed on the client computer or on clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.FailedCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that failed to install.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.FailedCount

Syntax

Visual Basic
ReadOnly Property FailedCount() As Integer
C#
int FailedCount {get;}
C++
property virtual int FailedCount {
    int get();
}
J#
public int get_FailedCount();
JScript
function get FailedCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients that received errors while trying to deploy the update. If the summary is for a client or target group, the count represents the number of updates that failed to install on the client computer or on clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.InstalledCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that have been successfully installed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.InstalledCount

Syntax

Visual Basic
ReadOnly Property InstalledCount() As Integer
C#
int InstalledCount {get;}
C++
property virtual int InstalledCount {
    int get();
}
J#
public int get_InstalledCount();
JScript
function get InstalledCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients that have successfully installed the update. If the summary is for a client or target group, the count represents the number of updates that have successfully installed on the client computer or on clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.InstalledPendingRebootCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that have been successfully installed and are pending a computer restart to finish the installation.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.InstalledPendingRebootCount

Syntax

Visual Basic
ReadOnly Property InstalledPendingRebootCount() As Integer
C#
int InstalledPendingRebootCount {get;}
C++
property virtual int InstalledPendingRebootCount {
    int get();
}
J#
public int get_InstalledPendingRebootCount();
JScript
function get InstalledPendingRebootCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients that have successfully installed the update and are pending a computer restart to finish the installation. If the summary is for a client or target group, the count represents the number of updates that have successfully installed on the client computer or on clients within the target group and are pending a computer restart to finish the installation.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary.IsSummedAcrossAllUpdates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a value that indicates if the summary counts are summed across all updates or represent a single update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Boolean
returnValue = iUpdateSummary1.IsSummedAcrossAllUpdates

Syntax

Visual Basic
ReadOnly Property IsSummedAcrossAllUpdates() As Boolean
C#
bool IsSummedAcrossAllUpdates {get;}
C++
property virtual bool IsSummedAcrossAllUpdates {
    bool get();
}
J#
public boolean get_IsSummedAcrossAllUpdates();
JScript
function get IsSummedAcrossAllUpdates() : Boolean;

Property Value

True if the summary counts are summed across all updates; otherwise, false if the counts represent a single update.

Remarks

If false, IUpdateSummary.UpdateId identifies the update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary.LastUpdated Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the date when the summary information was last updated.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As DateTime
returnValue = iUpdateSummary1.LastUpdated

Syntax

Visual Basic
ReadOnly Property LastUpdated() As DateTime
C#
DateTime LastUpdated {get;}
C++
property virtual DateTime^ LastUpdated {
    DateTime^ get();
}
J#
public DateTime get_LastUpdated();
JScript
function get LastUpdated() : DateTime;

Property Value

Date and time when the summary information was last updated. The date is in Coordinated Universal Time.

Remarks

The date represents the time when the client reported the event that corresponds to this summary information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


IUpdateSummary.NotApplicableCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that are not applicable to a client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.NotApplicableCount

Syntax

Visual Basic
ReadOnly Property NotApplicableCount() As Integer
C#
int NotApplicableCount {get;}
C++
property virtual int NotApplicableCount {
    int get();
}
J#
public int get_NotApplicableCount();
JScript
function get NotApplicableCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients to which the update is not applicable. If the summary is for a client or target group, the count represents the number of updates that were not applicable to the client computer or to clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.NotInstalledCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates that are applicable to the client computer but have not been downloaded or installed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.NotInstalledCount

Syntax

Visual Basic
ReadOnly Property NotInstalledCount() As Integer
C#
int NotInstalledCount {get;}
C++
property virtual int NotInstalledCount {
    int get();
}
J#
public int get_NotInstalledCount();
JScript
function get NotInstalledCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients that have not installed the update. If the summary is for a client or target group, the count represents the number of applicable updates that have not been installed on the client computer or on clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.UnknownCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the number of updates where the current state of the installation cannot be determined.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Integer
returnValue = iUpdateSummary1.UnknownCount

Syntax

Visual Basic
ReadOnly Property UnknownCount() As Integer
C#
int UnknownCount {get;}
C++
property virtual int UnknownCount {
    int get();
}
J#
public int get_UnknownCount();
JScript
function get UnknownCount() : int;

Property Value

If the summary is for an update, the count represents the number of clients where the installation state of the update cannot be determined. If the summary is for a client or target group, the count represents the number of updates whose installation state cannot be determined for the client computer or for clients within the target group.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members
Microsoft.UpdateServices.Administration Namespace
UpdateInstallationState


IUpdateSummary.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the unique identifier of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim iUpdateSummary1 As IUpdateSummary

Dim returnValue As Guid
returnValue = iUpdateSummary1.UpdateId

Syntax

Visual Basic
ReadOnly Property UpdateId() As Guid
C#
Guid UpdateId {get;}
C++
property virtual Guid^ UpdateId {
    Guid^ get();
}
J#
public Guid get_UpdateId();
JScript
function get UpdateId() : Guid;

Property Value

Unique identifier of the update. The GUID is empty if IUpdateSummary.IsSummedAcrossAllUpdates is true.

Remarks

To retrieve the IUpdate that is associated with the identifier, create an UpdateRevisionId, setting UpdateRevisionId.UpdateId to UpdateId. Then, call IUpdateServer.GetUpdate, setting id to the update revision identifier that you have just created. For example,

Copy Code
update = server.GetUpdate(new UpdateRevisionId(summary.UpdateId));

where update is an IUpdate variable, server is an IUpdateServer variable, and summary is an IUpdateSummary variable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

IUpdateSummary Interface
IUpdateSummary Members


LogDestinations Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate where log messages are written.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim logDestinations1 As LogDestinations = LogDestinations.All

Syntax

Visual Basic
Public Enum LogDestinations
C#
public enum LogDestinations
C++
public enum class LogDestinations
J#
public enum LogDestinations
JScript
public enum LogDestinations

Members

Member name | Description
All | Log messages are written to all available destinations.
Debugger | Log messages are written to the debugger, if one is attached.
File | Log messages are written to the log file that is specified in IUpdateServerConfiguration.LogFilePath.
None | Turn off logging.

Remarks

You can specify one or more values.

Setting LogDestinations.None is the same as setting LogLevel.Off.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateServerConfiguration.LogDestinations
LogLevel


LogLevel Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants for specifying the logging level that you want WSUS to use.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim logLevel1 As LogLevel = LogLevel.Change

Syntax

Visual Basic
Public Enum LogLevel
C#
public enum LogLevel
C++
public enum class LogLevel
J#
public enum LogLevel
JScript
public enum LogLevel

Members

Member name | Description
Change | Output change information, warnings, and error-handling messages.
Error | Log error messages.
Info | Log error, warning, and informational messages. This is the default logging level.
Off | Turn off logging.
Verbose | Log all messages.
Warning | Log error and warning messages.

Remarks

Setting LogLevel.Off is the same as setting LogDestinations.None.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


MsrcSeverity Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants for the severity rating of the Microsoft Security Response Center (MSRC) bulletin that is associated with an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim msrcSeverity1 As MsrcSeverity = MsrcSeverity.Critical

Syntax

Visual Basic
Public Enum MsrcSeverity
C#
public enum MsrcSeverity
C++
public enum class MsrcSeverity
J#
public enum MsrcSeverity
JScript
public enum MsrcSeverity

Members

Member name | Description
Critical | The update fixes a vulnerability whose exploitation could allow for the propagation of an Internet worm without user action.
Important | The update fixes a vulnerability whose exploitation could result in the compromise of the confidentiality, integrity, or availability of users' data, or of the integrity or availability of processing resources.
Low | The update fixes a vulnerability whose exploitation is extremely difficult, or whose impact is minimal.
Moderate | The update fixes a vulnerability whose exploitation is mitigated to a significant degree by factors such as default configuration, auditing, or difficulty of exploitation.
Unspecified | The update does not have a severity rating.

Remarks

To determine the current meaning of the severity ratings, see Microsoft Security Response Center Security Bulletin Severity Rating System.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.MsrcSeverity


OSInfo Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Contains information about the operating system of the client computer. To retrieve this class, call the IComputerTarget.OSInfo property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSInfo1 As New OSInfo()

Syntax

Visual Basic
Public Class OSInfo
C#
public class OSInfo
C++
public ref class OSInfo
J#
public class OSInfo
JScript
public class OSInfo

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.OSInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSInfo Members
Microsoft.UpdateServices.Administration Namespace
IComputerTarget.OSInfo
OSVersion


OSInfo Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Contains information about the operating system of the client computer. To retrieve this class, call the IComputerTarget.OSInfo property.

The following tables list the members exposed by the OSInfo type.

Public Constructors

Name | Description
OSInfo | Overloaded.
Top

Public Properties

 | Name | Description
public property | DefaultUILanguage | Locale of the operating system.
public property | Version | Version of the operating system.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

OSInfo Class
Microsoft.UpdateServices.Administration Namespace
IComputerTarget.OSInfo
OSVersion


OSInfo Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
OSInfo () | Initializes a new instance of the OSInfo class.
OSInfo (OSVersion, String) | Initializes a new instance of the OSInfo class.

See Also

Reference

OSInfo Class
OSInfo Members


OSInfo Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the OSInfo class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSInfo1 As New OSInfo()

Syntax

Visual Basic
Public Sub New()
C#
public OSInfo();
C++
public:
OSInfo();
J#
public OSInfo();
JScript
public function OSInfo();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSInfo Class
OSInfo Members


OSInfo Constructor (OSVersion, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the OSInfo class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim version As OSVersion
Dim locale As String
Dim oSInfo1 As New OSInfo(version, locale)

Syntax

Visual Basic
Public Sub New( _
    ByVal version As OSVersion, _
    ByVal locale As String _
)
C#
public OSInfo(
    OSVersion version,
    string locale
);
C++
public:
OSInfo(
    OSVersion^ version,
    String^ locale
);
J#
public OSInfo(
    OSVersion version,
    System.String locale
);
JScript
public function OSInfo(
     version : OSVersion,
     locale : String
);

Parameters

version

Version of the operating system. For details, see OSVersion.

locale

Locale of the operating system. For example, "en".

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSInfo Class
OSInfo Members


OSInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

OSInfo Class
Microsoft.UpdateServices.Administration Namespace
IComputerTarget.OSInfo
OSVersion


OSInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | DefaultUILanguage | Locale of the operating system.
public property | Version | Version of the operating system.

See Also

Reference

OSInfo Class
Microsoft.UpdateServices.Administration Namespace
IComputerTarget.OSInfo
OSVersion


OSInfo.DefaultUILanguage Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Locale of the operating system.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSInfo1 As OSInfo

Dim returnValue As String
returnValue = oSInfo1.DefaultUILanguage

Dim sampleValue As String
oSInfo1.DefaultUILanguage = sampleValue

Syntax

Visual Basic
Public Property DefaultUILanguage() As String
C#
public string DefaultUILanguage {get; set;}
C++
public:
property String^ DefaultUILanguage {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_DefaultUILanguage();
public void set_DefaultUILanguage(System.String);
JScript
public function get DefaultUILanguage() : String;
public function set DefaultUILanguage(String);

Property Value

Locale of the operating system.

Remarks

The locale string that the client provides is of the form <language code>-<country/region code>, for example, "en-US." However, WSUS does not fully support RFC1766—WSUS supports a subset of the language and culture codes specified in ISO 639 and ISO 3166, respectively. For example, WSUS supports only "en" for English, not "en-US."

If you pass the client's locale string to WSUS methods, the methods may fail. You should always use IUpdateServerConfiguration.SupportedUpdateLanguages to ensure that WSUS supports the locale before passing the locale string to the WSUS methods. For an example, see IUpdateServer.PreferredCulture.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSInfo Class
OSInfo Members
Microsoft.UpdateServices.Administration Namespace
IUpdateServerConfiguration.SupportedUpdateLanguages


OSInfo.Version Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Version of the operating system.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSInfo1 As OSInfo

Dim returnValue As OSVersion
returnValue = oSInfo1.Version

Dim sampleValue As OSVersion
oSInfo1.Version = sampleValue

Syntax

Visual Basic
Public Property Version() As OSVersion
C#
public OSVersion Version {get; set;}
C++
public:
property OSVersion^ Version {
    OSVersion^ get();
    void set(OSVersion^ value);
}
J#
public OSVersion get_Version();
public void set_Version(OSVersion);
JScript
public function get Version() : OSVersion;
public function set Version(OSVersion);

Property Value

Version of the operating system. For details, see OSVersion.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSInfo Class
OSInfo Members


OSVersion Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the version of the operating system. To retrieve this class, call the OSInfo.Version property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As New OSVersion()

Syntax

Visual Basic
Public Class OSVersion
C#
public class OSVersion
C++
public ref class OSVersion
J#
public class OSVersion
JScript
public class OSVersion

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.OSVersion

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Members
Microsoft.UpdateServices.Administration Namespace
OSInfo


OSVersion Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the version of the operating system. To retrieve this class, call the OSInfo.Version property.

The following tables list the members exposed by the OSVersion type.

Public Constructors

Name | Description
OSVersion | Overloaded.
Top

Public Properties

 | Name | Description
public property | Build | Version number of the build.
public property | Major | Major version number of the operating system.
public property | Minor | Minor version number of the operating system.
public property | ServicePackMajor | Major version number of the service pack.
public property | ServicePackMinor | Minor version number of the service pack.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

OSVersion Class
Microsoft.UpdateServices.Administration Namespace
OSInfo


OSVersion Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
OSVersion () | Initializes a new instance of the OSVersion class.
OSVersion (Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the OSVersion class.

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the OSVersion class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As New OSVersion()

Syntax

Visual Basic
Public Sub New()
C#
public OSVersion();
C++
public:
OSVersion();
J#
public OSVersion();
JScript
public function OSVersion();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion Constructor (Int32, Int32, Int32, Int32, Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the OSVersion class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim major As Integer
Dim minor As Integer
Dim build As Integer
Dim servicePackMajor As Integer
Dim servicePackMinor As Integer
Dim oSVersion1 As New OSVersion(major, minor, build, servicePackMajor, servicePackMinor)

Syntax

Visual Basic
Public Sub New( _
    ByVal major As Integer, _
    ByVal minor As Integer, _
    ByVal build As Integer, _
    ByVal servicePackMajor As Integer, _
    ByVal servicePackMinor As Integer _
)
C#
public OSVersion(
    int major,
    int minor,
    int build,
    int servicePackMajor,
    int servicePackMinor
);
C++
public:
OSVersion(
    int major,
    int minor,
    int build,
    int servicePackMajor,
    int servicePackMinor
);
J#
public OSVersion(
    int major,
    int minor,
    int build,
    int servicePackMajor,
    int servicePackMinor
);
JScript
public function OSVersion(
     major : int,
     minor : int,
     build : int,
     servicePackMajor : int,
     servicePackMinor : int
);

Parameters

major

Major version number of the operating system.

minor

Minor version number of the operating system.

build

Version number of the build.

servicePackMajor

Major version number of the service pack.

servicePackMinor

Minor version number of the service pack.

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

OSVersion Class
Microsoft.UpdateServices.Administration Namespace
OSInfo


OSVersion Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Build | Version number of the build.
public property | Major | Major version number of the operating system.
public property | Minor | Minor version number of the operating system.
public property | ServicePackMajor | Major version number of the service pack.
public property | ServicePackMinor | Minor version number of the service pack.

See Also

Reference

OSVersion Class
Microsoft.UpdateServices.Administration Namespace
OSInfo


OSVersion.Build Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Version number of the build.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As OSVersion

Dim returnValue As Integer
returnValue = oSVersion1.Build

Dim sampleValue As Integer
oSVersion1.Build = sampleValue

Syntax

Visual Basic
Public Property Build() As Integer
C#
public int Build {get; set;}
C++
public:
property int Build {
    int get();
    void set(int value);
}
J#
public int get_Build();
public void set_Build(int);
JScript
public function get Build() : int;
public function set Build(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion.Major Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Major version number of the operating system.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As OSVersion

Dim returnValue As Integer
returnValue = oSVersion1.Major

Dim sampleValue As Integer
oSVersion1.Major = sampleValue

Syntax

Visual Basic
Public Property Major() As Integer
C#
public int Major {get; set;}
C++
public:
property int Major {
    int get();
    void set(int value);
}
J#
public int get_Major();
public void set_Major(int);
JScript
public function get Major() : int;
public function set Major(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion.Minor Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Minor version number of the operating system.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As OSVersion

Dim returnValue As Integer
returnValue = oSVersion1.Minor

Dim sampleValue As Integer
oSVersion1.Minor = sampleValue

Syntax

Visual Basic
Public Property Minor() As Integer
C#
public int Minor {get; set;}
C++
public:
property int Minor {
    int get();
    void set(int value);
}
J#
public int get_Minor();
public void set_Minor(int);
JScript
public function get Minor() : int;
public function set Minor(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion.ServicePackMajor Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Major version number of the service pack.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As OSVersion

Dim returnValue As Integer
returnValue = oSVersion1.ServicePackMajor

Dim sampleValue As Integer
oSVersion1.ServicePackMajor = sampleValue

Syntax

Visual Basic
Public Property ServicePackMajor() As Integer
C#
public int ServicePackMajor {get; set;}
C++
public:
property int ServicePackMajor {
    int get();
    void set(int value);
}
J#
public int get_ServicePackMajor();
public void set_ServicePackMajor(int);
JScript
public function get ServicePackMajor() : int;
public function set ServicePackMajor(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


OSVersion.ServicePackMinor Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Minor version number of the service pack.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim oSVersion1 As OSVersion

Dim returnValue As Integer
returnValue = oSVersion1.ServicePackMinor

Dim sampleValue As Integer
oSVersion1.ServicePackMinor = sampleValue

Syntax

Visual Basic
Public Property ServicePackMinor() As Integer
C#
public int ServicePackMinor {get; set;}
C++
public:
property int ServicePackMinor {
    int get();
    void set(int value);
}
J#
public int get_ServicePackMinor();
public void set_ServicePackMinor(int);
JScript
public function get ServicePackMinor() : int;
public function set ServicePackMinor(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

OSVersion Class
OSVersion Members


PackagePublicationState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Publication State for the Package (optional)

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packagePublicationState1 As PackagePublicationState = PackagePublicationState.Expired

Syntax

Visual Basic
Public Enum PackagePublicationState
C#
public enum PackagePublicationState
C++
public enum class PackagePublicationState
J#
public enum PackagePublicationState
JScript
public enum PackagePublicationState

Members

Member name | Description
Expired | Expired state
Published | Published state

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


PackagePublisherOperationCanceledException Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packagePublisherOperationCanceledException1 As New PackagePublisherOperationCanceledException()

Syntax

Visual Basic
Public Class PackagePublisherOperationCanceledException
    Inherits Exception
C#
public class PackagePublisherOperationCanceledException : Exception
C++
public ref class PackagePublisherOperationCanceledException : Exception
J#
public class PackagePublisherOperationCanceledException extends Exception
JScript
public class PackagePublisherOperationCanceledException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.UpdateServices.Administration.PackagePublisherOperationCanceledException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the PackagePublisherOperationCanceledException type.

Public Constructors

Name | Description
PackagePublisherOperationCanceledException | Overloaded. Initializes a new instance of the PackagePublisherOperationCanceledException class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )
Top

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

PackagePublisherOperationCanceledException Class


PackagePublisherOperationCanceledException Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PackagePublisherOperationCanceledException class.

Overload List

Name | Description
PackagePublisherOperationCanceledException () | Initializes a new instance of the PackagePublisherOperationCanceledException class.
PackagePublisherOperationCanceledException (Exception) | Initializes a new instance of the PackagePublisherOperationCanceledException class.
PackagePublisherOperationCanceledException (String) | Initializes a new instance of the PackagePublisherOperationCanceledException class.
PackagePublisherOperationCanceledException (String, Exception) | Initializes a new instance of the PackagePublisherOperationCanceledException class.

See Also

Reference

PackagePublisherOperationCanceledException Class
PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PackagePublisherOperationCanceledException class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packagePublisherOperationCanceledException1 As New PackagePublisherOperationCanceledException()

Syntax

Visual Basic
Public Sub New()
C#
public PackagePublisherOperationCanceledException();
C++
public:
PackagePublisherOperationCanceledException();
J#
public PackagePublisherOperationCanceledException();
JScript
public function PackagePublisherOperationCanceledException();

Remarks

A default exception message will be used.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PackagePublisherOperationCanceledException Class
PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Constructor (Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PackagePublisherOperationCanceledException class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim innerException As Exception
Dim packagePublisherOperationCanceledException1 As New PackagePublisherOperationCanceledException(innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal innerException As Exception _
)
C#
public PackagePublisherOperationCanceledException(
    Exception innerException
);
C++
public:
PackagePublisherOperationCanceledException(
    Exception^ innerException
);
J#
public PackagePublisherOperationCanceledException(
    Exception innerException
);
JScript
public function PackagePublisherOperationCanceledException(
     innerException : Exception
);

Parameters

innerException

The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Remarks

A default exception message will be used.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PackagePublisherOperationCanceledException Class
PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PackagePublisherOperationCanceledException class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim packagePublisherOperationCanceledException1 As New PackagePublisherOperationCanceledException(message)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String _
)
C#
public PackagePublisherOperationCanceledException(
    string message
);
C++
public:
PackagePublisherOperationCanceledException(
    String^ message
);
J#
public PackagePublisherOperationCanceledException(
    System.String message
);
JScript
public function PackagePublisherOperationCanceledException(
     message : String
);

Parameters

message

The message that describes the error.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PackagePublisherOperationCanceledException Class
PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Constructor (String, Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PackagePublisherOperationCanceledException class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception
Dim packagePublisherOperationCanceledException1 As New PackagePublisherOperationCanceledException(message, innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String, _
    ByVal innerException As Exception _
)
C#
public PackagePublisherOperationCanceledException(
    string message,
    Exception innerException
);
C++
public:
PackagePublisherOperationCanceledException(
    String^ message,
    Exception^ innerException
);
J#
public PackagePublisherOperationCanceledException(
    System.String message,
    Exception innerException
);
JScript
public function PackagePublisherOperationCanceledException(
     message : String,
     innerException : Exception
);

Parameters

message

The message that describes the error.

innerException

The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PackagePublisherOperationCanceledException Class
PackagePublisherOperationCanceledException Members


PackagePublisherOperationCanceledException Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

PackagePublisherOperationCanceledException Class


PackagePublisherOperationCanceledException Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )

See Also

Reference

PackagePublisherOperationCanceledException Class


PackageType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Type of this package

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packageType1 As PackageType = PackageType.Application

Syntax

Visual Basic
Public Enum PackageType
C#
public enum PackageType
C++
public enum class PackageType
J#
public enum PackageType
JScript
public enum PackageType

Members

Member name | Description
Application |
Update |

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


PackageUpdateClassification Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The classification of the update as specified by the SE cabinet.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packageUpdateClassification1 As PackageUpdateClassification = PackageUpdateClassification.CriticalUpdates

Syntax

Visual Basic
Public Enum PackageUpdateClassification
C#
public enum PackageUpdateClassification
C++
public enum class PackageUpdateClassification
J#
public enum PackageUpdateClassification
JScript
public enum PackageUpdateClassification

Members

Member name | Description
CriticalUpdates | A broadly released fix for a specific problem addressing a critical, non-security related bug.
Drivers | A driver package.
FeaturePacks | New product functionality that is first distributed outside the context of a product release, and usually included in the next full product release.
Hotfixes | Hotfixes address a specific customer situation and may not be distributed outside that customer organization.
SecurityUpdates | A broadly released fix for a product-specific, security-related vulnerability. Security vulnerabilities are rated based on their severity, which is indicated in the Microsoft security bulletin as critical, important, moderate, or low.
ServicePacks | A tested, cumulative set of all hotfixes, security updates, critical updates, and updates, as well as additional fixes for problems found internally since the release of the product. Service packs may also contain a limited number of customer-requested design changes or features.
Tools | A utility or feature that aids in accomplishing a task or set of tasks.
UpdateRollups | A tested, cumulative set of hotfixes, security updates, critical updates, and updates packaged together for easy deployment. A rollup generally targets a specific area, such as security, or a component of a product, such as Internet Information Services (IIS).
Updates | A broadly released fix for a specific problem addressing a noncritical, non-security-related bug.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


ProgramKey Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Information of ProgramKey

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim programKey1 As New ProgramKey()

Syntax

Visual Basic
Public Class ProgramKey
C#
public class ProgramKey
C++
public ref class ProgramKey
J#
public class ProgramKey
JScript
public class ProgramKey

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ProgramKey

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Members


ProgramKey Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Information of ProgramKey

The following tables list the members exposed by the ProgramKey type.

Public Constructors (see also Protected Constructors )

Name | Description
ProgramKey | Overloaded. Initializes a new instance of the ProgramKey class.
Top

Protected Constructors

Name | Description
ProgramKey | Overloaded. Initializes a new instance of the ProgramKey class.
Top

Public Properties

 | Name | Description
public property | Description | Retrieves or sets the key description.
public property | Key | Retrieves or sets the program key.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden. Compares this object against another object to see if they are equal.
public method | GetHashCode | Overridden. Serves as a hash function for a ProgramKey, suitable for using in hashing algorithms and data structures like a hash table.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ProgramKey Class


ProgramKey Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ProgramKey class.

Overload List

Name | Description
ProgramKey () | Initializes a new instance of the ProgramKey class.
ProgramKey (Guid) | Constructor
ProgramKey (Guid, String) | Constructor.

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ProgramKey class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim programKey1 As New ProgramKey()

Syntax

Visual Basic
Protected Sub New()
C#
protected ProgramKey();
C++
protected:
ProgramKey();
J#
protected ProgramKey();
JScript
protected function ProgramKey();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey Constructor (Guid)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim guid As Guid
Dim programKey1 As New ProgramKey(guid)

Syntax

Visual Basic
Public Sub New( _
    ByVal guid As Guid _
)
C#
public ProgramKey(
    Guid guid
);
C++
public:
ProgramKey(
    Guid^ guid
);
J#
public ProgramKey(
    Guid guid
);
JScript
public function ProgramKey(
     guid : Guid
);

Parameters

guid

The Key.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey Constructor (Guid, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim guid As Guid
Dim description As String
Dim programKey1 As New ProgramKey(guid, description)

Syntax

Visual Basic
Public Sub New( _
    ByVal guid As Guid, _
    ByVal description As String _
)
C#
public ProgramKey(
    Guid guid,
    string description
);
C++
public:
ProgramKey(
    Guid^ guid,
    String^ description
);
J#
public ProgramKey(
    Guid guid,
    System.String description
);
JScript
public function ProgramKey(
     guid : Guid,
     description : String
);

Parameters

guid

The key.

description

Description of the key.

Exceptions

Exception type | Condition
ArgumentNullException | description is a null reference.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden. Compares this object against another object to see if they are equal.
public method | GetHashCode | Overridden. Serves as a hash function for a ProgramKey, suitable for using in hashing algorithms and data structures like a hash table.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ProgramKey Class


ProgramKey.Equals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Compares this object against another object to see if they are equal.

Overload List

Name | Description
ProgramKey.Equals (Object) | Compares this object against another object to see if they are equal.
ProgramKey.Equals (Object, Object) |

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey.Equals Method (Object)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Compares this object against another object to see if they are equal.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As Object
Dim returnValue As Boolean
Dim programKey1 As ProgramKey
returnValue = programKey1.Equals(value)

Syntax

Visual Basic
Overloads Public Overrides Function Equals( _
    ByVal value As Object _
) As Boolean
C#
public override bool Equals(
    object value
);
C++
public:
virtual bool Equals(
    Object^ value
) override;
J#
public override boolean Equals(
    System.Object value
);
JScript
public override function Equals(
     value : Object
) : Boolean;

Parameters

value

The object to compare against.

Return Value

Returns true if value is also a ProgramKey object and its Key and Description match this instance exactly; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Serves as a hash function for a ProgramKey, suitable for using in hashing algorithms and data structures like a hash table.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim programKey1 As ProgramKey
returnValue = programKey1.GetHashCode()

Syntax

Visual Basic
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode();
C++
public:
virtual int GetHashCode() override;
J#
public override int GetHashCode();
JScript
public override function GetHashCode() : int;

Return Value

A hash code for the current ProgramKey.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Description | Retrieves or sets the key description.
public property | Key | Retrieves or sets the program key.

See Also

Reference

ProgramKey Class


ProgramKey.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the key description.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim programKey1 As ProgramKey

Dim returnValue As String
returnValue = programKey1.Description

Dim sampleValue As String
programKey1.Description = sampleValue

Syntax

Visual Basic
Public Property Description() As String
C#
public string Description {get; set;}
C++
public:
property String^ Description {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Description();
public void set_Description(System.String);
JScript
public function get Description() : String;
public function set Description(String);

Property Value

The key description.

Exceptions

Exception type | Condition
ArgumentNullException | The property value is a null reference.
ArgumentOutOfRangeException | The property value is longer than 256.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


ProgramKey.Key Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the program key.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim programKey1 As ProgramKey

Dim returnValue As Guid
returnValue = programKey1.Key

Dim sampleValue As Guid
programKey1.Key = sampleValue

Syntax

Visual Basic
Public Property Key() As Guid
C#
public Guid Key {get; set;}
C++
public:
property Guid^ Key {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_Key();
public void set_Key(Guid);
JScript
public function get Key() : Guid;
public function set Key(Guid);

Property Value

The program key as a GUID value.

Exceptions

Exception type | Condition
ArgumentException | Guid is a empty Guid.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ProgramKey Class
ProgramKey Members


PublicationState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the publication states of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publicationState1 As PublicationState = PublicationState.Expired

Syntax

Visual Basic
Public Enum PublicationState
C#
public enum PublicationState
C++
public enum class PublicationState
J#
public enum PublicationState
JScript
public enum PublicationState

Members

Member name | Description
Expired | Indicates that the update is not deployable. The publisher of the update no longer wants the update to be deployed (this may occur if the publisher finds a problem with the update).
Published | Indicates that the update is deployable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.PublicationState


PublishingEventArgs Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Event Class containing information specific to the progress event

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As New PublishingEventArgs()

Syntax

Visual Basic
Public Class PublishingEventArgs
    Inherits EventArgs
C#
public class PublishingEventArgs : EventArgs
C++
public ref class PublishingEventArgs : EventArgs
J#
public class PublishingEventArgs extends EventArgs
JScript
public class PublishingEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.UpdateServices.Administration.PublishingEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Members


PublishingEventArgs Members
See Also Constructors Fields Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Event Class containing information specific to the progress event

The following tables list the members exposed by the PublishingEventArgs type.

Public Constructors

Name | Description
PublishingEventArgs | Overloaded.
Top

Public Fields

Name | Description
Empty | (Inherited from EventArgs )
Top

Public Properties

 | Name | Description
public property | CurrentProgress | Get/Set the Current Progress value for this operation
public property | ProgressInfo | Get/Set any additional information about the progress event
public property | ProgressStep | Get/Set the PublishingProcessProgressStep for this event
public property | UpperProgressBound | Get/Set the Upper Progress value for this operation
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

PublishingEventArgs Class


PublishingEventArgs Fields
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Fields

Name | Description
Empty | (Inherited from EventArgs )

See Also

Reference

PublishingEventArgs Class


PublishingEventArgs Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
PublishingEventArgs () | Initializes a new instance of the PublishingEventArgs class.
PublishingEventArgs (PublishingProcessProgressStep, String, Int64, Int64) | Initializes a new instance of the PublishingEventArgs class.

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PublishingEventArgs class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As New PublishingEventArgs()

Syntax

Visual Basic
Public Sub New()
C#
public PublishingEventArgs();
C++
public:
PublishingEventArgs();
J#
public PublishingEventArgs();
JScript
public function PublishingEventArgs();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs Constructor (PublishingProcessProgressStep, String, Int64, Int64)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the PublishingEventArgs class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim step As PublishingProcessProgressStep
Dim info As String
Dim current As Long
Dim upperBound As Long
Dim publishingEventArgs1 As New PublishingEventArgs(step, info, current, upperBound)

Syntax

Visual Basic
Public Sub New( _
    ByVal step As PublishingProcessProgressStep, _
    ByVal info As String, _
    ByVal current As Long, _
    ByVal upperBound As Long _
)
C#
public PublishingEventArgs(
    PublishingProcessProgressStep step,
    string info,
    long current,
    long upperBound
);
C++
public:
PublishingEventArgs(
    PublishingProcessProgressStep step,
    String^ info,
    long long current,
    long long upperBound
);
J#
public PublishingEventArgs(
    PublishingProcessProgressStep step,
    System.String info,
    long current,
    long upperBound
);
JScript
public function PublishingEventArgs(
     step : PublishingProcessProgressStep,
     info : String,
     current : long,
     upperBound : long
);

Parameters

step

The PublishingProcessProgressStep for this progress event

info

Additional information related to the progress step for this event

current

Current progress value

upperBound

Upper Progress value, when the 'current' progress reaches this value the step is complete

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

PublishingEventArgs Class


PublishingEventArgs Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | CurrentProgress | Get/Set the Current Progress value for this operation
public property | ProgressInfo | Get/Set any additional information about the progress event
public property | ProgressStep | Get/Set the PublishingProcessProgressStep for this event
public property | UpperProgressBound | Get/Set the Upper Progress value for this operation

See Also

Reference

PublishingEventArgs Class


PublishingEventArgs.CurrentProgress Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the Current Progress value for this operation

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As PublishingEventArgs

Dim returnValue As Long
returnValue = publishingEventArgs1.CurrentProgress

Dim sampleValue As Long
publishingEventArgs1.CurrentProgress = sampleValue

Syntax

Visual Basic
Public Property CurrentProgress() As Long
C#
public long CurrentProgress {get; set;}
C++
public:
property long long CurrentProgress {
    long long get();
    void set(long long value);
}
J#
public long get_CurrentProgress();
public void set_CurrentProgress(long);
JScript
public function get CurrentProgress() : long;
public function set CurrentProgress(long);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs.ProgressInfo Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set any additional information about the progress event

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As PublishingEventArgs

Dim returnValue As String
returnValue = publishingEventArgs1.ProgressInfo

Dim sampleValue As String
publishingEventArgs1.ProgressInfo = sampleValue

Syntax

Visual Basic
Public Property ProgressInfo() As String
C#
public string ProgressInfo {get; set;}
C++
public:
property String^ ProgressInfo {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_ProgressInfo();
public void set_ProgressInfo(System.String);
JScript
public function get ProgressInfo() : String;
public function set ProgressInfo(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs.ProgressStep Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the PublishingProcessProgressStep for this event

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As PublishingEventArgs

Dim returnValue As PublishingProcessProgressStep
returnValue = publishingEventArgs1.ProgressStep

Dim sampleValue As PublishingProcessProgressStep
publishingEventArgs1.ProgressStep = sampleValue

Syntax

Visual Basic
Public Property ProgressStep() As PublishingProcessProgressStep
C#
public PublishingProcessProgressStep ProgressStep {get; set;}
C++
public:
property PublishingProcessProgressStep ProgressStep {
    PublishingProcessProgressStep get();
    void set(PublishingProcessProgressStep value);
}
J#
public PublishingProcessProgressStep get_ProgressStep();
public void set_ProgressStep(PublishingProcessProgressStep);
JScript
public function get ProgressStep() : PublishingProcessProgressStep;
public function set ProgressStep(PublishingProcessProgressStep);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingEventArgs.UpperProgressBound Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the Upper Progress value for this operation

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingEventArgs1 As PublishingEventArgs

Dim returnValue As Long
returnValue = publishingEventArgs1.UpperProgressBound

Dim sampleValue As Long
publishingEventArgs1.UpperProgressBound = sampleValue

Syntax

Visual Basic
Public Property UpperProgressBound() As Long
C#
public long UpperProgressBound {get; set;}
C++
public:
property long long UpperProgressBound {
    long long get();
    void set(long long value);
}
J#
public long get_UpperProgressBound();
public void set_UpperProgressBound(long);
JScript
public function get UpperProgressBound() : long;
public function set UpperProgressBound(long);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

PublishingEventArgs Class
PublishingEventArgs Members


PublishingProcessProgressStep Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Enumeration showing the current step that the Publishing Process is working on.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim publishingProcessProgressStep1 As PublishingProcessProgressStep = PublishingProcessProgressStep.CopyFile

Syntax

Visual Basic
Public Enum PublishingProcessProgressStep
C#
public enum PublishingProcessProgressStep
C++
public enum class PublishingProcessProgressStep
J#
public enum PublishingProcessProgressStep
JScript
public enum PublishingProcessProgressStep

Members

Member name | Description
CopyFile | Copying files to the package directory structure
CreateCab | Creating cabs for the package
CreateDirectory | Creating the directory structure for the package being published
ExpandCab | Expanding cabs when publishing a pre signed package
Initializing | Initializing the publishing process, calculating size and file information
PublishPackage | Publishing the package
SignCab | Signing cabs for the package

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


RebootBehavior Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the computer restart behavior of an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim rebootBehavior1 As RebootBehavior = RebootBehavior.AlwaysRequiresReboot

Syntax

Visual Basic
Public Enum RebootBehavior
C#
public enum RebootBehavior
C++
public enum class RebootBehavior
J#
public enum RebootBehavior
JScript
public enum RebootBehavior

Members

Member name | Description
AlwaysRequiresReboot | The update requires the user to restart the computer after the update is installed or uninstalled. The user may restart the computer after installing or uninstalling other updates in the update bundle.
CanRequestReboot | The update may require the user to restart the computer during or after the update is installed or uninstalled. The user may restart the computer after installing or uninstalling other updates in the update bundle.
NeverReboots | The update does not require the user to restart the computer during or after the update is installed or uninstalled.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
InstallationBehavior.RebootBehavior


ReturnCode Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As New ReturnCode()

Syntax

Visual Basic
Public Class ReturnCode
C#
public class ReturnCode
C++
public ref class ReturnCode
J#
public class ReturnCode
JScript
public class ReturnCode

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ReturnCode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Members


ReturnCode Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the ReturnCode type.

Public Constructors

Name | Description
ReturnCode | Default constructor.
Top

Public Properties

 | Name | Description
public property | Description | Get/Set description Note: Language must be set before Description. Otherwise an InvalidOperationException will be thrown.
public property | InstallationResult | Get/Set installation result Default:
public property | IsRebootRequired | Get/Set IsRebootRequired.
public property | Language | Get/Set Language
public property | ReturnCodeValue | Get/Set return-code value
public property | SupportedLanguage | Get supported languages.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ReturnCode Class


ReturnCode Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As New ReturnCode()

Syntax

Visual Basic
Public Sub New()
C#
public ReturnCode();
C++
public:
ReturnCode();
J#
public ReturnCode();
JScript
public function ReturnCode();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ReturnCode Class


ReturnCode Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Description | Get/Set description Note: Language must be set before Description. Otherwise an InvalidOperationException will be thrown.
public property | InstallationResult | Get/Set installation result Default:
public property | IsRebootRequired | Get/Set IsRebootRequired.
public property | Language | Get/Set Language
public property | ReturnCodeValue | Get/Set return-code value
public property | SupportedLanguage | Get supported languages.

See Also

Reference

ReturnCode Class


ReturnCode.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set description Note: Language must be set before Description. Otherwise an InvalidOperationException will be thrown.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As String
returnValue = returnCode1.Description

Dim sampleValue As String
returnCode1.Description = sampleValue

Syntax

Visual Basic
Public Property Description() As String
C#
public string Description {get; set;}
C++
public:
property String^ Description {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Description();
public void set_Description(System.String);
JScript
public function get Description() : String;
public function set Description(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode.InstallationResult Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set installation result Default:

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As InstallationResult
returnValue = returnCode1.InstallationResult

Dim sampleValue As InstallationResult
returnCode1.InstallationResult = sampleValue

Syntax

Visual Basic
Public Property InstallationResult() As InstallationResult
C#
public InstallationResult InstallationResult {get; set;}
C++
public:
property InstallationResult InstallationResult {
    InstallationResult get();
    void set(InstallationResult value);
}
J#
public InstallationResult get_InstallationResult();
public void set_InstallationResult(InstallationResult);
JScript
public function get InstallationResult() : InstallationResult;
public function set InstallationResult(InstallationResult);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode.IsRebootRequired Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set IsRebootRequired.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As Boolean
returnValue = returnCode1.IsRebootRequired

Dim sampleValue As Boolean
returnCode1.IsRebootRequired = sampleValue

Syntax

Visual Basic
Public Property IsRebootRequired() As Boolean
C#
public bool IsRebootRequired {get; set;}
C++
public:
property bool IsRebootRequired {
    bool get();
    void set(bool value);
}
J#
public boolean get_IsRebootRequired();
public void set_IsRebootRequired(boolean);
JScript
public function get IsRebootRequired() : Boolean;
public function set IsRebootRequired(Boolean);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode.Language Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Language

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As String
returnValue = returnCode1.Language

Dim sampleValue As String
returnCode1.Language = sampleValue

Syntax

Visual Basic
Public Property Language() As String
C#
public string Language {get; set;}
C++
public:
property String^ Language {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Language();
public void set_Language(System.String);
JScript
public function get Language() : String;
public function set Language(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode.ReturnCodeValue Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set return-code value

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As Integer
returnValue = returnCode1.ReturnCodeValue

Dim sampleValue As Integer
returnCode1.ReturnCodeValue = sampleValue

Syntax

Visual Basic
Public Property ReturnCodeValue() As Integer
C#
public int ReturnCodeValue {get; set;}
C++
public:
property int ReturnCodeValue {
    int get();
    void set(int value);
}
J#
public int get_ReturnCodeValue();
public void set_ReturnCodeValue(int);
JScript
public function get ReturnCodeValue() : int;
public function set ReturnCodeValue(int);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


ReturnCode.SupportedLanguage Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get supported languages.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnCode1 As ReturnCode

Dim returnValue As StringCollection
returnValue = returnCode1.SupportedLanguage

Syntax

Visual Basic
Public ReadOnly Property SupportedLanguage() As StringCollection
C#
public StringCollection SupportedLanguage {get;}
C++
public:
property StringCollection^ SupportedLanguage {
    StringCollection^ get();
}
J#
public StringCollection get_SupportedLanguage();
JScript
public function get SupportedLanguage() : StringCollection;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ReturnCode Class
ReturnCode Members


RevisionChanges Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that are used to indicate the revisions that were made to an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim revisionChanges1 As RevisionChanges = RevisionChanges.ApplicabilityRules

Syntax

Visual Basic
Public Enum RevisionChanges
C#
public enum RevisionChanges
C++
public enum class RevisionChanges
J#
public enum RevisionChanges
JScript
public enum RevisionChanges

Members

Member name | Description
ApplicabilityRules | The update's applicability rules, prerequisites, or both applicability rules and prerequisites were revised. This change affects the clients to which the update is now applicable.
DescriptiveProperties | The update revised one or more of the following properties: IUpdate.AdditionalInformationUrls; IUpdate.Description; IUpdate.KnowledgeBaseArticles; IUpdate.MsrcSeverity; IUpdate.SecurityBulletins; IUpdate.Title.
Eula |
Expired | The update is expired. The publisher marks the update as expired when they do not want the update to be deployed.
FileBinaries | The binaries for the update were revised.
InstallationInformation | The update revised one or more of the following properties: IUpdate.InstallationBehavior; IUpdate.UninstallationBehavior; IUpdate.IsWsusInfrastructureUpdate. This value can also be set if the update is a bundled update and if one or more of the bundled update identifiers are changed.
None | No revisions were made to the update.
SupersededUpdates | One or more of the updates superseded by this update were revised.

Remarks

Some revision changes can generate false positives. For example, this can happen if the order of the attributes changed from one revision to the next, but there is no material differences between the attributes. The following table identifies those changes that can generate false positives.

Change | How a false positive can be returned
ApplicabilityRules | The order of the applicability rules, prerequisites, or both applicability rules and prerequisites changed; however, there is no material differences in the rules or prerequisites.
DescriptiveProperties | The order of the additional information URLs, knowledge base articles, or security bulletins changed; however, there is no material differences in the lists. For example, the list of security bulletins for the revision is the same as the last revision, only the order of the bulletin numbers changed.
EULA | The order of the end-user license agreement attributes changed; however, there is no material differences in the attributes.
InstallationInformation | The order of the installation or removal behavior changed; however, there is no material differences in the behaviors.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.GetChangesFromPreviousRevision


ScriptUtilities Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines a series of utilities for com clients scripting against the Windows Server Update Services API.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim scriptUtilities1 As New ScriptUtilities()

Syntax

Visual Basic
NotInheritable Public Class ScriptUtilities
C#
public sealed class ScriptUtilities
C++
public ref class ScriptUtilities sealed
J#
public final class ScriptUtilities
JScript
public class ScriptUtilities

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.ScriptUtilities

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Members


ScriptUtilities Members
See Also Constructors Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines a series of utilities for com clients scripting against the Windows Server Update Services API.

The following tables list the members exposed by the ScriptUtilities type.

Public Constructors

Name | Description
ScriptUtilities | Initializes a new instance of the ScriptUtilities class.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | ConvertEnumStringToInt | Converts an enum type and value string to the actual value.
public method | ConvertIntToEnumString | Converts an int enumeration value to it's name.
public method | ConvertStringToDateTime | Converts a string with a formatted DateTime value to a DateTime.
public method | ConvertStringToGuid | Converts a string with a formatted guid value to a guid.
public method | ConvertStringToTimeSpan | Converts a string with a formatted TimeSpan value to a TimeSpan.
public method | ConvertToString |
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

ScriptUtilities Class


ScriptUtilities Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the ScriptUtilities class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim scriptUtilities1 As New ScriptUtilities()

Syntax

Visual Basic
Public Sub New()
C#
public ScriptUtilities();
C++
public:
ScriptUtilities();
J#
public ScriptUtilities();
JScript
public function ScriptUtilities();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | ConvertEnumStringToInt | Converts an enum type and value string to the actual value.
public method | ConvertIntToEnumString | Converts an int enumeration value to it's name.
public method | ConvertStringToDateTime | Converts a string with a formatted DateTime value to a DateTime.
public method | ConvertStringToGuid | Converts a string with a formatted guid value to a guid.
public method | ConvertStringToTimeSpan | Converts a string with a formatted TimeSpan value to a TimeSpan.
public method | ConvertToString |
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

ScriptUtilities Class


ScriptUtilities.ConvertEnumStringToInt Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Converts an enum type and value string to the actual value.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim enumValueName As String
Dim returnValue As Integer
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertEnumStringToInt(enumValueName)

Syntax

Visual Basic
Public Function ConvertEnumStringToInt( _
    ByVal enumValueName As String _
) As Integer
C#
public int ConvertEnumStringToInt(
    string enumValueName
);
C++
public:
int ConvertEnumStringToInt(
    String^ enumValueName
);
J#
public int ConvertEnumStringToInt(
    System.String enumValueName
);
JScript
public function ConvertEnumStringToInt(
     enumValueName : String
) : int;

Parameters

enumValueName

The enum type and value.

Return Value

Int representing the enum type and value.

Remarks

enumValueName should contain the name of the enum and it's value. You do not need to specify "Microsoft.UpdateServices.Administration", as it is assumed by the the api. For example, to get the int value of the LogLevel enum, use "LogLevel.Verbose"

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities.ConvertIntToEnumString Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Converts an int enumeration value to it's name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim enumTypeName As String
Dim enumValue As Integer
Dim returnValue As String
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertIntToEnumString(enumTypeName, enumValue)

Syntax

Visual Basic
Public Function ConvertIntToEnumString( _
    ByVal enumTypeName As String, _
    ByVal enumValue As Integer _
) As String
C#
public string ConvertIntToEnumString(
    string enumTypeName,
    int enumValue
);
C++
public:
String^ ConvertIntToEnumString(
    String^ enumTypeName,
    int enumValue
);
J#
public System.String ConvertIntToEnumString(
    System.String enumTypeName,
    int enumValue
);
JScript
public function ConvertIntToEnumString(
     enumTypeName : String,
     enumValue : int
) : String;

Parameters

enumTypeName

The enum type the value represents.

enumValue

The value of the enum to be converted to string.

Return Value

The name of the value for the enum.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities.ConvertStringToDateTime Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Converts a string with a formatted DateTime value to a DateTime.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As String
Dim returnValue As DateTime
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertStringToDateTime(value)

Syntax

Visual Basic
Public Function ConvertStringToDateTime( _
    ByVal value As String _
) As DateTime
C#
public DateTime ConvertStringToDateTime(
    string value
);
C++
public:
DateTime^ ConvertStringToDateTime(
    String^ value
);
J#
public DateTime ConvertStringToDateTime(
    System.String value
);
JScript
public function ConvertStringToDateTime(
     value : String
) : DateTime;

Parameters

value

The string with the formatted DateTime value.

Return Value

A DateTime with the value of the DateTime in the string.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities.ConvertStringToGuid Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Converts a string with a formatted guid value to a guid.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As String
Dim returnValue As Guid
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertStringToGuid(value)

Syntax

Visual Basic
Public Function ConvertStringToGuid( _
    ByVal value As String _
) As Guid
C#
public Guid ConvertStringToGuid(
    string value
);
C++
public:
Guid^ ConvertStringToGuid(
    String^ value
);
J#
public Guid ConvertStringToGuid(
    System.String value
);
JScript
public function ConvertStringToGuid(
     value : String
) : Guid;

Parameters

value

The string w/ the formatted guid value.

Return Value

A guid with the value of the guid in the string.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities.ConvertStringToTimeSpan Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Converts a string with a formatted TimeSpan value to a TimeSpan.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As String
Dim returnValue As TimeSpan
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertStringToTimeSpan(value)

Syntax

Visual Basic
Public Function ConvertStringToTimeSpan( _
    ByVal value As String _
) As TimeSpan
C#
public TimeSpan ConvertStringToTimeSpan(
    string value
);
C++
public:
TimeSpan^ ConvertStringToTimeSpan(
    String^ value
);
J#
public TimeSpan ConvertStringToTimeSpan(
    System.String value
);
JScript
public function ConvertStringToTimeSpan(
     value : String
) : TimeSpan;

Parameters

value

The string with the formatted TimeSpan value.

Return Value

A TimeSpan with the value of the TimeSpan in the string.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


ScriptUtilities.ConvertToString Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim o As Object
Dim returnValue As String
Dim scriptUtilities1 As ScriptUtilities
returnValue = scriptUtilities1.ConvertToString(o)

Syntax

Visual Basic
Public Function ConvertToString( _
    ByVal o As Object _
) As String
C#
public string ConvertToString(
    object o
);
C++
public:
String^ ConvertToString(
    Object^ o
);
J#
public System.String ConvertToString(
    System.Object o
);
JScript
public function ConvertToString(
     o : Object
) : String;

Parameters

o

Object to be converted to string.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

ScriptUtilities Class
ScriptUtilities Members


SecurityRating Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The maximum severity rating of the Microsoft Security Response Center (MSRC) bulletin associated with the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim securityRating1 As SecurityRating = SecurityRating.Critical

Syntax

Visual Basic
Public Enum SecurityRating
C#
public enum SecurityRating
C++
public enum class SecurityRating
J#
public enum SecurityRating
JScript
public enum SecurityRating

Members

Member name | Description
Critical |
Important |
Low |
Moderate |
None |

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


SubscriptionEventCategory Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that are the possible categories for a subscription event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim subscriptionEventCategory1 As SubscriptionEventCategory = SubscriptionEventCategory.SubscriptionModification

Syntax

Visual Basic
Public Enum SubscriptionEventCategory
C#
public enum SubscriptionEventCategory
C++
public enum class SubscriptionEventCategory
J#
public enum SubscriptionEventCategory
JScript
public enum SubscriptionEventCategory

Members

Member name | Description
SubscriptionModification | This event relates to the modification of the subscription.
SynchronizationCompletion | This event relates to the completion of the synchronization process.
SynchronizationStart | This event relates to the start of the synchronization process.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.EventCategory


SubscriptionEventCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of subscription events. To retrieve the collection, call one of the following methods: ISubscription.GetEventHistory(); ISubscription.GetEventHistory(DateTime, DateTime).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim subscriptionEventCollection1 As New SubscriptionEventCollection()

Syntax

Visual Basic
Public Class SubscriptionEventCollection
    Inherits WsusCollection
C#
public class SubscriptionEventCollection : WsusCollection
C++
public ref class SubscriptionEventCollection : WsusCollection
J#
public class SubscriptionEventCollection extends WsusCollection
JScript
public class SubscriptionEventCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.SubscriptionEventCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Members


SubscriptionEventCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of subscription events. To retrieve the collection, call one of the following methods: ISubscription.GetEventHistory(); ISubscription.GetEventHistory(DateTime, DateTime).

The following tables list the members exposed by the SubscriptionEventCollection type.

Public Constructors

Name | Description
SubscriptionEventCollection | Initializes a new instance of the SubscriptionEventCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

SubscriptionEventCollection Class


SubscriptionEventCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the SubscriptionEventCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim subscriptionEventCollection1 As New SubscriptionEventCollection()

Syntax

Visual Basic
Public Sub New()
C#
public SubscriptionEventCollection();
C++
public:
SubscriptionEventCollection();
J#
public SubscriptionEventCollection();
JScript
public function SubscriptionEventCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

SubscriptionEventCollection Class


SubscriptionEventCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.Add (ISubscriptionEvent) | Adds a subscription event to the end of the collection.
SubscriptionEventCollection.Add (Object) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Add Method (ISubscriptionEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a subscription event to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISubscriptionEvent
Dim returnValue As Integer
Dim subscriptionEventCollection1 As SubscriptionEventCollection
returnValue = subscriptionEventCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As ISubscriptionEvent _
) As Integer
C#
public int Add(
    ISubscriptionEvent value
);
C++
public:
int Add(
    ISubscriptionEvent^ value
);
J#
public int Add(
    ISubscriptionEvent value
);
JScript
public function Add(
     value : ISubscriptionEvent
) : int;

Parameters

value

An ISubscriptionEvent of the subscription event to add.

Return Value

Zero-based index at which the subscription event was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The subscription event already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.AddRange (Array) |
SubscriptionEventCollection.AddRange (ISubscriptionEvent[]) | Adds an array of subscription events to the end of the collection.
SubscriptionEventCollection.AddRange (SubscriptionEventCollection) | Adds the members of a subscription event collection to the end of the collection.
SubscriptionEventCollection.AddRange (WsusCollection) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.AddRange Method (ISubscriptionEvent[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of subscription events to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As ISubscriptionEvent
Dim subscriptionEventCollection1 As SubscriptionEventCollection
subscriptionEventCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As ISubscriptionEvent _
)
C#
public void AddRange(
    ISubscriptionEvent[] value
);
C++
public:
void AddRange(
    array<ISubscriptionEvent^>^ value
);
J#
public void AddRange(
    ISubscriptionEvent[] value
);
JScript
public function AddRange(
     value : ISubscriptionEvent[]
) : Void;

Parameters

value

Array of ISubscriptionEvent to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.AddRange Method (SubscriptionEventCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a subscription event collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SubscriptionEventCollection
Dim subscriptionEventCollection1 As SubscriptionEventCollection
subscriptionEventCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As SubscriptionEventCollection _
)
C#
public void AddRange(
    SubscriptionEventCollection value
);
C++
public:
void AddRange(
    SubscriptionEventCollection^ value
);
J#
public void AddRange(
    SubscriptionEventCollection value
);
JScript
public function AddRange(
     value : SubscriptionEventCollection
) : Void;

Parameters

value

A SubscriptionEventCollection collection of subscription events to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.Contains (ISubscriptionEvent) | Determines if the collection contains the specified subscription event.
SubscriptionEventCollection.Contains (Object) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Contains Method (ISubscriptionEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified subscription event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISubscriptionEvent
Dim returnValue As Boolean
Dim subscriptionEventCollection1 As SubscriptionEventCollection
returnValue = subscriptionEventCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As ISubscriptionEvent _
) As Boolean
C#
public bool Contains(
    ISubscriptionEvent value
);
C++
public:
bool Contains(
    ISubscriptionEvent^ value
);
J#
public boolean Contains(
    ISubscriptionEvent value
);
JScript
public function Contains(
     value : ISubscriptionEvent
) : Boolean;

Parameters

value

An ISubscriptionEvent of the subscription event to locate in the collection.

Return Value

True if the collection contains the subscription event; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.CopyTo (Array, Int32) |
SubscriptionEventCollection.CopyTo (ISubscriptionEvent[], Int32) | Copies the subscription events in the collection to a one-dimensional array.

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.CopyTo Method (ISubscriptionEvent[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the subscription events in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As ISubscriptionEvent
Dim index As Integer
Dim subscriptionEventCollection1 As SubscriptionEventCollection
subscriptionEventCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As ISubscriptionEvent, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    ISubscriptionEvent[] array,
    int index
);
C++
public:
void CopyTo(
    array<ISubscriptionEvent^>^ array,
    int index
);
J#
public void CopyTo(
    ISubscriptionEvent[] array,
    int index
);
JScript
public function CopyTo(
     array : ISubscriptionEvent[],
     index : int
) : Void;

Parameters

array

Array of ISubscriptionEvent found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the subscription events.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.IndexOf (ISubscriptionEvent) | Determines if the collection contains the specified subscription event. If the collection contains the subscription event, the method returns the zero-based index to the subscription event in the collection.
SubscriptionEventCollection.IndexOf (Object) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.IndexOf Method (ISubscriptionEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified subscription event. If the collection contains the subscription event, the method returns the zero-based index to the subscription event in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISubscriptionEvent
Dim returnValue As Integer
Dim subscriptionEventCollection1 As SubscriptionEventCollection
returnValue = subscriptionEventCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As ISubscriptionEvent _
) As Integer
C#
public int IndexOf(
    ISubscriptionEvent value
);
C++
public:
int IndexOf(
    ISubscriptionEvent^ value
);
J#
public int IndexOf(
    ISubscriptionEvent value
);
JScript
public function IndexOf(
     value : ISubscriptionEvent
) : int;

Parameters

value

An ISubscriptionEvent of the subscription event to locate in the collection.

Return Value

Zero-based index of the subscription event in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.Insert (Int32, ISubscriptionEvent) | Inserts a subscription event into the collection.
SubscriptionEventCollection.Insert (Int32, Object) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Insert Method (Int32, ISubscriptionEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts a subscription event into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As ISubscriptionEvent
Dim subscriptionEventCollection1 As SubscriptionEventCollection
subscriptionEventCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As ISubscriptionEvent _
)
C#
public void Insert(
    int index,
    ISubscriptionEvent value
);
C++
public:
void Insert(
    int index,
    ISubscriptionEvent^ value
);
J#
public void Insert(
    int index,
    ISubscriptionEvent value
);
JScript
public function Insert(
     index : int,
     value : ISubscriptionEvent
) : Void;

Parameters

index

Zero-based index at which to insert the subscription event into the collection.

value

An ISubscriptionEvent of the subscription event to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The subscription event already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SubscriptionEventCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SubscriptionEventCollection.Remove (ISubscriptionEvent) | Removes the subscription event from the collection.
SubscriptionEventCollection.Remove (Object) |

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection.Remove Method (ISubscriptionEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the subscription event from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISubscriptionEvent
Dim subscriptionEventCollection1 As SubscriptionEventCollection
subscriptionEventCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As ISubscriptionEvent _
)
C#
public void Remove(
    ISubscriptionEvent value
);
C++
public:
void Remove(
    ISubscriptionEvent^ value
);
J#
public void Remove(
    ISubscriptionEvent value
);
JScript
public function Remove(
     value : ISubscriptionEvent
) : Void;

Parameters

value

An ISubscriptionEvent of the subscription event to remove.

Exceptions

Exception type | Condition
ArgumentException | The subscription event does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SubscriptionEventCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

SubscriptionEventCollection Class


SubscriptionEventCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim subscriptionEventCollection1 As SubscriptionEventCollection

Dim key As Integer
Dim returnValue As ISubscriptionEvent
returnValue = subscriptionEventCollection1.Item(key)

Dim sampleValue As ISubscriptionEvent
subscriptionEventCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As ISubscriptionEvent
C#
public new ISubscriptionEvent this[
    int index
] {get; set;}
C++
public:
property ISubscriptionEvent^ default[int] {
    ISubscriptionEvent^ get(int index);
    void set(int index, ISubscriptionEvent^ value);
}
J#
new public ISubscriptionEvent get_Item(
    int index
);
public void set_Item(
    int index
ISubscriptionEvent);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The subscription event already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SubscriptionEventCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SubscriptionEventCollection Class
SubscriptionEventCollection Members


SynchronizationError Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate what caused the synchronization process to fail.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationError1 As SynchronizationError = SynchronizationError.ApprovalError

Syntax

Visual Basic
Public Enum SynchronizationError
C#
public enum SynchronizationError
C++
public enum class SynchronizationError
J#
public enum SynchronizationError
JScript
public enum SynchronizationError

Members

Member name | Description
ApprovalError | Occurs on a replica server when one or more updates failed to be approved for an unknown reason.
DssAuthenticationError | The upstream server requires authentication.
ImportUpdateError | One or more errors occurred when trying to import updates into the local database. To retrieve a list of the errors, call ISynchronizationInfo.UpdateErrors.
IncompatibleProtocolVersion | The downstream server's protocol version is incompatible with the protocol version required by the upstream server. Typically, this occurs when the version of WSUS on the downstream server is too old. Please update the downstream server to a more current version of WSUS.
LocalDbConnectFail | Unable to connect to the local database.
LocalDbOtherError | A generic database error has occurred.
LocalDbTooBusy | Unable to execute a stored procedure on the local database.
LocalUpdateMissingForApproval | Occurs on replica servers when an update that the upstream server deployed is missing from the current server. The synchronization process should be retried at a later time.
NotApplicable | There is no error.
ProxyError | An error has occurred while using the proxy settings.
Unknown | An unknown error has occurred.
UserCanceled | The user has canceled the synchronization process.
UssBusy | The upstream server is too busy to process the request. .NET or the upstream server can generate the error.
UssCommunicationError | The upstream server has received an unrecoverable HTTP status code.
UssInternalError | The upstream server is unable to handle the request at this time. Resend the request at a later time. If the problem persists, contact the administrator of the upstream server.
UssNotFound | Unable to resolve the specified upstream server.
UssOtherError | The upstream server is unable to handle the request at this time. Resend the request at a later time. If the problem persists, contact the administrator of the upstream server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
ISubscriptionEvent.Error
ISynchronizationInfo.Error


SynchronizationInfoCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of synchronization information. To retrieve the collection, call one of the following methods: ISubscription.GetSynchronizationHistory() ; ISubscription.GetSynchronizationHistory(DateTime, DateTime).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationInfoCollection1 As New SynchronizationInfoCollection()

Syntax

Visual Basic
Public Class SynchronizationInfoCollection
    Inherits WsusCollection
C#
public class SynchronizationInfoCollection : WsusCollection
C++
public ref class SynchronizationInfoCollection : WsusCollection
J#
public class SynchronizationInfoCollection extends WsusCollection
JScript
public class SynchronizationInfoCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.SynchronizationInfoCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Members


SynchronizationInfoCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of synchronization information. To retrieve the collection, call one of the following methods: ISubscription.GetSynchronizationHistory() ; ISubscription.GetSynchronizationHistory(DateTime, DateTime).

The following tables list the members exposed by the SynchronizationInfoCollection type.

Public Constructors

Name | Description
SynchronizationInfoCollection | Initializes a new instance of the SynchronizationInfoCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

SynchronizationInfoCollection Class


SynchronizationInfoCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the SynchronizationInfoCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationInfoCollection1 As New SynchronizationInfoCollection()

Syntax

Visual Basic
Public Sub New()
C#
public SynchronizationInfoCollection();
C++
public:
SynchronizationInfoCollection();
J#
public SynchronizationInfoCollection();
JScript
public function SynchronizationInfoCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

SynchronizationInfoCollection Class


SynchronizationInfoCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.Add (ISynchronizationInfo) | Adds synchronization information to the end of the collection.
SynchronizationInfoCollection.Add (Object) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Add Method (ISynchronizationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds synchronization information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISynchronizationInfo
Dim returnValue As Integer
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
returnValue = synchronizationInfoCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As ISynchronizationInfo _
) As Integer
C#
public int Add(
    ISynchronizationInfo value
);
C++
public:
int Add(
    ISynchronizationInfo^ value
);
J#
public int Add(
    ISynchronizationInfo value
);
JScript
public function Add(
     value : ISynchronizationInfo
) : int;

Parameters

value

An ISynchronizationInfo of the synchronization information to add.

Return Value

Zero-based index at which the synchronization information was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The synchronization information already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.AddRange (Array) |
SynchronizationInfoCollection.AddRange (ISynchronizationInfo[]) | Adds an array of synchronization information to the end of the collection.
SynchronizationInfoCollection.AddRange (SynchronizationInfoCollection) | Adds the members of a synchronization information collection to the end of the collection.
SynchronizationInfoCollection.AddRange (WsusCollection) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.AddRange Method (ISynchronizationInfo[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of synchronization information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As ISynchronizationInfo
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
synchronizationInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As ISynchronizationInfo _
)
C#
public void AddRange(
    ISynchronizationInfo[] value
);
C++
public:
void AddRange(
    array<ISynchronizationInfo^>^ value
);
J#
public void AddRange(
    ISynchronizationInfo[] value
);
JScript
public function AddRange(
     value : ISynchronizationInfo[]
) : Void;

Parameters

value

Array of ISynchronizationInfo to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.AddRange Method (SynchronizationInfoCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a synchronization information collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationInfoCollection
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
synchronizationInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As SynchronizationInfoCollection _
)
C#
public void AddRange(
    SynchronizationInfoCollection value
);
C++
public:
void AddRange(
    SynchronizationInfoCollection^ value
);
J#
public void AddRange(
    SynchronizationInfoCollection value
);
JScript
public function AddRange(
     value : SynchronizationInfoCollection
) : Void;

Parameters

value

A SynchronizationInfoCollection collection of synchronization information to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.Contains (ISynchronizationInfo) | Determines if the collection contains the specified synchronization information.
SynchronizationInfoCollection.Contains (Object) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Contains Method (ISynchronizationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified synchronization information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISynchronizationInfo
Dim returnValue As Boolean
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
returnValue = synchronizationInfoCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As ISynchronizationInfo _
) As Boolean
C#
public bool Contains(
    ISynchronizationInfo value
);
C++
public:
bool Contains(
    ISynchronizationInfo^ value
);
J#
public boolean Contains(
    ISynchronizationInfo value
);
JScript
public function Contains(
     value : ISynchronizationInfo
) : Boolean;

Parameters

value

An ISynchronizationInfo of the synchronization information to locate in the collection.

Return Value

True if the collection contains the synchronization information; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.CopyTo (Array, Int32) |
SynchronizationInfoCollection.CopyTo (ISynchronizationInfo[], Int32) | Copies the synchronization information in the collection to a one-dimensional array.

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.CopyTo Method (ISynchronizationInfo[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the synchronization information in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As ISynchronizationInfo
Dim index As Integer
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
synchronizationInfoCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As ISynchronizationInfo, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    ISynchronizationInfo[] array,
    int index
);
C++
public:
void CopyTo(
    array<ISynchronizationInfo^>^ array,
    int index
);
J#
public void CopyTo(
    ISynchronizationInfo[] array,
    int index
);
JScript
public function CopyTo(
     array : ISynchronizationInfo[],
     index : int
) : Void;

Parameters

array

Array of ISynchronizationInfo found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the synchronization information.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.IndexOf (ISynchronizationInfo) | Determines if the collection contains the specified synchronization information. If the collection contains the synchronization information, the method returns the zero-based index to the synchronization information in the collection.
SynchronizationInfoCollection.IndexOf (Object) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.IndexOf Method (ISynchronizationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified synchronization information. If the collection contains the synchronization information, the method returns the zero-based index to the synchronization information in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISynchronizationInfo
Dim returnValue As Integer
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
returnValue = synchronizationInfoCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As ISynchronizationInfo _
) As Integer
C#
public int IndexOf(
    ISynchronizationInfo value
);
C++
public:
int IndexOf(
    ISynchronizationInfo^ value
);
J#
public int IndexOf(
    ISynchronizationInfo value
);
JScript
public function IndexOf(
     value : ISynchronizationInfo
) : int;

Parameters

value

An ISubscriptionEvent of the synchronization information to locate in the collection.

Return Value

Zero-based index of the synchronization information in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.Insert (Int32, ISynchronizationInfo) | Inserts synchronization information into the collection.
SynchronizationInfoCollection.Insert (Int32, Object) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Insert Method (Int32, ISynchronizationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts synchronization information into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As ISynchronizationInfo
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
synchronizationInfoCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As ISynchronizationInfo _
)
C#
public void Insert(
    int index,
    ISynchronizationInfo value
);
C++
public:
void Insert(
    int index,
    ISynchronizationInfo^ value
);
J#
public void Insert(
    int index,
    ISynchronizationInfo value
);
JScript
public function Insert(
     index : int,
     value : ISynchronizationInfo
) : Void;

Parameters

index

Zero-based index at which to insert the synchronization information into the collection.

value

An ISynchronizationInfo of the synchronization information to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The synchronization information already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SynchronizationInfoCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationInfoCollection.Remove (ISynchronizationInfo) | Removes the synchronization information from the collection.
SynchronizationInfoCollection.Remove (Object) |

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection.Remove Method (ISynchronizationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the synchronization information from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As ISynchronizationInfo
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection
synchronizationInfoCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As ISynchronizationInfo _
)
C#
public void Remove(
    ISynchronizationInfo value
);
C++
public:
void Remove(
    ISynchronizationInfo^ value
);
J#
public void Remove(
    ISynchronizationInfo value
);
JScript
public function Remove(
     value : ISynchronizationInfo
) : Void;

Parameters

value

An ISynchronizationInfo of the synchronization information to remove.

Exceptions

Exception type | Condition
ArgumentException | The synchronization information does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationInfoCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

SynchronizationInfoCollection Class


SynchronizationInfoCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationInfoCollection1 As SynchronizationInfoCollection

Dim key As Integer
Dim returnValue As ISynchronizationInfo
returnValue = synchronizationInfoCollection1.Item(key)

Dim sampleValue As ISynchronizationInfo
synchronizationInfoCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As ISynchronizationInfo
C#
public new ISynchronizationInfo this[
    int index
] {get; set;}
C++
public:
property ISynchronizationInfo^ default[int] {
    ISynchronizationInfo^ get(int index);
    void set(int index, ISynchronizationInfo^ value);
}
J#
new public ISynchronizationInfo get_Item(
    int index
);
public void set_Item(
    int index
ISynchronizationInfo);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The synchronization information already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SynchronizationInfoCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationInfoCollection Class
SynchronizationInfoCollection Members


SynchronizationPhase Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the content that the downstream server is currently synchronizing with the upstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationPhase1 As SynchronizationPhase = SynchronizationPhase.Approvals

Syntax

Visual Basic
Public Enum SynchronizationPhase
C#
public enum SynchronizationPhase
C++
public enum class SynchronizationPhase
J#
public enum SynchronizationPhase
JScript
public enum SynchronizationPhase

Members

Member name | Description
Approvals | The downstream server is currently synchronizing deployments with the upstream server. This phase occurs only on downstream replica servers.
Categories | Subscription is running and processing categories
NotProcessing | The downstream server is currently not synchronizing updates or deployments with the upstream server.
Updates | The downstream server is currently synchronizing updates with the upstream server.

Remarks

The Updates phase always occurs before the Approvals phase.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
SynchronizationProgress.SynchronizationPhase


SynchronizationProgress Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the progress of synchronizing update metadata and deployments to a WSUS server. If the server is a replica server, the synchronization process occurs in two phases: the first phase synchronizes the update metadata, and the second phase synchronizes the deployments. Otherwise, the server synchronizes only update metadata. The progress information reflects only the synchronization progress of the current phase, not all phases of the synchronization process. To retrieve this class, call ISubscription.GetSynchronizationProgress.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim totalItems As Integer
Dim processedItems As Integer
Dim phase As SynchronizationPhase
Dim synchronizationProgress1 As New SynchronizationProgress(totalItems, processedItems, phase)

Syntax

Visual Basic
Public Class SynchronizationProgress
C#
public class SynchronizationProgress
C++
public ref class SynchronizationProgress
J#
public class SynchronizationProgress
JScript
public class SynchronizationProgress

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.SynchronizationProgress

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationProgress Members
Microsoft.UpdateServices.Administration Namespace
ISubscription.GetSynchronizationProgress


SynchronizationProgress Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the progress of synchronizing update metadata and deployments to a WSUS server. If the server is a replica server, the synchronization process occurs in two phases: the first phase synchronizes the update metadata, and the second phase synchronizes the deployments. Otherwise, the server synchronizes only update metadata. The progress information reflects only the synchronization progress of the current phase, not all phases of the synchronization process. To retrieve this class, call ISubscription.GetSynchronizationProgress.

The following tables list the members exposed by the SynchronizationProgress type.

Public Constructors

Name | Description
SynchronizationProgress | Initialize a new instance of the SynchronizationProgress class.
Top

Public Properties

 | Name | Description
public property | Phase | Identifies the content that the downstream server is currently synchronizing with the upstream server.
public property | ProcessedItems | Number of updates or deployments that have been synchronized so far.
public property | TotalItems | Total number of updates or deployments to synchronize.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

SynchronizationProgress Class
Microsoft.UpdateServices.Administration Namespace
ISubscription.GetSynchronizationProgress


SynchronizationProgress Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initialize a new instance of the SynchronizationProgress class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim totalItems As Integer
Dim processedItems As Integer
Dim phase As SynchronizationPhase
Dim synchronizationProgress1 As New SynchronizationProgress(totalItems, processedItems, phase)

Syntax

Visual Basic
Public Sub New( _
    ByVal totalItems As Integer, _
    ByVal processedItems As Integer, _
    ByVal phase As SynchronizationPhase _
)
C#
public SynchronizationProgress(
    int totalItems,
    int processedItems,
    SynchronizationPhase phase
);
C++
public:
SynchronizationProgress(
    int totalItems,
    int processedItems,
    SynchronizationPhase phase
);
J#
public SynchronizationProgress(
    int totalItems,
    int processedItems,
    SynchronizationPhase phase
);
JScript
public function SynchronizationProgress(
     totalItems : int,
     processedItems : int,
     phase : SynchronizationPhase
);

Parameters

totalItems

Total number of updates or deployments to synchronize.

processedItems

Number of updates or deployments that have been synchronized so far.

phase

Identifies the content that the downstream server is currently synchronizing with the upstream server. For possible values, see SynchronizationPhase.

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationProgress Class
SynchronizationProgress Members


SynchronizationProgress Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

SynchronizationProgress Class
Microsoft.UpdateServices.Administration Namespace
ISubscription.GetSynchronizationProgress


SynchronizationProgress Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Phase | Identifies the content that the downstream server is currently synchronizing with the upstream server.
public property | ProcessedItems | Number of updates or deployments that have been synchronized so far.
public property | TotalItems | Total number of updates or deployments to synchronize.

See Also

Reference

SynchronizationProgress Class
Microsoft.UpdateServices.Administration Namespace
ISubscription.GetSynchronizationProgress


SynchronizationProgress.Phase Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifies the content that the downstream server is currently synchronizing with the upstream server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationProgress1 As SynchronizationProgress

Dim returnValue As SynchronizationPhase
returnValue = synchronizationProgress1.Phase

Syntax

Visual Basic
Public ReadOnly Property Phase() As SynchronizationPhase
C#
public SynchronizationPhase Phase {get;}
C++
public:
property SynchronizationPhase Phase {
    SynchronizationPhase get();
}
J#
public SynchronizationPhase get_Phase();
JScript
public function get Phase() : SynchronizationPhase;

Property Value

Content that the downstream server is currently synchronizing with the upstream server. For possible values, see SynchronizationPhase.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationProgress Class
SynchronizationProgress Members


SynchronizationProgress.ProcessedItems Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates or deployments that have been synchronized so far.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationProgress1 As SynchronizationProgress

Dim returnValue As Integer
returnValue = synchronizationProgress1.ProcessedItems

Syntax

Visual Basic
Public ReadOnly Property ProcessedItems() As Integer
C#
public int ProcessedItems {get;}
C++
public:
property int ProcessedItems {
    int get();
}
J#
public int get_ProcessedItems();
JScript
public function get ProcessedItems() : int;

Property Value

Number of updates or deployments that have been synchronized so far. To determine if the number of processed items represents synchronized updates or deployments, call SynchronizationProgress.Phase.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationProgress Class
SynchronizationProgress Members
Microsoft.UpdateServices.Administration Namespace
SynchronizationProgress.TotalItems


SynchronizationProgress.TotalItems Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Total number of updates or deployments to synchronize.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationProgress1 As SynchronizationProgress

Dim returnValue As Integer
returnValue = synchronizationProgress1.TotalItems

Syntax

Visual Basic
Public ReadOnly Property TotalItems() As Integer
C#
public int TotalItems {get;}
C++
public:
property int TotalItems {
    int get();
}
J#
public int get_TotalItems();
JScript
public function get TotalItems() : int;

Property Value

Total number of updates or deployments to synchronize. To determine if the total represents updates or deployments, call SynchronizationProgress.Phase.

Remarks

The total for the approval phase is the sum of:

  • Number of approvals to add

  • Number of approvals to remove

  • Number of target groups on the upstream server

  • One count for end-user license agreement (EULA) approval processing

  • One count for declined update processing

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationProgress Class
SynchronizationProgress Members
Microsoft.UpdateServices.Administration Namespace
SynchronizationProgress.ProcessedItems


SynchronizationResult Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the result of the synchronization process.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationResult1 As SynchronizationResult = SynchronizationResult.Canceled

Syntax

Visual Basic
Public Enum SynchronizationResult
C#
public enum SynchronizationResult
C++
public enum class SynchronizationResult
J#
public enum SynchronizationResult
JScript
public enum SynchronizationResult

Members

Member name | Description
Canceled | The synchronization process has been canceled.
Failed | The synchronization process has failed.
NeverRun | The synchronization process has never run.
Succeeded | The synchronization process has successfully completed.
Unknown | The synchronization process has ended for an unknown reason.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
ISynchronizationInfo.Result
SynchronizationStatus


SynchronizationStatus Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate if the synchronization process is currently running.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationStatus1 As SynchronizationStatus = SynchronizationStatus.NotProcessing

Syntax

Visual Basic
Public Enum SynchronizationStatus
C#
public enum SynchronizationStatus
C++
public enum class SynchronizationStatus
J#
public enum SynchronizationStatus
JScript
public enum SynchronizationStatus

Members

Member name | Description
NotProcessing | The synchronization process is not running.
Running | The synchronization process is running.
Stopping | The synchronization process is stopping. Stopping occurs when the process ends normally, ISubscription.StopSynchronization is called, or a synchronization error has occurred.

Remarks

The synchronization process transitions from Running to Stopping to NotProcessing. All synchronization events are not available until the status is NotProcessing.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
ISubscription.GetSynchronizationStatus()
SynchronizationResult


SynchronizationUpdateError Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the reason for the update failure.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateError1 As SynchronizationUpdateError = SynchronizationUpdateError.DependencyNotFound

Syntax

Visual Basic
Public Enum SynchronizationUpdateError
C#
public enum SynchronizationUpdateError
C++
public enum class SynchronizationUpdateError
J#
public enum SynchronizationUpdateError
JScript
public enum SynchronizationUpdateError

Members

Member name | Description
DependencyNotFound | The update is dependent on another update that was not found on the WSUS server and was not provided by an upstream server.
MetadataInvalid | The metadata for the update is not valid and could not be processed by the database.
Unknown | The error is unknown.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
SynchronizationUpdateErrorInfo.Error


SynchronizationUpdateErrorInfo Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this class to determine why an update failed. To retrieve this class, call SynchronizationUpdateErrorInfoCollection.Item or enumerate through the SynchronizationUpdateErrorInfoCollection collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateId As UpdateRevisionId
Dim error As SynchronizationUpdateError
Dim errorText As String
Dim synchronizationUpdateErrorInfo1 As New SynchronizationUpdateErrorInfo(updateId, error, errorText)

Syntax

Visual Basic
Public Class SynchronizationUpdateErrorInfo
C#
public class SynchronizationUpdateErrorInfo
C++
public ref class SynchronizationUpdateErrorInfo
J#
public class SynchronizationUpdateErrorInfo
JScript
public class SynchronizationUpdateErrorInfo

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.SynchronizationUpdateErrorInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use this class to determine why an update failed. To retrieve this class, call SynchronizationUpdateErrorInfoCollection.Item or enumerate through the SynchronizationUpdateErrorInfoCollection collection.

The following tables list the members exposed by the SynchronizationUpdateErrorInfo type.

Public Constructors

Name | Description
SynchronizationUpdateErrorInfo | Initialize a new instance of the SynchronizationUpdateErrorInfo class.
Top

Public Properties

 | Name | Description
public property | Error | Error that occurred while processing the update.
public property | ErrorText | Description of the error that occurred while processing the update.
public property | UpdateId | Identifier that identifies the failed update.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

SynchronizationUpdateErrorInfo Class


SynchronizationUpdateErrorInfo Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initialize a new instance of the SynchronizationUpdateErrorInfo class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateId As UpdateRevisionId
Dim error As SynchronizationUpdateError
Dim errorText As String
Dim synchronizationUpdateErrorInfo1 As New SynchronizationUpdateErrorInfo(updateId, error, errorText)

Syntax

Visual Basic
Public Sub New( _
    ByVal updateId As UpdateRevisionId, _
    ByVal error As SynchronizationUpdateError, _
    ByVal errorText As String _
)
C#
public SynchronizationUpdateErrorInfo(
    UpdateRevisionId updateId,
    SynchronizationUpdateError error,
    string errorText
);
C++
public:
SynchronizationUpdateErrorInfo(
    UpdateRevisionId^ updateId,
    SynchronizationUpdateError error,
    String^ errorText
);
J#
public SynchronizationUpdateErrorInfo(
    UpdateRevisionId updateId,
    SynchronizationUpdateError error,
    System.String errorText
);
JScript
public function SynchronizationUpdateErrorInfo(
     updateId : UpdateRevisionId,
     error : SynchronizationUpdateError,
     errorText : String
);

Parameters

updateId

Identifier that identifies the failed update. For details, see UpdateRevisionId.

error

Error that occurred while processing the update. For a list of possible errors, see SynchronizationUpdateError.

errorText

String that contains the exception message and call stack if the error represents an exception that occurred while processing the update; otherwise, String.Empty.

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

SynchronizationUpdateErrorInfo Class


SynchronizationUpdateErrorInfo.Equals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfo.Equals (Object) |
SynchronizationUpdateErrorInfo.Equals (Object, Object) |

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo.Equals Method (Object)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim obj As Object
Dim returnValue As Boolean
Dim synchronizationUpdateErrorInfo1 As SynchronizationUpdateErrorInfo
returnValue = synchronizationUpdateErrorInfo1.Equals(obj)

Syntax

Visual Basic
Overloads Public Overrides Function Equals( _
    ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
    object obj
);
C++
public:
virtual bool Equals(
    Object^ obj
) override;
J#
public override boolean Equals(
    System.Object obj
);
JScript
public override function Equals(
     obj : Object
) : Boolean;

Parameters

obj

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim synchronizationUpdateErrorInfo1 As SynchronizationUpdateErrorInfo
returnValue = synchronizationUpdateErrorInfo1.GetHashCode()

Syntax

Visual Basic
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode();
C++
public:
virtual int GetHashCode() override;
J#
public override int GetHashCode();
JScript
public override function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Error | Error that occurred while processing the update.
public property | ErrorText | Description of the error that occurred while processing the update.
public property | UpdateId | Identifier that identifies the failed update.

See Also

Reference

SynchronizationUpdateErrorInfo Class


SynchronizationUpdateErrorInfo.Error Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Error that occurred while processing the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfo1 As SynchronizationUpdateErrorInfo

Dim returnValue As SynchronizationUpdateError
returnValue = synchronizationUpdateErrorInfo1.Error

Syntax

Visual Basic
Public ReadOnly Property Error() As SynchronizationUpdateError
C#
public SynchronizationUpdateError Error {get;}
C++
public:
property SynchronizationUpdateError Error {
    SynchronizationUpdateError get();
}
J#
public SynchronizationUpdateError get_Error();
JScript
public function get Error() : SynchronizationUpdateError;

Property Value

Error that occurred while processing the update. For a list of possible errors, see SynchronizationUpdateError.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo.ErrorText Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Description of the error that occurred while processing the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfo1 As SynchronizationUpdateErrorInfo

Dim returnValue As String
returnValue = synchronizationUpdateErrorInfo1.ErrorText

Syntax

Visual Basic
Public ReadOnly Property ErrorText() As String
C#
public string ErrorText {get;}
C++
public:
property String^ ErrorText {
    String^ get();
}
J#
public System.String get_ErrorText();
JScript
public function get ErrorText() : String;

Property Value

String that contains the exception message and call stack if the error represents an exception that occurred while processing the update; otherwise, String.Empty.

Remarks

The text is localized in the language of the .NET Framework install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfo.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifier that identifies the failed update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfo1 As SynchronizationUpdateErrorInfo

Dim returnValue As UpdateRevisionId
returnValue = synchronizationUpdateErrorInfo1.UpdateId

Syntax

Visual Basic
Public ReadOnly Property UpdateId() As UpdateRevisionId
C#
public UpdateRevisionId UpdateId {get;}
C++
public:
property UpdateRevisionId^ UpdateId {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_UpdateId();
JScript
public function get UpdateId() : UpdateRevisionId;

Property Value

Identifier that identifies the failed update. For details, see UpdateRevisionId.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfo Class
SynchronizationUpdateErrorInfo Members


SynchronizationUpdateErrorInfoCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of errors that occurred while processing an update. To retrieve this collection, call one of the following properties: ISubscriptionEvent.UpdateErrors; ISynchronizationInfo.UpdateErrors.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfoCollection1 As New SynchronizationUpdateErrorInfoCollection()

Syntax

Visual Basic
Public Class SynchronizationUpdateErrorInfoCollection
    Inherits WsusCollection
C#
public class SynchronizationUpdateErrorInfoCollection : WsusCollection
C++
public ref class SynchronizationUpdateErrorInfoCollection : WsusCollection
J#
public class SynchronizationUpdateErrorInfoCollection extends WsusCollection
JScript
public class SynchronizationUpdateErrorInfoCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.SynchronizationUpdateErrorInfoCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of errors that occurred while processing an update. To retrieve this collection, call one of the following properties: ISubscriptionEvent.UpdateErrors; ISynchronizationInfo.UpdateErrors.

The following tables list the members exposed by the SynchronizationUpdateErrorInfoCollection type.

Public Constructors

Name | Description
SynchronizationUpdateErrorInfoCollection | Initializes a new instance of the SynchronizationUpdateErrorInfoCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded.
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded.
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded.
protected method | Insert | Overloaded.
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class


SynchronizationUpdateErrorInfoCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the SynchronizationUpdateErrorInfoCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfoCollection1 As New SynchronizationUpdateErrorInfoCollection()

Syntax

Visual Basic
Public Sub New()
C#
public SynchronizationUpdateErrorInfoCollection();
C++
public:
SynchronizationUpdateErrorInfoCollection();
J#
public SynchronizationUpdateErrorInfoCollection();
JScript
public function SynchronizationUpdateErrorInfoCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded.
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded.
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded.
protected method | Insert | Overloaded.
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class


SynchronizationUpdateErrorInfoCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.Add (Object) |
SynchronizationUpdateErrorInfoCollection.Add (SynchronizationUpdateErrorInfo) | Adds update error information to the end of the collection.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Add Method (SynchronizationUpdateErrorInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds update error information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationUpdateErrorInfo
Dim returnValue As Integer
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
returnValue = synchronizationUpdateErrorInfoCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As SynchronizationUpdateErrorInfo _
) As Integer
C#
public int Add(
    SynchronizationUpdateErrorInfo value
);
C++
public:
int Add(
    SynchronizationUpdateErrorInfo^ value
);
J#
public int Add(
    SynchronizationUpdateErrorInfo value
);
JScript
public function Add(
     value : SynchronizationUpdateErrorInfo
) : int;

Parameters

value

An SynchronizationUpdateErrorInfo of the update error information to add.

Return Value

Zero-based index at which the update error information was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The update error information already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.AddRange (Array) |
SynchronizationUpdateErrorInfoCollection.AddRange (SynchronizationUpdateErrorInfo[]) | Adds an array of update error information to the end of the collection.
SynchronizationUpdateErrorInfoCollection.AddRange (SynchronizationUpdateErrorInfoCollection) | Adds the members of an update error information collection to the end of the collection.
SynchronizationUpdateErrorInfoCollection.AddRange (WsusCollection) |

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.AddRange Method (SynchronizationUpdateErrorInfo[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of update error information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As SynchronizationUpdateErrorInfo
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
synchronizationUpdateErrorInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As SynchronizationUpdateErrorInfo _
)
C#
public void AddRange(
    SynchronizationUpdateErrorInfo[] value
);
C++
public:
void AddRange(
    array<SynchronizationUpdateErrorInfo^>^ value
);
J#
public void AddRange(
    SynchronizationUpdateErrorInfo[] value
);
JScript
public function AddRange(
     value : SynchronizationUpdateErrorInfo[]
) : Void;

Parameters

value

Array of SynchronizationUpdateErrorInfo to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.AddRange Method (SynchronizationUpdateErrorInfoCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update error information collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationUpdateErrorInfoCollection
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
synchronizationUpdateErrorInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As SynchronizationUpdateErrorInfoCollection _
)
C#
public void AddRange(
    SynchronizationUpdateErrorInfoCollection value
);
C++
public:
void AddRange(
    SynchronizationUpdateErrorInfoCollection^ value
);
J#
public void AddRange(
    SynchronizationUpdateErrorInfoCollection value
);
JScript
public function AddRange(
     value : SynchronizationUpdateErrorInfoCollection
) : Void;

Parameters

value

A SynchronizationUpdateErrorInfoCollection collection of update error information to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.Contains (Object) |
SynchronizationUpdateErrorInfoCollection.Contains (SynchronizationUpdateErrorInfo) | Determines if the collection contains the specified update error information.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Contains Method (SynchronizationUpdateErrorInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update error information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationUpdateErrorInfo
Dim returnValue As Boolean
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
returnValue = synchronizationUpdateErrorInfoCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As SynchronizationUpdateErrorInfo _
) As Boolean
C#
public bool Contains(
    SynchronizationUpdateErrorInfo value
);
C++
public:
bool Contains(
    SynchronizationUpdateErrorInfo^ value
);
J#
public boolean Contains(
    SynchronizationUpdateErrorInfo value
);
JScript
public function Contains(
     value : SynchronizationUpdateErrorInfo
) : Boolean;

Parameters

value

An SynchronizationUpdateErrorInfo of the update error information to locate in the collection.

Return Value

True if the collection contains the update error information; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.CopyTo (Array, Int32) |
SynchronizationUpdateErrorInfoCollection.CopyTo (SynchronizationUpdateErrorInfo[], Int32) | Copies the update error information in the collection to a one-dimensional array.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.CopyTo Method (SynchronizationUpdateErrorInfo[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the update error information in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As SynchronizationUpdateErrorInfo
Dim index As Integer
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
synchronizationUpdateErrorInfoCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As SynchronizationUpdateErrorInfo, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    SynchronizationUpdateErrorInfo[] array,
    int index
);
C++
public:
void CopyTo(
    array<SynchronizationUpdateErrorInfo^>^ array,
    int index
);
J#
public void CopyTo(
    SynchronizationUpdateErrorInfo[] array,
    int index
);
JScript
public function CopyTo(
     array : SynchronizationUpdateErrorInfo[],
     index : int
) : Void;

Parameters

array

Array of SynchronizationUpdateErrorInfo found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the update error information.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.IndexOf (Object) |
SynchronizationUpdateErrorInfoCollection.IndexOf (SynchronizationUpdateErrorInfo) | Determines if the collection contains the specified update error information. If the collection contains the update error information, the method returns the zero-based index to the update error information in the collection.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.IndexOf Method (SynchronizationUpdateErrorInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update error information. If the collection contains the update error information, the method returns the zero-based index to the update error information in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationUpdateErrorInfo
Dim returnValue As Integer
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
returnValue = synchronizationUpdateErrorInfoCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As SynchronizationUpdateErrorInfo _
) As Integer
C#
public int IndexOf(
    SynchronizationUpdateErrorInfo value
);
C++
public:
int IndexOf(
    SynchronizationUpdateErrorInfo^ value
);
J#
public int IndexOf(
    SynchronizationUpdateErrorInfo value
);
JScript
public function IndexOf(
     value : SynchronizationUpdateErrorInfo
) : int;

Parameters

value

An ISubscriptionEvent of the update error information to locate in the collection.

Return Value

Zero-based index of the update error information in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.Insert (Int32, Object) |
SynchronizationUpdateErrorInfoCollection.Insert (Int32, SynchronizationUpdateErrorInfo) | Inserts update error information into the collection.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Insert Method (Int32, SynchronizationUpdateErrorInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts update error information into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As SynchronizationUpdateErrorInfo
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
synchronizationUpdateErrorInfoCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As SynchronizationUpdateErrorInfo _
)
C#
public void Insert(
    int index,
    SynchronizationUpdateErrorInfo value
);
C++
public:
void Insert(
    int index,
    SynchronizationUpdateErrorInfo^ value
);
J#
public void Insert(
    int index,
    SynchronizationUpdateErrorInfo value
);
JScript
public function Insert(
     index : int,
     value : SynchronizationUpdateErrorInfo
) : Void;

Parameters

index

Zero-based index at which to insert the update error information into the collection.

value

An SynchronizationUpdateErrorInfo of the update error information to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The update error information already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SynchronizationUpdateErrorInfoCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
SynchronizationUpdateErrorInfoCollection.Remove (Object) |
SynchronizationUpdateErrorInfoCollection.Remove (SynchronizationUpdateErrorInfo) | Removes the update error information from the collection.

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection.Remove Method (SynchronizationUpdateErrorInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the update error information from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As SynchronizationUpdateErrorInfo
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection
synchronizationUpdateErrorInfoCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As SynchronizationUpdateErrorInfo _
)
C#
public void Remove(
    SynchronizationUpdateErrorInfo value
);
C++
public:
void Remove(
    SynchronizationUpdateErrorInfo^ value
);
J#
public void Remove(
    SynchronizationUpdateErrorInfo value
);
JScript
public function Remove(
     value : SynchronizationUpdateErrorInfo
) : Void;

Parameters

value

An SynchronizationUpdateErrorInfo of the update error information to remove.

Exceptions

Exception type | Condition
ArgumentException | The update error information does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


SynchronizationUpdateErrorInfoCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class


SynchronizationUpdateErrorInfoCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim synchronizationUpdateErrorInfoCollection1 As SynchronizationUpdateErrorInfoCollection

Dim key As Integer
Dim returnValue As SynchronizationUpdateErrorInfo
returnValue = synchronizationUpdateErrorInfoCollection1.Item(key)

Dim sampleValue As SynchronizationUpdateErrorInfo
synchronizationUpdateErrorInfoCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As SynchronizationUpdateErrorInfo
C#
public new SynchronizationUpdateErrorInfo this[
    int index
] {get; set;}
C++
public:
property SynchronizationUpdateErrorInfo^ default[int] {
    SynchronizationUpdateErrorInfo^ get(int index);
    void set(int index, SynchronizationUpdateErrorInfo^ value);
}
J#
new public SynchronizationUpdateErrorInfo get_Item(
    int index
);
public void set_Item(
    int index
SynchronizationUpdateErrorInfo);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The update error information already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than SynchronizationUpdateErrorInfoCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

SynchronizationUpdateErrorInfoCollection Class
SynchronizationUpdateErrorInfoCollection Members


TargetingMode Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants for the possible targeting modes. The targeting mode determines if the server or client decides to which group the client belongs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim targetingMode1 As TargetingMode = TargetingMode.Client

Syntax

Visual Basic
Public Enum TargetingMode
C#
public enum TargetingMode
C++
public enum class TargetingMode
J#
public enum TargetingMode
JScript
public enum TargetingMode

Members

Member name | Description
Client | Clients specify the target group to which they belong.
Server | Servers specify the target group to which the clients belong.

Remarks

When the client registers with the WSUS server they can specify to which group they want to belong. If client-side targeting is enabled and the group exists, the client is added to the specified group. Otherwise, the client is added to the Unassigned Computers group and IComputerTarget.RequestedTargetGroupName is set to the request group name.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateServerConfiguration.TargetingMode


UpdateApprovalAction Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the action a client performs when applying the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalAction1 As UpdateApprovalAction = UpdateApprovalAction.All

Syntax

Visual Basic
Public Enum UpdateApprovalAction
C#
public enum UpdateApprovalAction
C++
public enum class UpdateApprovalAction
J#
public enum UpdateApprovalAction
JScript
public enum UpdateApprovalAction

Members

Member name | Description
All | Use to query all updates, regardless of their action.
Install | Client installs the update.
NotApproved | The Update will not be available for clients. This value can be used in a simple targeting ComputerTargetGroup to "override" a UpdateApproval made to the "All Computers" ComputerTargetGroup.
Uninstall | Client removes the update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.Approve
IUpdateApproval.Action


UpdateApprovalActions Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalActions1 As UpdateApprovalActions = UpdateApprovalActions.All

Syntax

Visual Basic
Public Enum UpdateApprovalActions
C#
public enum UpdateApprovalActions
C++
public enum class UpdateApprovalActions
J#
public enum UpdateApprovalActions
JScript
public enum UpdateApprovalActions

Members

Member name | Description
All | Include all updates.
Install | Include updates that have been approved for install.
Uninstall | Include updates that have been approved for uninstall.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


UpdateApprovalCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update approvals. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateApprovals() ; IUpdate.GetUpdateApprovals(IComputerTargetGroup); IUpdate.GetUpdateApprovals(IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalCollection1 As New UpdateApprovalCollection()

Syntax

Visual Basic
Public Class UpdateApprovalCollection
    Inherits WsusCollection
C#
public class UpdateApprovalCollection : WsusCollection
C++
public ref class UpdateApprovalCollection : WsusCollection
J#
public class UpdateApprovalCollection extends WsusCollection
JScript
public class UpdateApprovalCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateApprovalCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Members


UpdateApprovalCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update approvals. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateApprovals() ; IUpdate.GetUpdateApprovals(IComputerTargetGroup); IUpdate.GetUpdateApprovals(IComputerTargetGroup, UpdateApprovalAction, DateTime, DateTime).

The following tables list the members exposed by the UpdateApprovalCollection type.

Public Constructors

Name | Description
UpdateApprovalCollection | Initializes a new instance of the UpdateApprovalCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateApprovalCollection Class


UpdateApprovalCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateApprovalCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalCollection1 As New UpdateApprovalCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateApprovalCollection();
C++
public:
UpdateApprovalCollection();
J#
public UpdateApprovalCollection();
JScript
public function UpdateApprovalCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateApprovalCollection Class


UpdateApprovalCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.Add (IUpdateApproval) | Adds an update approval to the end of the collection.
UpdateApprovalCollection.Add (Object) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Add Method (IUpdateApproval)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an update approval to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateApproval
Dim returnValue As Integer
Dim updateApprovalCollection1 As UpdateApprovalCollection
returnValue = updateApprovalCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateApproval _
) As Integer
C#
public int Add(
    IUpdateApproval value
);
C++
public:
int Add(
    IUpdateApproval^ value
);
J#
public int Add(
    IUpdateApproval value
);
JScript
public function Add(
     value : IUpdateApproval
) : int;

Parameters

value

An IUpdateApproval of the update approval to add.

Return Value

Zero-based index at which the update approval was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The update approval already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.AddRange (Array) |
UpdateApprovalCollection.AddRange (IUpdateApproval[]) | Adds an array of update approvals to the end of the collection.
UpdateApprovalCollection.AddRange (UpdateApprovalCollection) | Adds the members of an update approval collection to the end of the collection.
UpdateApprovalCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.AddRange Method (IUpdateApproval[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of update approvals to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateApproval
Dim updateApprovalCollection1 As UpdateApprovalCollection
updateApprovalCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateApproval _
)
C#
public void AddRange(
    IUpdateApproval[] value
);
C++
public:
void AddRange(
    array<IUpdateApproval^>^ value
);
J#
public void AddRange(
    IUpdateApproval[] value
);
JScript
public function AddRange(
     value : IUpdateApproval[]
) : Void;

Parameters

value

Array of IUpdateApproval to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.AddRange Method (UpdateApprovalCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update approval collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateApprovalCollection
Dim updateApprovalCollection1 As UpdateApprovalCollection
updateApprovalCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateApprovalCollection _
)
C#
public void AddRange(
    UpdateApprovalCollection value
);
C++
public:
void AddRange(
    UpdateApprovalCollection^ value
);
J#
public void AddRange(
    UpdateApprovalCollection value
);
JScript
public function AddRange(
     value : UpdateApprovalCollection
) : Void;

Parameters

value

An UpdateApprovalCollection collection of update approvals to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.Contains (IUpdateApproval) | Determines if the collection contains the specified update approval.
UpdateApprovalCollection.Contains (Object) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Contains Method (IUpdateApproval)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateApproval
Dim returnValue As Boolean
Dim updateApprovalCollection1 As UpdateApprovalCollection
returnValue = updateApprovalCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateApproval _
) As Boolean
C#
public bool Contains(
    IUpdateApproval value
);
C++
public:
bool Contains(
    IUpdateApproval^ value
);
J#
public boolean Contains(
    IUpdateApproval value
);
JScript
public function Contains(
     value : IUpdateApproval
) : Boolean;

Parameters

value

An IUpdateApproval of the update approval to locate in the collection.

Return Value

True if the collection contains the update approval; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.CopyTo (Array, Int32) |
UpdateApprovalCollection.CopyTo (IUpdateApproval[], Int32) | Copies the update approvals in the collection to a one-dimensional array.

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.CopyTo Method (IUpdateApproval[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the update approvals in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateApproval
Dim index As Integer
Dim updateApprovalCollection1 As UpdateApprovalCollection
updateApprovalCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateApproval, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateApproval[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateApproval^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateApproval[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateApproval[],
     index : int
) : Void;

Parameters

array

Array of IUpdateApproval found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the update approvals.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.IndexOf (IUpdateApproval) | Determines if the collection contains the specified update approval. If the collection contains the update approval, the method returns the zero-based index to the update approval in the collection.
UpdateApprovalCollection.IndexOf (Object) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.IndexOf Method (IUpdateApproval)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update approval. If the collection contains the update approval, the method returns the zero-based index to the update approval in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateApproval
Dim returnValue As Integer
Dim updateApprovalCollection1 As UpdateApprovalCollection
returnValue = updateApprovalCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateApproval _
) As Integer
C#
public int IndexOf(
    IUpdateApproval value
);
C++
public:
int IndexOf(
    IUpdateApproval^ value
);
J#
public int IndexOf(
    IUpdateApproval value
);
JScript
public function IndexOf(
     value : IUpdateApproval
) : int;

Parameters

value

An IUpdateApproval of the update approval to locate in the collection.

Return Value

Zero-based index of the update approval in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.Insert (Int32, IUpdateApproval) | Inserts an update approval into the collection.
UpdateApprovalCollection.Insert (Int32, Object) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Insert Method (Int32, IUpdateApproval)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an update approval into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateApproval
Dim updateApprovalCollection1 As UpdateApprovalCollection
updateApprovalCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateApproval _
)
C#
public void Insert(
    int index,
    IUpdateApproval value
);
C++
public:
void Insert(
    int index,
    IUpdateApproval^ value
);
J#
public void Insert(
    int index,
    IUpdateApproval value
);
JScript
public function Insert(
     index : int,
     value : IUpdateApproval
) : Void;

Parameters

index

Zero-based index at which to insert the update approval into the collection.

value

An IUpdateApproval of the update approval to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The update approval already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateApprovalCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateApprovalCollection.Remove (IUpdateApproval) | Removes the update approval from the collection.
UpdateApprovalCollection.Remove (Object) |

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection.Remove Method (IUpdateApproval)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the update approval from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateApproval
Dim updateApprovalCollection1 As UpdateApprovalCollection
updateApprovalCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateApproval _
)
C#
public void Remove(
    IUpdateApproval value
);
C++
public:
void Remove(
    IUpdateApproval^ value
);
J#
public void Remove(
    IUpdateApproval value
);
JScript
public function Remove(
     value : IUpdateApproval
) : Void;

Parameters

value

An IUpdateApproval of the update approval to remove.

Exceptions

Exception type | Condition
ArgumentException | The update approval does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateApprovalCollection Class


UpdateApprovalCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalCollection1 As UpdateApprovalCollection

Dim key As Integer
Dim returnValue As IUpdateApproval
returnValue = updateApprovalCollection1.Item(key)

Dim sampleValue As IUpdateApproval
updateApprovalCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateApproval
C#
public new IUpdateApproval this[
    int index
] {get; set;}
C++
public:
property IUpdateApproval^ default[int] {
    IUpdateApproval^ get(int index);
    void set(int index, IUpdateApproval^ value);
}
J#
new public IUpdateApproval get_Item(
    int index
);
public void set_Item(
    int index
IUpdateApproval);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The update approval already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateApprovalCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateApprovalCollection Class
UpdateApprovalCollection Members


UpdateApprovalState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants the indicate the current state of an approval.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateApprovalState1 As UpdateApprovalState = UpdateApprovalState.Active

Syntax

Visual Basic
Public Enum UpdateApprovalState
C#
public enum UpdateApprovalState
C++
public enum class UpdateApprovalState
J#
public enum UpdateApprovalState
JScript
public enum UpdateApprovalState

Members

Member name | Description
Active | The client has successfully downloaded the update and the update is ready to be installed.
Pending | The client is downloading the update. When the download is complete, the approval state will switch to Active.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateApproval.State


UpdateCategoryCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of product categories. For a description of product categories, see IUpdateServer.GetUpdateCategories(). To retrieve this collection, call one of the following methods: ISubscription.GetUpdateCategories(); GetUpdateCategories() ; IUpdateCategory.GetSubcategories(); IUpdateServer.GetRootUpdateCategories(); IUpdateServer.GetUpdateCategories() ; IUpdateServer.GetUpdateCategories(DateTime, DateTime) .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCategoryCollection1 As New UpdateCategoryCollection()

Syntax

Visual Basic
Public Class UpdateCategoryCollection
    Inherits WsusCollection
C#
public class UpdateCategoryCollection : WsusCollection
C++
public ref class UpdateCategoryCollection : WsusCollection
J#
public class UpdateCategoryCollection extends WsusCollection
JScript
public class UpdateCategoryCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateCategoryCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Members


UpdateCategoryCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of product categories. For a description of product categories, see IUpdateServer.GetUpdateCategories(). To retrieve this collection, call one of the following methods: ISubscription.GetUpdateCategories(); GetUpdateCategories() ; IUpdateCategory.GetSubcategories(); IUpdateServer.GetRootUpdateCategories(); IUpdateServer.GetUpdateCategories() ; IUpdateServer.GetUpdateCategories(DateTime, DateTime) .

The following tables list the members exposed by the UpdateCategoryCollection type.

Public Constructors

Name | Description
UpdateCategoryCollection | Initializes a new instance of the UpdateCategoryCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateCategoryCollection Class


UpdateCategoryCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateCategoryCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCategoryCollection1 As New UpdateCategoryCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateCategoryCollection();
C++
public:
UpdateCategoryCollection();
J#
public UpdateCategoryCollection();
JScript
public function UpdateCategoryCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateCategoryCollection Class


UpdateCategoryCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.Add (IUpdateCategory) | Adds a product category to the end of the collection.
UpdateCategoryCollection.Add (Object) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Add Method (IUpdateCategory)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds a product category to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateCategory
Dim returnValue As Integer
Dim updateCategoryCollection1 As UpdateCategoryCollection
returnValue = updateCategoryCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateCategory _
) As Integer
C#
public int Add(
    IUpdateCategory value
);
C++
public:
int Add(
    IUpdateCategory^ value
);
J#
public int Add(
    IUpdateCategory value
);
JScript
public function Add(
     value : IUpdateCategory
) : int;

Parameters

value

An IUpdateCategory of the category to add.

Return Value

Zero-based index at which the category was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The category already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.AddRange (Array) |
UpdateCategoryCollection.AddRange (IUpdateCategory[]) | Adds an array of product categories to the end of the collection.
UpdateCategoryCollection.AddRange (UpdateCategoryCollection) | Adds the members of a product category collection to the end of the collection.
UpdateCategoryCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.AddRange Method (IUpdateCategory[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of product categories to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateCategory
Dim updateCategoryCollection1 As UpdateCategoryCollection
updateCategoryCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateCategory _
)
C#
public void AddRange(
    IUpdateCategory[] value
);
C++
public:
void AddRange(
    array<IUpdateCategory^>^ value
);
J#
public void AddRange(
    IUpdateCategory[] value
);
JScript
public function AddRange(
     value : IUpdateCategory[]
) : Void;

Parameters

value

Array of IUpdateCategory to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.AddRange Method (UpdateCategoryCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of a product category collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateCategoryCollection
Dim updateCategoryCollection1 As UpdateCategoryCollection
updateCategoryCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateCategoryCollection _
)
C#
public void AddRange(
    UpdateCategoryCollection value
);
C++
public:
void AddRange(
    UpdateCategoryCollection^ value
);
J#
public void AddRange(
    UpdateCategoryCollection value
);
JScript
public function AddRange(
     value : UpdateCategoryCollection
) : Void;

Parameters

value

An UpdateCategoryCollection collection of categories to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.Contains (IUpdateCategory) | Determines if the collection contains the specified product category.
UpdateCategoryCollection.Contains (Object) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Contains Method (IUpdateCategory)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified product category.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateCategory
Dim returnValue As Boolean
Dim updateCategoryCollection1 As UpdateCategoryCollection
returnValue = updateCategoryCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateCategory _
) As Boolean
C#
public bool Contains(
    IUpdateCategory value
);
C++
public:
bool Contains(
    IUpdateCategory^ value
);
J#
public boolean Contains(
    IUpdateCategory value
);
JScript
public function Contains(
     value : IUpdateCategory
) : Boolean;

Parameters

value

An IUpdateCategory of the category to locate in the collection.

Return Value

True if the collection contains the category; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.CopyTo (Array, Int32) |
UpdateCategoryCollection.CopyTo (IUpdateCategory[], Int32) | Copies the product categories in the collection to a one-dimensional array.

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.CopyTo Method (IUpdateCategory[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the product categories in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateCategory
Dim index As Integer
Dim updateCategoryCollection1 As UpdateCategoryCollection
updateCategoryCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateCategory, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateCategory[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateCategory^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateCategory[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateCategory[],
     index : int
) : Void;

Parameters

array

Array of IUpdateCategory found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the categories.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.IndexOf (IUpdateCategory) | Determines if the collection contains the specified product category. If the collection contains the category, the method returns the zero-based index to the category in the collection.
UpdateCategoryCollection.IndexOf (Object) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.IndexOf Method (IUpdateCategory)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified product category. If the collection contains the category, the method returns the zero-based index to the category in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateCategory
Dim returnValue As Integer
Dim updateCategoryCollection1 As UpdateCategoryCollection
returnValue = updateCategoryCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateCategory _
) As Integer
C#
public int IndexOf(
    IUpdateCategory value
);
C++
public:
int IndexOf(
    IUpdateCategory^ value
);
J#
public int IndexOf(
    IUpdateCategory value
);
JScript
public function IndexOf(
     value : IUpdateCategory
) : int;

Parameters

value

An IUpdateCategory of the category to locate in the collection.

Return Value

Zero-based index of the category in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.Insert (Int32, IUpdateCategory) | Inserts a product category into the collection.
UpdateCategoryCollection.Insert (Int32, Object) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Insert Method (Int32, IUpdateCategory)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts a product category into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateCategory
Dim updateCategoryCollection1 As UpdateCategoryCollection
updateCategoryCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateCategory _
)
C#
public void Insert(
    int index,
    IUpdateCategory value
);
C++
public:
void Insert(
    int index,
    IUpdateCategory^ value
);
J#
public void Insert(
    int index,
    IUpdateCategory value
);
JScript
public function Insert(
     index : int,
     value : IUpdateCategory
) : Void;

Parameters

index

Zero-based index at which to insert the category into the collection.

value

An IUpdateCategory of the category to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The category already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateCategoryCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCategoryCollection.Remove (IUpdateCategory) | Removes the product category from the collection.
UpdateCategoryCollection.Remove (Object) |

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection.Remove Method (IUpdateCategory)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the product category from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateCategory
Dim updateCategoryCollection1 As UpdateCategoryCollection
updateCategoryCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateCategory _
)
C#
public void Remove(
    IUpdateCategory value
);
C++
public:
void Remove(
    IUpdateCategory^ value
);
J#
public void Remove(
    IUpdateCategory value
);
JScript
public function Remove(
     value : IUpdateCategory
) : Void;

Parameters

value

An IUpdateCategory of the category to remove.

Exceptions

Exception type | Condition
ArgumentException | The category does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateCategoryCollection Class


UpdateCategoryCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCategoryCollection1 As UpdateCategoryCollection

Dim key As Integer
Dim returnValue As IUpdateCategory
returnValue = updateCategoryCollection1.Item(key)

Dim sampleValue As IUpdateCategory
updateCategoryCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateCategory
C#
public new IUpdateCategory this[
    int index
] {get; set;}
C++
public:
property IUpdateCategory^ default[int] {
    IUpdateCategory^ get(int index);
    void set(int index, IUpdateCategory^ value);
}
J#
new public IUpdateCategory get_Item(
    int index
);
public void set_Item(
    int index
IUpdateCategory);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The category already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateCategoryCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCategoryCollection Class
UpdateCategoryCollection Members


UpdateCategoryType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that describe the different update categories.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCategoryType1 As UpdateCategoryType = UpdateCategoryType.Company

Syntax

Visual Basic
Public Enum UpdateCategoryType
C#
public enum UpdateCategoryType
C++
public enum class UpdateCategoryType
J#
public enum UpdateCategoryType
JScript
public enum UpdateCategoryType

Members

Member name | Description
Company | Company distributing the update.
Product | Product category under which the update falls. For example, all Windows related updates.
ProductFamily | Product family under which the update falls. For example, .

Remarks

The root category is the company category. The company category can have one or more subcategories known as product family categories. Product family categories contain one or more product categories. For example, the company category for Microsoft is Microsoft Corporation. The Microsoft Corporation category contains the Windows product family category, which in turn contains product categories, such as the Windows Server 2003 family and the family.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
GetUpdateCategories()
IUpdateCategory.ProhibitsSubcategories
IUpdateCategory.ProhibitsUpdates
IUpdateCategory.Type
IUpdateServer.GetRootUpdateCategories


UpdateClassificationCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update classifications. Classifications define a grouping of updates. For example, Security Updates, Critical Updates, or Driver Updates. To retrieve this collection, call one of the following methods: IAutomaticUpdateApprovalRule.GetUpdateClassifications(); ISubscription.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(DateTime, DateTime).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateClassificationCollection1 As New UpdateClassificationCollection()

Syntax

Visual Basic
Public Class UpdateClassificationCollection
    Inherits WsusCollection
C#
public class UpdateClassificationCollection : WsusCollection
C++
public ref class UpdateClassificationCollection : WsusCollection
J#
public class UpdateClassificationCollection extends WsusCollection
JScript
public class UpdateClassificationCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateClassificationCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Members


UpdateClassificationCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update classifications. Classifications define a grouping of updates. For example, Security Updates, Critical Updates, or Driver Updates. To retrieve this collection, call one of the following methods: IAutomaticUpdateApprovalRule.GetUpdateClassifications(); ISubscription.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(); IUpdateServer.GetUpdateClassifications(DateTime, DateTime).

The following tables list the members exposed by the UpdateClassificationCollection type.

Public Constructors

Name | Description
UpdateClassificationCollection | Initializes a new instance of the UpdateClassificationCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateClassificationCollection Class


UpdateClassificationCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateClassificationCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateClassificationCollection1 As New UpdateClassificationCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateClassificationCollection();
C++
public:
UpdateClassificationCollection();
J#
public UpdateClassificationCollection();
JScript
public function UpdateClassificationCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateClassificationCollection Class


UpdateClassificationCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.Add (IUpdateClassification) | Adds an update classification to the end of the collection.
UpdateClassificationCollection.Add (Object) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Add Method (IUpdateClassification)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an update classification to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateClassification
Dim returnValue As Integer
Dim updateClassificationCollection1 As UpdateClassificationCollection
returnValue = updateClassificationCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateClassification _
) As Integer
C#
public int Add(
    IUpdateClassification value
);
C++
public:
int Add(
    IUpdateClassification^ value
);
J#
public int Add(
    IUpdateClassification value
);
JScript
public function Add(
     value : IUpdateClassification
) : int;

Parameters

value

An IUpdateClassification of the classification to add.

Return Value

Zero-based index at which the classification was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The classification already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.AddRange (Array) |
UpdateClassificationCollection.AddRange (IUpdateClassification[]) | Adds an array of update classifications to the end of the collection.
UpdateClassificationCollection.AddRange (UpdateClassificationCollection) | Adds the members of an update classification collection to the end of the collection.
UpdateClassificationCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.AddRange Method (IUpdateClassification[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of update classifications to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateClassification
Dim updateClassificationCollection1 As UpdateClassificationCollection
updateClassificationCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateClassification _
)
C#
public void AddRange(
    IUpdateClassification[] value
);
C++
public:
void AddRange(
    array<IUpdateClassification^>^ value
);
J#
public void AddRange(
    IUpdateClassification[] value
);
JScript
public function AddRange(
     value : IUpdateClassification[]
) : Void;

Parameters

value

Array of IUpdateClassification to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.AddRange Method (UpdateClassificationCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update classification collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateClassificationCollection
Dim updateClassificationCollection1 As UpdateClassificationCollection
updateClassificationCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateClassificationCollection _
)
C#
public void AddRange(
    UpdateClassificationCollection value
);
C++
public:
void AddRange(
    UpdateClassificationCollection^ value
);
J#
public void AddRange(
    UpdateClassificationCollection value
);
JScript
public function AddRange(
     value : UpdateClassificationCollection
) : Void;

Parameters

value

An UpdateClassificationCollection collection of classification to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.Contains (IUpdateClassification) | Determines if the collection contains the specified update classification.
UpdateClassificationCollection.Contains (Object) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Contains Method (IUpdateClassification)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update classification.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateClassification
Dim returnValue As Boolean
Dim updateClassificationCollection1 As UpdateClassificationCollection
returnValue = updateClassificationCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateClassification _
) As Boolean
C#
public bool Contains(
    IUpdateClassification value
);
C++
public:
bool Contains(
    IUpdateClassification^ value
);
J#
public boolean Contains(
    IUpdateClassification value
);
JScript
public function Contains(
     value : IUpdateClassification
) : Boolean;

Parameters

value

An IUpdateClassification of the classification to locate in the collection.

Return Value

True if the collection contains the classification; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.CopyTo (Array, Int32) |
UpdateClassificationCollection.CopyTo (IUpdateClassification[], Int32) | Copies the update classifications in the collection to a one-dimensional array.

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.CopyTo Method (IUpdateClassification[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the update classifications in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateClassification
Dim index As Integer
Dim updateClassificationCollection1 As UpdateClassificationCollection
updateClassificationCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateClassification, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateClassification[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateClassification^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateClassification[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateClassification[],
     index : int
) : Void;

Parameters

array

Array of IUpdateClassification found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the classifications.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.IndexOf (IUpdateClassification) | Determines if the collection contains the specified update classification. If the collection contains the classification, the method returns the zero-based index to the classification in the collection.
UpdateClassificationCollection.IndexOf (Object) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.IndexOf Method (IUpdateClassification)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update classification. If the collection contains the classification, the method returns the zero-based index to the classification in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateClassification
Dim returnValue As Integer
Dim updateClassificationCollection1 As UpdateClassificationCollection
returnValue = updateClassificationCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateClassification _
) As Integer
C#
public int IndexOf(
    IUpdateClassification value
);
C++
public:
int IndexOf(
    IUpdateClassification^ value
);
J#
public int IndexOf(
    IUpdateClassification value
);
JScript
public function IndexOf(
     value : IUpdateClassification
) : int;

Parameters

value

An IUpdateClassification of the classification to locate in the collection.

Return Value

Zero-based index of the classification in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.Insert (Int32, IUpdateClassification) | Inserts an update classification into the collection.
UpdateClassificationCollection.Insert (Int32, Object) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Insert Method (Int32, IUpdateClassification)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an update classification into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateClassification
Dim updateClassificationCollection1 As UpdateClassificationCollection
updateClassificationCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateClassification _
)
C#
public void Insert(
    int index,
    IUpdateClassification value
);
C++
public:
void Insert(
    int index,
    IUpdateClassification^ value
);
J#
public void Insert(
    int index,
    IUpdateClassification value
);
JScript
public function Insert(
     index : int,
     value : IUpdateClassification
) : Void;

Parameters

index

Zero-based index at which to insert the classification into the collection.

value

An IUpdateClassification of the classification to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The classification already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateClassificationCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateClassificationCollection.Remove (IUpdateClassification) | Removes the update classification from the collection.
UpdateClassificationCollection.Remove (Object) |

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection.Remove Method (IUpdateClassification)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the update classification from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateClassification
Dim updateClassificationCollection1 As UpdateClassificationCollection
updateClassificationCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateClassification _
)
C#
public void Remove(
    IUpdateClassification value
);
C++
public:
void Remove(
    IUpdateClassification^ value
);
J#
public void Remove(
    IUpdateClassification value
);
JScript
public function Remove(
     value : IUpdateClassification
) : Void;

Parameters

value

An IUpdateClassification of the classification to remove.

Exceptions

Exception type | Condition
ArgumentException | The classification does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateClassificationCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateClassificationCollection Class


UpdateClassificationCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateClassificationCollection1 As UpdateClassificationCollection

Dim key As Integer
Dim returnValue As IUpdateClassification
returnValue = updateClassificationCollection1.Item(key)

Dim sampleValue As IUpdateClassification
updateClassificationCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateClassification
C#
public new IUpdateClassification this[
    int index
] {get; set;}
C++
public:
property IUpdateClassification^ default[int] {
    IUpdateClassification^ get(int index);
    void set(int index, IUpdateClassification^ value);
}
J#
new public IUpdateClassification get_Item(
    int index
);
public void set_Item(
    int index
IUpdateClassification);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The classification already exists in this collection.
ArgumentNullException | A member of the collection cannot be set to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater thanUpdateClassificationCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateClassificationCollection Class
UpdateClassificationCollection Members


UpdateCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of updates. To retrieve this collection, call one of the following methods: IUpdate.GetRelatedUpdates(UpdateRelationship); IUpdateCategory.GetUpdates() ; IUpdateCategory.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(); IUpdateServer.GetUpdates() ; IUpdateServer.GetUpdates(ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection); IUpdateServer.SearchUpdates(String) .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCollection1 As New UpdateCollection()

Syntax

Visual Basic
Public Class UpdateCollection
    Inherits WsusCollection
C#
public class UpdateCollection : WsusCollection
C++
public ref class UpdateCollection : WsusCollection
J#
public class UpdateCollection extends WsusCollection
JScript
public class UpdateCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Members


UpdateCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of updates. To retrieve this collection, call one of the following methods: IUpdate.GetRelatedUpdates(UpdateRelationship); IUpdateCategory.GetUpdates() ; IUpdateCategory.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(ApprovedStates); IUpdateClassification.GetUpdates(); IUpdateServer.GetUpdates() ; IUpdateServer.GetUpdates(ApprovedStates, DateTime, DateTime, UpdateCategoryCollection, UpdateClassificationCollection); IUpdateServer.SearchUpdates(String) .

The following tables list the members exposed by the UpdateCollection type.

Public Constructors

Name | Description
UpdateCollection | Initializes a new instance of the UpdateCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateCollection Class


UpdateCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCollection1 As New UpdateCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateCollection();
C++
public:
UpdateCollection();
J#
public UpdateCollection();
JScript
public function UpdateCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateCollection Class


UpdateCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.Add (IUpdate) | Adds an update to the end of the collection.
UpdateCollection.Add (Object) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Add Method (IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an update to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdate
Dim returnValue As Integer
Dim updateCollection1 As UpdateCollection
returnValue = updateCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdate _
) As Integer
C#
public int Add(
    IUpdate value
);
C++
public:
int Add(
    IUpdate^ value
);
J#
public int Add(
    IUpdate value
);
JScript
public function Add(
     value : IUpdate
) : int;

Parameters

value

An IUpdate of the update to add.

Return Value

Zero-based index at which the update was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The update already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.AddRange (Array) |
UpdateCollection.AddRange (IUpdate[]) | Adds an array of updates to the end of the collection.
UpdateCollection.AddRange (UpdateCollection) | Adds the members of an update collection to the end of the collection.
UpdateCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.AddRange Method (IUpdate[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of updates to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdate
Dim updateCollection1 As UpdateCollection
updateCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdate _
)
C#
public void AddRange(
    IUpdate[] value
);
C++
public:
void AddRange(
    array<IUpdate^>^ value
);
J#
public void AddRange(
    IUpdate[] value
);
JScript
public function AddRange(
     value : IUpdate[]
) : Void;

Parameters

value

Array of IUpdate instances to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.AddRange Method (UpdateCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateCollection
Dim updateCollection1 As UpdateCollection
updateCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateCollection _
)
C#
public void AddRange(
    UpdateCollection value
);
C++
public:
void AddRange(
    UpdateCollection^ value
);
J#
public void AddRange(
    UpdateCollection value
);
JScript
public function AddRange(
     value : UpdateCollection
) : Void;

Parameters

value

An UpdateCollection collection of updates to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.Contains (IUpdate) | Determines if the collection contains the specified update.
UpdateCollection.Contains (Object) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Contains Method (IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdate
Dim returnValue As Boolean
Dim updateCollection1 As UpdateCollection
returnValue = updateCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdate _
) As Boolean
C#
public bool Contains(
    IUpdate value
);
C++
public:
bool Contains(
    IUpdate^ value
);
J#
public boolean Contains(
    IUpdate value
);
JScript
public function Contains(
     value : IUpdate
) : Boolean;

Parameters

value

An IUpdate of the update to locate in the collection.

Return Value

True if the collection contains the update; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.CopyTo (Array, Int32) |
UpdateCollection.CopyTo (IUpdate[], Int32) | Copies the updates in the collection to a one-dimensional array.

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.CopyTo Method (IUpdate[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the updates in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdate
Dim index As Integer
Dim updateCollection1 As UpdateCollection
updateCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdate, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdate[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdate^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdate[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdate[],
     index : int
) : Void;

Parameters

array

Array of IUpdate instances found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the updates.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.IndexOf (IUpdate) | Determines if the collection contains the specified update. If the collection contains the update, the method returns the zero-based index to the update in the collection.
UpdateCollection.IndexOf (Object) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.IndexOf Method (IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update. If the collection contains the update, the method returns the zero-based index to the update in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdate
Dim returnValue As Integer
Dim updateCollection1 As UpdateCollection
returnValue = updateCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdate _
) As Integer
C#
public int IndexOf(
    IUpdate value
);
C++
public:
int IndexOf(
    IUpdate^ value
);
J#
public int IndexOf(
    IUpdate value
);
JScript
public function IndexOf(
     value : IUpdate
) : int;

Parameters

value

An IUpdate of the update to locate in the collection.

Return Value

Zero-based index of the update in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.Insert (Int32, IUpdate) | Inserts an update into the collection.
UpdateCollection.Insert (Int32, Object) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Insert Method (Int32, IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an update into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdate
Dim updateCollection1 As UpdateCollection
updateCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdate _
)
C#
public void Insert(
    int index,
    IUpdate value
);
C++
public:
void Insert(
    int index,
    IUpdate^ value
);
J#
public void Insert(
    int index,
    IUpdate value
);
JScript
public function Insert(
     index : int,
     value : IUpdate
) : Void;

Parameters

index

Zero-based index at which to insert the update into the collection.

value

An IUpdate of the update to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The update already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateCollection.Remove (IUpdate) | Removes the update from the collection.
UpdateCollection.Remove (Object) |

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection.Remove Method (IUpdate)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the update from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdate
Dim updateCollection1 As UpdateCollection
updateCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdate _
)
C#
public void Remove(
    IUpdate value
);
C++
public:
void Remove(
    IUpdate^ value
);
J#
public void Remove(
    IUpdate value
);
JScript
public function Remove(
     value : IUpdate
) : Void;

Parameters

value

An IUpdate of the update to remove.

Exceptions

Exception type | Condition
ArgumentException | The update does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateCollection Class


UpdateCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateCollection1 As UpdateCollection

Dim key As Integer
Dim returnValue As IUpdate
returnValue = updateCollection1.Item(key)

Dim sampleValue As IUpdate
updateCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdate
C#
public new IUpdate this[
    int index
] {get; set;}
C++
public:
property IUpdate^ default[int] {
    IUpdate^ get(int index);
    void set(int index, IUpdate^ value);
}
J#
new public IUpdate get_Item(
    int index
);
public void set_Item(
    int index
IUpdate);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The update already exists in this collection.
ArgumentNullException | Cannot set a member of the collection to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateCollection Class
UpdateCollection Members


UpdateEventCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update events. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IComputerTarget) ; IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate, WsusEventSource, WsusEventId[]).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateEventCollection1 As New UpdateEventCollection()

Syntax

Visual Basic
Public Class UpdateEventCollection
    Inherits WsusCollection
C#
public class UpdateEventCollection : WsusCollection
C++
public ref class UpdateEventCollection : WsusCollection
J#
public class UpdateEventCollection extends WsusCollection
JScript
public class UpdateEventCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateEventCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Members


UpdateEventCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update events. To retrieve this collection, call one of the following methods: IUpdate.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IComputerTarget) ; IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate); IUpdateServer.GetUpdateEventHistory(DateTime, DateTime, IUpdate, WsusEventSource, WsusEventId[]).

The following tables list the members exposed by the UpdateEventCollection type.

Public Constructors

Name | Description
UpdateEventCollection | Initialize a new instance of the UpdateEventCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateEventCollection Class


UpdateEventCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initialize a new instance of the UpdateEventCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateEventCollection1 As New UpdateEventCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateEventCollection();
C++
public:
UpdateEventCollection();
J#
public UpdateEventCollection();
JScript
public function UpdateEventCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateEventCollection Class


UpdateEventCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.Add (IUpdateEvent) | Adds an update event to the end of the collection.
UpdateEventCollection.Add (Object) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Add Method (IUpdateEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an update event to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateEvent
Dim returnValue As Integer
Dim updateEventCollection1 As UpdateEventCollection
returnValue = updateEventCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateEvent _
) As Integer
C#
public int Add(
    IUpdateEvent value
);
C++
public:
int Add(
    IUpdateEvent^ value
);
J#
public int Add(
    IUpdateEvent value
);
JScript
public function Add(
     value : IUpdateEvent
) : int;

Parameters

value

An IUpdateEvent of the update event to add.

Return Value

Zero-based index at which the update event was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The update event already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.AddRange (Array) |
UpdateEventCollection.AddRange (IUpdateEvent[]) | Adds an array of update events to the end of the collection.
UpdateEventCollection.AddRange (UpdateEventCollection) | Adds the members of an update event collection to the end of the collection.
UpdateEventCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.AddRange Method (IUpdateEvent[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of update events to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateEvent
Dim updateEventCollection1 As UpdateEventCollection
updateEventCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateEvent _
)
C#
public void AddRange(
    IUpdateEvent[] value
);
C++
public:
void AddRange(
    array<IUpdateEvent^>^ value
);
J#
public void AddRange(
    IUpdateEvent[] value
);
JScript
public function AddRange(
     value : IUpdateEvent[]
) : Void;

Parameters

value

Array of IUpdateEvent instances to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.AddRange Method (UpdateEventCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update event collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateEventCollection
Dim updateEventCollection1 As UpdateEventCollection
updateEventCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateEventCollection _
)
C#
public void AddRange(
    UpdateEventCollection value
);
C++
public:
void AddRange(
    UpdateEventCollection^ value
);
J#
public void AddRange(
    UpdateEventCollection value
);
JScript
public function AddRange(
     value : UpdateEventCollection
) : Void;

Parameters

value

An UpdateEventCollection collection of update events to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.Contains (IUpdateEvent) | Determines if the collection contains the specified update event.
UpdateEventCollection.Contains (Object) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Contains Method (IUpdateEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateEvent
Dim returnValue As Boolean
Dim updateEventCollection1 As UpdateEventCollection
returnValue = updateEventCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateEvent _
) As Boolean
C#
public bool Contains(
    IUpdateEvent value
);
C++
public:
bool Contains(
    IUpdateEvent^ value
);
J#
public boolean Contains(
    IUpdateEvent value
);
JScript
public function Contains(
     value : IUpdateEvent
) : Boolean;

Parameters

value

An IUpdateEvent of the update event to locate in the collection.

Return Value

True if the collection contains the update event; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.CopyTo (Array, Int32) |
UpdateEventCollection.CopyTo (IUpdateEvent[], Int32) | Copies the update events in the collection to a one-dimensional array.

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.CopyTo Method (IUpdateEvent[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the update events in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateEvent
Dim index As Integer
Dim updateEventCollection1 As UpdateEventCollection
updateEventCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateEvent, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateEvent[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateEvent^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateEvent[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateEvent[],
     index : int
) : Void;

Parameters

array

Array of IUpdateEvent instances found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the update events.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.IndexOf (IUpdateEvent) | Determines if the collection contains the specified update event. If the collection contains the event, the method returns the zero-based index to the event in the collection.
UpdateEventCollection.IndexOf (Object) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.IndexOf Method (IUpdateEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update event. If the collection contains the event, the method returns the zero-based index to the event in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateEvent
Dim returnValue As Integer
Dim updateEventCollection1 As UpdateEventCollection
returnValue = updateEventCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateEvent _
) As Integer
C#
public int IndexOf(
    IUpdateEvent value
);
C++
public:
int IndexOf(
    IUpdateEvent^ value
);
J#
public int IndexOf(
    IUpdateEvent value
);
JScript
public function IndexOf(
     value : IUpdateEvent
) : int;

Parameters

value

An IUpdateEvent of the event to locate in the collection.

Return Value

Zero-based index of the event in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.Insert (Int32, IUpdateEvent) | Inserts an update event into the collection.
UpdateEventCollection.Insert (Int32, Object) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Insert Method (Int32, IUpdateEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an update event into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateEvent
Dim updateEventCollection1 As UpdateEventCollection
updateEventCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateEvent _
)
C#
public void Insert(
    int index,
    IUpdateEvent value
);
C++
public:
void Insert(
    int index,
    IUpdateEvent^ value
);
J#
public void Insert(
    int index,
    IUpdateEvent value
);
JScript
public function Insert(
     index : int,
     value : IUpdateEvent
) : Void;

Parameters

index

Zero-based index at which to insert the event into the collection.

value

An IUpdateEvent of the event to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The event already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateEventCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateEventCollection.Remove (IUpdateEvent) | Removes the update event from the collection.
UpdateEventCollection.Remove (Object) |

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection.Remove Method (IUpdateEvent)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the update event from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateEvent
Dim updateEventCollection1 As UpdateEventCollection
updateEventCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateEvent _
)
C#
public void Remove(
    IUpdateEvent value
);
C++
public:
void Remove(
    IUpdateEvent^ value
);
J#
public void Remove(
    IUpdateEvent value
);
JScript
public function Remove(
     value : IUpdateEvent
) : Void;

Parameters

value

An IUpdateEvent of the event to remove.

Exceptions

Exception type | Condition
ArgumentException | The event does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateEventCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateEventCollection Class


UpdateEventCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateEventCollection1 As UpdateEventCollection

Dim key As Integer
Dim returnValue As IUpdateEvent
returnValue = updateEventCollection1.Item(key)

Dim sampleValue As IUpdateEvent
updateEventCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateEvent
C#
public new IUpdateEvent this[
    int index
] {get; set;}
C++
public:
property IUpdateEvent^ default[int] {
    IUpdateEvent^ get(int index);
    void set(int index, IUpdateEvent^ value);
}
J#
new public IUpdateEvent get_Item(
    int index
);
public void set_Item(
    int index
IUpdateEvent);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The event already exists in this collection.
ArgumentNullException | Cannot set a member of the collection to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateEventCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateEventCollection Class
UpdateEventCollection Members


UpdateFile Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines an update file associated with an InstallableItem.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim modified As DateTime
Dim fileUri As Uri
Dim totalBytes As Long
Dim type As FileType
Dim isEula As Boolean
Dim hash() As Byte
Dim updateFile1 As New UpdateFile(name, modified, fileUri, totalBytes, type, isEula, hash)

Syntax

Visual Basic
Public Class UpdateFile
C#
public class UpdateFile
C++
public ref class UpdateFile
J#
public class UpdateFile
JScript
public class UpdateFile

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateFile

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Members


UpdateFile Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines an update file associated with an InstallableItem.

The following tables list the members exposed by the UpdateFile type.

Public Constructors

Name | Description
UpdateFile | Public constructor.
Top

Public Properties

 | Name | Description
public property | FileUri | Gets the path to this file (on MU download center, 3 rd party site, or local path).
public property | Hash | Gets the SHA1 hash of this file.
public property | IsEula | Gets the IsEula flag of this file.
public property | Modified | Gets the NTFS modified date of the published file.
public property | Name | Gets the file Name.
public property | TotalBytes | Gets the total size in Bytes of this file.
public property | Type | Gets the type of this file.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateFile Class


UpdateFile Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim name As String
Dim modified As DateTime
Dim fileUri As Uri
Dim totalBytes As Long
Dim type As FileType
Dim isEula As Boolean
Dim hash() As Byte
Dim updateFile1 As New UpdateFile(name, modified, fileUri, totalBytes, type, isEula, hash)

Syntax

Visual Basic
Public Sub New( _
    ByVal name As String, _
    ByVal modified As DateTime, _
    ByVal fileUri As Uri, _
    ByVal totalBytes As Long, _
    ByVal type As FileType, _
    ByVal isEula As Boolean, _
    ByVal hash() As Byte _
)
C#
public UpdateFile(
    string name,
    DateTime modified,
    Uri fileUri,
    long totalBytes,
    FileType type,
    bool isEula,
    byte[] hash
);
C++
public:
UpdateFile(
    String^ name,
    DateTime^ modified,
    Uri^ fileUri,
    long long totalBytes,
    FileType type,
    bool isEula,
    array<unsigned char>^ hash
);
J#
public UpdateFile(
    System.String name,
    DateTime modified,
    Uri fileUri,
    long totalBytes,
    FileType type,
    boolean isEula,
    ubyte[] hash
);
JScript
public function UpdateFile(
     name : String,
     modified : DateTime,
     fileUri : Uri,
     totalBytes : long,
     type : FileType,
     isEula : Boolean,
     hash : Byte[]
);

Parameters

name

modified

fileUri

totalBytes

type

isEula

hash

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateFile Class


UpdateFile Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | FileUri | Gets the path to this file (on MU download center, 3 rd party site, or local path).
public property | Hash | Gets the SHA1 hash of this file.
public property | IsEula | Gets the IsEula flag of this file.
public property | Modified | Gets the NTFS modified date of the published file.
public property | Name | Gets the file Name.
public property | TotalBytes | Gets the total size in Bytes of this file.
public property | Type | Gets the type of this file.

See Also

Reference

UpdateFile Class


UpdateFile.FileUri Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the path to this file (on MU download center, 3 rd party site, or local path).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As Uri
returnValue = updateFile1.FileUri

Syntax

Visual Basic
Public ReadOnly Property FileUri() As Uri
C#
public Uri FileUri {get;}
C++
public:
property Uri^ FileUri {
    Uri^ get();
}
J#
public Uri get_FileUri();
JScript
public function get FileUri() : Uri;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.Hash Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the SHA1 hash of this file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As Byte
returnValue = updateFile1.Hash

Syntax

Visual Basic
Public ReadOnly Property Hash() As Byte()
C#
public byte[] Hash {get;}
C++
public:
property array<unsigned char>^ Hash {
    array<unsigned char>^ get();
}
J#
public ubyte[] get_Hash();
JScript
public function get Hash() : Byte[];

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.IsEula Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the IsEula flag of this file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As Boolean
returnValue = updateFile1.IsEula

Syntax

Visual Basic
Public ReadOnly Property IsEula() As Boolean
C#
public bool IsEula {get;}
C++
public:
property bool IsEula {
    bool get();
}
J#
public boolean get_IsEula();
JScript
public function get IsEula() : Boolean;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.Modified Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the NTFS modified date of the published file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As DateTime
returnValue = updateFile1.Modified

Syntax

Visual Basic
Public ReadOnly Property Modified() As DateTime
C#
public DateTime Modified {get;}
C++
public:
property DateTime^ Modified {
    DateTime^ get();
}
J#
public DateTime get_Modified();
JScript
public function get Modified() : DateTime;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.Name Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the file Name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As String
returnValue = updateFile1.Name

Syntax

Visual Basic
Public ReadOnly Property Name() As String
C#
public string Name {get;}
C++
public:
property String^ Name {
    String^ get();
}
J#
public System.String get_Name();
JScript
public function get Name() : String;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.TotalBytes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the total size in Bytes of this file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As Long
returnValue = updateFile1.TotalBytes

Syntax

Visual Basic
Public ReadOnly Property TotalBytes() As Long
C#
public long TotalBytes {get;}
C++
public:
property long long TotalBytes {
    long long get();
}
J#
public long get_TotalBytes();
JScript
public function get TotalBytes() : long;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateFile.Type Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the type of this file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateFile1 As UpdateFile

Dim returnValue As FileType
returnValue = updateFile1.Type

Syntax

Visual Basic
Public ReadOnly Property Type() As FileType
C#
public FileType Type {get;}
C++
public:
property FileType Type {
    FileType get();
}
J#
public FileType get_Type();
JScript
public function get Type() : FileType;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateFile Class
UpdateFile Members


UpdateInstallationInfoCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update installation information. To retrieve this collection, call one of the following methods: IComputerTarget.GetUpdateInstallationInfoPerUpdate(); IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(IUpdate); IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup) .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateInstallationInfoCollection1 As New UpdateInstallationInfoCollection()

Syntax

Visual Basic
Public Class UpdateInstallationInfoCollection
    Inherits WsusCollection
C#
public class UpdateInstallationInfoCollection : WsusCollection
C++
public ref class UpdateInstallationInfoCollection : WsusCollection
J#
public class UpdateInstallationInfoCollection extends WsusCollection
JScript
public class UpdateInstallationInfoCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateInstallationInfoCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of update installation information. To retrieve this collection, call one of the following methods: IComputerTarget.GetUpdateInstallationInfoPerUpdate(); IComputerTargetGroup.GetUpdateInstallationInfoPerComputerTarget(IUpdate); IUpdate.GetUpdateInstallationInfoPerComputerTarget(IComputerTargetGroup) .

The following tables list the members exposed by the UpdateInstallationInfoCollection type.

Public Constructors

Name | Description
UpdateInstallationInfoCollection | Initializes a new instance of the UpdateInstallationInfoCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateInstallationInfoCollection Class


UpdateInstallationInfoCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateInstallationInfoCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateInstallationInfoCollection1 As New UpdateInstallationInfoCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateInstallationInfoCollection();
C++
public:
UpdateInstallationInfoCollection();
J#
public UpdateInstallationInfoCollection();
JScript
public function UpdateInstallationInfoCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateInstallationInfoCollection Class


UpdateInstallationInfoCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.Add (IUpdateInstallationInfo) | Adds installation information to the end of the collection.
UpdateInstallationInfoCollection.Add (Object) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Add Method (IUpdateInstallationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds installation information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateInstallationInfo
Dim returnValue As Integer
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
returnValue = updateInstallationInfoCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateInstallationInfo _
) As Integer
C#
public int Add(
    IUpdateInstallationInfo value
);
C++
public:
int Add(
    IUpdateInstallationInfo^ value
);
J#
public int Add(
    IUpdateInstallationInfo value
);
JScript
public function Add(
     value : IUpdateInstallationInfo
) : int;

Parameters

value

An IUpdateInstallationInfo of the installation information to add.

Return Value

Zero-based index at which the installation information was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The installation information already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.AddRange (Array) |
UpdateInstallationInfoCollection.AddRange (IUpdateInstallationInfo[]) | Adds an array of installation information to the end of the collection.
UpdateInstallationInfoCollection.AddRange (UpdateInstallationInfoCollection) | Adds the members of an installation information collection to the end of the collection.
UpdateInstallationInfoCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.AddRange Method (IUpdateInstallationInfo[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of installation information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateInstallationInfo
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
updateInstallationInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateInstallationInfo _
)
C#
public void AddRange(
    IUpdateInstallationInfo[] value
);
C++
public:
void AddRange(
    array<IUpdateInstallationInfo^>^ value
);
J#
public void AddRange(
    IUpdateInstallationInfo[] value
);
JScript
public function AddRange(
     value : IUpdateInstallationInfo[]
) : Void;

Parameters

value

Array of IUpdateInstallationInfo instances to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.AddRange Method (UpdateInstallationInfoCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an installation information collection to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateInstallationInfoCollection
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
updateInstallationInfoCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateInstallationInfoCollection _
)
C#
public void AddRange(
    UpdateInstallationInfoCollection value
);
C++
public:
void AddRange(
    UpdateInstallationInfoCollection^ value
);
J#
public void AddRange(
    UpdateInstallationInfoCollection value
);
JScript
public function AddRange(
     value : UpdateInstallationInfoCollection
) : Void;

Parameters

value

An UpdateInstallationInfoCollection collection of installation information to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.Contains (IUpdateInstallationInfo) | Determines if the collection contains the specified installation information.
UpdateInstallationInfoCollection.Contains (Object) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Contains Method (IUpdateInstallationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified installation information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateInstallationInfo
Dim returnValue As Boolean
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
returnValue = updateInstallationInfoCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateInstallationInfo _
) As Boolean
C#
public bool Contains(
    IUpdateInstallationInfo value
);
C++
public:
bool Contains(
    IUpdateInstallationInfo^ value
);
J#
public boolean Contains(
    IUpdateInstallationInfo value
);
JScript
public function Contains(
     value : IUpdateInstallationInfo
) : Boolean;

Parameters

value

An IUpdateInstallationInfo of the installation information to locate in the collection.

Return Value

True if the collection contains the installation information; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.CopyTo (Array, Int32) |
UpdateInstallationInfoCollection.CopyTo (IUpdateInstallationInfo[], Int32) | Copies the installation information in the collection to a one-dimensional array.

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.CopyTo Method (IUpdateInstallationInfo[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the installation information in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateInstallationInfo
Dim index As Integer
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
updateInstallationInfoCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateInstallationInfo, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateInstallationInfo[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateInstallationInfo^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateInstallationInfo[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateInstallationInfo[],
     index : int
) : Void;

Parameters

array

Array of IUpdateInstallationInfo instances found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the installation information.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.IndexOf (IUpdateInstallationInfo) | Determines if the collection contains the specified installation information. If the collection contains the installation information, the method returns the zero-based index to the installation information in the collection.
UpdateInstallationInfoCollection.IndexOf (Object) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.IndexOf Method (IUpdateInstallationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified installation information. If the collection contains the installation information, the method returns the zero-based index to the installation information in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateInstallationInfo
Dim returnValue As Integer
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
returnValue = updateInstallationInfoCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateInstallationInfo _
) As Integer
C#
public int IndexOf(
    IUpdateInstallationInfo value
);
C++
public:
int IndexOf(
    IUpdateInstallationInfo^ value
);
J#
public int IndexOf(
    IUpdateInstallationInfo value
);
JScript
public function IndexOf(
     value : IUpdateInstallationInfo
) : int;

Parameters

value

An IUpdateInstallationInfo of the installation information to locate in the collection.

Return Value

Zero-based index of the installation information in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.Insert (Int32, IUpdateInstallationInfo) | Inserts installation information into the collection.
UpdateInstallationInfoCollection.Insert (Int32, Object) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Insert Method (Int32, IUpdateInstallationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts installation information into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateInstallationInfo
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
updateInstallationInfoCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateInstallationInfo _
)
C#
public void Insert(
    int index,
    IUpdateInstallationInfo value
);
C++
public:
void Insert(
    int index,
    IUpdateInstallationInfo^ value
);
J#
public void Insert(
    int index,
    IUpdateInstallationInfo value
);
JScript
public function Insert(
     index : int,
     value : IUpdateInstallationInfo
) : Void;

Parameters

index

Zero-based index at which to insert the installation information into the collection.

value

An IUpdateInstallationInfo of the installation information to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The installation information already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateInstallationInfoCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateInstallationInfoCollection.Remove (IUpdateInstallationInfo) | Removes the installation information from the collection.
UpdateInstallationInfoCollection.Remove (Object) |

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection.Remove Method (IUpdateInstallationInfo)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the installation information from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateInstallationInfo
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection
updateInstallationInfoCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateInstallationInfo _
)
C#
public void Remove(
    IUpdateInstallationInfo value
);
C++
public:
void Remove(
    IUpdateInstallationInfo^ value
);
J#
public void Remove(
    IUpdateInstallationInfo value
);
JScript
public function Remove(
     value : IUpdateInstallationInfo
) : Void;

Parameters

value

An IUpdateInstallationInfo of the installation information to remove.

Exceptions

Exception type | Condition
ArgumentException | The installation information does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationInfoCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateInstallationInfoCollection Class


UpdateInstallationInfoCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateInstallationInfoCollection1 As UpdateInstallationInfoCollection

Dim key As Integer
Dim returnValue As IUpdateInstallationInfo
returnValue = updateInstallationInfoCollection1.Item(key)

Dim sampleValue As IUpdateInstallationInfo
updateInstallationInfoCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateInstallationInfo
C#
public new IUpdateInstallationInfo this[
    int index
] {get; set;}
C++
public:
property IUpdateInstallationInfo^ default[int] {
    IUpdateInstallationInfo^ get(int index);
    void set(int index, IUpdateInstallationInfo^ value);
}
J#
new public IUpdateInstallationInfo get_Item(
    int index
);
public void set_Item(
    int index
IUpdateInstallationInfo);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The installation information already exists in this collection.
ArgumentNullException | Cannot set a member of the collection to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateInstallationInfoCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateInstallationInfoCollection Class
UpdateInstallationInfoCollection Members


UpdateInstallationState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the current state of the update on the client computer.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateInstallationState1 As UpdateInstallationState = UpdateInstallationState.Downloaded

Syntax

Visual Basic
Public Enum UpdateInstallationState
C#
public enum UpdateInstallationState
C++
public enum class UpdateInstallationState
J#
public enum UpdateInstallationState
JScript
public enum UpdateInstallationState

Members

Member name | Description
Downloaded | The update is applicable and is downloaded to the client computer, but the update is not installed.
Failed | The installation of the update on the client computer failed.
Installed | The update is installed on the client computer.
InstalledPendingReboot | The update is installed on the client computer, but the update does not take effect until the user restarts the computer.
NotApplicable | The update is not applicable to the client computer.
NotInstalled | The update is applicable to the client computer, but the update is not downloaded or installed.
Unknown | The state is unknown. The client may not have synchronized with the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
InstallationStatus
IUpdateInstallationInfo.UpdateInstallationState


UpdateInstallationStates Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateInstallationStates1 As UpdateInstallationStates = UpdateInstallationStates.All

Syntax

Visual Basic
Public Enum UpdateInstallationStates
C#
public enum UpdateInstallationStates
C++
public enum class UpdateInstallationStates
J#
public enum UpdateInstallationStates
JScript
public enum UpdateInstallationStates

Members

Member name | Description
All | Include Updates/Computers regardless of their installation state.
Downloaded | When searching for Updates, include updates that have at least one computer in the Downloaded state. When searching for Computers, include computers that have at least one update in the Downloaded state.
Failed | When searching for Updates, include updates that have at least one computer in the Failed state. When searching for Computers, include computers that have at least one update in the Failed state.
Installed | When searching for Updates, include updates that have at least one computer in the Installed state. When searching for Computers, include computers that have at least one update in the Installed state.
InstalledPendingReboot | When searching for Updates, include updates that have at least one computer in the InstalledPendingReboot state. When searching for Computers, include computers that have at least one update in the InstalledPendingReboot state.
NotApplicable | When searching for Updates, include updates that have at least one computer in the NotApplicable state. When searching for Computers, include computers that have at least one update in the NotApplicable state.
NotInstalled | When searching for Updates, include updates that have at least one computer in the NotInstalled state. When searching for Computers, include computers that have at least one update in the NotInstalled state.
Unknown | When searching for Updates, include updates that have at least one computer in the Unknown state. When searching for Computers, include computers that have at least one update in the Unknown state.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


UpdateLanguage Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use the language code strings that are defined in this class to specify a language code.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateLanguage1 As New UpdateLanguage()

Syntax

Visual Basic
NotInheritable Public Class UpdateLanguage
C#
public sealed class UpdateLanguage
C++
public ref class UpdateLanguage sealed
J#
public final class UpdateLanguage
JScript
public class UpdateLanguage

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateLanguage

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateLanguage Members


UpdateLanguage Members
See Also Constructors Fields Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Use the language code strings that are defined in this class to specify a language code.

The following tables list the members exposed by the UpdateLanguage type.

Public Constructors

Name | Description
UpdateLanguage |
Top

Public Fields

Name | Description
All |
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateLanguage Class


UpdateLanguage Fields
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Fields

Name | Description
All |

See Also

Reference

UpdateLanguage Class


UpdateLanguage.All Field
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As String
returnValue = UpdateLanguage.All

Syntax

Visual Basic
Public Const All As String
C#
public const string All;
C++
public:
literal String^ All;
J#
public static final System.String All;
JScript
public var All : String;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateLanguage Class
UpdateLanguage Members


UpdateLanguage Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateLanguage Class .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateLanguage1 As New UpdateLanguage()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateLanguage();
C++
public:
UpdateLanguage();
J#
public UpdateLanguage();
JScript
public function UpdateLanguage();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateLanguage Class
UpdateLanguage Members


UpdateLanguage Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateLanguage Class


UpdateMetadata Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines the set of properties belonged to an Update that includes the actual xml data and its content files if existing.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As New UpdateMetadata()

Syntax

Visual Basic
Public Class UpdateMetadata
C#
public class UpdateMetadata
C++
public ref class UpdateMetadata
J#
public class UpdateMetadata
JScript
public class UpdateMetadata

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateMetadata

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Members


UpdateMetadata Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class defines the set of properties belonged to an Update that includes the actual xml data and its content files if existing.

The following tables list the members exposed by the UpdateMetadata type.

Public Constructors

Name | Description
UpdateMetadata | Overloaded. Constructor for testability.
Top

Public Properties

 | Name | Description
public property | Files | Files belong to this Update
public property | Id | Files belong to this Update
public property | Metadata | (Uncompressed) xml meta-data of this Update's latest revision
public property | RevisionId | Locally unique revision ID
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateMetadata Class


UpdateMetadata Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor for testability.

Overload List

Name | Description
UpdateMetadata () | Constructor for testability.
UpdateMetadata (Guid, Int32, Int32, String) | Constructor to create an UpdateMetadata out of data extracted from the DB

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor for testability.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As New UpdateMetadata()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateMetadata();
C++
public:
UpdateMetadata();
J#
public UpdateMetadata();
JScript
public function UpdateMetadata();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata Constructor (Guid, Int32, Int32, String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor to create an UpdateMetadata out of data extracted from the DB

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateId As Guid
Dim revisionNumber As Integer
Dim revisionId As Integer
Dim metadata As String
Dim updateMetadata1 As New UpdateMetadata(updateId, revisionNumber, revisionId, metadata)

Syntax

Visual Basic
Public Sub New( _
    ByVal updateId As Guid, _
    ByVal revisionNumber As Integer, _
    ByVal revisionId As Integer, _
    ByVal metadata As String _
)
C#
public UpdateMetadata(
    Guid updateId,
    int revisionNumber,
    int revisionId,
    string metadata
);
C++
public:
UpdateMetadata(
    Guid^ updateId,
    int revisionNumber,
    int revisionId,
    String^ metadata
);
J#
public UpdateMetadata(
    Guid updateId,
    int revisionNumber,
    int revisionId,
    System.String metadata
);
JScript
public function UpdateMetadata(
     updateId : Guid,
     revisionNumber : int,
     revisionId : int,
     metadata : String
);

Parameters

updateId

revisionNumber

revisionId

metadata

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateMetadata Class


UpdateMetadata Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | Files | Files belong to this Update
public property | Id | Files belong to this Update
public property | Metadata | (Uncompressed) xml meta-data of this Update's latest revision
public property | RevisionId | Locally unique revision ID

See Also

Reference

UpdateMetadata Class


UpdateMetadata.Files Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Files belong to this Update

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As UpdateMetadata

Dim returnValue As Collection(Of UpdateFile)
returnValue = updateMetadata1.Files

Syntax

Visual Basic
Public ReadOnly Property Files() As Collection(Of UpdateFile)
C#
public Collection<UpdateFile> Files {get;}
C++
public:
property Collection<UpdateFile^>^ Files {
    Collection<UpdateFile^>^ get();
}
J#
public Collection<UpdateFile> get_Files();
JScript
public function get Files() : JScript does not support Generics.;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata.Id Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Files belong to this Update

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As UpdateMetadata

Dim returnValue As UpdateRevisionId
returnValue = updateMetadata1.Id

Syntax

Visual Basic
Public ReadOnly Property Id() As UpdateRevisionId
C#
public UpdateRevisionId Id {get;}
C++
public:
property UpdateRevisionId^ Id {
    UpdateRevisionId^ get();
}
J#
public UpdateRevisionId get_Id();
JScript
public function get Id() : UpdateRevisionId;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata.Metadata Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

(Uncompressed) xml meta-data of this Update's latest revision

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As UpdateMetadata

Dim returnValue As String
returnValue = updateMetadata1.Metadata

Syntax

Visual Basic
Public ReadOnly Property Metadata() As String
C#
public string Metadata {get;}
C++
public:
property String^ Metadata {
    String^ get();
}
J#
public System.String get_Metadata();
JScript
public function get Metadata() : String;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadata.RevisionId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Locally unique revision ID

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadata1 As UpdateMetadata

Dim returnValue As Integer
returnValue = updateMetadata1.RevisionId

Syntax

Visual Basic
Public ReadOnly Property RevisionId() As Integer
C#
public int RevisionId {get;}
C++
public:
property int RevisionId {
    int get();
}
J#
public int get_RevisionId();
JScript
public function get RevisionId() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateMetadata Class
UpdateMetadata Members


UpdateMetadataPropertyRowIndex Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateMetadataPropertyRowIndex1 As UpdateMetadataPropertyRowIndex = UpdateMetadataPropertyRowIndex.CompressedSize

Syntax

Visual Basic
Public Enum UpdateMetadataPropertyRowIndex
C#
public enum UpdateMetadataPropertyRowIndex
C++
public enum class UpdateMetadataPropertyRowIndex
J#
public enum UpdateMetadataPropertyRowIndex
JScript
public enum UpdateMetadataPropertyRowIndex

Members

Member name | Description
CompressedSize |
Metadata |
RevisionId |
RevisionNumber |
UpdateId |
XmlCompressed |

Remarks

This enumeration type is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


UpdateRelationship Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants the describe the relationship between updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateRelationship1 As UpdateRelationship = UpdateRelationship.AllRevisionsOfThisUpdate

Syntax

Visual Basic
Public Enum UpdateRelationship
C#
public enum UpdateRelationship
C++
public enum class UpdateRelationship
J#
public enum UpdateRelationship
JScript
public enum UpdateRelationship

Members

Member name | Description
AllRevisionsOfThisUpdate | All revisions of this update.
UpdatesBundledByThisUpdate | Child updates that this update bundles.
UpdatesRequiredByThisUpdate | Updates that must be installed before this update can be installed.
UpdatesSupersededByThisUpdate | Updates that are superseded by this update.
UpdatesThatBundleThisUpdate | Parent updates that bundle this update.
UpdatesThatRequireThisUpdate | Updates that require this update to be installed before they can be installed.
UpdatesThatSupersedeThisUpdate | Updates that supersede this update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.GetRelatedUpdates


UpdateRevisionId Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifies a specific revision of an update. Use the new keyword to initialize a new instance of the class or call one of the following properties to retrieve an instance of this class: IUpdateClassification.Id ; IUpdateCategory.Id ; SynchronizationUpdateErrorInfo.UpdateId ; IUpdate.Id .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateRevisionId1 As New UpdateRevisionId()

Syntax

Visual Basic
Public Class UpdateRevisionId
C#
public class UpdateRevisionId
C++
public ref class UpdateRevisionId
J#
public class UpdateRevisionId
JScript
public class UpdateRevisionId

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateRevisionId

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Members


UpdateRevisionId Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifies a specific revision of an update. Use the new keyword to initialize a new instance of the class or call one of the following properties to retrieve an instance of this class: IUpdateClassification.Id ; IUpdateCategory.Id ; SynchronizationUpdateErrorInfo.UpdateId ; IUpdate.Id .

The following tables list the members exposed by the UpdateRevisionId type.

Public Constructors

Name | Description
UpdateRevisionId | Overloaded.
Top

Public Properties

 | Name | Description
public property | RevisionNumber | Revision number of a specific revision of an update.
public property | UpdateId | Identifier that uniquely identifies the update.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateRevisionId Class


UpdateRevisionId Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateRevisionId () | Initializes a new instance of the UpdateRevisionId class.
UpdateRevisionId (Guid) | Initializes a new instance of the UpdateRevisionId class to the latest revision of an update.
UpdateRevisionId (Guid, Int32) | Initializes a new instance of the UpdateRevisionId class to a specific revision of an update.

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateRevisionId class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateRevisionId1 As New UpdateRevisionId()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateRevisionId();
C++
public:
UpdateRevisionId();
J#
public UpdateRevisionId();
JScript
public function UpdateRevisionId();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId Constructor (Guid)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateRevisionId class to the latest revision of an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateId As Guid
Dim updateRevisionId1 As New UpdateRevisionId(updateId)

Syntax

Visual Basic
Public Sub New( _
    ByVal updateId As Guid _
)
C#
public UpdateRevisionId(
    Guid updateId
);
C++
public:
UpdateRevisionId(
    Guid^ updateId
);
J#
public UpdateRevisionId(
    Guid updateId
);
JScript
public function UpdateRevisionId(
     updateId : Guid
);

Parameters

updateId

Identifier that uniquely identifies the update.

Remarks

Sets UpdateRevisionId.RevisionNumber to zero, which indicates the latest revision of the update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId Constructor (Guid, Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateRevisionId class to a specific revision of an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateId As Guid
Dim revisionNumber As Integer
Dim updateRevisionId1 As New UpdateRevisionId(updateId, revisionNumber)

Syntax

Visual Basic
Public Sub New( _
    ByVal updateId As Guid, _
    ByVal revisionNumber As Integer _
)
C#
public UpdateRevisionId(
    Guid updateId,
    int revisionNumber
);
C++
public:
UpdateRevisionId(
    Guid^ updateId,
    int revisionNumber
);
J#
public UpdateRevisionId(
    Guid updateId,
    int revisionNumber
);
JScript
public function UpdateRevisionId(
     updateId : Guid,
     revisionNumber : int
);

Parameters

updateId

Identifier that uniquely identifies the update.

revisionNumber

Revision number of a specific revision of the update. To specify the latest revision, set to zero.

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. Overridden.
public method | GetHashCode | Overridden.
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateRevisionId Class


UpdateRevisionId.Equals Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateRevisionId.Equals (Object) |
UpdateRevisionId.Equals (Object, Object) |

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId.Equals Method (Object)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim obj As Object
Dim returnValue As Boolean
Dim updateRevisionId1 As UpdateRevisionId
returnValue = updateRevisionId1.Equals(obj)

Syntax

Visual Basic
Overloads Public Overrides Function Equals( _
    ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
    object obj
);
C++
public:
virtual bool Equals(
    Object^ obj
) override;
J#
public override boolean Equals(
    System.Object obj
);
JScript
public override function Equals(
     obj : Object
) : Boolean;

Parameters

obj

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId.GetHashCode Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim returnValue As Integer
Dim updateRevisionId1 As UpdateRevisionId
returnValue = updateRevisionId1.GetHashCode()

Syntax

Visual Basic
Public Overrides Function GetHashCode() As Integer
C#
public override int GetHashCode();
C++
public:
virtual int GetHashCode() override;
J#
public override int GetHashCode();
JScript
public override function GetHashCode() : int;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | RevisionNumber | Revision number of a specific revision of an update.
public property | UpdateId | Identifier that uniquely identifies the update.

See Also

Reference

UpdateRevisionId Class


UpdateRevisionId.RevisionNumber Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Revision number of a specific revision of an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateRevisionId1 As UpdateRevisionId

Dim returnValue As Integer
returnValue = updateRevisionId1.RevisionNumber

Dim sampleValue As Integer
updateRevisionId1.RevisionNumber = sampleValue

Syntax

Visual Basic
Public Property RevisionNumber() As Integer
C#
public int RevisionNumber {get; set;}
C++
public:
property int RevisionNumber {
    int get();
    void set(int value);
}
J#
public int get_RevisionNumber();
public void set_RevisionNumber(int);
JScript
public function get RevisionNumber() : int;
public function set RevisionNumber(int);

Property Value

Revision number of a specific revision of an update. To specify the latest revision, set to zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateRevisionId.UpdateId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Identifier that uniquely identifies the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateRevisionId1 As UpdateRevisionId

Dim returnValue As Guid
returnValue = updateRevisionId1.UpdateId

Dim sampleValue As Guid
updateRevisionId1.UpdateId = sampleValue

Syntax

Visual Basic
Public Property UpdateId() As Guid
C#
public Guid UpdateId {get; set;}
C++
public:
property Guid^ UpdateId {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_UpdateId();
public void set_UpdateId(Guid);
JScript
public function get UpdateId() : Guid;
public function set UpdateId(Guid);

Property Value

Identifier that uniquely identifies the update. The identifier is assigned by the publisher of the update.

Remarks

All revisions of an update use the same identifier. To specify a specific revision of the update, use UpdateRevisionId.RevisionNumber

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateRevisionId Class
UpdateRevisionId Members


UpdateScope Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the set of parameters that can be used to filter the results when obtaining the list of Updates.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As New UpdateScope()

Syntax

Visual Basic
Public Class UpdateScope
C#
public class UpdateScope
C++
public ref class UpdateScope
J#
public class UpdateScope
JScript
public class UpdateScope

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateScope

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Members


UpdateScope Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines the set of parameters that can be used to filter the results when obtaining the list of Updates.

The following tables list the members exposed by the UpdateScope type.

Public Constructors

Name | Description
UpdateScope | Default constructor.
Top

Public Properties

 | Name | Description
public property | ApprovedComputerTargetGroups | Gets the list of target groups to search in for approvals. An update will be included only if is approved for install or uninstall to at least one of these groups. If empty, then no filtering will be done based on approved target groups. Defaults to empty.
public property | ApprovedStates | Gets or sets the approval states to search for. An update will be included only if it matches at least one of the specified states. This value may be a combination of any number of values from ApprovedStates. Defaults to ApprovedStates.Any.
public property | Categories | Gets or sets the list of update categories to search in. An update will be included only if it belongs to at least one of these groups. If empty, then no filtering will be done based on category; updates from all categories will be included. Defaults to empty.
public property | Classifications | Gets or sets the list of update classifications to search in. An update will be included only if it belongs to at least one of these classifications. If empty, then no filtering will be done based on classification; updates from all classifications will be included. Defaults to empty.
public property | ExcludedInstallationStates | Gets or sets the installation states to exclude. An update will be included only if it does not have any computers in any of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to 0.
public property | FromArrivalDate | Gets or sets the minimum ArrivalDate to search for. An update will be included only if its ArrivalDate is greater than or equal to this value. Defaults to DateTime.MinValue.
public property | FromCreationDate | Gets or sets the minimum CreationDate to search for. An update will be included only if its CreationDate is greater than or equal to this value. Defaults to DateTime.MinValue.
public property | IncludedInstallationStates | Gets or sets the installation states to search for. An update will be included only if it has at least one computer in one of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to UpdateInstallationStates.All.
public property | IsWsusInfrastructureUpdate | Gets or sets whether or not to filter for WSUS infrastructure updates. If set to true, only WSUS infrastructure updates will be included. If set to false, all updates are included. Defaults to false.
public property | TextIncludes | Gets or sets the string to search for. An update will be included only if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.
public property | TextNotIncludes | Gets or sets the string to exclude. An update will be not be included if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.
public property | ToArrivalDate | Gets or sets the maximum ArrivalDate to search for. An update will be included only if its ArrivalDate is less than or equal to this value. Defaults to DateTime.MaxValue.
public property | ToCreationDate | Gets or sets the maximum CreationDate to search for. An update will be included only if its CreationDate is less than or equal to this value. Defaults to DateTime.MaxValue.
public property | UpdateApprovalActions | Gets or sets the update approval actions to search for. An update will be included only if it is approved to at least one computer target group for one of the specified approval actions. This value may be a combination of any number of values from UpdateApprovalActions. Defaults to UpdateApprovalActions.All.
public property | UpdateTypes | Gets or sets the update types to search for. An update will be included only if its UpdateType is included in this value. This value may be a combination of any number of values from UpdateTypes. Defaults to UpdateTypes.All.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateScope Class


UpdateScope Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As New UpdateScope()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateScope();
C++
public:
UpdateScope();
J#
public UpdateScope();
JScript
public function UpdateScope();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateScope Class


UpdateScope Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApprovedComputerTargetGroups | Gets the list of target groups to search in for approvals. An update will be included only if is approved for install or uninstall to at least one of these groups. If empty, then no filtering will be done based on approved target groups. Defaults to empty.
public property | ApprovedStates | Gets or sets the approval states to search for. An update will be included only if it matches at least one of the specified states. This value may be a combination of any number of values from ApprovedStates. Defaults to ApprovedStates.Any.
public property | Categories | Gets or sets the list of update categories to search in. An update will be included only if it belongs to at least one of these groups. If empty, then no filtering will be done based on category; updates from all categories will be included. Defaults to empty.
public property | Classifications | Gets or sets the list of update classifications to search in. An update will be included only if it belongs to at least one of these classifications. If empty, then no filtering will be done based on classification; updates from all classifications will be included. Defaults to empty.
public property | ExcludedInstallationStates | Gets or sets the installation states to exclude. An update will be included only if it does not have any computers in any of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to 0.
public property | FromArrivalDate | Gets or sets the minimum ArrivalDate to search for. An update will be included only if its ArrivalDate is greater than or equal to this value. Defaults to DateTime.MinValue.
public property | FromCreationDate | Gets or sets the minimum CreationDate to search for. An update will be included only if its CreationDate is greater than or equal to this value. Defaults to DateTime.MinValue.
public property | IncludedInstallationStates | Gets or sets the installation states to search for. An update will be included only if it has at least one computer in one of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to UpdateInstallationStates.All.
public property | IsWsusInfrastructureUpdate | Gets or sets whether or not to filter for WSUS infrastructure updates. If set to true, only WSUS infrastructure updates will be included. If set to false, all updates are included. Defaults to false.
public property | TextIncludes | Gets or sets the string to search for. An update will be included only if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.
public property | TextNotIncludes | Gets or sets the string to exclude. An update will be not be included if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.
public property | ToArrivalDate | Gets or sets the maximum ArrivalDate to search for. An update will be included only if its ArrivalDate is less than or equal to this value. Defaults to DateTime.MaxValue.
public property | ToCreationDate | Gets or sets the maximum CreationDate to search for. An update will be included only if its CreationDate is less than or equal to this value. Defaults to DateTime.MaxValue.
public property | UpdateApprovalActions | Gets or sets the update approval actions to search for. An update will be included only if it is approved to at least one computer target group for one of the specified approval actions. This value may be a combination of any number of values from UpdateApprovalActions. Defaults to UpdateApprovalActions.All.
public property | UpdateTypes | Gets or sets the update types to search for. An update will be included only if its UpdateType is included in this value. This value may be a combination of any number of values from UpdateTypes. Defaults to UpdateTypes.All.

See Also

Reference

UpdateScope Class


UpdateScope.ApprovedComputerTargetGroups Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets the list of target groups to search in for approvals. An update will be included only if is approved for install or uninstall to at least one of these groups. If empty, then no filtering will be done based on approved target groups. Defaults to empty.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As ComputerTargetGroupCollection
returnValue = updateScope1.ApprovedComputerTargetGroups

Syntax

Visual Basic
Public ReadOnly Property ApprovedComputerTargetGroups() As ComputerTargetGroupCollection
C#
public ComputerTargetGroupCollection ApprovedComputerTargetGroups {get;}
C++
public:
property ComputerTargetGroupCollection^ ApprovedComputerTargetGroups {
    ComputerTargetGroupCollection^ get();
}
J#
public ComputerTargetGroupCollection get_ApprovedComputerTargetGroups();
JScript
public function get ApprovedComputerTargetGroups() : ComputerTargetGroupCollection;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.ApprovedStates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the approval states to search for. An update will be included only if it matches at least one of the specified states. This value may be a combination of any number of values from ApprovedStates. Defaults to ApprovedStates.Any.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As ApprovedStates
returnValue = updateScope1.ApprovedStates

Dim sampleValue As ApprovedStates
updateScope1.ApprovedStates = sampleValue

Syntax

Visual Basic
Public Property ApprovedStates() As ApprovedStates
C#
public ApprovedStates ApprovedStates {get; set;}
C++
public:
property ApprovedStates ApprovedStates {
    ApprovedStates get();
    void set(ApprovedStates value);
}
J#
public ApprovedStates get_ApprovedStates();
public void set_ApprovedStates(ApprovedStates);
JScript
public function get ApprovedStates() : ApprovedStates;
public function set ApprovedStates(ApprovedStates);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.Categories Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the list of update categories to search in. An update will be included only if it belongs to at least one of these groups. If empty, then no filtering will be done based on category; updates from all categories will be included. Defaults to empty.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateCategoryCollection
returnValue = updateScope1.Categories

Dim sampleValue As UpdateCategoryCollection
updateScope1.Categories = sampleValue

Syntax

Visual Basic
Public Property Categories() As UpdateCategoryCollection
C#
public UpdateCategoryCollection Categories {get; set;}
C++
public:
property UpdateCategoryCollection^ Categories {
    UpdateCategoryCollection^ get();
    void set(UpdateCategoryCollection^ value);
}
J#
public UpdateCategoryCollection get_Categories();
public void set_Categories(UpdateCategoryCollection);
JScript
public function get Categories() : UpdateCategoryCollection;
public function set Categories(UpdateCategoryCollection);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.Classifications Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the list of update classifications to search in. An update will be included only if it belongs to at least one of these classifications. If empty, then no filtering will be done based on classification; updates from all classifications will be included. Defaults to empty.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateClassificationCollection
returnValue = updateScope1.Classifications

Dim sampleValue As UpdateClassificationCollection
updateScope1.Classifications = sampleValue

Syntax

Visual Basic
Public Property Classifications() As UpdateClassificationCollection
C#
public UpdateClassificationCollection Classifications {get; set;}
C++
public:
property UpdateClassificationCollection^ Classifications {
    UpdateClassificationCollection^ get();
    void set(UpdateClassificationCollection^ value);
}
J#
public UpdateClassificationCollection get_Classifications();
public void set_Classifications(UpdateClassificationCollection);
JScript
public function get Classifications() : UpdateClassificationCollection;
public function set Classifications(UpdateClassificationCollection);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.ExcludedInstallationStates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the installation states to exclude. An update will be included only if it does not have any computers in any of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to 0.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateInstallationStates
returnValue = updateScope1.ExcludedInstallationStates

Dim sampleValue As UpdateInstallationStates
updateScope1.ExcludedInstallationStates = sampleValue

Syntax

Visual Basic
Public Property ExcludedInstallationStates() As UpdateInstallationStates
C#
public UpdateInstallationStates ExcludedInstallationStates {get; set;}
C++
public:
property UpdateInstallationStates ExcludedInstallationStates {
    UpdateInstallationStates get();
    void set(UpdateInstallationStates value);
}
J#
public UpdateInstallationStates get_ExcludedInstallationStates();
public void set_ExcludedInstallationStates(UpdateInstallationStates);
JScript
public function get ExcludedInstallationStates() : UpdateInstallationStates;
public function set ExcludedInstallationStates(UpdateInstallationStates);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.FromArrivalDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the minimum ArrivalDate to search for. An update will be included only if its ArrivalDate is greater than or equal to this value. Defaults to DateTime.MinValue.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As DateTime
returnValue = updateScope1.FromArrivalDate

Dim sampleValue As DateTime
updateScope1.FromArrivalDate = sampleValue

Syntax

Visual Basic
Public Property FromArrivalDate() As DateTime
C#
public DateTime FromArrivalDate {get; set;}
C++
public:
property DateTime^ FromArrivalDate {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_FromArrivalDate();
public void set_FromArrivalDate(DateTime);
JScript
public function get FromArrivalDate() : DateTime;
public function set FromArrivalDate(DateTime);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.FromCreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the minimum CreationDate to search for. An update will be included only if its CreationDate is greater than or equal to this value. Defaults to DateTime.MinValue.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As DateTime
returnValue = updateScope1.FromCreationDate

Dim sampleValue As DateTime
updateScope1.FromCreationDate = sampleValue

Syntax

Visual Basic
Public Property FromCreationDate() As DateTime
C#
public DateTime FromCreationDate {get; set;}
C++
public:
property DateTime^ FromCreationDate {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_FromCreationDate();
public void set_FromCreationDate(DateTime);
JScript
public function get FromCreationDate() : DateTime;
public function set FromCreationDate(DateTime);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.IncludedInstallationStates Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the installation states to search for. An update will be included only if it has at least one computer in one of the specified states. This value may be a combination of any number of values from UpdateInstallationStates. Defaults to UpdateInstallationStates.All.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateInstallationStates
returnValue = updateScope1.IncludedInstallationStates

Dim sampleValue As UpdateInstallationStates
updateScope1.IncludedInstallationStates = sampleValue

Syntax

Visual Basic
Public Property IncludedInstallationStates() As UpdateInstallationStates
C#
public UpdateInstallationStates IncludedInstallationStates {get; set;}
C++
public:
property UpdateInstallationStates IncludedInstallationStates {
    UpdateInstallationStates get();
    void set(UpdateInstallationStates value);
}
J#
public UpdateInstallationStates get_IncludedInstallationStates();
public void set_IncludedInstallationStates(UpdateInstallationStates);
JScript
public function get IncludedInstallationStates() : UpdateInstallationStates;
public function set IncludedInstallationStates(UpdateInstallationStates);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.IsWsusInfrastructureUpdate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets whether or not to filter for WSUS infrastructure updates. If set to true, only WSUS infrastructure updates will be included. If set to false, all updates are included. Defaults to false.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As Boolean
returnValue = updateScope1.IsWsusInfrastructureUpdate

Dim sampleValue As Boolean
updateScope1.IsWsusInfrastructureUpdate = sampleValue

Syntax

Visual Basic
Public Property IsWsusInfrastructureUpdate() As Boolean
C#
public bool IsWsusInfrastructureUpdate {get; set;}
C++
public:
property bool IsWsusInfrastructureUpdate {
    bool get();
    void set(bool value);
}
J#
public boolean get_IsWsusInfrastructureUpdate();
public void set_IsWsusInfrastructureUpdate(boolean);
JScript
public function get IsWsusInfrastructureUpdate() : Boolean;
public function set IsWsusInfrastructureUpdate(Boolean);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.TextIncludes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the string to search for. An update will be included only if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As String
returnValue = updateScope1.TextIncludes

Dim sampleValue As String
updateScope1.TextIncludes = sampleValue

Syntax

Visual Basic
Public Property TextIncludes() As String
C#
public string TextIncludes {get; set;}
C++
public:
property String^ TextIncludes {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_TextIncludes();
public void set_TextIncludes(System.String);
JScript
public function get TextIncludes() : String;
public function set TextIncludes(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.TextNotIncludes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the string to exclude. An update will be not be included if its Title, Description, KnowledgebaseArticles, or SecurityBulletins contains this string.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As String
returnValue = updateScope1.TextNotIncludes

Dim sampleValue As String
updateScope1.TextNotIncludes = sampleValue

Syntax

Visual Basic
Public Property TextNotIncludes() As String
C#
public string TextNotIncludes {get; set;}
C++
public:
property String^ TextNotIncludes {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_TextNotIncludes();
public void set_TextNotIncludes(System.String);
JScript
public function get TextNotIncludes() : String;
public function set TextNotIncludes(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.ToArrivalDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the maximum ArrivalDate to search for. An update will be included only if its ArrivalDate is less than or equal to this value. Defaults to DateTime.MaxValue.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As DateTime
returnValue = updateScope1.ToArrivalDate

Dim sampleValue As DateTime
updateScope1.ToArrivalDate = sampleValue

Syntax

Visual Basic
Public Property ToArrivalDate() As DateTime
C#
public DateTime ToArrivalDate {get; set;}
C++
public:
property DateTime^ ToArrivalDate {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_ToArrivalDate();
public void set_ToArrivalDate(DateTime);
JScript
public function get ToArrivalDate() : DateTime;
public function set ToArrivalDate(DateTime);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.ToCreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the maximum CreationDate to search for. An update will be included only if its CreationDate is less than or equal to this value. Defaults to DateTime.MaxValue.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As DateTime
returnValue = updateScope1.ToCreationDate

Dim sampleValue As DateTime
updateScope1.ToCreationDate = sampleValue

Syntax

Visual Basic
Public Property ToCreationDate() As DateTime
C#
public DateTime ToCreationDate {get; set;}
C++
public:
property DateTime^ ToCreationDate {
    DateTime^ get();
    void set(DateTime^ value);
}
J#
public DateTime get_ToCreationDate();
public void set_ToCreationDate(DateTime);
JScript
public function get ToCreationDate() : DateTime;
public function set ToCreationDate(DateTime);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.UpdateApprovalActions Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the update approval actions to search for. An update will be included only if it is approved to at least one computer target group for one of the specified approval actions. This value may be a combination of any number of values from UpdateApprovalActions. Defaults to UpdateApprovalActions.All.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateApprovalActions
returnValue = updateScope1.UpdateApprovalActions

Dim sampleValue As UpdateApprovalActions
updateScope1.UpdateApprovalActions = sampleValue

Syntax

Visual Basic
Public Property UpdateApprovalActions() As UpdateApprovalActions
C#
public UpdateApprovalActions UpdateApprovalActions {get; set;}
C++
public:
property UpdateApprovalActions UpdateApprovalActions {
    UpdateApprovalActions get();
    void set(UpdateApprovalActions value);
}
J#
public UpdateApprovalActions get_UpdateApprovalActions();
public void set_UpdateApprovalActions(UpdateApprovalActions);
JScript
public function get UpdateApprovalActions() : UpdateApprovalActions;
public function set UpdateApprovalActions(UpdateApprovalActions);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateScope.UpdateTypes Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the update types to search for. An update will be included only if its UpdateType is included in this value. This value may be a combination of any number of values from UpdateTypes. Defaults to UpdateTypes.All.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateScope1 As UpdateScope

Dim returnValue As UpdateTypes
returnValue = updateScope1.UpdateTypes

Dim sampleValue As UpdateTypes
updateScope1.UpdateTypes = sampleValue

Syntax

Visual Basic
Public Property UpdateTypes() As UpdateTypes
C#
public UpdateTypes UpdateTypes {get; set;}
C++
public:
property UpdateTypes UpdateTypes {
    UpdateTypes get();
    void set(UpdateTypes value);
}
J#
public UpdateTypes get_UpdateTypes();
public void set_UpdateTypes(UpdateTypes);
JScript
public function get UpdateTypes() : UpdateTypes;
public function set UpdateTypes(UpdateTypes);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateScope Class
UpdateScope Members


UpdateServerConfigurationState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate if the WSUS database is ready to save changes.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerConfigurationState1 As UpdateServerConfigurationState = UpdateServerConfigurationState.ProcessingSave

Syntax

Visual Basic
Public Enum UpdateServerConfigurationState
C#
public enum UpdateServerConfigurationState
C++
public enum class UpdateServerConfigurationState
J#
public enum UpdateServerConfigurationState
JScript
public enum UpdateServerConfigurationState

Members

Member name | Description
ProcessingSave | The database is currently processing another save request at this time and cannot support your request.
Ready | The database is available to process requests. You should check for this value before calling IUpdateServerConfiguration.Save.
SynchronizationInProgress | The database is currently synchronizing update information at this time and cannot support your request.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateServerConfiguration.GetUpdateServerConfigurationState


UpdateServerStatus Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class contains statistics summarizing the current state of the WSUS server, updates, and the client computers. To retrieve this class, call the IUpdateServer.GetStatus method. The statistics are a snapshot in time of the current counts. You need to call the IUpdateServer.GetStatus method each time you want to receive the current counts. Do not use the new keyword to create a this class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As New UpdateServerStatus()

Syntax

Visual Basic
Public Class UpdateServerStatus
C#
public class UpdateServerStatus
C++
public ref class UpdateServerStatus
J#
public class UpdateServerStatus
JScript
public class UpdateServerStatus

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateServerStatus

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Members


UpdateServerStatus Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class contains statistics summarizing the current state of the WSUS server, updates, and the client computers. To retrieve this class, call the IUpdateServer.GetStatus method. The statistics are a snapshot in time of the current counts. You need to call the IUpdateServer.GetStatus method each time you want to receive the current counts. Do not use the new keyword to create a this class.

The following tables list the members exposed by the UpdateServerStatus type.

Public Constructors

Name | Description
UpdateServerStatus | Initializes a new instance of the UpdateServerStatus class.
Top

Public Properties

 | Name | Description
public property | ApprovedUpdateCount | Number of updates on the WSUS server that have been approved.
public property | ComputersUpToDateCount | Get or set the number of ComputerTargets on which all Updates are known to be Installed or NotApplicable.
public property | ComputerTargetCount | Number of clients that are known to the WSUS server.
public property | ComputerTargetsNeedingUpdatesCount | Number of clients with at least one update that is not yet installed.
public property | ComputerTargetsWithUpdateErrorsCount | Number of clients with at least one update that is currently in a failure state.
public property | CriticalOrSecurityUpdatesNotApprovedForInstallCount | Number of critical or security updates on the WSUS server that are not approved for installation.
public property | CustomComputerTargetGroupCount | Number of administrator-created computer target groups on the WSUS server.
public property | DeclinedUpdateCount | Number of updates on the WSUS server that have been declined by an administrator.
public property | ExpiredUpdateCount | Number of updates on the WSUS server whose latest revision is marked as expired by the publisher of the update.
public property | NotApprovedUpdateCount | Number of updates on the WSUS server that have not been approved or declined.
public property | ShouldDeleteUnneededRevisions | Indicates if the WSUS database is growing too large and that unneeded revisions should be deleted.
public property | UnrecognizedClientRequestedTargetGroupNames | Names of target groups requested by clients that do not match existing target groups on the server.
public property | UpdateCount | Total number of updates on the WSUS server.
public property | UpdatesNeededByComputersCount | Number of updates on the WSUS server that are needed by one or more client computers.
public property | UpdatesNeedingFilesCount | Number of updates on the WSUS server that do not have all the required installation files.
public property | UpdatesUpToDateCount | Get or set the number of Updates on the UpdateServer that are known to be Installed or NotApplicable on all computers.
public property | UpdatesWithClientErrorsCount | Number of updates on the WSUS server that have at least one client that is currently in a failed state for that update.
public property | UpdatesWithServerErrorsCount | Number of updates on the WSUS server that are in a failure state.
public property | UpdatesWithStaleUpdateApprovalsCount | Number of updates on the WSUS server that have a revision of an update that is approved but is not the latest revision.
public property | WsusInfrastructureUpdatesNotApprovedForInstallCount | Number of WSUS infrastructure updates on the WSUS server that are not approved for installation.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateServerStatus Class


UpdateServerStatus Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateServerStatus class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As New UpdateServerStatus()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateServerStatus();
C++
public:
UpdateServerStatus();
J#
public UpdateServerStatus();
JScript
public function UpdateServerStatus();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateServerStatus Class


UpdateServerStatus Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApprovedUpdateCount | Number of updates on the WSUS server that have been approved.
public property | ComputersUpToDateCount | Get or set the number of ComputerTargets on which all Updates are known to be Installed or NotApplicable.
public property | ComputerTargetCount | Number of clients that are known to the WSUS server.
public property | ComputerTargetsNeedingUpdatesCount | Number of clients with at least one update that is not yet installed.
public property | ComputerTargetsWithUpdateErrorsCount | Number of clients with at least one update that is currently in a failure state.
public property | CriticalOrSecurityUpdatesNotApprovedForInstallCount | Number of critical or security updates on the WSUS server that are not approved for installation.
public property | CustomComputerTargetGroupCount | Number of administrator-created computer target groups on the WSUS server.
public property | DeclinedUpdateCount | Number of updates on the WSUS server that have been declined by an administrator.
public property | ExpiredUpdateCount | Number of updates on the WSUS server whose latest revision is marked as expired by the publisher of the update.
public property | NotApprovedUpdateCount | Number of updates on the WSUS server that have not been approved or declined.
public property | ShouldDeleteUnneededRevisions | Indicates if the WSUS database is growing too large and that unneeded revisions should be deleted.
public property | UnrecognizedClientRequestedTargetGroupNames | Names of target groups requested by clients that do not match existing target groups on the server.
public property | UpdateCount | Total number of updates on the WSUS server.
public property | UpdatesNeededByComputersCount | Number of updates on the WSUS server that are needed by one or more client computers.
public property | UpdatesNeedingFilesCount | Number of updates on the WSUS server that do not have all the required installation files.
public property | UpdatesUpToDateCount | Get or set the number of Updates on the UpdateServer that are known to be Installed or NotApplicable on all computers.
public property | UpdatesWithClientErrorsCount | Number of updates on the WSUS server that have at least one client that is currently in a failed state for that update.
public property | UpdatesWithServerErrorsCount | Number of updates on the WSUS server that are in a failure state.
public property | UpdatesWithStaleUpdateApprovalsCount | Number of updates on the WSUS server that have a revision of an update that is approved but is not the latest revision.
public property | WsusInfrastructureUpdatesNotApprovedForInstallCount | Number of WSUS infrastructure updates on the WSUS server that are not approved for installation.

See Also

Reference

UpdateServerStatus Class


UpdateServerStatus.ApprovedUpdateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that have been approved.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ApprovedUpdateCount

Dim sampleValue As Integer
updateServerStatus1.ApprovedUpdateCount = sampleValue

Syntax

Visual Basic
Public Property ApprovedUpdateCount() As Integer
C#
public int ApprovedUpdateCount {get; set;}
C++
public:
property int ApprovedUpdateCount {
    int get();
    void set(int value);
}
J#
public int get_ApprovedUpdateCount();
public void set_ApprovedUpdateCount(int);
JScript
public function get ApprovedUpdateCount() : int;
public function set ApprovedUpdateCount(int);

Property Value

Number of updates on the WSUS server that have been approved.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ComputersUpToDateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get or set the number of ComputerTargets on which all Updates are known to be Installed or NotApplicable.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ComputersUpToDateCount

Dim sampleValue As Integer
updateServerStatus1.ComputersUpToDateCount = sampleValue

Syntax

Visual Basic
Public Property ComputersUpToDateCount() As Integer
C#
public int ComputersUpToDateCount {get; set;}
C++
public:
property int ComputersUpToDateCount {
    int get();
    void set(int value);
}
J#
public int get_ComputersUpToDateCount();
public void set_ComputersUpToDateCount(int);
JScript
public function get ComputersUpToDateCount() : int;
public function set ComputersUpToDateCount(int);

Property Value

The number of ComputerTargets on which all Updates are known to be Installed or NotApplicable.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ComputerTargetCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of clients that are known to the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ComputerTargetCount

Dim sampleValue As Integer
updateServerStatus1.ComputerTargetCount = sampleValue

Syntax

Visual Basic
Public Property ComputerTargetCount() As Integer
C#
public int ComputerTargetCount {get; set;}
C++
public:
property int ComputerTargetCount {
    int get();
    void set(int value);
}
J#
public int get_ComputerTargetCount();
public void set_ComputerTargetCount(int);
JScript
public function get ComputerTargetCount() : int;
public function set ComputerTargetCount(int);

Property Value

Number of clients that are known to the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ComputerTargetsNeedingUpdatesCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of clients with at least one update that is not yet installed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ComputerTargetsNeedingUpdatesCount

Dim sampleValue As Integer
updateServerStatus1.ComputerTargetsNeedingUpdatesCount = sampleValue

Syntax

Visual Basic
Public Property ComputerTargetsNeedingUpdatesCount() As Integer
C#
public int ComputerTargetsNeedingUpdatesCount {get; set;}
C++
public:
property int ComputerTargetsNeedingUpdatesCount {
    int get();
    void set(int value);
}
J#
public int get_ComputerTargetsNeedingUpdatesCount();
public void set_ComputerTargetsNeedingUpdatesCount(int);
JScript
public function get ComputerTargetsNeedingUpdatesCount() : int;
public function set ComputerTargetsNeedingUpdatesCount(int);

Property Value

Number of clients with at least one update that is not yet installed.

Remarks

This count includes only updates that are currently approved for installation or scan on the client.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ComputerTargetsWithUpdateErrorsCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of clients with at least one update that is currently in a failure state.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ComputerTargetsWithUpdateErrorsCount

Dim sampleValue As Integer
updateServerStatus1.ComputerTargetsWithUpdateErrorsCount = sampleValue

Syntax

Visual Basic
Public Property ComputerTargetsWithUpdateErrorsCount() As Integer
C#
public int ComputerTargetsWithUpdateErrorsCount {get; set;}
C++
public:
property int ComputerTargetsWithUpdateErrorsCount {
    int get();
    void set(int value);
}
J#
public int get_ComputerTargetsWithUpdateErrorsCount();
public void set_ComputerTargetsWithUpdateErrorsCount(int);
JScript
public function get ComputerTargetsWithUpdateErrorsCount() : int;
public function set ComputerTargetsWithUpdateErrorsCount(int);

Property Value

Number of clients with at least one update that is currently in a failure state.

Remarks

This count includes only approved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.CriticalOrSecurityUpdatesNotApprovedForInstallCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of critical or security updates on the WSUS server that are not approved for installation.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.CriticalOrSecurityUpdatesNotApprovedForInstallCount

Dim sampleValue As Integer
updateServerStatus1.CriticalOrSecurityUpdatesNotApprovedForInstallCount = sampleValue

Syntax

Visual Basic
Public Property CriticalOrSecurityUpdatesNotApprovedForInstallCount() As Integer
C#
public int CriticalOrSecurityUpdatesNotApprovedForInstallCount {get; set;}
C++
public:
property int CriticalOrSecurityUpdatesNotApprovedForInstallCount {
    int get();
    void set(int value);
}
J#
public int get_CriticalOrSecurityUpdatesNotApprovedForInstallCount();
public void set_CriticalOrSecurityUpdatesNotApprovedForInstallCount(int);
JScript
public function get CriticalOrSecurityUpdatesNotApprovedForInstallCount() : int;
public function set CriticalOrSecurityUpdatesNotApprovedForInstallCount(int);

Property Value

Number of critical or security updates on the WSUS server that are not approved for installation.

Remarks

This count does not include declined updates.

This count includes both approved and unapproved updates (approved updates are included as long as the update is not approved for installation.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.CustomComputerTargetGroupCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of administrator-created computer target groups on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.CustomComputerTargetGroupCount

Dim sampleValue As Integer
updateServerStatus1.CustomComputerTargetGroupCount = sampleValue

Syntax

Visual Basic
Public Property CustomComputerTargetGroupCount() As Integer
C#
public int CustomComputerTargetGroupCount {get; set;}
C++
public:
property int CustomComputerTargetGroupCount {
    int get();
    void set(int value);
}
J#
public int get_CustomComputerTargetGroupCount();
public void set_CustomComputerTargetGroupCount(int);
JScript
public function get CustomComputerTargetGroupCount() : int;
public function set CustomComputerTargetGroupCount(int);

Property Value

Number of administrator-created computer target groups on the WSUS server.

Remarks

This count does not include the All Computers or Unassigned Computers groups.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.DeclinedUpdateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that have been declined by an administrator.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.DeclinedUpdateCount

Dim sampleValue As Integer
updateServerStatus1.DeclinedUpdateCount = sampleValue

Syntax

Visual Basic
Public Property DeclinedUpdateCount() As Integer
C#
public int DeclinedUpdateCount {get; set;}
C++
public:
property int DeclinedUpdateCount {
    int get();
    void set(int value);
}
J#
public int get_DeclinedUpdateCount();
public void set_DeclinedUpdateCount(int);
JScript
public function get DeclinedUpdateCount() : int;
public function set DeclinedUpdateCount(int);

Property Value

Number of updates on the WSUS server that have been declined by an administrator.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ExpiredUpdateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server whose latest revision is marked as expired by the publisher of the update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.ExpiredUpdateCount

Dim sampleValue As Integer
updateServerStatus1.ExpiredUpdateCount = sampleValue

Syntax

Visual Basic
Public Property ExpiredUpdateCount() As Integer
C#
public int ExpiredUpdateCount {get; set;}
C++
public:
property int ExpiredUpdateCount {
    int get();
    void set(int value);
}
J#
public int get_ExpiredUpdateCount();
public void set_ExpiredUpdateCount(int);
JScript
public function get ExpiredUpdateCount() : int;
public function set ExpiredUpdateCount(int);

Property Value

Number of updates on the WSUS server whose latest revision is marked as Expired by the publisher of the update. See PublicationState.

Remarks

This count does not include declined updates.

This count includes both approved and unapproved updates.

You should decline any expired updates and approve the update that supersedes it instead.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.NotApprovedUpdateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that have not been approved or declined.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.NotApprovedUpdateCount

Dim sampleValue As Integer
updateServerStatus1.NotApprovedUpdateCount = sampleValue

Syntax

Visual Basic
Public Property NotApprovedUpdateCount() As Integer
C#
public int NotApprovedUpdateCount {get; set;}
C++
public:
property int NotApprovedUpdateCount {
    int get();
    void set(int value);
}
J#
public int get_NotApprovedUpdateCount();
public void set_NotApprovedUpdateCount(int);
JScript
public function get NotApprovedUpdateCount() : int;
public function set NotApprovedUpdateCount(int);

Property Value

Number of updates on the WSUS server that have not been approved or declined.

Remarks

This count includes only unapproved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.ShouldDeleteUnneededRevisions Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Indicates if the WSUS database is growing too large and that unneeded revisions should be deleted.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Boolean
returnValue = updateServerStatus1.ShouldDeleteUnneededRevisions

Dim sampleValue As Boolean
updateServerStatus1.ShouldDeleteUnneededRevisions = sampleValue

Syntax

Visual Basic
Public Property ShouldDeleteUnneededRevisions() As Boolean
C#
public bool ShouldDeleteUnneededRevisions {get; set;}
C++
public:
property bool ShouldDeleteUnneededRevisions {
    bool get();
    void set(bool value);
}
J#
public boolean get_ShouldDeleteUnneededRevisions();
public void set_ShouldDeleteUnneededRevisions(boolean);
JScript
public function get ShouldDeleteUnneededRevisions() : Boolean;
public function set ShouldDeleteUnneededRevisions(Boolean);

Property Value

True if unneeded revisions should be deleted. False if no action is currently necessary.

Remarks

When running on MSDE, the WSUS database can grow beyond the 2-gigabyte limitation of that database. To ensure that WSUS continues to work, it will notify you when the database grows too large by setting this flag. When this flag is set, you should use the WsusUtil tool to delete unneeded revisions from the WSUS database.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UnrecognizedClientRequestedTargetGroupNames Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Names of target groups requested by clients that do not match existing target groups on the server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As StringCollection
returnValue = updateServerStatus1.UnrecognizedClientRequestedTargetGroupNames

Syntax

Visual Basic
Public ReadOnly Property UnrecognizedClientRequestedTargetGroupNames() As StringCollection
C#
public StringCollection UnrecognizedClientRequestedTargetGroupNames {get;}
C++
public:
property StringCollection^ UnrecognizedClientRequestedTargetGroupNames {
    StringCollection^ get();
}
J#
public StringCollection get_UnrecognizedClientRequestedTargetGroupNames();
JScript
public function get UnrecognizedClientRequestedTargetGroupNames() : StringCollection;

Property Value

Names of target groups requested by clients that do not match existing target groups on the server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Total number of updates on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdateCount

Dim sampleValue As Integer
updateServerStatus1.UpdateCount = sampleValue

Syntax

Visual Basic
Public Property UpdateCount() As Integer
C#
public int UpdateCount {get; set;}
C++
public:
property int UpdateCount {
    int get();
    void set(int value);
}
J#
public int get_UpdateCount();
public void set_UpdateCount(int);
JScript
public function get UpdateCount() : int;
public function set UpdateCount(int);

Property Value

Total number of updates on the WSUS server.

Remarks

This count includes declined, approved, and unapproved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesNeededByComputersCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that are needed by one or more client computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesNeededByComputersCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesNeededByComputersCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesNeededByComputersCount() As Integer
C#
public int UpdatesNeededByComputersCount {get; set;}
C++
public:
property int UpdatesNeededByComputersCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesNeededByComputersCount();
public void set_UpdatesNeededByComputersCount(int);
JScript
public function get UpdatesNeededByComputersCount() : int;
public function set UpdatesNeededByComputersCount(int);

Property Value

Number of updates on the WSUS server that are needed by one or more client computers.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesNeedingFilesCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that do not have all the required installation files.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesNeedingFilesCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesNeedingFilesCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesNeedingFilesCount() As Integer
C#
public int UpdatesNeedingFilesCount {get; set;}
C++
public:
property int UpdatesNeedingFilesCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesNeedingFilesCount();
public void set_UpdatesNeedingFilesCount(int);
JScript
public function get UpdatesNeedingFilesCount() : int;
public function set UpdatesNeedingFilesCount(int);

Property Value

Number of updates on the WSUS server that do not have all the required installation files.

Remarks

This count does not include declined updates.

This count includes both approved and unapproved updates (typically an update will only need files after it is approved for installation).

If you are hosting content locally, files may not be downloaded until they are approved for install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesUpToDateCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get or set the number of Updates on the UpdateServer that are known to be Installed or NotApplicable on all computers.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesUpToDateCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesUpToDateCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesUpToDateCount() As Integer
C#
public int UpdatesUpToDateCount {get; set;}
C++
public:
property int UpdatesUpToDateCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesUpToDateCount();
public void set_UpdatesUpToDateCount(int);
JScript
public function get UpdatesUpToDateCount() : int;
public function set UpdatesUpToDateCount(int);

Property Value

The number of Updates on the UpdateServer that are known to be Installed or NotApplicable on all computers.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesWithClientErrorsCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that have at least one client that is currently in a failed state for that update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesWithClientErrorsCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesWithClientErrorsCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesWithClientErrorsCount() As Integer
C#
public int UpdatesWithClientErrorsCount {get; set;}
C++
public:
property int UpdatesWithClientErrorsCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesWithClientErrorsCount();
public void set_UpdatesWithClientErrorsCount(int);
JScript
public function get UpdatesWithClientErrorsCount() : int;
public function set UpdatesWithClientErrorsCount(int);

Property Value

Number of updates on the WSUS server that have at least one client that is currently in a failed state for that update.

Remarks

This count does not include declined updates.

This count includes only approved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesWithServerErrorsCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that are in a failure state.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesWithServerErrorsCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesWithServerErrorsCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesWithServerErrorsCount() As Integer
C#
public int UpdatesWithServerErrorsCount {get; set;}
C++
public:
property int UpdatesWithServerErrorsCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesWithServerErrorsCount();
public void set_UpdatesWithServerErrorsCount(int);
JScript
public function get UpdatesWithServerErrorsCount() : int;
public function set UpdatesWithServerErrorsCount(int);

Property Value

Number of updates on the WSUS server that are in a failure state (whose UpdateState is Failed or LicenseAgreementFailed).

Remarks

This count does not include declined updates.

This count includes both approved and unapproved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.UpdatesWithStaleUpdateApprovalsCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of updates on the WSUS server that have a revision of an update that is approved but is not the latest revision.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.UpdatesWithStaleUpdateApprovalsCount

Dim sampleValue As Integer
updateServerStatus1.UpdatesWithStaleUpdateApprovalsCount = sampleValue

Syntax

Visual Basic
Public Property UpdatesWithStaleUpdateApprovalsCount() As Integer
C#
public int UpdatesWithStaleUpdateApprovalsCount {get; set;}
C++
public:
property int UpdatesWithStaleUpdateApprovalsCount {
    int get();
    void set(int value);
}
J#
public int get_UpdatesWithStaleUpdateApprovalsCount();
public void set_UpdatesWithStaleUpdateApprovalsCount(int);
JScript
public function get UpdatesWithStaleUpdateApprovalsCount() : int;
public function set UpdatesWithStaleUpdateApprovalsCount(int);

Property Value

Number of updates on the WSUS server that have a revision of an update that is approved but is not the latest revision.

Remarks

This count does not include declined updates. Declined updates cannot have revisions of an update that is approved.

This count includes both approved and unapproved updates.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerStatus.WsusInfrastructureUpdatesNotApprovedForInstallCount Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Number of WSUS infrastructure updates on the WSUS server that are not approved for installation.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerStatus1 As UpdateServerStatus

Dim returnValue As Integer
returnValue = updateServerStatus1.WsusInfrastructureUpdatesNotApprovedForInstallCount

Dim sampleValue As Integer
updateServerStatus1.WsusInfrastructureUpdatesNotApprovedForInstallCount = sampleValue

Syntax

Visual Basic
Public Property WsusInfrastructureUpdatesNotApprovedForInstallCount() As Integer
C#
public int WsusInfrastructureUpdatesNotApprovedForInstallCount {get; set;}
C++
public:
property int WsusInfrastructureUpdatesNotApprovedForInstallCount {
    int get();
    void set(int value);
}
J#
public int get_WsusInfrastructureUpdatesNotApprovedForInstallCount();
public void set_WsusInfrastructureUpdatesNotApprovedForInstallCount(int);
JScript
public function get WsusInfrastructureUpdatesNotApprovedForInstallCount() : int;
public function set WsusInfrastructureUpdatesNotApprovedForInstallCount(int);

Property Value

Number of WSUS infrastructure updates on the WSUS server that are not approved for installation.

Remarks

This count does not include declined updates.

This count includes both approved and unapproved updates, as long as the approval action is not install.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServerStatus Class
UpdateServerStatus Members


UpdateServerUserRole Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Describes a user's role on the WSUS server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServerUserRole1 As UpdateServerUserRole = UpdateServerUserRole.Administrator

Syntax

Visual Basic
Public Enum UpdateServerUserRole
C#
public enum UpdateServerUserRole
C++
public enum class UpdateServerUserRole
J#
public enum UpdateServerUserRole
JScript
public enum UpdateServerUserRole

Members

Member name | Description
Administrator | The user has full control over the WSUS server.
Reporter | The user is authorized to view reports on the WSUS server.
Unauthorized | The user is not authorized to perform any operations on the WSUS server.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


UpdateServicesPackage Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Update Services package class. This class implements the functions of creating or updating of SDP file. Note: an admin can update/expire a locally published package only if he/she has the original SDP file. If a locally published application is imported from another server, then admin cannot update/expire this imported locally published application. Admin needs to export the SDP from the original server, revise and re-publish this application.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As New UpdateServicesPackage()

Syntax

Visual Basic
Public Class UpdateServicesPackage
C#
public class UpdateServicesPackage
C++
public ref class UpdateServicesPackage
J#
public class UpdateServicesPackage
JScript
public class UpdateServicesPackage

Remarks

A default class which creates the default skeleton including:

  • PackageId: new Guid

  • CreationDate: Current UTC time

  • SchemaVersion: default 1.0 3.

  • PackageType: default Application.

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateServicesPackage
Microsoft.UpdateServices.Administration.UpdateServicesPackageWithServerInformation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Members


UpdateServicesPackage Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Update Services package class. This class implements the functions of creating or updating of SDP file. Note: an admin can update/expire a locally published package only if he/she has the original SDP file. If a locally published application is imported from another server, then admin cannot update/expire this imported locally published application. Admin needs to export the SDP from the original server, revise and re-publish this application.

The following tables list the members exposed by the UpdateServicesPackage type.

Public Constructors

Name | Description
UpdateServicesPackage | Overloaded.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | AdditionalInformationUrls | Retrieves the additional URLs list.
public property | CanSourceBeRequired | Retrieves the value indicating whether the source for the Update Services Package is required.
public property | CommonVulnerabilitiesIds | Retrieves the list of common vulnerability IDs.
public property | CreationDate | Retrieves the Creation Date of this package.
public property | CurrentLanguage | Retrieves or sets the current language of the Title/Description pair.
public property | DefaultLanguage | Retrieves or sets the default language for the Title/Description pair.
public property | Description | Retrieves or sets the localized description which can be displayed in package description in the WSUS UI.
public property | InstallableItems | Retrieve the InstallableItems list.
public property | IsInstallable | Get/Set IsInstallable applicability rules of this package.
public property | KnowledgebaseArticleId | Get KBArticleIds list. Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.
public property | PackageId | Get/Set PackageId.
public property | PackageType | Get/Set package type. Currently, it can be Application or Update types.
public property | PackageUpdateClassification | Get/Set PackageUpdateClassification
public property | ProductNames | Get product names list of this package
public property | PublicationState | Get/Set PackagePublicationState
public property | SecurityBulletinId | Retrieves a security bulletin Id.
public property | SecurityRating | Get/Set MSRC Sevevirty value.
public property | SupersededPackages | Get Supersed PackageIds list.
public property | SupportedLanguages | Get supported languages of Title/Description pairs.
public property | SupportUrl | Get/Set support url.
public property | Title | Get/Set the localized Title which can be displayed on WSUS UI.
public property | VendorName | Get/Set VendorName
Top

Protected Properties

 | Name | Description
protected property | MaxDownloadSize |
protected property | MinDownloadSize |
protected property | PublisherId |
protected property | RevisionNumber |
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | PopulatePackageFromExe | Create a CommandLineInstallerData installable item from input exe file name.
public method | PopulatePackageFromExeWrappedMSI | Create a ExeWrappedMSI installable item from input exe and MSI files
public method | PopulatePackageFromWindowsInstaller | Create a MSIInstallerData installable item. ProductCode will be extracted automatically from the input Msi file. Note: PackageType remains the same. (Default: Application.)
public method | PopulatePackageFromWindowsInstallerPatch | Create a MSPInstallerData installable item from input msp file name.
 | ReferenceEquals | (Inherited from Object )
public method | Save | Save the SDP file. Note: it will overwrite the file if it already exists.
public method | ToString | (Inherited from Object )
public method | Verify | Overloaded. Verify the content of this instance
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
protected method | SaveAsUpdateServicesPackage | Save the USP file. Note: it will overwrite the file if it already exists.
Top

See Also

Reference

UpdateServicesPackage Class


UpdateServicesPackage Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateServicesPackage () | Default constructor
UpdateServicesPackage (String) | Create USP class and load properties from input packageFile.
UpdateServicesPackage (XmlElement) | Create USP class and load properties from the input SDP Xml node.

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As New UpdateServicesPackage()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateServicesPackage();
C++
public:
UpdateServicesPackage();
J#
public UpdateServicesPackage();
JScript
public function UpdateServicesPackage();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create USP class and load properties from input packageFile.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packageFile As String
Dim updateServicesPackage1 As New UpdateServicesPackage(packageFile)

Syntax

Visual Basic
Public Sub New( _
    ByVal packageFile As String _
)
C#
public UpdateServicesPackage(
    string packageFile
);
C++
public:
UpdateServicesPackage(
    String^ packageFile
);
J#
public UpdateServicesPackage(
    System.String packageFile
);
JScript
public function UpdateServicesPackage(
     packageFile : String
);

Parameters

packageFile

USP file path

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage Constructor (XmlElement)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create USP class and load properties from the input SDP Xml node.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim sdpNode As XmlElement
Dim updateServicesPackage1 As New UpdateServicesPackage(sdpNode)

Syntax

Visual Basic
Public Sub New( _
    ByVal sdpNode As XmlElement _
)
C#
public UpdateServicesPackage(
    XmlElement sdpNode
);
C++
public:
UpdateServicesPackage(
    XmlElement^ sdpNode
);
J#
public UpdateServicesPackage(
    XmlElement sdpNode
);
JScript
public function UpdateServicesPackage(
     sdpNode : XmlElement
);

Parameters

sdpNode

the node contains a valid SDP package

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | PopulatePackageFromExe | Create a CommandLineInstallerData installable item from input exe file name.
public method | PopulatePackageFromExeWrappedMSI | Create a ExeWrappedMSI installable item from input exe and MSI files
public method | PopulatePackageFromWindowsInstaller | Create a MSIInstallerData installable item. ProductCode will be extracted automatically from the input Msi file. Note: PackageType remains the same. (Default: Application.)
public method | PopulatePackageFromWindowsInstallerPatch | Create a MSPInstallerData installable item from input msp file name.
 | ReferenceEquals | (Inherited from Object )
public method | Save | Save the SDP file. Note: it will overwrite the file if it already exists.
public method | ToString | (Inherited from Object )
public method | Verify | Overloaded. Verify the content of this instance

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
protected method | SaveAsUpdateServicesPackage | Save the USP file. Note: it will overwrite the file if it already exists.

See Also

Reference

UpdateServicesPackage Class


UpdateServicesPackage.PopulatePackageFromExe Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a CommandLineInstallerData installable item from input exe file name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePath As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.PopulatePackageFromExe(filePath)

Syntax

Visual Basic
Public Sub PopulatePackageFromExe( _
    ByVal filePath As String _
)
C#
public void PopulatePackageFromExe(
    string filePath
);
C++
public:
void PopulatePackageFromExe(
    String^ filePath
);
J#
public void PopulatePackageFromExe(
    System.String filePath
);
JScript
public function PopulatePackageFromExe(
     filePath : String
) : Void;

Parameters

filePath

Input exe file path

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PopulatePackageFromExeWrappedMSI Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a ExeWrappedMSI installable item from input exe and MSI files

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim exePath As String
Dim relativePathsToPrimaryMSIs() As String
Dim relativePathsToSecondaryMSIs() As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.PopulatePackageFromExeWrappedMSI(exePath, relativePathsToPrimaryMSIs, relativePathsToSecondaryMSIs)

Syntax

Visual Basic
Public Sub PopulatePackageFromExeWrappedMSI( _
    ByVal exePath As String, _
    ByVal relativePathsToPrimaryMSIs() As String, _
    ByVal relativePathsToSecondaryMSIs() As String _
)
C#
public void PopulatePackageFromExeWrappedMSI(
    string exePath,
    string[] relativePathsToPrimaryMSIs,
    string[] relativePathsToSecondaryMSIs
);
C++
public:
void PopulatePackageFromExeWrappedMSI(
    String^ exePath,
    array<String^>^ relativePathsToPrimaryMSIs,
    array<String^>^ relativePathsToSecondaryMSIs
);
J#
public void PopulatePackageFromExeWrappedMSI(
    System.String exePath,
    System.String[] relativePathsToPrimaryMSIs,
    System.String[] relativePathsToSecondaryMSIs
);
JScript
public function PopulatePackageFromExeWrappedMSI(
     exePath : String,
     relativePathsToPrimaryMSIs : String[],
     relativePathsToSecondaryMSIs : String[]
) : Void;

Parameters

exePath

The exe which wraps the MSI package

relativePathsToPrimaryMSIs

The wrapped primary MSI files which construct detection rules and repair paths.

relativePathsToSecondaryMSIs

The wrapped second MSI files which we used to register their repair paths.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PopulatePackageFromWindowsInstaller Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a MSIInstallerData installable item. ProductCode will be extracted automatically from the input Msi file. Note: PackageType remains the same. (Default: Application.)

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePath As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.PopulatePackageFromWindowsInstaller(filePath)

Syntax

Visual Basic
Public Sub PopulatePackageFromWindowsInstaller( _
    ByVal filePath As String _
)
C#
public void PopulatePackageFromWindowsInstaller(
    string filePath
);
C++
public:
void PopulatePackageFromWindowsInstaller(
    String^ filePath
);
J#
public void PopulatePackageFromWindowsInstaller(
    System.String filePath
);
JScript
public function PopulatePackageFromWindowsInstaller(
     filePath : String
) : Void;

Parameters

filePath

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PopulatePackageFromWindowsInstallerPatch Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a MSPInstallerData installable item from input msp file name.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePath As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.PopulatePackageFromWindowsInstallerPatch(filePath)

Syntax

Visual Basic
Public Sub PopulatePackageFromWindowsInstallerPatch( _
    ByVal filePath As String _
)
C#
public void PopulatePackageFromWindowsInstallerPatch(
    string filePath
);
C++
public:
void PopulatePackageFromWindowsInstallerPatch(
    String^ filePath
);
J#
public void PopulatePackageFromWindowsInstallerPatch(
    System.String filePath
);
JScript
public function PopulatePackageFromWindowsInstallerPatch(
     filePath : String
) : Void;

Parameters

filePath

the MSP file path.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Save Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Save the SDP file. Note: it will overwrite the file if it already exists.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packageFile As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.Save(packageFile)

Syntax

Visual Basic
Public Sub Save( _
    ByVal packageFile As String _
)
C#
public void Save(
    string packageFile
);
C++
public:
void Save(
    String^ packageFile
);
J#
public void Save(
    System.String packageFile
);
JScript
public function Save(
     packageFile : String
) : Void;

Parameters

packageFile

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SaveAsUpdateServicesPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Save the USP file. Note: it will overwrite the file if it already exists.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class updateServicesPackageImplementation
    Inherits UpdateServicesPackage
        Protected Overrides Sub SaveAsUpdateServicesPackage(updateServicesPackageFile As String)
            MyBase.SaveAsUpdateServicesPackage(updateServicesPackageFile)
        End Sub
End Class

Syntax

Visual Basic
Protected Sub SaveAsUpdateServicesPackage( _
    ByVal updateServicesPackageFile As String _
)
C#
protected void SaveAsUpdateServicesPackage(
    string updateServicesPackageFile
);
C++
protected:
void SaveAsUpdateServicesPackage(
    String^ updateServicesPackageFile
);
J#
protected void SaveAsUpdateServicesPackage(
    System.String updateServicesPackageFile
);
JScript
protected function SaveAsUpdateServicesPackage(
     updateServicesPackageFile : String
) : Void;

Parameters

updateServicesPackageFile

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Verify Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Verify the content of this instance

Overload List

Name | Description
UpdateServicesPackage.Verify () | Verify the content of this instance
UpdateServicesPackage.Verify (String) | Verify the content of the package. Exception will be thrown if error found.

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Verify Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Verify the content of this instance

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.Verify()

Syntax

Visual Basic
Overloads Public Sub Verify()
C#
public void Verify();
C++
public:
void Verify();
J#
public void Verify();
JScript
public function Verify() : Void;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Verify Method (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Verify the content of the package. Exception will be thrown if error found.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim packageFile As String
Dim updateServicesPackage1 As UpdateServicesPackage
updateServicesPackage1.Verify(packageFile)

Syntax

Visual Basic
Overloads Public Sub Verify( _
    ByVal packageFile As String _
)
C#
public void Verify(
    string packageFile
);
C++
public:
void Verify(
    String^ packageFile
);
J#
public void Verify(
    System.String packageFile
);
JScript
public function Verify(
     packageFile : String
) : Void;

Parameters

packageFile

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | AdditionalInformationUrls | Retrieves the additional URLs list.
public property | CanSourceBeRequired | Retrieves the value indicating whether the source for the Update Services Package is required.
public property | CommonVulnerabilitiesIds | Retrieves the list of common vulnerability IDs.
public property | CreationDate | Retrieves the Creation Date of this package.
public property | CurrentLanguage | Retrieves or sets the current language of the Title/Description pair.
public property | DefaultLanguage | Retrieves or sets the default language for the Title/Description pair.
public property | Description | Retrieves or sets the localized description which can be displayed in package description in the WSUS UI.
public property | InstallableItems | Retrieve the InstallableItems list.
public property | IsInstallable | Get/Set IsInstallable applicability rules of this package.
public property | KnowledgebaseArticleId | Get KBArticleIds list. Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.
public property | PackageId | Get/Set PackageId.
public property | PackageType | Get/Set package type. Currently, it can be Application or Update types.
public property | PackageUpdateClassification | Get/Set PackageUpdateClassification
public property | ProductNames | Get product names list of this package
public property | PublicationState | Get/Set PackagePublicationState
public property | SecurityBulletinId | Retrieves a security bulletin Id.
public property | SecurityRating | Get/Set MSRC Sevevirty value.
public property | SupersededPackages | Get Supersed PackageIds list.
public property | SupportedLanguages | Get supported languages of Title/Description pairs.
public property | SupportUrl | Get/Set support url.
public property | Title | Get/Set the localized Title which can be displayed on WSUS UI.
public property | VendorName | Get/Set VendorName

Protected Properties

 | Name | Description
protected property | MaxDownloadSize |
protected property | MinDownloadSize |
protected property | PublisherId |
protected property | RevisionNumber |

See Also

Reference

UpdateServicesPackage Class


UpdateServicesPackage.AdditionalInformationUrls Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the additional URLs list.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As IList(Of Uri)
returnValue = updateServicesPackage1.AdditionalInformationUrls

Syntax

Visual Basic
Public ReadOnly Property AdditionalInformationUrls() As IList(Of Uri)
C#
public IList<Uri> AdditionalInformationUrls {get;}
C++
public:
property IList<Uri^>^ AdditionalInformationUrls {
    IList<Uri^>^ get();
}
J#
public IList<Uri> get_AdditionalInformationUrls();
JScript
public function get AdditionalInformationUrls() : JScript does not support Generics.;

Property Value

A collection of strings, each string contains an URL linking to additional information, provided by the publisher of the Update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.CanSourceBeRequired Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the value indicating whether the source for the Update Services Package is required.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Boolean
returnValue = updateServicesPackage1.CanSourceBeRequired

Dim sampleValue As Boolean
updateServicesPackage1.CanSourceBeRequired = sampleValue

Syntax

Visual Basic
Public Property CanSourceBeRequired() As Boolean
C#
public bool CanSourceBeRequired {get; set;}
C++
public:
property bool CanSourceBeRequired {
    bool get();
    void set(bool value);
}
J#
public boolean get_CanSourceBeRequired();
public void set_CanSourceBeRequired(boolean);
JScript
public function get CanSourceBeRequired() : Boolean;
public function set CanSourceBeRequired(Boolean);

Property Value

True, if the Update Services Package requires a source; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.CommonVulnerabilitiesIds Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the list of common vulnerability IDs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As StringCollection
returnValue = updateServicesPackage1.CommonVulnerabilitiesIds

Syntax

Visual Basic
Public ReadOnly Property CommonVulnerabilitiesIds() As StringCollection
C#
public StringCollection CommonVulnerabilitiesIds {get;}
C++
public:
property StringCollection^ CommonVulnerabilitiesIds {
    StringCollection^ get();
}
J#
public StringCollection get_CommonVulnerabilitiesIds();
JScript
public function get CommonVulnerabilitiesIds() : StringCollection;

Property Value

The list of common vulnerabilities IDs associated with this package.

Remarks

Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.CreationDate Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves the Creation Date of this package.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As DateTime
returnValue = updateServicesPackage1.CreationDate

Syntax

Visual Basic
Public ReadOnly Property CreationDate() As DateTime
C#
public DateTime CreationDate {get;}
C++
public:
property DateTime^ CreationDate {
    DateTime^ get();
}
J#
public DateTime get_CreationDate();
JScript
public function get CreationDate() : DateTime;

Property Value

The creation date of this package.

Remarks

Default: the current UTC date when this class is created.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.CurrentLanguage Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the current language of the Title/Description pair.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.CurrentLanguage

Dim sampleValue As String
updateServicesPackage1.CurrentLanguage = sampleValue

Syntax

Visual Basic
Public Property CurrentLanguage() As String
C#
public string CurrentLanguage {get; set;}
C++
public:
property String^ CurrentLanguage {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_CurrentLanguage();
public void set_CurrentLanguage(System.String);
JScript
public function get CurrentLanguage() : String;
public function set CurrentLanguage(String);

Property Value

The current language of the Title/Description pair.

Remarks

Default: "en".

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.DefaultLanguage Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the default language for the Title/Description pair.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.DefaultLanguage

Dim sampleValue As String
updateServicesPackage1.DefaultLanguage = sampleValue

Syntax

Visual Basic
Public Property DefaultLanguage() As String
C#
public string DefaultLanguage {get; set;}
C++
public:
property String^ DefaultLanguage {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_DefaultLanguage();
public void set_DefaultLanguage(System.String);
JScript
public function get DefaultLanguage() : String;
public function set DefaultLanguage(String);

Property Value

The default language to use for the title and description pair.

Remarks

Default: "en".

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Description Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the localized description which can be displayed in package description in the WSUS UI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.Description

Dim sampleValue As String
updateServicesPackage1.Description = sampleValue

Syntax

Visual Basic
Public Property Description() As String
C#
public string Description {get; set;}
C++
public:
property String^ Description {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Description();
public void set_Description(System.String);
JScript
public function get Description() : String;
public function set Description(String);

Property Value

The localized package description text.

Remarks

Note: the locale of the current description is CurrentLanguage property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.InstallableItems Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieve the InstallableItems list.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As IList(Of InstallableItem)
returnValue = updateServicesPackage1.InstallableItems

Syntax

Visual Basic
Public ReadOnly Property InstallableItems() As IList(Of InstallableItem)
C#
public IList<InstallableItem> InstallableItems {get;}
C++
public:
property IList<InstallableItem^>^ InstallableItems {
    IList<InstallableItem^>^ get();
}
J#
public IList<InstallableItem> get_InstallableItems();
JScript
public function get InstallableItems() : JScript does not support Generics.;

Property Value

The list of installable items contains in this package.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.IsInstallable Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set IsInstallable applicability rules of this package.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.IsInstallable

Dim sampleValue As String
updateServicesPackage1.IsInstallable = sampleValue

Syntax

Visual Basic
Public Property IsInstallable() As String
C#
public string IsInstallable {get; set;}
C++
public:
property String^ IsInstallable {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_IsInstallable();
public void set_IsInstallable(System.String);
JScript
public function get IsInstallable() : String;
public function set IsInstallable(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.KnowledgebaseArticleId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get KBArticleIds list. Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.KnowledgebaseArticleId

Dim sampleValue As String
updateServicesPackage1.KnowledgebaseArticleId = sampleValue

Syntax

Visual Basic
Public Property KnowledgebaseArticleId() As String
C#
public string KnowledgebaseArticleId {get; set;}
C++
public:
property String^ KnowledgebaseArticleId {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_KnowledgebaseArticleId();
public void set_KnowledgebaseArticleId(System.String);
JScript
public function get KnowledgebaseArticleId() : String;
public function set KnowledgebaseArticleId(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.MaxDownloadSize Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Integer
returnValue = updateServicesPackage1.MaxDownloadSize

Dim sampleValue As Integer
updateServicesPackage1.MaxDownloadSize = sampleValue

Syntax

Visual Basic
Protected Property MaxDownloadSize() As Integer
C#
protected int MaxDownloadSize {get; set;}
C++
protected:
property int MaxDownloadSize {
    int get();
    void set(int value);
}
J#
protected int get_MaxDownloadSize();
protected void set_MaxDownloadSize(int);
JScript
protected function get MaxDownloadSize() : int;
protected function set MaxDownloadSize(int);

Property Value

This property type is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.MinDownloadSize Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Integer
returnValue = updateServicesPackage1.MinDownloadSize

Dim sampleValue As Integer
updateServicesPackage1.MinDownloadSize = sampleValue

Syntax

Visual Basic
Protected Property MinDownloadSize() As Integer
C#
protected int MinDownloadSize {get; set;}
C++
protected:
property int MinDownloadSize {
    int get();
    void set(int value);
}
J#
protected int get_MinDownloadSize();
protected void set_MinDownloadSize(int);
JScript
protected function get MinDownloadSize() : int;
protected function set MinDownloadSize(int);

Property Value

This property type is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PackageId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set PackageId.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Guid
returnValue = updateServicesPackage1.PackageId

Dim sampleValue As Guid
updateServicesPackage1.PackageId = sampleValue

Syntax

Visual Basic
Public Property PackageId() As Guid
C#
public Guid PackageId {get; set;}
C++
public:
property Guid^ PackageId {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_PackageId();
public void set_PackageId(Guid);
JScript
public function get PackageId() : Guid;
public function set PackageId(Guid);

Remarks

Default: a new system generated Guid.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PackageType Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set package type. Currently, it can be Application or Update types.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As PackageType
returnValue = updateServicesPackage1.PackageType

Dim sampleValue As PackageType
updateServicesPackage1.PackageType = sampleValue

Syntax

Visual Basic
Public Property PackageType() As PackageType
C#
public PackageType PackageType {get; set;}
C++
public:
property PackageType PackageType {
    PackageType get();
    void set(PackageType value);
}
J#
public PackageType get_PackageType();
public void set_PackageType(PackageType);
JScript
public function get PackageType() : PackageType;
public function set PackageType(PackageType);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PackageUpdateClassification Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set PackageUpdateClassification

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As PackageUpdateClassification
returnValue = updateServicesPackage1.PackageUpdateClassification

Dim sampleValue As PackageUpdateClassification
updateServicesPackage1.PackageUpdateClassification = sampleValue

Syntax

Visual Basic
Public Property PackageUpdateClassification() As PackageUpdateClassification
C#
public PackageUpdateClassification PackageUpdateClassification {get; set;}
C++
public:
property PackageUpdateClassification PackageUpdateClassification {
    PackageUpdateClassification get();
    void set(PackageUpdateClassification value);
}
J#
public PackageUpdateClassification get_PackageUpdateClassification();
public void set_PackageUpdateClassification(PackageUpdateClassification);
JScript
public function get PackageUpdateClassification() : PackageUpdateClassification;
public function set PackageUpdateClassification(PackageUpdateClassification);

Property Value

Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.ProductNames Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get product names list of this package

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As StringCollection
returnValue = updateServicesPackage1.ProductNames

Syntax

Visual Basic
Public ReadOnly Property ProductNames() As StringCollection
C#
public StringCollection ProductNames {get;}
C++
public:
property StringCollection^ ProductNames {
    StringCollection^ get();
}
J#
public StringCollection get_ProductNames();
JScript
public function get ProductNames() : StringCollection;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PublicationState Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set PackagePublicationState

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As PackagePublicationState
returnValue = updateServicesPackage1.PublicationState

Dim sampleValue As PackagePublicationState
updateServicesPackage1.PublicationState = sampleValue

Syntax

Visual Basic
Public Property PublicationState() As PackagePublicationState
C#
public PackagePublicationState PublicationState {get; set;}
C++
public:
property PackagePublicationState PublicationState {
    PackagePublicationState get();
    void set(PackagePublicationState value);
}
J#
public PackagePublicationState get_PublicationState();
public void set_PublicationState(PackagePublicationState);
JScript
public function get PublicationState() : PackagePublicationState;
public function set PublicationState(PackagePublicationState);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.PublisherId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Guid
returnValue = updateServicesPackage1.PublisherId

Dim sampleValue As Guid
updateServicesPackage1.PublisherId = sampleValue

Syntax

Visual Basic
Protected Property PublisherId() As Guid
C#
protected Guid PublisherId {get; set;}
C++
protected:
property Guid^ PublisherId {
    Guid^ get();
    void set(Guid^ value);
}
J#
protected Guid get_PublisherId();
protected void set_PublisherId(Guid);
JScript
protected function get PublisherId() : Guid;
protected function set PublisherId(Guid);

Remarks

This property type is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.RevisionNumber Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Integer
returnValue = updateServicesPackage1.RevisionNumber

Dim sampleValue As Integer
updateServicesPackage1.RevisionNumber = sampleValue

Syntax

Visual Basic
Protected Property RevisionNumber() As Integer
C#
protected int RevisionNumber {get; set;}
C++
protected:
property int RevisionNumber {
    int get();
    void set(int value);
}
J#
protected int get_RevisionNumber();
protected void set_RevisionNumber(int);
JScript
protected function get RevisionNumber() : int;
protected function set RevisionNumber(int);

Remarks

This property type is for internal use only. It may be removed in a future release.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SecurityBulletinId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves a security bulletin Id.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.SecurityBulletinId

Dim sampleValue As String
updateServicesPackage1.SecurityBulletinId = sampleValue

Syntax

Visual Basic
Public Property SecurityBulletinId() As String
C#
public string SecurityBulletinId {get; set;}
C++
public:
property String^ SecurityBulletinId {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_SecurityBulletinId();
public void set_SecurityBulletinId(System.String);
JScript
public function get SecurityBulletinId() : String;
public function set SecurityBulletinId(String);

Property Value

The security bulletin Id

Remarks

Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SecurityRating Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set MSRC Sevevirty value.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As SecurityRating
returnValue = updateServicesPackage1.SecurityRating

Dim sampleValue As SecurityRating
updateServicesPackage1.SecurityRating = sampleValue

Syntax

Visual Basic
Public Property SecurityRating() As SecurityRating
C#
public SecurityRating SecurityRating {get; set;}
C++
public:
property SecurityRating SecurityRating {
    SecurityRating get();
    void set(SecurityRating value);
}
J#
public SecurityRating get_SecurityRating();
public void set_SecurityRating(SecurityRating);
JScript
public function get SecurityRating() : SecurityRating;
public function set SecurityRating(SecurityRating);

Remarks

Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SupersededPackages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get Supersed PackageIds list.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As IList(Of Guid)
returnValue = updateServicesPackage1.SupersededPackages

Syntax

Visual Basic
Public ReadOnly Property SupersededPackages() As IList(Of Guid)
C#
public IList<Guid> SupersededPackages {get;}
C++
public:
property IList<Guid^>^ SupersededPackages {
    IList<Guid^>^ get();
}
J#
public IList<Guid> get_SupersededPackages();
JScript
public function get SupersededPackages() : JScript does not support Generics.;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SupportedLanguages Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get supported languages of Title/Description pairs.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As StringCollection
returnValue = updateServicesPackage1.SupportedLanguages

Syntax

Visual Basic
Public ReadOnly Property SupportedLanguages() As StringCollection
C#
public StringCollection SupportedLanguages {get;}
C++
public:
property StringCollection^ SupportedLanguages {
    StringCollection^ get();
}
J#
public StringCollection get_SupportedLanguages();
JScript
public function get SupportedLanguages() : StringCollection;

Remarks

Note: Any language without related Title/Description pairs won't be save to XML file in Save().

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.SupportUrl Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set support url.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As Uri
returnValue = updateServicesPackage1.SupportUrl

Dim sampleValue As Uri
updateServicesPackage1.SupportUrl = sampleValue

Syntax

Visual Basic
Public Property SupportUrl() As Uri
C#
public Uri SupportUrl {get; set;}
C++
public:
property Uri^ SupportUrl {
    Uri^ get();
    void set(Uri^ value);
}
J#
public Uri get_SupportUrl();
public void set_SupportUrl(Uri);
JScript
public function get SupportUrl() : Uri;
public function set SupportUrl(Uri);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.Title Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the localized Title which can be displayed on WSUS UI.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.Title

Dim sampleValue As String
updateServicesPackage1.Title = sampleValue

Syntax

Visual Basic
Public Property Title() As String
C#
public string Title {get; set;}
C++
public:
property String^ Title {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_Title();
public void set_Title(System.String);
JScript
public function get Title() : String;
public function set Title(String);

Remarks

Note: the locale of the current Title is CurrentLanguage property.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackage.VendorName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set VendorName

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackage1 As UpdateServicesPackage

Dim returnValue As String
returnValue = updateServicesPackage1.VendorName

Dim sampleValue As String
updateServicesPackage1.VendorName = sampleValue

Syntax

Visual Basic
Public Property VendorName() As String
C#
public string VendorName {get; set;}
C++
public:
property String^ VendorName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_VendorName();
public void set_VendorName(System.String);
JScript
public function get VendorName() : String;
public function set VendorName(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackage Class
UpdateServicesPackage Members


UpdateServicesPackageWithServerInformation Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Update Services package with server specific information class used by Publishing

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim file As String
Dim updateServicesPackageWithServerInformation1 As New UpdateServicesPackageWithServerInformation(file)

Syntax

Visual Basic
Public Class UpdateServicesPackageWithServerInformation
    Inherits UpdateServicesPackage
C#
public class UpdateServicesPackageWithServerInformation : UpdateServicesPackage
C++
public ref class UpdateServicesPackageWithServerInformation : UpdateServicesPackage
J#
public class UpdateServicesPackageWithServerInformation extends UpdateServicesPackage
JScript
public class UpdateServicesPackageWithServerInformation extends UpdateServicesPackage

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.UpdateServicesPackage
Microsoft.UpdateServices.Administration.UpdateServicesPackageWithServerInformation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Update Services package with server specific information class used by Publishing

The following tables list the members exposed by the UpdateServicesPackageWithServerInformation type.

Public Constructors

Name | Description
UpdateServicesPackageWithServerInformation | Constructor which takes an input SDP/USP file.
Top

Public Properties

 | Name | Description
public property | AdditionalInformationUrls | Retrieves the additional URLs list.(Inherited from UpdateServicesPackage)
public property | CanSourceBeRequired | Retrieves the value indicating whether the source for the Update Services Package is required.(Inherited from UpdateServicesPackage)
public property | CommonVulnerabilitiesIds | Retrieves the list of common vulnerability IDs. (Inherited from UpdateServicesPackage)
public property | CreationDate | Retrieves the Creation Date of this package. (Inherited from UpdateServicesPackage)
public property | CurrentLanguage | Retrieves or sets the current language of the Title/Description pair.(Inherited from UpdateServicesPackage)
public property | DefaultLanguage | Retrieves or sets the default language for the Title/Description pair. (Inherited from UpdateServicesPackage)
public property | Description | Retrieves or sets the localized description which can be displayed in package description in the WSUS UI. (Inherited from UpdateServicesPackage)
public property | InstallableItems | Retrieve the InstallableItems list.(Inherited from UpdateServicesPackage)
public property | IsInstallable | Get/Set IsInstallable applicability rules of this package.(Inherited from UpdateServicesPackage)
public property | KnowledgebaseArticleId | Get KBArticleIds list. Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown.(Inherited from UpdateServicesPackage)
public property | MaxDownloadSize | Get/Set the maximum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.
public property | MinDownloadSize | Get/Set the minimum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.
public property | PackageId | Get/Set PackageId.(Inherited from UpdateServicesPackage)
public property | PackageType | Get/Set package type. Currently, it can be Application or Update types. (Inherited from UpdateServicesPackage)
public property | PackageUpdateClassification | Get/Set PackageUpdateClassification(Inherited from UpdateServicesPackage)
public property | ProductNames | Get product names list of this package(Inherited from UpdateServicesPackage)
public property | PublicationState | Get/Set PackagePublicationState(Inherited from UpdateServicesPackage)
public property | PublisherId | Get/Set the identity of publisher which publishs this package
public property | RevisionNumber | Get/Set revision number of package.
public property | SecurityBulletinId | Retrieves a security bulletin Id. (Inherited from UpdateServicesPackage)
public property | SecurityRating | Get/Set MSRC Sevevirty value. (Inherited from UpdateServicesPackage)
public property | SupersededPackages | Get Supersed PackageIds list.(Inherited from UpdateServicesPackage)
public property | SupportedLanguages | Get supported languages of Title/Description pairs.(Inherited from UpdateServicesPackage)
public property | SupportUrl | Get/Set support url.(Inherited from UpdateServicesPackage)
public property | Title | Get/Set the localized Title which can be displayed on WSUS UI.(Inherited from UpdateServicesPackage)
public property | VendorName | Get/Set VendorName(Inherited from UpdateServicesPackage)
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | PopulatePackageFromExe | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromExeWrappedMSI | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromWindowsInstaller | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromWindowsInstallerPatch | (Inherited from UpdateServicesPackage )
 | ReferenceEquals | (Inherited from Object )
public method | Save | (Inherited from UpdateServicesPackage )
public method | SaveAsUpdateServicesPackage | Save the USP file. Note: it will overwrite the file if it already exists.
public method | ToString | (Inherited from Object )
public method | Verify | Overloaded. The overloaded Verify function which will verify the USP content (not SDP).
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

UpdateServicesPackageWithServerInformation Class


UpdateServicesPackageWithServerInformation Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Constructor which takes an input SDP/USP file.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim file As String
Dim updateServicesPackageWithServerInformation1 As New UpdateServicesPackageWithServerInformation(file)

Syntax

Visual Basic
Public Sub New( _
    ByVal file As String _
)
C#
public UpdateServicesPackageWithServerInformation(
    string file
);
C++
public:
UpdateServicesPackageWithServerInformation(
    String^ file
);
J#
public UpdateServicesPackageWithServerInformation(
    System.String file
);
JScript
public function UpdateServicesPackageWithServerInformation(
     file : String
);

Parameters

file

SDP/USP file

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | PopulatePackageFromExe | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromExeWrappedMSI | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromWindowsInstaller | (Inherited from UpdateServicesPackage )
public method | PopulatePackageFromWindowsInstallerPatch | (Inherited from UpdateServicesPackage )
 | ReferenceEquals | (Inherited from Object )
public method | Save | (Inherited from UpdateServicesPackage )
public method | SaveAsUpdateServicesPackage | Save the USP file. Note: it will overwrite the file if it already exists.
public method | ToString | (Inherited from Object )
public method | Verify | Overloaded. The overloaded Verify function which will verify the USP content (not SDP).

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

UpdateServicesPackageWithServerInformation Class


UpdateServicesPackageWithServerInformation.SaveAsUpdateServicesPackage Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Save the USP file. Note: it will overwrite the file if it already exists.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageFile As String
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation
updateServicesPackageWithServerInformation1.SaveAsUpdateServicesPackage(updateServicesPackageFile)

Syntax

Visual Basic
Public Shadows Sub SaveAsUpdateServicesPackage( _
    ByVal updateServicesPackageFile As String _
)
C#
public new void SaveAsUpdateServicesPackage(
    string updateServicesPackageFile
);
C++
public:
void SaveAsUpdateServicesPackage(
    String^ updateServicesPackageFile
);
J#
public new void SaveAsUpdateServicesPackage(
    System.String updateServicesPackageFile
);
JScript
public hide function SaveAsUpdateServicesPackage(
     updateServicesPackageFile : String
) : Void;

Parameters

updateServicesPackageFile

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation.Verify Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The overloaded Verify function which will verify the USP content (not SDP).

Overload List

Name | Description
UpdateServicesPackageWithServerInformation.Verify () | The overloaded Verify function which will verify the USP content (not SDP).
UpdateServicesPackageWithServerInformation.Verify (String) |

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation.Verify Method ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The overloaded Verify function which will verify the USP content (not SDP).

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation
updateServicesPackageWithServerInformation1.Verify()

Syntax

Visual Basic
Overloads Public Shadows Sub Verify()
C#
public new void Verify();
C++
public:
void Verify();
J#
public new void Verify();
JScript
public hide function Verify() : Void;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | AdditionalInformationUrls | Retrieves the additional URLs list. (Inherited from UpdateServicesPackage )
public property | CanSourceBeRequired | Retrieves the value indicating whether the source for the Update Services Package is required. (Inherited from UpdateServicesPackage )
public property | CommonVulnerabilitiesIds | Retrieves the list of common vulnerability IDs. (Inherited from UpdateServicesPackage )
public property | CreationDate | Retrieves the Creation Date of this package. (Inherited from UpdateServicesPackage )
public property | CurrentLanguage | Retrieves or sets the current language of the Title/Description pair. (Inherited from UpdateServicesPackage )
public property | DefaultLanguage | Retrieves or sets the default language for the Title/Description pair. (Inherited from UpdateServicesPackage )
public property | Description | Retrieves or sets the localized description which can be displayed in package description in the WSUS UI. (Inherited from UpdateServicesPackage )
public property | InstallableItems | Retrieve the InstallableItems list. (Inherited from UpdateServicesPackage )
public property | IsInstallable | Get/Set IsInstallable applicability rules of this package. (Inherited from UpdateServicesPackage )
public property | KnowledgebaseArticleId | Get KBArticleIds list. Note: Only Update type package can access this property. If not, an InvalidOperationException will be thrown. (Inherited from UpdateServicesPackage )
public property | MaxDownloadSize | Get/Set the maximum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.
public property | MinDownloadSize | Get/Set the minimum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.
public property | PackageId | Get/Set PackageId. (Inherited from UpdateServicesPackage )
public property | PackageType | Get/Set package type. Currently, it can be Application or Update types. (Inherited from UpdateServicesPackage )
public property | PackageUpdateClassification | Get/Set PackageUpdateClassification (Inherited from UpdateServicesPackage )
public property | ProductNames | Get product names list of this package (Inherited from UpdateServicesPackage )
public property | PublicationState | Get/Set PackagePublicationState (Inherited from UpdateServicesPackage )
public property | PublisherId | Get/Set the identity of publisher which publishs this package
public property | RevisionNumber | Get/Set revision number of package.
public property | SecurityBulletinId | Retrieves a security bulletin Id. (Inherited from UpdateServicesPackage )
public property | SecurityRating | Get/Set MSRC Sevevirty value. (Inherited from UpdateServicesPackage )
public property | SupersededPackages | Get Supersed PackageIds list. (Inherited from UpdateServicesPackage )
public property | SupportedLanguages | Get supported languages of Title/Description pairs. (Inherited from UpdateServicesPackage )
public property | SupportUrl | Get/Set support url. (Inherited from UpdateServicesPackage )
public property | Title | Get/Set the localized Title which can be displayed on WSUS UI. (Inherited from UpdateServicesPackage )
public property | VendorName | Get/Set VendorName (Inherited from UpdateServicesPackage )

See Also

Reference

UpdateServicesPackageWithServerInformation Class


UpdateServicesPackageWithServerInformation.MaxDownloadSize Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the maximum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation

Dim returnValue As Integer
returnValue = updateServicesPackageWithServerInformation1.MaxDownloadSize

Dim sampleValue As Integer
updateServicesPackageWithServerInformation1.MaxDownloadSize = sampleValue

Syntax

Visual Basic
Public Shadows Property MaxDownloadSize() As Integer
C#
public new int MaxDownloadSize {get; set;}
C++
public:
property int MaxDownloadSize {
    int get();
    void set(int value);
}
J#
new public int get_MaxDownloadSize();
public void set_MaxDownloadSize(int);
JScript
public hide function get MaxDownloadSize() : int;
public hide function set MaxDownloadSize(int);

Remarks

This attribute will usually be omitted, and the number of bytes may be calculated by adding up the sizes specified by the relevent File elements. But certain kinds of updates (Windows Patches) can perform an optimized download. For these updates, it is not possible to determine the actual download size without performing an analysis of the Client machine. The update author should include a MaxDownloadSize and MinDownloadSize, and the Client will present these to the user as an initial approximation of what would happen if he elected to download and install/uninstall the update. This attribute is omitted on bundles, and the value is calculated by adding the values on all applicable bundled children.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation.MinDownloadSize Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the minimum number of bytes that could be downloaded by the MSUS Client in order to perform installation/uninstallation of this update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation

Dim returnValue As Integer
returnValue = updateServicesPackageWithServerInformation1.MinDownloadSize

Dim sampleValue As Integer
updateServicesPackageWithServerInformation1.MinDownloadSize = sampleValue

Syntax

Visual Basic
Public Shadows Property MinDownloadSize() As Integer
C#
public new int MinDownloadSize {get; set;}
C++
public:
property int MinDownloadSize {
    int get();
    void set(int value);
}
J#
new public int get_MinDownloadSize();
public void set_MinDownloadSize(int);
JScript
public hide function get MinDownloadSize() : int;
public hide function set MinDownloadSize(int);

Remarks

Please see the documentation of MaxDownloadSize for more information.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation.PublisherId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set the identity of publisher which publishs this package

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation

Dim returnValue As Guid
returnValue = updateServicesPackageWithServerInformation1.PublisherId

Dim sampleValue As Guid
updateServicesPackageWithServerInformation1.PublisherId = sampleValue

Syntax

Visual Basic
Public Shadows Property PublisherId() As Guid
C#
public new Guid PublisherId {get; set;}
C++
public:
property Guid^ PublisherId {
    Guid^ get();
    void set(Guid^ value);
}
J#
new public Guid get_PublisherId();
public void set_PublisherId(Guid);
JScript
public hide function get PublisherId() : Guid;
public hide function set PublisherId(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateServicesPackageWithServerInformation.RevisionNumber Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set revision number of package.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateServicesPackageWithServerInformation1 As UpdateServicesPackageWithServerInformation

Dim returnValue As Integer
returnValue = updateServicesPackageWithServerInformation1.RevisionNumber

Dim sampleValue As Integer
updateServicesPackageWithServerInformation1.RevisionNumber = sampleValue

Syntax

Visual Basic
Public Shadows Property RevisionNumber() As Integer
C#
public new int RevisionNumber {get; set;}
C++
public:
property int RevisionNumber {
    int get();
    void set(int value);
}
J#
new public int get_RevisionNumber();
public void set_RevisionNumber(int);
JScript
public hide function get RevisionNumber() : int;
public hide function set RevisionNumber(int);

Remarks

This is required field.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateServicesPackageWithServerInformation Class
UpdateServicesPackageWithServerInformation Members


UpdateState Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the state of an update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateState1 As UpdateState = UpdateState.Canceled

Syntax

Visual Basic
Public Enum UpdateState
C#
public enum UpdateState
C++
public enum class UpdateState
J#
public enum UpdateState
JScript
public enum UpdateState

Members

Member name | Description
Canceled | The update is approved for installation, but the update, one of its children, or its parent was canceled by the Administrator. The update remains in this state until the download is resumed by calling IUpdate.ResumeDownload or by creating a new approval for this update.
Failed | The update is approved for installation, but failed because of one of the following reasons: One or more of the required files could not be retrieved from the upstream server; One or more of the child updates failed. The update remains in this state until the download is resumed by calling IUpdate.ResumeDownload or by creating a new approval for this update.
InstallationImpossible | The update cannot be installed because of one of the following reasons: The update does not support installation; The WSUS server does not support a language for which this update has a localized license agreement; One or more updates that bundled this update are in the InstallationImpossible state. You cannot approve the update for installation, but you may approve the update for scanning or removal. If the update is part of a bundle, you cannot install the parent update if one of its children is in the InstallationImpossible state.
LicenseAgreementFailed | The update has a license agreement file associated with it, but the license agreement failed to download. You cannot approve the update for installation. The update remains in this state until the download is resumed by calling IUpdate.ResumeDownload or by creating a new approval for this update.
LicenseAgreementNotReady | The license agreement for this update has not been downloaded to the server. You cannot approve the update for installation, but you may approve the update for scanning or removal. If the update is part of a bundle, you cannot install the parent update until all of its children have license agreements available.
NotNeeded | The update is available to be approved for installation, but it is not yet needed. This state is used only if IUpdateServerConfiguration.HostBinariesOnMicrosoftUpdate is true.
NotReady | The update is approved for installation but one or more files or child updates is not available. The server is trying to obtain the files and children necessary to install this update.
Ready | The update is approved for installation and all files and children are available. Clients can download and install the update.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.State


UpdateSummaryCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of summary installation information for updates. To retrieve this collection, call one of the following methods: IComputerTargetGroup.GetSummaryPerUpdate(); IComputerTargetGroup.GetTotalSummaryPerComputerTarget(); IUpdate.GetSummaryPerComputerTargetGroup().

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateSummaryCollection1 As New UpdateSummaryCollection()

Syntax

Visual Basic
Public Class UpdateSummaryCollection
    Inherits WsusCollection
C#
public class UpdateSummaryCollection : WsusCollection
C++
public ref class UpdateSummaryCollection : WsusCollection
J#
public class UpdateSummaryCollection extends WsusCollection
JScript
public class UpdateSummaryCollection extends WsusCollection

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Microsoft.UpdateServices.Administration.UpdateSummaryCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Members


UpdateSummaryCollection Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Collection of summary installation information for updates. To retrieve this collection, call one of the following methods: IComputerTargetGroup.GetSummaryPerUpdate(); IComputerTargetGroup.GetTotalSummaryPerComputerTarget(); IUpdate.GetSummaryPerComputerTargetGroup().

The following tables list the members exposed by the UpdateSummaryCollection type.

Public Constructors

Name | Description
UpdateSummaryCollection | Initializes a new instance of the UpdateSummaryCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance.(Inherited from WsusCollection)
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

UpdateSummaryCollection Class


UpdateSummaryCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the UpdateSummaryCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateSummaryCollection1 As New UpdateSummaryCollection()

Syntax

Visual Basic
Public Sub New()
C#
public UpdateSummaryCollection();
C++
public:
UpdateSummaryCollection();
J#
public UpdateSummaryCollection();
JScript
public function UpdateSummaryCollection();

Remarks

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Add | Overloaded.
public method | AddRange | Overloaded.
public method | Clear | (Inherited from CollectionBase )
public method | Contains | Overloaded.
public method | CopyTo | Overloaded.
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
public method | IndexOf | Overloaded.
public method | Insert | Overloaded.
 | ReferenceEquals | (Inherited from Object )
public method | Remove | Overloaded.
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Overloaded. (Inherited from WsusCollection )
protected method | AddRange | Overloaded.
protected method | Contains | Overloaded. (Inherited from WsusCollection )
protected method | CopyTo | Overloaded.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Overloaded. (Inherited from WsusCollection )
protected method | Insert | Overloaded. (Inherited from WsusCollection )
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Performs additional custom processes after clearing the contents of the UpdateCollection instance. (Inherited from WsusCollection )
protected method | OnInsert | (Inherited from WsusCollection )
protected method | OnInsertComplete | (Inherited from WsusCollection )
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | (Inherited from WsusCollection )
protected method | OnSet | (Inherited from WsusCollection )
protected method | OnSetComplete | (Inherited from WsusCollection )
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Overloaded. (Inherited from WsusCollection )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

UpdateSummaryCollection Class


UpdateSummaryCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.Add (IUpdateSummary) | Adds an update's summary installation information to the end of the collection.
UpdateSummaryCollection.Add (Object) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Add Method (IUpdateSummary)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an update's summary installation information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateSummary
Dim returnValue As Integer
Dim updateSummaryCollection1 As UpdateSummaryCollection
returnValue = updateSummaryCollection1.Add(value)

Syntax

Visual Basic
Overloads Public Function Add( _
    ByVal value As IUpdateSummary _
) As Integer
C#
public int Add(
    IUpdateSummary value
);
C++
public:
int Add(
    IUpdateSummary^ value
);
J#
public int Add(
    IUpdateSummary value
);
JScript
public function Add(
     value : IUpdateSummary
) : int;

Parameters

value

An IUpdateSummary of an update's summary information to add to the collection.

Return Value

Zero-based index at which the summary information was added to the collection.

Exceptions

Exception type | Condition
ArgumentException | The summary information already exists in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.AddRange (Array) |
UpdateSummaryCollection.AddRange (IUpdateSummary[]) | Adds an array of update summary information to the end of the collection.
UpdateSummaryCollection.AddRange (UpdateSummaryCollection) | Adds the members of an update summary information collection to the end of this collection.
UpdateSummaryCollection.AddRange (WsusCollection) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.AddRange Method (IUpdateSummary[])
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an array of update summary information to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value() As IUpdateSummary
Dim updateSummaryCollection1 As UpdateSummaryCollection
updateSummaryCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value() As IUpdateSummary _
)
C#
public void AddRange(
    IUpdateSummary[] value
);
C++
public:
void AddRange(
    array<IUpdateSummary^>^ value
);
J#
public void AddRange(
    IUpdateSummary[] value
);
JScript
public function AddRange(
     value : IUpdateSummary[]
) : Void;

Parameters

value

Array of IUpdateSummary instances to add to the collection.

Exceptions

Exception type | Condition
ArgumentException | One or more elements of the array already exist in this collection.
ArgumentNullException | value or elements of the array cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.AddRange Method (UpdateSummaryCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the members of an update summary information collection to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As UpdateSummaryCollection
Dim updateSummaryCollection1 As UpdateSummaryCollection
updateSummaryCollection1.AddRange(value)

Syntax

Visual Basic
Overloads Public Sub AddRange( _
    ByVal value As UpdateSummaryCollection _
)
C#
public void AddRange(
    UpdateSummaryCollection value
);
C++
public:
void AddRange(
    UpdateSummaryCollection^ value
);
J#
public void AddRange(
    UpdateSummaryCollection value
);
JScript
public function AddRange(
     value : UpdateSummaryCollection
) : Void;

Parameters

value

An UpdateSummaryCollection collection of update summary information to add.

Exceptions

Exception type | Condition
ArgumentException | One or more members of the collection to add already exist in this collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.Contains (IUpdateSummary) | Determines if the collection contains the specified update summary installation information.
UpdateSummaryCollection.Contains (Object) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Contains Method (IUpdateSummary)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update summary installation information.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateSummary
Dim returnValue As Boolean
Dim updateSummaryCollection1 As UpdateSummaryCollection
returnValue = updateSummaryCollection1.Contains(value)

Syntax

Visual Basic
Overloads Public Function Contains( _
    ByVal value As IUpdateSummary _
) As Boolean
C#
public bool Contains(
    IUpdateSummary value
);
C++
public:
bool Contains(
    IUpdateSummary^ value
);
J#
public boolean Contains(
    IUpdateSummary value
);
JScript
public function Contains(
     value : IUpdateSummary
) : Boolean;

Parameters

value

An IUpdateSummary of an update's summary installation information to locate in the collection.

Return Value

True if the collection contains the summary information; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.CopyTo (Array, Int32) |
UpdateSummaryCollection.CopyTo (IUpdateSummary[], Int32) | Copies the summary installation information for the updates in the collection to a one-dimensional array.

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.CopyTo Method (IUpdateSummary[], Int32)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the summary installation information for the updates in the collection to a one-dimensional array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim array() As IUpdateSummary
Dim index As Integer
Dim updateSummaryCollection1 As UpdateSummaryCollection
updateSummaryCollection1.CopyTo(array, index)

Syntax

Visual Basic
Overloads Public Sub CopyTo( _
    ByVal array() As IUpdateSummary, _
    ByVal index As Integer _
)
C#
public void CopyTo(
    IUpdateSummary[] array,
    int index
);
C++
public:
void CopyTo(
    array<IUpdateSummary^>^ array,
    int index
);
J#
public void CopyTo(
    IUpdateSummary[] array,
    int index
);
JScript
public function CopyTo(
     array : IUpdateSummary[],
     index : int
) : Void;

Parameters

array

Array of IUpdateSummary instances found in the collection.

index

Zero-based index that specifies the location in the array at which to begin adding the summary information.

Exceptions

Exception type Condition
ArgumentException

Can occur because of either of the following reasons:

  • index is greater than or equal to the length of the array.

  • The number of elements from index to the end of the array is less than the number of members in the collection.
ArgumentNullException

array cannot be null.
ArgumentOutOfRangeException

array cannot be less than zero.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.IndexOf (IUpdateSummary) | Determines if the collection contains the specified update summary installation information. If the collection contains the summary information, the method returns the zero-based index to the summary information in the collection.
UpdateSummaryCollection.IndexOf (Object) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.IndexOf Method (IUpdateSummary)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines if the collection contains the specified update summary installation information. If the collection contains the summary information, the method returns the zero-based index to the summary information in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateSummary
Dim returnValue As Integer
Dim updateSummaryCollection1 As UpdateSummaryCollection
returnValue = updateSummaryCollection1.IndexOf(value)

Syntax

Visual Basic
Overloads Public Function IndexOf( _
    ByVal value As IUpdateSummary _
) As Integer
C#
public int IndexOf(
    IUpdateSummary value
);
C++
public:
int IndexOf(
    IUpdateSummary^ value
);
J#
public int IndexOf(
    IUpdateSummary value
);
JScript
public function IndexOf(
     value : IUpdateSummary
) : int;

Parameters

value

An IUpdateSummary of the summary information to locate in the collection.

Return Value

Zero-based index of the summary information in the collection if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.Insert (Int32, IUpdateSummary) | Inserts the summary installation information for an update into the collection.
UpdateSummaryCollection.Insert (Int32, Object) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Insert Method (Int32, IUpdateSummary)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts the summary installation information for an update into the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim index As Integer
Dim value As IUpdateSummary
Dim updateSummaryCollection1 As UpdateSummaryCollection
updateSummaryCollection1.Insert(index, value)

Syntax

Visual Basic
Overloads Public Sub Insert( _
    ByVal index As Integer, _
    ByVal value As IUpdateSummary _
)
C#
public void Insert(
    int index,
    IUpdateSummary value
);
C++
public:
void Insert(
    int index,
    IUpdateSummary^ value
);
J#
public void Insert(
    int index,
    IUpdateSummary value
);
JScript
public function Insert(
     index : int,
     value : IUpdateSummary
) : Void;

Parameters

index

Zero-based index at which to insert the summary information into the collection.

value

An IUpdateSummary of the summary information to insert into the collection.

Exceptions

Exception type | Condition
ArgumentException | The summary information already exists in this collection.
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateSummaryCollection.Count.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
UpdateSummaryCollection.Remove (IUpdateSummary) | Removes the summary installation information for an update from the collection.
UpdateSummaryCollection.Remove (Object) |

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection.Remove Method (IUpdateSummary)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes the summary installation information for an update from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As IUpdateSummary
Dim updateSummaryCollection1 As UpdateSummaryCollection
updateSummaryCollection1.Remove(value)

Syntax

Visual Basic
Overloads Public Sub Remove( _
    ByVal value As IUpdateSummary _
)
C#
public void Remove(
    IUpdateSummary value
);
C++
public:
void Remove(
    IUpdateSummary^ value
);
J#
public void Remove(
    IUpdateSummary value
);
JScript
public function Remove(
     value : IUpdateSummary
) : Void;

Parameters

value

An IUpdateSummary of the summary information to remove.

Exceptions

Exception type | Condition
ArgumentException | The summary information does not exist in the collection.
ArgumentNullException | value cannot be null.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateSummaryCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
public property | Item | Retrieves or sets the member of the collection at the specified index.

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

UpdateSummaryCollection Class


UpdateSummaryCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Retrieves or sets the member of the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateSummaryCollection1 As UpdateSummaryCollection

Dim key As Integer
Dim returnValue As IUpdateSummary
returnValue = updateSummaryCollection1.Item(key)

Dim sampleValue As IUpdateSummary
updateSummaryCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Public Shadows Property Item( _
    ByVal index As Integer _
) As IUpdateSummary
C#
public new IUpdateSummary this[
    int index
] {get; set;}
C++
public:
property IUpdateSummary^ default[int] {
    IUpdateSummary^ get(int index);
    void set(int index, IUpdateSummary^ value);
}
J#
new public IUpdateSummary get_Item(
    int index
);
public void set_Item(
    int index
IUpdateSummary);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

Zero-based index of the member to retrieve or set.

Exceptions

Exception type | Condition
ArgumentException | The summary installation information for the update already exists in this collection.
ArgumentNullException | Cannot set a member of the collection to null.
ArgumentOutOfRangeException | index cannot be less than zero or greater than UpdateSummaryCollection.Count.

Remarks

This property is an indexer in C#.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

UpdateSummaryCollection Class
UpdateSummaryCollection Members


UpdateType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate if the update is a software or driver update.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateType1 As UpdateType = UpdateType.Driver

Syntax

Visual Basic
Public Enum UpdateType
C#
public enum UpdateType
C++
public enum class UpdateType
J#
public enum UpdateType
JScript
public enum UpdateType

Members

Member name | Description
Driver | The update is a driver update.
Software | The update is a software update.
SoftwareApplication | The update is a Software Application

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdate.UpdateType


UpdateTypes Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Set of flags used to specify what kind of updates to retrieve

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim updateTypes1 As UpdateTypes = UpdateTypes.All

Syntax

Visual Basic
Public Enum UpdateTypes
C#
public enum UpdateTypes
C++
public enum class UpdateTypes
J#
public enum UpdateTypes
JScript
public enum UpdateTypes

Members

Member name | Description
All |
Driver |
SoftwareApplication |
SoftwareUpdate |

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


WindowsInstallerItem Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As New WindowsInstallerItem()

Syntax

Visual Basic
Public Class WindowsInstallerItem
    Inherits InstallableItem
C#
public class WindowsInstallerItem : InstallableItem
C++
public ref class WindowsInstallerItem : InstallableItem
J#
public class WindowsInstallerItem extends InstallableItem
JScript
public class WindowsInstallerItem extends InstallableItem

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallableItem
Microsoft.UpdateServices.Administration.WindowsInstallerItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Members


WindowsInstallerItem Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the WindowsInstallerItem type.

Public Constructors

Name | Description
WindowsInstallerItem | Overloaded.
Top

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.(Inherited from InstallableItem)
public property | Id | Retrieves the ID uniquely identifying the InstallableItem(Inherited from InstallableItem)
public property | InstallBehavior | Get/Set InstallBehavior property(Inherited from InstallableItem)
public property | InstallCommandLine | Get/Set Install command
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.(Inherited from InstallableItem)
public property | Languages | Retrieves the list of languages that this binary has been localized to.(Inherited from InstallableItem)
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem)
public property | UninstallBehavior | Get/Set UninstallBehavior(Inherited from InstallableItem)
public property | UninstallCommandLine | Get/Set Unintall command.
public property | WindowsInstallerFile | Get/Set MSIFile
public property | WindowsInstallerProductCode | Get/Set ProductCode.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WindowsInstallerItem Class


WindowsInstallerItem Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
WindowsInstallerItem () | Default constructor.
WindowsInstallerItem (String) | Create a WindowsInstallerItem and set MSI related properties. Currently only MSIFile property and ProductCode are set.

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As New WindowsInstallerItem()

Syntax

Visual Basic
Public Sub New()
C#
public WindowsInstallerItem();
C++
public:
WindowsInstallerItem();
J#
public WindowsInstallerItem();
JScript
public function WindowsInstallerItem();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Create a WindowsInstallerItem and set MSI related properties. Currently only MSIFile property and ProductCode are set.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePath As String
Dim windowsInstallerItem1 As New WindowsInstallerItem(filePath)

Syntax

Visual Basic
Public Sub New( _
    ByVal filePath As String _
)
C#
public WindowsInstallerItem(
    string filePath
);
C++
public:
WindowsInstallerItem(
    String^ filePath
);
J#
public WindowsInstallerItem(
    System.String filePath
);
JScript
public function WindowsInstallerItem(
     filePath : String
);

Parameters

filePath

MSI file path

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WindowsInstallerItem Class


WindowsInstallerItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item. (Inherited from InstallableItem )
public property | Id | Retrieves the ID uniquely identifying the InstallableItem (Inherited from InstallableItem )
public property | InstallBehavior | Get/Set InstallBehavior property (Inherited from InstallableItem )
public property | InstallCommandLine | Get/Set Install command
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item. (Inherited from InstallableItem )
public property | Languages | Retrieves the list of languages that this binary has been localized to. (Inherited from InstallableItem )
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem )
public property | UninstallBehavior | Get/Set UninstallBehavior (Inherited from InstallableItem )
public property | UninstallCommandLine | Get/Set Unintall command.
public property | WindowsInstallerFile | Get/Set MSIFile
public property | WindowsInstallerProductCode | Get/Set ProductCode.

See Also

Reference

WindowsInstallerItem Class


WindowsInstallerItem.InstallCommandLine Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Install command

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As WindowsInstallerItem

Dim returnValue As String
returnValue = windowsInstallerItem1.InstallCommandLine

Dim sampleValue As String
windowsInstallerItem1.InstallCommandLine = sampleValue

Syntax

Visual Basic
Public Property InstallCommandLine() As String
C#
public string InstallCommandLine {get; set;}
C++
public:
property String^ InstallCommandLine {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_InstallCommandLine();
public void set_InstallCommandLine(System.String);
JScript
public function get InstallCommandLine() : String;
public function set InstallCommandLine(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem.UninstallCommandLine Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Unintall command.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As WindowsInstallerItem

Dim returnValue As String
returnValue = windowsInstallerItem1.UninstallCommandLine

Dim sampleValue As String
windowsInstallerItem1.UninstallCommandLine = sampleValue

Syntax

Visual Basic
Public Property UninstallCommandLine() As String
C#
public string UninstallCommandLine {get; set;}
C++
public:
property String^ UninstallCommandLine {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_UninstallCommandLine();
public void set_UninstallCommandLine(System.String);
JScript
public function get UninstallCommandLine() : String;
public function set UninstallCommandLine(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem.WindowsInstallerFile Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set MSIFile

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As WindowsInstallerItem

Dim returnValue As String
returnValue = windowsInstallerItem1.WindowsInstallerFile

Dim sampleValue As String
windowsInstallerItem1.WindowsInstallerFile = sampleValue

Syntax

Visual Basic
Public Property WindowsInstallerFile() As String
C#
public string WindowsInstallerFile {get; set;}
C++
public:
property String^ WindowsInstallerFile {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_WindowsInstallerFile();
public void set_WindowsInstallerFile(System.String);
JScript
public function get WindowsInstallerFile() : String;
public function set WindowsInstallerFile(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerItem.WindowsInstallerProductCode Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set ProductCode.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerItem1 As WindowsInstallerItem

Dim returnValue As Guid
returnValue = windowsInstallerItem1.WindowsInstallerProductCode

Dim sampleValue As Guid
windowsInstallerItem1.WindowsInstallerProductCode = sampleValue

Syntax

Visual Basic
Public Property WindowsInstallerProductCode() As Guid
C#
public Guid WindowsInstallerProductCode {get; set;}
C++
public:
property Guid^ WindowsInstallerProductCode {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_WindowsInstallerProductCode();
public void set_WindowsInstallerProductCode(Guid);
JScript
public function get WindowsInstallerProductCode() : Guid;
public function set WindowsInstallerProductCode(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerItem Class
WindowsInstallerItem Members


WindowsInstallerPackageType Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Type of the MSI package

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPackageType1 As WindowsInstallerPackageType = WindowsInstallerPackageType.MsiPatch

Syntax

Visual Basic
Public Enum WindowsInstallerPackageType
C#
public enum WindowsInstallerPackageType
C++
public enum class WindowsInstallerPackageType
J#
public enum WindowsInstallerPackageType
JScript
public enum WindowsInstallerPackageType

Members

Member name | Description
MsiPatch |
MsiProduct |

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


WindowsInstallerPatchItem Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As New WindowsInstallerPatchItem()

Syntax

Visual Basic
Public Class WindowsInstallerPatchItem
    Inherits InstallableItem
C#
public class WindowsInstallerPatchItem : InstallableItem
C++
public ref class WindowsInstallerPatchItem : InstallableItem
J#
public class WindowsInstallerPatchItem extends InstallableItem
JScript
public class WindowsInstallerPatchItem extends InstallableItem

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.InstallableItem
Microsoft.UpdateServices.Administration.WindowsInstallerPatchItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Members


WindowsInstallerPatchItem Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The following tables list the members exposed by the WindowsInstallerPatchItem type.

Public Constructors

Name | Description
WindowsInstallerPatchItem | Overloaded.
Top

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item.(Inherited from InstallableItem)
public property | Id | Retrieves the ID uniquely identifying the InstallableItem(Inherited from InstallableItem)
public property | InstallBehavior | Get/Set InstallBehavior property(Inherited from InstallableItem)
public property | InstallCommandLine | Get/Set Install command.
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item.(Inherited from InstallableItem)
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item.(Inherited from InstallableItem)
public property | Languages | Retrieves the list of languages that this binary has been localized to.(Inherited from InstallableItem)
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem)
public property | UninstallBehavior | Get/Set UninstallBehavior(Inherited from InstallableItem)
public property | UninstallCommandLine | Get/Set Uninstall command.
public property | WindowsInstallerFullFilePatchCode | Get/Set full file patch code guid.
public property | WindowsInstallerPatchCode | Get/Set MSP PatchCode Guid.
public property | WindowsInstallerPatchFileName | Get/Set file name of the windows installer patch package
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WindowsInstallerPatchItem Class


WindowsInstallerPatchItem Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
WindowsInstallerPatchItem () | Default constructor.
WindowsInstallerPatchItem (String) | Construct and set FilePath property from input file parameter.

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Default constructor.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As New WindowsInstallerPatchItem()

Syntax

Visual Basic
Public Sub New()
C#
public WindowsInstallerPatchItem();
C++
public:
WindowsInstallerPatchItem();
J#
public WindowsInstallerPatchItem();
JScript
public function WindowsInstallerPatchItem();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Construct and set FilePath property from input file parameter.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim filePath As String
Dim windowsInstallerPatchItem1 As New WindowsInstallerPatchItem(filePath)

Syntax

Visual Basic
Public Sub New( _
    ByVal filePath As String _
)
C#
public WindowsInstallerPatchItem(
    string filePath
);
C++
public:
WindowsInstallerPatchItem(
    String^ filePath
);
J#
public WindowsInstallerPatchItem(
    System.String filePath
);
JScript
public function WindowsInstallerPatchItem(
     filePath : String
);

Parameters

filePath

MSP file path

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | GetXml | (Inherited from InstallableItem )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WindowsInstallerPatchItem Class


WindowsInstallerPatchItem Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | ApplicabilityMetadata | Retrieves or sets Metadata applicability rules of this installable item. (Inherited from InstallableItem )
public property | Id | Retrieves the ID uniquely identifying the InstallableItem (Inherited from InstallableItem )
public property | InstallBehavior | Get/Set InstallBehavior property (Inherited from InstallableItem )
public property | InstallCommandLine | Get/Set Install command.
public property | InstallHandlerSpecificData | (Inherited from InstallableItem )
public property | IsInstallableApplicabilityRule | Retrieves or sets the IsInstallable applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsInstalledApplicabilityRule | Retrieves or sets the InInstalled applicability rules of this installable item. (Inherited from InstallableItem )
public property | IsSupersededApplicabilityRule | Retrieves or sets the IsSupersed applicability rules of this installable item. (Inherited from InstallableItem )
public property | Languages | Retrieves the list of languages that this binary has been localized to. (Inherited from InstallableItem )
public property | OriginalSourceFile | Retrieve the original source of this update. (Inherited from InstallableItem )
public property | UninstallBehavior | Get/Set UninstallBehavior (Inherited from InstallableItem )
public property | UninstallCommandLine | Get/Set Uninstall command.
public property | WindowsInstallerFullFilePatchCode | Get/Set full file patch code guid.
public property | WindowsInstallerPatchCode | Get/Set MSP PatchCode Guid.
public property | WindowsInstallerPatchFileName | Get/Set file name of the windows installer patch package

See Also

Reference

WindowsInstallerPatchItem Class


WindowsInstallerPatchItem.InstallCommandLine Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Install command.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As WindowsInstallerPatchItem

Dim returnValue As String
returnValue = windowsInstallerPatchItem1.InstallCommandLine

Dim sampleValue As String
windowsInstallerPatchItem1.InstallCommandLine = sampleValue

Syntax

Visual Basic
Public Property InstallCommandLine() As String
C#
public string InstallCommandLine {get; set;}
C++
public:
property String^ InstallCommandLine {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_InstallCommandLine();
public void set_InstallCommandLine(System.String);
JScript
public function get InstallCommandLine() : String;
public function set InstallCommandLine(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem.UninstallCommandLine Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set Uninstall command.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As WindowsInstallerPatchItem

Dim returnValue As String
returnValue = windowsInstallerPatchItem1.UninstallCommandLine

Dim sampleValue As String
windowsInstallerPatchItem1.UninstallCommandLine = sampleValue

Syntax

Visual Basic
Public Property UninstallCommandLine() As String
C#
public string UninstallCommandLine {get; set;}
C++
public:
property String^ UninstallCommandLine {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_UninstallCommandLine();
public void set_UninstallCommandLine(System.String);
JScript
public function get UninstallCommandLine() : String;
public function set UninstallCommandLine(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem.WindowsInstallerFullFilePatchCode Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set full file patch code guid.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As WindowsInstallerPatchItem

Dim returnValue As Guid
returnValue = windowsInstallerPatchItem1.WindowsInstallerFullFilePatchCode

Dim sampleValue As Guid
windowsInstallerPatchItem1.WindowsInstallerFullFilePatchCode = sampleValue

Syntax

Visual Basic
Public Property WindowsInstallerFullFilePatchCode() As Guid
C#
public Guid WindowsInstallerFullFilePatchCode {get; set;}
C++
public:
property Guid^ WindowsInstallerFullFilePatchCode {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_WindowsInstallerFullFilePatchCode();
public void set_WindowsInstallerFullFilePatchCode(Guid);
JScript
public function get WindowsInstallerFullFilePatchCode() : Guid;
public function set WindowsInstallerFullFilePatchCode(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem.WindowsInstallerPatchCode Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set MSP PatchCode Guid.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As WindowsInstallerPatchItem

Dim returnValue As Guid
returnValue = windowsInstallerPatchItem1.WindowsInstallerPatchCode

Dim sampleValue As Guid
windowsInstallerPatchItem1.WindowsInstallerPatchCode = sampleValue

Syntax

Visual Basic
Public Property WindowsInstallerPatchCode() As Guid
C#
public Guid WindowsInstallerPatchCode {get; set;}
C++
public:
property Guid^ WindowsInstallerPatchCode {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_WindowsInstallerPatchCode();
public void set_WindowsInstallerPatchCode(Guid);
JScript
public function get WindowsInstallerPatchCode() : Guid;
public function set WindowsInstallerPatchCode(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerPatchItem.WindowsInstallerPatchFileName Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Get/Set file name of the windows installer patch package

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerPatchItem1 As WindowsInstallerPatchItem

Dim returnValue As String
returnValue = windowsInstallerPatchItem1.WindowsInstallerPatchFileName

Dim sampleValue As String
windowsInstallerPatchItem1.WindowsInstallerPatchFileName = sampleValue

Syntax

Visual Basic
Public Property WindowsInstallerPatchFileName() As String
C#
public string WindowsInstallerPatchFileName {get; set;}
C++
public:
property String^ WindowsInstallerPatchFileName {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_WindowsInstallerPatchFileName();
public void set_WindowsInstallerPatchFileName(System.String);
JScript
public function get WindowsInstallerPatchFileName() : String;
public function set WindowsInstallerPatchFileName(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerPatchItem Class
WindowsInstallerPatchItem Members


WindowsInstallerRepairPath Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class is used to support Exe-wrapped-Msi. It contains TargetId (ProductCode of Msi), TargetType: for either MSI or MSP; and RelativePathToExe: a relative path to setup executable which AU will use it to determine where the repair path is for each MSI/MSP.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPath1 As New WindowsInstallerRepairPath()

Syntax

Visual Basic
Public Class WindowsInstallerRepairPath
C#
public class WindowsInstallerRepairPath
C++
public ref class WindowsInstallerRepairPath
J#
public class WindowsInstallerRepairPath
JScript
public class WindowsInstallerRepairPath

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.WindowsInstallerRepairPath

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPath Members


WindowsInstallerRepairPath Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class is used to support Exe-wrapped-Msi. It contains TargetId (ProductCode of Msi), TargetType: for either MSI or MSP; and RelativePathToExe: a relative path to setup executable which AU will use it to determine where the repair path is for each MSI/MSP.

The following tables list the members exposed by the WindowsInstallerRepairPath type.

Public Constructors

Name | Description
WindowsInstallerRepairPath | Initializes a new instance of the WindowsInstallerRepairPath class.
Top

Public Properties

 | Name | Description
public property | RelativePathToExe | A relative path with filename to the setup program. '.' or '..' are allowed.
public property | TargetId | ProductCode of MSI or PatchCode for MSP
public property | TargetType | MsiProduct for MSI or MsiPatch for MSP.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WindowsInstallerRepairPath Class


WindowsInstallerRepairPath Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WindowsInstallerRepairPath class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPath1 As New WindowsInstallerRepairPath()

Syntax

Visual Basic
Public Sub New()
C#
public WindowsInstallerRepairPath();
C++
public:
WindowsInstallerRepairPath();
J#
public WindowsInstallerRepairPath();
JScript
public function WindowsInstallerRepairPath();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPath Class
WindowsInstallerRepairPath Members


WindowsInstallerRepairPath Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WindowsInstallerRepairPath Class


WindowsInstallerRepairPath Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | RelativePathToExe | A relative path with filename to the setup program. '.' or '..' are allowed.
public property | TargetId | ProductCode of MSI or PatchCode for MSP
public property | TargetType | MsiProduct for MSI or MsiPatch for MSP.

See Also

Reference

WindowsInstallerRepairPath Class


WindowsInstallerRepairPath.RelativePathToExe Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

A relative path with filename to the setup program. '.' or '..' are allowed.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPath1 As WindowsInstallerRepairPath

Dim returnValue As String
returnValue = windowsInstallerRepairPath1.RelativePathToExe

Dim sampleValue As String
windowsInstallerRepairPath1.RelativePathToExe = sampleValue

Syntax

Visual Basic
Public Property RelativePathToExe() As String
C#
public string RelativePathToExe {get; set;}
C++
public:
property String^ RelativePathToExe {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_RelativePathToExe();
public void set_RelativePathToExe(System.String);
JScript
public function get RelativePathToExe() : String;
public function set RelativePathToExe(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPath Class
WindowsInstallerRepairPath Members


WindowsInstallerRepairPath.TargetId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

ProductCode of MSI or PatchCode for MSP

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPath1 As WindowsInstallerRepairPath

Dim returnValue As Guid
returnValue = windowsInstallerRepairPath1.TargetId

Dim sampleValue As Guid
windowsInstallerRepairPath1.TargetId = sampleValue

Syntax

Visual Basic
Public Property TargetId() As Guid
C#
public Guid TargetId {get; set;}
C++
public:
property Guid^ TargetId {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_TargetId();
public void set_TargetId(Guid);
JScript
public function get TargetId() : Guid;
public function set TargetId(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPath Class
WindowsInstallerRepairPath Members


WindowsInstallerRepairPath.TargetType Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

MsiProduct for MSI or MsiPatch for MSP.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPath1 As WindowsInstallerRepairPath

Dim returnValue As WindowsInstallerPackageType
returnValue = windowsInstallerRepairPath1.TargetType

Dim sampleValue As WindowsInstallerPackageType
windowsInstallerRepairPath1.TargetType = sampleValue

Syntax

Visual Basic
Public Property TargetType() As WindowsInstallerPackageType
C#
public WindowsInstallerPackageType TargetType {get; set;}
C++
public:
property WindowsInstallerPackageType TargetType {
    WindowsInstallerPackageType get();
    void set(WindowsInstallerPackageType value);
}
J#
public WindowsInstallerPackageType get_TargetType();
public void set_TargetType(WindowsInstallerPackageType);
JScript
public function get TargetType() : WindowsInstallerPackageType;
public function set TargetType(WindowsInstallerPackageType);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPath Class
WindowsInstallerRepairPath Members


WindowsInstallerRepairPathInfo Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This is used for publishing to fill server specific information for RepairPath. It actually only needs to fill Path property.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As WindowsInstallerRepairPath
Dim windowsInstallerRepairPathInfo1 As New WindowsInstallerRepairPathInfo(value)

Syntax

Visual Basic
Public Class WindowsInstallerRepairPathInfo
C#
public class WindowsInstallerRepairPathInfo
C++
public ref class WindowsInstallerRepairPathInfo
J#
public class WindowsInstallerRepairPathInfo
JScript
public class WindowsInstallerRepairPathInfo

Inheritance Hierarchy

System.Object
Microsoft.UpdateServices.Administration.WindowsInstallerRepairPathInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Members


WindowsInstallerRepairPathInfo Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This is used for publishing to fill server specific information for RepairPath. It actually only needs to fill Path property.

The following tables list the members exposed by the WindowsInstallerRepairPathInfo type.

Public Constructors

Name | Description
WindowsInstallerRepairPathInfo |
Top

Public Properties

 | Name | Description
public property | RelativePathToExe | Since this value is defined in SDP:WindowsInstallerRepairPath, it's readonly here.
public property | RepairPath | The repair path of each MSI/MSP which will be registered by AU on client machines.
public property | TargetId | ProductCode for MSI or PatchCode for MSP
public property | TargetType | MSI or MSP. Since the type is defined in SDP section, it's readonly here.
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WindowsInstallerRepairPathInfo Class


WindowsInstallerRepairPathInfo Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim value As WindowsInstallerRepairPath
Dim windowsInstallerRepairPathInfo1 As New WindowsInstallerRepairPathInfo(value)

Syntax

Visual Basic
Public Sub New( _
    ByVal value As WindowsInstallerRepairPath _
)
C#
public WindowsInstallerRepairPathInfo(
    WindowsInstallerRepairPath value
);
C++
public:
WindowsInstallerRepairPathInfo(
    WindowsInstallerRepairPath^ value
);
J#
public WindowsInstallerRepairPathInfo(
    WindowsInstallerRepairPath value
);
JScript
public function WindowsInstallerRepairPathInfo(
     value : WindowsInstallerRepairPath
);

Parameters

value

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Class
WindowsInstallerRepairPathInfo Members


WindowsInstallerRepairPathInfo Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WindowsInstallerRepairPathInfo Class


WindowsInstallerRepairPathInfo Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties

 | Name | Description
public property | RelativePathToExe | Since this value is defined in SDP:WindowsInstallerRepairPath, it's readonly here.
public property | RepairPath | The repair path of each MSI/MSP which will be registered by AU on client machines.
public property | TargetId | ProductCode for MSI or PatchCode for MSP
public property | TargetType | MSI or MSP. Since the type is defined in SDP section, it's readonly here.

See Also

Reference

WindowsInstallerRepairPathInfo Class


WindowsInstallerRepairPathInfo.RelativePathToExe Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Since this value is defined in SDP:WindowsInstallerRepairPath, it's readonly here.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPathInfo1 As WindowsInstallerRepairPathInfo

Dim returnValue As String
returnValue = windowsInstallerRepairPathInfo1.RelativePathToExe

Syntax

Visual Basic
Public ReadOnly Property RelativePathToExe() As String
C#
public string RelativePathToExe {get;}
C++
public:
property String^ RelativePathToExe {
    String^ get();
}
J#
public System.String get_RelativePathToExe();
JScript
public function get RelativePathToExe() : String;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Class
WindowsInstallerRepairPathInfo Members


WindowsInstallerRepairPathInfo.RepairPath Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

The repair path of each MSI/MSP which will be registered by AU on client machines.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPathInfo1 As WindowsInstallerRepairPathInfo

Dim returnValue As String
returnValue = windowsInstallerRepairPathInfo1.RepairPath

Dim sampleValue As String
windowsInstallerRepairPathInfo1.RepairPath = sampleValue

Syntax

Visual Basic
Public Property RepairPath() As String
C#
public string RepairPath {get; set;}
C++
public:
property String^ RepairPath {
    String^ get();
    void set(String^ value);
}
J#
public System.String get_RepairPath();
public void set_RepairPath(System.String);
JScript
public function get RepairPath() : String;
public function set RepairPath(String);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Class
WindowsInstallerRepairPathInfo Members


WindowsInstallerRepairPathInfo.TargetId Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

ProductCode for MSI or PatchCode for MSP

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPathInfo1 As WindowsInstallerRepairPathInfo

Dim returnValue As Guid
returnValue = windowsInstallerRepairPathInfo1.TargetId

Dim sampleValue As Guid
windowsInstallerRepairPathInfo1.TargetId = sampleValue

Syntax

Visual Basic
Public Property TargetId() As Guid
C#
public Guid TargetId {get; set;}
C++
public:
property Guid^ TargetId {
    Guid^ get();
    void set(Guid^ value);
}
J#
public Guid get_TargetId();
public void set_TargetId(Guid);
JScript
public function get TargetId() : Guid;
public function set TargetId(Guid);

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Class
WindowsInstallerRepairPathInfo Members


WindowsInstallerRepairPathInfo.TargetType Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

MSI or MSP. Since the type is defined in SDP section, it's readonly here.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim windowsInstallerRepairPathInfo1 As WindowsInstallerRepairPathInfo

Dim returnValue As WindowsInstallerPackageType
returnValue = windowsInstallerRepairPathInfo1.TargetType

Syntax

Visual Basic
Public ReadOnly Property TargetType() As WindowsInstallerPackageType
C#
public WindowsInstallerPackageType TargetType {get;}
C++
public:
property WindowsInstallerPackageType TargetType {
    WindowsInstallerPackageType get();
}
J#
public WindowsInstallerPackageType get_TargetType();
JScript
public function get TargetType() : WindowsInstallerPackageType;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WindowsInstallerRepairPathInfo Class
WindowsInstallerRepairPathInfo Members


WsusCollection Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class provides custom validation for CollectionBase.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusCollection1 As New WsusCollection()

Syntax

Visual Basic
MustInherit Public Class WsusCollection
    Inherits CollectionBase
C#
public abstract class WsusCollection : CollectionBase
C++
public ref class WsusCollection abstract : CollectionBase
J#
public abstract class WsusCollection extends CollectionBase
JScript
public abstract class WsusCollection extends CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
Microsoft.UpdateServices.Administration.WsusCollection
Derived Classes

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Members


WsusCollection Members
See Also Methods Properties Constructors Explicit Interface Implementations
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This class provides custom validation for CollectionBase.

The following tables list the members exposed by the WsusCollection type.

Protected Constructors

Name | Description
WsusCollection | Initializes a new instance of the WsusCollection class.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )
Top

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | Item | Gets or sets the element at the specified index. In C#, this property is the indexer for the collection.
protected property | List | (Inherited from CollectionBase )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Clear | (Inherited from CollectionBase )
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )
Top

Protected Methods

 | Name | Description
protected method | Add | Adds an element to the end of the collection.
protected method | AddRange | Overloaded. Adds the items in the specified SusCollectionBase to the end of this collection.
protected method | Contains | Determines whether the specified element is in the collection.
protected method | CopyTo | Copies the entire collection of values to a one-dimensional array, starting at the specified index of the target array.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Searches for the specified element and returns the zero-based index of it if it exists.
protected method | Insert | Inserts an element into the collection at the specified index.
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Overridden. Performs additional custom processes after clearing the contents of the UpdateCollection instance.
protected method | OnInsert | Overridden. Provides overridden validation functionality which checks that we do not insert duplicates into our collection.
protected method | OnInsertComplete | Overridden. Performs additional custom processes after inserting a new element into the UpdateCollection instance.
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | Overridden. Performs additional custom processes after removing an element from the UpdateCollection instance.
protected method | OnSet | Overridden. Provices overridden validation functionality which checks that we do not insert duplicates into our collection.
protected method | OnSetComplete | Overridden. Performs additional custom processes after setting a value in the UpdateCollection instance.
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Removes a specified element from the collection.
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )
Top

See Also

Reference

WsusCollection Class


WsusCollection Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusCollection class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusCollection1 As New WsusCollection()

Syntax

Visual Basic
Protected Sub New()
C#
protected WsusCollection();
C++
protected:
WsusCollection();
J#
protected WsusCollection();
JScript
protected function WsusCollection();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Clear | (Inherited from CollectionBase )
public method | Equals | Overloaded. (Inherited from Object )
public method | GetEnumerator | (Inherited from CollectionBase )
public method | GetHashCode | (Inherited from Object )
public method | GetType | (Inherited from Object )
 | ReferenceEquals | (Inherited from Object )
public method | RemoveAt | (Inherited from CollectionBase )
public method | ToString | (Inherited from Object )

Protected Methods

 | Name | Description
protected method | Add | Adds an element to the end of the collection.
protected method | AddRange | Overloaded. Adds the items in the specified SusCollectionBase to the end of this collection.
protected method | Contains | Determines whether the specified element is in the collection.
protected method | CopyTo | Copies the entire collection of values to a one-dimensional array, starting at the specified index of the target array.
protected method | Finalize | (Inherited from Object )
protected method | IndexOf | Searches for the specified element and returns the zero-based index of it if it exists.
protected method | Insert | Inserts an element into the collection at the specified index.
protected method | MemberwiseClone | (Inherited from Object )
protected method | OnClear | (Inherited from CollectionBase )
protected method | OnClearComplete | Overridden. Performs additional custom processes after clearing the contents of the UpdateCollection instance.
protected method | OnInsert | Overridden. Provides overridden validation functionality which checks that we do not insert duplicates into our collection.
protected method | OnInsertComplete | Overridden. Performs additional custom processes after inserting a new element into the UpdateCollection instance.
protected method | OnRemove | (Inherited from CollectionBase )
protected method | OnRemoveComplete | Overridden. Performs additional custom processes after removing an element from the UpdateCollection instance.
protected method | OnSet | Overridden. Provices overridden validation functionality which checks that we do not insert duplicates into our collection.
protected method | OnSetComplete | Overridden. Performs additional custom processes after setting a value in the UpdateCollection instance.
protected method | OnValidate | (Inherited from CollectionBase )
protected method | Remove | Removes a specified element from the collection.

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (Inherited from CollectionBase )
System.Collections.IList.Add | (Inherited from CollectionBase )
System.Collections.IList.Contains | (Inherited from CollectionBase )
System.Collections.IList.IndexOf | (Inherited from CollectionBase )
System.Collections.IList.Insert | (Inherited from CollectionBase )
System.Collections.IList.Remove | (Inherited from CollectionBase )

See Also

Reference

WsusCollection Class


WsusCollection.Add Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds an element to the end of the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Function Add(value As Object)
            MyBase.Add(value)
        End Function
End Class

Syntax

Visual Basic
Protected Function Add( _
    ByVal value As Object _
) As Integer
C#
protected int Add(
    object value
);
C++
protected:
int Add(
    Object^ value
);
J#
protected int Add(
    System.Object value
);
JScript
protected function Add(
     value : Object
) : int;

Parameters

value

The element to add to the end of the collection.

Return Value

The zero-based index at which the new element is indexed.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.AddRange Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the items in the specified SusCollectionBase to the end of this collection.

Overload List

Name | Description
WsusCollection.AddRange (Array) | Adds the elements of the specified array to the end of this collection.
WsusCollection.AddRange (WsusCollection) | Adds the items in the specified SusCollectionBase to the end of this collection.

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.AddRange Method (Array)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the elements of the specified array to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub AddRange(value As Array)
            MyBase.AddRange(value)
        End Sub
End Class

Syntax

Visual Basic
Overloads Protected Sub AddRange( _
    ByVal value As Array _
)
C#
protected void AddRange(
    Array value
);
C++
protected:
void AddRange(
    Array^ value
);
J#
protected void AddRange(
    Array value
);
JScript
protected function AddRange(
     value : Array
) : Void;

Parameters

value

The IEnumerable containg the object to be added to the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.AddRange Method (WsusCollection)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Adds the items in the specified SusCollectionBase to the end of this collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub AddRange(value As WsusCollection)
            MyBase.AddRange(value)
        End Sub
End Class

Syntax

Visual Basic
Overloads Protected Sub AddRange( _
    ByVal value As WsusCollection _
)
C#
protected void AddRange(
    WsusCollection value
);
C++
protected:
void AddRange(
    WsusCollection^ value
);
J#
protected void AddRange(
    WsusCollection value
);
JScript
protected function AddRange(
     value : WsusCollection
) : Void;

Parameters

value

The SusCollectionBase containg the object to be added to the collection.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.Contains Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Determines whether the specified element is in the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Function Contains(value As Object)
            MyBase.Contains(value)
        End Function
End Class

Syntax

Visual Basic
Protected Function Contains( _
    ByVal value As Object _
) As Boolean
C#
protected bool Contains(
    object value
);
C++
protected:
bool Contains(
    Object^ value
);
J#
protected boolean Contains(
    System.Object value
);
JScript
protected function Contains(
     value : Object
) : Boolean;

Parameters

value

The element to locate in the collection.

Return Value

true if value is found in the collection; otherwise, false.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.CopyTo Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Copies the entire collection of values to a one-dimensional array, starting at the specified index of the target array.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub CopyTo(array As Array, _
            index As Integer)
            MyBase.CopyTo(array, index)
        End Sub
End Class

Syntax

Visual Basic
Protected Sub CopyTo( _
    ByVal array As Array, _
    ByVal index As Integer _
)
C#
protected void CopyTo(
    Array array,
    int index
);
C++
protected:
void CopyTo(
    Array^ array,
    int index
);
J#
protected void CopyTo(
    Array array,
    int index
);
JScript
protected function CopyTo(
     array : Array,
     index : int
) : Void;

Parameters

array

The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.

index

The zero-based index in array at which copying begins.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.IndexOf Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Searches for the specified element and returns the zero-based index of it if it exists.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Function IndexOf(value As Object)
            MyBase.IndexOf(value)
        End Function
End Class

Syntax

Visual Basic
Protected Function IndexOf( _
    ByVal value As Object _
) As Integer
C#
protected int IndexOf(
    object value
);
C++
protected:
int IndexOf(
    Object^ value
);
J#
protected int IndexOf(
    System.Object value
);
JScript
protected function IndexOf(
     value : Object
) : int;

Parameters

value

The Update to locate.

Return Value

zero-based index of the first occurrence of value in the collection, if found; otherwise, -1.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.Insert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Inserts an element into the collection at the specified index.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub Insert(index As Integer, _
            value As Object)
            MyBase.Insert(index, value)
        End Sub
End Class

Syntax

Visual Basic
Protected Sub Insert( _
    ByVal index As Integer, _
    ByVal value As Object _
)
C#
protected void Insert(
    int index,
    object value
);
C++
protected:
void Insert(
    int index,
    Object^ value
);
J#
protected void Insert(
    int index,
    System.Object value
);
JScript
protected function Insert(
     index : int,
     value : Object
) : Void;

Parameters

index

The zero-based index at which value is inserted.

value

The element to insert.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnClearComplete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Performs additional custom processes after clearing the contents of the UpdateCollection instance.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnClearComplete()
            MyBase.OnClearComplete()
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnClearComplete()
C#
protected override void OnClearComplete();
C++
protected:
virtual void OnClearComplete() override;
J#
protected override void OnClearComplete();
JScript
protected override function OnClearComplete() : Void;

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnInsert Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Provides overridden validation functionality which checks that we do not insert duplicates into our collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnInsert(index As Integer, _
            value As Object)
            MyBase.OnInsert(index, value)
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnInsert( _
    ByVal index As Integer, _
    ByVal value As Object _
)
C#
protected override void OnInsert(
    int index,
    object value
);
C++
protected:
virtual void OnInsert(
    int index,
    Object^ value
) override;
J#
protected override void OnInsert(
    int index,
    System.Object value
);
JScript
protected override function OnInsert(
     index : int,
     value : Object
) : Void;

Parameters

index

The index at which the object will be inserted.

value

The object to be added

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnInsertComplete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Performs additional custom processes after inserting a new element into the UpdateCollection instance.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnInsertComplete(index As Integer, _
            value As Object)
            MyBase.OnInsertComplete(index, value)
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnInsertComplete( _
    ByVal index As Integer, _
    ByVal value As Object _
)
C#
protected override void OnInsertComplete(
    int index,
    object value
);
C++
protected:
virtual void OnInsertComplete(
    int index,
    Object^ value
) override;
J#
protected override void OnInsertComplete(
    int index,
    System.Object value
);
JScript
protected override function OnInsertComplete(
     index : int,
     value : Object
) : Void;

Parameters

index

The zero-based index at which to insert value.

value

The new value of the element at index.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnRemoveComplete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Performs additional custom processes after removing an element from the UpdateCollection instance.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnRemoveComplete(index As Integer, _
            value As Object)
            MyBase.OnRemoveComplete(index, value)
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnRemoveComplete( _
    ByVal index As Integer, _
    ByVal value As Object _
)
C#
protected override void OnRemoveComplete(
    int index,
    object value
);
C++
protected:
virtual void OnRemoveComplete(
    int index,
    Object^ value
) override;
J#
protected override void OnRemoveComplete(
    int index,
    System.Object value
);
JScript
protected override function OnRemoveComplete(
     index : int,
     value : Object
) : Void;

Parameters

index

The zero-based index at which value can be found.

value

The value of the element to remove from index.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnSet Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Provices overridden validation functionality which checks that we do not insert duplicates into our collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnSet(index As Integer, _
            oldValue As Object, _
            newValue As Object)
            MyBase.OnSet(index, oldValue, newValue)
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnSet( _
    ByVal index As Integer, _
    ByVal oldValue As Object, _
    ByVal newValue As Object _
)
C#
protected override void OnSet(
    int index,
    object oldValue,
    object newValue
);
C++
protected:
virtual void OnSet(
    int index,
    Object^ oldValue,
    Object^ newValue
) override;
J#
protected override void OnSet(
    int index,
    System.Object oldValue,
    System.Object newValue
);
JScript
protected override function OnSet(
     index : int,
     oldValue : Object,
     newValue : Object
) : Void;

Parameters

index

The index at which the object will be set.

oldValue

The old value at index

newValue

The new value to be placed at index.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.OnSetComplete Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Performs additional custom processes after setting a value in the UpdateCollection instance.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub OnSetComplete(index As Integer, _
            oldValue As Object, _
            newValue As Object)
            MyBase.OnSetComplete(index, oldValue, newValue)
        End Sub
End Class

Syntax

Visual Basic
Protected Overrides Sub OnSetComplete( _
    ByVal index As Integer, _
    ByVal oldValue As Object, _
    ByVal newValue As Object _
)
C#
protected override void OnSetComplete(
    int index,
    object oldValue,
    object newValue
);
C++
protected:
virtual void OnSetComplete(
    int index,
    Object^ oldValue,
    Object^ newValue
) override;
J#
protected override void OnSetComplete(
    int index,
    System.Object oldValue,
    System.Object newValue
);
JScript
protected override function OnSetComplete(
     index : int,
     oldValue : Object,
     newValue : Object
) : Void;

Parameters

index

The zero-based index at which oldValue can be found.

oldValue

The value to replace with newValue.

newValue

The new value of the element at index.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection.Remove Method
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Removes a specified element from the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Public Class wsusCollectionImplementation
    Inherits WsusCollection
        Protected Overrides Sub Remove(value As Object)
            MyBase.Remove(value)
        End Sub
End Class

Syntax

Visual Basic
Protected Sub Remove( _
    ByVal value As Object _
)
C#
protected void Remove(
    object value
);
C++
protected:
void Remove(
    Object^ value
);
J#
protected void Remove(
    System.Object value
);
JScript
protected function Remove(
     value : Object
) : Void;

Parameters

value

The element to remove from the collection.

Remarks

The elements that follow the removed element move up to occupy vacated spot.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusCollection Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Capacity | (Inherited from CollectionBase )
public property | Count | (Inherited from CollectionBase )

Protected Properties

 | Name | Description
protected property | InnerList | (Inherited from CollectionBase )
protected property | Item | Gets or sets the element at the specified index. In C#, this property is the indexer for the collection.
protected property | List | (Inherited from CollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (Inherited from CollectionBase )
System.Collections.ICollection.SyncRoot | (Inherited from CollectionBase )
System.Collections.IList.IsFixedSize | (Inherited from CollectionBase )
System.Collections.IList.IsReadOnly | (Inherited from CollectionBase )
System.Collections.IList.Item | (Inherited from CollectionBase )

See Also

Reference

WsusCollection Class


WsusCollection.Item Property
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Gets or sets the element at the specified index. In C#, this property is the indexer for the collection.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusCollection1 As WsusCollection

Dim key As Integer
Dim returnValue As Object
returnValue = wsusCollection1.Item(key)

Dim sampleValue As Object
wsusCollection1.Item(key) = sampleValue

Syntax

Visual Basic
Protected Property Item( _
    ByVal index As Integer _
) As Object
C#
protected object this[
    int index
] {get; set;}
C++
protected:
property Object^ default[int] {
    Object^ get(int index);
    void set(int index, Object^ value);
}
J#
protected System.Object get_Item(
    int index
);
protected void set_Item(
    int index
System.Object);
JScript
In JScript, you can use Indexed Properties defined by a class, but you cannot define your own.

Parameters

index

The zero-based index of the element to get or set.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusCollection Class
WsusCollection Members


WsusEventId Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusEventId1 As WsusEventId = WsusEventId.ClientDetectionComplete

Syntax

Visual Basic
Public Enum WsusEventId
C#
public enum WsusEventId
C++
public enum class WsusEventId
J#
public enum WsusEventId
JScript
public enum WsusEventId

Members

Member name | Description
ClientDetectionComplete |
ClientDetectionFailed |
ClientDownloadCanceled |
ClientDownloadFailed |
ClientDownloadSucceeded |
ClientInstallationAtShutdownCompletedWithReboot |
ClientInstallationAtShutdownFailed |
ClientInstallationAtShutdownSucceeded |
ClientInstallationAtShutdownTimedOut |
ClientInstallationCanceled |
ClientInstallationCompletedWithReboot |
ClientInstallationFailed |
ClientInstallationHidden |
ClientInstallationSucceeded |
ClientInstallationTimedOut |
ClientInstallationUnhidden |
ClientInventoryCollectionFailed |
ClientInventoryCollectionSucceeded |
ClientInventoryOperationalFailure |
ClientInventoryRulesDownloadFailed |
ClientInventoryRulesProcessingFailed |
ClientInventoryUploadFailed |
ClientScheduledInstallationCompletedWithReboot |
ClientScheduledInstallationFailed |
ClientScheduledInstallationSucceeded |
ClientScheduledInstallationTimedOut |
ClientUninstallationCanceled |
ClientUninstallationCompleteWithReboot |
ClientUninstallationFailed |
ClientUninstallationSucceeded |
ClientUninstallationTimedOut |
ContentSynchronizationFailed |
ContentSynchronizationFileDownloadCanceled |
ContentSynchronizationFileDownloadFailed |
ContentSynchronizationFileDownloadSucceeded |
ContentSynchronizationStarted |
ContentSynchronizationSucceeded |
SubscriptionModified |
SynchronizationCompletedCancel |
SynchronizationCompletedFailure |
SynchronizationCompletedSuccess |
SynchronizationManualStart |
SynchronizationScheduledStart |

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace

Send comments about this topic to Microsoft.


WsusEventSource Enumeration
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Defines constants that indicate the source of an event.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusEventSource1 As WsusEventSource = WsusEventSource.Client

Syntax

Visual Basic
Public Enum WsusEventSource
C#
public enum WsusEventSource
C++
public enum class WsusEventSource
J#
public enum WsusEventSource
JScript
public enum WsusEventSource

Members

Member name | Description
Client | The client computer created the event.
Server | WSUS created the event.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

Microsoft.UpdateServices.Administration Namespace
IUpdateEvent.WsusEventSource
IUpdateServer.GetUpdateEventHistory


WsusInvalidDataException Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when data is found in the WSUS database that is not valid.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusInvalidDataException1 As New WsusInvalidDataException()

Syntax

Visual Basic
Public Class WsusInvalidDataException
    Inherits Exception
C#
public class WsusInvalidDataException : Exception
C++
public ref class WsusInvalidDataException : Exception
J#
public class WsusInvalidDataException extends Exception
JScript
public class WsusInvalidDataException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.UpdateServices.Administration.WsusInvalidDataException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidDataException Members


WsusInvalidDataException Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when data is found in the WSUS database that is not valid.

The following tables list the members exposed by the WsusInvalidDataException type.

Public Constructors (see also Protected Constructors )

Name | Description
WsusInvalidDataException | Overloaded.
Top

Protected Constructors

Name | Description
WsusInvalidDataException | Overloaded.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )
Top

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WsusInvalidDataException Class


WsusInvalidDataException Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
WsusInvalidDataException () |
WsusInvalidDataException (String) |
WsusInvalidDataException (SerializationInfo, StreamingContext) |
WsusInvalidDataException (String, Exception) |

See Also

Reference

WsusInvalidDataException Class
WsusInvalidDataException Members


WsusInvalidDataException Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusInvalidDataException Class .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusInvalidDataException1 As New WsusInvalidDataException()

Syntax

Visual Basic
Public Sub New()
C#
public WsusInvalidDataException();
C++
public:
WsusInvalidDataException();
J#
public WsusInvalidDataException();
JScript
public function WsusInvalidDataException();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidDataException Class
WsusInvalidDataException Members


WsusInvalidDataException Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim wsusInvalidDataException1 As New WsusInvalidDataException(message)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String _
)
C#
public WsusInvalidDataException(
    string message
);
C++
public:
WsusInvalidDataException(
    String^ message
);
J#
public WsusInvalidDataException(
    System.String message
);
JScript
public function WsusInvalidDataException(
     message : String
);

Parameters

message

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidDataException Class
WsusInvalidDataException Members


WsusInvalidDataException Constructor (SerializationInfo, StreamingContext)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim info As SerializationInfo
Dim context As StreamingContext
Dim wsusInvalidDataException1 As New WsusInvalidDataException(info, context)

Syntax

Visual Basic
Protected Sub New( _
    ByVal info As SerializationInfo, _
    ByVal context As StreamingContext _
)
C#
protected WsusInvalidDataException(
    SerializationInfo info,
    StreamingContext context
);
C++
protected:
WsusInvalidDataException(
    SerializationInfo^ info,
    StreamingContext^ context
);
J#
protected WsusInvalidDataException(
    SerializationInfo info,
    StreamingContext context
);
JScript
protected function WsusInvalidDataException(
     info : SerializationInfo,
     context : StreamingContext
);

Parameters

info
context

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidDataException Class
WsusInvalidDataException Members


WsusInvalidDataException Constructor (String, Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception
Dim wsusInvalidDataException1 As New WsusInvalidDataException(message, innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String, _
    ByVal innerException As Exception _
)
C#
public WsusInvalidDataException(
    string message,
    Exception innerException
);
C++
public:
WsusInvalidDataException(
    String^ message,
    Exception^ innerException
);
J#
public WsusInvalidDataException(
    System.String message,
    Exception innerException
);
JScript
public function WsusInvalidDataException(
     message : String,
     innerException : Exception
);

Parameters

message
innerException

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidDataException Class
WsusInvalidDataException Members


WsusInvalidDataException Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WsusInvalidDataException Class


WsusInvalidDataException Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )

See Also

Reference

WsusInvalidDataException Class


WsusInvalidServerException Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception should be used when AdminProxy.GetUpdateServer() is called with an invalid server.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusInvalidServerException1 As New WsusInvalidServerException()

Syntax

Visual Basic
Public Class WsusInvalidServerException
    Inherits Exception
C#
public class WsusInvalidServerException : Exception
C++
public ref class WsusInvalidServerException : Exception
J#
public class WsusInvalidServerException extends Exception
JScript
public class WsusInvalidServerException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.UpdateServices.Administration.WsusInvalidServerException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidServerException Members


WsusInvalidServerException Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception should be used when AdminProxy.GetUpdateServer() is called with an invalid server.

The following tables list the members exposed by the WsusInvalidServerException type.

Public Constructors (see also Protected Constructors )

Name | Description
WsusInvalidServerException | Overloaded. Initializes a new instance of the WsusInvalidServerException class.
Top

Protected Constructors

Name | Description
WsusInvalidServerException | Overloaded.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )
Top

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WsusInvalidServerException Class


WsusInvalidServerException Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusInvalidServerException class.

Overload List

Name | Description
WsusInvalidServerException () | Initializes a new instance of the WsusInvalidServerException class.
WsusInvalidServerException (String) | Initializes a new instance of the WsusInvalidServerException class with a specified error message.
WsusInvalidServerException (SerializationInfo, StreamingContext) | Initializes a new instance of the Exception class with serialized data.
WsusInvalidServerException (String, Exception) | Initializes a new instance of the WsusInvalidServerException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

Reference

WsusInvalidServerException Class
WsusInvalidServerException Members


WsusInvalidServerException Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusInvalidServerException class.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusInvalidServerException1 As New WsusInvalidServerException()

Syntax

Visual Basic
Public Sub New()
C#
public WsusInvalidServerException();
C++
public:
WsusInvalidServerException();
J#
public WsusInvalidServerException();
JScript
public function WsusInvalidServerException();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidServerException Class
WsusInvalidServerException Members


WsusInvalidServerException Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusInvalidServerException class with a specified error message.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim wsusInvalidServerException1 As New WsusInvalidServerException(message)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String _
)
C#
public WsusInvalidServerException(
    string message
);
C++
public:
WsusInvalidServerException(
    String^ message
);
J#
public WsusInvalidServerException(
    System.String message
);
JScript
public function WsusInvalidServerException(
     message : String
);

Parameters

message

The message that describes the error.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidServerException Class
WsusInvalidServerException Members


WsusInvalidServerException Constructor (SerializationInfo, StreamingContext)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the Exception class with serialized data.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim info As SerializationInfo
Dim context As StreamingContext
Dim wsusInvalidServerException1 As New WsusInvalidServerException(info, context)

Syntax

Visual Basic
Protected Sub New( _
    ByVal info As SerializationInfo, _
    ByVal context As StreamingContext _
)
C#
protected WsusInvalidServerException(
    SerializationInfo info,
    StreamingContext context
);
C++
protected:
WsusInvalidServerException(
    SerializationInfo^ info,
    StreamingContext^ context
);
J#
protected WsusInvalidServerException(
    SerializationInfo info,
    StreamingContext context
);
JScript
protected function WsusInvalidServerException(
     info : SerializationInfo,
     context : StreamingContext
);

Parameters

info

The SerializationInfo that holds the serialized object data about the exception being thrown.

context

The StreamingContext that contains contextual information about the source or destination.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidServerException Class
WsusInvalidServerException Members


WsusInvalidServerException Constructor (String, Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusInvalidServerException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception
Dim wsusInvalidServerException1 As New WsusInvalidServerException(message, innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String, _
    ByVal innerException As Exception _
)
C#
public WsusInvalidServerException(
    string message,
    Exception innerException
);
C++
public:
WsusInvalidServerException(
    String^ message,
    Exception^ innerException
);
J#
public WsusInvalidServerException(
    System.String message,
    Exception innerException
);
JScript
public function WsusInvalidServerException(
     message : String,
     innerException : Exception
);

Parameters

message

The message that describes the error.

innerException

The exception that is the cause of the current exception. If the innerException parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusInvalidServerException Class
WsusInvalidServerException Members


WsusInvalidServerException Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WsusInvalidServerException Class


WsusInvalidServerException Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )

See Also

Reference

WsusInvalidServerException Class


WsusObjectAlreadyExistsException Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when the object already exists in the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusObjectAlreadyExistsException1 As New WsusObjectAlreadyExistsException()

Syntax

Visual Basic
Public Class WsusObjectAlreadyExistsException
    Inherits Exception
C#
public class WsusObjectAlreadyExistsException : Exception
C++
public ref class WsusObjectAlreadyExistsException : Exception
J#
public class WsusObjectAlreadyExistsException extends Exception
JScript
public class WsusObjectAlreadyExistsException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.UpdateServices.Administration.WsusObjectAlreadyExistsException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when the object already exists in the database.

The following tables list the members exposed by the WsusObjectAlreadyExistsException type.

Public Constructors (see also Protected Constructors )

Name | Description
WsusObjectAlreadyExistsException | Overloaded.
Top

Protected Constructors

Name | Description
WsusObjectAlreadyExistsException | Overloaded.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )
Top

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WsusObjectAlreadyExistsException Class


WsusObjectAlreadyExistsException Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
WsusObjectAlreadyExistsException () |
WsusObjectAlreadyExistsException (String) |
WsusObjectAlreadyExistsException (SerializationInfo, StreamingContext) |
WsusObjectAlreadyExistsException (String, Exception) |

See Also

Reference

WsusObjectAlreadyExistsException Class
WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusObjectAlreadyExistsException Class .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusObjectAlreadyExistsException1 As New WsusObjectAlreadyExistsException()

Syntax

Visual Basic
Public Sub New()
C#
public WsusObjectAlreadyExistsException();
C++
public:
WsusObjectAlreadyExistsException();
J#
public WsusObjectAlreadyExistsException();
JScript
public function WsusObjectAlreadyExistsException();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectAlreadyExistsException Class
WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim wsusObjectAlreadyExistsException1 As New WsusObjectAlreadyExistsException(message)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String _
)
C#
public WsusObjectAlreadyExistsException(
    string message
);
C++
public:
WsusObjectAlreadyExistsException(
    String^ message
);
J#
public WsusObjectAlreadyExistsException(
    System.String message
);
JScript
public function WsusObjectAlreadyExistsException(
     message : String
);

Parameters

message

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectAlreadyExistsException Class
WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Constructor (SerializationInfo, StreamingContext)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim info As SerializationInfo
Dim context As StreamingContext
Dim wsusObjectAlreadyExistsException1 As New WsusObjectAlreadyExistsException(info, context)

Syntax

Visual Basic
Protected Sub New( _
    ByVal info As SerializationInfo, _
    ByVal context As StreamingContext _
)
C#
protected WsusObjectAlreadyExistsException(
    SerializationInfo info,
    StreamingContext context
);
C++
protected:
WsusObjectAlreadyExistsException(
    SerializationInfo^ info,
    StreamingContext^ context
);
J#
protected WsusObjectAlreadyExistsException(
    SerializationInfo info,
    StreamingContext context
);
JScript
protected function WsusObjectAlreadyExistsException(
     info : SerializationInfo,
     context : StreamingContext
);

Parameters

info
context

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectAlreadyExistsException Class
WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Constructor (String, Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception
Dim wsusObjectAlreadyExistsException1 As New WsusObjectAlreadyExistsException(message, innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String, _
    ByVal innerException As Exception _
)
C#
public WsusObjectAlreadyExistsException(
    string message,
    Exception innerException
);
C++
public:
WsusObjectAlreadyExistsException(
    String^ message,
    Exception^ innerException
);
J#
public WsusObjectAlreadyExistsException(
    System.String message,
    Exception innerException
);
JScript
public function WsusObjectAlreadyExistsException(
     message : String,
     innerException : Exception
);

Parameters

message
innerException

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectAlreadyExistsException Class
WsusObjectAlreadyExistsException Members


WsusObjectAlreadyExistsException Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WsusObjectAlreadyExistsException Class


WsusObjectAlreadyExistsException Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )

See Also

Reference

WsusObjectAlreadyExistsException Class


WsusObjectNotFoundException Class
See Also Members
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when the requested object is not found in the database.

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException()

Syntax

Visual Basic
Public Class WsusObjectNotFoundException
    Inherits Exception
C#
public class WsusObjectNotFoundException : Exception
C++
public ref class WsusObjectNotFoundException : Exception
J#
public class WsusObjectNotFoundException extends Exception
JScript
public class WsusObjectNotFoundException extends Exception

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.UpdateServices.Administration.WsusObjectNotFoundException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Members


WsusObjectNotFoundException Members
See Also Constructors Methods Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

This exception is thrown when the requested object is not found in the database.

The following tables list the members exposed by the WsusObjectNotFoundException type.

Public Constructors (see also Protected Constructors )

Name | Description
WsusObjectNotFoundException | Overloaded.
Top

Protected Constructors

Name | Description
WsusObjectNotFoundException | Overloaded.
Top

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )
Top

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )
Top

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )
Top

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )
Top

See Also

Reference

WsusObjectNotFoundException Class


WsusObjectNotFoundException Constructor
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Overload List

Name | Description
WsusObjectNotFoundException () |
WsusObjectNotFoundException (Exception) |
WsusObjectNotFoundException (String) |
WsusObjectNotFoundException (SerializationInfo, StreamingContext) |
WsusObjectNotFoundException (String, Exception) |

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Constructor ()
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Initializes a new instance of the WsusObjectNotFoundException Class .

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException()

Syntax

Visual Basic
Public Sub New()
C#
public WsusObjectNotFoundException();
C++
public:
WsusObjectNotFoundException();
J#
public WsusObjectNotFoundException();
JScript
public function WsusObjectNotFoundException();

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Constructor (Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim innerException As Exception
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException(innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal innerException As Exception _
)
C#
public WsusObjectNotFoundException(
    Exception innerException
);
C++
public:
WsusObjectNotFoundException(
    Exception^ innerException
);
J#
public WsusObjectNotFoundException(
    Exception innerException
);
JScript
public function WsusObjectNotFoundException(
     innerException : Exception
);

Parameters

innerException

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Constructor (String)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException(message)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String _
)
C#
public WsusObjectNotFoundException(
    string message
);
C++
public:
WsusObjectNotFoundException(
    String^ message
);
J#
public WsusObjectNotFoundException(
    System.String message
);
JScript
public function WsusObjectNotFoundException(
     message : String
);

Parameters

message

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Constructor (SerializationInfo, StreamingContext)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim info As SerializationInfo
Dim context As StreamingContext
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException(info, context)

Syntax

Visual Basic
Protected Sub New( _
    ByVal info As SerializationInfo, _
    ByVal context As StreamingContext _
)
C#
protected WsusObjectNotFoundException(
    SerializationInfo info,
    StreamingContext context
);
C++
protected:
WsusObjectNotFoundException(
    SerializationInfo^ info,
    StreamingContext^ context
);
J#
protected WsusObjectNotFoundException(
    SerializationInfo info,
    StreamingContext context
);
JScript
protected function WsusObjectNotFoundException(
     info : SerializationInfo,
     context : StreamingContext
);

Parameters

info
context

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Constructor (String, Exception)
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Namespace: Microsoft.UpdateServices.Administration
Assembly: Microsoft.UpdateServices.Administration (in microsoft.updateservices.administration.dll)

Usage

Visual Basic
Dim message As String
Dim innerException As Exception
Dim wsusObjectNotFoundException1 As New WsusObjectNotFoundException(message, innerException)

Syntax

Visual Basic
Public Sub New( _
    ByVal message As String, _
    ByVal innerException As Exception _
)
C#
public WsusObjectNotFoundException(
    string message,
    Exception innerException
);
C++
public:
WsusObjectNotFoundException(
    String^ message,
    Exception^ innerException
);
J#
public WsusObjectNotFoundException(
    System.String message,
    Exception innerException
);
JScript
public function WsusObjectNotFoundException(
     message : String,
     innerException : Exception
);

Parameters

message
innerException

Platforms

Development Platforms

Windows Server 2003, Windows 2000 Server SP4 and later

Target Platforms

See Also

Reference

WsusObjectNotFoundException Class
WsusObjectNotFoundException Members


WsusObjectNotFoundException Methods
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Methods (see also Protected Methods )

 | Name | Description
public method | Equals | Overloaded. (Inherited from Object )
public method | GetBaseException | (Inherited from Exception )
public method | GetHashCode | (Inherited from Object )
public method | GetObjectData | (Inherited from Exception )
public method | GetType | (Inherited from Exception )
 | ReferenceEquals | (Inherited from Object )
public method | ToString | (Inherited from Exception )

Protected Methods

 | Name | Description
protected method | Finalize | (Inherited from Object )
protected method | MemberwiseClone | (Inherited from Object )

See Also

Reference

WsusObjectNotFoundException Class


WsusObjectNotFoundException Properties
[image]

[WSUS 3.0 API - This is prerelease documentation and is subject to change in future releases. Blank topics are included as placeholders.]

Public Properties (see also Protected Properties )

 | Name | Description
public property | Data | (Inherited from Exception )
public property | HelpLink | (Inherited from Exception )
public property | InnerException | (Inherited from Exception )
public property | Message | (Inherited from Exception )
public property | Source | (Inherited from Exception )
public property | StackTrace | (Inherited from Exception )
public property | TargetSite | (Inherited from Exception )

Protected Properties

 | Name | Description
protected property | HResult | (Inherited from Exception )

See Also

Reference

WsusObjectNotFoundException Class


WsusCollection Hierarchy

The following table lists the classes derived from Microsoft.UpdateServices.Administration.WsusCollection .

Derived Classes

Class | Description
Microsoft.UpdateServices.Administration.AutomaticUpdateApprovalRuleCollection |
Microsoft.UpdateServices.Administration.ComputerTargetCollection |
Microsoft.UpdateServices.Administration.ComputerTargetGroupCollection |
Microsoft.UpdateServices.Administration.DownstreamServerCollection |
Microsoft.UpdateServices.Administration.SubscriptionEventCollection |
Microsoft.UpdateServices.Administration.SynchronizationInfoCollection |
Microsoft.UpdateServices.Administration.SynchronizationUpdateErrorInfoCollection |
Microsoft.UpdateServices.Administration.UpdateApprovalCollection |
Microsoft.UpdateServices.Administration.UpdateCategoryCollection |
Microsoft.UpdateServices.Administration.UpdateClassificationCollection |
Microsoft.UpdateServices.Administration.UpdateCollection |
Microsoft.UpdateServices.Administration.UpdateEventCollection |
Microsoft.UpdateServices.Administration.UpdateInstallationInfoCollection |
Microsoft.UpdateServices.Administration.UpdateSummaryCollection |

See Also

Reference

WsusCollection Class
WsusCollection Members